POP UP ACTION

Hi,
I created one popup with  buttons SUBMIT and NO.
In my code I am calliing popup on some condition, its going to the popup code, but without opening immediatly popup,
other code is executing and after that popup is openiing.
I need to call action when I click on submit. after that only rest of code has to work. I created action also.
How to stop the code up to popup.
How to get which button is triggered (eg Submit or No)
Regards,
sarath
Edited by: sarath kumar on Oct 9, 2009 7:41 AM

hi,
SUBSCRIBE_TO_BUTTON_EVENT  method of the interface if_wd_window registers the user action when a button is clicked.
in order to the exection of ur rest of code , make a attribute of type WDY_BOOLEAN in ur component controller.
IN the DOINIT of component controller set its value to ABAP_FALSE or blank
   DATA lo_nd_cn_check TYPE REF TO if_wd_context_node.
    DATA lo_el_cn_check TYPE REF TO if_wd_context_element.
    DATA ls_cn_check TYPE wd_this->element_cn_check.
    DATA lv_ca_check LIKE ls_cn_check-ca_check.
*   navigate from <CONTEXT> to <CN_CHECK> via lead selection
    lo_nd_cn_check = wd_context->get_child_node( name = wd_this->wdctx_cn_check ).
*   get element via lead selection
    lo_el_cn_check = lo_nd_cn_check->get_element(  ).
*   set single attribute
    lo_el_cn_check->set_attribute(
      EXPORTING
        name =  `CA_CHECK`
      IMPORTING
        value = ' ' ).
now in ur method , in which u r calling the popup , after ur logic for popup ; put a IF condition and write remaining of ur code there
IF wd_comp_controller->ca_check = 'X'
ur piece of code
ENDIF
set ca_check  to 'X' after ur popup .It shud help
regards,
amit
Edited by: amit saini on Oct 9, 2009 8:05 AM

Similar Messages

  • Finesse 9.0 Browser Pop Workflow Action?

    Hello,
    Finesse 10.0 offers 'browser pop workflow action' making it easy to generate URLs upon call delivery.
    Is there a way to do this in Finesse 9.0? 
    Thanks in advance!

    quote:
    Originally posted by:
    Jumanjisf
    Did u download IE8 and just using immulator coz it will have
    problems
    thx, no ... just IE7, never downldd or used ie8 ...

  • Excel 2013 - There isn't enough memory to complete this action.

    BSOD'D, Thank you for your caring. I finally solved that problem by removing a COM Addin. 

    When I trie to open an Excel file on my laptop, an Error Notice Window just pops out.Below please see the details of this situation.1. This occurs only on my Lenovo laptop.2. The total RAM is 8GB, and the operating system on this laptop is 64-bit.3. Windows 8.1 + Office Professional Plus 20134. After a fresh boot, I still get this message when using Excel spreadsheets ONLY.5. This just happened now with spreadsheets successfully used over a period of time.6. Even when I try to open a blank file, this message pops up.Actions taken:1. Increased virtual memory size from 1408 MB to 4586 MB, nothing changed.2. Scaned the computer by ESET NOD32 Antivirus, no virus is found.3. I copied the Excel files and run them on another laptop (COMPAQ+windows 7+32bit operating system +4gbram+excel2010), no problem, althought it's slower.Your...
    This topic first appeared in the Spiceworks Community

  • Downloads Folder No Longer Jumps Up When Saving Attachments

    When saving attachments in Mail, my downloads folder on the Doc used to jump up a couple of times when I hit "save" from within an email that I received to signify that I just saved it into that folder.
    However, for no rhyme or reason, the downloads folder no longer jumps up when I save attachments. The attachment still save in to that folder but I miss the pop-up action telling me that it did.
    I searched the net and posts and found nothing on this quark. This is driving me nutz!
    Please help!

    Check in System Preferences>Dock and check off Animate opening applications and see if that doesn't do it. Not sure if that is why but it is worth a shot.

  • Table with in a table Popin

    Hi,
    I need to put a table with in a Table pop in. I am able to achieve the table but the I am unable to display different data for each pop in. action.
    Example.
    Table has 3 records
    Row 1
    Row 2
    Row 3
    On expanding Row1 using pop in I am able to display the table.
    On expanding Row 2, leaving Row 1 expanded, changes the data in both the Areas, showing data  of Row 2.
    Could you please help in resolving the issue.

    Hi Prasanth,
    To display different data inside the table popin, create child node inside the parent node.
    Parent_node(0....n)
         Child_node( 0....n )
    Create a supply function for CHILD_NODE and on select of any row in parent table, write the logic to fill data of child node . Bind this child node to TABLE_POPIN's table
    Now, if you select row1, you can fill child node in supply function and it populates the data,
    similarly, it works for other rows as well
    Hope this helps you.
    Regards,
    Rama

  • Hiding exceeded data in h:dataTable columns

    hi,
    my requirement is I have to display some data in dataTable and I need to put fixed height for the columns.if the data in that column exceeds then the data should hide and onmouseover one tooltip should come showing the exceeded data.
    but the jsf data table is not hiding the data at all.I have given width and height for that column using css but it is showing the data completely.
    please tell me how can I do this one.

    Hi,
    I tried using overflow property also..but i is not working for me..I am sending my code also
    <h:dataTable id="popresults"
    value="#{popsearch.popList}"
    var="pop"
    columnClasses="name"
    border="0" rowClasses="standardTable_Row2,standardTable_Row1"
    headerClass="DHTMLSuite_tableWigdet_headerCellDown_searchlist" style="vertical-align:middle;" styleClass="tableList_search" width="100%" cellpadding="1" cellspacing="0">
              <h:column>
    <f:facet name="header">
    <h:outputText value="POP Id" style="text-decoration:none;color:black;font-weight:bold;"/>
         </f:facet>
              <h:commandLink id="id"
                             action="#{popdetails.getPOPDetails}"
                             actionListener="#{popsearch.selectPOP}" onmouseover="ddrivetip('#{pop.id}')" onmouseout="hideddrivetip()">
                   <h:outputText value="#{pop.id}" style="text-decoration: none;color: black;border-bottom: 1px solid black;" />
                   <f:param id="popId"
                             name="popId"
                             value="#{pop.id}" />
                   <f:param id="discriminator"
                             name="discriminator"
                             value="#{pop.discriminator}" />
              </h:commandLink>
         </h:column>
         <h:column>
    <f:facet name="header">
         <h:panelGrid columns="2">
         <h:commandLink value="Provider Id" action="#{popsearch.getPopResults}" actionListener="#{popsearch.sortPidDataList}" style="text-decoration:none;color:black;font-weight:bold;">
    <f:attribute name="providerid" value="providerID"/>
         </h:commandLink>
         <h:graphicImage id="pidarrowup" url="#{popsearch.popimg}" rendered="#{popsearch.pidren}"/>
    </h:panelGrid>
    </f:facet>
    <h:outputLabel value="#{pop.providerID}" onmouseover="ddrivetip('#{pop.providerID}')" onmouseout="hideddrivetip()"/>
    </h:column>
    <h:column>
    <f:facet name="header">
    <h:outputText value="Modem Phone"/>
    </f:facet>
    <h:outputLabel value="#{pop.modemPhone}" onmouseover="ddrivetip('#{pop.modemPhone}')" onmouseout="hideddrivetip()"/>
    </h:column>
         <h:column>
    <f:facet name="header">
    <h:panelGrid columns="2">
         <h:commandLink value="POP Class" action="#{popsearch.getPopResults}" actionListener="#{popsearch.sortPclassDataList}" style="text-decoration:none;color:black;font-weight:bold;">
    <f:attribute name="popClass" value="discriminator"/>
         </h:commandLink>
                        <h:graphicImage id="pclassarrowup" url="#{popsearch.popimg}" rendered="#{popsearch.pclassren}"/>
    </h:panelGrid>
    </f:facet>
    <h:outputText value="Broadband" rendered="#{pop.discriminator eq 'B'}">
    </h:outputText>
    <h:outputText value="Dial" rendered="#{pop.discriminator eq 'D'}">
    </h:outputText>
    </h:column>
         <h:column>
    <f:facet name="header">
    <h:outputText value="Location" />
    </f:facet>
    <h:outputLabel value="#{pop.siteAddress}" rendered="#{pop.discriminator eq 'B'}" onmouseover="ddrivetip('#{pop.siteAddress}')" onmouseout="hideddrivetip()"/>
    </h:column>
    </h:dataTable>
    and css is
    .name {
    width: 25px;
    text-align: left;
    nowrap:true
    white-space:nowrap
    overflow:hidden
    please tell me If I missed any thing.

  • JDeveloper popup window using ADF Faces

    Has anyone actually managed to get a popup window working properly using ADF Faces? I have slavishly copied examples from the Developer's Guide, but nothing works - I never get a popup window appearing.

    I'm back again and unfortunately I haven't got this to work. I've scaled down my jsp to just include enough to test the pop-up functionality.
    First here's the code from my jsp page(index.jsp):
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <%@ taglib uri="http://xmlns.oracle.com/adf/faces/html" prefix="afh"%>
    <!-- import tag libraries -->
    <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
    <%@ taglib uri="http://xmlns.oracle.com/adf/faces" prefix="af" %>
    <f:view>
    <afh:html>
    <afh:head title="JSF Test Pop-up Page">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
    <meta name="MSSmartTagsPreventParsing" content="true"/>
    </afh:head>
    <afh:body>
    <af:commandLink text="Test Pop-up" action="dialog:test" useWindow="true"/>
    </afh:body>
    </afh:html>
    </f:view>
    and here's a copy of faces-config.xml:
    <?xml version="1.0" encoding="windows-1252"?>
    <!DOCTYPE faces-config PUBLIC
    "-//Sun Microsystems, Inc.//DTD JavaServer Faces Config 1.1//EN"
    "http://java.sun.com/dtd/web-facesconfig_1_1.dtd">
    <faces-config xmlns="http://java.sun.com/JSF/Configuration">
    <application>
    <default-render-kit-id>oracle.adf.core</default-render-kit-id>
    </application>
    <!-- Navigation Rules -->
    <navigation-rule>
    <from-view-id>/index.jsp</from-view-id>
    <navigation-case>
    <from-outcome>dialog:test</from-outcome>
    <to-view-id>/results.jsp</to-view-id>
    </navigation-case>
    </navigation-rule>
    </faces-config>
    According to the docs on ADF Dialog Framework this is all I need to have in place in order for it to work. What am I missing?
    Thanks again to all replies.

  • Excel 2013 Problem: couldn't open excel files-Notice: There isn't enough memory

    1. This occurs only on my Lenovo laptop.2. The total RAM is 8GB, and the operating system on this laptop is 64-bit.3. Windows 8.1 + Office Professional Plus 20134. After a fresh boot, I still get this message when using Excel spreadsheets ONLY.5. This just happened now with spreadsheets successfully used over a period of time.6. Even when I try to open a blank file, this message pops up.Actions taken:1. Increased virtual memory size from 1408 MB to 4586 MB, nothing changed.2. Scaned the computer by ESET NOD32 Antivirus, no virus is found.3. I copied the Excel files and run them on another laptop (COMPAQ+windows 7+32bit operating system +4gbram+excel2010), no problem, althought it's slower.Your help on this problem will be highly appreciated.
    This topic first appeared in the Spiceworks Community

    so i set up this bit of a lab network in packet tracer. (will set up a more complex lab once this little bit is working right). See imageI've got the following172.16.1.0/24 on the left172.16.2.0/24 on the right172.16.4.0/24 serial link between the two routersThe host PC's can ping each other, across the "pond". they can also ping the router interfaces. the routers can ping each other and the hosts. the only goofy thing is, i can't ping the switches on the opposite side from the router or hosts. I can ping the switch from within it's own subnet but not from afar.the switches also can't ping the serial port IP's of the router on it's own side. (example, switch on the left can ping 172.16.1.1 but not 172.16.4.1I've set up static routes on both routers, and what I believe to be the proper default gateway routes on both switches. Maybe it's...

  • MP-BGP query need help

    Hi Experts,
    I've gone through so many mpls documents and I believe i have a decent grasp of how it works but applying those principles i appear to be stuck in a setup that just won't work.
    The setup is pretty straigh forward: R1 is connected to R2 and R2 is connected to R3.
    R1 has ospf peering with R2 and R2 has ospf peering with R3.
    OSPF working fine and connectivity via Lo on all routers working.
    R1 has MP-BGP bgp peering with R3 where R1 and R3 is advertising its Lo100 interface to each other.
    BGP working fine and I can see from R1 the Lo100 ip of R3 on the vrf myvrf routing table of R1.
    When I do a show ip route vrf myvrf on R1, route to Lo100 of R3 (99.1.1.3) has an egress of 5.1.1.3 (default global table).
    But when i try to ping from R1, 'ping vrf myvrf  99.1.1.3 source 99.1.1.1' ,  ping fails.
    Documentation says that this should work but apparently it doesn't for me; am not sure what i am missing here.
    I even tried to leak the route on both R1 and R3.  But still no go.
    R1:
    ip route vrf myvrf 5.1.1.3 255.255.255.255 f0/0 1.1.1.2
    R3:
    ip route vrf myvrf 5.1.1.1 255.255.255.255 f0/0 2.1.1.1
    Don't know what i am doing wrong here.  And to be honest am getting confused.  Please help.
    Setup is as follows:
    R1:
    int f0/0
    ip 1.1.1.1 255.255.255.0
    mpls ip
    int Lo0
    ip add 5.1.1.1
    int Lo100
    ip vrf forwarding myvrf
    ip add 99.1.1.1 255.255.255.255
    ip vrf myvrf
    rd 10:20
    route-target both 10:20
    router ospf 1
    router-id 5.1.1.1
    network 1.1.1.0 0.0.0.255 area 0
    network 5.1.1.3 0.0.0.0.0 area 0
    router bgp 10
    neighbor 5.1.1.3 remote-as 10
    no neighbor 5.1.1.3 active
    neighbor 5.1.1.3 update-source Lo0
    address-family vpnv4
    neighbor 5.1.1.3 activate
    neighbor 5.1.1.3 send-community both
    address-family ipv4 vrf myvrf
    network 99.1.1.1 mask 255.255.255.255
    R2:
    int f0/0
    ip add 1.1.1.2 255.255.255.0
    mpls ip
    int f1/0
    ip add 2.1.1.1 255.255.255.0
    mpls ip
    int Lo0
    ip add 5.1.1.2 255.255.255.0
    router ospf 1
    router-id 5.1.1.2
    network 1.1.1.0 0.0.0.255 area 0
    network 2.1.1.0 0.0.0.255 area 0
    network 5.1.1.2 0.0.0.0 area 0
    R3:
    int f0/0
    ip add 2.1.1.2 255.255.255.0
    mpls ip
    int Lo0
    ip add 5.1.1.3 255.255.255.0
    int Lo100
    ip vrf forwarding myvrf
    ip add 99.1.1.3 255.255.255.255
    router ospf 1
    network 2.1.1.0 0.0.0.255 area 0
    network 5.1.1.2 0.0.0.0 area 0
    router bgp 10
    neighbor 5.1.1.1 remote-as 10
    no neighbor 5.1.1.1 activate
    neighbor 5.1.1.1 update-source Lo0
    address-family vpnv4
    neighbor 5.1.1.3 activate
    neighbor 5.1.1.3 send-community both
    address-family ipv4 vrf myvrf
    network 99.1.1.3 mask 255.255.255.255

    Hello Marcusbrutus,
    blau grana is right you have an issue with loopback addresses subnet masks.
    Your control plane looks like fine because you have all the expected MP BGP VPNv4 routes in place, but the forwarding plane is broken.
    MPLS L3 VPN packets are sent within the LSP with destination the remote PE loopback address so from R1 point of view is R3's L0.
    If you go on R2 device and you check the state of MPLS forwarding for R3 L0 IP address you will see that instead of seeing a POP TAG action you will see an untagged action.
    The reason for the wrong LSP binding is the subnet mask on R3 loopback address:  OSPF advertises all loopback addresses with a /32 mask by default, but the subnet mask is different. LDP carries the configured subnet mask. But installation of labels is made after check with IGP (OSPF in this case).
    As a result of this the R2 router cannot install the correct POP TAG  = implicit null label as action to do to reach R3 L0.
    With POP TAG  action the R2 router removes the external label  (POP a label) and sends a packet (with MPLS ethertype on ethernet) with a single label MPLS stack to the egress PE R3. R3 sees a label associated to the VRF and it is able to route the packet to the appropriate interface.
    With untagged action R2 removes a label take all the packet content and sends it as it was an IP packet to the downstream device. (with ethertype 0x800 on ethernet) The downstream device finds a packet that is supposed to be an IP packet but it isn't (for the inner label still there) and silently drops it.
    This is what we had seen in lab tests.
    To solve this issue you should:
    use /32 loopback addresses this the recommended best practice
    or you can still use non overlapping non /32 loopback addresses but you need to add the command ip ospf network point-to-point under loopback configuration as this makes OSPF to advertise the true IP subnet mask
    Hope to help
    Giuseppe

  • Fireworks button what to do now

    ok i made a pop up button in FW8 with a jpeg file. So i made
    a hotspot added the pop up button and then i previewed in browser
    from Fw. works like planned. so i go to image preview to view it .
    saved as image and HTML. then from there, i went to DW , i have the
    jpeg button in place how do i get the css and the js onto the
    button to make it do the pop up action? thanks, TyyK

    > what did i do wrong? an ideas?
    no idea without seeing code.
    BTW- those fireworks popup menus will give you nightmares
    down the road in
    my opinion. Especially if you are trying to use multiple
    different ones on a
    page.
    Think through what you want for navigation, then if you do
    want/need some
    kind of expanding thing, look over this list:
    Why not to use them, by the author of them.
    http://www.losingfight.com/blog/2006/08/11/the-sordid-tale-of-mm_menufw_menu
    js/
    Check the uberlink and MacFly tutorials at PVII -
    http://www.projectseven.com/
    and the Navbar tutorial/articles at Thierry's place
    http://tjkdesign.com/articles/dropdown/
    Or this one (more recent article):
    http://tjkdesign.com/articles/Pure_CSS_Dropdown_Menus.asp
    Or to get it done fast, go here -
    http://www.projectseven.com/tutorials/navigation/auto_hide/index.htm
    Alan
    Adobe Community Expert, dreamweaver
    http://www.adobe.com/communities/experts/

  • About Hierarchical dimension

    Hi experts
    I have some doubts about hierarchical dimension (only obiee 11g)
    I've a dimension with some levels:
    +Total
    ---+Level1a
    ---+Level1b
    -------Level2b.1
    -------Level2b.2
    ----+Level1c
    My first question is how to begin my report with childs of "Total". I get this in selection steps pane and choose all elements of level1. Obiee shows me hardcoded so...if in the future there is new members on level1 I will not see it... I need a function like "childs of Total".
    Second question: I want to apply a different Conditional format depending level of hierarchy and I have to choose all members hardcoded...not "childs of"
    Any help about it??
    Thanks!

    Hi Alex,
    I need a function like "childs of Total".In Selection steps, start with all members, in step 2, click on New Step-> "Select members Based on Hierarchy" ->In the pop up Action select "Keep Only Members of" -> select all the levels except Total. This will display the report with all child s of total
    I want to apply a different Conditional format depending level of hierarchy and I have to choose all members hardcoded...not "child of"Possible.In Criteria tab, click on + icon to display all the levels.If you want to apply conditional format at Level 2 ->Click on Hierarchy Level Properties of Level 2->Conditional Format->Add condition->select your hierarchy column->In the filter click on Search ->In "At Level" drop down select "Level 2" and click on Search-> This will display all the members at level 2->Move the members to the right pane->OK and apply formatting.
    Regards,
    Dpka

  • Is it normal for a dvd - rom to be detected as a cd - rom ? ( Note:problem since new 2005)

    intermittant ahum.... so after a time i upgraded the cd-rom-rw to a dvd-rom-rw to solve the problem. once all was well i swaped locations of the 2 dvd-rom so the writer is at the top. always things work when first discoverd. but after some time not so much. since then..... i have also upgraded OS to windows 7 from xp sp2/3  . worked just as desribed above. been through the mill with the fixit and manualy upper/lower, enable -disable ... only thing i can think of is licenseing that pops into action stopping use. and i'm not doing any illegal downloads or copy protect etc..  i just watched matrix on dvd 2 piece movie and when switching to disc 2 it would not continue. what happens ? 

    Hi,
    I don't think that the laptop is powerful enough to handle blu-ray disks. I have checked the specs for a dv6910us and there is a D2C AMD 2GHz cpu and nVidia 7150M which is a very poor config for playing BR disks. Blu-Ray players are supported on Intel based full featured dv6700 series laptops which might suggest that it would be the same on dv6900 series laptops.
    Dv6-7000 /Full HD/Core i5-3360M/GF 650M/Corsair 8GB/Intel 7260AC/Samsung Pro 256GB
    Testing - HP 15-p000
    HP Touchpad provided by HP
    Currently on Debian Wheeze
    *Please, help other users with the same issue by marking your solved topics as "Accept as Solution"*

  • Window Shade Effect

    I have always been annoyed by the Mac OS X window shade effect in the "Save as..." dialog. It usually ends up hiding information in the underlying screen that I need to look at to title my "Save as..." dialog, such as date, names, titles, etc. However, I have learned to live with this annoyance.
    Now I've discovered another reason to dislike that effect. I have a MacBook Pro with a 15" screen, so there is not that much screen real estate. When I go to Mail Preferences and select "Rules" there is an item named "News from Apple". Click on it and select "Edit". The window shade effect pops into action and, since there are so many rules for this item, the bottom of the window where all the buttons are located falls off the bottom of the screen and can't be seen.
    I can't figure out a way to get out of this window without quitting Mail.
    Is there a way to dismiss this window if the "Cancel" or "OK" buttons can't be reached?
    Does this window shade effect annoy anyone else also??? As much as I hate to suggest this but, why can't this be a separate window that can be moved around the screen like in Windows?

    My apologies for misunderstanding. The different applications and screens you work in on your Mac are called windows, and I thought you meant "shade" as in contrast and darkness (ie that is a dark shade of green). You actually meant a literal shade! I see what you mean now, it does look like that.
    As I mentioned before, there should never be any circumstance that you are unable to see the buttons on the bottom of a window, especially on your large 15" screen. What is your [screen resolution set to|http://support.apple.com/kb/ht2490#l2]? The higher up the list (and smaller the numbers,) the more magnified everything will be and consequently less screen real estate will be available. Remember, you can always reposition a window to the top of your screen so you can see the whole thing by simply dragging the menu bar (the top title bar, where the red yellow and green circles are) anywhere you like.
    It is true that these sliding windows, or window shades, such as the Save as dialog will prohibit you from interacting from the main window. There is no way around this, but what exactly would you be trying to do with the main window while simultaneously saving it? It slides right back up as soon as you save it.
    -SM

  • MBGP use interface establish problem

    We have one network link need to run MBGP using interface establish, not use loopback0.
    I tested from lab environment and ping test from R6-CE src:6.6.6.6 to R1-CE dst:1.1.1.1 fail, becasue ldp label pop at R4, not R3.
    R3 should be Penultimate Hop Popping (PHP) router, not R4.
    I want to know if there any command setting on R2-PE can conduct one 172.16.9.89/32 prefix and assign label. Like inter-AS option 2, when ASBR establish multihop multiprotocol eBGP, it conduct one /32 host prefix automatically.
    Network connection:
    vrf A:1.1.1.1---R1-CE----R2-PE:172.16.8.89/30------172.16.8.90/30:R3-P------R4-P------R5-PE-----R6-CE--vrf a:6.6.6.6
    R2-PE and R3-P have to use interface to establish mBGP.
    R4#sho mpls forwarding-table
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    424    Pop tag     172.16.9.88/30   636        Fa1/0      10.0.34.1
    R4#
    R5#sh mpls forwarding-table
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    521    424         172.16.9.88/30   0          Fa1/0      10.0.45.1
    Thank You so much.
    Jeffrey

    Hi Mahesh
      R3 already generate a implicit-null label to R4 for 172.16.9.88/30, becasue it's connect interface.
    so the ldp label will be pop on R4, but R3 don't know vpn label, packet dropped. R2 know the vpn label.
    I expect R3 is PHP router, but if use interface setup MBGP R4 become PHP router.
    That's why I want R2 advetise /32 and assign ldp label.
    You can see label for prefix 9.88/30 is pop tag action on R4, packet forward to R3 leave vpn label will be drop.
    R4>sho mpls forwarding-table
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    416    Pop tag     172.16.9.88/30   0          Fa1/0      10.0.34.1
    I expect like below forwarding table, I am not sure whether can achieve it.
    R4>sho mpls forwarding-table
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    416    300     172.16.9.89/32   0          Fa1/0      10.0.34.1
    I tried set explicit-null on R3, and generate 0 label as you side.
    R4#sho mpls forwarding-table
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    416    0           172.16.9.88/30   40992      Fa1/0      10.0.34.1
    R4#sh ip cef vrf a 1.1.1.1 detail
    1.1.1.1/32, version 8, epoch 0, cached adjacency 10.0.34.1
    0 packets, 0 bytes
      tag information set, all rewrites owned
        local tag: VPN route head
        fast tag rewrite with Fa1/0, 10.0.34.1, tags imposed {0 229}
      via 172.16.9.89, 0 dependencies, recursive, mpls required
        next hop 10.0.34.1, FastEthernet1/0 via 172.16.9.88/30 (Default)
        valid cached adjacency
        tag rewrite with Fa1/0, 10.0.34.1, tags imposed {0 229}
    The label packet arrive at R3 can not forward to R2, dropped.
    Label Packet arrive on R3 like below:
    |label 0|label 229|dst 1.1.1.1|src 6.6.6.6|data ICMP|
    It seem don't know how to pop label 0 and then forward to R2.
    Thank You
    Jeffery

  • Seperating Actionscript and MXML

    I have a MXML file called PopUp.mxml which contains tabs. I
    need to pop this up after a menu is being pressed. I try to keep my
    as3 separate from MXML code..and I tried this.
    var popUp = new PopUp(); // the object of an MXML file
    var settingsWindow:TitleWindow =
    TitleWindow(PopUpManager.createPopUp(this, popTab, flase));
    I get the error.. 1034 when the settingsWindow is created..
    can someone help me in this. or can someone tell me how to
    create a pop up tabnavigator ?. I want the tabnavigator in a
    seperate MXML and the pop up action in a AS3..
    thanks in advance
    domnic

    found a solution for you
    in your eclipse instlation
    go to \plugins\com.adobe.flexbuilder.editors.common_xxxxx\
    directory
    P.S xxxx means some numbers it might be different on your
    machin .
    unzip common.jar file
    then go into
    common\com\adobe\flexbuilder\editors\common\color directory
    edit Colors.xml to your prefferences (it has hex values for
    colors , its pretty self descriptive) and after you finish editing
    put that back into the jar or re-jar that whole directory .

Maybe you are looking for

  • How do I back up or save my Notes?  Iphone 5 ios 7.0.4

    My notes are the most important thing in my phone and i would like to restore my phone but still be able to keep all of my notes. Ive tried backing up everything up through icloud and my mac but when i go back to my notes and click my Icloud account

  • How to reduce image's file size in Preview?

    I am in Preview Version 5.0.3 (504.1).  I have a PDF file that is 3.7 meg. in size.  That is a big large for what I want to do with it.  I would like to reduce its size to something a bit more manageable.   The Preview Help gives these instructions:

  • Skype Profile Pages

    Hi,  Are there links that a company can gather that takes them to their skype profile pages, they want to add a link in their email signatures that takes them to their profiles. Where can you seach for skype users, and get that link to add it to a e-

  • Query Performance Issues on a cube sized 64GB.

    Hi, We have a non-time based cube whose size is 64 GB . Effectively, I can't use time dimension for partitioning. The transaction table has ~ 850 million records. We have 20+ dimensions among which 2 of the dimensions have 50 million records. I have

  • Will iOS 7 be free?

    iOS 7 for iPod Touch, iPhone and iPad . . . free? I was reading on Wikipedia (in spanish) about iOS version history, I read that "iPhone Users have all free updates, while iPod Touch users payed for iOS 2.0 and iOS 3.0 updates. For 4.0 version, Apple