Problem with auto forward in nested groups of 3-levels deep (Struts/UIX)

Hi all,
In my time registration applications I use master-detail relations of 3 levels deep: Weeks - Days - Hours.
For user convenience I forward directly from the Weeks table page to the DaysHours master-detail page, skipping the Weeks detail page.
Therefore I replaced the forward-on-success-path to the WeeksPage with the WeeksDaysRouter, as if the user selected it manually in the WeeksPage.
This works well, including getting the propper dataobjects and dataobjectsets of all levels.
However when I browse to the next Day in the DaysHours master-detail page using the '>'-button, the server responds with the next week in a WeeksPage.
It seems that the application turns into another state when a user action is simulated in the struts config.
It is unclear to me how to configure the controller to exactly simulate the user action. Who else is in control here? According to MVC I would not expect controlling behaviour in the UIX views.
Can somebody help?
kind regards,
     Martijn

Martijn,
In formPage.uit, the template used by your page that includes the brow2sebuttons, you can find the following line:
<formValue name="targetGroup" data:value="jhsPreviousForward@jheadstart:sessionData"/>
The problem is that jhsPreviousForward still points to the weeks group. You can do two things to solve this:
1. put a custom Struts action in between that changes the value of jhsPreviousForward to "DaysHours" (assuming that is the name of your group.
The code to do this in your Struts action:
sessionData.setAttribute(JHS_PREVIOUS_FORWARD,"DaysHours",SessionData.SESSION_SCOPE);
See chapter 2 of the Dev Guide for more info on writing custom Struts actions.
2. Make a copy of formPage.uit, rename it and change the targetGroup formValue to
<formValue name="targetGroup" value="DaysHours"/>
and have your page use your custom template instead of formPage.uit.
I would favor the first option, you could even make this action generic by passing in the targetGroup name using set-property in the struts-config, rather than hardcoding it in the action.
Steven Davelaar,
JHeadstart Team.

Similar Messages

  • HELP!! asa 5505 8.4(5) problem with port forwarding-smtp

    Hi I am having a big problem with port forwarding on my asa. I am trying to forward smtp through the asa  to my mail server.
    my mail server ip is 10.0.0.2 and my outside interface is 80.80.80.80 , the ASA is setup with pppoe (I get internet access no problem and that seems fine)
    When I run a trace i get "(ACL-Drop) - flow is deied by configured rule"
    below is my config file , any help would be appreciated
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISPDsl
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_SMTP
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object server_SMTP eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network server_SMTP
    nat (inside,outside) static interface service tcp smtp smtp
    nat (inside,outside) after-auto source dynamic any interface
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c5570d7ddffd46c528a76e515e65f366
    : end

    Hi Jennifer
    I have removed that nat line as suggested but still no joy.
    here is my current config
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.4(5)
    hostname ciscoasa
    domain-name domain.local
    enable password mXa5sNUu4rCZ.t5y encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ISP
    ip address 80.80.80.80 255.255.255.255 pppoe setroute
    ftp mode passive
    dns server-group DefaultDNS
    domain-name domain.local
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Server_Mail
    host 10.0.0.2
    access-list outside_access_in extended permit tcp any object Server_Mail eq smtp
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
    nat (inside,outside) dynamic interface
    object network Server_Mail
    nat (inside,outside) static interface service tcp smtp smtp
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group ISP request dialout pppoe
    vpdn group ISP localname [email protected]
    vpdn group ISP ppp authentication chap
    vpdn username [email protected] password *****
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:f3bd954d1f9499595aab4f9da8c15795
    : end
    also here is the packet trace
    and my acl
    Thanks

  • Problems with auto upgrade Anyconnect 3.1

    Hello,
    I'm having problem with auto upgrade of Anyconnect 2.5 to 3.1.
    Here is the situation :
    I have ASA5510 running ASA 8.4.5 and clients are running Anyconnect 2.5.3055 and 3.1.00495 with 2 different profiles.
    Clients with 2.5 can upgrade to 3.1 but then receive an "Invalid host entry" when they try to connect with new client. It works if they use FQDN instead of profiles. It's the same situation with Windows 7, Mac OS X and linux.
    If I configure client software back to 2.5 on ASA, it works again for every client.
    Do you have an idea ?
    Thanks for your reply.
    Yann

    I have seen the same behavior on Mac OS X. A couple of points for me:
    If I delete the profiles from /opt/cisco/anyconnect/profile then I can connect once (using the FQDN) but it then downloads the client profile and on next attempted connection it receives "invalid host entry." My profiles use the FQDN of my ASA and both forward and reverse DNS resolution are configured properly.
    My workaround is to remove the AnyConnect Client Profile entirely, but I can get away with that because I have a very simple setup, with all users in one default group. If I had to pass different profile information to different users that would not be a solution.
    Second, better workaround: I just exported the client profile, imported it under a different name, edited the new client profile to remove the server address, and assigned the new profile to the group policy. At their next login, users get all the profile settings and since the client remembers the FQDN they used to connect it doesn't adversely affect the user experience.

  • Problem with call forwarding. Calls can not be forwarded for incoming external calls

    Hi Everybody, how are you?
    I have a problem with call forwarding. Everything was fine but now is not working.
    In the reception of an office, the receptionist activate the call forward option to an internal extension. If somebody, internal in the office, call to the reception, the call is forwarding to the extension configured. But if I call from the outside (in example, from my cellphone) the call is not forwarded to the extension configured and continue ringing in the reception phone. Why this behavior? Any idea?
    If you know something please tell me.
    Thanks. Best regards.
    Andres Collazos.

    I encounter a similar problem with 9.1.1.
    My problem is link to this bug ID : CSCtq10477.
    Mathieu

  • Problem with Port Forwarding in WRT320N

    Good day.
    I have a web-server and Internet-radio translator to local network of my provider. And I found a problem with Port Forwarding. I'm trying to setup 80 & 8000 ports to forward. And it's working but only for Internet, without provider's local network. My web-server isn't accessible in local network and radio-translator too. 
    So is it possible to forward ports absolutely - for any type of connections? 
    P.S. DMZ is working like Port Forwarding.

    If you ask questions you have to mention that you have an PPTP connection to the internet and another network directly on the internet port. Otherwise noone will really understand your question as it is a very unusual setup.
    Your setup is not one really supported by the router. You are lucky that it works but don't expect too much. Port forwarding only the internet connection. If you use PPTP the network on the internet port is basically hidden. Using that local network on the internet port is not supported.
    The DMZ host is the IP address to which all ports are forwarded to which are not forwarded otherwise. The same restriction applies here.
    I would recommend to ask your ISP which router they recommend for their internet connection. I think most/all Linksys routers and many other brand's consumer routers won't really support a setup like yours...

  • Mail has problem with auto address.

    My mail recently has had a problem with auto addressing. Sometimes it fills in the address, at other times it will not. I have checked mail preferences often...making sure auto-address is on. I CAN use the address book to click on an address when auto addressing doesn't work. Mail is also quirky about quitting and sometimes preferences have to be re-edited to send. Basically, it is behaving badly. What to do? Thanks ACE

    My mail recently has had a problem with auto
    addressing. Sometimes it fills in the address, at
    other times it will not. I have checked mail
    preferences often...making sure auto-address is on. I
    CAN use the address book to click on an address when
    auto addressing doesn't work. Mail is also quirky
    about quitting and sometimes preferences have to be
    re-edited to send. Basically, it is behaving badly.
    What to do? Thanks ACE
    Later...12/03. Autofill not working with mail or safari. Autofill icon, when touched says something like...autofill has no infomation. this is weird, since it had been working nicely for 2.5 years. I've tried everything I could think of. Need a pro's help...MNICE

  • Problem with AUTO PUBLISH nd update NEW POLICY to Client .

    To : who may concern , which really need urgent help .
    after few days of setting up the ZESM , but then i was unable to find is there any setting which can "AUTO PUBLISH " into the Client side . Without the Client need to use the manual "UPDATE POLICY " button ?
    Because , we find it that to make it silent update without the CLIENT side need to manually click the UPDATE POLICY , so i would wonder is there any way to have the AUTO UPDATE the policy from SERVER side ?
    thank alot first .
    From : NX ( which this few days has been keep on try and explore the ZESM 3.5 , 4.0 , 4.1IR )
    Which really need help in here , due to we are almost to the end of the setup server and the IT infrastructure .

    I would recommend that you READ and UNDERSTAND the Installation and Administration guides from the Documentation (somebody took the job to write those, so be kind enough to read it)
    Main Doc
    http://www.novell.com/documentation/zesm41/
    Your question is answered here:
    http://www.novell.com/documentation/...a/bnk7bdx.html
    See "Update Interval".
    Lastly, this is a public support forum, served on a best-effort basis from the community. As such, there's no guarantee that you'll get an answer, and if you get one, that works and is correct. So, if you have un urgent or important issue, go ahead an open a support ticket with Novell Technical Services in order to be served by professional support engineers backed up by the engineers who wrote the code.
    http://support.novell.com/contact/
    >>>
    From: nxgame<[email protected]>
    To:novell.support.zenworks.endpoint-security-management
    Date: 12/11/2010 3:06 pm
    Subject: problem with AUTO PUBLISH nd update NEW POLICY to Client .
    To : who may concern , which really need urgent help .
    after few days of setting up the ZESM , but then i was unable to find
    is there any setting which can "AUTO PUBLISH " into the Client side .
    Without the Client need to use the manual "UPDATE POLICY " button ?
    Because , we find it that to make it silent update without the CLIENT
    side need to manually click the UPDATE POLICY , so i would wonder is
    there any way to have the AUTO UPDATE the policy from SERVER side ?
    thank alot first .
    From : NX ( which this few days has been keep on try and explore the
    ZESM 3.5 , 4.0 , 4.1IR )
    Which really need help in here , due to we are almost to the
    end of the setup server and the IT infrastructure .
    nxgame
    nxgame's Profile: http://forums.novell.com/member.php?userid=99703
    View this thread: http://forums.novell.com/showthread.php?t=427947

  • Problem with generating xml and nested cursor (ora-600)

    I have a problem with generating xml (with dbms_xmlquery or xmlgen) and nested cursors.
    When I execute the following command, I get a ORA-600 error:
    select dbms_xmlquery.getxml('select mst_id
    , mst_source
    , cursor(select per.*
    , cursor(select ftm_fdf_number
    , ftm_value
    from t_feature_master
    where ftm_mstr_id = pers_master_id ) as features
    from t_person per
    where pers_master_id = mst_id ) as persons
    from f_master
    where mst_id = 3059435')
    from dual;
    <?xml version = '1.0'?>
    <ERROR>oracle.xml.sql.OracleXMLSQLException: ORA-00600: internal error code, arguments: [kokbnp2], [1731], [], [], [], [], [], []
    </ERROR>
    The problem is the second cursor (t_feature_master).
    I want to generate this:
    <master>
    <..>
    <persons>
    <..>
    <features>
    <..>
    </features>
    </persons>
    <persons>
    <..>
    <features>
    <..>
    </features>
    </persons>
    </master>
    If i execute the select-statement in sql-plus, then I get the next result.
    MST_ID MST_SOURCE PERSONS
    3059435 GG CURSOR STATEMENT : 3
    CURSOR STATEMENT : 3
    PERS_MASTER_ID PERS_TITLE PERS_INITI PERS_FIRSTNAME PERS_MIDDL PERS_LASTNAME
    3059435 W. Name
    CURSOR STATEMENT : 15
    FTM_FDF_NUMBER FTM_VALUE
    1 [email protected]
    10 ....
    I use Oracle 8.1.7.4 with Oracle XDK v9.2.0.5.0.
    Is this a bug and do somebody know a workaround?

    Very simple...Drop all type objects and nested tables and create them again. You will get no error. I'll explain the reason later.

  • Problems with auto-cap of I on ios6?

    I upgraded my 4s to iOS6 and not my auto capitalization of "I" is not working. Anyone else have this problem or know how to fix it?

    Yeah I tried making a shortcut to make i into I, but it has to be two characters. I guess I'll just go into the store tomorrow and see if anyone else has had problems with it with iOS6. I haven't heard that anyone has had any wonderful experiences with it yet

  • Problem with Port Forwarding (when PPTP is up) in WRT-160N

    Hi, everybody!
    I'm looking for some help with Port Forwarding in my new router from Linksys. I've bought the router afew daysago, and was badly surprised when I found out that there is DD-WRT firmware is installed in it (the router was 100% NEW when I've purchased it). I have downloaded the latest original Linksys firmware file and successfully flashed it.
    But I still have problem (same I had on DD-WRT firmware too) with port forwarding for my DC++ and Vuze (app for torrents): I've written port forward for ports 49151 (for Vuze) and 4000 (for DC++) to be forwarded to my desktop computer (IP 192.168.1.201) -- I've seen a post at this forum, that there could be a problem, if you forward to an IP, which is inside DHCP local zone, so I've forwarded it to .201 IP (my local DHCPzone is 192.168.1.100 - .149). But forwardind doesn't work ((
    What's wrong?
    My configuration:
    Router IP: 192.168.1.1
    PPTP (I've got it from my ISP)
    IP address: 192.168.226.127
    Default Gateway: 192.168.226.2
    DNS 1: 192.168.1.1
    DNS 2 & 3: 0.0.0.0
    PPTP Server IP Address: 192.168.226.2
    Username: ****
    Password: ****
    Single Port Forwarding:
    Application name     External port     Internal port     Protocol     To IP address     Enabled
    Vuze                       49151               49151             Both           192.168.1.201    Checked
    DC                          4000                 4000              Both           192.168.1.201    Checked
    Solved!
    Go to Solution.

    As you have mentioned in your post that your ISP has provided you a PPTP connection with an IP address: 192.x.x.x. The IP address which is provided to you by your ISP is in a Private Range, and if you try to forward any ports on your router it will not work, as your ISP modem will block that port. So you need to get a Public IP address from your ISP.
    As you are getting Private IP from your ISP, so this connection is called as NAT behind NAT, and your Modem is acting like a Router. 
    So now you have 2 options, get the Public IP address from your ISP or change the connection type. 

  • Problems with auto-enroll with the certificate expiration

    Hello,
    we have routers that work with certificates. We have problems with the auto-enroll when the certificates go to expire.
    ?Can somebody help?
    I can send mor debug o configurations.
    We attach a debug.
    Very thanks

    Hello,
    I attach the debug.
    Very thanks

  • Problem with fast forward of trackball in media player of 8330

    I'm a fairly new BB owner of a Sprint 8330 Curve.  I've checked the newbies site on Crackberry and checked here also.  Can anyone help with this problem:
    I've downloaded some MP3 audiobooks from my local public library.  They play fine, but the problem is that it always starts at the beginning every time.  The book is in multiple parts, each of which is 60 minutes long, each of which is treated as a single song.  I can see the reverse, pause, and fast forward buttons but I can't get the trackball to work with them.
    When I scroll the trackball to the right to fast forward, it scrolls to the next part of the book, not within the same part (song).  When I scroll the trackball left, it goes back to the last song.  When I scroll it up or down, the whole playlist shows up on the screen and I can scroll through those.
    I found one post that talked about how to fast forward video, but it showed a different screen that mine.
    I just can't get the trackball to position itself on the progress bar or on the controls.
    Any help would be greatly appreciated!
    Thanks.

    I've got the same problem with my BlackBerry 8330.  I have v4.5.0.169 (Platform 3.4.0.51). Once i start an audio file, I am unable to select the scroll bar above the play so that I can fast forward through the song, book, etc.

  • Problems with Auto approval workflow (WS 10000060) for shopping carts

    Hi SAP Network community,
    I have got a problem with the auto approval workflow for shopping carts.
    Basically the workflow approves the shopping cart once it was created.
    But then the related Purchase Order remains in Status held. If the PO gets ordered manually then it is not transferred to the R/3 backend system.
    For testing purposes also the one step approval workflow was activated. If the shopping cart gets approved by clicking into the detail approval screen (not by approving through the green tick box in the shopping cart overview) then the PO gets ordered and transferred to the backend system as normal.
    But if the shopping cart gets approved by using the green tick box in the shopping cart overview then the same problem occurs as described for the auto approval workflow.
    The system version is SRM 4.00
    Did anybody have the same or similar problems with the auto approval workflow and what could be the reason for this problems.
    Thanks in advance,
    Robert

    Hi
    Which SRM Workflow Scenario are you using (IS it Item level workflow or Shopping cart level Workflow) ?
    Are you using customized SRM Business workflow or Standard SRM Workflow ?
    <u>Please go through these links as well.</u>
    http://help.sap.com/saphelp_srm50/helpdata/en/2c/e68d406b305537e10000000a1550b0/frameset.htm
    http://help.sap.com/saphelp_srm50/helpdata/en/eb/289f4099852e54e10000000a1550b0/frameset.htm
    Incase you are using Standard SRM Workflow, please raise an Customer OSS message with SAP at the earliest.
    Regards
    - Atul

  • Problems with call forwarding setup

    I just got an iPhone and it's great, except for one annoying problem with the call forwarding behavior.
    With my old RAZR phone (also on AT&T) I had two choices when turning on forwarding, "forward immediately" or "forward when unavailable". I used the second choice and had forwarding turned on all the time. Calls would go to the cell phone first but then forward to my home number if I was on another call or didn't answer after a couple of rings. That behavior is important because I want all voice messages in the same place, on my answering machine at home, regardless of whether my cell or home number was called (so I want to deliberately bypass AT&T's voicemail system).
    However the iPhone seems to only have the "immediately" behavior, which means I don't have a chance to answer a call on the iPhone before it forwards, and the iPhone doesn't even log it as a missed call. The forwarding setup is stored in AT&T's system so it seems like the capability should be there regardless of the type of phone, and this is just an arbitrary user-interface restriction with the iPhone. Anyone know how to work around this and get the "forward when unavailable" behavior?

    Jason -
    Thanks, this did the trick. The instructions under the section for "former AT&T Wireless customers" worked perfectly (perhaps because I am actually a former AT&T Wireless customer; I've had the number for almost 6 years, since before the merger with Cingular). Anyway, I dial 61xxxxxxxxxx# (xxx = the number to forward to), make the call, and a confirmation message appears on the screen; now the forwarding is working just the way I like it.
    Thanks again!
    Bob

  • Prime Infrastructure 2.1 problem with sorting devices in device groups

    Hi,
    I have a problem with prime infrastructure, namely prime is not doing appropriate sorting of devices in default device groups.
    Example: device type > routers > Cisco 2800 series integrated services routers - under shown results there are Cisco 2911 Integrated Service router, Cisco 2901 etc.
    Any solution? 
    Tnx

    Hi all:
    I have tried using Designing Monitoring Template to set the Health Check Polling time from default 15 minutes to 5 minutes and also tried also 1 minute.
    The result is 5 minutes is working but 1 minute is not working.
    May I know any one can help on this?
    Many thanks!
    Best regards,
    tangsuan

Maybe you are looking for

  • Hiding a table column and its contents yet reading the values

    Hi all, hope someone can help as i urgently need a solution for this although its probably more of a javascript and html forms question than a JSP - but i couldnt find a good javascript forum - if any one has come across a good JS and HTML - i would

  • Can i use "begin" and "end" in a database control

    hi there i just want to know if i can use begin and end with several sql update statments in between in a database control. u see, i need to run few update statements together. i don't want to put them in seperate method. i was wondering if i could p

  • Cant restore iCal library from Time Machine ?

    I could not find Calendar library in Time Machine; I was searching under my user name, nothing there So how can I restore my iCal ? By the way, I am not content with iCal, I would like another calendar, but is there anything for free ?

  • Function Pointer Problem?

    I need to call a function that is in main of a running class from another class. How could I do that? I have a single GUI frame that use for display all info sent (via TCP/IP) from the object which called by several short java programs (all running a

  • Datagrid and verticalScrollPosition

    Hello everyone I have a datagrid with an editable column. When I enter in an editable cell, automatically a new position of vertical scroll bar is set. Why? How can I prevent it? Thanks