Problem wrapping LDAP access

We're running into problems wrapping C functions that access LDAP in Forte. We are using the Netscape Directory SDK for C (Version 4.0) and have written and compiled C code (on Solaris 2.6) into a shared library that calls out to the Netscape LDAP shared library. The problems arise once they are Forte-wrapped...
I can see from several status messages that I have within both the C functions and the TOOL code that everything is working as it should, however, Forte locks up upon completing any of the functions, and I sometimes get a "libc internal error - rmutex not held" error message. The multithreaded property for this C project is set to FALSE.
Any insights/tips would be appreciated...

Hi Julie,
You can try to turn on multithreading for your C project (multiThreaded -
TRUE) and use your Forte wrapper object to synchronize the access to C
functions (using for example Shared property = IsDefault). Probably, the C
project is not linked with the thread-safe libc if you are using
multiThreaded - FALSE.
Regards,
Zenon
-----Original Message-----
From: Julie Muth [SMTP:MUTHdcjs.state.ny.us]
Sent: Thursday, September 07, 2000 9:10 AM
To: Forte-userslists.xpedior.com
Subject: (forte-users) Problem wrapping LDAP access
We're running into problems wrapping C functions that access LDAP in
Forte. We are using the Netscape Directory SDK for C (Version 4.0) and
have written and compiled C code (on Solaris 2.6) into a shared library
that calls out to the Netscape LDAP shared library. The problems arise
once they are Forte-wrapped...
I can see from several status messages that I have within both the C
functions and the TOOL code that everything is working as it should,
however, Forte locks up upon completing any of the functions, and I
sometimes get a "libc internal error - rmutex not held" error message.
The multithreaded property for this C project is set to FALSE.
Any insights/tips would be appreciated...
For the archives, go to: http://lists.xpedior.com/forte-users and use
the login: forte and the password: archive. To unsubscribe, send in a new
email the word: 'Unsubscribe' to: forte-users-requestlists.xpedior.com

Similar Messages

  • Problems with LDAP Server fail-over

    Our Xsan installed with 12 FCP, 2 MDC Xserve and 2 LDAP Xserver for fail-over.
    The 2 MDC fail-over runs well but the 2 LDAP fail-over got problems.
    The first time we up-plug the powercode of 1 xserve and the other LDAP takes over successfully but FCP users re-login takes 15 minutes. That's unacceptable.
    The fail-over never succeed after that.
    That means once the LDAP down and the backup LDAP will not take the job, we will lose everything related to user login.
    Anybody can help? Thanks a lot.

    I believe you can enter both LDAP servers in the client configuration for LDAP access. (Even though you shouldn't have to)
    IP failover is not the issue, your LDAP configuration is.
    Start at page 90 and work throught this document to make sure you have the clients setup properly.
    http://manuals.info.apple.com/en/MacOSXSrvr10.3_OpenDirectoryAdmin.pdf

  • When I use the CTUOnline site, the IM window will not open, and the Outlook mail frequently crashes. I do not have these problems if I access the site via Safari. I am using a Mac OS 10.4.11.

    I am teaching an online course through CTUOnline. I use a Mac OS 10.4.11. When I access the site thru Firefox, the IM chat window just says "Loading" but never loads. My campus mail, which is accessed through Outlook, frequently boots me out. I must copy and save every message, because I cannot predict when it will go through and when I will be thrown out. I have set my Preferences to allow pop-ups from ctuonline.edu and from campus.ctuonline.edu. I do not have these (connection?) problems when I access the site through Safari.
    == URL of affected sites ==
    https://campus.ctuonline.edu/MainFrame.aspx?ContentFrame=/Default.aspx

    I am teaching an online course through CTUOnline. I use a Mac OS 10.4.11. When I access the site thru Firefox, the IM chat window just says "Loading" but never loads. My campus mail, which is accessed through Outlook, frequently boots me out. I must copy and save every message, because I cannot predict when it will go through and when I will be thrown out. I have set my Preferences to allow pop-ups from ctuonline.edu and from campus.ctuonline.edu. I do not have these (connection?) problems when I access the site through Safari.
    == URL of affected sites ==
    https://campus.ctuonline.edu/MainFrame.aspx?ContentFrame=/Default.aspx

  • Problem with LDAP in BEA Portal

    Problem with LDAP in BEA Portal
    I have a list of 50 user which should be cerated in portal staging(devlopment) machine and should be transfered to
    production machine using LDAP
    Steps which i followed to create Users
    1.Create User Profile with 2 parameters branch and Role
    2.I have list user in the Xls file with Username,password ,branch and Role
    3.Write a java File which will read the Xls File
    4.The users are created in the staging machine for the portal
    Steps which i followed in LDAP to tranfer the created User form Devlopment to Production
    1.Export the created user from Devlopment (which was moved as .DAT in my local directory)
    2.import the user from local direcory to production machine
    The Users are imported in the production machine with username and password but the role and branch values are empty
    We need a solution for importing the user with role and branch corresponding to each user.
    Thanks in Adv
    Suresh

    In Portal 8.1, user name and password in stored in LDAP where as user profile values are stored in database. That is the reason you are not able to see the user profile values.
    Check once again whether you can see these values through admin tool. In case,it is not(after confirmation again),you might have to use APIs to do this for you incase you dont want to manage through Admin Tool.
    Thanks,
    Prashanth Bhat.

  • Problem with file access in other computer in jsp

    I have problem with file accessing in other computer in jsp.
    The follow code
    File folder=new File("Z:"+File.separator+"sharefolder");//Z is a net share driver
    File[] files=folder.listFiles();
    System.out.println("test");
    System.out.println("length="+files.length);
    will throw exception at the second print.
    but it works well in main funtion.
    Is anybody know what is the problem.
    JSP works on windows2003 server,tomcat 5.0.28 JDK1.4 net share folder on windows2000 server

    no error code for this.But when I start tomcat I get the follow error.
    java.lang.IllegalArgumentException: Document base Z:\ does not exist or is not a readable directory
         at org.apache.naming.resources.FileDirContext.setDocBase(FileDirContext.java:138)
         at org.apache.catalina.core.StandardContext.resourcesStart(StandardContext.java:3910)
         at org.apache.catalina.core.StandardContext.start(StandardContext.java:4138)
         at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:823)
         at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:807)
         at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:595)
         at org.apache.catalina.core.StandardHostDeployer.addChild(StandardHostDeployer.java:903)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at org.apache.commons.beanutils.MethodUtils.invokeMethod(MethodUtils.java:216)
         at org.apache.commons.digester.SetNextRule.end(SetNextRule.java:256)
         at org.apache.commons.digester.Rule.end(Rule.java:276)
         at org.apache.commons.digester.Digester.endElement(Digester.java:1058)
         at org.apache.catalina.util.CatalinaDigester.endElement(CatalinaDigester.java:76)
         at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
         at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
         at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
         at org.apache.commons.digester.Digester.parse(Digester.java:1567)
         at org.apache.catalina.core.StandardHostDeployer.install(StandardHostDeployer.java:488)
         at org.apache.catalina.core.StandardHost.install(StandardHost.java:863)
         at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:483)
         at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:427)
         at org.apache.catalina.startup.HostConfig.start(HostConfig.java:983)
         at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:349)
         at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1091)
         at org.apache.catalina.core.StandardHost.start(StandardHost.java:789)
         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
         at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:478)
         at org.apache.catalina.core.StandardService.start(StandardService.java:480)
         at org.apache.catalina.core.StandardServer.start(StandardServer.java:2313)
         at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)
         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:425)
    Jun 5, 2006 6:55:41 PM org.apache.catalina.core.StandardContext start
    SEVERE: Error in resourceStart()
    Jun 5, 2006 6:55:41 PM org.apache.catalina.core.StandardContext start
    SEVERE: Error getConfigured
    Jun 5, 2006 6:55:41 PM org.apache.catalina.core.StandardContext start
    SEVERE: Context startup failed due to previous errors
    Jun 5, 2006 6:55:41 PM org.apache.catalina.core.StandardContext start
    SEVERE: Exception during cleanup after start failed
    LifecycleException: Container StandardContext[msgstore] has not been started
         at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4466)
         at org.apache.catalina.core.StandardContext.start(StandardContext.java:4371)
         at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:823)
         at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:807)
         at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:595)
         at org.apache.catalina.core.StandardHostDeployer.addChild(StandardHostDeployer.java:903)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at org.apache.commons.beanutils.MethodUtils.invokeMethod(MethodUtils.java:216)
         at org.apache.commons.digester.SetNextRule.end(SetNextRule.java:256)
         at org.apache.commons.digester.Rule.end(Rule.java:276)
         at org.apache.commons.digester.Digester.endElement(Digester.java:1058)
         at org.apache.catalina.util.CatalinaDigester.endElement(CatalinaDigester.java:76)
         at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanEndElement(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
         at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
         at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
         at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
         at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
         at org.apache.commons.digester.Digester.parse(Digester.java:1567)
         at org.apache.catalina.core.StandardHostDeployer.install(StandardHostDeployer.java:488)
         at org.apache.catalina.core.StandardHost.install(StandardHost.java:863)
         at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:483)
         at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:427)
         at org.apache.catalina.startup.HostConfig.start(HostConfig.java:983)
         at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:349)
         at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1091)
         at org.apache.catalina.core.StandardHost.start(StandardHost.java:789)
         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
         at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:478)
         at org.apache.catalina.core.StandardService.start(StandardService.java:480)
         at org.apache.catalina.core.StandardServer.start(StandardServer.java:2313)
         at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:585)
         at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:287)

  • LDAP access info in datasource xml file for multidomain Test Connect fails.

    Hello SDN
    I've gone through the video that explains how to setup the multidomain conf.
    I have my service users but when it comes to enter the ldap access user I'm not sure what info to enter.
    My ldap user is created at the  company.com level not at the domain1.company.com level as is indicated in the video.
    I entered the following values
    ume.ldap.access.server_name> server1
    ume.ldap.access.user> [email protected]
    ume.ldap.access.base_path.user> CN=USERS,DC=COMPANY,DC=COM
    ume.ldap.access.base_path.grup> CN=USERS,DC=COMPANY,DC=COM
    And when I try to test connection I'm getting an error. So I have two questions:
    Should the ldap account be created at the domain1.company.com level?
    And how do I get the correct info to populate the base_path fields? Not sure where to get it, I just followed video.
    Thanks for any help.
    MR

    Couple of things.,
    1. What LDAP you are using
    2. What kind of hierarchy (flat or deep)
    The hierachy will decide the user path and the group path.
    Given you have all the right values then you populate the values for the foolowing.,
    - Server Name or IP
    - Server port number
    - LDAP user name by (used for connectivity and access which should have enough rights)
    - Password for the LDAP user
    - User path
    - Group path
    With all the above given right the test connection should succeed.
    Optionally SSL can be enabled for LDAP connectivity and can specify unique attribute for UME unique ID (this field will be uid for SUN LDAP and samaccountname for MS AD)
    Regards,
    Muthu Kumaran KG

  • Problem with Table Access Full

    Hi,
    Please help me how to resolve the problem of table access full, when i am executing query i facing a problem with these. all though i have create index on these is queru but execution time taking too late.
    Also please help if there any syntax to run faster execution.
    Thanks in Advance
    Sreenivas

    Hi,
    Please try to analyze your tables once with DBA's help.
    If the above does not work, try to use hints which will force use the index created on the column.
    Do not use any conversion functions on that column, in the where clause while checking any condition.
    If you are storing numbers in a character column, try to have the conditional value as character value in where clause instead of number type.
    Thanks and Regards,
    Sridhar.

  • Problem With Site Access

    Hi guys,
    I've been trying to access the Market Place as well as my account at: www.renderosity.com, but when I click to the Market Place on the link I get the message below (included also is my correspondence with the site's admin). I can access the rest of the site with no seeming problem. And it seems to be only that site that I have been having problems with. I have Java enabled and the block pop-up is unchecked. But it is only with that site that I am having problems with. They have had no reports of any problems from their side. Thanks for any help. Please reply to my other e-mail: [email protected]
    Cheers;-)
    Michael
    404 Not Found
    http://219.235.223.223/forbid.htm
    Not Found
    The requested URL /forbid.htm was not found on this server.
    Apache/1.3.22 Server at WebRoad Port 80
    Hi Michael,
    Do you have javascript enabled? Are you running any security software?
    Karen
    Michael Boatwright wrote:
    Hi Karen,
    I finally managed to get through to the Market Place, but this is how the page looked (See Attached image). Any ideas? I still cannot get into my account though.
    Hi Michael,
    I've never seen that url before which is why I got confused.
    Try this one and let me know if you have problems.
    http://market.renderosity.com/
    Regards,
    Debbie Montique
    MarketPlace Manager
    Michael Boatwright wrote:
    Hi Deb,
    and thanks for the quick reply. That URL is what shows up when I click on the Market Place Home. Maybe it's just temporary. I certainly hope so! I've never had this problem before. I guess time will tell. Thanks again.
    Cheers,
    Michael
    Hi Michael,
    We're not aware of any problem on the site. Can you please give me the exact URL that you are trying to access?
    Additionally, it may be helpful if you log out of Renderosity, empty your cookies and cache on your browser, and then sign back in and see if that resolves the problem.
    Kind regards,
    Karen Janes
    Renderosity Admin Team
    Michael Boatwright wrote:
    Hi guys,
    I have never had problems before with access to any part of Rendo and even now I can access parts of your site, but I can neither access my account nor the market place. Is there something going on from your end? Here is the message that I'm getting when I try to get to those parts of the site that I just mentioned:

    Hi Ayesh,
    Per my test, it seems that the Site Collection Access is only available for the local group of that site collection which is used to store the site collection local term sets.
    To make the site collection local group available, please refer to the steps in the link below:
    http://www.dotnetsharepoint.com/2013/10/how-to-get-site-collection-local-term.html#.U-PVOvmSyd5
    After that, you will see the Site Collection Access when you click the group in Term Store Management.
    Best regards.
    Thanks
    Victoria Xia
    TechNet Community Support

  • I have been having problem for cad access since I upgrade from OSX 10.6 to OSX 10.8  Now it is akin me to select a certificate, but there is none listed

    I have been having problem for cac access since I upgrade from OSX 10.6 to OSX 10.8.   Now it is aking me to select a certificate, but there is none listed.

    Is the SW  you are using campaitible with 10.8.x?

  • Problem transferring keychain access to new iMac

    just bought a new iMac, but am having problems with keychain access which has not automatically transferred with Migratiin Assistant.
    can anyon help please? My old computer is also an iMac.

    Are you really using 10.4.9? 'Apple Menu > About this Mac' should tell you the correct OS X version number.
    The keychain is stored inside your home 'library'
    On your old Mac or old backup find the /Users/YOUR-OLD-USERNAME/Library/Keychains folder. This may be hidden! You will need to use the Finders 'Go Menu > Go to Folder…' to open the library within that folder. Just drop the old home folder into that field to complete the path and add /Library to the end of it.
    Double click that file & it should import that into the Keychain Access database.
    Eject the backup & double check that you can still read items in the old keychain. It should copy it into the new library - but I cannot recall if 10.4 behaved the same way.

  • Problems with Timed Access on Airport Extreme n & Express

    Hi
    I have recently upgraded to an Apple network at home, with good results. The extreme n is my main router, connected to a Netgear modem, with an express n used to extend the network across the house.
    This all works fine, except for one problem - the timed access. I am trying to restrict the access on my son's iPod touch without success.
    The set up is as follows:
    Default - no access
    All other machines - all day everyday
    My son's iPod touch - weekdays restricted to evenings and weekends a more relaxed restriction.
    The problem is this - his iPod touch allows him to access at any time. If I take his iPod touch off the timed access list, the default works i.e. he can't connect to the network. If I apply the settings again, he has free access.
    I've tested his restrictions on my iPhone and they apply perfectly - doh!
    Any suggestions please?
    Thanks
    Paul

    Found the answers myself
    MAC address is a unique address (looks like 00:05:92:a6:3a:70) that each network card on a Mac or PC has. To find it, go to System Prefs/Network/Firewire. On the PC use the Start-button and write the command ipconfig_/all to get the physical address. Add one line for each client (Mac or PC) in the time access configuration for the Airport Base Station, and here you can limit the access time for each client.
    Message was edited by: Helge Krabye

  • Still having problems with VPN access

    Hello!
    I am having problems with my VPN clients getting access to the networks over a MPLS infrastruture. I can reach these resources form my Core network (172.17.1.0/24) and my Wifi (172.17.100.0/24) but not from my VPN network (172.17.200.0/24). From the VPN I can reach the Wifi network (which is behind a router) and the rule that allows that also allows access to the other networks but for some reason it is not working.
    When I ping inside the core network from VPN I can connect and get responses. When I ping to the Wifi network, I can get responses and connect to resources there. A tracert to the wifi network shows it hitting the core switch (a 3750 stack) @ 172.17.1.1, then the Wifi router (172.17.1.3) and then the host. A tracert to a resource on the MPLS network from the VPN shows a single entry (the destination host) and then 29 time outs but will not ping that resource nor connect.
    I've posted all the info I can think of below. Any help appreciated.
    *** Here is a tracert from a core network machine to the resource we need on the MPLS:
    C:\Windows\system32>tracert 10.2.0.125
    Tracing route to **************** [10.2.0.125]
    over a maximum of 30 hops:
      1     1 ms    <1 ms    <1 ms  172.17.1.1
      2     1 ms    <1 ms    <1 ms  172.17.1.10
      3     5 ms     5 ms     5 ms  192.168.0.13
      4    31 ms    30 ms    31 ms  192.168.0.5
      5    29 ms    30 ms    29 ms  192.168.0.6
      6    29 ms    29 ms    29 ms  192.168.20.4
      7    29 ms    29 ms    29 ms  RV-TPA-CRMPROD [10.2.0.125]
    Trace complete.
    172.17.1.10 is the mpls router.
    **** Here is the routing table (sh ip route) from the 3750 @ 172.17.1.1
    Gateway of last resort is 172.17.1.2 to network 0.0.0.0
    S    192.168.30.0/24 [1/0] via 172.17.1.10
         172.17.0.0/24 is subnetted, 3 subnets
    S       172.17.200.0 [1/0] via 172.17.1.2
    C       172.17.1.0 is directly connected, Vlan20
    S       172.17.100.0 [1/0] via 172.17.1.3
         172.18.0.0/24 is subnetted, 1 subnets
    S       172.18.1.0 [1/0] via 172.17.1.10
    S    192.168.11.0/24 [1/0] via 172.17.1.10
         10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    S       10.2.0.0/24 [1/0] via 172.17.1.10
    S       10.10.10.0/24 [1/0] via 172.17.1.10
    S       10.20.0.0/24 [1/0] via 172.17.1.10
    S       10.3.0.128/25 [1/0] via 172.17.1.10
    S    192.168.1.0/24 [1/0] via 172.17.1.10
    S*   0.0.0.0/0 [1/0] via 172.17.1.2
    *** Here is the firewall config (5510):
    ASA Version 8.4(1)
    hostname RVGW
    domain-name ************
    enable password b5aqRk/6.KRmypWW encrypted
    passwd 1ems91jznlfZHhfU encrypted
    names
    interface Ethernet0/0
    nameif Outside
    security-level 10
    ip address 5.29.79.10 255.255.255.248
    interface Ethernet0/1
    nameif Inside
    security-level 100
    ip address 172.17.1.2 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 172.19.1.1 255.255.255.0
    management-only
    banner login RedV GW
    ftp mode passive
    dns server-group DefaultDNS
    domain-name RedVector.com
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network WiFi
    subnet 172.17.100.0 255.255.255.0
    description WiFi 
    object network inside-net
    subnet 172.17.1.0 255.255.255.0
    object network NOSPAM
    host 172.17.1.60
    object network BH2
    host 172.17.1.60
    object network EX2
    host 172.17.1.61
    description Internal Exchange / Outbound SMTP
    object network Mail2
    host 5.29.79.11
    description Ext EX2
    object network NETWORK_OBJ_172.17.1.240_28
    subnet 172.17.1.240 255.255.255.240
    object network NETWORK_OBJ_172.17.200.0_24
    subnet 172.17.200.0 255.255.255.0
    object network VPN-CLIENT
    subnet 172.17.200.0 255.255.255.0
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq www
    port-object eq https
    object-group network DM_INLINE_NETWORK_1
    network-object object BH2
    network-object object NOSPAM
    object-group network VPN-CLIENT-PAT-SOURCE
    description VPN-CLIENT-PAT-SOURCE
    network-object object VPN-CLIENT
    object-group network LAN-NETWORKS
    network-object 10.10.10.0 255.255.255.0
    network-object 10.2.0.0 255.255.255.0
    network-object 10.3.0.0 255.255.255.0
    network-object 172.17.100.0 255.255.255.0
    network-object 172.18.1.0 255.255.255.0
    network-object 192.168.1.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 192.168.30.0 255.255.255.0
    object-group network VPN-POOL
    network-object 172.17.200.0 255.255.255.0
    object-group protocol DM_INLINE_PROTOCOL_1
    protocol-object ip
    protocol-object icmp
    access-list Outside_access_in extended permit tcp any object-group DM_INLINE_NETWORK_1 eq smtp
    access-list Outside_access_in extended permit tcp any object BH2 object-group DM_INLINE_TCP_1
    access-list global_mpc extended permit ip any any
    access-list Inside_access_in extended permit object-group DM_INLINE_PROTOCOL_1 any any
    pager lines 24
    logging enable
    logging asdm informational
    no logging message 106015
    no logging message 313001
    no logging message 313008
    no logging message 106023
    no logging message 710003
    no logging message 106100
    no logging message 302015
    no logging message 302014
    no logging message 302013
    no logging message 302018
    no logging message 302017
    no logging message 302016
    no logging message 302021
    no logging message 302020
    flow-export destination Inside 172.17.1.52 9996
    mtu Outside 1500
    mtu Inside 1500
    mtu management 1500
    ip local pool VPN 172.17.1.240-172.17.1.250 mask 255.255.255.0
    ip local pool VPN2 172.17.200.100-172.17.200.200 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    nat (Inside,Outside) source static EX2 Mail2
    nat (Inside,Outside) source static any any destination static NETWORK_OBJ_172.17.1.240_28 NETWORK_OBJ_172.17.1.240_28
    nat (Inside,Outside) source static any any destination static NETWORK_OBJ_172.17.200.0_24 NETWORK_OBJ_172.17.200.0_24
    nat (Inside,Outside) source static inside-net inside-net destination static NETWORK_OBJ_172.17.1.240_28 NETWORK_OBJ_172.17.1.240_28
    nat (Inside,Outside) source static LAN-NETWORKS LAN-NETWORKS destination static VPN-POOL VPN-POOL
    object network inside-net
    nat (Inside,Outside) dynamic interface
    object network NOSPAM
    nat (Inside,Outside) static 5.29.79.12
    nat (Outside,Outside) after-auto source dynamic VPN-CLIENT-PAT-SOURCE interface
    access-group Outside_access_in in interface Outside
    access-group Inside_access_in in interface Inside
    route Outside 0.0.0.0 0.0.0.0 5.29.79.9 1
    route Inside 10.2.0.0 255.255.255.0 172.17.1.1 1
    route Inside 10.3.0.0 255.255.255.128 172.17.1.1 1
    route Inside 10.10.10.0 255.255.255.0 172.17.1.1 1
    route Inside 172.17.100.0 255.255.255.0 172.17.1.3 1
    route Inside 172.18.1.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.1.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.11.0 255.255.255.0 172.17.1.1 1
    route Inside 192.168.30.0 255.255.255.0 172.17.1.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server RedVec protocol ldap
    aaa-server RedVec (Inside) host 172.17.1.41
    ldap-base-dn DC=adrs1,DC=net
    ldap-group-base-dn DC=adrs,DC=net
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password *****
    ldap-login-dn CN=Hanna\, Roger,OU=Humans,OU=WPLAdministrator,DC=adrs1,DC=net
    server-type microsoft
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 172.17.1.0 255.255.255.0 Inside
    http 24.32.208.223 255.255.255.255 Outside
    snmp-server host Inside 172.17.1.52 community *****
    snmp-server location Server Room 3010
    snmp-server contact Roger Hanna
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map Outside_map interface Outside
    crypto ikev1 enable Outside
    crypto ikev1 policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 172.17.1.0 255.255.255.0 Inside
    telnet timeout 5
    ssh 172.17.1.0 255.255.255.0 Inside
    ssh timeout 5
    console timeout 0
    dhcpd address 172.17.1.100-172.17.1.200 Inside
    dhcpd dns 172.17.1.41 172.17.1.42 interface Inside
    dhcpd lease 100000 interface Inside
    dhcpd domain adrs1.net interface Inside
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    group-policy RedV internal
    group-policy RedV attributes
    wins-server value 172.17.1.41
    dns-server value 172.17.1.41 172.17.1.42
    vpn-tunnel-protocol ikev1
    default-domain value ADRS1.NET
    group-policy RedV_1 internal
    group-policy RedV_1 attributes
    wins-server value 172.17.1.41
    dns-server value 172.17.1.41 172.17.1.42
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    default-domain value adrs1.net
    username rparker password FnbvAdOZxk4r40E5 encrypted privilege 15
    username rparker attributes
    vpn-group-policy RedV
    username mhale password 2reWKpsLC5em3o1P encrypted privilege 0
    username mhale attributes
    vpn-group-policy RedV
    username dcoletto password g53yRiEqpcYkSyYS encrypted privilege 0
    username dcoletto attributes
    vpn-group-policy RedV
    username rhanna password Pd3E3vqnGmV84Ds2 encrypted privilege 15
    username rhanna attributes
    vpn-group-policy RedV
    tunnel-group RedV type remote-access
    tunnel-group RedV general-attributes
    address-pool VPN2
    authentication-server-group RedVec
    default-group-policy RedV
    tunnel-group RedV ipsec-attributes
    ikev1 pre-shared-key *****
    class-map global-class
    match access-list global_mpc
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    class global-class
      flow-export event-type all destination 172.17.1.52
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:202ad58ba009fb24cbd119ed6d7237a9

    Hi Roger,
    I bet you already checked it, but does the MPLS end router has route to VPN client subnet 172.17.200.x (or default) pointing to core rtr)?
    Also, if the MPLS link has any /30 subnet assigned, you may need to include that as well in Object group LAN-NETWORKS.
    Thx
    MS

  • Problem in LDAP search

    I am having problem in running the below code, can someone pls help me out with it ? It either doesn't return anything or gives error code 32.
    import javax.naming.*;
    import javax.naming.ldap.*;
    import java.util.*;
    import javax.naming.directory.*;
    public class ldapdemo {
         public static void main(String[] args) {
              try {
                   Hashtable env = new Hashtable();
                   env.put(Context.INITIAL_CONTEXT_FACTORY,"com.sun.jndi.ldap.LdapCtxFactory");
                   env.put(Context.PROVIDER_URL, "LDAP://dewdfx1b1:389");
                   LdapContext ldapctx = new InitialLdapContext(env, null);
                   Attributes matchAttrs = new BasicAttributes();
                   matchAttrs.put("uid","I028949");
                   String [] attrIDs = {"cn","mail"};
                   NamingEnumeration answer = ldapctx.search("o=SAP", matchAttrs, attrIDs);
         while(answer.hasMore()) {
                   SearchResult sr = (SearchResult)answer.next();
                   Attributes resultAttrs = sr.getAttributes();
                   String username = resultAttrs.get("cn").getID();
                   String mail = resultAttrs.get("mail").getID();
                   System.out.println("username="+username);
                   System.out.println("mail="+mail);
              } catch (NamingException e) {
                   System.out.println(e.getMessage());
                   return;

    Sameer,
    First, I see no authentication in your coding. Probably it is required.
    Second, where is base DN for binding?
    Try this sample (for InitialContext info with credentials):
    http://www.sgi.nu/diary/2005/10/27/accessing-the-global-address-list-in-ms-exchange-from-java/
    Also I highly recommend to download Java LDAP browser/editor and try to perform your program task it:
    http://www-unix.mcs.anl.gov/~gawor/ldap/
    Valery Silaev
    EPAM Systems
    http://www.NetWeaverTeam.com

  • Remote Delta link setup problem with Bean / Access Service

    Hello,
    I am trying to setup Remote Delta Link (RDL) between two portals. (Both portals same version - EP 7.0 EHP1 SP 05 - are in the same domain)
    I already have the Remote Role Assignment working without any issues.
    The following have been done successfully:
    1. Same user repository has been setup for both the portals
    2. Setup trust between producer and consumer (SSO working fine)
    3. Producer added and registered succesfully on consumer
    4. Permissions setup on producer and consumer
    4. pcd_service user with required UME actions setup
    I am able to see all the remote content in the Consumer portal.
    When I try to copy the remote content and paste it as local content, I am getting the following error:
    Could not create remote delta link to object 'page id'. Could not connect to the remote portal. The remote portal may be down, there may be a network problem, or your connection settings to the remote portal may be configured incorrectly.
    After increasing the log severity, I am able to see the following in Default Trace:
    com.sap.portal.fpn.transport.Trying to lookup access service (P4-RMI) for connecting to producer 'ess_int' with information: com.sap.portal.fpn.remote.AccessServiceInformation@31c92207[connectionURL=hostname.mycompany.com:50004, shouldUseSSL=false, RemoteName=AccessService]
    com.sap.portal.fpn.transport.Unable to lookup access service (P4-RMI) with information: com.sap.portal.fpn.remote.AccessServiceInformation@31c92207[connectionURL=hostname.mycompany.com:50004, shouldUseSSL=false, RemoteName=AccessService]
    AbstractAdvancedOperation.handleDirOperationException
    [EXCEPTION]
    com.sap.portal.pcm.admin.exceptions.DirOperationFailedException: Could not retrieve the bean / access service to connect with producer
    Could not retrieve the bean / access service to connect with producer
    Like you can see above, there is some bean / access service which is not retrieved successfully. I am not sure if this is a permission problem on the consumer.
    I have checked that the P4 ports are configured correctly (standard - not changed) and I am able to telnet from producer to consumer (and vice versa) on the P4 port.
    I am stuck at this point and am not able to find any information on this.
    I would really appreciate if some one can point me in the right direction.
    Thank you for reading.
    - Raj

    Hi Raj,
    Please check your config of the P4 port on the producer.  Is it really 50004 (check SystemInfo of the producer)?
    I do think there's a problem with the P4 communication since RDL requires P4 connection.
    Do you have load balanced consumer-producer connection? Please refer to this blog for further details
    Little known ways to create a load balanced Consumer – Producer connection in a FPN scenario
    Regards,
    Dao

  • Problem with MS Access Files and executable files migrateds

    Hi all.
    We are migrating an old Netware 6.0 server to new SLES 10 SP3 with OES 2 SP2a. I already migrated one volume and in this weekend well migrate the last, and most important, volume to new OES 2 server.
    The problem is about some MS Access databases that are very very used for all users and some executable applications that was writed using fisical path like \\OLDSERVER\VOL\PATH\APP.EXE or some links to libraries, databases, images, etc.
    The old NW 6.0 server will be removed from the tree in 2 or 3 weeks and in this time the two servers will co-exists. I want to know if it is possible redirect NCP requests to OLDSERVER to NEWSERVER without users rewrite all of MS Access and executable applications. Is it possible?
    Tks
    Alan Cota.

    AlanCota wrote:
    >
    > Hi all.
    >
    > We are migrating an old Netware 6.0 server to new SLES 10 SP3 with OES
    > 2 SP2a. I already migrated one volume and in this weekend we´ll migrate
    > the last, and most important, volume to new OES 2 server.
    >
    > The problem is about some MS Access databases that are very very used
    > for all users and some executable applications that was writed using
    > fisical path like \\OLDSERVER\VOL\PATH\APP.EXE or some links to
    > libraries, databases, images, etc.
    >
    > The old NW 6.0 server will be removed from the tree in 2 or 3 weeks and
    > in this time the two servers will co-exists. I want to know if it is
    > possible redirect NCP requests to OLDSERVER to NEWSERVER without users
    > rewrite all of MS Access and executable applications. Is it possible?
    >
    > Tks
    >
    > Alan Cota.
    >
    >
    Have you considered trying to use a dns alias to it. I have not tested with
    MS access specifically but many other apps it works perfectly for. This is
    how I get around those issues. Of course your issue is that you still
    havethe existing server in the tree. How much will there still be on the
    old server. You could rename the old nw server and than update its info in
    dns to resolve this.

Maybe you are looking for

  • Array of Class object

    Pls.c the following code, public class Rate private Points []startPoints; public Rate() startPoints = new Points[4]; startPoints[0].p_intX = 40; startPoints[0].p_intY = 40; }//Constr public static void main(String []args) new Rate(); }//main class Po

  • Didn't register soon enough, so photoshop elements 12 not working

    Apparently, I didn't register and sign in my adobe photoshop elements 12 within 7 days, so it isn't working. Now what?

  • 12" Pbook / 12" iBook & Aperture - Experiences?

    Hi all, I am wondering about comparative performance using Aperture on either of the 12" Apple portables. One has more video memory but the other has a more modern graphics chip... Anybody care to share their own experience of how well either of thes

  • Can I get a replacement?

    I ordered my C2D MacBook the day they were released. When I recieved it I noticed a whine, and called Apple about it. I had it for about a week and then I took it to a repair center. They kept the computer for three weeks, and did nothing about the w

  • Content Area Search Engine

    I need to create a search engine portlet for my content areas , in fact I found two portlets in the portal portlet provider, I would like to know where could I find this portlets' source code in order to modify them and create my own portlet, or is t