Rate limit the internet Bandwidth/Speed

Hello ,
In ASA 5510.
How I can limit the users in (VLAN 20) to use the internet with a limited Bandwidth/speed with 3 mbps upload and 5 mbps download?
In case the outside interface (Native vlan) which is connected to the ISP and have a bandwidth/speed of 30 mbps upload and 50 mbps download.
Thanks in advanced,
MKD

This worked well for limiting download but doesn't seem to put a limit on the upload.  Am I doing something wrong?
I was just using speedtest.net to verify my upload and download are 10 Mbps.  The test result is 9.40 Mbps down and 17.22 Mbps upload.  I've retested a few times with the same result.
If I remove the service policy I get 55-60 Mbps up and down so it seems like the upload limit is doing something.
I do get matched packets for input and output though,
Interface Public_Wireless:
  Service-policy: SHAPE-PUBLIC-WIRELESS
    Class-map: LimitPublicWireless
      Output police Interface Public_Wireless:
        cir 10000000 bps, bc 312500 bytes
        conformed 160908 packets, 180033824 bytes; actions:  transmit
        exceeded 4952 packets, 6813748 bytes; actions:  drop
        conformed 1502312 bps, exceed 56968 bps
      Input police Interface Public_Wireless:
        cir 10000000 bps, bc 312500 bytes
        conformed 103702 packets, 26569368 bytes; actions:  transmit
        exceeded 1193 packets, 1561054 bytes; actions:  drop
        conformed 221728 bps, exceed 13048 bps
Here's my config,
! all wireless ip traffic
access-list PublicWireless extended permit ip 10.0.0.0 255.255.248.0 any
access-list PublicWireless extended permit ip any 10.0.0.0 255.255.248.0
class-map LimitPublicWireless
match access-list PublicWireless
policy-map SHAPE-PUBLIC-WIRELESS
class LimitPublicWireless
  ! 10Mbps limits
  police output 10000000
  police input   10000000
! What interface it is sourcing from
service-policy SHAPE-PUBLIC-WIRELESS interface Public_Wireless

Similar Messages

  • The easiest way to limit the overall bandwidth

    I want to limit the overall bandwidth of some machines in my lan .
    Example :
    Machine 1 : 10KB/s dl / 3KB/s do
    Machine 2 : 15KB/s dl / 5KB/s do
    All the machines run Arch and I have full access on them .

    Well, if squid seemed hard to setup, prepare yourself for the iproute2/tc setups. I use an old "automated" script, called cbq.init. I think I have to patch it a little for it to work on Arch (because of a wrong find option order somewhere in the script. I think I found the workaround with my Google friend.
    HTBTools  is another software that implements the iproute2/tc solution, but in the latest distros I've encountered lots of problems setting it up and running. It is also currently unmaintained and unsupported.

  • What is the internet sharing speed of macmini

    what is the internet sharing speed of macmini?

    Depends on the port you are sharing. If over wireless it will be the wireless speed of the slowest wireless device on your network for the wireless band in use. That might be anywere from 54 Mb/s to 230 Mb/s - that's Mega-Bits/second.

  • Can RV042 limit the bandwidth for a certain website?

    Can it limit streaming websites? example "youtube" and torrent downloads? and dont affect other websites/ gaming speeds
    currently has 50 units connected with 2 ADSL connections both with maximum down of upto 4.5mbps.
    thank you
    newbie here
    ian

    You could try configuring rate control rules (under System Management>Bandwidth Management) to "rate limit" the traffic (in terms of TCP/UDP port numbers) from specific IP address (or range). But this may not be sufficient for your need.

  • How to globally limit the bandwidth of FMS 3.5

    Hi all,
    Can you give me a hint on how to solve this or confirm me the following ?
        Is it possible to limit globally the bandwidth usage of FMS 3.5 ?
    I don't want FMS  to use all the bandwidth available via our ISP.
    I want my coworkers and other servers to be able to continue using Internet while sending/receiving data from/to FMS
    I know it is possible to limit various bandwidths per Applications, but it seems there is no easy way - using the xml config files - to globally limit the server bandwidth.Ok I could compute a limit per app, but it is not a long terme solution to modify all the config files each time a new applications is to be installed.
    So I think it is not possible to easily limit globally the bandwidth of FMS.
    Do you agree with me ?
    If not, how did you manage this : do you have an example, some code ?
    Thanks for your answers
    Fred

    Thanks for the try, though I'd hope you aimed at a another solution
    I think your proposition is not possible this way, because:
    (It is for streaming only )
    1) say we have a BW of 100 [Mb/s] available for this FMS.
    2) the individual bw needed by the media files (indbw) within an application ranges from 200 [kb/s] to 2000[kb/s] (some files are audio, others medium quality video, some good quality video)
    3) the BandwidthCap (in application.xml) is  per connection within the application. (to simplify the talk we choose a BandwidthCap = indbw )
    4) the MaxConnections (in vhost.xml) is per vhost
    The question is "which indbw one chooses to divide the available 100 [Mb/s] BW" : ( MaxConnections = BW divided by BandwidthCap )
    Two possibilities:
    A) Let's take audio only indbw, that's 200 [kb/s], then FMS can serve 500 connections
    B) Let's take good quality vid indbw, that's 20000 [kb/s], then FMS would be limited to 50 connections.
    Both ways are not good :  in A) we risk jamming the internet link if too many of the connections are in fact streaming video, in B) we can not serve enough people and will likely waste some BW sinc not all clients will stream good quality video.
    Does anyone has another hint about " how to globally limiting the bandwidth of Flash Media Server 3.5" ?

  • How to rate-limit different IP's entering/leaving an Interface?

    Hi There,
    We are an ISP and have an interconnect with say Provider A. Customers of ours use Provider A for layer 2 and us for Layer 3 (IP/Internet).
    Customer #1 to #100 --- (10Mb) --> Provider A ---> ISP ---> Internet
    We'd like to rate limit some customers to 2mb/sec (in/out) on our end because at present they have a 10mb/sec connection coming from Provider A.
    The config we use to peer with Provider A is this:
    interface GigabitEthernet0/1.120
    description Interconnect with Provider A
    bandwidth 400000
    encapsulation dot1Q 120
    ip address A.B.C.1 255.255.255.252
    Customers of ours are simply routed out through this interface like so:
    Customer #1:
    ip route W.X.Y.Z. 255.255.255.255 A.B.C.2
    Customer #2:
    ip route J.K.L.M 255.255.255.255 A.B.C.2
    Is there a way to rate limit both these customers without needing to create a separate class map for each like so:
    class-map match-all CUSTOMER-1-2MB
    match access-group name ACL-CUSTOMER-1
    class-map match-all CUSTOMER-2-2MB
    match access-group name ACL-CUSTOMER-2
    policy-map POLICY-RATE-LIMIT
    class CUSTOMER-1-2MB
    police 2000000 375000 750000
    class CUSTOMER-2-2MB
    police 2000000 375000 750000
    interface GigabitEthernet0/1.120
    service-policy input POLICY-RATE-LIMIT
    service-policy output POLICY-RATE-LIMIT
    I've done this in the lab and I know it works, so Customer #1 ends up with 2mb/sec and Customer #2 gets 2mb/sec too.
    But in production, I'm talking about 100's of customers which we simply route out of this interface. I can't imagine having to configure 100's of class maps and policy maps for each customer to rate limit them to 2mb/sec like in the config above.
    Is there a better way to do this on the router???
    Thanks.
    Andy

    Hi All,
    Doing what Laurent suggested works great. We are able to rate-limit the desired customers by having a separate class-map for each customer that needs to be rate limited under the single policy-map.
    But now we're finding that the CPU utilization has increased by 20% because of this.
    We're pushing about 400M through this interface and rate limiting 7 customers on it.
    Given the large traffic flow through this interface (400M), is it common to see an increase in CPU utilisation by 20%???
    When we take the service-policy off the interface, sure enough the CPU drops by 20%.
    Here's the MQC applied:
    interface GigabitEthernet0/1.120
    bandwidth 400000
    encapsulation dot1Q 120
    ip address 203.17.x.x 255.255.255.252
    ip flow ingress
    service-policy input RATE-LIMIT
    service-policy output RATE-LIMIT
    class-map match-all CLASS-TCS-200338
    description Customer #1 rate limited to 4mb/sec
    match access-group name ACL-TCS-200338
    class-map match-all CLASS-TCS-200208
    description Customer #2 rate limited to 2mb/sec
    match access-group name ACL-TCS-200208
    class-map match-all CLASS-TCS-205593
    description Customer #3 rate limited to 3mb/sec
    match access-group name ACL-TCS-205593
    class-map match-all CLASS-TCS-205679
    description Customer #4 rate limited to 4mb/sec
    match access-group name ACL-TCS-205679
    class-map match-all CLASS-TCS-200441
    description Customer #5 rate limited to 4mb/sec
    match access-group name ACL-TCS-200441
    class-map match-all CLASS-TCS-200005
    description Customer #6 rate limited to 2mb/sec
    match access-group name ACL-TCS-200005
    class-map match-all CLASS-TCS-205560
    description Customer #7 rate limited to 4mb/sec
    match access-group name ACL-TCS-205560
    policy-map RATE-LIMIT
    class CLASS-TCS-200005
    police 2000000 375000 750000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-200208
    police 2000000 375000 750000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-200441
    police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-200338
    police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-205679
    police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-205560
    police 4000000 750000 1500000 conform-action transmit exceed-action transmit violate-action drop
    class CLASS-TCS-205593
    police 3000000 562500 1125000 conform-action transmit exceed-action transmit violate-action drop
    Is this the correct behaviour of applying the service-policy to the interface whereby the CPU increases by 20% or can the MQC be fine tuned to have less of an impact on the CPU?
    Is the router just overloaded, taking into account it's only pushing about 400M? Should it be able to do more than this??
    Thanks.
    Andy

  • WLC user rate limit on guest ssid anchor controller

    Hi,
    I have been looking through the forums & some cisco documents but not found a good example similar to what I am seeking to do so now I am turning to the expertise of my peers.
    We have been deploying 3502 APs remotely to locations with full T1s that backhaul to where I sit at HQ.
    Both the foreign and anchor controller are here at my location.
    I am seeking to rate limit per user the bandwidth each client will get on the guest internet ssid.
    As you know this traffic is encapsulated in capwap between the AP and the controller so I cant use a standard ACL on the switch or router.
    We are trying to keep the guest internet access usage in check on the T1 at any given site so the other ssid's & local lan traffic is not overly competing for the bandwidth.
    I found the place to edit the default profiles in the controller but the documentation really isnt clear on best practices.
    So I put it to you my fellow wireless engineers to suggest how you are implementing bandwidth management on your wireless guest internet.
    Thanks guys!           
    Oh and here is my hardware & software levels.
    5508wlc - forgeign
    4402wlc - anchor
    Software Version
    7.0.230.0

    Amjad,
    Thank you for taking the time to respond as well as the document link.
    It was pretty clear on the steps and what it would impact.
    Two things that push me for a different solution (assuming their is one).
    Note The values that you configure for the per-user bandwidth contracts affect only the amount of bandwidth going downstream (from the access point to the wireless client). They do not affect the bandwidth for upstream traffic (from the client to the access point).
    As you can see from the above note taken out of the linked document the roll based rate limit doesnt really rate limit the T1 traffic any guest user consumes it only limits usage from the AP down to the client.
    #1 I am looking for a solution that limits the users up & down streams (if possible) & also before it leaves the AP for the T1.
    The idea is to limit WAN utilization.
    #2 I read in the forums here others asking about the "user role" and saw some comments saying it is not considered "best practice" to use user roles.
    Let me clarify that our guest ssid's are using the http webpage pass through for authentication and it is really only the tic mark to indicate they understand the terms and conditions of using our internet as a guest service. No actual user accounts are used on the guest ssid's.
    ***One last question about this and any other changes***
    Will any change I make be on the "Foreign, Anchor" or both Controllers?

  • Bandwidth/speed limiter java

    Hi,
    I am working on a ftp application and was wondering if anyone knows a way to determine and limit the current upload speed of a connection.
    I don't know the exact code that will be helpful but some info from my app:
    Use Socket() to connect to ftp server.
    the outputstream (os) is from socket().getOutputStream();
    byte[] buf= new byte[16384]; c = is.read();
    then I upload using os.write(buf, 0, c);
    Essentially I am looking for a method to lower the upload bandwidth consumption of my program so users can browse the internet and such simutaneously. I am hoping that there might be some function in the java packages made for this or a small method that doesn't have to doesn't hog much cpu resources. Any help would be appreciated. Thanks

    ai_77 wrote:
    Hi, Can anyone suggest a good method for determining the current upload speed used by my program. My current method basically adds the amount written after each successful os.write(x,x,x) to a seperate variable in a seperate speedWorker thread, which then each second(I tried variations as well) displays that amount and resets the count. The problem is that this has been quite inaccurate for me, reporting anywhere from 50-70% off from what I know the speed should be. It may be important to note that I have several threads and connections doing the uploading simultaneously and one speedWorker.
    P.S: ejp: I tried using the set Socket.setSendBufferSize() to various values ranging from 1- 65000 and noticed no difference in the speed. I checked if it Make it smaller like 512 or 256(Something smaller than the bytes being written). Anyways you could use the Thread.sleep(Long time) method but it should work the way ejp said. I dont know any other way of getting the download speed but if I were you I would add the number of bytes being written in 1 second and divide by the seconds. For example Download speed at the moment= #of bytes per 'x' Seconds divided by 'x' Seconds. Should work though becuase it gives you an average of bytes written per second.

  • Upstream traffic rate limit

    Hi all,
    Upstream traffic rate limit is not supported by WLC . It will be done by AP.
    We have setup of Auto anchor for both corporate and guest(but authentication mechanism is diffrent) . They wont access any internal resouce .Only interner traffic is permitted.
    So can we limit the internet traffic for guest users .? If we limiting the upstream traffic at the AP level what would be the concerns we may face?
    Kindly help on this.
    Thanks,
    Regards,
    Vijay

    Hello Vijay,
    As per your query i can suggest you the following solution-
    Please refer table 1 of the given link-
    http://www.cisco.com/en/US/products/ps10315/products_tech_note09186a0080bd3900.shtml
    Hope this will help you.

  • How to measure and limit the data volume?

    Morning.
    I need a tool to measure and limit the data volume of internet usage. My internet tariff allows a maximum of 5 GB data volume per month. Exceeds my usage that amount the bandwidth will reduce to only 64 kB/s or the exceeding data volume must be paid extraordinarily expensive.
    Do you know a tool that measures the data volume in a given time period and can alert or limit the internet connection for instance if the data volume at the half of the months has exceeded more than the half of the data volume for the entire month?
    Kind regards, vatolin

    You could generate large amount of data and then use any SNMP Viewer (BMC Dahsboard, Solarwinds, Nagios, CiscoWorks etc.) to see the throughput of the interfaces at peak. But why bother? Cisco has been commented by numerous research firms (Gartner etc.) to be very precise about their stated throughputs.
    Regards
    Farrukh

  • Rate Limit Traffic on Router

    Is it possible to limit bandwidth between two IPs using ACL or policy map. Like for example i want to limit 50% file sharing traffic coming or going to an IP 172.19.60.50

    Hello,
    You can rate limit the traffic using Traffic Policing or traffic shapping and YES you can match based on the flow of the traffic
    Looking for some Networking Assistance? 
    Contact me directly at [email protected]
    I will fix your problem ASAP.
    Cheers,
    Julio Carvajal Segura
    http://laguiadelnetworking.com

  • Possible to rate limit console input?

    I built a tool that allows us to input device information such as IP, VLAN, etc, etc and this tool builds the entire config file that can be pasted into a switch/router.  The problem is that when I start getting down near the banner and motd sections, the console cannot keep up with the input and it drops lines of input.
    Is there a way to rate limit the input when large configs are pasted into con 0?

    I built a tool that allows us to input device information such as IP, VLAN, etc, etc and this tool builds the entire config file that can be pasted into a switch/router.  The problem is that when I start getting down near the banner and motd sections, the console cannot keep up with the input and it drops lines of input.
    Is there a way to rate limit the input when large configs are pasted into con 0?

  • Best tool to reduce the network bandwidth for WEBI reports

    Hi Experts,
    We have a central BO XI server installed in Head Office. Few users are needed to connet to Head Office from their place (Regions) to access the WEBI reports.
    For this we have two options to refresh the report.
              1. BO InfoView
              2. Web Intelligence Rich Client
    My question is , which is the best way to reduce the internet bandwidth. Since my users are on remote location and doesn't have good link, which one is the best option to reduce the bandwidth consumtion.
    Regards,
    Suresh

    If you're launching Webi Rich Client in 3-tier (ZABO) mode there should be no difference from Infoview refresh, as WRC will utilize same webi report servers for refresh as Infoview does.
    If you use 2-tier mode with WRC, then refresh will be local, using local connection to the reporting DB.
    I'd say Infoview will be less bandwith intensive and you will be sending only structured and prepared data tot he client browser, not the rough data report needs.
    To further decrease bandwith, you can design your server infrastructure to have regional processing, that way most communicatyions with be local and requests go to central location only for main data...

  • RATE limit RATE limit RATE limit RATE limit

    Dear,
    I have tried using RADIUS server to apply rate-limit to my ADSL coustomers using :
    rate-limit output access-group 101 1024000 6000 512000 conform-action transmit exceed-action drop
    i applied this at raduis server at my output interface but i does not work.
    there is no output for sh interface rate limit.
    the configuration and settings for rate limit are applied at raduis server....ok
    when i do sh interface rate limit on router....i dont have any results.
    i have configured (VPDN interface-Virtual and interface-access ) for my ADSL coustomers.
    i need to make bills for this customrs.
    please if the points not clear let me know

    Try this configuration in your interface , or write the access list depend upon your requirement and implement it.
    access-list 152 permit tcp any host eq www
    access-list 153 permit tcp any host eq www established
    interface {int}
    rate-limit output access-group 153 1024000 6000 512000
    conform-action transmit exceed-action drop
    rate-limit output access-group 152 1024000 6000 512000
    conform-action transmit exceed-action drop
    finally verifies this configuration through the following commands.
    show access-lists rate-limit
    Displays information about rate-limit access lists.
    show interfaces rate-limit
    Displays information about CAR for a specified interface

  • Monitoring Internet Bandwidth Utilization

    Dear Net Pros,
    I am looking for some software which can help me monitor Internet Bandwidth Utilization in more details. Currently I am already using MRTG to monitor the Internet Bandwidth. Need something deeper than that. Can anyone suggest a suitable solution for the same??
    Rushabh

    Buying it I think.
    Sorry, its a joke.
    You can try download a Demo on CCO Software Library.
    Well, happy new year and good luck.

Maybe you are looking for