Replace plsql batch interface with BPEL?

I have an existing batch-oriented interface that calls an asp webservice from within a database package. The webservice returns an XML-file that is processed within the stored procedure that calls the service.
Would it be possible to initiate a BPEL proces from within a stored procedure to retrieve the XML file from the webservice? Currently the webservice is called using the UTL_HTTP package.
Any suggestions would be appreciated.
Regards, Rob

BPEL Process is nothing but a service. So you should be able to call it.

Similar Messages

  • BPEL's ability to interface with tools

    Please describe BPEL's ability to interface with the following tools
    Microsoft Outlook
    Microsoft Exchange
    Microsoft Project
    Active Directory (security integration)
    SOX Express
    IBM Websphere Datastage
    IBM Websphere Metastage

    Aruna,
    could you elaborate a little bit on the usecase pls, you mix here client tools, such as outlook, with servers (such as exchange)
    so, for now, here is a shot on 2 products ..
    1) Exchange - we can use it as email server
    2) Active Directory (security integration) - we can have the Human workflow, and the bpel security integrating with it
    besides, check out iWayAdapters that we can leverage directly to connect natively to systems, but in your case I am still not sure, how the integration w(s)ould look like
    thx clemens

  • NAT on sub-interface with no internet access

    Good morning,
    Please I have a router 2901, which I configured tow sub-interfaces for Voice and Data. Everything seems to be working fine but I can't access the internet after configuring NAT.
    Config below
    Router1#sh config
    Using 5392 out of 262136 bytes
    ! No configuration change since last restart
    ! NVRAM config last updated at 16:15:07 UTC Wed Jul 2 2014 by aadmin
    ! NVRAM config last updated at 16:15:07 UTC Wed Jul 2 2014 by aadmin
    version 15.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname A
    boot-start-marker
    boot-end-marker
    ! card type command needed for slot/vwic-slot 0/0
    logging buffered 51200 warnings
    enable secret 4 U3/EVMmZsx9ys3vbB8aDhHy.5h4qh2V8/DkTGNsxvTA
    enable password 7 06150E2C5F5B071E
    aaa new-model
    aaa authentication login default local
    aaa session-id common
    memory-size iomem 25
    ip cef
    ip dhcp excluded-address 10.10.36.1 10.10.36.25
    ip dhcp excluded-address 10.10.36.200 10.10.36.254
    ip dhcp pool DATA
     network 10.10.36.0 255.255.255.0
     default-router 10.10.36.1
     dns-server 8.8.8.8 4.2.2.2
    ip dhcp pool VOICE
     network 10.1.1.0 255.255.255.0
     default-router 10.1.1.1
     option 150 ip 10.10.36.4
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-3112445314
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-3112445314
     revocation-check none
     rsakeypair TP-self-signed-3112445314
    crypto pki certificate chain TP-self-signed-3112445314
     certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
    voice-card 0
    license udi pid CISCO2901/K9 sn FCZ1808C4L8
    hw-module pvdm 0/0
    username a password 7 1416111F05557C
    username e privilege 15 password 7 1437455E0E2A25382525260B67
    username c password 7 030B580E0701284F165B5C
    username a password 7 01000709481E0808
    redundancy
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address #.#.#.58 255.255.255.248
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
     no keepalive
    interface GigabitEthernet0/1
     no ip address
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
     no keepalive
    interface GigabitEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 10.10.36.1 255.255.255.0
     ip verify unicast reverse-path
     ip nat inside
     ip virtual-reassembly in
    interface GigabitEthernet0/1.100
     encapsulation dot1Q 100
     ip address 10.1.1.1 255.255.255.0
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source list LAN_NAT_POLICY interface GigabitEthernet0/1.1 ov
    ip route 0.0.0.0 0.0.0.0 #.#.#.57
    ip access-list extended LAN_NAT_POLICY
     permit ip 10.0.0.0 0.255.255.255 any
    access-list 23 permit 10.10.36.0 0.0.0.255
    access-list 23 permit 10.10.0.0 0.0.0.255
    access-list 23 permit 10.10.0.0 0.0.255.255
    access-list 101 permit tcp 10.10.36.0 0.0.0.255 host 10.10.36.1 eq telnet
    control-plane
    mgcp profile default
    gatekeeper
     shutdown
    banner exec ^C
    % Password expiration warning.
    Cisco Configuration Professional (Cisco CP) is installed on this device
    and it provides the default username "cisco" for  one-time use. If you hav
    already used the username "cisco" to login to the router and your IOS imag
    supports the "one-time" user option, then this username has already expire
    You will not be able to login to the router with this username after you e
    this session.
    It is strongly suggested that you create a new username with a privilege l
    of 15 using the following command.
    username <myuser> privilege 15 secret 0 <mypassword>
    Replace <myuser> and <mypassword> with the username and password you want
    use.
    ^C
    banner login ^C
    Cisco Configuration Professional (Cisco CP) is installed on this device.
    This feature requires the one-time use of the username "cisco" with the
    password "cisco". These default credentials have a privilege level of 15.
    YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
    CREDENTIALS
    Here are the Cisco IOS commands.
    username <myuser>  privilege 15 secret 0 <mypassword>
    no username cisco
    Replace <myuser> and <mypassword> with the username and password you want
    to use.
    IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
    TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
    For more information about Cisco CP please follow the instructions in the
    QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
    ^C
    line con 0
     password 7 13041406025D52
    line aux 0
     exec-timeout 0 1
     no exec
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     access-class 23 in
     privilege level 15
     password 7 094D4D1D105441
     transport input telnet ssh
    line vty 5 15
     access-class 23 in
     privilege level 15
     transport input telnet ssh
    scheduler allocate 20000 1000
    ntp master
    ntp server 10.10.36.1
    end
    Please I need a quick response
    Thank you.

    Can you change the interface to outside interface in this command
    ip nat inside source list LAN_NAT_POLICY interface GigabitEthernet0/1.1 ov
    can you try this below command
    ip nat inside source list LAN_NAT_POLICY interface GigabitEthernet0/0 ov
    Regards
    PrajithTR

  • Batch Reading with Custom SQL

    Hello,
    Queries
    1. Is it possible to use Batch Reading in conjunction with Custom Stored Procs/ SQL?
    2. Is it possible to map an attribute to a SQL expression (like in Hibernate we have formula columns mapped using the formula* property)?
    Background
    1. We use Toplink 11g (11.1.1.0.1) (not EclipseLink) in our application and are controlling mapping using XML files (not annotations).
    2. We are migrating a legacy application with most of its data retreival logic present in stored procedures to Java.
    3. I am effectively a newbie to Toplink.
    Scenario
    1. We have a deep class heirarchy with ClassA+ at the following having a one-to-many relation with ClassB+ and ClassB+ having a one-to-many relation with ClassC+ and so on and so forth.
    2. For each of these classes the data retreival logic is present in stored procedures (coming from the legacy application) containing not so simple queries.
    3. Also there are a quite a few attributes that actually represent computed values (computed and returned from the stored procedure). Also the logic for computing the values are not simple either.
    4. So to make things easy we configured toplink to use the stored procedures to retreive data for objects of ClassA+, ClassB+ and ClassC+.
    5. But since the class heirarchy was deep, we ended up firing too many stored procedure calls to the database.
    6. We thought we could use the Batch Reading feature to help with this, but I have come across documentation that says that it wont work if you override toplink's queries with stored procedures.
    7. I wrote some sample code to determine this and for the heirarchy shown above it uses the speicifed Custom procedure (I also tried replacing the stored procs with custom SQL, but the behavior is the same) for ClassA+ and ClassB+, but for ClassC+ and below it resorts to its own generated SQL.
    8. This is a problem because the generated SQL contains the names of the computed columns which is not present in the underlying source tables.
    Thanks
    Arvind

    Batch reading is not supported with custom SQL or stored procedures.
    Join fetching is though, so you may wish to investigate that (you need to ensure you return the correct data from the stored procedure).
    James : http://www.eclipselink.org

  • Batch Editing with Photoshop Elements 4.0

    I have an folder of photos which I would like to resize as a batch with Photoshop Elements 4.0. However, I am at a loss as to how to do it and am missing a step or two in my workflow.
    I would appreciate any specific step by step suggestion that you may have.
    Thanks for your help.
    Vernon

    not for "batch editing"
    You can set PSE as the external editor in the iPhoto preferences. iPhoto has the capability to directly interface with any external editor - simply go to the iPhoto preferences (iPhoto menu ==> preferences ==> General and set the Edit photo option to in external editor - select the desired external editor and you are set - now when you edit photos they are sent to the selected external editor and when you are finished editing you save (not save as) and the edited photo is returned to iPhoto, the original is maintained in iPhoto and the iPhoto database is correctly updated.
    If you want the option of editing in either iPhoto or the external editor after selecting your external editor simply set the edit in back to main window - now when you right click (control Click) on a photo you will get a menu which allows you to select either.
    LN

  • Business Catalog updated with BPEL refs, not with BPMN refs

    When adding BPEL processes to the SCA component you see the Business catalog modules "References" and "Services" are updated. However, when adding BPMN processes the Business catalog is not updated (and btw you cannot check "Expose as an web service" when creating a BPMN process like you can with BPEL processes). In my opinion the current solution seems incomplete: viewing the "Exposed services" lane of my composite.xml I should expect all of them in the Business Catalog, not only the BPEL ones. It seems Oracle's work behind the Business Catalog component has not finished yet or is there some logic behind this behaviour?
    I am working with version 11.1.1.6
    Edited by: GSmink on Jul 9, 2012 5:12 AM
    corrected spelling errors

    Dan,
    No I did not use Reusable or Manual processes, I use processes (asyn) with a Message Start event, and yes, I see them nicely in the Composite's Exposed Services and the wsdl's in the project's SOA Content folder. But my 'concern' is why the Business Catalog (BC) is not populated with BPMN processes like it is with BPEL processes. In the "Services" module of the BC I see the submodule BPEL with my BPEL processes so I had expected a submodule BPMN with my BPMN processes. From a business perspective I certainly would also see my business processes in the BC, so for me it seems 'unbalanced'
    (I ran against this issue when using correlation:
    In the process receiving an 'in flight' message I defined a Message catch event step in where I defined in the box "Message Exchange" Type :"Define Interface". Then building the process that throws the message to the in-flight process instance I defined the Message Throw event step and in that step I had expected to be able to use the Message Exchange Type "Use Interface" but that was not possible because I could only select BPEL services.
    I solved this by selecting "Process call" in stead of "Use Interface".)

  • Difficulties replacing some BC functionality with XI (refer to example)

    <b>Difficulties replacing some BC functionality with XI (refer to example)</b>
    I am transferring all interface processing from BC to XI and am having difficulties replacing some of the current BC functionality.  Please refer to my example below
    <b>Current process</b>
    <b>SAP R/3</b>
    SAP R/3 executes an abap that extracts certain data.  This data is passed via a remote function which is configured to point to Business Connector
    <b>Business Connector</b>
    Business Connector takes control and the relevant package does some internal processing then calls the remote enabled function BAPI_ACC_BILLING_POST
    <b>SAP R/3</b>
    Control is returned to SAP R/3 to post the data and on completion control is returned to Business Connector
    <b>Business Connector</b>
    Business Connector again takes control where some more processing is done to generate an xml version of the data prior to returning control back to SAP R/3
    <b>SAP R/3</b>
    Control is returned to the abap immediately following the call to the remote function and processing completes
    The initial synchronous call from SAP R/3 to Business Connector remains open whilst Business Connector executes a subsequent synchronous call to SAP R/3.
    Finally the initial synchronous call in SAP R/3 completes
    <b>Proposed Process</b>
    I am transferring all interface processing from BC to XI and am having difficulties replacing some of the current BC functionality.  In this instance I can set up the initial synchronous call via an XI Integration Process (sync/async bridge).  This allows me to perform subsequent asynchronous calls prior to closing the synchronous bridge
    I have successfully performed synchronous calls to SAP R/3 from XI for different scenarios and have set up the XI design and config in the same manner
    When I try to perform the synchronous posting back to SAP R/3 from within the SA bridge I get the message ‘Message is incomplete. No Sender found’
    Unlike BC, it appears that XI does not allow me to perform the synchronous posting back to SAP R/3 from within the SA bridge.
    <b>Refer to</b> http://help.sap.com/saphelp_nw04/helpdata/en/83/d2a84028c9e469e10000000a1550b0/frameset.htm <b>for the SAP description</b> To enable the communication between a synchronously calling business system (synchronous outbound interface) and an asynchronously called business system (asynchronous inbound and outbound interface), you can define a sync/async bridge in an integration process. You can only define one sync/async bridge for each integration process.
    How can I replace the current BC functionality using XI?
    Regards,
    Mike

    Hi all,
    I cannot replicate the current BC functionality in XI
    So I will take this opportunity to simplify and improve the design for XI --> R/3
    Regards,
    Mike

  • Scanning interface with epaon printer

    I have a WF-7520 & WF-4530 & WF-3640 All-in-One Printers. I had been using the WF-4530 for scanning using Adobe Acrobat X, version 10.1.12. The combination of Adobe and WF-4530 worked perfectly for several years. Then the WF-4530 started profusely leaking yellow ink (a product defect) and I replaced it with the WF-3640. The WF-3640 and the WF-4530 does not interface with adobe like the WF-4530 did. A lot of the interface is greyed out and I get the message "WIA Scanner Driver might face problems using 'Hide Scanner's Native Interface' mode. Switching to 'Show Scanner's Native Interface' mode.
    I have searched through the manual, when on line and to youtube and can't find information on how to fix the interface problem. Can you help me?

    How could anyone "Be Well" with  your response/solution? Acrobat does not scan? Well that's obvious. But something is really screwed up  here and I also have this same stupid problem. And for  well over a decade I've used various versions of Acrobat  on numerous scanners and printers, and there are basic requirements set for communicating scanning and printing for both Acrobat and scanners and printers. Are you telling  this person that Adobe software has no responsibility to recognize scanner or printer interfaces  either with a USB or wireless? This whole interface issue should be a no-brainer and apparently Adobe is the problem!
    Ed Horgan (see my problem)

  • Multiple IP's on a single interface with Gateway config

    I have exasperated myself trying to figure this out!! I have setup multiple IP's on a mac mini server using USB ethernet. Everything works as it should and it's fairly snappy with the new mini.
    The problem is when I try to enable NAT, DHCP, etc., for the private network. It locks up and the server quits responding. If i turn off NAT, DHCP, everything goes back to normal. I used the gateway configuration wizard and it still didn't work. I'm thinking it has to do with DNS but can't figure out how. I am using the mini as a FQDN for my domain. Any ideas?

    Thanks Gordon for the info. I don't intend to use OD since I hope to replace the 3 servers with 1 mac mini server. I basically want to setup authoritative DNS, Mail, a PostgreSQL db, and maybe some of the new collaborative servers Apple just came out with. I basically want 1 server to appear as 3.
    I assume then that the first interface will be used unless I specify the IP to listen in the service itself. If my assumption is wrong, please let me know.

  • Swift Net MT-103 Interface with SAP

    Hello all,
    I am having a hard time to understand the concept and reason to use the Swiftnet MT103 (Outgoing Payment).
    1)At what point I will consider MT103 solution versus EDI820 (Outgoing Payment)?
    2)What will be the considerations I need to take place when I am creating the Functional Design of this interface with SAP?
    3)What will be the steps I need to take on the config side?
    4)Do I need to setup inbound interface as well for confirmation once I sent the MT103 file?
    5)DME will be only solution that produce this format?
    6)Please provide me the File structure of MT103?
    I would appreciate your prompt response since I need to represent this to the client.
    Thanks

    Hi
    It is a good practice to know the status of payment file rather than waiting for the bank to call. Yes, if need be, you will need to create an inbound interface.
    Many things would depend on the method of communcation with banks you choose (i.e. direct connection or value added network), which needs to be secure and encrypted. SWIFTnet is a product that SWIFT offers to allow companies to build a single connection to SWIFT net and connect to thousands of banks around the globe. I am not sure whether this is a valid scenario for your project. Obviously, there is a cost implication attached to it.
    If you are using BCM module, you would need to use a format created in Payment media workbench for MT103 and PI to faciliate the file mapping, conversion, encryption and secure transmission to your bank. In this case, you would build an inbound interface for Status/Confirmation from bank into BCM for Batch monitor.
    while if you are not using BCM module, you would map IDOC to MT103. in this case, you would build an Inbound Interface to manage the confirmation message from bank. I have worked on this sort of interface development and developed a report output for users to run.
    Hope that this helps
    taro

  • ADF Integration with BPEL

    Hello,
    I am new to BPEL. I am working on a sample .
    I am working on ADF Integration with BPEL process.
    I have an ADF Screen displaying data from an EMPLOYEE table in HR Schema . It has a button called "Update". I need to call a synchronous BPEL process on click of "Update" . This BPEL process will take the selected employee information as an XML input and update the last name to the first name as the response.
    I have some doubts in that :
    1. How to pass an XML Schema as input parameter to a BPEL process ? Can you please let me know some sample applications ?
    2. I am creating a web proxy for the BPEL WSDL (created above) and my "Update" button is binded to a method which is calling the BPEL process.
    How can i pass my XML input as the argument of the method to invoke the BPEL process ?
    Thanks
    Nutan

    When using a web service proxy, you need to pass the data as an object, which' structure is defined in the web service proxy wrapper classes.
    When you've defined a data control for your bpel process, you can just drag and drop the 'initiate'/'execute', your operation and bind this to the update-button.
    When working with the proxy client, you need to populate your java class objects with the employee-object, this can be done in a backing bean or managed bean in your adf faces application.
    For more information you can always have a look at my blog where I've provided an explanation about the different possibilities of interfacing adf with SOA.
    Kind regards,
    Nathalie

  • Interface with oracle system

    Dear all,
                 I am working on asset tracking process for telecommunication sector.
    here they are maintaining rt now all there equipment data in some CRAMER system basically oracle based system but they are not having any asset tracking system in this.
    My solution for them is creating equipment-asset sync....so that whenever asset is created system will create equip and vice versa...but i hav 2 concerns here:
    1. Can we do many equipment to one asset integration....as this is requirement here....and if we can den how we will handle change in master data wether in equip or asset.
    2. I can't obslete their CRAMER system cause they are having other activities to it also.
        So, I need to make interface with CRAMER that whenever any equoipment is created in the CRAMER parlaely in SAP equipment master data should be created and also asset and vice versa.......
    plz suggest how wud i handle this.....
    thanks in advance
    RManchanda

    Its common to make one or other of the systems the master system, and the other the slave.
    This ensures that the data is created/changed in one system only with a one-way interface.
    Depending how you create the interface, it can be real-time(single record) , or batch (multiple records)
    PeteA

  • Plsql code called frm bpel taking 5 mins and bpel instance is not creating.

    Hello All,
    I am calling a plsql procedure from the bpel using db adapter.
    The procedure is bit complex and taking around 5 mins to finish and before bpel receive any responce, its session is getting timed out and cannot see any instance created in bpel dashboard.
    How to configure the bpel to wait for more than 5 mins before getting response from the partner link.
    Thanks
    Saikrishna

    So are you creating the instance from polling the DB adapter??? if so I found a (IMO) better way. 1 instead of DB polling if this is infrequent use a transactional trigger this trigger will first get the information from your PL/SQL call then raise the bpel event with the information in the call. this way bpel has everything it needs at the beginning of the process. Or if you are looking for something more periodic use a materialized view instead of a PL/SQL call this view could have your PL/SQL in it....
    --Bryan Colligan                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

  • How to replace iphone 5s contacts with imac (10.6.8) contacts

    need to totally replace contacts in the iPhone 5s with the contacts in Apple Mail Address Book on an iMac running OS 10.6.8 (Snow Leopard) with latest version of iTunes.  I know there must be a way to do this, but have been unable to figure it out so far.  This is my first smartphone and it's only 3 weeks old.  IT person at work set my email up, but I want the contacts to be the ones from my home computer.  A merge or sync would produce the wrong desired results, so I need to completely replace the iPhone contacts.

    Correct.  To use an iPhone5 with iTunes you must use iTunes 10.7.  To use iTunes 10.7 you absolutely must be running at least OSX 10.6.8.
    We use an iPhone without iTunes but the main thing we do not do is sync.  We do not have an music or movies on the phone, though you could as long as you did all the interfacing with iCloud.  We back up our modest (<5GB) collection of things to iCloud.  You can use Image capture or iPhoto to transfer photos and movies you take with the phone to a computer.

  • Do I have to Replace Every Word doc with a New Pages doc?

    Everytime I open an old Word document (I now use Pages exclusively) in Pages, I have to re-save the document as a Pages document. The old Word file stays on my computer, as I'm creating something new, a Pages document. I now am left with two files: the old Word file, and the new Pages file. Is there some sort of "batch" operation, a way to convert ALL my word files on my HD into Pages files?
    Or (more realistically) is there a way to have Pages automatically REPLACE the Word file with the new Pages file, so that I'm left with 1 new file, not 1 old and 1 new.
    Thanks a lot,
    Lee

    The difference between the two files is that one's extension is .doc and the other's is .pages. So, for the Pages document to replace the Word document, it's name would need to be "Testdoc.doc" instead of "Testdoc.pages" as it would normally save. This may cause problems in the future since .doc isn't a Pages document, so that wouldn't be something you'd want to do for documents you intend to keep.
    It seems that Automator would be a good choice for this, but I don't know enough about Automator to be able to say if it can be done or how to do it.

Maybe you are looking for

  • ID3 Tags won't write to file

    I recently received a disc from a friend, the disc had 16 songs on it, with no ID3 Tag info. I went through and added the missing info manually using the "Get Info" option from the file in iTunes & hit OK, but when I was done, the files look complete

  • How can i insert a heart shape into keynote

    Hi I am new to IMAC and want to insert a heart shape into Keynote so I can colour code it and write text inside - can someone help please -I've tried the drawing tool but no success!! thanks

  • Cisco Prime Infrastructure 1.4 SNMP Traps are not converted into Alarms

    Hi everybody, I just configured SNMP Traps on a Cisco Catalyst 3750-x to send to our Cisco Prime Infrastructure 1.4 Appliance. Now I forced the Switch to send some traps (Power off a Power Supply, Interface errdisable). The only events I see in Alarm

  • External Web Access Management - Juniper

    Hello Experts, We are planning to implement external authentication mechanism, when a user logs on from Internet, he comes through an external system (juniper), that authenticates the user through LDAP. This user credentials should be matched against

  • Oracle bat scripts on windows log file generation

    I want to generate logfile/recording of this .bat file, msglog file is not generating any thing , any idea or any other suggestion how i can generate logfile ? like we can do in crotab scropt>> script.log etc set ORACLE_HOME=c:\oracle\10 set ORACLE_S