RTMFP group neighbor

A few questions about who is considered a "neighbor" in an RTMFP group:
Suppose I am the first person to connect to an RTMFP group. Will my NetStatusEvent handler be called every time a new person connects to the NetGroup (with its info.code property set to "NetGroup.Neighbor.Connect")? For example, if 1,000 people connect after me from all over the world, will I be notified about all of them?
Suppose I am the last person to connect to an RTMFP group that already has 1,000 people. Will my  NetStatusEvent handler immediately be called 1,000 times (with its info.code property set to  "NetGroup.Neighbor.Connect")?
What if one person leaves the group, either by explicitly closing the NetConnection or by closing his browser. Will all 1,000 people be notified that he left?

for some background/technical information about what an RTMFP group really is, please watch Matthew Kaufman's presentation from MAX 2009:
   http://tv.adobe.com/watch/max-2009-develop/p2p-on-the-flash-platform-with-rtmfp/

Similar Messages

  • Change rtmfp groupspec with javascript

    hello
    is it possible to change dynamically the groupspec and play the new rtmfp group?
    test code
      var parameters =
                            {       src: "rtmfp://p2p.rtmfp.com/2924a8afa44eaff4aac318fe5b39248d277688d663c6dfb422e6e9663967d39b/"
                            ,       autoPlay: true
                            ,       groupspec: "G:0101010c040e6f747200"
                            ,       multicastStreamName: "stream"
                            ,       streamType: "live"
                            ,       streamName: "stream"
                            ,       controlBarAutoHide: false
                            ,   javascriptCallbackFunction: "onJavaScriptBridgeCreated"
                    // Embed the player SWF:
                    swfobject.embedSWF
                            ( "StrobeMediaPlayback.swf"
                            , "strobeMediaPlayback"
                            , 640
                            , 480
                            , "10.1.0"
                            , parameters
                            , { allowFullScreen: "true"}
                            , { name: "strobeMediaPlayback" }
    var player = null;
                    function onJavaScriptBridgeCreated(playerId)
                            if (player == null) {
                                    player = document.getElementById(playerId);
                                    document.getElementById("newchannelgroup").onclick = function(){
                                                   //HERE SET NEW groupspec and play the rtmfp
                                                    player.play2();

    hello maybe other have same problem i found a simple solution for me
    use the javascript bridge and juse the f4m manifest files
    function changeSrc(playerdivId,src){
                var player = document.getElementById(playerdivId);
                player.setMediaResourceURL(src);
    src multicast fm4 manifest like this
    http://sourceforge.net/apps/mediawiki/osmf.adobe/index.php?title=Flash_Media_Manifest_(F4M )_File_Format
    best regards

  • RF groups

    Possibly a simple question but we have 15 WLC's running 7.0.230, WCS running 7.0.250.  RF groups are all set to auto, but we have usually 12 RF groups when I look at RRM in WCS.  The sites are separated geographically, so should I set the groups for leaders and members for same building?  This seems like it would make sense, then you get into how the APs build off of neighbors for RRM and in that respect it seems like it should not even matter...I have tried very unsuccessfully to research it, cant find much though.
    Thanks!!

    "RF Groups are groups of controllers that share the same RF group name and who’s APs can hear the neighbor messages of each other. "
    I have a similar situation where my controllers are supporting APs that are deployed in different locations throughout the country.  It does not make sense to me to enable RF Grouping if, as an example, controller A has no influence over any of the APs on controller B.
    "The APs use neighbor messages (sent every 60 seconds) that are authenticated by other APs that hear them. The neighbor messages include information about the AP, the controller, and the configured RF group name."
    By turning off RF Grouping, thus disabling RF Group neighbor messages, will this provide better throughput?
    Through my research, the only viable piece of information I found was this statement:
    "If the APs on one controller will not be able to hear the APs on another controller, it is not practical to configure the controllers with the same RF group name."
    Also found this in the Cisco WLC Configuration Guide:
    "If you disable it, the controller does not participate in automatic RF grouping; instead it optimizes the access points connected directly to it."
    Thank you in advance for your time and help!

  • Group Video Chat

    I am yet to find a good tutorial or example code on how to implement a group video chatting application.  Is it possible to use RTMFP Groups to launch multiple chat windows without using point-to-point connections?  If I'm attempting to use RTMFP Groups then should I use DIRECT_CONNECTIONS or not?  I have looked over the Video Phone Sample Application but it is a 2 way communication model and I'm interested in group video chats.
    Any help, resources or advice would be greatly appreciated!  Thanks in advance.

    I would also like to know, how do you get all peerIDs for everyone who is a member of a group.  To link up video, do you have to h
    ave the explicit peerID of the user from which to pull the camera feed?  Is there a way to iterate through all users in a group and pull the camera feed?

  • Dose RTMFP able to publish existing video file?

    Hope someone can answer me.
    Already Google but no luck.
    I know that in AS3,
    netstream.attachAudio( _mic ) can publish microphone,
    netstream.attachCamera( _cam ) can publish camera,
    but if that are something method such as: netstream.attach("http://xxx.com/xxx.flv") to publish videos on rtmfp group?

    HI Captiware,
    When you insert a swf, which was created from Captivate, as animation into Captivate and publish => the swfs are kept external. This is by design.
    Manish
    http://blogs.adobe.com/captivate

  • Connection Limits

    Hi,
    I was searching online for limit on the service and there are multiple different version on the answer accross 2 years of posting.
    Is there a maximum number of concurrent connection on a single account?
    Is there a maximum number of groups?
    My application use voice-chat in p2p. Is there any kind of limitation I should know before launching public?
    I am creating a "prototype" project, but it might "boom" because of its originality.
    If there is a limit, can I remove it by asking Adobe? (I am asking right now)
    Thanks!
    ps: I do not have any servers, nor FMS, and I a not planning on using cummulus for the same (server) reason.
    jpauclair

    the 16 limit is per user/client/connection to the server, not per developer key.  if each user is in one group, then it doesn't matter if you have one group with a thousand members or a thousand different groups each with one member.
    RTMFP Groups are self-organizing (via gossip), but a new joiner to a group needs to find out about at least one other member of the group to become connected. Cirrus tells new group joiners (via the "server channel") about a few other members already in the group to get them started. that's the "bootstrap" operation.  Cirrus will track up to 16 concurrent groups per client connection.  Cirrus will close the server channel for the 17th or later concurrent group for any one user/client connection.  closing the server channel has no effect on whether the client is in the group, but the bootstrap operation won't be performed so the client won't be joined to the other members of the group automatically by Cirrus.

  • BGP route-reflector next-hop issue

    Hello,
    I have a small GNS3 lab that is working with one exception: I cannot ping loopback0 on RRc2 and RRc3 from RRc1.
    RRc1, RRc2 and RRc3 can all ping loopback0 on SmileyISP and RRc2 and RRc3 can ping each others loopback0
    interfaces.
    I am broken between the two route-reflectors: RRS1 and RRS2.
    Given these conditions:
    1) Do not configure any IGP.
    2) No static routes
    How do I get connectivity from RRc1's loopback0 interface to RRc2 loopback0 and RRc3 loopback0?
    I used a route-map to set the next hop, but I am obviously doing something wrong.
    I am providing relevant show command outputs, router configs, and the GNS3 topology.net config.
    You will have to change the image and working directories to match your computer.
    Not quite sure where I am going wrong.
    Any help would be greatly appreciated.
    Thanks.
    -- Mark
    RRc1#sh ip bgp
    BGP table version is 53, local router ID is 172.16.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
                  x best-external, a additional-path, c RIB-compressed,
    Origin codes: i - IGP, e - EGP, ? - incomplete
    RPKI validation codes: V valid, I invalid, N Not found
         Network          Next Hop            Metric LocPrf Weight Path
     *>i 1.1.1.0/24       10.1.25.5                0    100      0 100 i
     *>i 10.1.12.0/24     10.1.26.2                0    100      0 i
     *>i 10.1.13.0/24     10.1.12.1                0    100      0 i
     *>i 10.1.14.0/24     10.1.12.1                0    100      0 i
     *>i 10.1.15.0/24     10.1.12.1                0    100      0 i
     *>i 10.1.25.0/24     10.1.26.2                0    100      0 i
     * i 10.1.26.0/24     10.1.26.2                0    100      0 i
     *>                   0.0.0.0                  0         32768 i
     *>  172.16.1.0/24    0.0.0.0                  0         32768 i
     *>i 172.16.2.0/24    10.1.12.1                0    100      0 i
     *>i 172.16.3.0/24    10.1.12.1                0    100      0 i
    RRc1#
    RRc1#ping 172.16.2.1 so lo0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
    Packet sent with a source address of 172.16.1.1
    Success rate is 0 percent (0/5)
    RRc1#
    RRc2#sh ip bgp
    BGP table version is 31, local router ID is 172.16.2.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
                  x best-external, a additional-path, c RIB-compressed,
    Origin codes: i - IGP, e - EGP, ? - incomplete
    RPKI validation codes: V valid, I invalid, N Not found
         Network          Next Hop            Metric LocPrf Weight Path
     *>i 1.1.1.0/24       10.1.15.5                0    100      0 100 i
     * i 10.1.12.0/24     10.1.12.2                0    100      0 i
     * i 10.1.13.0/24     10.1.13.1                0    100      0 i
     *>                   0.0.0.0                  0         32768 i
     *>i 10.1.14.0/24     10.1.13.1                0    100      0 i
     *>i 10.1.15.0/24     10.1.13.1                0    100      0 i
     * i 10.1.25.0/24     10.1.12.2                0    100      0 i
     * i 10.1.26.0/24     10.1.12.2                0    100      0 i
     * i 172.16.1.0/24    10.1.12.2                0    100      0 i
     *>  172.16.2.0/24    0.0.0.0                  0         32768 i
     *>i 172.16.3.0/24    10.1.14.4                0    100      0 i
    RRc2#
    SmileyISP#sh run
    Building configuration...
    Current configuration : 988 bytes
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname SmileyISP
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface Loopback0
     ip address 1.1.1.1 255.255.255.0
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.15.5 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     ip address 10.1.25.5 255.255.255.0
     speed auto
     duplex auto
    router bgp 100
     bgp log-neighbor-changes
     network 1.1.1.0 mask 255.255.255.0
     network 10.1.15.0 mask 255.255.255.0
     neighbor 10.1.15.1 remote-as 200
     neighbor 10.1.25.2 remote-as 200
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    RRS1#sh run
    Building configuration...
    Current configuration : 1594 bytes
    ! Last configuration change at 19:24:34 UTC Sat Feb 7 2015
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname RRS1
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.15.1 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     ip address 10.1.12.1 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet2/0
     ip address 10.1.13.1 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet2/1
     ip address 10.1.14.1 255.255.255.0
     speed auto
     duplex auto
    router bgp 200
     bgp log-neighbor-changes
     network 10.1.13.0 mask 255.255.255.0
     network 10.1.14.0 mask 255.255.255.0
     network 10.1.15.0 mask 255.255.255.0
     neighbor RouteReflectors peer-group
     neighbor RouteReflectors remote-as 200
     neighbor RouteReflectors route-map NEXTHOP out
     neighbor RRClients peer-group
     neighbor RRClients remote-as 200
     neighbor RRClients route-reflector-client
     neighbor 10.1.12.2 peer-group RouteReflectors
     neighbor 10.1.13.3 peer-group RRClients
     neighbor 10.1.14.4 peer-group RRClients
     neighbor 10.1.15.5 remote-as 100
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    route-map NEXTHOP permit 10
     set ip next-hop peer-address
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    RRS2#sh ru
    Building configuration...
    Current configuration : 1542 bytes
    ! Last configuration change at 19:42:06 UTC Sat Feb 7 2015
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname RRS2
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.12.2 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     ip address 10.1.25.2 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet2/0
     ip address 10.1.26.2 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet2/1
     no ip address
     shutdown
     speed auto
     duplex auto
    router bgp 200
     bgp log-neighbor-changes
     network 10.1.12.0 mask 255.255.255.0
     network 10.1.25.0 mask 255.255.255.0
     network 10.1.26.0 mask 255.255.255.0
     neighbor RouteReflectors peer-group
     neighbor RouteReflectors remote-as 200
     neighbor RouteReflectors route-map NEXTHOP out
     neighbor RRClients peer-group
     neighbor RRClients remote-as 200
     neighbor RRClients route-reflector-client
     neighbor 10.1.12.1 peer-group RouteReflectors
     neighbor 10.1.25.5 remote-as 100
     neighbor 10.1.26.6 peer-group RRClients
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    route-map NEXTHOP permit 10
     set ip next-hop peer-address
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    RRc1#sh run
    Building configuration...
    Current configuration : 1005 bytes
    ! Last configuration change at 18:43:57 UTC Sat Feb 7 2015
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname RRc1
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface Loopback0
     ip address 172.16.1.1 255.255.255.0
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.26.6 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     no ip address
     shutdown
     speed auto
     duplex auto
    router bgp 200
     bgp log-neighbor-changes
     network 10.1.26.0 mask 255.255.255.0
     network 172.16.1.0 mask 255.255.255.0
     neighbor 10.1.26.2 remote-as 200
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    RRc2#sh run
    Building configuration...
    Current configuration : 1005 bytes
    ! Last configuration change at 18:45:05 UTC Sat Feb 7 2015
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname RRc2
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface Loopback0
     ip address 172.16.2.1 255.255.255.0
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.13.3 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     no ip address
     shutdown
     speed auto
     duplex auto
    router bgp 200
     bgp log-neighbor-changes
     network 10.1.13.0 mask 255.255.255.0
     network 172.16.2.0 mask 255.255.255.0
     neighbor 10.1.13.1 remote-as 200
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    RRc3#wr term
    Building configuration...
    Current configuration : 1005 bytes
    ! Last configuration change at 18:31:12 UTC Sat Feb 7 2015
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    hostname RRc3
    boot-start-marker
    boot-end-marker
    no aaa new-model
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    interface Loopback0
     ip address 172.16.3.1 255.255.255.0
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex half
    interface FastEthernet1/0
     ip address 10.1.14.4 255.255.255.0
     speed auto
     duplex auto
    interface FastEthernet1/1
     no ip address
     shutdown
     speed auto
     duplex auto
    router bgp 200
     bgp log-neighbor-changes
     network 10.1.14.0 mask 255.255.255.0
     network 172.16.3.0 mask 255.255.255.0
     neighbor 10.1.14.1 remote-as 200
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
     logging synchronous
     transport preferred none
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     login
    end
    autostart = False
    version = 0.8.6
    [127.0.0.1:7202]
        workingdir = C:\Users\Mark\AppData\Local\Temp
        udp = 10200
            image = C:\downloads\GNS3\c7200-adventerprisek9-mz.152-4.S5.image
            idlepc = 0x62f1e4ec
            ghostios = True
            console = 2005
            aux = 2100
            cnfg = configs\SmileyISP.cfg
            slot1 = PA-2FE-TX
            f1/0 = RRS1 f1/0
            f1/1 = RRS2 f1/1
            x = -24.0
            y = -259.0
            z = 1.0
            hx = -1.5
            hy = -24.0
            console = 2015
            aux = 2101
            cnfg = configs\RRc1.cfg
            slot1 = PA-2FE-TX
            f1/0 = RRS2 f2/0
            x = -292.0
            y = 200.0
            z = 1.0
            hx = -5.5
            hy = -25.0
    [127.0.0.1:7200]
        workingdir = C:\Users\Mark\AppData\Local\Temp
        udp = 10000
            image = C:\downloads\GNS3\c7200-adventerprisek9-mz.152-4.S5.image
            idlepc = 0x62f1e4ec
            ghostios = True
            console = 2012
            aux = 2102
            cnfg = configs\RRS1.cfg
            slot1 = PA-2FE-TX
            f1/0 = SmileyISP f1/0
            f1/1 = RRS2 f1/0
            slot2 = PA-2FE-TX
            f2/0 = RRc2 f1/0
            f2/1 = RRc3 f1/0
            x = 197.0
            y = 6.0
            z = 1.0
            hx = 42.5
            hy = -20.0
            console = 2013
            aux = 2103
            cnfg = configs\RRS2.cfg
            slot1 = PA-2FE-TX
            f1/0 = RRS1 f1/1
            f1/1 = SmileyISP f1/1
            slot2 = PA-2FE-TX
            f2/0 = RRc1 f1/0
            x = -239.0
            y = 9.0
            z = 1.0
            hx = 1.5
            hy = -24.0
    [127.0.0.1:7201]
        workingdir = C:\Users\Mark\AppData\Local\Temp
        udp = 10100
            image = C:\downloads\GNS3\c7200-adventerprisek9-mz.152-4.S5.image
            idlepc = 0x62f1e4ec
            ghostios = True
            console = 2009
            aux = 2104
            cnfg = configs\RRc3.cfg
            slot1 = PA-2FE-TX
            f1/0 = RRS1 f2/1
            x = 337.0
            y = 155.0
            z = 1.0
            hx = 17.5
            hy = -25.0
            console = 2008
            aux = 2105
            cnfg = configs\RRc2.cfg
            slot1 = PA-2FE-TX
            f1/0 = RRS1 f2/0
            x = 149.0
            y = 204.0
            z = 1.0
            hx = -13.5
            hy = -23.0
    [GNS3-DATA]
        configs = configs
            text = ".1"
            x = 208.0
            y = -23.0
            text = "10.1.12.0/24"
            x = -19.0
            y = 5.0
            text = ".1"
            x = 153.0
            y = 25.0
            text = ".1"
            x = 259.0
            y = 33.0
            text = "10.1.13.0/24"
            x = 238.0
            y = 84.0
            rotate = 99
            text = "10.1.25.0/24"
            x = -188.0
            y = -124.0
            text = "l0: 172.16.2.1/24"
            x = 125.0
            y = 244.0
            text = "l0:172.16.1.1/24"
            x = -269.0
            y = 240.0
            text = "10.1.15.0/24"
            x = 116.0
            y = -127.0
            text = "10.1.14.0/24"
            x = 293.0
            y = 53.0
            rotate = 50
            text = ".1"
            x = 194.0
            y = 68.0
            text = "AS100"
            x = -20.0
            y = -342.0
            text = ".2"
            x = -148.0
            y = 46.0
            text = "AS200"
            x = 33.0
            y = 300.0
            text = "l0: 1.1.1.1/24"
            x = -42.0
            y = -306.0
            text = ".5"
            x = 50.0
            y = -213.0
            text = ".2"
            x = -248.0
            y = 60.0
            text = ".2"
            x = -174.0
            y = -52.0
            text = ".5"
            x = -54.0
            y = -209.0
            text = ".6"
            x = -232.0
            y = 189.0
            text = "l0:172.16.3.1/24"
            x = 299.0
            y = 194.0
            text = "10.1.26.0/24"
            x = -274.0
            y = 167.0
            rotate = 290
            text = ".3"
            x = 208.0
            y = 187.0
            text = ".4"
            x = 312.0
            y = 155.0
            type = ellipse
            x = 50.0
            y = -35.0
            width = 385.0
            height = 345.0
            fill_color = "#ffff7f"
            border_style = 2
            z = -1.0
            type = ellipse
            x = -171.0
            y = -346.0
            width = 359.0
            height = 200.0
            fill_color = "#aaff7f"
            border_style = 2
            z = -1.0
            type = ellipse
            x = -407.0
            y = -87.0
            width = 883.0
            height = 443.0
            border_style = 2
            z = -2.0
            type = ellipse
            x = -361.0
            y = -29.0
            width = 385.0
            height = 326.0
            fill_color = "#55aaff"
            border_style = 2
            z = -3.0

    BD,
    Ahh...
    OK.  In the original article, the author states that the final piece with the route map
    NEXTHOP was supposed to fix the reachability issue.  Obviously it doesn't.
    After reading your last post, I looked more carefully at the output from 'sh ip bgp'
    on each of the client routers and I realized that several of the next hop addresses were
    wrong for some of the prefixes.
    1) I completely removed the 'neighbor RouteReflectors route-map NEXTHOP out'
    from both RR's.  Then I ran 'sh ip bgp' on the clients and noted a change in the next hop addresses.  Still wrong, but it changed.
    2) I then tried next-hop-self from the RR's to the clients, but it did not change from where
    it was after I completed step 1.  I am not sure why there was no change. (actually, see the very end of this post)
    3) I then applied my version of the route map:  route-map NEXTHOP permit 10
                                                                                 set ip next-hop peer-address
    to the RR's with this: neighbor RRClients route-map NEXTHOP out
    That fixed it.  All three clients have as their next hop for all prefixes their respective
    RR's (which is what they should have for this topology).
    I have full connectivity everywhere, even loopback to loopback between all clients.
    1) THANK YOU for pointing me in the right direction.
    2) If I may ask, why did next hop self fail?  More specifically, I saw no change at all
    in the next hop for the advertised prefixes.  Is it because next-hop-self should be used
    for eBGP peers and all of the RR's and clients are all within the same AS?

  • BGP Advertised Routes two Peering

    Dear all
    I have issue with BGP behaviour. I have two BGP peering; from both I receive default route, but one of them,
    AS 65472 is primary so I setup local preference in 200; it is because I want to use AS 65472 as internet
    provider. The another one, AS 65472 is used as secundary internet access, but for internal network (private) is
    used as primary. The issue is when try ping from LAN, can not reach internal network, seems to be that
    becuase Local preference is setup within AS65472 and the packet try to go thru AS 65472 because local prefeence 200,
    but I need that internal network go thru AS 65471.
    I am sure that I am advertising network as I expect, but when is running BGP for both peering, it fails.
    Here are go output for this situation:
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    * i0.0.0.0          172.16.40.37             0    100      0 i
    Total number of prefixes 1
    7204VXR-SCT#sh ip bgp neighbors 172.16.40.37 advertised-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.10.200.0/30   0.0.0.0                  0         32768 i
    *> 10.30.24.0/21    172.16.40.4              0         32768 i
    *> 172.16.17.0/24   172.16.40.5              0         32768 i
    *> 172.16.211.0/24  0.0.0.0                  0         32768 i
    *> 172.18.56.16/29  0.0.0.0                  0         32768 i
    *> 172.30.100.18/32 0.0.0.0                  0         32768 i
    *> 172.31.0.20/30   0.0.0.0                  0         32768 i
    7204VXR-SCT#sh ip bgp neighbors 190.97.254.241 received-routes
       Network          Next Hop            Metric LocPrf Weight Path
    *  0.0.0.0          190.97.254.241                         0 65472 i
    Total number of prefixes 1
       Network          Next Hop            Metric LocPrf Weight Path
    *> 190.153.116.0/22 172.16.40.4              0         32768 i
    *> 190.153.120.0/22 172.16.40.4              0         32768 i
    *> 190.153.124.0/24 172.16.40.37            10         32768 i
    router bgp 65471
     bgp log-neighbor-changes
     neighbor externalBGP peer-group
     neighbor externalBGP remote-as 65472
     neighbor externalBGP version 4
     neighbor internalBGP-SCT peer-group
     neighbor internalBGP-SCT remote-as 65471
     neighbor internalBGP-SCT version 4
     neighbor 172.16.40.37 peer-group internalBGP-SCT
     neighbor 190.97.254.241 peer-group viginet
     address-family ipv4
     neighbor externalBGPsoft-reconfiguration inbound
     neighbor externalBGProute-map viginet-in in
     neighbor externalBGProute-map viginet-out out
     neighbor internalBGP-SCT soft-reconfiguration inbound
     neighbor internalBGP-SCT route-map internalBGP-SCT-out out
     neighbor 172.16.40.37 activate
     neighbor 190.97.254.241 activate
     no auto-summary
     no synchronization
     network 10.10.200.0 mask 255.255.255.252
     network 10.30.24.0 mask 255.255.248.0
     network 172.16.17.0 mask 255.255.255.0
     network 172.16.40.0 mask 255.255.255.0
     network 172.16.211.0 mask 255.255.255.0
     network 172.18.56.16 mask 255.255.255.248
     network 172.30.100.18 mask 255.255.255.255
     network 172.31.0.20 mask 255.255.255.252
     network 190.153.116.0 mask 255.255.252.0
     network 190.153.120.0 mask 255.255.252.0
     network 190.153.124.0 mask 255.255.255.0
     exit-address-family
    ip route 172.16.40.36 255.255.255.252 Null0 250
    ip route 190.153.116.0 255.255.252.0 172.16.40.4
    ip route 190.153.120.0 255.255.252.0 172.16.40.4
    ip prefix-list invalidas seq 10 permit 172.16.40.0/24
    ip prefix-list invalidas seq 15 permit 10.30.24.0/21
    ip prefix-list invalidas seq 20 permit 172.16.211.0/24
    ip prefix-list invalidas seq 25 permit 172.18.56.16/29
    ip prefix-list invalidas seq 30 permit 172.30.100.18/32
    ip prefix-list invalidas seq 35 permit 10.10.200.0/30
    ip prefix-list invalidas seq 40 permit 172.16.17.0/24
    ip prefix-list invalidas seq 45 permit 172.31.0.20/30
    ip access-list standard viginet-100
     permit 190.153.116.0 0.0.3.255
     permit 190.153.120.0 0.0.3.255
     permit 190.153.124.0 0.0.0.255
    route-map externalBGP-out permit 10
     match ip address viginet-100
    route-map externalBGP-in permit 10
     set local-preference 200
    route-map internalBGP-SCT-out permit 10
     match ip address prefix-list invalidas

    Hello.
    If you want your internal network to go through peer 65471 (to 0.0.0.0/0), then why do you need AS 65472?
    Could you please provide "show ip bgp 0.0.0.0/0"?

  • Is it possible to do this kind of system with Cirrus?

    Sorry for my poor english.
    I am looking for a technology that solve my problem
    and I am not sure if Adobe Cirrus is the right one.
    I am making 1vs1 turn based game system for cross platform (iOS, Android, Web)
    The game process ...
    PlayerA start app and send some data to central server
    PlayerA need to wait until PlayerB start app then server can tell both player to start the game
    Once the game time is up on both side, each player send score to server and server do some calculation and tell both player the result
    During PlayerA playing with PlayerB, PlayerC may playing PlayerD, and so on ...
    It will be great if we can let user do P2P connection during game process to save bandwidth cost and server capacity.
    Thank you for your help
    sw.

    if you meant "how do i connect to multiple peers in the same NetConnection?", then it's no different than connecting to one peer -- just make another NetStream for the other peer using the same NetConnection.
    you can also use RTMFP Groups (NetGroup, GroupSpecifier) to connect multiple peers together in interesting ways.  you can watch my session from MAX 2011 on "Advanced P2P with RTMFP: Tips and Tricks":
      http://tv.adobe.com/watch/max-2011-develop/advanced-p2p-with-rtmfp-tips-and-tricks/
    the demo assets from that session are at
       http://www.adobe-max.com/published/adobemax2011/sessions/S4600/S4600_Thornburgh-AdvancedP2 P_Assets.zip
    (except that site seems to be down at the moment)

  • BGP received-only Question

    Hi
    From what I understand in the show ip bgp x.x.x.x/x output the received-only would be present when soft-reconfiguration inbound is configured and the route has been rejected by a policy i.e. a route map
    What i have also found is that on many outputs i can see the exact same route in the output twice, one which has the received-only keyword and one doesn't.
    Now for a specified neighbor we have a route map configured inbound which will change the weight based on the community value. It seems as though when a route map is configured and an attribute is changed that route appears in the output twice, one being modified and one which is unchanged. But this contradicts what is said on the Cisco website its states 'the received-only keyword will only show up if the route is denied by a policy', but its not.. it's just changed.
    Has anyone had this discussion before? I would like to hear people's thoughts on the matter.
    Thanks
    Andre
    corerouter#show ip bgp | b 10.141.54.0
    * 10.141.54.0/23 10.199.10.18 0 64000 34406 65502 ?
    *> 10.199.10.18 0 64000 34406 65502 ?
    corerouter#sho ip bgp 10.141.54.0/23
    BGP routing table entry for 10.141.54.0/23, version 1219279
    Paths: (4 available, best #3, table Default-IP-Routing-Table)
    Advertised to update-groups:
    2 3 4 5 6 7
    34406 65502
    10.199.10.18 from 10.199.10.20 (82.196.60.60)
    Origin incomplete, metric 0, localpref 100, weight 64000, valid, external
    Community: 10199111
    34406 65502, (received-only)
    10.199.10.18 from 10.199.10.20 (82.196.60.60)
    Origin incomplete, metric 0, localpref 100, valid, external
    Community: 10199111
    34406 65502
    10.199.10.18 from 10.199.10.19 (82.196.60.1)
    Origin incomplete, metric 0, localpref 100, weight 64000, valid, external, best
    Community: 10199111
    34406 65502, (received-only)
    10.199.10.18 from 10.199.10.19 (82.196.60.1)
    Origin incomplete, metric 0, localpref 100, valid, external
    Community: 10199111

    show ip bgp neighbor x.x.x.x received-routes
    show ip bgp neighbor x.x.x.x routes
    sho ip bgp a.b.c.d
    If you found this page, like I did, while searching for "received-only" - that means that the route has only been received, but not entered in the routing table. This is good if you meant to block that route.  But if that route is actually also installed in the routing table and you meant to block it, check your route-map, specifically your prefix-lists and you will likely find that you have an error with wither the IP address or the CIDR mask, resulting in a non-match condition. The inverse is also true if you intend to allow a route but you only see the "received-only" route, you probably have a typo in your route-map or prefix list.  Below are some examples that might help.
    Here are some BGP with route-map and prefix-list examples, although the data is not meaningful. 
    router bgp 1234
      neighbor CARRIER1 peer-group
      neighbor CARRIER1 route-map PROVIDER1-IN in
      neighbor 6.7.8.9 peer group CARRIER1
    route-map PROVIDER1-IN deny 5
      match ip address prefix-list MyIPs
    route-map PROVIDER1-IN permit 10
      match ip address prefix-list GOOG APPL
    ip prefix-list GOOG seq 5 permit 8.8.8.0/24 le 32
    ip prefix-list GOOG seq 10 permit 8.8.4.4/32
    ip prefix-list APPL seq 5 per 17.142.160.59/32
    ip prefix-list APPL seq 10 per 17.178.96.0/24 le 32
    ip prefix-list MyIPs seq 5 per 1.2.0.0/16 le 24
    ip prefix-list MyIPs seq 10 per 2.3.4.0/24 le 32
    ip prefix-list MyIPs seq 15 per 4.5.6.7/32

  • Compiling multiple outputs into one stream?

    Hi All-
    I posted this morning to see if anyone knew how to get multiple work centers to display on the SAP standard report (t/code CMP9, report name RCMPP010) I didn't see any responses but thought I would ask if anyone knows of a way to capture the outputs of the reports and at least allow all of the workcenters to be downloaded in one datastream?  The user wants to avoid having to hit 'shift F-5' to go to the next work center.  As they are downloading into excel, I am curious if there is a way to capture this data?  Thanks for any help you can give!

    if there were 5 publishers and you subscribed to all 5 streams, then you would hear them all.  at once.  i assume you're talking about multicast (since you mentioned "few-to-many"); in an RTMFP group there can be any number of simultaneous multicast streams flowing.  each stream flows through every member of the group.

  • Problem about NetGroup with Cirrus

    Hi guys, I try to setup NetConnection and NetGroup following the example code in tutorial "Peer-assisted networking using RTMFP groups in Flash Player 10.1"  ( http://www.adobe.com/devnet/flashmediaserver/articles/p2p_rtmfp_groups.html ) but have got some problems. No matter how many node I connect to the same netgroup, estimatedMemberCount and neighborCount is always 1 and 0. I can receive NetConnection.Connect.Success and NetGroup.Connect.Success event and calling NetGroup.post does return a vaild id but still, nobody could receive a NetGroup.Posting.Notify. Any idea what may be wrong or missing ? Thanks.

    I have the same problem... what do you mean with "wrong version of playerglobal.swc"? Thanks

  • Netstream.send() privacy settings

    I'm using Netstream.send() to transfer a file between two users.
    A previous discussion can be found here:
    http://forums.adobe.com/thread/890122?tstart=0
    It works well except of flash settings issue.
    When trying to access a camera or mic the Flash ask the user for permissions automatically.
    When trying to send a file, the Flash player doesn't show the privacy popup.
    If the user doesn't set his privacy to Allow, the file transfer fails.
    There are two issues:
    1. The privacy settings popup isn't shown automatically.
    2. The privacy popup ask permissions to access the camera and mic and doesn't say anything about data transfer.
    Am I missing something or are the above real issues?
    Thanks

    the P2P access dialog will only show when using RTMFP Groups (NetGroup or a group NetStream).  if you're just doing NetStream.send() on a 1-to-1 (NetStream.DIRECT_CONNECTIONS and new NetStream(netConnection, peerID)) P2P connection, then there is no P2P access dialog.
    if you're doing groups and the P2P access dialog isn't showing up, there are a few possible causes:
      1) for some reason you at one point selected "Deny" *and* checked "Remember"; in that case, Flash Player won't present the dialog and will behave as though you clicked "Deny"
      2) Flash Player's window or region in the browser page is too small for the P2P access dialog.  if the P2P access dialog can't be presented because the window is too small, it will behave as though you clicked "Deny"
      3) there is a known bug in Flash Player when using wmode=direct (which you would use for Stage Video) where, when you set wmode=direct, the P2P access dialog won't be displayed, and the behavior will be as though you clicked "Deny".  this issue will be fixed in a future release of Flash Player. to work around this, set wmode to a different value.

  • NetStream.send() with datareliable=false

    Does NetStream.send() and setting NetStream.datareliable = false make the flash player use UDP? Or does it just use TCP for 1 second and then stop?
    Thanks

    the dataReliable flag doesn't control whether you're using TCP or UDP. if you're using RTMP, you're using TCP because that's what RTMP goes over. if you're using RTMFP, you're using UDP because that's what RTMFP goes over.
    if you're using RTMP, the videoReliable, audioReliable, and dataReliable flags have no effect because TCP is fully reliable all the time.
    those flags only have meaning for RTMFP connections. when video/audio/dataReliable is set to true, RTMFP sends the corresponding message with full reliability, retransmitting it if necessary. if a reliable flag is false, RTMFP will not retransmit the corresponding message, and the message will only remain in the transmission queue for 1 second (so depending on network congestion/throughput, the message might not be transmitted at all).
    messages of different types are sent with different priority in RTMFP. audio is highest priority, then NetStream.send() (data), then video. all RTMFP Groups modes (multicast, posting, directed routing, object replication) are lower priority than video.  priority matters when bandwidth is tight.

  • Are there any examples that do not require a personal webserver?  I do not need a server for my aps.

    Back when Cirrus was Stratus, there was no need for a personal webserver to host a CGI script.
    I have no need for a non AS3 server because my server is simply going to be another peer node on the network
    It is a professional way to handle things too:
    1) You have a computer with a static IP that computers refer to as the master peer(yes wordplay).
    2)If you can't afford a computer with a static IP, you can simply create a peer that responds to requests,"Are you the server?"  Yes, this is easily hackable, but when you're debugging, your friends aren't gonna be jerks.
    All I want when I contact Cirrus is:
    1) A list of IP addresses of connected peers.
    And if someone has example code:
    2) The ability to send "Hello World" to all peers.
    Is this doable in Cirrus?  Stratus could do it.

    the only difference between "Stratus" and "Cirrus (codename)" is the name.
    Cirrus has never had a "list connected peers" function, nor has it ever reported IP addresses/port numbers of connected peers in ActionScript.
    the VideoPhoneLabs example program has always required some kind of external registration service to register a peer ID for a name, and to look up the peer ID for a name.
    it's possible to do P2P with Cirrus and no active web server by using RTMFP Groups (NetGroup, GroupSpecifier and friends). i have posted examples from my labs at MAX from years past that implement text chat and other functions using only Cirrus. and you can do P2P with groups on a LAN with no server at all (not even Cirrus).  see this thread:
       http://forums.adobe.com/thread/766959
    for links to my lab materials from MAX 2009 and 2010. and come to my session at MAX this year where i'll be covering "Advanced P2P With RTMFP: Tips & Tricks".

Maybe you are looking for