Service-policy on Vlan interface failed

Hi, All!
This is my configuration:
class-map match-any voip_control_trust-CMAP
match ip dscp cs3
match ip dscp af31
class-map match-any voip_rtp_trust-CMAP
match ip dscp ef
class-map match-any internetwork-cntrl-CMAP
match ip dscp cs6
policy-map output_qos-PMAP
class voip_rtp_trust-CMAP
  priority 56
class voip_control_trust-CMAP
  bandwidth percent 2
class internetwork-cntrl-CMAP
  bandwidth percent 5
class class-default
  fair-queue
  random-detect
cisco(config)#int Vlan 2
cisco(config-if)#service-policy output output_qos-PMAP
Configuration failed!
It was tested on 877, 871, 871W, 877W with ios c870-advipservicesk9-mz.124-15.T5.bin, c870-advipservicesk9-mz.124-15.T8.bin, c870-advipservicesk9-mz.124-15.T10.bin, c870-advipservicesk9-mz.124-15.T11.bin, c870-advipservicesk9-mz.124-24.T2.bin
Strange error. Does anybody know what's the problem?

Ok, i tried to make workaround solution:
policy-map OUTPUT_QOS_PMAP
class VOIP_RTP_TRUST_CMAP
    priority 56
class VOIP_CTRL_TRUST_CMAP
    bandwidth percent 2
class INETWORK-CTRL-CMAP
    bandwidth percent 5
class class-default
    fair-queue
     random-detect
  service-policy OUTPUT_QOS_PMAP
service-policy output OUTPUT_QOS_PMAP
interface Vlan2
description *** WAN SVI ***
bandwidth 256
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
bridge-group 1
end
interface BVI1
description *** WAN BVI ***
bandwidth 256
ip address 10.96.0.57 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
service-policy output OUTPUT_QOS_PMAP
end
sh policy-map interface
BVI1
  Service-policy output: OUTPUT_QOS_PMAP
    queue stats for all priority classes:
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
    Class-map: VOIP_RTP_TRUST_CMAP (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp ef (46)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Priority: 56 kbps, burst bytes 1500, b/w exceed drops: 0
    Class-map: VOIP_CTRL_TRUST_CMAP (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs3 (24)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: ip dscp af31 (26)
        0 packets, 0 bytes
        5 minute rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 0/0
      bandwidth 2% (5 kbps)
    Class-map: INETWORK-CTRL-CMAP (match-any)
      6 packets, 896 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: ip dscp cs6 (48)
        6 packets, 896 bytes
        5 minute rate 0 bps
      Match: access-group name IKE
        0 packets, 0 bytes
        5 minute rate 0 bps
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 5/0/0
      (pkts output/bytes output) 6/1120
      bandwidth 5% (12 kbps)
    Class-map: class-default (match-any)
      11 packets, 660 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops/flowdrops) 10/0/0/0
      (pkts output/bytes output) 11/660
      Fair-queue: per-flow queue limit 16
        Exp-weight-constant: 9 (1/512)
        Mean queue depth: 0 packets
        class     Transmitted       Random drop      Tail/Flow drop Minimum Maximum Mark
                  pkts/bytes    pkts/bytes       pkts/bytes    thresh  thresh  prob
        0              11/660             0/0              0/0                 20            40  1/10
        1               0/0               0/0              0/0                 22            40  1/10
        2               0/0               0/0              0/0                 24            40  1/10
        3               0/0               0/0              0/0                 26            40  1/10
        4               0/0               0/0              0/0                 28            40  1/10
        5               0/0               0/0              0/0                 30            40  1/10
        6               0/0               0/0              0/0                 32            40  1/10
        7               0/0               0/0              0/0                 34            40  1/10
BUT! Until service-policy is on interface works nothing.
sh int bvi1
BVI1 is up, line protocol is up
  Hardware is BVI, address is 0025.454a.940d (bia 0024.c495.6780)
  Description: *** WAN BVI ***
  Internet address is 10.96.0.57/24
  MTU 1500 bytes, BW 256 Kbit/sec, DLY 5000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 74
  Queueing strategy: Class-based queueing
  Output queue: 33/1000/0 (size/max total/drops)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     114 packets output, 11034 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
ping 10.96.0.1 source bvi1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.96.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.96.0.57
Success rate is 0 percent (0/5)

Similar Messages

  • Service-policy output statement interface vs interface .500 point-to-point

    We are running AutoQoS but have recently migrated our WAN service that puts our IP connectivity to a sub-interface (interface serial0/1:0.500 point-to-point and a frame-relay interface-DLCI). In our prior WAN configuration we bound the IP address directly to the interface s0/1:0.
    After the migration, the auto qos statement service-policy output AutQoS is still on the interface serial 0/1:0 . Should this service-policy statement be moved down to the serial 0/1:0.500 point-to-point in order to be effective? We have been experiencing QoS problems but I understand it could be many different places, but I wanted to start here.
    Thanks
    ryan

    as a rule those are applied in a frame relay policy map.
    Create the LLC policy
    Create the Frame Relay Policy map (and refer to the LLC policy map in the Frame Relay Config)
    Apply the Frame Relay Policy Map to the subinterface (to the DLCI).

  • Error while applying the Service Policy

    Hi,
    I am getting the below error while applying the service policy to the Interface.
    I have set the mpls exp 4 as well as want to limit the bandwidth to 1Mbps
    PE#sh policy-map setexp-GBoIP
      Policy Map setexp-GBoIP
        Class GBoIP-traffic
          set mpls experimental imposition 4
         police cir 1024000 bc 32000
           conform-action transmit
           exceed-action drop
    PE(config-if)#int vlan 2007
    PE(config-if)#service-policy input setexp-GBoIP
    QoS-ERROR: Addition/Modification made to policymap setexp-GBoIP and class GBoIP-traffic is not valid, command is rejected
    As well as I have created new clas--map with priority and Bandwidth and applied in output direction, I got the belwo error while applying the Service policy in
    PE(config-if)#service-policy out TEST
    bandwidth command is not supported in output direction for this interface
    PE(config-if)#service-policy output TEST
    priority command is not supported in output direction for this interface
    Any idea why so ?
    Thanks in Advance.
    Regards,
    Nilesh

    Check the current value of IGW_AWARDS_S sequence and make sure the MINVALUE in the patch (i.e. 10000) is not greater than the current one.
    OERR: ORA 4007 MINVALUE cannot be made to exceed the current value (Doc ID 19824.1)
    You may also log a SR.
    Thanks,
    Hussein

  • Service policy direction

    I'm trying to get some input on the direction policy maps should be applied, inbound vs outbound. If I have a central site that is hosting resources that include web related apps, Citrix, and SQL, and want users at a remote end of a point 2 point connection or VPN tunnel to have QoS guarantees such as bandwidth reservation and cbwfq, should the policy be applied in the outbound direction of the serial interface on the remote router that makes the point 2 point connection, and the inbound direction of the central site router's serial interface that is the other end of that point 2 point?
    Or, from the remote site, should it be the outbound direction on the serial interface that classifies traffic such as http to certain urls, citrix, and sql servers, but on the central router's serial interface that marking would be using acls, having the source being the http, citrix, and sql servers and the remote clients being the destination?
    What?s the recommended method of implementing something like this in terms of the direction of the policy maps?
    Thank you
    Bill

    If the policy map is being used for classification marking (e.g. DSCP marking), the usual recommendation is mark as close to the source as possible, usually "IN" on an ingress edge interface.
    If the policy map is being used for congestion management, and since congestion usually is found on an egress interface, such policies are applied there.
    So, from end-to-end, you might have an inbound policy on the local LAN device's edge interface, and an outbound policy on the local WAN device's WAN interface. Same on the remote side's devices for return traffic.
    Since congestion is usually of primary concern on the WAN device, the inbound classification could be done inbound on that device's LAN interface, or even as part of the outbound policy.
    Sample IOS policies (NB: syntax is incorrect):
    wan router
    class map VoIP
    match protocol Voice
    class map mission-critical match-any
    match protocol citrix
    match protocol sql
    match protocol http
    class map real-time
    match dscp ef
    class map gold
    match dscp af31
    policy map classify
    class VoIP
    set dscp ef
    class mission-critical
    set dscp af31
    class class-default
    set dscp best-effort
    policy CBWFQ
    class real-time
    priority 50 percent
    class gold
    bandwidth remaining 80 percent
    interface ethernet
    service policy classify in
    interface serial
    service policy CBWFQ out

  • Service policy on subinterface or main interface

    Folks,
    We have a frame relay circuit and are applying MQC to the branch sites. We are not sure if we should apply the service policy to the subinterface or the main interface(serial). any pros and cons?
    Thanks

    If you want the same policy applied to each VC then applying at the physical interface would be best (depending on the scenario and how many sub-interfaces you have). In the long run applying the service-policy to the sub-interface will pay for itself.

  • Applying a service policy on an ACE vlan

    Hi All
    Our ACE is held at a remote site and i just want to apply a Service policy on the client vlan which is also
    our mgmt/access vlan.
    As i am new to ACE s i thought i  would run it past you guyst before i apply it - I am not going to lose
    connectivity to my ACE am i -
    Heres the Service policy -
    policy-map multi-match CLIENT-VIPS
      class VIP-150
        loadbalance vip inservice
        loadbalance policy lb-logic
    class-map match-all VIP-150
      2 match virtual-address xx.xx.xx.150 any
    I was going to apply it  on vlan 121
    int vlan 121
    service-policy input CLIENT-VIPS
    Now the way i read it
    - it should only affect access to the virtual address specified
    Its not going to cut off my access to the ACE by only allowing
    that address through is it ?
    Could be a career damaging move if so for me
    Thanks for your advice
    Steve

    Hello Steve,
    If you are not modifying the MGMT class or policy, you do not need to worry about, like you mentioned, this LB policy is just intended to allow connections to that VIP, nothing else.
    As always it is a good practice to not apply this during production time, as well you can create a test context, where you can test all this without using the production context, so you can play safe and learn at the same time.
    Thanks, hope this help.

  • Service Policy won't attach to interface - NO error

    Hi,
    Am doing some simple CE VoIP QoS for a IPSEC/GRE Customer. I try to ATTACH the policy to the tunnel outbound and the command is accepted without any error but nothing appears in the config.
    Here's the base config:
    class-map match-all IPSEC-VPN
    match access-group name IKE_ACL
    class-map match-all ROUTING
    match ip dscp cs6
    class-map match-all NETWORK-MANAGEMENT
    match ip dscp cs2
    class-map match-any VOICE-SIGNAL
    match protocol rtp
    match ip precedence 3
    match ip dscp cs3
    match ip dscp af31
    match ip dscp af32
    class-map match-any VOICE-BEARER
    match ip precedence 5
    match ip dscp ef
    match ip dscp cs5
    policy-map SHAPE-ADSL-UPLINK
    class class-default
    bandwidth remaining percent 50
    random-detect
    random-detect ecn
    policy-map VoIP-QoS
    class VOICE-BEARER
    priority percent 34
    class VOICE-SIGNAL
    bandwidth percent 5
    class ROUTING
    bandwidth percent 2
    class NETWORK-MANAGEMENT
    bandwidth percent 2
    class IPSEC-VPN
    bandwidth percent 2
    class class-default
    (config)# int t203
    (config-if)#service-policy output SHAPE-ADSL-UPLINK
    NOTHING appears in the config and sh policy-map int t100 shows an unapplied policy.
    Using:
    c836-k9o3s8y6-mz.123-8.T5
    Another bug?
    Thx

    Policy should read (nested):
    policy-map SHAPE-ADSL-UPLINK
    class class-default
    bandwidth remaining percent 50
    random-detect
    random-detect ecn
    service-policy VoIP-QoS

  • Service-policy output not working in Cisco 3560 switch

    We got some Cisco catalyst 3560 that we want to control the bandwidth
    on the ports. Can this be done, and how do i do it?
    Ive got 3550s that can do policy-map with the interface command;
    service-policy output(and input) <policyname>
    But 3560 only seems to handle service-policy input.
    If i try to configure output, it says the following:
    SW(config-if)#service-policy output 4mbit-out
    police command is not supported for this interface
    Configuration failed!
    Warning: Assigning a policy map to the output side of an interface not
    supported
    Any workarounds or new ways to accomplish bandwith-control on a 3560 ?
    regards,
    Rajib

    The 3560 & 3750 (& 2960) don't support egress policy-maps. They do however support queueing so it is possible to achieve similar results by applying an ingress policer to your user ports to classify (& police?) the traffic, at the egress port you can then queue the traffic based on it's DSCP or CoS value that it was classified with (same as 3550).
    It is also possible to restrict the bandwidth in use at an egress port with the interface command 'srr-queue bandwidth limit <10-90>' where 10-90 represents a percentage of the links bandwidth. For example if you want to restrict a 100Mbps port to 10Mbps you would use the command 'srr-queue bandwidth limit 10'
    HTH
    Andy

  • Service-Policy Or Bandwidth Rate Limit for IP

    Hii Netpros,
    Is this possible to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit for Single IP. For eg: If we want to configure the Service Policy(for Bandwidth) or Bandwidth Rate Limit of 2Mb for only IP " 10.10.10.3" on network  i.e the Host or device which is configured with this IP can access upto 2Mb only.
    Actual Network :-   We need this to configure this for wireless customers, Actually we have created one Vlan 2 (IP:- 10.10.10.1/29 @ our end router) , 10.10.10.2 on Basestation wiresss device (Vlan 2 allowed on this wireless device) and this wireless device is working as point to multipoint wireless. i.e 2 or more then 2 wireless customers or last mile will connect to this basestation wireless.  Wireless customer-1 is 10.10.10.3 (2Mb bandwidth)  and Wireless Customer-2  10.10.10.4 (512Kb).
    Hence we require to limit the bandwidth for this 2 wireless customers having different bandwidth. how to acheive & control bandwidth @ our end router for them. please suggest.
    Thanks

    This topic is probably better suited in another Infrastructure forum, but I suppose it depends on which features are supported by your Cisco hardware and software. This doc discusses a variety of options:
    http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpolsh.html
    For example, with the older CAR (committed access rate) approach:
    interface FastEthernet5/0
         rate-limit input access-group 101 20000000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
         rate-limit input access-group 102 5120000 [normal burst size] [excess burst size] conform-action transmit exceed-action drop
    access-list 101 permit ip 10.10.10.3 0.0.0.0
    access-list 102 permit ip 10.10.10.4 0.0.0.0
    You can observe CAR in action with "show interfaces fa5/0 rate-limit" for example.

  • C3750-48ts Service-Policy Output Like Command

    Hello,
    I'm having an issue trying to find a way to make a QOS or limiting of network traffic on a cisco 3750 that we have at a client site. 
    What the end goal is to make the network traffic 10x5mbs on some ports and 5x1mbs on others.
    From how I normally do traffic shaping on routers is Class-map, policy-map and service-policy. However as I found out with with this project I can't run the Service-policy Output command on the 3750 model. The other way that I know how to limit bandwidth on these switches is to use the srr-queue bandwidth limit % command. However, this isn't going to work for the clients that have 30x5mbs connection though us.
    Here is what I have programmed: 
    mls qos
    vlan 100
    class-map match-any IN
     match access-group 100
    class-map match-any OUT
     match ip dscp default
    policy-map 5M_IN
     class IN
      police 5000000 256000 exceed-action drop
    policy-map 1M_IN
     class IN
      police 1000000 256000 exceed-action drop
    policy-map 30M_OUT
     class OUT
      police 30000000 512000 exceed-action drop
    policy-map 5M_OUT
     class OUT
      police 5000000 256000 exceed-action drop
    interface FastEthernet1/0/36
     description TEST
     switchport access vlan 100
    servic-policy input 1M_IN
    (This is where I would like to run the service-policy output 5M_OUT)
    If you have any idea on how to limit traffic per port please let me know so that this may help others.
    Thank you,
    Michael 

    The 3560 & 3750 (& 2960) don't support egress policy-maps. They do however support queueing so it is possible to achieve similar results by applying an ingress policer to your user ports to classify (& police?) the traffic, at the egress port you can then queue the traffic based on it's DSCP or CoS value that it was classified with (same as 3550).
    It is also possible to restrict the bandwidth in use at an egress port with the interface command 'srr-queue bandwidth limit <10-90>' where 10-90 represents a percentage of the links bandwidth. For example if you want to restrict a 100Mbps port to 10Mbps you would use the command 'srr-queue bandwidth limit 10'
    HTH
    Andy

  • PING TO ACE VLAN INTERFACES

    Hi,
    I am not able to ping the VLAN interfaces defined on the ACE devices unless directly connected to the subnet.
    I tried options - defining Access-list,service-policy.I can ping the servers behind the ACE but i cannt ping the ACE vlan interface.
    I captured the traffic on the ACE.I cannt see any traffic on the interfaces if i ping the VLAN ip address.I can see the traffic if i am pinging the host behind the ACE.
    Is there any option available to enable icmp on the interfaces.

    In order to ping the Vlan Interface you just need management policy applied to the vlan interface.
    Class-maps used in the management-policy
    defines the source addresses from where these management accesses are allowed.
    If you can ping the interfaces from locally connected subnets but not from the remote subnets then there could be 2 reasons.
    1. Some routing issues
    2. Source IPs in Management class maps are not defined.
    Following is an example of typical management policy
    #Allow telnet & SSH from these ip addresses
    #Allow ICMP from any source
    class-map type management match-any MGMT-CLASS
    10 match protocol telnet
    20 match protocol ssh
    30 match protocol icmp any
    policy-map type management first-match MGMT-POLICY
    class MGMT-CLASS
    permit
    interface vlan 10
    ip address x.x.x.x 255.255.255.0
    service-policy input MGMT-POLICY
    no shutdown
    interface vlan 20
    ip address y.y.y.y 255.255.255.0
    service-policy input MGMT-POLICY
    no shutdown
    Syed Iftekhar Ahmed

  • Broadcast/multicast counters does not increase on vlan interface

    Hi,
    on a Cat6500 we try to monitor interface packet statistics via snmp, in detail we want to get information about the relation between unicast, multicast and broadcast packet counter.
    What we found out is that while on physical l2 interfaces all counters (ifHCInUcastPkts, ifHCInMulticastPkts, fHCInBroadcastPkts, ifHCOutUcastPkts, ifHCOutMulticastPkts, ifHCOutBroadcastPkts) are filled, on vlan interfaces multicast in/out and broadcast out packets stay zero whole the time. We use arp, hsrp, ospf and other well know broadcast and multicast based protocols.
    Does anybody know why this counters do not increase?
    Attached you find an excel sheet which shows an example of interface counter vs. vlan counter.
    many thanks in advance,
    Thorsten Steffen

    Hi jon,
    belown the result of sh sdm prefer,so need i a licence ip service to apply the route-maap on the interface vlan,or just entrer the config"sdm prefer routing" and reboot the switch?
    SWBB0#sh sdm prefer
    The current template is "desktop default" template.
    The selected template optimizes the resources in
    the switch to support this level of features for
    8 routed interfaces and 1024 VLANs.
      number of unicast mac addresses:                  6K
      number of IPv4 IGMP groups + multicast routes:    1K
      number of IPv4 unicast routes:                    8K
        number of directly-connected IPv4 hosts:        6K
        number of indirect IPv4 routes:                 2K
      number of IPv6 multicast groups:                  64
      number of directly-connected IPv6 addresses:      74
      number of indirect IPv6 unicast routes:           32
      number of IPv4 policy based routing aces:         0
      number of IPv4/MAC qos aces:                      0.5K
      number of IPv4/MAC security aces:                 0.875k
      number of IPv6 policy based routing aces:         0
      number of IPv6 qos aces:                          0
      number of IPv6 security aces:                     60

  • Service policy counters not working..

    I have a service policy on a 6509 interface so I can see what the packets per second of a video stream coming out of a DVR (digital video recorder) is. This DVR has 16 security cameras attached and I'm concerned that when someone views all 16 cameras the video stream is going to be huge.
    So I create a service policy to match an access list for all IP from the DVR. But no counters increment unless I add in some other match statement. I added in a match protocol telnet and the service policy counters started to work. I removed the match on telnet and the counters stopped. Telnet has nothing to do with the DVR. Here is the config of the class map, policy map and show commands: (By the way video is streaming through this interface continually during this excercise)
    MATCHING ACCESS LIST ONLY:
    class-map match-any DVR
    match access-group 130
    policy-map DVR-test
    class DVR
    ROC-6509-DU-A#sh access-list 130
    Extended IP access list 130
    10 permit ip host 164.72.2.125 any
    ROC-6509-DU-A#sh policy-map int
    GigabitEthernet2/5
    Service-policy output: DVR-test
    Class-map: DVR (match-any)
    0 packets, 0 bytes
    30 second offered rate 0 bps
    Match: access-group 130
    0 packets, 0 bytes
    30 second rate 0 bps
    Class-map: class-default (match-any)
    0 packets, 0 bytes
    30 second offered rate 0 bps, drop rate 0 bps
    Match: any
    ADDING IN TELNET:
    class-map match-any DVR
    match access-group 130
    match protocol telnet
    policy-map DVR-test
    class DVR
    ROC-6509-DU-A#sh policy-map int
    GigabitEthernet2/5
    Service-policy output: DVR-test
    Class-map: DVR (match-any)
    524025 packets, 70724866 bytes
    30 second offered rate 3991000 bps
    Match: access-group 130
    523896 packets, 70689220 bytes
    30 second rate 3991000 bps
    Match: protocol telnet
    129 packets, 35646 bytes
    30 second rate 0 bps
    Class-map: class-default (match-any)
    18696 packets, 11180265 bytes
    30 second offered rate 129000 bps, drop rate 0 bps
    Match: any
    If I remove the 'match protocol telnet' and clear the counters, no longer do the counters for the access-list 130 increment - put back in match telnet and they start to increment.
    This is a Sup720 with IOS 12.2(18)SXE3
    Is this a bug or do I not have my class map or policy map correct?

    The hardware ASICs do not support collecting the individual policer information.
    Try:
    http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/1216ea1/3550scg/swqos.htm#xtocid1990743

  • Why doesn't "show service-policy url-summary" work?

    Does any one know -- At Cisco Live this year -- this command was shown as an Option to see the number of
    hits on L7 class maps urls.
    It's not an option for me:  Running A3 (2.5)
    Thanks,
    From A2 documentation  (maybe this command was dropped from A3 -- but that would be unfortunate)
    To display the statistics for all policy maps or a specific policy map that is currently in service, use the show service-policy command. This command also allows you to display statistics for a specific class map in a policy or the hit counts for match HTTP URL statements in a Layer 7 HTTP policy map. If you do not enter an option with this command, the ACE displays all enabled policy statistics.
    show service-policy [policy_name [class-map class_name]] [detail | summary | url-summary] [|] [>]
    Syntax Description
    policy_name
    (Optional) Identifier of an existing policy map that is currently in service (applied to an interface) as an unquoted text string with a maximum of 64 alphanumeric characters. If you do not enter the name of an existing policy map, the ACE displays information and statistics for all policy maps.
    class-map class_name
    (Optional) Displays the statistics for the specified class map associated with the policy.
    detail
    (Optional) Displays a more detailed listing of policy map or class map statistics and status information.
    summary
    (Optional) Displays a summary of policy map or class map statistics and status information.
    url-summary
    (Optional) Displays the number of times that a connection is established based on a match HTTP URL statement for a class map in a Layer 7 HTTP policy map.
    The URL hit counter is per match statement per load-balancing Layer 7 policy. If you are using the same combination of Layer 7 policy and class maps with URL match statements in different VIPs, the count is combined. If the ACE configuration exceeds 64K URL and load-balancing policy combinations, this counter displays NA.

    Hi Dan,
    The url-summary has only been added to the ACE module code at this time.  The A2 code train is only for the module, while the A3 train is only for the appliance.  The good news is that later this year, we will have a new software coming out (A4) that will be the exact same image that can be loaded on either the module or the appliance, hence all functionality will be the same for both (except the acceleration and optimization that only the appliance will support.
    Hope this helps,
    Sean

  • Policy map/ class map/ service policy for IOS xr

    Hi,
    I need to create a policy map and class map/service policy to limit the amount of bandwidth that can be used on one interface both in and out.
    I need the cap for the bandwidth to traverse this circuit to ne 10 Meg.
    the IOS xr version we are using is 4.3.4
    I was hoping someone could help me out by giving me a configuration example I could follow.
    Thank you.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

Maybe you are looking for