Service Policy won't attach to interface - NO error

Hi,
Am doing some simple CE VoIP QoS for a IPSEC/GRE Customer. I try to ATTACH the policy to the tunnel outbound and the command is accepted without any error but nothing appears in the config.
Here's the base config:
class-map match-all IPSEC-VPN
match access-group name IKE_ACL
class-map match-all ROUTING
match ip dscp cs6
class-map match-all NETWORK-MANAGEMENT
match ip dscp cs2
class-map match-any VOICE-SIGNAL
match protocol rtp
match ip precedence 3
match ip dscp cs3
match ip dscp af31
match ip dscp af32
class-map match-any VOICE-BEARER
match ip precedence 5
match ip dscp ef
match ip dscp cs5
policy-map SHAPE-ADSL-UPLINK
class class-default
bandwidth remaining percent 50
random-detect
random-detect ecn
policy-map VoIP-QoS
class VOICE-BEARER
priority percent 34
class VOICE-SIGNAL
bandwidth percent 5
class ROUTING
bandwidth percent 2
class NETWORK-MANAGEMENT
bandwidth percent 2
class IPSEC-VPN
bandwidth percent 2
class class-default
(config)# int t203
(config-if)#service-policy output SHAPE-ADSL-UPLINK
NOTHING appears in the config and sh policy-map int t100 shows an unapplied policy.
Using:
c836-k9o3s8y6-mz.123-8.T5
Another bug?
Thx

Policy should read (nested):
policy-map SHAPE-ADSL-UPLINK
class class-default
bandwidth remaining percent 50
random-detect
random-detect ecn
service-policy VoIP-QoS

Similar Messages

  • Service policy on subinterface or main interface

    Folks,
    We have a frame relay circuit and are applying MQC to the branch sites. We are not sure if we should apply the service policy to the subinterface or the main interface(serial). any pros and cons?
    Thanks

    If you want the same policy applied to each VC then applying at the physical interface would be best (depending on the scenario and how many sub-interfaces you have). In the long run applying the service-policy to the sub-interface will pay for itself.

  • Can't set service policy

    I am not able to have Service-Policy... " commands enabled in my Router that is working as a PE in the lab.
    The router info is as follows:
    Cisco Internetwork Operating System Software
    IOS (tm) 3600 Software (C3640-JS-M), Version 12.2(21a), RELEASE SOFTWARE (fc2)
    Copyright (c) 1986-2004 by cisco Systems, Inc.
    Compiled Fri 09-Jan-04 16:23 by kellmill
    Image text-base: 0x60008930, data-base: 0x61458000
    ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (f
    c1)
    PE uptime is 5 hours, 12 minutes
    System returned to ROM by power-on
    System image file is "flash:slot0"
    cisco 3640 (R4700) processor (revision 0x00) with 44032K/5120K bytes of memory.
    Processor board ID 22105451
    R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
    Bridging software.
    X.25 software, Version 3.0.0.
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    TN3270 Emulation software.
    1 Ethernet/IEEE 802.3 interface(s)
    2 FastEthernet/IEEE 802.3 interface(s)
    1 Serial network interface(s)
    1 Serial network interface(s)
    DRAM configuration is 64 bits wide with parity disabled.
    125K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read/Write)
    Configuration register is 0x2102
    Can someone help with it.. thx.

    Hi
    Are you trying to bind the service policy under any of the interface or class map or in the control plane config ?
    can you post what exactly you are trying to do and the error you are recieving while do so ..
    regds

  • Service-policy on Vlan interface failed

    Hi, All!
    This is my configuration:
    class-map match-any voip_control_trust-CMAP
    match ip dscp cs3
    match ip dscp af31
    class-map match-any voip_rtp_trust-CMAP
    match ip dscp ef
    class-map match-any internetwork-cntrl-CMAP
    match ip dscp cs6
    policy-map output_qos-PMAP
    class voip_rtp_trust-CMAP
      priority 56
    class voip_control_trust-CMAP
      bandwidth percent 2
    class internetwork-cntrl-CMAP
      bandwidth percent 5
    class class-default
      fair-queue
      random-detect
    cisco(config)#int Vlan 2
    cisco(config-if)#service-policy output output_qos-PMAP
    Configuration failed!
    It was tested on 877, 871, 871W, 877W with ios c870-advipservicesk9-mz.124-15.T5.bin, c870-advipservicesk9-mz.124-15.T8.bin, c870-advipservicesk9-mz.124-15.T10.bin, c870-advipservicesk9-mz.124-15.T11.bin, c870-advipservicesk9-mz.124-24.T2.bin
    Strange error. Does anybody know what's the problem?

    Ok, i tried to make workaround solution:
    policy-map OUTPUT_QOS_PMAP
    class VOIP_RTP_TRUST_CMAP
        priority 56
    class VOIP_CTRL_TRUST_CMAP
        bandwidth percent 2
    class INETWORK-CTRL-CMAP
        bandwidth percent 5
    class class-default
        fair-queue
         random-detect
      service-policy OUTPUT_QOS_PMAP
    service-policy output OUTPUT_QOS_PMAP
    interface Vlan2
    description *** WAN SVI ***
    bandwidth 256
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    bridge-group 1
    end
    interface BVI1
    description *** WAN BVI ***
    bandwidth 256
    ip address 10.96.0.57 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    service-policy output OUTPUT_QOS_PMAP
    end
    sh policy-map interface
    BVI1
      Service-policy output: OUTPUT_QOS_PMAP
        queue stats for all priority classes:
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
        Class-map: VOIP_RTP_TRUST_CMAP (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp ef (46)
            0 packets, 0 bytes
            5 minute rate 0 bps
          Priority: 56 kbps, burst bytes 1500, b/w exceed drops: 0
        Class-map: VOIP_CTRL_TRUST_CMAP (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp cs3 (24)
            0 packets, 0 bytes
            5 minute rate 0 bps
          Match: ip dscp af31 (26)
            0 packets, 0 bytes
            5 minute rate 0 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          bandwidth 2% (5 kbps)
        Class-map: INETWORK-CTRL-CMAP (match-any)
          6 packets, 896 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp cs6 (48)
            6 packets, 896 bytes
            5 minute rate 0 bps
          Match: access-group name IKE
            0 packets, 0 bytes
            5 minute rate 0 bps
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops) 5/0/0
          (pkts output/bytes output) 6/1120
          bandwidth 5% (12 kbps)
        Class-map: class-default (match-any)
          11 packets, 660 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
          Queueing
          queue limit 64 packets
          (queue depth/total drops/no-buffer drops/flowdrops) 10/0/0/0
          (pkts output/bytes output) 11/660
          Fair-queue: per-flow queue limit 16
            Exp-weight-constant: 9 (1/512)
            Mean queue depth: 0 packets
            class     Transmitted       Random drop      Tail/Flow drop Minimum Maximum Mark
                      pkts/bytes    pkts/bytes       pkts/bytes    thresh  thresh  prob
            0              11/660             0/0              0/0                 20            40  1/10
            1               0/0               0/0              0/0                 22            40  1/10
            2               0/0               0/0              0/0                 24            40  1/10
            3               0/0               0/0              0/0                 26            40  1/10
            4               0/0               0/0              0/0                 28            40  1/10
            5               0/0               0/0              0/0                 30            40  1/10
            6               0/0               0/0              0/0                 32            40  1/10
            7               0/0               0/0              0/0                 34            40  1/10
    BUT! Until service-policy is on interface works nothing.
    sh int bvi1
    BVI1 is up, line protocol is up
      Hardware is BVI, address is 0025.454a.940d (bia 0024.c495.6780)
      Description: *** WAN BVI ***
      Internet address is 10.96.0.57/24
      MTU 1500 bytes, BW 256 Kbit/sec, DLY 5000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input never, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 74
      Queueing strategy: Class-based queueing
      Output queue: 33/1000/0 (size/max total/drops)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         0 packets input, 0 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         114 packets output, 11034 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 unknown protocol drops
         0 output buffer failures, 0 output buffers swapped out
    ping 10.96.0.1 source bvi1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.96.0.1, timeout is 2 seconds:
    Packet sent with a source address of 10.96.0.57
    Success rate is 0 percent (0/5)

  • Service-policy output statement interface vs interface .500 point-to-point

    We are running AutoQoS but have recently migrated our WAN service that puts our IP connectivity to a sub-interface (interface serial0/1:0.500 point-to-point and a frame-relay interface-DLCI). In our prior WAN configuration we bound the IP address directly to the interface s0/1:0.
    After the migration, the auto qos statement service-policy output AutQoS is still on the interface serial 0/1:0 . Should this service-policy statement be moved down to the serial 0/1:0.500 point-to-point in order to be effective? We have been experiencing QoS problems but I understand it could be many different places, but I wanted to start here.
    Thanks
    ryan

    as a rule those are applied in a frame relay policy map.
    Create the LLC policy
    Create the Frame Relay Policy map (and refer to the LLC policy map in the Frame Relay Config)
    Apply the Frame Relay Policy Map to the subinterface (to the DLCI).

  • Service policy counters not working..

    I have a service policy on a 6509 interface so I can see what the packets per second of a video stream coming out of a DVR (digital video recorder) is. This DVR has 16 security cameras attached and I'm concerned that when someone views all 16 cameras the video stream is going to be huge.
    So I create a service policy to match an access list for all IP from the DVR. But no counters increment unless I add in some other match statement. I added in a match protocol telnet and the service policy counters started to work. I removed the match on telnet and the counters stopped. Telnet has nothing to do with the DVR. Here is the config of the class map, policy map and show commands: (By the way video is streaming through this interface continually during this excercise)
    MATCHING ACCESS LIST ONLY:
    class-map match-any DVR
    match access-group 130
    policy-map DVR-test
    class DVR
    ROC-6509-DU-A#sh access-list 130
    Extended IP access list 130
    10 permit ip host 164.72.2.125 any
    ROC-6509-DU-A#sh policy-map int
    GigabitEthernet2/5
    Service-policy output: DVR-test
    Class-map: DVR (match-any)
    0 packets, 0 bytes
    30 second offered rate 0 bps
    Match: access-group 130
    0 packets, 0 bytes
    30 second rate 0 bps
    Class-map: class-default (match-any)
    0 packets, 0 bytes
    30 second offered rate 0 bps, drop rate 0 bps
    Match: any
    ADDING IN TELNET:
    class-map match-any DVR
    match access-group 130
    match protocol telnet
    policy-map DVR-test
    class DVR
    ROC-6509-DU-A#sh policy-map int
    GigabitEthernet2/5
    Service-policy output: DVR-test
    Class-map: DVR (match-any)
    524025 packets, 70724866 bytes
    30 second offered rate 3991000 bps
    Match: access-group 130
    523896 packets, 70689220 bytes
    30 second rate 3991000 bps
    Match: protocol telnet
    129 packets, 35646 bytes
    30 second rate 0 bps
    Class-map: class-default (match-any)
    18696 packets, 11180265 bytes
    30 second offered rate 129000 bps, drop rate 0 bps
    Match: any
    If I remove the 'match protocol telnet' and clear the counters, no longer do the counters for the access-list 130 increment - put back in match telnet and they start to increment.
    This is a Sup720 with IOS 12.2(18)SXE3
    Is this a bug or do I not have my class map or policy map correct?

    The hardware ASICs do not support collecting the individual policer information.
    Try:
    http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/1216ea1/3550scg/swqos.htm#xtocid1990743

  • Assign QoS Service Policy via RADIUS to Catalyst 45k/37k?

    hi,
    is there a way to assigen a QoS service policy via Radius to an Caltalyst 4500/3750 Switchport?
    in detail, we would like to assign this policy
        policy-map SET_EF
         class class-default
           set dscp ef
    to an interface. All traffic should be marked with a defined DSCP value.
    This works find when doing it statically with
        interface FastEthernet2/1
             service-policy input SET_EF
    but we would need to assign such a policy via Radius during the 802.1x Authentication. different users should get differnt policies. We use Cisco ACS 5.2 as Radius Server and there actually is a field for
    that in the Authorization Profile Common Tasks Configuration. in detail, this uses the cisco-av-pair "sub-policy-In=<policy name>" attribute to assign a service policy to an NAS.
    we found also two other attributes "sub-qos-policy-in" and "ip:sub-qos-polcy-in" for that. CCO says that "ip:sub-qos-polcy-in" works with Catalyst 65k (http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/qos.html#wp1926523)
    unfortunately this seems to not work on Catalyst 45k and 37k.
    In the ACS Logs we can see that these attributes are attached to the Radius Reply, but unfortunately they are ignored by the switch.
    it is interesing that when entering "show aaa attributes" on the Catalyst 45k, these attributes are displayd - so for my understanding the switch should understand these attibutes (?)
        4503-E#sh aaa attributes
        AAA ATTRIBUTE LIST:
            Type=1     Name=disc-cause-ext                 Format=Enum
            Type=2     Name=Acct-Status-Type               Format=Enum
        <snip>
            Type=345   Name=sub-policy-In                  Format=String
            Type=346   Name=sub-qos-policy-in              Format=String
            Type=347   Name=sub-policy-Out                 Format=String
            Type=348   Name=sub-qos-policy-out             Format=String
    any input is welcome :-))
    best reagrds

    additionally to this discussion, i've just opened a service request with TAC.
    unfortunately the engineer told me that by now per-User QoS is definitely no supported on this two plattforms but it's listed on the roadmap and will be possibly availabe mid 2012......

  • Policy-map input on an interface VLAN

    Hi there,
    I have a problem with a policy-map on an interface VLAN on my Cisco 6509-E.
    The switch has the IOS Version 12.2(33)SXI10, RELEASE SOFTWARE (fc2).
    I have configured this policy-map:
    policy-map PM-10Mbit
      class class-default
       police cir 10000000 bc 1875000 be 3750000    conform-action transmit     exceed-action drop     violate-action drop
     I bind this map on a physical interface
    interface GigabitEthernet2/2
     description <removed>
     ip vrf forwarding <removed>
     ip address <removed>
     ip access-group <removed> out
     service-policy input PM-10Mbit
     service-policy output PM-10Mbit
    and get this result:
    show policy-map interface
    GigabitEthernet2/2
      Service-policy input: PM-10Mbit
        class-map: class-default (match-any)
          Match: any
          police :
            10000000 bps 1875000 limit 1875000 extended limit
          Earl in slot 5 :
            6428065284 bytes
            5 minute offered rate 14696 bps
            aggregate-forwarded 6294160565 bytes action: transmit
            exceeded 133904719 bytes action: drop
            aggregate-forward 584 bps exceed 0 bps
      Service-policy output: PM-10Mbit
        class-map: class-default (match-any)
          Match: any
          police :
            10000000 bps 1875000 limit 1875000 extended limit
          Earl in slot 4 :
            10335145381 bytes
            5 minute offered rate 21536 bps
            aggregate-forwarded 10142894661 bytes action: transmit
            exceeded 192250720 bytes action: drop
            aggregate-forward 128 bps exceed 0 bps
          Earl in slot 5 :
            263335780 bytes
            5 minute offered rate 176 bps
            aggregate-forwarded 263335780 bytes action: transmit
            exceeded 0 bytes action: drop
            aggregate-forward 448 bps exceed 0 bps
    But when I bind it on an interface VLAN i see no incoming traffic:
    show policy-map interface
     Vlan1012
      Service-policy input: PM-100Mbit
        class-map: class-default (match-any)
          Match: any
          police :
            100000000 bps 18750000 limit 18750000 extended limit
          Earl in slot 4 :
            0 bytes
            30 second offered rate 0 bps
            aggregate-forwarded 0 bytes action: transmit
            exceeded 0 bytes action: drop
            aggregate-forward 0 bps exceed 0 bps
          Earl in slot 5 :
            0 bytes
            30 second offered rate 0 bps
            aggregate-forwarded 0 bytes action: transmit
            exceeded 0 bytes action: drop
            aggregate-forward 0 bps exceed 0 bps
      Service-policy output: PM-100Mbit
        class-map: class-default (match-any)
          Match: any
          police :
            100000000 bps 18750000 limit 18750000 extended limit
          Earl in slot 4 :
            1005376843668 bytes
            30 second offered rate 33016448 bps
            aggregate-forwarded 1005362388151 bytes action: transmit
            exceeded 14455517 bytes action: drop
            aggregate-forward 30943792 bps exceed 0 bps
          Earl in slot 5 :
            1828318775 bytes
            30 second offered rate 1296 bps
            aggregate-forwarded 1828318775 bytes action: transmit
            exceeded 0 bytes action: drop
            aggregate-forward 1272 bps exceed 0 bps
    Is this a bug or am I doing something wrong here?

    Hello
    As I understand it , this is command is required in mls qos because on a SVI ( L3 vlan interface) runs in a vlan-based mode which differs from normal L3 routed interfaces which run in interface mode.
    As per cisco ="In VLAN-based mode, the policy map that is attached to the Layer 2 interface is ignored, and QoS is driven by the policy map that is attached to the corresponding VLAN interface."
    Lastly regards
    Try matching on all traffic incoming on the trunk interface on that switch for it to successfully police incoming traffic:
    class-map V102
    match input-interface x/x
    Policy-map POLICE
    class V102
    Police xxxx xxxx
    res
    Paul

  • Error while applying the Service Policy

    Hi,
    I am getting the below error while applying the service policy to the Interface.
    I have set the mpls exp 4 as well as want to limit the bandwidth to 1Mbps
    PE#sh policy-map setexp-GBoIP
      Policy Map setexp-GBoIP
        Class GBoIP-traffic
          set mpls experimental imposition 4
         police cir 1024000 bc 32000
           conform-action transmit
           exceed-action drop
    PE(config-if)#int vlan 2007
    PE(config-if)#service-policy input setexp-GBoIP
    QoS-ERROR: Addition/Modification made to policymap setexp-GBoIP and class GBoIP-traffic is not valid, command is rejected
    As well as I have created new clas--map with priority and Bandwidth and applied in output direction, I got the belwo error while applying the Service policy in
    PE(config-if)#service-policy out TEST
    bandwidth command is not supported in output direction for this interface
    PE(config-if)#service-policy output TEST
    priority command is not supported in output direction for this interface
    Any idea why so ?
    Thanks in Advance.
    Regards,
    Nilesh

    Check the current value of IGW_AWARDS_S sequence and make sure the MINVALUE in the patch (i.e. 10000) is not greater than the current one.
    OERR: ORA 4007 MINVALUE cannot be made to exceed the current value (Doc ID 19824.1)
    You may also log a SR.
    Thanks,
    Hussein

  • Why doesn't "show service-policy url-summary" work?

    Does any one know -- At Cisco Live this year -- this command was shown as an Option to see the number of
    hits on L7 class maps urls.
    It's not an option for me:  Running A3 (2.5)
    Thanks,
    From A2 documentation  (maybe this command was dropped from A3 -- but that would be unfortunate)
    To display the statistics for all policy maps or a specific policy map that is currently in service, use the show service-policy command. This command also allows you to display statistics for a specific class map in a policy or the hit counts for match HTTP URL statements in a Layer 7 HTTP policy map. If you do not enter an option with this command, the ACE displays all enabled policy statistics.
    show service-policy [policy_name [class-map class_name]] [detail | summary | url-summary] [|] [>]
    Syntax Description
    policy_name
    (Optional) Identifier of an existing policy map that is currently in service (applied to an interface) as an unquoted text string with a maximum of 64 alphanumeric characters. If you do not enter the name of an existing policy map, the ACE displays information and statistics for all policy maps.
    class-map class_name
    (Optional) Displays the statistics for the specified class map associated with the policy.
    detail
    (Optional) Displays a more detailed listing of policy map or class map statistics and status information.
    summary
    (Optional) Displays a summary of policy map or class map statistics and status information.
    url-summary
    (Optional) Displays the number of times that a connection is established based on a match HTTP URL statement for a class map in a Layer 7 HTTP policy map.
    The URL hit counter is per match statement per load-balancing Layer 7 policy. If you are using the same combination of Layer 7 policy and class maps with URL match statements in different VIPs, the count is combined. If the ACE configuration exceeds 64K URL and load-balancing policy combinations, this counter displays NA.

    Hi Dan,
    The url-summary has only been added to the ACE module code at this time.  The A2 code train is only for the module, while the A3 train is only for the appliance.  The good news is that later this year, we will have a new software coming out (A4) that will be the exact same image that can be loaded on either the module or the appliance, hence all functionality will be the same for both (except the acceleration and optimization that only the appliance will support.
    Hope this helps,
    Sean

  • Policy map/ class map/ service policy for IOS xr

    Hi,
    I need to create a policy map and class map/service policy to limit the amount of bandwidth that can be used on one interface both in and out.
    I need the cap for the bandwidth to traverse this circuit to ne 10 Meg.
    the IOS xr version we are using is 4.3.4
    I was hoping someone could help me out by giving me a configuration example I could follow.
    Thank you.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

  • My attachments won't attach???

    My e-mail attachments won't attach. After a long wait while trying to attach, I get a message that allows me to try again. If I select "switch" and retry, the attachment takes. The process is very slow. How may I fix this?

    Please follow these directions to delete the Mail "sandbox" folder.
    Back up all data.
    Triple-click the line below to select it:
    ~/Library/Containers/com.apple.mail
    Right-click or control-click the highlighted line and select
    Services ▹ Reveal
    from the contextual menu.* A Finder window should open with a folder named "com.apple.mail" selected. If it does, move the selected folder — not just its contents — to the Desktop. Leave the Finder window open for now.
    Quit and relaunch Mail, and test. If the problem is resolved, you may have to recreate some of your Mail settings. You can then delete the folder you moved and close the Finder window. If you still have the problem, quit Mail again and put the folder back where it was, overwriting the one that may have been created in its place. Post your results.
    Caution: If you change any of the contents of the sandbox, but leave the folder itself in place, Mail may crash or not launch at all. Deleting the whole sandbox will cause it to be rebuilt automatically.
    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). In the Finder, select
    Go ▹ Go to Folder...
    from the menu bar, paste into the box that opens (command-V). You won't see what you pasted because a line break is included. Press return.

  • Can't apply service-policy to atm int?

    Attempted to apply service-policy output MPLS-EGRESS to ATM Int:
    class-map match-any GOLD
    match mpls experimental topmost 5
    match ip precedence 5
    class-map match-any BRONZE
    match mpls experimental topmost 3
    match ip precedence 3
    class-map match-any SILVER
    match mpls experimental topmost 4
    match ip precedence 4
    policy-map MPLS-EGRESS
    class GOLD
    priority percent 5
    set mpls experimental topmost 5
    class SILVER
    bandwidth percent 10
    random-detect
    set mpls experimental topmost 4
    class BRONZE
    bandwidth percent 20
    random-detect
    set mpls experimental topmost 3
    class class-default
    set mpls experimental topmost 0
    fair-queue
    random-detect
    interface ATM4/0.102 point-to-point
    description TRUNK LINK TO PE_B
    bandwidth 16000
    ip address xxx.xxx.xxx.xxx 255.255.255.252
    no ip redirects
    no ip proxy-arp
    ip ospf message-digest-key xxx
    no snmp trap link-status
    mpls ip
    pvc PE_B 10/102
    tx-ring-limit 3
    oam-pvc manage
    encapsulation aal5snap
    service-policy output MPLS-EGRESS
    And it *appears* to apply without error, but logs show:
    Jul 28 09:34:32.550 aest: %SCHED-3-SEMLOCKED: Virtual Exec attempted to lock a semaphore, already locked by itself -Traceback= 0x61317864 0x62658A88 0x620F0A4C 0x60DD3668 0x60DD5648 0x6135ABD8 0x61379744 0x62644508 0x626444EC
    Jul 28 09:34:33.870 aest: I/f ATM4/0.102 VC 10/102 class GOLD requested bandwidth 0 (kbps), available only 0 (kbps)
    And ATM4/0.102 does not include the service-policy output MPLS-EGRESS when I do a show run nor when I do a sho policy-map interface?

    Resolved my own issue - I needed:
    vbr-nrt 32000 16000
    under the atm sub int...

  • Service-policy output not working in Cisco 3560 switch

    We got some Cisco catalyst 3560 that we want to control the bandwidth
    on the ports. Can this be done, and how do i do it?
    Ive got 3550s that can do policy-map with the interface command;
    service-policy output(and input) <policyname>
    But 3560 only seems to handle service-policy input.
    If i try to configure output, it says the following:
    SW(config-if)#service-policy output 4mbit-out
    police command is not supported for this interface
    Configuration failed!
    Warning: Assigning a policy map to the output side of an interface not
    supported
    Any workarounds or new ways to accomplish bandwith-control on a 3560 ?
    regards,
    Rajib

    The 3560 & 3750 (& 2960) don't support egress policy-maps. They do however support queueing so it is possible to achieve similar results by applying an ingress policer to your user ports to classify (& police?) the traffic, at the egress port you can then queue the traffic based on it's DSCP or CoS value that it was classified with (same as 3550).
    It is also possible to restrict the bandwidth in use at an egress port with the interface command 'srr-queue bandwidth limit <10-90>' where 10-90 represents a percentage of the links bandwidth. For example if you want to restrict a 100Mbps port to 10Mbps you would use the command 'srr-queue bandwidth limit 10'
    HTH
    Andy

  • Command "service-policy input policy-name permit-any" will not work

    Hi all,
    have a SG500 with latest Firmware, but this command will not work.
    service-policy input QoS_01 permit-any
    i get this error message:
    % Wrong number of parameters or invalid range, size or characters entered
    without the option "permit-any or deny-any" the command is successfully.
    What is the reason?
    It is important, directly to specify this options. Otherwise to lose the access to the switch.
    Regards
    Stefan

    Hi Tom,
    i have a ACL / ACE and create a QoS "policy table" put the "policy class map" (with class mappings) in it.
    And now i will bind this QoS policy to a Ethernet port.
    cli tutorial example say:
    Use the service-policy Interface Configuration (Ethernet, Port-channel) mode command to bind a policy map to a port/port-channel. Use the no form of this command to detach a policy map from an interface.
    This command is only available in QoS advanced mode.
    Syntax
    service-policy input policy-map-name default-action [permit-any | deny-any]
    no service-policy input
    Example:
    witchxxxxxx(config-if)# service-policy input policy1 permit-any
    A cisco support open a ticket for me.
    -Stefan

Maybe you are looking for

  • A perplexing "put" problem... within CS6

    Dear Adobe Community, Recently, I have encountered a problem while trying to "put" files from my local view to the remote server using FTP. While some pages seem to upload successfully and can be seen when I open the internet browser to view my webpa

  • Error displaying when trying to view the screens

    Hi All, when a user is trying to view the screens in the portal he is getting a message saying "wp integration . js could not find capwf_send sess info () to send bbpsc07ssess info to dsm portal dsm - interface might have changed" what settings must

  • Report to display materials and prices

    Hi everyone. Pls. I would like to know if there is a report to display materials and prices, I mean prices from material master accounting view. Thanks a lot.

  • How do I add text to an output of a formula?

    I've tried various scripts to get it work in "Simplified Field Notations". The script below is the only one that doesn't return an error, but I get no output. This one is without a formula script, but I would like to know how to add text to a formuls

  • Video exports without image, just sound

    I'm using photoshop CS6 extended, and i'm trying to put together a 'slideshow' with images in timeline fading in to eachother. I also added an audio clip, an mp3. For some reason, after exporting the video, the mp4 i created has NO images, just the s