SSH and Ping to WAN IP not working correctly.

Hey all!
I've run into an issue that i cant seem to figure out. For some reason i can't SSH to my router, and i also cant ping the WAN IP addresses, which i need for my monitoring service. This ones got me stuck so any help is very much appreciated. Here is my sanitized config. Thanks!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no aaa new-model
dot11 syslog
ip source-route
ip cef
ip domain name xxxxxxx
no ipv6 cef
multilink bundle-name authenticated
voice-card 0
crypto pki token default removal timeout 0
username admin privilege 0 password 7 xxxxxxxxxxxxxxxxx
redundancy
interface FastEthernet0/0
 ip address xx.xx.xxx.xxx 255.255.255.240
 ip access-group OutsideIn in
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
interface FastEthernet0/1
 no ip address
 ip virtual-reassembly in
 duplex auto
 speed auto
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.10.100.60 255.255.0.0
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 10.34.1.1 255.255.240.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.30
 encapsulation dot1Q 30
 ip address 10.60.0.1 255.255.252.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.31
 encapsulation dot1Q 31
 ip address 10.31.1.2 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.32
 encapsulation dot1Q 32
 ip address 10.32.1.2 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.33
 encapsulation dot1Q 33
 ip address 10.33.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.50
 encapsulation dot1Q 50
 ip address 10.50.1.2 255.255.0.0
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.51
 encapsulation dot1Q 51
 ip address 10.51.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.52
 encapsulation dot1Q 52
 ip address 10.52.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.53
 encapsulation dot1Q 53
 ip address 10.53.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 no ip redirects
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.54
 encapsulation dot1Q 54
 ip address 10.54.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 no ip redirects
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.55
 encapsulation dot1Q 55
 ip address 10.55.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 ip nat inside
 ip virtual-reassembly in
interface FastEthernet0/1.56
 encapsulation dot1Q 56
 ip address 10.56.1.1 255.255.0.0
 ip helper-address 10.34.1.7
 no ip redirects
 ip nat inside
 ip virtual-reassembly in
ip forward-protocol nd
ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0/0 overload
ip nat inside source static tcp 10.34.1.155 8020 interface FastEthernet0/0 8020
ip nat inside source static udp 10.34.1.155 8020 interface FastEthernet0/0 8020
ip nat inside source static tcp 10.34.1.155 8025 interface FastEthernet0/0 8025
ip nat inside source static udp 10.34.1.155 8025 interface FastEthernet0/0 8025
ip nat inside source static tcp 10.34.1.165 8030 interface FastEthernet0/0 8030
ip nat inside source static tcp 10.34.1.165 8035 interface FastEthernet0/0 8035
ip nat inside source static udp 10.34.1.165 8035 interface FastEthernet0/0 8035
ip nat inside source static udp 10.34.1.165 8030 interface FastEthernet0/0 8030
ip nat inside source static tcp 10.34.1.156 8010 interface FastEthernet0/0 8010
ip nat inside source static udp 10.34.1.156 8010 interface FastEthernet0/0 8010
ip nat inside source static tcp 10.34.1.156 8015 interface FastEthernet0/0 8015
ip nat inside source static udp 10.34.1.156 8015 interface FastEthernet0/0 8015
ip nat inside source static tcp 10.34.1.3 8061 interface FastEthernet0/0 8061
ip nat inside source static udp 10.34.1.3 8061 interface FastEthernet0/0 8061
ip nat inside source static tcp 10.34.1.3 8062 interface FastEthernet0/0 8062
ip nat inside source static udp 10.34.1.3 8062 interface FastEthernet0/0 8062
ip nat inside source static tcp 10.34.1.3 8063 interface FastEthernet0/0 8063
ip nat inside source static udp 10.34.1.3 8063 interface FastEthernet0/0 8063
ip nat inside source static tcp 10.34.1.3 8064 interface FastEthernet0/0 8064
ip nat inside source static udp 10.34.1.3 8064 interface FastEthernet0/0 8064
ip nat inside source static tcp 10.34.1.3 8065 interface FastEthernet0/0 8065
ip nat inside source static udp 10.34.1.3 8065 interface FastEthernet0/0 8065
ip nat inside source static tcp 10.34.1.3 8066 interface FastEthernet0/0 8066
ip nat inside source static udp 10.34.1.3 8066 interface FastEthernet0/0 8066
ip nat inside source static tcp 10.34.1.7 3389 interface FastEthernet0/0 3389
ip nat inside source static tcp 10.34.2.87 80 interface FastEthernet0/0 80
ip nat inside source static udp 10.34.2.87 80 interface FastEthernet0/0 80
ip nat inside source static tcp 10.34.1.16 80 interface FastEthernet0/0 8045
ip nat inside source static udp 10.34.1.16 80 interface FastEthernet0/0 8045
ip nat inside source static tcp 10.34.1.17 80 interface FastEthernet0/0 8055
ip nat inside source static udp 10.34.1.17 80 interface FastEthernet0/0 8055
ip nat inside source static tcp 10.34.1.18 80 interface FastEthernet0/0 8056
ip nat inside source static udp 10.34.1.18 80 interface FastEthernet0/0 8056
ip route 0.0.0.0 0.0.0.0 (NEXT HOP)
ip access-list extended OutsideIn
 permit ip any host xx.xx.xxx.xxx
 permit ip any host xx.xx.xxx.xxx
 deny   udp any any eq 1723
 deny   tcp any any eq 1723
 deny   udp any any eq isakmp
 deny   tcp any any eq 500
 deny   udp any any eq non500-isakmp
 deny   tcp any any eq 4500
 permit tcp any host (WAN IP) eq www
 permit tcp any host (WAN IP) eq 8010
 permit udp any host (WAN IP) eq 8010
 permit tcp any host (WAN IP) eq 8015
 permit udp any host (WAN IP) eq 8015
 permit tcp any host (WAN IP) eq 8020
 permit udp any host (WAN IP) eq 8020
 permit tcp any host (WAN IP) eq 8025
 permit udp any host (WAN IP) eq 8025
 permit tcp any host (WAN IP) eq 8030
 permit udp any host (WAN IP) eq 8030
 permit tcp any host (WAN IP) eq 8035
 permit udp any host (WAN IP) eq 8035
 permit tcp any host (WAN IP) eq 8045
 permit udp any host (WAN IP) eq 8045
 permit tcp any host (WAN IP) eq 8055
 permit udp any host (WAN IP) eq 8055
 permit tcp any host (WAN IP) eq 8061
 permit udp any host (WAN IP) eq 8061
 permit tcp any host (WAN IP) eq 8062
 permit udp any host (WAN IP) eq 8062
 permit tcp any host (WAN IP) eq 8063
 permit udp any host (WAN IP) eq 8063
 permit tcp any host (WAN IP) eq 8064
 permit udp any host (WAN IP) eq 8064
 permit tcp any host (WAN IP) eq 8065
 permit udp any host (WAN IP) eq 8065
 permit tcp any host (WAN IP) eq 8066
 permit udp any host (WAN IP) eq 8066
 permit ip any any
ip access-list extended nat
 permit ip any any
logging esm config
logging 10.34.1.7
access-list 50 permit (OUR WAN NETWORK) 0.0.2.255
access-list 100 permit ip any any
control-plane
mgcp profile default
line con 0
 logging synchronous
line aux 0
line vty 0 4
 logging synchronous
 login local
 transport input all
line vty 5 988
 logging synchronous
 login local
 transport input all
scheduler allocate 20000 1000
end

  Hardware is MV96340 Ethernet, address is 0022.551a.3b80 (bia 0022.551a.3b80)
  Internet address is XX.XX.XXX.XXX/28
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 4/255, rxload 44/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/1670/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 17259000 bits/sec, 1788 packets/sec
  5 minute output rate 1728000 bits/sec, 1350 packets/sec
     87395905 packets input, 766557199 bytes
     Received 1332539 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 96 throttles
     25676 input errors, 0 CRC, 0 frame, 0 overrun, 25676 ignored
     0 watchdog
     0 input packets with dribble condition detected
     126794802 packets output, 2276449807 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
FastEthernet0/1 is up, line protocol is up
  Hardware is MV96340 Ethernet, address is 0022.551a.3b81 (bia 0022.551a.3b81)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 42/255, rxload 4/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/6376/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1701000 bits/sec, 1317 packets/sec
  5 minute output rate 16522000 bits/sec, 1712 packets/sec
     129134088 packets input, 3150074778 bytes
     Received 1290762 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 383 throttles
     101275 input errors, 0 CRC, 0 frame, 0 overrun, 101275 ignored
     0 watchdog
     0 input packets with dribble condition detected
     87242554 packets output, 1114685246 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     31588 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     1 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Similar Messages

  • HT6114 I just updated the last version of OS X Mavericks on my Mac Pro and my Thunderbolt display is not working correctly

    I just updated the last version of OSX Mavericks on my MAc Pro and my thunder bolt display is not working correctly. Could you please help

    Reset the NVRAM/PRAM and Reset the SMC, then try again.

  • Vista has left the building...and the Recovery Disks do not work correctly.

    I've spent over a month and a half trying to fix my non-booting Satellite A215-S5818 running Vista.  Sometime mid-March (ah, the Ides of March!) I think I downloaded an automatic update and I remember the next time it booted my desktop was black; icons but no background picture.  Then I noticed on the bottom right it was saying my copy of Vista was not genuine.  I know that it is, because it is pre-installed.  So I ran check disk from the Properties page of C: in Windows Explorer. After it ran, I got BSOD.  At first I just booted into SafeMode and tried to disable whatever hardware/uninstall whatever software was causing the problem.  I think I got it to boot in SafeMode once or twice, then no more.  For a while I kept getting IRQL-NOT-LESS-OR-EQUAL, but I somehow stopped that through the command prompt(forum advice?).  Startup Repair could not fix it,  System Restore would not work on ANY restore points, even before March. The new BSOD error was:
    "STOP: c000021a {Fatal System Error}-
    The initial session process or system process terminated unexpectedly with a status of 0x00000000 (0xc0000221 0x00100594)"
    From then on I could only get a command prompt through the Repair Console.  So I xcopy-ed my Users directory to an external hard drive and grudgingly booted from the Toshiba CD, knowing it would obliterate everything, but I was desperate.  I got the 03-EEEE-0000 error.  Now I have a plethora of useless(?) CDs and DVDs I have burned ISO images on of any Freeware I thought could fix it, downloaded from the Internet using my husband's Windows 7 desktop computer.  I followed these instructions to the letter and it worked (I guess; it started immediately, no DOS objection), but when it rebooted I got a window (!) saying something about the type of hardware.  I haven't added or changed any hardware, but I have updated the BIOS recently.  So I clicked OK (no other choice), and now every boot up I get a window saying "Windows could not complete the installation.  To install Windows on this computer, restart the installation".  Startup Repair does not find any problems.  Could it be the BIOS?  I have re-flashed it twice, no difference.

    Oops! Sorry that was stupid on my part.
    From the command prompt you could type in   systeminfo   , and hit the 'Enter' key, it will take a little while to run, when it finishes, scroll back up to the top and you'll see OS Version and Service Pack you've got loaded. But, if you're booting off the recovery disk, that's the system info you'll get.
    If you can't get to the command prompt from the Advanced Boot Options menu, by trying to boot off the hard drive, and pressing F8, I'm not sure how you can find what Service Pack you have loaded.
    By using the Recovery Boot Disk, have you exhausted all the recovery options that Jerry linked before?
    What are the system recovery options in Windows Vista?
    How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair start...
    Mike

  • Firefox 4.1 and Firefox 11.1 do not work correctly on my systems

    <pre><nowiki>From : <[email protected]>
    To : support.mozilla.com
    Subject : Firefox Version 11.1 Does Not Work for Me
    Date : Sat, 24 Mar 2012 18:45:39 GMT
    Spell Check in your version 11.1 is just as impeding in my three systems as was 4.1.
    (Note the string below.) I have returned to 3.6.28, and will refuse to upgrade your
    program in the future until Mozilla can demonstrate that the newer versions will not
    impede when the user attempts to spell check in email.
    Thank you.
    [email protected]
    From : [email protected]
    To : [email protected]
    Subject: Please confirm your email address
    Date: Fri, May 06, 2011 11:21 AM
    Welcome to support.mozilla.com.
    Before you can use your new account you must activate it -
    this ensures the e-mail address you used is valid and belongs
    to you. To activate your account, click the link below or
    copy and paste the whole thing into your browser's location bar:
    https://support.mozilla.com/en-US/users/activate/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    Once you've successfully activated your account, you can throw
    away this e-mail.
    Thanks!
    The support.mozilla.com team
    Downloading the new Version 4 stripped out my dictionary, so none of my email send.
    What's
    up with that?
    You can see which dictionary is selected if you right-click in a text area and open the
    Languages submenu.
    You can open the "Add Dictionaries" link to install a dictionary if you do not
    have one.
    Make sure that [X] "Check Spelling" in the right-click context menu has a tick.
    You can enable or disable spell checking globally:
    Firefox > Preferences > Advanced : General: Browsing: "Check my spelling
    as I type"
    See also:
    http://kb.mozillazine.org/Spell_checking
    KingGhidorah 1 solutions 1 answers
    1 month ago
    https://addons.mozilla.org/en-US/firefox/addon/united-states-english-spellche/
    Added this and it works (again) like a charm.
    From : [email protected]
    To : [email protected]
    Subject: Solution found to Firefox Help question
    Date: Fri, May 06, 2011 12:27 PM
    Hi mjattie,
    We just wanted to let you know that KingGhidorah
    has found a solution to a Firefox question that you're following.
    The question:
    Spell checker not working since FF 4 was marked as solved by its asker, djf42.
    You can view the solution using the link below.
    Did this answer also help you? Did you find another post more
    helpful?
    mjattie: No!!
    Let other Firefox users know by voting next to the answer.
    https://support.mozilla.com/questions/800727#answer-162639
    Unsubscribe from these emails:
    https://support.mozilla.com/unsubscribe/385490?s=xxxxxxxxxx
    mjattie: Nope! Still does not work. I am running XP Might that be the problem?
    djf42: Sorry my suggestion hasn't worked for you. Not being a computer wizz can't help
    you further.
    Perhaps the back room boys at FF can step in and help, I'm sure that they wouldn't want
    you to go backwards in the versions.
    mjattie: I was perfectly happy with 3.6.17 (all of the 3s by the way.) How do I get in
    touch with the back room boys at FF?
    From : [email protected]
    To : [email protected]
    Subject: Reply: Solution found to Firefox Help question
    Date: Sat, May 07, 2011 11:47 PM
    Date: Sun, 8 May 2011 06:46:44 GMT
    From : [email protected]
    To : [email protected]
    Subject: Re: Reply: Solution found to Firefox Help question
    Date: Sun, May 08, 2011 11:51 AM
    Hi, djf42. I have found the 3.6.17 installer, have reinstalled it, and I am now
    perfectly happy.
    One of these days, Mozilla will come out with 4.02 with this problem fixed (hopefully).
    I will
    then give it a try. Thanks for your help.</nowiki></pre>

    This problem occurs on the Juno webmail site?
    I assume you are doing something different than just correcting the squiggly red underlined words. How are you spell-checking the email: using an add-on or using a feature of the Juno webmail site? If it's an add-on, which one is it?

  • Word documents (New and Existing) paper area does not work correctly

    Hello all. I have a rather hard to explain situation with one of our workstations. It is an HP 8760w and it has had Office 2010 installed on it for quite some time. Currently, when opening a new document or any existing document, the program will look normal
    but will not show a cursor on the page. Scrolling wll result in the page looking obscure as if a graphics inside the document stops working. Scrolling will cause lines of text to melt into each other and will duplicate lines of text. The ribbon functions fine
    and hitting File brings up the entire menu like it should. Switching back to the document will show what was over that section in the file menu. How do I fix this? Installing and uninstalling office did not work along with changing the Normal.dot and deleting
    the Data registry file. 
    All help is appreciated greatly. 

    Hi Travis,
    This sounds more like a Graphic Driver or Graphics Card problem. You might try switching out the Graphic Card if that is possible on the system.
    Another outside possibility might be a corrupt user profile, so you could create a different profile on the machine and try it. However, my guess would be the Graphics Card is failing.
    Are you also certain there are no other Office add-ins loaded that might be causing this. Start Word in Safe Mode and see if this clears the problem. If it does, then systematically disable add-ins one at a time until the culprit is found.
    Hope this helps
    Kind Regards, Rich ... http://greatcirclelearning.com

  • Just did security update and restated now monitor is not working correctly

    Just did the latest security update (didn't catch the specific number), restarted my 1.83 GHZ macbook white, intel chip. Running 10.4.11.
    Monitor from has what appears to be scan lines at the bottom and are slowly creeping up the screen!
    Any help would be appreciated, don't know if I can undo the update somehow, or if it is a driver conflict?

    does an external monitor work(with descrete or optimus only since integrated doesnt drive the panel), if so, then it might be a display issue. if not, then check resolution and refresh rate.
    looks kind of like my monitor did when the resolution was wrong(computer tried 1366x768 on an FHD display)
    W530(2436-CTO): i7-3720QM, nVidia Quadro K2000M,16GB RAM, 500 GB hard drive, 128GB mSATA SSD, Ubuntu 14.04 Gnome, Centrino Ultimate-N 6300.
    Yoga 3 Pro: Intel Core-M 5Y70, Intel HD 5300, 8GB RAM, 128GB eMMC, Windows 8.1, Broadcom Wireless 802.11ac.

  • After a software update why doesnt the under armour website and a few other still not work correctly?

    the pictures don't want to be "active" when you highlight or click  the colors, the color should change and they don't.  Also if i click on  the item and go into its own section the pictures don't come up.  I also  cannot select a size of the item or add to cart(says error adding).  This is one of the few that does it.  Some other websites will not play videos, it acts like there is no media to be played when this happens as the area is boxed off but the box stays completely blank.  i have  upgraded to mavericks today, i have reinstalled java, i have reinstalled  browsers(it is the same across all browsers) any ideas of the culprit?   it does work on mac(as i have another startup disk it works fine on.  the problem is none of my information is on that hard drive(pictures,  itunes data, etc)

    Hey, guys, I have solved my own problem.
    I unplugged the Apple TV (there is no off switch) and let it rest overnight.  When I plugged it in again, it re-booted (I suppose) and, anyway, Airplay works now.
    Ralph aka beppi6

  • I have iphone 5 And my phone icon is not working correctly

    I have a iPhone 5 and I am having an problem with it that when I click on phone App and it doesn't work for example I have an pre paid sim and when I enter that pin then it doesn't work I hope you guys can help me solve my. Problems thanks

    We're all in the same boat, more or less. iOS 8.1 was supposed to fix Bluetooth issues (among other things) that appeared with the release of iOS 8.0.1 that iOS 8.0.2 didn't fix, and, well, they're still there...
    A fix is probably on the way, already, but when will Apple release it, no one know...

  • Help! Working with Kethley GPIB and NI DIO-24 does not work correctly.

    Who encounter the same problem ?
    tahnks a lot david.

    If you are using LabVIEW Instrument Drivers, the following KnowledgeBase may be useful to you: http://ae.natinst.com/operations/ae/public.nsf/fca7838c4500dc10862567a100753500/3aa9f0de80c495d386256b98005efba7?OpenDocument.
    However, if that is not helpful, I would suggest contacting Keithley for help. It sounds as though the driver for the card may not be compatibable with the Instrument Driver and you may need to do additional programming. Good luck!
    -Heather S.
    Applications Engineer
    National Instruments

  • My mouse is not working correctly after upgrade to ITunes 11

    I upgraded to iTunes 11 for WinXP and now my mouse is not working correctly. No double clicks, no right button function and sometimes refuses to do simple left click options. What can I do?
    I've tried new mouse drivers and checking the settings in Control Panel but no joy so far.
    Driving me mad and taking me three times longer to do anything as I look for keyboard solutions.

    I'm facing the same problem too on Windows 8. No mouse clicks (just 'ding' sound whenever trying to click anything).
    I could work around it on Windows 8, but ultimately have to restart my PC to get back mouse functionality.
    I wasn't quite sure which app is to blame, but ultimately concluded it's iTunes 11. As this behaviour always concided with having iTunes running in the background for 15-20 minutes (usually listening to podcasts) and never seems to happen when iTunes 11 isn't running.
    Don't know what to make of this, I'm currently playing my podcasts through Windows Media Player instead. I'll hopefully try running iTunes 11 in Windows 7 Compatibiliy mode to see if that helps.

  • Hi Guys,  I am using the full width video widget on a site. The widget was working perfectly however I have just added additional content to the site and re-uploaded and now the video is not working! Please help I have tried everything and am freaking out

    Hi Guys,
    I am using the full width video widget on a site. The widget was working perfectly however I have just added additional content to the site and re-uploaded and now the video is not working! Please help I have tried everything and am freaking out as this web-site has been payed for by my client.
    Alex

    Many thanks.
    With those symptoms, I'd try the following document:
    Apple software on Windows: May see performance issues and blank iTunes Store
    (If there's a SpeedBit LSP showing up in Autoruns, it's usually best to just uninstall your SpeedBit Video Accelerator.)

  • Read Only Display of Radio group and Text area with counter not working

    Hello,
    I am using Apex 3.2, with 10g for the database
    I have this form, with fields that will set to read only when status = 'closed'
    All of the fields display as read only except for 2. I cannot figure out why this is not working correctly.
    1st field is Issues that is a text area with character counter, with a sql query behind it, that is set to null unless the query is pulling in the data.
    2nd field is Status which is a radio group that will not display as read only when status = 'closed'
    I have other fields on the form with the same format and they change to read only when the status = 'closed', I have even copied the pl/sql expression from one field to these fields and it still doesn't work correctly. I have also tried javascript for an on load event, which works, but once I click on the save button, it disables all of the page items, which works correctly, but I purposely forget to enter information, to make sure the validations are firing correctly, which it does, but the script disables everything, not allowing me to correct the errors. The javascript is firing on the on page load event.
    Any help on this is greatly appreciated.
    Mary

    Dung,
    That API seems to have a bug, it returns true/false/null, so you could use 'return not nvl(htmldb_util.current_user_in_group(p_group_name => 'APP Admin'),false)' to get a false value.
    Unfortunately there's another problem: using the read-only attributes for checkbox or radiogroup item makes them hidden. My suggestion would be to create another item that has disabled="disabled" in the HTML Form Element attribute in the item definition and display that item or the non-disabled item alternately, using conditions based on the current_user_in_group logic.
    Scott

  • Why cant I add contacts on the iphone4? the mail contacts calendars button unders settings, the contacts button, the add a contacts button under message and the phone button will not work to add a contact.

    Why cant I add contacts on the iphone4? the mail contacts calendars button unders settings, the contacts button, the add a contacts button under message and the phone button will not work to add a contact.

    Have you attempted a restore?

  • HT3887 my bluetooth says 'Not Available' how do i get it to work again. I have restarted the computer several times and have replaced the batteries in both the keyboard and mouse and yet it still is not working! please help

    my bluetooth says 'Not Available' how do i get it to work again. I have restarted the computer several times and have replaced the batteries in both the keyboard and mouse and yet it still is not working! please help

    I have had the same problem. It was cured by turning computer off and/or restarting it. I am not sure  if once was enough. I think shutting down must cut out whatever it is that blocks bluetooth. Good luck

  • I have iphone 4s and just bought an ebook for ibook, trouble is the font is so tiny I can't read it and the font sizer is not working? Please help!

    Hi, I have the  iphone 4s and just bought an ebook for ibook, trouble is the font is so tiny I can't read it and the font sizer is not working? Please help!

    Hello Glittergirl68,
    Thank you for using Apple Support Communities.
    It sounds like the function to reseize the Font in an iBook is not functioning properly.
    I recommend a few things here. First close all the apps that are running in the background:
    Double-click the Home button.
    Swipe left or right until you have located the app you wish to close.
    Swipe the app up to close it.
    From: iOS: Force an app to close
              http://support.apple.com/kb/ht5137
    When you have done that, restart the phone, and try again.
    If the issue persists, I would follow these steps from the article:
    iOS: Troubleshooting apps purchased from the App Store
    http://support.apple.com/kb/TS1702
    2. Check for app updates
    You can setup apps to update automatically in Settings > iTunes & App Store, but make sure that your apps are up to date:
    Open the App Store and tap Updates. If updates are available, tap Update All.
    If  prompted, enter your iTunes Store account information. App Store will then download and install the app updates.
    Note: Some apps may require a Wi-Fi connection to update.
    3. Install another app from the App Store
    If none of your user-installed apps will launch, there could be an issue with Apple ID authorization. Download and install an app that isn't already installed on your device to reset this information. You can also remove an app from your iOS device and download it again from the App Store or sync the app from your computer.Note: If you have installed apps using multiple Apple ID accounts, you may need to perform this step for each account.
    4. Restart the app
    If the issue affects only a single app, try closing just that app.
    5. Restart your device
    Turn the device off and on.
    6. Reinstall the affected app
    Remove the app from your device and reinstall it:
    Tap and hold any app icon on the Home Screen until the icons start to wiggle and show a small "x" in the top-right corner of the app.
    Tap the "x" in the corner of the app you want to delete.
    Tap Delete to remove the app and all of its data from your device.
    Press the Home button.
    Go to the App Store.
    Search for the app and then download it again.
    All the very best,
    Sterling

Maybe you are looking for

  • [JS][CS3] Socket and IP Addresses

    First, let me say that I'm developing an Illustrator CS3 solution, but the Bridge forum seems to be more alive, and the issue seems to be common for all CS apps. I need to somehow obtain and then store in a text file an identifier of a computer acces

  • How to display the bw-variables in webi Filter

    Hi,everyone,      When I  set default values ( ex. last month ) to BW-variables in the BW enhanmance, this default valuse can not display in webi. I use the routing: BW-QUERY --> Universe --> webi. So I hope to display the BW-variable in the Webi fil

  • Can I import video from an unprotected dvd?

    I have videos of concerts for the group I sign with, and I wanted to download them into Idvd to make some editing. Is that possible?

  • SCCM 2012 Client was removed but SCCM console still showing the status as "Yes"

    Hi, In a VM, SCCM 2012 client agent was removed and the VM was reverted back to a clean machine. SCCM console still shows the status as "Yes" even after the client agent was removed. Heartbeat Discovery is set to run every 1 hour. Please guide on thi

  • Installing Bi content errors

    Hi, I am trying to install Bi content and i get many errors, can someone tell me what this means and the solution to it, Characteristic 0soursystem must equally be a navigational attribute of  charac  0asset characteristic 0asset: attribute 0plant co