Stacking openvpn connections with systemd

I have many openvpn servers,I am trying to stack multiple openvpn connections one though the other, that is I want tun1 to go through tun0. If I enter the commands in order and wait for the interfaces to come up before proceeding, it works. I switch servers, and order of servers, several times a day. I am trying to get this automated. As i can not risk having any data sent over non tunneled channels, I cannot automate much of my system until this is. My problem is that I pull the routing table from the servers that sends my traffic through the tunnel, if i
systemctl start openvpn@(Server1Name)
systemctl start openvpn@(Server2Name)
this will start the Server2 before Server1 is connected and the tun0 interface is up, resulting in 2 interfaces but each connected directly to the Internet.Reading the man systemd.unit i found the "Before= and After=" but i am unsure of how to use these correctly as I switch servers(and ordering) multiple times a day.I have a script that can randomly select the server the next server for me. What i am really hoping for is a way to have systemd only start the next openvpn tunnel after the previous tun[n] interface is up. that is
script picks next random server
start next server
if tun[n] up then n+=1
loop until n = current paranoid level
Why not just put this in a script and run it after startup? Because I need all traffic to go through these tunnels. and not having this at boot means that i cannot have systemd start any network applications(I have a lot). Also but not as important, is it is nice to have the Internet ready to go after boot up.

You have your own answer
tsr-nc wrote:Reading the man systemd.unit i found the "Before= and After="
Yes, that way.
copy the /usr/lib/systemd/system/[email protected] to /etc/systemd/system, for each connection you have. and don't forget to name them with different name, like /etc/systemd/system/ovpn1.service, /etc/systemd/system/ovpn2.service, etc
Edit every one of those files, setting both After and Requires putting them in order. and change the %i to be the name of the conf file.
...Not sure why you are doing such thing, I don't think that makes it more secure or anything.

Similar Messages

  • Support for multiple OpenVPN configurations with systemd

    In Debian I just put the OpenVPN configurations in /etc/openvpn. This makes all of them start automatically at boot time.
    In Arch I tried with
    systemctl start [email protected]
    Where FILENAME is the filename of a OpenVPN configuration in /etc/openvpn. This brings up OpenVPN but it also brings down all other OpenVPN configurations started this way.
    How should I go about solving this, and getting a similar behaviour as in Debian?
    Last edited by 84081 (2013-07-30 09:20:22)

    markus40 wrote:
    With the link named '[email protected]'
    the openvpn config file name must have name '/etc/openvpnFILENAME.conf'
    not '/etc/openvpnFILENAME'.
    With your mail it is not clear if you did this...
    Yeah I'm not having an issue with OpenVPN. Those configurations work well. They also start with systemctl, BUT it's only possible to run one OpenVPN instance at a time through systemd on Arch Linux.
    So my issue is Arch Linux or systemd specific.

  • "stack overflow" when trying to connect with Oracle ODBC

    Hi,
    I'm trying to connect to Oracle DB (8.1.7.3.0) from WinNT 4.0 SP6 with Oracle ODBC driver 8.0.6.6.0. I've been trying to connect with "Oracle ODBC Test" and with "MS Query". In either way I end up with Dr. Watson reporting about "stack overflow". Before starting to upgrade ODBC driver I wanted to ask - should these versions of driver and DB work together at all (even unofficially)? Or may I be missing some other thing? Any hints, ideas are welcome.
    Regards,
    Madis Priilinn

    Thank You for replying, Justin!
    Yes, I can connect successfully to the database through other tools - at the moment I tried SQL*Plus, Net8 Easy Config and Schema Manager.
    The Oracle client in the NT machine is 8.0.5.0.0. And unfortunately I do not know anything about the Oracle installation on this machine and at the moment I don't have that person near me too whom to ask also. But I think the installation was ok, because the connection through ODBC was working before the DB upgrade as far as I understood (sorry, again at the moment I don't know what was the previous version of DB. I will ask that information as soon as possible).
    The main problem that bothers me at the moment is that I can't install 8.1.* series OraODBC driver with 8.0.5.0.0 Oracle Installer. I managed to install 8.0.6.6.0 version of the driver, but not the newer ones. As far as I've understood I have to upgrade the whole Oracle in the NT machine to upgrade that installer. Am I correct?
    Regards,
    Madis Priilinn

  • Challenge: Spanning Tree Control Between 2 links from Switch DELL M6220 to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior like one switch for redundancy)

    Hello,
    I have an Spanning tree problem when i conect  2 links from Switch DELL M6220 (there are blades to virtual machines too) to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior  like one switch  for redundancy, with one IP of management)
    In dell virtual machine is Spanning tree rapid stp, and in 3750 is Spanning tree mode pvst, cisco says that this is not important, only is longer time to create the tree.
     I dont know but do you like this solutions i want to try on sunday?:
     Could Spanning tree needs to work to send one native vlan to negociate the bdpus? switchport trunk native vlan 250
    Is it better to put spanning-tree guard root in both 3750 in the ports to mitigate DELL to be root in Spanning Tree?
    Is it better to put spanning- tree port-priority in the ports of Swicht Dell?
    ¿could you help me to control the root? ¿Do you think its better another solution? thanks!
     CONFIG WITH PROBLEM
    ======================
    3750: (the 2 ports are of 2 switches 3750s conected with a stack cable, in a show run you can see this)
    interface GigabitEthernet2/0/28
     description VIRTUAL SNMP2
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     logging event trunk-status
     shutdown
    interface GigabitEthernet1/0/43
     description VIRTUAL SNMP1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     shutdown
    DELL M6220: (its only one swith)
    interface Gi3/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit
    interface Gi4/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

  • SGE2010: stack member reboots with 'Lost connection with unit x reason 0x20097'

    Hi All,
    Over the last 2 months we've had repeated issues with SGE2010 units in a stacking configuration rebooting randomly.
    Prior to a member reboot occuring we see the following logging message via SNMP Trap on on the unit's internal logging via the GUI:
    'Lost connection with unit x reason 0x20097'
    We've made attempts at consulting Linksys/Cisco support regarding this 'feature' but aren't really getting anywhere with 1st level support who don't seem to understand much about supporting the device.
    The layout is thus:
    * 3 x SGE2010 units all of the same firmware version (3.0.1.0)
    * Stack configured in a ring topology
    * Cat6 cabling used on the stacking ports
    * 7 VLAN's
    * Mixture of trunking + VLAN tagging & standard ports configured
    We've tried the following:
    * Swapping out the member that reboots with another, but we get the same behaviour even with a new unit after about three weeks of running
    * Changing the cabling between the members, same behaviour
    * Upgrading the firmware from a previous version to the current 3.0.1.0
    I'm not really keen on factory resetting the whole show & reconfiguring 144 ports by hand (the downtime will cost my users dearly, not to mention carpal tunnel from overuse of the web GUI)
    Is anyone able to clarify what a reason code of 0x20097 is?
    At least understanding what the error is may allow us to better understand the condition in which the switch decides it must reboot.

    Hi Lee,
    The small Business support center (SBSC) is the place to get this problem resolved.  If the technician needs to get the error code looked at by a Product Engineer, then they have to escalate your call into the bowels of Cisco development.
    Please call into  the SBSC again,  and try to reopen or open a new case.  This call has to be resolved or escalated.
    You have the ability to say to the technician ,
    1.  "I want this call escalated"  or
    2.  " I want to speak to the Manager On Duty to esclatate the call"
    If you have any issues, please  let me know.
    My email address is   dhornste  at  cisco.com    (remove the spaces and replace at with @)
    here is a link to get hopefully a local number to call into the SBSC.
    http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html
    regards Dave

  • My iPhone 4S Bluetooth will not connect with either my iPad1, MacBook Pro or Automobile BT.  Suspect a stack issue in new BT 4.0 (BTLE) release. Has any one discovered fix to this. I have tried this with two separate 4S phones and have same problem..

    One further clarification. I am most concerned with connecting with BT in automobile. I can use WiFi to tether to my other devices.  I cannot change the car very easily! My iPhone 3G had no connection issues.

    I'm new.  Same bluetooth problem. Will not pair with my 2010 VW GTI w NAV system, or my MacBook Pro 17" (just discovered the MacB prob.)
    When I initially discovered the problem I went to an Apple Store. Genius was excellent but requested that I check with VW.  VW people were very helpful. A mechanic had an iphone 4s. He came out to the car ... He could not pair my phone but he could pair his phone ... So, it's the iphone ... Back to the Apple Store ... the genius was really good. He replaced the iphone. Great !  So, back out to the car & it would not pair, still.  So ... can't be the phone , right.  Back to VW. The Audi manager had an iphone 4S. He paired his phone with my car. He could not pair my phone to my car. He tries my phone in a new 2011 GTI sitting on the lot ... my phone pairs with it just fine.  So ... it's my car.  So ... make an appointment to get the bluetooth module replaced. They replace the Bluetooth module. My iphone will not pair.  They end up pairing 2 different iphone 4S to my car ... but not my iphone 4S. My iphone 4S will also not pair with another 2010 GTI they have in for service. Though the 2 iphone 4S
    pair with the second GTI just fine.  They even try pairing my iphone with a brand new 2012 GTI in the showroom ... yep ... it paired fine.    So ... ????????????????
    They are going to update my nav software next (tomorrow), Hopeful ??? not really ... Will be taking my computer to Apple Store next ... maybe if they can discover why it will not pair to my MacBook Pro it will lead to a solution for the GTI ???  I'll get back to you.

  • [VPN] [GUIDE] Setting up nordvpn with systemd

    Since I haven't seen specific guide to setting up nordvpn for archlinux with systemd, I thought I should write them up what I have done. This might be useful for those unfamiliar with systemd. Simply connecting with provided *.ovpn file do not update the DNS correctly and the command
    sudo systemctl start [email protected] do not work.
    1. Follow nordvpn's connecting with shell instruction at https://nordvpn.com/tutorials/linux/linux-openvpn/ and make sure you can manually connect by typing:
    sudo openvpn vpn_at_nordvpn_tcp.ovpn
    2. Create unit systemd for a server
    sudo nano /etc/systemd/system/nordvpn.service
    [Unit]
    Description=OpenVPN connection to yourovpn.ovpn
    [Service]
    Type=forking
    ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/yourovpn.ovpn --daemon [email protected] --writepid /run/[email protected]
    PIDFile=/run/[email protected]
    [Install]
    WantedBy=multi-user.target
    replace yourovpn with the desired server.
    For whatever reason, the following modified /usr/lib/systemd/system/[email protected] do not work.
    [Unit]
    Description=OpenVPN connection to %i
    [Service]
    Type=forking
    #ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/%i.conf --daemon openvpn@%i --writepid /run/openvpn@%i.pid
    ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/%i.ovpn --daemon openvpn@%i --writepid /run/openvpn@%i.pid
    PIDFile=/run/openvpn@%i.pid
    [Install]
    WantedBy=multi-user.target
    3. The DNS was not updated. So use the guide from the wiki and add these to your .ovpn file
    # auto update /etc/resolv.conf
    script-security 2
    up /etc/openvpn/update-resolv-conf.sh
    down /etc/openvpn/update-resolv-conf.sh
    the shell script is found at https://raw.githubusercontent.com/maste … lv-conf.sh
    One issue I found is that you do not get that "Initialization Sequence Completed" to indicate a successful vpn connection. I had to either google my public ip address or type:
    ip addr show | grep tun0
    Any feedback or improvisations are appreciated.

    Since I haven't seen specific guide to setting up nordvpn for archlinux with systemd, I thought I should write them up what I have done. This might be useful for those unfamiliar with systemd. Simply connecting with provided *.ovpn file do not update the DNS correctly and the command
    sudo systemctl start [email protected] do not work.
    1. Follow nordvpn's connecting with shell instruction at https://nordvpn.com/tutorials/linux/linux-openvpn/ and make sure you can manually connect by typing:
    sudo openvpn vpn_at_nordvpn_tcp.ovpn
    2. Create unit systemd for a server
    sudo nano /etc/systemd/system/nordvpn.service
    [Unit]
    Description=OpenVPN connection to yourovpn.ovpn
    [Service]
    Type=forking
    ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/yourovpn.ovpn --daemon [email protected] --writepid /run/[email protected]
    PIDFile=/run/[email protected]
    [Install]
    WantedBy=multi-user.target
    replace yourovpn with the desired server.
    For whatever reason, the following modified /usr/lib/systemd/system/[email protected] do not work.
    [Unit]
    Description=OpenVPN connection to %i
    [Service]
    Type=forking
    #ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/%i.conf --daemon openvpn@%i --writepid /run/openvpn@%i.pid
    ExecStart=/usr/bin/openvpn --cd /etc/openvpn --config /etc/openvpn/%i.ovpn --daemon openvpn@%i --writepid /run/openvpn@%i.pid
    PIDFile=/run/openvpn@%i.pid
    [Install]
    WantedBy=multi-user.target
    3. The DNS was not updated. So use the guide from the wiki and add these to your .ovpn file
    # auto update /etc/resolv.conf
    script-security 2
    up /etc/openvpn/update-resolv-conf.sh
    down /etc/openvpn/update-resolv-conf.sh
    the shell script is found at https://raw.githubusercontent.com/maste … lv-conf.sh
    One issue I found is that you do not get that "Initialization Sequence Completed" to indicate a successful vpn connection. I had to either google my public ip address or type:
    ip addr show | grep tun0
    Any feedback or improvisations are appreciated.

  • Gnome and kde not loading with systemd

    Hello!
    I use [testing] repo and after some updates i can't use gnome or kde with systemd anymore.
    * with sysvinit everything works
    * xfce and other wms works fine with systemd and sysv
    * 'gnome-shell --replace' also work in xfce with systemd
    * I've got some errors:
    gnome-session[2301]: WARNING: Application 'gnome-settings-daemon.desktop' failed to register before timeout
    (gnome-settings-daemon:2321): libupower-glib-WARNING **: Couldn't enumerate devices: Activation of org.freedesktop.UPower timed out
    gnome-session[2301]: WARNING: Application 'gnome-shell.desktop' failed to register before timeout
    (gnome-settings-daemon:2321): color-plugin-WARNING **: GDBus.Error:org.freedesktop.ColorManager.Failed: failed to obtain org.freedesktop.color-manager.create-profile auth
    QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
    Object::connect: No such signal QDBusAbstractInterface::DeviceAdded(QString)
    plasma-desktop(2323): Communication problem with  "plasma-desktop" , it probably crashed.
    Error message was:  "org.freedesktop.DBus.Error.Disconnected" : " "Connection was disconnected before a reply was received" "
    I think there is some problems with dbus...

    Without a dbus socket, dbus probably isn't running. It's supposed to be started automatically when a program needs it. Check to see that it is installed and running:
    pacman -Q dbus
    pgrep -l dbus
    Dbus won't run without hal, so hal should be in:
    tail /etc/rc.conf
    Are any of your partitions full?
    df -h
    For the other error, it looks like libdrm isn't installed, but I don't think you need it if you're running the nvidia driver.
    Your xorg.conf and Xorg.0.log would also be useful. Also check dmesg for errors.
    And see if /etc/rc.d/dbus is marked executable.
    Last edited by fphillips (2009-05-12 18:27:41)

  • Stacked bar chart with single group

    Post Author: rt50896
    CA Forum: Charts and Graphs
    Dear all,   I have a question about stacked bar chart with one group value(normally more than one group value is ok)   ex. YYYYMM      PRODUCT    AMT        -
            200601          ABC            1000        200602          ABC              300        200603          ABC              500       .....   the data collection is as above,then chart display: x-axis as YYYYMM,y-axis as PRODUCT...   but why this case the bar chart color not the same for each YYYYMM? and legend not display one PRODUCT as ABC only?   the bar chart display like this:   http://tkfiles.storage.live.com/y1po30C7CH6eW9phoLAXH89MBGwFLYdEZ3kOMQXUQzDzwM-VNnffibEwqPI8TIUNBm1f7uKTjnkaOI   ps. crystal report version is 8.5Regina

    Thanks, Jeff. I did try this but for whatever reason it doesn't make a difference. I think it is because if there's no data for a given series for a certain week, there is no entry in the data set that is sent to AnyChart.
    I was able to get around the issue by "filling in" the missing weeks from each data series. To generate the list of "Week Of" dates for a given date range, I used this code:
    select
         trunc (each_day) as week_of,
         0 as effort
    from (
         select
              (to_date(:p920_start_date,:app_date_format) + 2 - to_char(to_date(:p920_start_date,:app_date_format),'D') - 1) + level each_day
         from dual
         connect by level <= to_date(:p920_end_date,:app_date_format) - to_date(:p920_start_date,:app_date_format) + 1
    where
         to_char (each_day, 'D') = '2'This creates an effort entry of 0 for each week within the date range; I use the Monday date of a week as the "Week Of" date. I then union this with my actual data and summarize by week and viola, I get the weeks in order. This also has the benefit of showing a week for which there are no entries in any of the three series.
    Thanks for taking a look at this.
    Mike

  • Stacked Bar Chart with Multiple Series Sort Question

    Hi,
    Apex version 4.1.1
    I have a stacked bar chart with three separate series, one showing customer effort, another showing project effort and the third showing other effort, summarized by calendar week. The x-axis of the chart is the calendar "week of" date, and the y-axis has a bar for each of the three series. Not every type of effort occurs every week.
    When AnyChart renders the chart, the order of entries on the x-axis seems to be dependent both on which series are present in a given week as well as the "week of" date. Weeks with all three series sort in order by calendar date, followed by weeks where just the 2nd & 3rd series are present, followed by weeks where just the 3rd series is present. See this [url http://tinypic.com/r/b9zdt/6] picture of the chart  noting the "week of" dates. Note that the months go Sep-Oct-Nov-Aug-Oct.
    Is there a way to force AnyChart to sort the x-axis in chronological order regardless of whether there is data for all three series for a given week? I have looked through the AnyChart XML reference but cannot find a way to do this.
    Incidentally, I can solve the sorting problem by combining all three series into a single query:
    select
      null as link,
      week_of as label,
      sum(customer_effort) as "Customer Effort",
      sum(project_effort) as "Project Effort",
      sum(other_effort) as "Training, Admin and Other Effort"
    from ...But if I do this, I cannot figure out how to have each bar on a given week link to a different detail page, e.g., if I click on a bar representing customer effort I want to link to one page, but if I click on a bar representing project effort, I want to link to a different page. I have had a look at the [url http://apex.oracle.com/pls/apex/f?p=36648:59:1570983160946101::NO:::] chart examples  posted on apex.oracle.com, but cannot figure out how to apply to multiple series in a single query.
    Thanks,
    Mike

    Thanks, Jeff. I did try this but for whatever reason it doesn't make a difference. I think it is because if there's no data for a given series for a certain week, there is no entry in the data set that is sent to AnyChart.
    I was able to get around the issue by "filling in" the missing weeks from each data series. To generate the list of "Week Of" dates for a given date range, I used this code:
    select
         trunc (each_day) as week_of,
         0 as effort
    from (
         select
              (to_date(:p920_start_date,:app_date_format) + 2 - to_char(to_date(:p920_start_date,:app_date_format),'D') - 1) + level each_day
         from dual
         connect by level <= to_date(:p920_end_date,:app_date_format) - to_date(:p920_start_date,:app_date_format) + 1
    where
         to_char (each_day, 'D') = '2'This creates an effort entry of 0 for each week within the date range; I use the Monday date of a week as the "Week Of" date. I then union this with my actual data and summarize by week and viola, I get the weeks in order. This also has the benefit of showing a week for which there are no entries in any of the three series.
    Thanks for taking a look at this.
    Mike

  • Unable to establish connection with SQLServer from Java Application

    Dear All,
    I am facing the issue of establishing connection with SQL Server from Java project developed in NWDS. I am writing a jaas plug-in, as a part of that I am writing a login module to authenticate a web application through jaas, and I got need of fetching some data from SQL Server which is located in remote host. I am getting error in the line of code
    <b>Class.forName("com.microsoft.jdbc.sqlserver.SQLServerDriver")</b>
    I also added the 3 jar files (msbase.jar,mssqlserver.jar,and msutil.jar) to my login module project and copied the same files at C:\usr\sap\J2E\JC01\j2ee\cluster\server0\bin\ext\MSSQL.
    My MI Landscape is j2ee stack + abap stack +WAS 6.40 with MAXDb as a database.
    Could anyone please let me know the solution if you are aware of it.
    Thanks and Regards,
    Kishore

    I solved it by writing the following code
    Connection con;
    Statement stmt;
    DataSource ds;
    Context ctx;
    ctx = new InitialContext();
    if(ctx == null)     throw new Exception("Boom - No Context");
    ds=(DataSource)ctx.lookup("jdbc/SQLDB");     
    con = ds.getConnection();
    stmt = con.createStatement();
    String query = "SELECT * FROM SubjectBIR where Subject_ID='" + user + "'";
    ResultSet result  = stmt.executeQuery(query);
    stmt.close();
    con.close();

  • N5800 not maintaining connection with plantronics ...

    it can be easily paired with headset. but every now and then it disconnect and connect with the headset. i have already consulted with plantronics and mentioned a power cycle to be done and remove current pairing and re-pairing it again. but the issue is still exists.
    5800 current firmware version is v 30.0.0.11
    any idea from nokia's end?
    highly appreciatted a response.
    thanks

    i have the same problemo but i read that it can be rectified with broadcomm bluetoth stack.
    Regards

  • 9.0.1  DB-Connect with jdbc

    Hello,
    we have a problem with a connect of the oracle 9.0.1 datebase.
    a connect with the sqlplus-editor and a precompiler programm is
    without problems.
    a connect with the jdbc (java) is a problem.
    the error message is in the file:
    /u01/app/oracle/admin/mpb1/bdump/s000_617_mpb1.tr
    /u01/app/oracle/admin/mpb1/bdump/s000_617_mpb1.trc
    Oracle9i Release 9.0.1.0.0 - 64bit Production
    JServer Release 9.0.1.0.0 - Production
    ORACLE_HOME = /u01/app/oracle/product/9.0.1
    System name: HP-UX
    Node name: MPB1
    Release: B.11.11
    Version: U
    Machine: 9000/800
    Instance name: mpb1
    Redo thread mounted by this instance: 1
    Oracle process number: 8
    Unix process pid: 617, image: oracle@MPB1 (S000)
    *** SESSION ID:(8.60) 2001-12-04 11:32:22.999
    *** 2001-12-04 11:32:22.998
    ksedmp: internal or fatal error
    ORA-00600: Interner Fehlercode, Argumente: [ttcgcshnd-1], [0],
    Current SQL statement for this session:
    SELECT VALUE FROM NLS_INSTANCE_PARAMETERS WHERE PARAMETER
    ='NLS_DATE_FORMAT'
    ----- Call Stack Trace -----
    calling call entry argument
    values in hex
    location type point (? means
    dubious value)
    have anybody a solution for this problem.
    thanks
    chris

    Are you trying external auth with LDAP?
    Have you tried using the ssooid.sql rather than ssoldap.sql?
    I saw a posting here recently indicating that they also got ssoldap.sql to work though.

  • Connection with sapinst get broken: Netweaver 2004 on aix machine

    Hi
    I am installing Netweaver 2004 on aix machine.
    Java instance
    database : maxdb
    When I run sapinst , connection with it get broken in between.
    Warnings and errors are as follows:
    Current (soft) resource limit stacksize should be unlimited but it is 33554432. This may cause core dumps. Stop the installation set the limit to unlimited and start again.
    WARNING    2007-05-08 13:19:56 [sapinst.cpp:124]
               CSapInst::initMessaging()
    Current (soft) resource limit stacksize should be unlimited but it is 33554432. This may cause core dumps. Stop the installation set the limit to unlimited and start again.
    Current (soft) resource limit datasize should be unlimited but it is 134217728. This may cause core dumps. Stop the installation set the limit to unlimited and start again.
    WARNING    2007-05-08 13:19:56 [sapinst.cpp:139]
               CSapInst::initMessaging()
    Current (soft) resource limit datasize should be unlimited but it is 134217728. This may cause core dumps. Stop the installation set the limit to unlimited and start again.
    <b>iauxsysex.c:317: child /tmp/sapinst_exe.631026.1178648293/sapinst (pid 753700) has crashed. Executable directory is /tmp/sapinst_exe.631026.1178648293. Contact Support.
    iaextract.c:885: child has signaled an exec error. Keeping directory /tmp/sapinst_exe.631026.1178648293</b>
    What is the solution for this?

    "Current (soft) <b>resource limit stacksize should be unlimited</b> but it is 33554432. This may cause core dumps. Stop the installation set the limit to unlimited and start again."
    -> plz check your root values using SMITTY -> Security & Users -> Users -> Change/Show  Characteristics of a User -> insert 'root' -> check parameter 'Soft STACK size' -> value should be '-1' (minus one)
    GreetZ, AH

  • Cannot connect with Bluetooth

    Hi,
    I'm on Windows XP Pro service pack 3. I use PC Suite 7.0.9.2.
    I used to connect my phone (Nokia 6500c) to my laptop via bluetooth fine. However, I got a new laptop (Lenovo SL500) and I can't connect via bluetooth anymore.
    Here is what happens:
    I go "Get Connected" -> Bluetooth connection -> it fins my phone, I click on the phone, then click next -> it asks to enter a passcode (let's say the usual "123"), I click net. Then, a bubble pops up for my bluetooth icon in the system tray saying "Bluetooth Security Code Required: Bluetooth device "Nokia Tony" is attempting to connect to this computer. Click here to proceed with the conection".
    I click on the bubble, a window called Bluetooth Security Setup pops up and tries to connect my phone.... "Pairing failed". I click "try again", my phone then asks me if I want to connect with my PC, I accept, the window "Bluetooth Security Setup" generates a six-digits code that I enter in the phone... pairing is made... but the window "Get Connected" of PC Suite tells me "Cannot authenticate the phone".
    any help, please?? I probably need to override the Bluetooth software, but dunno how.
    when I look into Device Manager, there are two things under "Bluetooth Devices":
    - Bluetooth Bus Enumerator
    - ThinkPad Bluetooth with Enhanced Data Rate II
    thanks for helping
    Tony

    05-Dec-2008 05:07 AM
    miksu wrote:
    hi, I think that pc suite 7.0 does not support widcomm 5.5 stack. There will come PC Suite 7.1 quite soon (it is now in beta testing). Please try that when it is available.
    For those who can't wait (like me), the PC Suite 7.1.18.0 beta is available for download there: http://fileforum.betanews.com/detail/Nokia_PC_Suit​e/1084122750/1
    oh yeah, and by the way... with this version of PC Suite, it CAN connect the phone and the Thinkpad SL500 via Bluetooth
    Message Edited by tonydoss on 05-Dec-2008 06:53 AM

Maybe you are looking for