Syslogging routing table updates

I have a stable network that rarely has any routing changes. I would like any routing table updates to be sent to a logging server or possibly generate a trap so I am aware of the changes. Currently I use a Debug ip routing command and get the output sent. Is there another way to accomplish this without using the debug command?
Keith

This will depend on your version of IOS.  Newer versions of IOS include the Embedded Event Manager version 3.0.  This version of EEM includes a route table event detector that can be used to spot routing updates.  You can try something like this:
event manager applet routing-changes event routing type all network 0.0.0.0/0 ge 1 action 1.0 syslog msg "Routing table changed; Type: $_routing_type, Network: $_routing_network, Mask: $_routing_mask, Protocol: $_routing_protocol, Gateway: $_routing_lastgateway, Interface: $_routing_lastinterface"

Similar Messages

  • VPN connection created with CMAK fails to update routing table on Windows 8.1 with error 8000ffff

    When my clients connect their CMAK-created VPN, it fails to run the script to set their routing table with the following error:
    Custom script (to update your routing table) failed (8000ffff)
    My objective is to create a VPN connection with split tunneling - does not use the VPN connection as the client's default gateway.
    All my clients are on Windows 8.1 64-bit, and are logged in with Administrative privileges
    My VPN Clients are on 10.242.2.0/24, my internal network is on 10.172.16.0/24
    I want only traffic for 10.172.16.0 to go via the VPN. Everything else should go via the client's internet connection
    My Connection Manager Administration Kit profile, was created on Windows 2012 R2 CMAK with the following settings:
    "Make this connection the client's default gateway" is UNticked on the IPv4 tab.
    Define a routing table update is specified with a text file containing:
    +++ Start of txt file +++
    REMOVE_GATEWAY
    add 10.172.16.0 mask 255.255.255.0 default metric default if default
    +++ End of txt file +++
    The txt file is saved in DOS/Windows format (not Unicode or UTF-8 which I've read causes problems)
    I've tried everything in lower and upper case in the txt file after reading that the file might be case sensitive
    The following appears on the client with logging enabled:
    [cmdial32] 10:42:34
    03 Pre-Init Event       CallingProcess = C:\WINDOWS\system32\rasautou.exe
    [cmdial32] 10:42:40
    04 Pre-Connect Event    ConnectionType = 1
    [cmdial32] 10:42:40
    06 Pre-Tunnel Event     UserName = UserName Domain =  DUNSetting = VPN (L2TP x64 NoGW) Tunnel DeviceName =  TunnelAddress = vpn.mydomain.tld
    [cmdial32] 10:42:43
    07 Connect Event
    [cmdial32] 10:42:43
    09 Custom Action Exe    ActionType = Connect Actions Description = (none) ActionPath = CMDL32.EXE. The program was launched successfully.
    [cmdial32] 10:42:43
    08 Custom Action Dll    ActionType = Connect Actions Description = to update your routing table ActionPath = C:\Users\UserName\AppData\Roaming\Microsoft\Network\Connections\Cm\VPN64\CMROUTE.DLL ReturnValue
    = 0x8000ffff
    [cmdial32] 10:42:43
    21 On-Error Event       ErrorCode = -2147418113 ErrorSource = to update your routing table
    [cmdial32] 10:42:43
    13 Disconnect Event     CallingProcess = C:\WINDOWS\system32\cmdial32.dll
    Where can I find out what error codes 8000ffff or -2147418113 mean?

    That was it. Thanks, Steven
    "By default, the dial-up entry and the VPN entry have Make this connection the default gateway selected.
    Leave this default in place, and remove any gateways by using the REMOVE_GATEWAY command in the routing table update file itself."
    It seems counter-intuitive to leave
    Make this connection the default gateway selected, when I specifically don't want that behaviour, but leaving it selected and using REMOVE_GATEWAY works for me.

  • How to stop windows ipv6 route table auto-update

    In ipv6 , windows xp can get one global ipv6-address. how to delete the address and del the route in route table persistent? And stop route table auto update?

    The WsusContent folder is filled with 256 folders that are two-characters long (e.g. 00, 0A, 0B, etc), and each of those folders are filled with exe and cab files all with what appears to be a GUID as a filename.
    Currently the C:\Program Files\Update Services\WsusContent folder is 27.5GB in size with 256 folders and 15,361 files.
    Classifications are confirmed matching exactly when viewed from either the WSUS console or the Software Update Point Component Properties on the CAS server:
    Critical Updates
    Definition Updates
    Security Updates
    Service Packs
    Update Rollups
    Updates
    Product selection is confirmed matching exactly when viewed from either the WSUS console or the Software Update Point Component Properties on the CAS server:
    Developer Tools (VS 2005 - 2013, etc)
    Exchange 2007, 2010, 2013
    Forefront Endpoint Protection 2010, TMG Definition Updates for HTTP Malware and NIS, TMG, TMG Firewall Client
    BitLocker Admin
    Lync 2010, Lync Server 2010 and 2013
    System Center DPM 2006 and 2010
    Office Dictionary updates, new dictionaires, XP, 2003, 2007, 2010, 2013
    Silverlight
    SQL Server 2012, 2000, 2005, 2008, 2008 R2, 2012, feature pack
    System Center 2012 (all), 2012 R2 (all), 2012 SP1 (all)
    Windows (all except EU browser choice and graphics drivers for 8.1 upgrade)
    Admittedly we could update that list a bit, but it sounds like you don't think there should be any content downloading to the WsusContent folder at all?

  • Eem script monitor routing table - multiple entries into 1 email

    I have the following script running to report on routing table changes
    event manager applet route-table-monitor
    event routing network 0.0.0.0/0 ge 1
    action 0.5 set msg "Route changed: Type: $_routing_type, Network: $_routing_network, Mask/Prefix: $_routing_mask, Protocol: $_routing_protocol, GW: $_routing_lastgateway, Intf: $_routing_lastinterface"
    action 1.0 syslog msg "$msg"
    action 2.0 cli command "enable"
    action 4.0 info type routername
    action 5.0 mail server "10.*.*.*" to "roger.perkin@****" from "Switch1" subject "Routing Table Change" body "$msg  $_cli_result"
    It works perfectly however if multiple routes change I get multiple emails.
    Last night we had a site go out and I got about 20 separate email for each subnet change.
    What I would like to do is get this script to take all routes changed in a 1 minute interval and then output them into an email.
    Not quite sure how I would go about that?
    Thanks
    Roger
    Currently studying for my CCIE and just started on EEM, have not done much scripting before so this is all good stuff to know.

    You can't do this with one policy.  However, you could accomplish this with a timer policy that will batch up the pending updates, though.  Something like this would work.
    event manager applet route-table-monitor event routing network 0.0.0.0/0 ge 1 action 0.5 set msg "Route changed: Type: $_routing_type, Network:  $_routing_network, Mask/Prefix: $_routing_mask, Protocol:  $_routing_protocol, GW: $_routing_lastgateway, Intf:  $_routing_lastinterface" action 0.6 syslog msg "$msg" action 1.0 handle-error type ignore action 2.0 context retrieve key RTRCTXT variable msgs action 3.0 if $_error ne FH_EOK action 4.0  set msgs "$msg\n" action 5.0 else action 6.0  append msgs "$msg\n" action 7.0 end action 8.0 handle-error type exit action 9.0 context save key RTRCTXT variable msgs!event manager applet route-table-batcher event timer watchdog time 60 action 1.0 handle-error type ignore action 2.0 context retrieve key RTRCTXT variable msgs action 3.0 if $_error eq FH_EOK action 4.0  info type routername action 5.0  mail server "10.*.*.*" to "roger.perkin@****" from "$_info_routername" subject "Routing Table Change" body "$msgs" action 6.0 end action 7.0 handle-error type exit

  • How to add a route in routing table

    Hi,
    I want to add a new route to the routing table to get access to a explicit tunnel. Using Terminal I tried
    route add 172.16.0.0 mask 255.255.0.0 192.168.0.102
    route: must be root to alter routing table
    so I tried:
    sudo route add 172.16.0.0 mask 255.255.0.0 192.168.0.102
    To proceed, enter your password
    My password ist enmpty. But I see the message:
    Sorry, try again.
    Is there a better way to add a route to the actual routing table?
    How can I reset my root-password?
    Thanks & best regards,
    Torsten

    In JDev "help", there are tutorial exercises which show you how to develop custom Search, Create, Drilldown, and Update pages. It also goes indepth into adding Delete functionality and Partial Page Rendering.

  • Difference between sh ip bgp & sh ip route? BGP tables and main routing table.

    Difference between sh ip bgp & sh ip route?
    sh ip bgp :::: loc-rib ?
    sh ip bgp nei x.x.x.x advertised-routes : adj-rib-in.
    sh ip bgp nei x.x.x.x recieved-routes : adj-rib-out.
    sh ip bgp nei x.x.x.x routes : loc-rib ?
    sh ip route = rib ? if yes does it mean its loc-rib ?
    so in a given router with bgp running, will there be 5 tables (sh ip bgp; adj-rib-in; loc-rib;adj-rib-out; sh ip route) ? if yes where are they saved ?

    sh ip bgp
    shows the BGP table (where are stored info coming from BGP update) 
    sh ip bgp nei x.x.x.x advertised-routes 
    shows networks that your router will advertise to a specific neighbor
    sh ip bgp nei x.x.x.x recieved-routes 
    shows advertisement received from a specific neighbor;  networks (NLRI) filtered with route-map distribute-list,... are included  (Inbound soft reconfiguration must be enabled)
    sh ip bgp nei x.x.x.x routes 
    shows only routes sent by a specific neighbor and not filtered or discarded (i.s accepted)
    sh ip route 
    show routing table; it contains the best route for each network (best is first of all the lowest administrative distance, then the lowest metric)
    Bye,
    enrico.
    PS please rate if useful

  • Naming Networks in EEM route table monitor

    I have the following EEM applet running on one of my core devices to monitor any changes in the routing table.
    event manager applet route-table-monitor
    event routing network 0.0.0.0/0 ge 1
    action 0.5 set msg "Route changed: Type: $_routing_type, Network: $_routing_network, Mask/Prefix: $_routing_mask, Protocol: $_routing_protocol, GW: $_routing_lastgateway, Intf: $_routing_lastinterface"
    action 1.0 syslog msg "$msg"
    action 2.0 cli command "enable"
    action 3.0 info type routername
    action 4.0 mail server "*.*.*.*" to "roger@*********" from "Core1" subject "Routing Table Change" body "$msg  $_cli_result"
    action 8.0 set msg "Route changed: Type: "
    This works brilliantly however the email I get lists the networks by IP and I am trying to get it to identify them by name
    Email Output
    Route changed: Type: modify, Network: 10.8.4.0, Mask/Prefix: 255.255.255.0, Protocol: BGP, GW: 10.1.1.1, Intf: N/A
    The script is running on a 3750
    I tried putting ip host info on the switch but that did not work.
    I am not sure if there is an extra line I can add to the script or if anyone else has done this?
    Thanks
    Roger

    I don't understand the request.  Where would the network "name" come from?  Networks are unnamed on IOS.

  • Trouble getting internet route table distributet in a VRF

    Hi every one ..
    I'm have some trouble getting distributed the internet routing table between PE routers ...
    CE1 og PE1 works fine, BGP routes all internet routes are shown i en route table, but distributing between PE1 and PE2 is now working .. any one having a clue !!.
    My gold is to move internet access into it's oven VRF, and away from the global routing table
    In the MPLS core aim running the same AS number as our official AS, that we use for peering to the internet..
    snap of configurations
    ***CE1***
    router bgp 65534
    neighbor 172.31.61.55 remote-as 65534
    neighbor 172.31.61.55 description PE-1
    neighbor 172.31.61.55 shutdown
    neighbor 172.31.61.55 update-source Loopback0
    neighbor 172.31.61.55 next-hop-self
    ***MPLS PE1***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.35
    encapsulation dot1Q 35
    ip vrf forwarding NET-INTERNET
    ip address 172.31.61.55 255.255.255.224
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.146 remote-as 65534
    neighbor 192.168.0.146 description PE2
    neighbor 192.168.0.146 update-source Loopback0
    neighbor 192.168.0.146 version 4
    neighbor 192.168.0.146 next-hop-self
    address-family vpnv4
    neighbor 192.168.0.146 activate
    neighbor 192.168.0.146 send-community both
    exit-address-family
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.1.2 remote-as 65534
    neighbor 172.31.1.2 activate
    neighbor 172.31.1.2 description CE1
    no auto-summary
    no synchronization
    exit-address-family
    ***MPLS PE2***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.67
    encapsulation dot1Q 67
    ip vrf forwarding NET-INTERNET
    ip address 172.31.254.1 255.255.255.252
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.132 remote-as 65534
    neighbor 192.168.0.132 description PE1
    neighbor 192.168.0.132 update-source Loopback0
    neighbor 192.168.0.132 version 4
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.254.2 remote-as 65534
    neighbor 172.31.254.2 activate
    Best regards
    /Peter

    For VPN routes to be exchanged between the two PEs, you first need to configure VPNv4 address family on each one of the PEs.
    Carrying the full Internet routing table over VPNv4 will work but it is not very scalable since all PE routers have to hold the full Internet routing table in the VRF context in addition to potentially full Internet routing table in the global routing table. If you want to exchange full Internet routing table between the two CEs, it would be preferable to use something Carrier Supporting Carrier (CSC).
    Please refer to the following URL for additional information on CSC:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/fscscl23.htm
    Hope this helps,

  • 3845 router failing to look up routes from routing table correctly!

    Hi all,
    Got a really strange issue which I am wondering if someone can point me in the right direction for. Facts of the issue:
    - Some customers, all with a specific ISP, cannot access a hosted service we host internally
    - External user can reach service but never gets a response - hence focussing on reachability of their public IP
    - Cisco 3845 router used, peers with service provider over BGP - receives full internet routing tables
    - All affected customers receive dynamic IP addresses within the same /10 public IP range
    I received an example IP address and when doing "show ip route x.x.x.x" for this IP, the router responds "Subnet not in table". When trying to traceroute to the IP, the router doesnt even go to the next hop. However, the subnet is definitely in the routing table with the correct next hop (and, for complete information, is also within the BGP updates). Before anyone asks the question :) - yes I have definitely verified that the hosts are within this subnet.
    If I put a static /32 route in for this specific IP address, everything works fine - then fails again once its taken out.
    I literally cannot understand why the router is not correctly performing the lookup for the hosts within this subnet. I can understand a lot of potential reasons why the BGP received route wouldnt be placed in the routing table, but that is not the case here. 
    Some other factors (if applicable):
    - Nothing showing in the logs
    - Plenty memory available (despite the high number of routes)
    - Plenty CPU resource available
    - No default route is ran
    I am going to restart the router and really expect this to resolve the issue (would log a TAC but this one is a bit time precious) - but it is frankly doing my head in and I assume I am missing something!
    Any help or guidance would be appreciated!

    Hi all,
    Got a really strange issue which I am wondering if someone can point me in the right direction for. Facts of the issue:
    - Some customers, all with a specific ISP, cannot access a hosted service we host internally
    - External user can reach service but never gets a response - hence focussing on reachability of their public IP
    - Cisco 3845 router used, peers with service provider over BGP - receives full internet routing tables
    - All affected customers receive dynamic IP addresses within the same /10 public IP range
    I received an example IP address and when doing "show ip route x.x.x.x" for this IP, the router responds "Subnet not in table". When trying to traceroute to the IP, the router doesnt even go to the next hop. However, the subnet is definitely in the routing table with the correct next hop (and, for complete information, is also within the BGP updates). Before anyone asks the question :) - yes I have definitely verified that the hosts are within this subnet.
    If I put a static /32 route in for this specific IP address, everything works fine - then fails again once its taken out.
    I literally cannot understand why the router is not correctly performing the lookup for the hosts within this subnet. I can understand a lot of potential reasons why the BGP received route wouldnt be placed in the routing table, but that is not the case here. 
    Some other factors (if applicable):
    - Nothing showing in the logs
    - Plenty memory available (despite the high number of routes)
    - Plenty CPU resource available
    - No default route is ran
    I am going to restart the router and really expect this to resolve the issue (would log a TAC but this one is a bit time precious) - but it is frankly doing my head in and I assume I am missing something!
    Any help or guidance would be appreciated!

  • HOST ROUTING TABLE IS EMPTY please HELP

    HELLO THERE PLEASE HELP ME , MY HOST ROUTING TABLE IS EMPTY
    WHAT DO I DO NOW?

    Hi and Welcome to the Community!!
    With a strong carrier network signal (not WiFi), I suggest the following steps, in order, even if they seem redundant to what you have already tried (steps 1 and 2 each should result in a message coming to your BB...please wait for that before proceeding to the next step):
    1) Register HRT
    KB00510 How to register a BlackBerry smartphone with the wireless network
    Please wait for one "registration" message to arrive to your Messages app
    2) Resend Service Books
    KB02830 Send the service books for the BlackBerry Internet Service
    Please wait for "Activation" Messages, one per already configured email account, to arrive in your Messages. If you have no already configured email accounts, please wait 1 hour.
    3) Batt Pull Reboot
    With power ON, remove the back cover and pull out the battery. Wait about a minute then replace the battery and cover. Power up and wait patiently through the long reboot -- ~5 minutes. See if things have returned to good operation. Like all computing devices, BB's suffer from memory leaks and such...with a hard reboot being the best cure.
    Hopefully that will get things going again for you! If not, then you should contact your mobile service provider for formal support...it is, after all, your carrier network that must populate these items to your BB.
    Good luck!
    Occam's Razor nearly always applies when troubleshooting technology issues!
    If anyone has been helpful to you, please show your appreciation by clicking the button inside of their post. Please click here and read, along with the threads to which it links, for helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions.
    Join our BBM Channels
    BSCF General Channel
    PIN: C0001B7B4   Display/Scan Bar Code
    Knowledge Base Updates
    PIN: C0005A9AA   Display/Scan Bar Code

  • Route Table refresh

    Hi All,
    Do you know if it is possible to tweak the time it takes to refresh the routing table when a route changes? Is there a reg key for this? I think by default it seems to be 10 mins or so before it works out the new route.
    Cheers,
    Simon.

    I am aware that Windows has a Dead Gateway Detection in TCP/IP: http://support.microsoft.com/kb/128978
    This makes Windows identify if a Gateway is still functional.
    Otherwise, manual configuration changes on TCP/IP make immediate updates on your routing table to make changes.
    Not sure what are the other scenarios that are interesting you but I am not a way about a setting to tweak automatic refreshes or checks. 
    This posting is provided AS IS with no warranties or guarantees , and confers no rights.
    Ahmed MALEK
    My Website Link
    My Linkedin Profile
    My MVP Profile

  • Full routing table exchange in Link State Routing?

    In link state routing protocols, full update that happen every 30 minutes, does the routers exchange the whole routing table with each other? Or exchange something else, not full routing table. If not the whole routing table, what they are exchanged?

    The interval depends on the routing table. OSPF will send out a fresh copy of the LSA (link-state advertisement) every 30 minutes. ISIS will send it every 20 minutes. Only LSAs are sent, not the routing table.
    Paresh

  • Activating failover config drops routing table

    I'm attempting to configure two ASA 5520 for active/standby failover.
    When I enter the “failover” command to enable the config on the primary ASA, the entire routing table disappears.
    There is no routing process running, only static routes are configured.
    Is this an expected behavior of the failover process and if so, how long should I wait for the routes to come back?
    Is there a document somewhere explaining this behavior?
    I’ve searched all day but couldn’t find anything that came close to explain this.
    If this is not normal, what could be causing this to happen?
    Thanks

    Originally, both primary and secondary were configured for failover.
    At this point I'm only trying to understand why the rounting table is cleared so the secondary is turned off.
    Is it an expected result to have your routing cleared when you enable failover?
    I've waited only ~30 seconds for the routes to come back. Maybe I'm not waiting long enough, but I haven't seen in all the documents I've read that lost of traffic should be expected when Failover is enabled.
    hfn-asa5520-01# sh route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is 62.117.51.1 to network 0.0.0.0
    S    172.26.0.0 255.255.0.0 [1/0] via 172.26.1.252, inside
    S    172.26.30.30 255.255.255.255 [1/0] via 62.117.51.1, outside
    C    172.26.1.0 255.255.255.0 is directly connected, inside
    S    172.26.30.31 255.255.255.255 [1/0] via 62.117.51.1, outside
    C    62.117.51.0 255.255.255.0 is directly connected, outside
    C    10.1.1.0 255.255.255.0 is directly connected, dmz
    S    10.21.21.0 255.255.255.0 [1/0] via 172.26.1.250, inside
    C    10.255.255.0 255.255.255.252 is directly connected, Failover
    C    192.168.168.0 255.255.255.0 is directly connected, Flora
    S*   0.0.0.0 0.0.0.0 [1/0] via 62.117.51.1, outside
    hfn-asa5520-01# sh failover
    Failover Off
    Failover unit Primary
    Failover LAN Interface: Failover Management0/0 (Failed - No Switchover)
    Unit Poll frequency 1 seconds, holdtime 15 seconds
    Interface Poll frequency 5 seconds, holdtime 25 seconds
    Interface Policy 1
    Monitored Interfaces 3 of 160 maximum
    hfn-asa5520-01# sh failover
    Failover Off
    Failover unit Primary
    Failover LAN Interface: Failover Management0/0 (Failed - No Switchover)
    Unit Poll frequency 1 seconds, holdtime 15 seconds
    Interface Poll frequency 5 seconds, holdtime 25 seconds
    Interface Policy 1
    Monitored Interfaces 3 of 160 maximum
    hfn-asa5520-01# conf t
    hfn-asa5520-01(config)# failover
    hfn-asa5520-01(config)# sh failover
    Failover On
    Failover unit Primary
    Failover LAN Interface: Failover Management0/0 (Failed - No Switchover)
    Unit Poll frequency 1 seconds, holdtime 15 seconds
    Interface Poll frequency 5 seconds, holdtime 25 seconds
    Interface Policy 1
    Monitored Interfaces 3 of 160 maximum
    Version: Ours 8.4(3), Mate Unknown
    Last Failover at: 12:23:12 PDT May 21 2012
            This host: Primary - Negotiation
                    Active time: 116 (sec)
                    slot 0: ASA5520 hw/sw rev (2.0/8.4(3)) status (Up Sys)
                      Interface outside (62.117.51.100): No Link (Waiting)
                      Interface inside (172.26.1.251): No Link (Waiting)
                      Interface dmz (10.1.1.1): No Link (Waiting)
                      Interface Flora (192.168.168.1): No Link (Not-Monitored)
                    slot 1: empty
            Other host: Secondary - Not Detected
                    Active time: 0 (sec)
                    slot 0: empty
                      Interface outside (62.117.51.99): Unknown (Waiting)
                      Interface inside (172.26.1.249): Unknown (Waiting)
                      Interface dmz (10.1.1.2): Unknown (Waiting)
                      Interface Flora (192.168.168.2): Unknown (Not-Monitored)
                    slot 1: empty
    Stateful Failover Logical Update Statistics
            Link : Failover Management0/0 (Failed)
            Stateful Obj    xmit       xerr       rcv        rerr     
            General         0          0          0          0        
            sys cmd         0          0          0          0        
            up time         0          0          0          0        
            RPC services    0          0          0          0        
            TCP conn        0          0          0          0        
            UDP conn        0          0          0          0        
            ARP tbl         0          0          0          0        
            Xlate_Timeout   0          0          0          0        
            IPv6 ND tbl     0          0          0          0        
            VPN IKEv1 SA    0          0          0          0        
            VPN IKEv1 P2    0          0          0          0        
            VPN IKEv2 SA    0          0          0          0        
            VPN IKEv2 P2    0          0          0          0        
            VPN CTCP upd    0          0          0          0        
            VPN SDI upd     0          0          0          0        
            VPN DHCP upd    0          0          0          0        
            SIP Session     0          0          0          0        
            Route Session   0          0          0          0        
            User-Identity   0          0          0          0        
            Logical Update Queue Information
                            Cur     Max     Total
            Recv Q:         0       0       0
            Xmit Q:         0       0       0
    hfn-asa5520-01(config)# sh route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    Gateway of last resort is not set
    C    10.255.255.0 255.255.255.252 is directly connected, Failover
    hfn-asa5520-01(config)# no failover

  • The growth of the internet routing table + LISP

    I have been challenged with the task of putting together a 15-20 minute presentation of how I might go about solving the problem of the growth of the internet routing table.
    If I am understanding the question correctly - as the internet grows so will the number of IPv4 and (moreso) IPv6 prefixes that appear in the global internet routing table. This will mean that the PE and P routers in a Service Provider network will find themselves having to deal with more prefixes that will in turn increase the possibility of bogons interferring with proper routing and increase the load on the routers themselves.
    Besides being a very open ended question, I am trying to look at it from the perspective of a Service Provider (whom I work for) and have come up with the following options (admittedly this is only after a quick google on the topic):
    > Improvise in the short term by adjusting CAM table allocation
    > Use selective hearing by filtering prefixes that are not important
    > Use external assistance like LISP and DNS
    > Spend Money and upgrading existing routers to handle the load
    Obviously with only a 20 minute window I cannot talk about much and I would like the options to be innnovative and interesting. LISP seems like an interesting option and I would like to learn about it - however I am having trouble tracking down resources that give a basic introduction to exactly what and how LISP works (every time I try and search for it a get pushed to sites talking about the programming language ).
    So this leads me to two questions:
    1. Is there anything important, vital or interesting that I have not included in my quickly put together list above.
    2. Is anyone aware for a good site/resource that explains LISP from a beginners/tutorial-type perspective.

    I have been challenged with the task of putting together a 15-20 minute presentation of how I might go about solving the problem of the growth of the internet routing table.
    If I am understanding the question correctly - as the internet grows so will the number of IPv4 and (moreso) IPv6 prefixes that appear in the global internet routing table. This will mean that the PE and P routers in a Service Provider network will find themselves having to deal with more prefixes that will in turn increase the possibility of bogons interferring with proper routing and increase the load on the routers themselves.
    Besides being a very open ended question, I am trying to look at it from the perspective of a Service Provider (whom I work for) and have come up with the following options (admittedly this is only after a quick google on the topic):
    > Improvise in the short term by adjusting CAM table allocation
    > Use selective hearing by filtering prefixes that are not important
    > Use external assistance like LISP and DNS
    > Spend Money and upgrading existing routers to handle the load
    Obviously with only a 20 minute window I cannot talk about much and I would like the options to be innnovative and interesting. LISP seems like an interesting option and I would like to learn about it - however I am having trouble tracking down resources that give a basic introduction to exactly what and how LISP works (every time I try and search for it a get pushed to sites talking about the programming language ).
    So this leads me to two questions:
    1. Is there anything important, vital or interesting that I have not included in my quickly put together list above.
    2. Is anyone aware for a good site/resource that explains LISP from a beginners/tutorial-type perspective.

  • How to count number of default routes in routing table

    Is there a way for java to count the number of default routes in the routing table?

    Hi Sathish,
    If you are using table mean surely you are binding the table to some model like JSON model. You can bind the checked value of the column with the checkbox in the template. So while checking you can directly check the property by taking the reference from the model. Navigate through all the objects in the model and check  the property you wanted.
    This is the logic I have used to get the checked property form the table column. My table id is "tableId" and it is being binded with "/tableModelData" of json model.
      var myModel = sap.ui.getCore().getElementById("tableId").getModel().getProperty("/tableModelData");
      for(var i= 0 ; i< myModel.length ; i++)
      var singleObject = myModel [i];
      if(singleObject.checked ==  true){
    your logic.

Maybe you are looking for