Tree Optimization

Hi All!
I have a form named Chart of Accounts.
I make this form using tree patterns.
just on startup this form takes too much time to open because table of COA has 2500 records hence, it takes too much time to load.
kindly tell me the good way to resolve this problem.
i use following query to populate tree on startup:
SELECT
     1,
     LEV,
     ' ' || ACCOUNT_NO || ' -> ' || ACCOUNT_NAME,
     DECODE(IS_TRANSACTIONAL,'C','OPEN','T','NEW'),
     TO_CHAR(ACCOUNT_NO)
FROM
     ACCOUNTS_CHART
CONNECT BY
     PRIOR ACCOUNT_NO = PARENT_ACCOUNT_NO
AND      COMP_ID = :GLOBAL.COMP_ID
START WITH
     PARENT_ACCOUNT_NO IS NULL
AND      COMP_ID = :GLOBAL.COMP_ID
ORDER BY COMP_ID, ACCOUNT_NO

-- Specification
Package PK_Tree Is
     itTree Item := Find_Item( 'BL_TREE.IT_TREE' );
     Procedure PR_Fill_Tree;
     Procedure PR_WTNE( i_ndNode In Ftree.Node );
Procedure Pro_Release_Memory Is
End PK_Tree;
-- body
Package Body PK_Tree Is
Function Func_Add_Node( ndMaster In Ftree.Node,
                                                            ndValue In Varchar2,
                                                            ndLabel In Varchar2,
                                                            ndIcon In Varchar2 Default Null,
                                                            ndState In Number Default Ftree.Expanded_Node
                                                       ) Return Ftree.Node Is
Begin
Return Ftree.Add_Tree_Node( itTree,
                                                                      ndMaster,
                                                                      Ftree.Parent_Offset,
                                                                      Ftree.Last_Child,
                                                                      ndState,
                                                                      ndLabel,
                                                                      ndIcon,
                                                                      ndValue
End Func_Add_Node;
Procedure Pro_Query_Details( ndMaster               In Ftree.Node,
                                                                      ndMasterValue In Number
                                                                 ) Is
          Cursor crDetails Is
Select ACCOUNT_NO      Value,
               ' -> ' || ACCOUNT_NO || ' ' || ACCOUNT_NAME Label,
               Decode( IS_TRANSACTIONAL, 'C', 'OPEN', 'T', 'NEW') Icon
From ACCOUNTS_CHART
Where PARENT_ACCOUNT_NO = ndMasterValue
Order By ACCOUNT_NO;
nd Ftree.Node;
Begin
          -- show working message and set cursor state busy
          Set_Application_Property( Cursor_Style, 'BUSY' );
          Message( 'Please wiat! data is fetching...', No_Acknowledge );
          Synchronize;
For rec In crDetails Loop
-- add the node with a negative id
nd := Func_Add_Node( ndMaster, -rec.Value , rec.Label, rec.Icon );
-- don't add details here
End Loop;
          -- clear message and set cursor state normal
          Set_Application_Property( Cursor_Style, 'NORMAL' );
          Clear_Message;
End Pro_Query_Details;
Procedure PR_Fill_Tree Is
CURSOR crTop IS
SELECT ACCOUNT_NO      VALUE,
               ACCOUNT_NAME LABEL,
               Decode( IS_TRANSACTIONAL, 'C', 'OPEN', 'T', 'NEW') Icon
FROM ACCOUNTS_CHART
WHERE PARENT_ACCOUNT_NO IS NULL
ORDER BY ACCOUNT_NO;
nd Ftree.Node;
Begin
Ftree.Delete_Tree_Node( itTree, Ftree.Root_Node );
For rec In crTop Loop
-- add the node with a negative id
nd := Func_Add_Node( Ftree.Root_Node, -rec.VALUE , rec.LABEL, rec.Icon, Ftree.Collapsed_Node );
-- don't add details here
End Loop;
End PR_Fill_Tree;
Procedure PR_WTNE( i_ndNode In Ftree.Node ) Is
nValue Number;
ndDetail Ftree.Node;
Begin
-- Get the value of the node to be expanded
nValue := Ftree.Get_Tree_Node_Property( itTree, i_ndNode, Ftree.Node_Value );
If nValue < 0 Then
-- value is negative, then we have to read the details
Pro_Query_Details( i_ndNode, Abs( nValue ));
-- Now set the value of the node to positive, so that at next expansion we won't re-read the details
Ftree.Set_Tree_Node_Property( itTree, i_ndNode, Ftree.Node_Value, Abs( nValue ));
Ftree.Set_Tree_Node_Property( itTree, i_ndNode, Ftree.Node_State, Ftree.Expanded_Node );
End If;
     End PR_WTNE;
Procedure Pro_Release_Memory Is
Begin
          Ftree.Set_Tree_Node_Property( itTree, 1, Ftree.Node_State, Ftree.Collapsed_Node );
Ftree.Delete_Tree_Node( itTree, Ftree.Root_Node );
End Pro_Release_Memory;
End PK_Tree;

Similar Messages

  • Command Info spanning-tree optimize bpdu transmission

    Cannot find any information on CCO, anyone have a link or definition of this command ??

    "spanning-tree optimize bpdu transmission" enables the switch to send multiple BPDUs from the interrupt context thereby reducing the CPU usage for the transmission function.
    Note that not all platforms support it.
    PS: Remember to rate useful posts.

  • Routing Issue with 3550 Switch

    I am having an issue with routing with one of my Cisco 3550 switches.  I know the 3550s are EoL but some of us have to work with what we have.
    I am using a 3550 on either side of a Layer 2 link.  The Layer 2 link is 2 Extreme Summit X-440 switches with Microwave between the switches.  I have a VLAN configured on both switches and tagged on the ports connected to the Microwave.  The 3550 switch on each end is configured for IP routing but I cannot pass traffic between the switches.  If I unplug the switch on the local end and plug in a laptop, I can ping the switch on the remote end and access devices at the remote end. 
    I know this should work because I am doing the same thing over another Microwave link and Layer 2 link using another 3550 and a HP ProCurve at the remote end.
    Here are the configs for each 3550:
    Local end;  Port Fa0/23 goes to the Remote Side.  Port Fa0/24 goes to the rest of the network
    Current configuration : 5417 bytes
    ! No configuration change since last restart
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname Brindley3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring 1 Sun Apr 2:00 1 Sun Nov 2:00
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos min-reserve 5 170
    mls qos min-reserve 6 10
    mls qos min-reserve 7 65
    mls qos min-reserve 8 26
    mls qos
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    ip name-server 1.2.150.5
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 18
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    |
    interface FastEthernet0/7
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/8
     switchport access vlan 13
     switchport mode dynamic desirable
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     description To Gum Springs via Extreme P10
     no switchport
     ip address 1.2.147.1 255.255.255.252
     speed 100
     duplex full
    interface FastEthernet0/24
     description To Flint via Ceragon Eth 2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     mls qos trust cos
     auto qos voip trust
     wrr-queue bandwidth 20 1 80 1
     wrr-queue min-reserve 1 5
     wrr-queue min-reserve 2 6
     wrr-queue min-reserve 3 7
     wrr-queue min-reserve 4 8
     wrr-queue cos-map 1 0 1 2 4
     wrr-queue cos-map 3 3 6 7
     wrr-queue cos-map 4 5
     priority-queue out
     spanning-tree link-type point-to-point
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport access vlan 10
     switchport trunk native vlan 50
     switchport mode dynamic desirable
     spanning-tree portfast trunk
    interface Vlan1
     ip address 1.2.145.2 255.255.255.0
    ip default-gateway 1.2.145.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.145.1
    ip route 1.2.165.0 255.255.255.240 1.2.147.2
    ip route 1.2.166.0 255.255.255.240 1.2.147.2
    ip http server
    snmp-server community public RO
    snmp-server community public/RO RO
    snmp-server location Brindlee Mountain Tower Site
    snmp-server contact Jamey Wright
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  tty envmon syslog snmp
    control-plane
    ntp clock-period 17180143
    ntp server 1.2.150.21
    end
    And this is the config for the remote end.  Port Fa0/24 is the port for the link back to the local end.
    Current configuration : 5058 bytes
    version 12.2
    no service pad
    service timestamps debug datetime localtime show-timezone
    service timestamps log datetime localtime show-timezone
    no service password-encryption
    service sequence-numbers
    hostname GS3550
    enable secret 5 $1$3A.n$lzBUQg.fn4hJ7f0jEOqe71
    no aaa new-model
    clock timezone UTC -6
    clock summer-time UTC recurring
    mls qos map cos-dscp 0 8 16 24 32 46 46 56
    udld aggressive
    ip subnet-zero
    ip routing
    ip domain-name morgan911.net
    ip name-server 1.2.150.11
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    interface FastEthernet0/1
     switchport access vlan 21
     switchport mode dynamic desirable
     spanning-tree portfast
    interface FastEthernet0/2
     switchport access vlan 21
     switchport mode dynamic desirable
     power inline delay shutdown 20 initial 300
     spanning-tree portfast
    {Removed for Brevity}
    interface FastEthernet0/23
     switchport access vlan 22
     switchport trunk encapsulation dot1q
     switchport mode trunk
     speed 100
     duplex full
     spanning-tree portfast
    interface FastEthernet0/24
     description To Brindlee via Extreme P10
     switchport mode dynamic desirable
    (Is a member of VLAN 1)
     speed 100
     spanning-tree portfast
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     spanning-tree portfast
    interface Vlan1
     ip address 1.2.147.2 255.255.255.252
    interface Vlan21
     ip address 1.2.165.1 255.255.255.240
     ip helper-address 1.2.150.11
     ip helper-address 1.2.150.5
    interface Vlan22
     ip address 1.2.166.1 255.255.255.240
     ip helper-address 1.2.150.5
     ip helper-address 1.2.150.11
    ip default-gateway 1.2.147.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 1.2.147.1 10
    ip http server
    snmp-server community public RO
    snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
    snmp-server enable traps cluster
    snmp-server enable traps entity
    snmp-server enable traps envmon fan shutdown supply temperature
    snmp-server enable traps vtp
    snmp-server enable traps vlancreate
    snmp-server enable traps vlandelete
    snmp-server enable traps flash insertion removal
    snmp-server enable traps port-security
    snmp-server enable traps config
    snmp-server enable traps hsrp
    snmp-server enable traps bridge newroot topologychange
    snmp-server enable traps syslog
    snmp-server enable traps mac-notification
    snmp-server enable traps vlan-membership
    snmp-server host 1.2.150.100 public  envmon syslog snmp
    control-plane
    ntp clock-period 17180192
    ntp server 1.2.150.21 key 0 prefer
    Ideas?  Anything stand out as grossly wrong?  I have worked on this for 2 days and am at a loss.
    Thanks
    Jamey

    Sorry for the delay in replying.  Other items at the office took priority over this project.  I tried that and no change.  I pulled the switch from the remote site and took it back to the local end and connected the switches with a crossover cable and everything works fine.  I have pretty much determined that it is an issue with the config in one of the Extreme switches.  The config in those look pretty normal but there are a few things I am unsure of.  Guess I'll see if there is a similar site for Extreme gear.
    Thanks
    Jamey

  • Packet Loss after Reboot of ASA 5510

    Hi all,
    I have an ASA and a 2811 behind it and I had to replace a battery on a UPS so I had to take down the network to do it. Before doing it the network ran fine, but I did a WR MEM and a Copy RUNNING to STARTUP config thinking that the configs I had were fine. At some point in the past I must of made a change and never applied it and maybe it is causing the issue, but I am at a loss as to what is the cause. I am getting consistent packet loss from the ASA out. Any address I ping on the inside is clear and quick. Also, I do not know if it is related, but I cannot get results from TRACE ROUTES and I believe I used to.
    I have confirmed the PL is related to my network, if I plug the static IP info from the provider in to a laptop, it is clear. I am at my wits end, and I know just enough to be dangerous, so any help would be appreciated.
    Here are my configs:
    ASA5510# sh run
    : Saved
    ASA Version 9.1(4)
    hostname ASA5510
    domain-name m.int
    enable password encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd  encrypted
    names
    dns-guard
    interface Ethernet0/0
     description LAN Interface
     nameif Inside
     security-level 100
     ip address 10.10.1.1 255.255.255.252
    interface Ethernet0/1
     description WAN Interface
     nameif Outside
     security-level 0
     ip address 68.233.x.x 255.255.255.128
    interface Ethernet0/2
     description DMZ
     nameif DMZ
     security-level 100
     ip address 10.10.0.1 255.255.255.252
    interface Ethernet0/3
     description VOIP
     nameif VOIP
     security-level 100
     ip address 10.10.2.1 255.255.255.252
    interface Management0/0
     management-only
     shutdown
     nameif management
     security-level 0
     no ip address
    boot system disk0:/asa914-k8.bin
    ftp mode passive
    dns domain-lookup Inside
    dns domain-lookup Outside
    dns server-group DefaultDNS
     name-server 8.8.8.8
     name-server 8.8.4.4
     name-server 68.233.xx.5
     name-server 68.233.xx.6
     domain-name m.int
    same-security-traffic permit inter-interface
    object network ROUTER-2811
     host 10.10.1.2
    object network ROUTER-2821
     host 10.10.0.2
    object network WEBCAM-01
     host 192.168.1.5
    object network DNS-SERVER
     host 192.168.1.2
    object network ROUTER-3745
     host 10.10.2.2
    object network RDP-DC1
     host 192.168.1.2
    object network BLUE
     host 192.168.1.6
     description Blue Iris Server
    object network M_LAP_LEA
     host 192.168.1.20
     description Laptop from LEA
    object-group network PAT-SOURCE
     network-object 10.10.1.0 255.255.255.252
     network-object 10.10.0.0 255.255.255.252
     network-object 10.10.2.0 255.255.255.252
     network-object 192.168.0.0 255.255.255.0
     network-object 172.16.10.0 255.255.255.0
     network-object 172.16.20.0 255.255.255.0
     network-object 128.162.1.0 255.255.255.0
     network-object 128.162.10.0 255.255.255.0
     network-object 128.162.20.0 255.255.255.0
     network-object 192.168.1.0 255.255.255.0
     network-object 192.168.10.0 255.255.255.0
     network-object 192.168.20.0 255.255.255.0
     network-object 172.16.1.0 255.255.255.0
     network-object 162.128.1.0 255.255.255.0
     network-object 162.128.10.0 255.255.255.0
     network-object 162.128.20.0 255.255.255.0
     network-object 142.16.1.0 255.255.255.0
     network-object 142.16.10.0 255.255.255.0
     network-object 142.16.20.0 255.255.255.0
    object-group network DM_INLINE_NETWORK_2
     network-object host 98.22.xxx
    object-group network Outside_access_in
    object-group protocol DM_INLINE_PROTOCOL_1
     protocol-object gre
    access-list USERS standard permit 10.10.1.0 255.255.255.0
    access-list Outside_access_in extended permit tcp host 98.22.xxx object ROUTER-2811 eq ssh
    access-list Outside_access_in extended permit tcp host 98.22.xxx object ROUTER-2821 eq ssh
    access-list Outside_access_in extended permit tcp host 98.22.xxx interface Outside eq https
    access-list Outside_access_in extended permit tcp host 98.22.xxx object WEBCAM-01 eq www inactive
    access-list Outside_access_in extended permit tcp host 98.22.xxx object RDP-DC1 eq xxxx
    access-list Outside_access_in extended permit tcp host 98.22.xxx object BLUE eq xxxx
    access-list Outside_access_in extended permit tcp host 98.22.xxx object ROUTER-3745 eq ssh
    access-list Outside_access_in extended permit tcp any object BLUE eq xxxx
    access-list dmz-access-vlan1 extended permit ip 128.162.1.0 255.255.255.0 any
    access-list dmz-access remark Permit all traffic to DC1
    access-list dmz-access extended permit ip 128.162.1.0 255.255.255.0 host 192.168.1.2
    access-list dmz-access remark Permit only DNS traffic to DNS server
    access-list dmz-access extended permit udp 128.162.1.0 255.255.255.0 host 192.168.1.2 eq domain
    access-list dmz-access remark Permit ICMP to all devices in DC
    access-list dmz-access extended permit icmp 128.162.1.0 255.255.255.0 192.168.1.0 255.255.255.0
    access-list dmz-access remark Permit all traffic to DC1
    access-list dmz-access remark Permit only DNS traffic to DNS server
    access-list dmz-access remark Permit ICMP to all devices in DC
    pager lines 24
    logging enable
    logging asdm informational
    mtu Inside 1500
    mtu Outside 1500
    mtu DMZ 1500
    mtu VOIP 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp deny any Outside
    asdm image disk0:/asdm-715.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network ROUTER-2811
     nat (Inside,Outside) static interface service tcp ssh x
    object network ROUTER-2821
     nat (DMZ,Outside) static interface service tcp ssh x
    object network WEBCAM-01
     nat (Inside,Outside) static interface service tcp www x
    object network ROUTER-3745
     nat (VOIP,Outside) static interface service tcp ssh x
    object network RDP-DC1
     nat (Inside,Outside) static interface service tcp xxxx xxxx
    object network BLUE
     nat (Inside,Outside) static interface service tcp xxxx xxxx
    nat (any,Outside) after-auto source dynamic any interface
    access-group Outside_access_in in interface Outside
    route Outside 0.0.0.0 0.0.0.0 68.233.151.1 1
    route DMZ 128.162.1.0 255.255.255.0 10.10.0.2 1
    route DMZ 128.162.10.0 255.255.255.0 10.10.0.2 1
    route DMZ 128.162.20.0 255.255.255.0 10.10.0.2 1
    route VOIP 142.16.1.0 255.255.255.0 10.10.2.2 1
    route VOIP 142.16.10.0 255.255.255.0 10.10.2.2 1
    route VOIP 142.16.20.0 255.255.255.0 10.10.2.2 1
    route Inside 172.16.10.0 255.255.255.0 10.10.1.2 1
    route Inside 172.16.20.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.1.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.10.0 255.255.255.0 10.10.1.2 1
    route Inside 192.168.20.0 255.255.255.0 10.10.1.2 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server PNL-RADIUS protocol radius
    aaa-server PNL-RADIUS (Inside) host 192.168.1.2
     key *****
     radius-common-pw *****
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 Inside
    http 98.22.xxx 255.255.255.255 Outside
    snmp-server host Inside 192.168.1.2 community ***** version 2c udp-port 161
    snmp-server location Lovington NM USA
    snmp-server contact Mitchell Tuckness
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Inside
    ssh 98.22.xxx 255.255.255.255 Outside
    ssh timeout 60
    ssh version 2
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ntp server 24.56.178.140 source Outside prefer
    username xxxx password x encrypted privilege 15
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns migrated_dns_map_1
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
      inspect icmp error
      inspect pptp
     class class-default
      user-statistics accounting
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
     profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    password encryption aes
    hpm topN enable
    Cryptochecksum:949189d67866f6c09450769d41649992
    : end
    C2811#sh run
    Building configuration...
    Current configuration : 3925 bytes
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname C2811
    boot-start-marker
    boot system flash
    boot-end-marker
    enable secret 4 DWJfYBf6KhkIRmhhIhx8ibAAXVGQWjwfuyzfaX4Im8M
    aaa new-model
    aaa session-id common
    dot11 syslog
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip domain name maladomini.int
    ip name-server 192.168.1.2
    ip name-server 8.8.8.8
    ip name-server 68.233.xxx.x
    ip name-server 68.233.xxx.x
    no vlan accounting input
    multilink bundle-name authenticated
    password encryption aes
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1290569776
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1290569776
     revocation-check none
     rsakeypair TP-self-signed-1290569776
    crypto pki certificate chain TP-self-signed-1290569776
     certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31323930 35363937 3736301E 170D3134 30313035 30363130
      33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32393035
      36393737 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100B18F F63C5121 00785DE0 854601BA EE77DAA3 21286D8C 6E700C37 237CC1BE
      611023AF FBE04BBE 7B4B3233 E4E129DD A74604E5 62AA39BF 77F98D5D D63944E9
      2345AE37 D93C5753 E425E85A EB22C2C9 CFC5D1A0 F800449B 0419A5C8 A0A101EC
      02928172 7B30A609 71ADA3D4 68F4F484 AF2B3249 0E225DB2 C72C136A E670D761
      DDE30203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 1461F6DE 8EF50F7B 0E46359F 421EA106 9375F65F 30301D06
      03551D0E 04160414 61F6DE8E F50F7B0E 46359F42 1EA10693 75F65F30 300D0609
      2A864886 F70D0101 05050003 81810049 BA55F695 8525265F ED2D77EE 8706BF10
      63A7E644 202F6663 9EA5551F 47F7FC50 D4021EDD E3DC5A80 39FD161A C337D20D
      71B98875 0F1FE887 649E81D3 F93F7A1B A1E18B99 A77B1A59 84DB4711 867913FD
      044084FB 651ECA6E C6EDF35C E43A2946 8C01781E 26DB9484 C8740A82 4A7CA266
      A0655526 CBCB4982 F30D68E9 D70753
            quit
    license udi pid CISCO2811 sn FTX1041A07T
    username admin secret 5 $1$iBeC$8dqYMcpTex8gtUfannzox.
    username xxxx privilege 15 secret 4 DWJfYBf6KhkIRmhhIhx8ibAAXVGQWjwfuyzfaX4Im8M
    redundancy
    ip ssh time-out 60
    ip ssh authentication-retries 5
    ip ssh version 2
    interface FastEthernet0/0
     description CONNECTION TO INSIDE INT. OF ASA
     ip address 10.10.1.2 255.255.255.252
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface FastEthernet0/1
     no ip address
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface FastEthernet0/1.1
     description VLAN 10
     encapsulation dot1Q 10
     ip address 192.168.10.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface FastEthernet0/1.2
     description VLAN 20
     encapsulation dot1Q 20
     ip address 192.168.20.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface FastEthernet0/1.3
     description Trunk Interface VLAN 1
     encapsulation dot1Q 1 native
     ip address 192.168.1.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface Dialer0
     no ip address
    ip default-gateway 10.10.1.1
    ip forward-protocol nd
    no ip http server
    ip http authentication local
    ip http secure-server
    ip dns server
    ip route 0.0.0.0 0.0.0.0 10.10.1.1
    ip ospf name-lookup
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    snmp-server community Maladomini-RW RW
    tftp-server system:running-config 1
    control-plane
    line con 0
     exec-timeout 0 0
     password 7 101D58415D361606050A147A
    line aux 0
    line vty 0 4
     exec-timeout 0 0
     password 7 0527031B2C49470758
     transport input ssh
    scheduler allocate 20000 1000
    end
    2821:
    C2821#sh run
    Building configuration...
    Current configuration : 4128 bytes
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname C2821
    boot-start-marker
    boot system flash
    boot-end-marker
    enable secret 4 x
    aaa new-model
    aaa session-id common
    dot11 syslog
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip domain name maladomini.int
    ip name-server 192.168.1.2
    ip name-server 8.8.8.8
    ip name-server 68.233.xxx.x
    ip name-server 68.233.xxx.x
    no vlan accounting input
    multilink bundle-name authenticated
    password encryption aes
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-3335929422
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-3335929422
     revocation-check none
     rsakeypair TP-self-signed-3335929422
    crypto pki certificate chain TP-self-signed-3335929422
     certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 33333335 39323934 3232301E 170D3134 30313135 30333537
      32385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33333539
      32393432 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100AF6D 8C23745E 80AA83AC BE0243DD C8F8EC56 85BBE495 EF790354 B7E81921
      4C46CE35 F840420A 8385D3E3 B7B14EDF F4A8DB51 1A29E0ED A2704F69 9632ED7E
      5F66E546 486B2821 FB77266F 950D351E 13AA18FE 687643F6 FB9BF95F E56A0195
      19B8A7B6 7A582357 2517F08E 5E3BA197 2CD71E3E 32AB4B96 412E9AE3 1932A218
      7A1F0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14A86115 C2CA9E15 399B2A9C 21585323 1E2F3D98 45301D06
      03551D0E 04160414 A86115C2 CA9E1539 9B2A9C21 5853231E 2F3D9845 300D0609
      2A864886 F70D0101 05050003 81810028 81D8F701 D6AFDC54 94A93185 1E5F4DAC
      4DBF50B7 30B57ABD D1612E69 D964B77A A379F55C 7E823F42 4D01440C B237DED9
      6B8047B7 0496D8BB BD7EAC18 E6ACA1B1 3B527172 4A7B0D7B 4A031168 F99B171D
      D217CB06 2F31E4DF FD9AC1C9 1199869A 34E90671 5611A6DA 7CC6A7B0 A39F78FB
      B3932E37 4B302779 E761DB00 AFA7CC
            quit
    license udi pid CISCO2821 sn FTX1327AH7A
    username x privilege 15 secret 4 x
    redundancy
    ip ssh time-out 60
    ip ssh authentication-retries 5
    ip ssh version 2
    interface GigabitEthernet0/0
     description CONNECTION TO INSIDE INT. OF ASA
     ip address 10.10.0.2 255.255.255.252
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     no ip address
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface GigabitEthernet0/1.1
     description VLAN 10
     encapsulation dot1Q 10
     ip address 128.162.10.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface GigabitEthernet0/1.2
     description VLAN 20
     encapsulation dot1Q 20
     ip address 128.162.20.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface GigabitEthernet0/1.3
     description Trunk Interface VLAN1
     encapsulation dot1Q 1 native
     ip address 128.162.1.1 255.255.255.0
     ip helper-address 192.168.1.2
     ip virtual-reassembly in
    interface Serial0/0/0
     no ip address
     shutdown
    interface Serial0/1/0
     no ip address
     shutdown
    interface Serial0/2/0
     no ip address
     shutdown
    interface Dialer0
     no ip address
    ip default-gateway 10.10.0.1
    ip forward-protocol nd
    no ip http server
    ip http authentication local
    ip http secure-server
    ip dns server
    ip route 0.0.0.0 0.0.0.0 10.10.0.1
    ip ospf name-lookup
    access-list 1 permit any
    dialer-list 1 protocol ip permit
    snmp-server community Maladomini-RW RW
    snmp-server host 192.168.1.2 version 2c Maladomini-RW  envmon cpu snmp
    control-plane
    line con 0
     exec-timeout 0 0
     password 7 101D58415D361606050A147A
    line aux 0
    line vty 0 4
     exec-timeout 0 0
     password 7 15415A545C0B2F29213D0B73
     transport input ssh
    scheduler allocate 20000 1000
    end
    POE Switch:
    C3560#sh run
    Building configuration...
    Current configuration : 7368 bytes
    version 12.2
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname C3560
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$wzS5$Kl0aHmGjOrfNL8H8QN9gJ1
    enable password 7 091F1F514124131F02023A7B
    username mtuckness privilege 15 secret 5 $1$j68Z$ObA6K7Qc2Vsmyu479Hlh6/
    aaa new-model
    aaa session-id common
    clock timezone MST -7
    system mtu routing 1500
    ip domain-name maladomini.int
    password encryption aes
    crypto pki trustpoint TP-self-signed-2488747392
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2488747392
     revocation-check none
     rsakeypair TP-self-signed-2488747392
    crypto pki certificate chain TP-self-signed-2488747392
     certificate self-signed 01
      3082024C 308201B5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32343838 37343733 3932301E 170D3933 30333031 30303031
      30385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34383837
      34373339 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100B715 1CCA0EFB 6D550F27 A4B9F403 7D1CBCCE AB363F89 61AF4773 64351010
      AB866AA6 411463BC A7D9C6E3 0CA4EEEC 47C50D33 2F904AD1 8FC5B10B 8F204157
      FB5B3A4C 78BD4BDF 14F79CCC D9A0E10B 909BF5BA 095BB9AC 722197D4 3C2CB70B
      15D2A221 5FF8BC03 6A642B36 437B9E22 858BF597 F1844026 5DAF2114 EF75718D
      EC3B0203 010001A3 74307230 0F060355 1D130101 FF040530 030101FF 301F0603
      551D1104 18301682 14433335 36302E6D 616C6164 6F6D696E 692E696E 74301F06
      03551D23 04183016 8014D364 9162E0D2 C7936513 1E1C677C 73D675EC 37FF301D
      0603551D 0E041604 14D36491 62E0D2C7 9365131E 1C677C73 D675EC37 FF300D06
      092A8648 86F70D01 01040500 03818100 2DE49969 2E9C7A81 E96B97A8 7E15BC69
      2DA62233 C958092D 2E51DD59 526DA795 CBFE219E 3536852A 5F71A90A BF5016E0
      F93FA6F7 55D9BA23 52A2858E B927E0FB B3DC6B20 28FBD64C 6FA956EC 3E6E8756
      F12F7182 538D13AE E343674E 41A1BDE1 A42579F2 8070FC92 5C805995 7BA25FA5
      3A89C4E5 C6B2D76F FF2C1CF9 6A8DF631
      quit
    spanning-tree mode pvst
    spanning-tree portfast bpduguard default
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    vlan internal allocation policy ascending
    ip ssh time-out 60
    ip ssh authentication-retries 5
    ip ssh version 2
    interface FastEthernet0/1
     switchport mode access
     spanning-tree portfast
    interface FastEthernet0/2
     switchport mode access
     spanning-tree portfast
    Removed interfaces
    interface GigabitEthernet0/1
     description CONNECTION TO 2821 ROUTER - TRUNK
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,10,20
     switchport mode trunk
    interface GigabitEthernet0/2
    interface GigabitEthernet0/3
    interface GigabitEthernet0/4
    interface Vlan1
     ip address 128.162.1.3 255.255.255.0
     ip helper-address 192.168.1.2
     no ip route-cache
     no ip mroute-cache
    interface Vlan10
     ip address 128.162.10.3 255.255.255.0
     ip helper-address 192.168.1.2
    interface Vlan20
     ip address 128.192.20.3 255.255.255.0
     ip helper-address 192.168.1.2
    ip default-gateway 10.10.0.2
    no ip classless
    ip http server
    ip http authentication local
    ip http secure-server
    access-list 1 permit any
    snmp-server community Maladomini-RW RO
    snmp-server location Lovington NM USA
    line con 0
     exec-timeout 0 0
     password 7 075C701416281D081E1C355D
    line vty 0 4
     password 7 0527031B2C49470758
     transport input ssh
    line vty 5 15
     exec-timeout 0 0
     password 7 05585757796D4A04100B2943
    end

    I located the issue of the packet loss. I have a security system that uploads FTP images of the cameras and after the reboot of the network, the only computer that wasn't shut down was the security camera PC.
    So I think what happened was after I brought everything back up, it was saturating the outgoing bandwidth, causing packet loss and high latency. Once I determined what it was and shut off the FTP image upload, the pings stabilized and it is working fine now. Trace routes are still not functioning, but I can live without that for now.

  • Book default page doesn't display

    I have a portal with several books with a few pages each. the books are tied to a single level menu across the top, the pages are all set to no navigation. The "Return to default page" is set to true and a default page is set.
    The problem is that after I initially load the book, if I navigate to another page in the book and then try to get back to the book (using an anchor tag and render:pageUrl or by navigating to another book and then back again) the default page never shows up again. I can get it if I access it directly with pageLabel=pagename, but pageLabel=book doesn't work.
    I have tried setting up pageChangeEvents in the handlepostback of the book, but to no avail. The default page just never shows up again.

    As I am sure that you know it is tough to dissect portals to send good examples... I do have some more information. I turned off Tree Optimization and it has had a partially positive impact. Now when you navigate between books via the single level menu the default page loads, albeit notably slower.
    Where it doesn't work is where my manual book links rendered in the children pages do not reload the default page for the parent book.
    Let me explain this a little: I have pages within books, each page is in two column layout with a menu on the left. The top menu item on the left is a link back to the parent book (which should display the default page). This link does not reload the default page, it remains on the current page, the url in the navigation bar clearly contains the book url.
    The urls for the single level menu and my custom book link appear to be identical, but one works, the other doesn't:
    <i>http://localhost:7001/v2portal/modine.portal?_nfpb=true&_pageLabel=modineNewsRoom</i>
    I have tried _nfto=false, but that hasn't worked either.
    It is almost like the portal isn't sending control up high enough on the tree to recognize what it really needs to do, which is re-render the book.

  • LMS config deployement with new device

    Hello,
    I have recovered some configuration files from my 2950 switches with the Configuration Archive Tool in LMS.
    Now, I'd like to replace my old 2950s by 2960 switches, which have the same number of ports.
    Will there be any issue if I copy the exact same config from 2950 to 2960 ? Will some features not work or is everything interoperable ?
    Here's an extract of the config :
    Global
    version 12.1
    no service pad
    service timestamps debug  datetime
    service timestamps log datetime
    no service password-encryption
    hostname sw48
    logging buffered 20000 debugging
    enable secret 5  ********
    enable password ********
    clock timezone UTC 1
    clock  summer-time UTC recurring last Sun Mar 2:00 last Sun Oct 3:00
    ntp  clock-period 17179870
    ntp server 192.168.32.17
    ntp server 192.168.32.18
    IP
    IP Global
    ip subnet-zero
    ip default-gateway  172.25.1.1
    ip http server
    Spanning Tree
    spanning-tree mode  rapid-pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree  extend system-id
    Interface
    Interface FastEthernet0/1
    interface FastEthernet0/1
    switchport trunk allowed vlan 1,17,1001-1005
    switchport mode trunk
    switchport voice vlan 17
    spanning-tree  portfast
    Interface Vlan1
    interface Vlan1
    no ip address
    no ip  route-cache
    shutdown
    Interface Vlan25
    interface Vlan25
    ip  address 172.25.11.48 255.255.0.0
    no ip route-cache
    SNMP
    snmp-server community ******** RO
    snmp-server community ******** RW
    Line
    Line con 0
    line con 0
    Line vty 0 4
    line vty 0 4
    password ********
    login
    Line vty 5 15
    line vty 5 15
    password ********
    login
    Thank you for your further help !

    The 2960 is just an upgrade of the 2950 switch much like the 2960S is an upgrade of the 2960 so there should be no major problems unless there are some weird commands on the interfaces themselves. Nothing shown above looks like it wouldn't work to me.
    You may want to go through the config a little, having enable secret and enable password is worthless, only keep enable secret, it is more secure. service password-encryption and some ACL's on SNMP might also be worth considering, depends how security concencious you are. Also the new enable secret command on IOS 15.1+ I think uses encryption type 4 to encrypt the password, again more secure but up to you. I'm guessing this is more about will it work rather than pointing out best practices that are fairly well documented by many others.
    If you do come across a line of unsupported config the 2960 should give a warning or error anyway, things don't go boom and blow blue smoke, most of the time anyway.

  • If we run a query,what all happens in background/what are phases of query processesing.?

    Hi Friends,
    if we run a query,what all happens in background/what are phases of query processesing.?
    Many thanks
    Shashikala

    It has to go through
    Parsing-on this stage it perform basic check on code (T-SQL,
    Binding(Algebrizer Stage)-on this stage does more parsing and perform query tree,
    Optimize- on this stage take query tree from Binding and parsing and find a better way to return the result that you need so cost might apply here and then
    Execute 
    To know about transaction Log we have to know first how Transaction log file internally works: when you are trying to make change in data as Insert, Update, Delete requests
    from applications using T-SQL or on object explorer, SQL Server will load (load) to the corresponding page data memory where we call this memory area as DATA CACHE.  Then the data in the data cache are changed which is also known as known as DIRTY PAGE.
    Next all changes we made by running query will be recorded in the transaction log file so they called the write-ahead log. At final stage, a process known as CHECK POINT PROCESS will check and write all the transaction has been committed AND completed to your
    hard drive by flushing the page.
    So simply put here are the steps
    Data modification sent by application
    Data pages are located in or read into, cache and modified
    Modification is recorded in transaction log on DISK
    Checkpoint writes committed transactions to database
    I hope this helps a bit in answering your question good luck.

  • Interface flapping and always shows up/up even other side is shutdown

    Hi, there, I have a interface flapping issue in my network. 2 Cat3560 is connected through 2 trunk port configured with port-channel. When I shutdown one of port in Vlan100, other 2 ports in the same vlan will flap going up and down and OSPF will lose the neighbor. One thing I notice that is when I shutdown the switch port, on the other side of router, the L1-L2 is still up/up. I think it should be up/down. I have a keepalive setting on the router interface to 1800. Any body can give me some hints here to troubleshoot?
    Here is the switch configs.
    Building configuration...
    no service pad
    ip subnet-zero
    ip routing
    no ip domain-lookup
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 999
    switchport trunk allowed vlan 100,200,300,400,600,700
    switchport mode trunk
    interface GigabitEthernet0/1
    switchport access vlan 600
    speed 100
    duplex full
    interface GigabitEthernet0/2
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/3
    switchport access vlan 600
    speed 100
    duplex full
    interface GigabitEthernet0/4
    switchport access vlan 700
    speed 100
    duplex full
    interface GigabitEthernet0/5
    switchport access vlan 700
    speed 100
    duplex full
    interface GigabitEthernet0/6
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/7
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/8
    switchport access vlan 100
    interface GigabitEthernet0/9
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/10
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/11
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/12
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/13
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/14
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/15
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/16
    switchport access vlan 100
    speed 100
    duplex full
    interface GigabitEthernet0/17
    speed 100
    duplex full
    interface GigabitEthernet0/27
    switchport access vlan 400
    interface GigabitEthernet0/28
    switchport access vlan 400
    interface GigabitEthernet0/29
    switchport access vlan 400
    interface GigabitEthernet0/30
    switchport access vlan 200
    interface GigabitEthernet0/31
    switchport access vlan 200
    interface GigabitEthernet0/45
    switchport access vlan 500
    speed 100
    duplex full
    interface GigabitEthernet0/46
    switchport access vlan 500
    speed 100
    duplex full
    interface GigabitEthernet0/47
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 999
    switchport trunk allowed vlan 100,200,300,400,600,700
    switchport mode trunk
    channel-group 1 mode on
    interface GigabitEthernet0/48
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 999
    switchport trunk allowed vlan 100,200,300,400,600,700
    switchport mode trunk
    channel-group 1 mode on
    interface Vlan1
    no ip address
    shutdown
    interface Vlan100
    ip address 192.168.40.11 255.255.252.0
    no ip redirects
    no ip proxy-arp
    standby 1 ip 192.168.40.1
    standby 1 priority 110
    standby 1 preempt
    standby 1 track Vlan600 20
    interface Vlan200
    no ip address
    interface Vlan600
    ip address 192.168.35.1 255.255.255.0
    router ospf 7
    log-adjacency-changes
    network 192.168.0.0 0.0.255.255 area 0
    ip classless
    =====================
    When I shutdown interface gig 0/2, interface gig0/3 and gig0/4 will go down as well and come back online after a while.
    Thanks for your help.

    Your question is really missing a BUNCH of details, but I will take a stab at it:
    1) Why on earth do you have a keepalive set to 1800 seconds on the router?
    2) Your discussion and config above only talks about qty 2 c3560 switches. Where is the router in this topology?
    3) You are going against several Cisco best practices here with your trunk ports:
    a) I would never config a port-channel as mode 'on' because the switches will ignore any errors on the ports that would not keep the channel stable because you have configured them to hard set on. ALWAYS set the port channel to mode 'desirable silent'. The config needs to match on both ends of the link.
    b) I would never config a port as a trunk mode 'on' without also running UDLD. It appears that your 2-port port-channel trunk above is using copper ports. You MUST enable UDLD on the copper gigabit ports manually (UDLD is enable by default on fiber gigabit ports). You may need to 'udld enable' globally on the switch depending on the IOS version. Obviously, as above, the same config needs to be done on both switches.
    4) The log message that you get when you say ports g0/3 and g0/4 go down, is that for just VLAN 100 or are they line-protocol messages?
    5) When port g0/2 goes down, are there any other ports in VLAN 100 still up?
    6) What are the results of the following commands:
    show int g0/3 switchport
    show spanning-tree summary
    show spanning-tree int po1
    show spanning-tree int g0/2
    show spanning-tree int g0/3
    show spanning-tree int g0/4
    show spanning-tree vlan 100
    show spanning-tree vlan 600
    show int status
    show etherchannel summary
    show etherchannel detail
    show int trunk mod 0
    Post more details and I'll try to help...

  • Backing file question

    Very basic question
    I have three page --page 1 , page2 and page 3
    I have attached the below backing file to page2
    The println statement always says curPage to be page2 even when I click other pages (page1 and page3) I;m not clear why backing file is executed when page 1 and page 3 is clicked. any pointers?
    package age;
    import com.bea.netuix.servlets.controls.page.PageBackingContext;
    import javax.servlet.http.HttpServletRequest;
    import javax.servlet.http.HttpServletResponse;
    public class testPageBackingFile extends com.bea.netuix.servlets.controls.content.backing.AbstractJspBacking
    public boolean handlePostbackData(HttpServletRequest request, HttpServletResponse response) {
    PageBackingContext testContext = PageBackingContext.getPageBackingContext(request);
    String curPage = testContext.getLabel();
    system.out.println("curPage" + curPage);
    String newPage;
    try {
    Integer.parseInt(request.getParameter("age"));
    newPage = "page5";
    } catch (NumberFormatException nfe) {
    newPage = "page2";
    if(!curPage.equals(newPage)) {
    testContext.setupPageChangeEvent(newPage);
    return true;
    } else {
    return false;
    }

    Hello,
    Unless "Control Tree Optimization" is turned on, the handlePostbackData() method of every backing file in the whole desktop will generally be run, even if the page / book / portal the backing file is attached to is not being displayed.
    Kevin

  • Backing file init method always called for proxy portlets

    Hello,
    We are currently using Weblogic Portal 10 MP1. Deployed within our Portal EAR is a local proxy portlet and attached to this proxy portlet is a backing file, which currently implements the init() and prerender() methods from the backing interface.
    When this is placed in a page that is within a desktop, the init() method is always invoked no matter which page you access within the desktop. As I understand it from the documentation, if you have "tree optimization" turned on, then the init() method will only be called when rendering the actual page the proxy portlet is in. But this doesn't seem to be the case. However, if I define a standard Java portlet within the EAR and attach a backing file, then the init() follows the rules when tree optimization is turned on or off.
    Does anyone know if this is a defect within the portal framework, or is this expected and proxy portlets do not follow this rule?
    And I guess, if it is a defect or known limitation, is there a possible workaround? I assume the simplest workaround will be to move the logic into the prerender() method.
    Regards,
    Jonathan

    Hello Jonathan,
    Tree optimization is a tricky thing- some portlets may still be initialized even when the page they are on isn't visible. The rules for which get initialized and which don't are very complicated and depend on a number of things, so it is just best to not rely on the init() method not getting called.
    By far the best option for your use-case is to have the proxy portlet listen to the "onRefresh" event, and move the logic from the backing file's init() method into an event-handling method in the backing file, then have this method called when the refresh event is received. Here's a sample portion of the .portlet file for doing this:
    <netuix:handlePortalEvent event="onRefresh" eventLabel="onRefreshEvent">
        <netuix:invokeBackingFileMethod method="handleRefreshEvent"/>
    </netuix:handlePortalEvent>The "onRefresh" event is sent to the portlet only when it is visible on the page, so it should work perfectly for your use-case.
    Kevin

  • Getting hierarchy of books and pages in portal - sitemap

    Hi,
    I am using BEA Portal 8.1 SP5. I want to get a list of all the books and pages (up to the lowest level as one book can contain multiple books) contained in the portal. I am using BookPresentationContext.getEntitledPagePresentationContexts function. I also tried getPagePresentationContexts function. These functions return data only for active books. If user is not within a book, I do not get information about all children of this book.
    Is there a way to get hierarchy of all available books/pages? I want to use this information to create sitemap. Is there another way to do it with in portal?
    I would appreciate any help in this regards.
    Thank you,
    mqassim

    mqassim wrote:
    Hi,
    I am using BEA Portal 8.1 SP5. I want to get a list of all the books and pages (up to the lowest level as one book can contain multiple books) contained in the portal. I am using BookPresentationContext.getEntitledPagePresentationContexts function. I also tried getPagePresentationContexts function. These functions return data only for active books. If user is not within a book, I do not get information about all children of this book.
    Is there a way to get hierarchy of all available books/pages? I want to use this information to create sitemap. Is there another way to do it with in portal?
    I would appreciate any help in this regards.You have tree optimization on hence you only get the active items. To disable
    this for a specific request, such as to your site map, include the parameter
    _nfto=false in the link. See the docs on tree optimization for more info here:
    http://e-docs.bea.com/wlp/docs81/taxonomy/taxonomy.html
    In particular, look at the section "Disabling Tree Optimization"
    Gerald

  • SetupPageChangeEvent 8.1 sp3 navigate to a page in other bookrom backing

    I am using 8.1 sp3 and have this issue with setupPageChangeEvent. Appreciate any help to resolve this.
    I have book2 inside a main book (book1). book1 has several pages and and book2. I have attached a backing file to book2 and trying to redirect the user to a book1 default page if the user access any page of book2 directly. Below code doesnot give any error and does not work. It simply executes the code and still goes to book2 page instead of book1.
    backing file for book2 .. handlePostbackData code..
    BookBackingContext bbc BookBackingContext.getBookBackingContext(request);
    BookBackingContext pbc = bbc.getParentBookBackingContext();
    log("Got Parent Book.."+pbc.getTitle());//this is printing proper value
    bbc.setupPageChangeEvent("MY_HOME_PAGE_LABEL");
    bbc.setActive(false);
    pbc.setActive(true);

    resolved using PostbackURL and response.sendRedirect..
    Still not sure why in sp3 setUpPageChangeEvent is not working from backing file..(no tree optimization..handlePostBack returning true..??)

  • TACACS queries

    Hi
    My ACS accounting doesn't show the Logs for commands executed . As per me, it should be under "TACACS Administration" Tab. But its blank.. Please let me know what is the problem causing no accounting for Authorized commands.
    Below is the configuration on AAA client:
    =~=~=~=~=~=~=~=~=~=~=~=
    Switch>
    Switch>
    Switch>
    Switch#
    Switch#
    Switch#
    Switch#sh run
    Building configuration...
    Current configuration : 4068 bytes
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    hostname Switch
    aaa new-model
    aaa authentication login default group tacacs+ local
    aaa authentication enable default group tacacs+ enable
    aaa authorization config-commands
    aaa authorization exec default group tacacs+ local
    aaa authorization commands 1 default group tacacs+ local
    aaa authorization commands 15 default group tacacs+ local
    aaa accounting update newinfo
    aaa accounting exec default start-stop group tacacs+
    aaa accounting commands 1 default start-stop group tacacs+
    aaa accounting commands 15 default start-stop group tacacs+
    username bhaven privilege 15 password 7 ****************
    ip subnet-zero
    no ip igmp snooping
    spanning-tree mode rapid-pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    interface FastEthernet0/1
    switchport access vlan 203
    switchport trunk allowed vlan 10,20
    switchport mode access
    spanning-tree portfast
    interface FastEthernet0/2
    switchport access vlan 203
    switchport mode access
    speed 100
    spanning-tree portfast
    interface FastEthernet0/3
    switchport access vlan 203
    switchport mode access
    spanning-tree portfast
    interface FastEthernet0/4
    spanning-tree portfast
    interface FastEthernet0/5
    switchport mode access
    duplex full
    speed 100
    spanning-tree portfast
    interface FastEthernet0/6
    switchport mode access
    duplex full
    speed 100
    spanning-tree portfast
    interface FastEthernet0/7
    spanning-tree portfast
    interface FastEthernet0/8
    switchport mode access
    spanning-tree portfast
    interface FastEthernet0/9
    spanning-tree portfast
    interface FastEthernet0/10
    spanning-tree portfast
    interface Vlan1
    ip address 172.20.7.26 255.255.255.0
    no ip route-cache
    shutdown
    interface Vlan3
    no ip address
    no ip route-cache
    shutdown
    interface Vlan10
    ip address 172.20.65.246 255.255.255.0
    no ip route-cache
    interface Vlan11
    no ip address
    no ip route-cache
    shutdown
    interface Vlan77
    ip address 172.16.4.5 255.255.255.0
    no ip route-cache
    shutdown
    ip default-gateway 172.20.65.3
    ip http server
    tacacs-server host 172.20.65.247 key ******
    tacacs-server host 172.20.65.248 key ******
    radius-server host 172.20.65.247 auth-port 1812 acct-port 1813 key ******
    radius-server retransmit 3
    line con 0
    line vty 0 4
    password 7 ***********
    line vty 5 15
    password 7 **************
    ntp authentication-key 24 md5 ********** 7
    ntp authenticate
    ntp trusted-key 24
    ntp clock-period 17179742
    ntp server 172.20.25.221 key 24
    monitor session 1 source interface Gi0/1
    monitor session 1 destination interface Fa0/10 ingress vlan 77
    end
    Switch# exit
    I would apprciate if somebody can help me on this.
    Also my second query is when i configure two ACS servers in HA mode, primary is configure to send & secendory is configured to receive.
    But in case of any failure any my primry goes down , will my configuration changes done on Secendory ACS server will sync with primary ACS when primary comes back online.
    Thanks in advance!

    Hi,
    If you have acs ver 4.1.1 23 then this is a known issue, you need to apply patch ACS 4.1.1.23.5 to fix the issue.
    Patch for appliance is available on,
    http://www.cisco.com/cgi-bin/tablebuild.pl/acs-soleng-3des
    Patch name : ACS SE 4.1.1.23.5 accumulative patch
    Patch for acs windows is available on
    http://www.cisco.com/cgi-bin/tablebuild.pl/acs-win-3des
    Patch Name:ACS 4.1.1.23.5 accumulative patch
    That should fix the issue.
    Second Issue,
    ACS replication is always one way, from primary to secondary.
    Regards,
    ~JG
    Note: If that answers your question, then please mark this thread as resolved, so that others can benefit from it.

  • Configuration deletion to security standard

                      We have a client (UK Gov Dept) stating that all faulty equipment must be destroyed before leaving site if it has the potential to hold information. Their Cisco estate includes several ASA5520-BUN-K9 and WS-C2960-48TT-L routers.  It does not sound a 21st century solution to me, to physically destoy this kit if one goes down and a replacement is deployed.  Is there an agreed security process/protocol that could be followed in order to scrub the configuration/client info that would be acceptable to the client?  I apologise if this is well documented and covered elsewhere on this site.  My experience is limited to the commercials of CSCC.
    Thanks
    Simon

    Shahid,
    hereby an example of a (similar) configuration of a L2 switch.
    Maybe it can act as an example
    Paul De Valck
    no service pad
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    service password-encryption
    hostname
    enable secret
    ! Summertime definition (Brussels)
    clock timezone CET 1
    clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00
    ! automatic restart of ports after a port error
    errdisable recovery cause all
    errdisable recovery interval 180
    ip subnet-zero
    vtp mode trans
    vlan 4
    name Admininstrative_VLAN
    exit
    no ip domain-lookup
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    interface Vlan4
    descr Aministrative VLAN for switch management
    ip address 10.40.2.251 255.255.255.248
    no ip route-cache
    no shut
    ip default-gateway 10.40.2.254
    ip http server
    logging history size 50
    ! syslog servers
    logging 10.32.1.40
    logging 10.192.1.40
    ! limit snmp access
    access-list 1 permit 10.40.0.0 0.0.3.255
    access-list 1 permit 10.192.1.32 0.0.0.31
    access-list 1 permit 172.31.0.0 255.255.0.0
    ! snmp access
    snmp-server community
    snmp-server community RW 1
    snmp-server queue-length 100
    snmp-server location Brussels Main Office
    ! SNMP traps
    snmp-server enable traps
    snmp-server host 10.192.1.38
    snmp-server host 10.32.1.38
    ! Console & Telnet login
    line con 0
    session-timeout 10
    exec-timeout 7 0
    password
    login
    line vty 0 15
    session-timeout 10
    exec-timeout 7 0
    password
    login
    ! time synchronisation with ntp server
    ntp server 10.32.1.38 prefer
    ntp server 10.192.1.38
    end

  • Portal, Book and pages enumeration

    Hi, I´m having a bit of a problem using Bea Workshop 8.1.5.
    I´m building a Portal which has inside books and pages.
    The pages can hold inside books.
    The problem is that I ´ve using the methods
    DesktopBackingContext dbc=DesktopBackingContext.getDesktopBackingContext(this.getRequest());
    BookBackingContext books=dbc.getBookBackingContextRecursive(rama);
    List lista=books.getPages(); //Here is the list of the books and pages that it contains.
    where "rama" is a String containing the Definition label of the book where I want to start the enumeration.
    If the portlet that contains the .jpf ,where the previous code is, is placed outside the main book, it works perfectly but if that same portlets is placed inside the main book o the books that it contains it won´t work.
    I debugged it and it seems that this
    books.getPages(); is returning null (as it has no books or pages, but it does!).
    Does anybody knows what I am missing here?
    Best
    Alejo

    You need to set the portal property Tree Optimization to false, this way you force the portal to create instances of all the trees but you´ll loose performace.

Maybe you are looking for