Trouble getting BGP route to be primary

We have an MPLS network between locations using BGP. Several locations have a VPN connection as a backup and use OSPF for those routes.
When an MPLS link goes down, the traffic switches over to the VPN connection just fine. But when the MPLS link comes back up, the OSPF route is still overriding the BGP route.  I've changed the weights for both BGP & OSPF but still can't get the BGP route to override the OSPF route.
Any ideas as to what I'm missing?
Main router, MPLS link active at remote site:
nbrtr2#sh ip bgp
BGP table version is 6837, local router ID is 216.149.85.242
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.104.0/24  216.149.85.241                       300 2828 3549 2828 i
nbrtr2#sh ip bgp 172.16.104.0
BGP routing table entry for 172.16.104.0/24, version 6839
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  2828 3549 2828
    216.149.85.241 from 216.149.85.241 (216.149.85.241)
      Origin IGP, localpref 100, weight 300, valid, external, best
After shutting down the remote interface, traffic switches to the VPN link.
nbrtr2#sh ip bgp
BGP table version is 6842, local router ID is 216.149.85.242
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.104.0/24  172.16.196.4           123           100 ?
nbrtr2#sh ip bgp 172.16.104.0
BGP routing table entry for 172.16.104.0/24, version 6842
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
        1
  Local
    172.16.196.4 from 0.0.0.0 (216.149.85.242)
      Origin incomplete, metric 123, localpref 100, weight 100, valid, sourced,
best
Bringing up the remote interface, the traffic stays on the VPN.
nbrtr2#sh ip bgp
BGP table version is 6843, local router ID is 216.149.85.242
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.104.0/24  172.16.196.4           123           100 ?
nbrtr2#sh ip bgp 172.16.104.0
BGP routing table entry for 172.16.104.0/24, version 6842
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Advertised to update-groups:
        1
  Local
    172.16.196.4 from 0.0.0.0 (216.149.85.242)
      Origin incomplete, metric 123, localpref 100, weight 100, valid, sourced,
best
Finally, terminating the site-site VPN tunnel restores the MPLS route:
nbrtr2#sh ip bgp
BGP table version is 6845, local router ID is 216.149.85.242
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 172.16.104.0/24  216.149.85.241                       300 2828 3549 2828 i
nbrtr2#sh ip bgp 172.16.104.0
BGP routing table entry for 172.16.104.0/24, version 6845
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  2828 3549 2828
    216.149.85.241 from 216.149.85.241 (216.149.85.241)
      Origin IGP, localpref 100, weight 300, valid, external, best
Config details:
router ospf 100
 log-adjacency-changes
 redistribute static subnets
 redistribute bgp 36166 metric 20 subnets
 network 172.16.196.0 0.0.0.255 area 0
 network 172.16.224.0 0.0.3.255 area 0
router bgp 36166
 network 172.16.210.0 mask 255.255.255.0
 network 172.16.211.0 mask 255.255.255.0
 redistribute ospf 100 route-map Redist-OSPF
 neighbor 216.149.85.241 remote-as 2828
 neighbor 216.149.85.241 weight 300
 default-information originate
access-list 11 remark Define OSPF routes for redistribution
access-list 11 permit 172.16.11.0 0.0.0.255
access-list 11 permit 172.16.16.0 0.0.1.255
access-list 11 permit 172.16.196.0 0.0.1.255
access-list 11 permit 172.16.198.0 0.0.0.255
access-list 12 remark Define VPN routes for redistribution
access-list 12 permit 172.16.104.0 0.0.0.255
access-list 12 permit 192.168.1.0 0.0.0.255
access-list 12 permit 192.168.3.0 0.0.0.255
access-list 12 permit 192.168.4.0 0.0.0.255
access-list 12 permit 192.168.8.0 0.0.0.255
route-map Redist-OSPF permit 10
 match ip address 11
 set weight 500
route-map Redist-OSPF permit 20
 match ip address 12
 set weight 100
route-map Redist-OSPF permit 30

Hi,
IMHO, you should use the same Weight for both the BGP prefix redistributed from OSPF and received from the BGP neighbor.
And set other attribute (Local Preference, e.g.) to make the prefix received from the BGP neighbor to win when the MPLS interface goes Up again.
Another issue might be though:
When the MPLS interface is Down, you get the OSPF prefix redistributed to your BGP table, And when the MPLS interface goes Up again, you might be advertising this prefix to the backbone. And it can beat the prefix advertised from the remote site. If it's your case, I'd also try to prepend your AS number several times to the prefix advertised from your router to make it less preferred within the backbone comparing to the original BGP prefix.
Best regards,
Milan.

Similar Messages

  • Trouble getting internet route table distributet in a VRF

    Hi every one ..
    I'm have some trouble getting distributed the internet routing table between PE routers ...
    CE1 og PE1 works fine, BGP routes all internet routes are shown i en route table, but distributing between PE1 and PE2 is now working .. any one having a clue !!.
    My gold is to move internet access into it's oven VRF, and away from the global routing table
    In the MPLS core aim running the same AS number as our official AS, that we use for peering to the internet..
    snap of configurations
    ***CE1***
    router bgp 65534
    neighbor 172.31.61.55 remote-as 65534
    neighbor 172.31.61.55 description PE-1
    neighbor 172.31.61.55 shutdown
    neighbor 172.31.61.55 update-source Loopback0
    neighbor 172.31.61.55 next-hop-self
    ***MPLS PE1***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.35
    encapsulation dot1Q 35
    ip vrf forwarding NET-INTERNET
    ip address 172.31.61.55 255.255.255.224
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.146 remote-as 65534
    neighbor 192.168.0.146 description PE2
    neighbor 192.168.0.146 update-source Loopback0
    neighbor 192.168.0.146 version 4
    neighbor 192.168.0.146 next-hop-self
    address-family vpnv4
    neighbor 192.168.0.146 activate
    neighbor 192.168.0.146 send-community both
    exit-address-family
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.1.2 remote-as 65534
    neighbor 172.31.1.2 activate
    neighbor 172.31.1.2 description CE1
    no auto-summary
    no synchronization
    exit-address-family
    ***MPLS PE2***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.67
    encapsulation dot1Q 67
    ip vrf forwarding NET-INTERNET
    ip address 172.31.254.1 255.255.255.252
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.132 remote-as 65534
    neighbor 192.168.0.132 description PE1
    neighbor 192.168.0.132 update-source Loopback0
    neighbor 192.168.0.132 version 4
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.254.2 remote-as 65534
    neighbor 172.31.254.2 activate
    Best regards
    /Peter

    For VPN routes to be exchanged between the two PEs, you first need to configure VPNv4 address family on each one of the PEs.
    Carrying the full Internet routing table over VPNv4 will work but it is not very scalable since all PE routers have to hold the full Internet routing table in the VRF context in addition to potentially full Internet routing table in the global routing table. If you want to exchange full Internet routing table between the two CEs, it would be preferable to use something Carrier Supporting Carrier (CSC).
    Please refer to the following URL for additional information on CSC:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/fscscl23.htm
    Hope this helps,

  • Having trouble getting ethernet router off computer to use local wifi

    My daughters touchscreen laptop was used on an ethernet router at college.  She is now home and we use an AT&T elevate hot spot.   The laptop will not let her online due to  looking for router.  How can we get the router off and get our internet in?

    Chery,
    Welcome to the HP Community Forum.
    The following is a Guess:
    This is answer may seem counter-intuitive to your question:
    How to Assign a Static IP Address in Windows 7, 8, XP, or Vista
    The computer may be set up to use a Static IP address and / or it is set up to look for a particular Internet Service Provider -- (DNS Server), that is, the provider at the school.
    You might go in and check the Network setup.
    You may need to do this in the WiFi and Lan Network Adapter settings if such are available.
    If your computer is set up as shown in the directions in the Link -- then you want to make the following changes to remove that static IP setup and allow your computer to be "free" to select your home Wifi network.
    Local Area Connection Properties window:
    Where it suggests in the directions that you Select
    "Use the following IP address"
    and
    "Use the folling DNS Server Address"
    on your computer:
    You confirm / Select "Obtain a IP Address automatically"
    and
    You confirm / Select "Obtain DNS Server address automatically"
    ===========================================================================
    I hope this makes sense.
    Click the Kudos Thumbs-Up to show you appreciate the help.
    Click Accept as Solution when the Answer provides a Fix or Workaround!
    I am pleased to provide assistance on behalf of HP. I do not work for HP. 
    Kind Regards,
    Dragon-Fur

  • MPLS BGP routes push to DMVPN spokes

    I have an MPLS with BGP. I also have sites that are not connected directly to the MPLS, but have a s2s VPN to hub sites that are connected to the MPLS and that way they access the MPLS resources. I need to communicate the route changes to the MPLS when the DMVPN fails-over to another hub.
    Currently this is my config:
    Datacenter (MPLS only)
    interface GigabitEthernet0/1
    description MPLS
    ip address 192.168.0.34 255.255.255.252
    interface Vlan2
    ip address 192.168.96.2 255.255.255.0
    router bgp 65511
    bgp log-neighbor-changes
    network 192.168.96.0
    neighbor 192.168.0.33 remote-as 65510
    Hub site 1 (MPLS + internet)
    interface Tunnel200
    ip address 10.99.99.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication auth
    ip nhrp map multicast dynamic
    ip nhrp network-id 12345
    ip nhrp holdtime 600
    tunnel source GigabitEthernet0/0
    tunnel mode gre multipoint
    tunnel key 200
    tunnel protection ipsec profile dmvpn
    interface GigabitEthernet0/1
    description MPLS
    ip address 192.168.1.2 255.255.255.0 secondary
    ip address 192.168.0.2 255.255.255.252
    router bgp 65001
    bgp log-neighbor-changes
    network 192.168.1.0
    network 192.168.21.0
    !10.99 clients are DMVPN spokes
    neighbor 10.99.99.3 remote-as 99010
    neighbor 10.99.99.3 route-reflector-client
    neighbor 10.99.99.21 remote-as 99001
    neighbor 10.99.99.21 route-reflector-client
    !as 65000 is the MPLS PE
    neighbor 192.168.0.1 remote-as 65000
    Hub Site 2, has the same configuration, except for local ip address and router BGP ID.
    Spoke site:
    interface Tunnel200
    ip address 10.99.99.3 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication auth
    ip nhrp map 10.99.99.1 PUBLIC_IP_HUB_1
    ip nhrp map 10.99.99.16 PUBLIC_IP_HUB_2
    ip nhrp network-id 12345
    ip nhrp holdtime 600
    ip nhrp nhs 10.99.99.1 priority 1
    ip nhrp nhs 10.99.99.16 priority 5
    ip nhrp nhs fallback 60
    tunnel source GigabitEthernet0/0
    tunnel mode gre multipoint
    tunnel key 200
    tunnel protection ipsec profile dmvpn
    interface GigabitEthernet0/1
    description Internal
    ip address 192.168.3.1 255.255.255.192
    router bgp 99010
    bgp log-neighbor-changes
    network 192.168.3.0
    neighbor 10.99.99.1 remote-as 65001
    neighbor 10.99.99.16 remote-as 65013
    On this spoke site 
    #sh ip route
    B 192.168.1.0/24 [20/0] via 10.99.99.1, 00:47:01
    which is the HUB network, but the rest of the MPLS routes are not "learned".
    What am I missing?
    Thanks!

    Hi Jon, I've ommited the configuration of the MPLS provider routers in between.  The DC is connected to a router that has the AS 65510.
    DC:CPE---PE:{MPLS}PE---CPE:HUB---{internet}---Spoke
    The DC is ok getting the network information via BGP:
    #sh ip route
    B 192.168.3.0/24 [20/0] via 192.168.0.33, 3d05h
    B 192.168.21.0/24 [20/0] via 192.168.0.33, 3d05h
    #sh ip bgp 192.168.21.0
    BGP routing table entry for 192.168.21.0/24, version 559
    Paths: (1 available, best #1, table default)
    Not advertised to any peer
    Refresh Epoch 1
    65510 3549 6140 3549 65000
    192.168.0.33 from 192.168.0.33 (###.###.###.###)
    Origin IGP, localpref 100, valid, external, best
    #sh ip route 192.168.21.0
    Routing entry for 192.168.21.0/24
    Known via "bgp 65511", distance 20, metric 0
    Tag 65510, type external
    Last update from 192.168.0.33 3d05h ago
    Routing Descriptor Blocks:
    * 192.168.0.33, from 192.168.0.33, 3d05h ago
    Route metric is 0, traffic share count is 1
    AS Hops 5
    Route tag 65510
    MPLS label: none
    Spoke:
    #sh ip bgp
    BGP table version is 494, local router ID is 192.168.21.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
    x best-external, a additional-path, c RIB-compressed,
    Origin codes: i - IGP, e - EGP, ? - incomplete
    RPKI validation codes: V valid, I invalid, N Not found
    Network Next Hop Metric LocPrf Weight Path
    *> 10.0.129.32/27 10.99.99.16 0 65013 65012 3549 ?
    *> 192.168.96.0 10.99.99.16 0 65013 65012 3549 6745 65510 ?
    #sh ip route 192.168.96.0
    Routing entry for 192.168.96.0/24
    Known via "bgp 99001", distance 20, metric 0
    Tag 65013, type external
    Last update from 10.99.99.16 00:02:11 ago
    Routing Descriptor Blocks:
    * 10.99.99.16, from 10.99.99.16, 00:02:11 ago
    Route metric is 0, traffic share count is 1
    AS Hops 5
    Route tag 65013
    MPLS label: none
    #sh ip bgp 192.168.96.0
    BGP routing table entry for 192.168.96.0/24, version 465
    Paths: (1 available, best #1, table default)
    Not advertised to any peer
    Refresh Epoch 2
    65013 65012 3549 6745 65510
    10.99.99.16 from 10.99.99.16 (10.2.16.1)
    Origin incomplete, localpref 100, valid, external, best
    The route is not being updated to the rest of the routers, and the 192.168.21.0 network is still announced via the old route.
    (from spoke)
    ping 192.168.96.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.96.2, timeout is 2 seconds:
    Success rate is 0 percent (0/5)
    From DC
    #traceroute 192.168.21.1
    Type escape sequence to abort.
    Tracing the route to 192.168.21.1
    VRF info: (vrf in name/id, vrf out name/id)
    1 192.168.0.33 [AS 65510] 0 msec 0 msec 0 msec
    2 172.50.1.33 [AS 65510] 56 msec 36 msec 36 msec
    3 10.80.1.1 [AS 3549] 44 msec 44 msec 44 msec
    4 10.80.1.2 [AS 3549] 172 msec 172 msec 168 msec
    5 172.50.1.1 [AS 3549] 168 msec 168 msec 172 msec
    6 172.50.1.2 [AS 3549] 180 msec 180 msec 176 msec
    7 192.168.0.2 [AS 65000] 172 msec 172 msec 168 msec <- old route, should be 192.168.0.9
    8 192.168.0.2 [AS 65000] !H * !H

  • Query on BGP route distribution

    Hello Everyone
    In the below scenario (GNS3), IBGP peering enabled between R1-R2, R1-R3, R2-R3 and EBGP peering enabled between R2-R4,R3-R5,R4-R6,R5-R7. OSPF enabled as IGP. Scenario attached for reference.
    The problem I've observed in R1 is not getting entire BGP routing table for destinations 30.x.x.x/40.x.x.x.
    I'm able to see only best routes in R1 BGP routing table, but alternate valid routes are not visible in its topology table.
    R1#sh ip bgp
    BGP table version is 81, local router ID is 100.100.2.1
    *>i30.30.1.0/24     10.10.1.2                0    100      0 200 300 ?
    *>i30.30.2.0/24     10.10.1.2                0    100      0 200 300 ?
    *>i40.40.1.0/24     10.10.2.2                0    100      0 200 400 i
    *>i40.40.2.0/24     10.10.2.2                0    100      0 200 400 i
    *> 100.100.1.0/24   0.0.0.0                  0         32768 i
    *> 100.100.2.0/24   0.0.0.0                  0         32768 i
    More confusing part to me is when I disable IBGP peering between R2-R3 or shutdown interface between R2-R3 or else if I disable ospf in R1,R2 & R3 routers , I'm able to see both best route and alternate valid route in BGP topology table.
    R1#sh ip bgp

    Hi Milin & Renan,
    Thanks for your replies. To narrow down the problem, I’ve shut down the 40.40.x.x network.
    Now between R2-R3, R3 is not advertising 30.30.X.X network to R2, but whereas R2 is advertising 30.30.X.X network to R3. Why R3 is not advertising 30.30.X.X (route via 200 400 300) to R2.
    R2#sh ip bgp ( No alternate route)
     Network          Next Hop            Metric LocPrf Weight Path
    *> 30.30.1.0/24     10.10.4.2                              0 200 300 ?
    *> 30.30.2.0/24     10.10.4.2                              0 200 300 ?
    *>i100.100.1.0/24   10.10.1.1                0    100      0 i
    *>i100.100.2.0/24   10.10.1.1                0    100      0 i
    R2#sh ip bgp summary
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.10.1.1       4   100      96      98        5    0    0 01:05:50        2
    10.10.3.2       4   100      98     100        5    0    0 01:05:54        0
    10.10.4.2       4   200     100      98        5    0    0 01:05:39        2
    R3#sh ip bgp  ( only in R3 we can see both best route & alternate route)
       Network          Next Hop            Metric LocPrf Weight Path
    *>i30.30.1.0/24     10.10.3.1                0    100      0 200 300 ?
    *                   10.10.5.2                              0 200 400 300 ?
    *>i30.30.2.0/24     10.10.3.1                0    100      0 200 300 ?
    *                   10.10.5.2                              0 200 400 300 ?
    *>i100.100.1.0/24   10.10.2.1                0    100      0 i
    *>i100.100.2.0/24   10.10.2.1                0    100      0 i
    R3#sh ip bgp summary
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.10.2.1       4   100      54      57       19    0    0 00:50:17        2
    10.10.3.1       4   100      62      60       19    0    0 00:27:22        2
    10.10.5.2       4   200      58      58       19    0    0 00:50:08        2

  • Trouble getting internet access

    I'm having trouble getting the internet to open up using SAFARI when my MAC wakes up.
    When I try to bring it up I get the following message "Redirect Server: Rapid Logic/1.1 MIME-version: 1.0 Connection: close Content-Type: text/html Location:http://launchmodem/redirectBS.htm"
    The only way I get it to work is to type in "http://launchmodem/redirectBS.htm"
    and I get this message "WARNING!
    Unable to resolve your redirection DNS entry
    Please clear browser cache close and then reopen it to try again"
    Then I hit ok and it works.
    Any ideas on why this happens and how to fix it?

    Forgot to mention that I am I am using a wireless router to connect if that is important.

  • I am having trouble getting buttons to work in Captivate 8 trial version using a responsive design template. Any suggestions?

    I have a trial version of Captivate 8 that I am evaluating to determine if it will be an option to replace a software we currently use. However I am having a lot of trouble getting even the simplest of tasks to work using the responsive design template. To troubleshoot I created 2 projects 1st a completed empty project using responsive design and a 2nd blank project using the blank project template. I created an audio file that the button, when pressed, will play. I can place a button on first slide of both projects, rollovers work fine, but in the responsive design project buttons will not work to trigger the action. Is this a known issue in the trial version?

    A Blank project is a normal cptx-project, not a responsive project, it has no breakpoint views like a responsive project, it is meant to have always the same layout but on publishing you can choose to have it 'rescale' automatically.  A responsive project allows you to create slightly different layouts for the three breakpoint views: Primary (desktop/laptop/landscape on tablets), Tablet (portrait on tablet) and mobile (phones, where the browser has much lower resolution than the real phone resolution). The 'look' of a project, whether it is responsive or not will be defined by the Theme that is the default theme at that moment, and with the default theme colors that you have at that moment. I think in newbie mode the default theme is White (not sure, never used newbie mode). If you choose another theme as default theme, a blank project and a responsive project will open with that theme applied to it. All themes coming with CP8 are responsive, but you can use them also for normal projects, in that case you only use the object styles for Primary view. Each object style normally has 3 versions, for the 3 breakpoint views.

  • Since downloading mountain lion we are having trouble getting on the internet

    since downloading mountain lion we are having trouble getting on the internet

    Try restarting your router, but I will need more info like how are you trying to connect wi-fi, Ethernet, type of connection cable or DSL what type of router Apple, Linksys.

  • New to CS6 Dreamweaver, creating a "Responsive Website" having trouble getting fluid divs to behave

    Trying to create a "Responsive Website" and I'm having trouble getting my fluid divs that I create to "break" their link from the "Boilerplate" .
    I'm using a "Fluid Grid layout Div" to create a section that has a transparent background of rgba(0,0,0,0.3) and that's perfect, then I add two more "Fluid Grid layout Div's" inside the transparent one to create a 2-column part in the section and that's where the trouble is.
    None of the "formatting" I've set for the text in my ID's or Classes are being used - just reverts to what's in the "Boilerplate" i.e. "p,h2,h3" and I can't get it to "break" it's link the "Boilerplate" so I can apply my formatting.
    I have been able to select my formatting at times but it is ignored and uses what's in the "Boilerplate".
    Kept trying different ways to get it to work and now I've so many of both the ID's and Class's that their not all showing up as an option to be able select them.
    I'm missing something basic and after two days it still escapes me.
    Please somebody, tell me what I'm missing.
    Frustrated

    FluidGrid Layouts are not easy to learn.  You need a good grasp of fundamental RWD concepts including CSS Media Queries.  Keep your layout simple and be patient.  The first time I used FGLayouts, I had to start over 9 times before I got acceptable results.
    Responsive Web Design
    http://coding.smashingmagazine.com/2011/01/12/guidelines-for-responsive-web-design/
    Introduction to CSS Media Queries
    http://www.adobe.com/devnet/dreamweaver/articles/introducing-media-queries.html
    CS6 Fluid Grid layouts (17 min video)
    http://tv.adobe.com/watch/learn-dreamweaver-cs6/using-fluid-grid-layouts/
    Best advice for beginners:
    Build Mobile Layout first.  Everything else is based on this primary layout.  Then build Tablet layout and finally Desktop.  Don't worry about content.  Just build the layout & save often during development.
    DO NOT TAMPER with the boilerplate.css or FGLayout.css code.  Even experts can break the layout in a hurry.  Use a separate external style sheet for content and typography styles.
    If you're using CS6 ver 12.0, you cannot nest divs inside other divs.  Everything must be inside the .gridContainer like this:
    <body>
        <div class="gridContainer">
              <div> </div>
              <div> </div>
              <div> </div>
        </div>
    </body>
    If you care to post a link to your online test page, we can take a look and possibly offer more suggestions.
    Nancy O.

  • Troubleshooting with IOS BGP and IOS XR BGP - routing table Empty

    Hi
    actually we tried to make a neigborhood between ASR9000 and Cisco 7600, we have the neigborhood active but on routing tables from ASR only have the networks locals or connected doesn´t learn anything from BGP 7600
    the diagram is this:
    When try to know the routes on ASR9000 from Cisco 7609 happen the follow
    the neighbor is UP from Cisco 7600 and ASR 9000 but the routing table is empty.
    the config on cisco 7600 is:
    router bgp 2006
    neighbor 172.16.14.6 remote-as 64512
    address-family ipv4
    neighbor 172.16.14.6 activate
    the config on cisco ASR9000 is:
    router bgp 64512
    bgp router-id 172.16.161.1
    address-family ipv4 unicast
    neighbor 172.16.14.5
      remote-as 2006
      address-family ipv4 unicast
    Help us
    Best Regards

    Another important one is the fact that in XR you need to have RPL policies (even if they only have a "pass-all" functionality) to accept inbound/outbound routes in eBGP.
    Check the article on the asr9000 unequal cost multipath that has some sample BGP outputs and show command verifications that may help also.
    If not the case, get us the XR config from the A9K side.
    Also what does the bgp table on teh IOS side look like? as Richard suggests, there doesnt seem to be anything injected by the 7600 itself.
    regards
    xander
    Xander Thuijs
    Principal Engineer CCIE#6775, ASR9000

  • Dual homed bgp route perference help

    Good Morning, sir
    I have a question regarding bgp route preference. 
    We have multi-homed BGP on remote site. 
    Let's call this site , site_a has verizon and at&t MPLS connection using bgp. 
    Currently, at&t route is preferred using as path prepend method. 
    We have addition AS number prepended on link to Verizon to prefer at&t route. 
    At this time, verizon is idle and not being used. 
    We would like to utilize this network to pass backup traffic. 
    We have source and destination address that we would like to pass through Verizon (out backup) link. 
    Any idea how I can do this? 
    I created the source/destination with ACL and created route-map matching that ACL and tweaked the local preference. 
    and since only major route is listed under 'show ip bgp' and not the specific route which I would like to influence, 
    I didn't see the tweaked route on routing table. 
    Any idea, anyone? 
    Thanks

    Getting the specific route into the routing depends on what is there ie. -
    if there is already a route with same prefix and subnet mask in your IP routing table then you are fine.
    If there isn't and your routing table does not have even more specific routes covering the whole subnet you want to advertise then you could use a static route either pointing to the next hop IP or the interface on the router used to get to that subnet.
    Then you can use a "network ..." statement under your BGP configuration to advertise it and use a route map to only advertise it down the backup link.
    Jon

  • Trouble getting WDS Mode to work between 2 RG54G2s

    Hi,
    I have bought two RG54G2s and am trying to use them to wirelessly bridge 2 wired LANs in my home. (Upstairs &  Downstairs)
    I am not getting connectivity between the two routers however.
    I have read the manual and the article in the FAQ and I *thought* I had it all set up correctly.
    Each device has 'Wireless Bridge' & 'Enable WDS Only' options ticked. The MAC address of the 'other' router is also set in each.
    The SSIDs are different, the radio channel is the same and there is no security of any kind on the link to cause troubles.
    Each router has one test PC connected by Ethernet. Each PC can ping its own router but not the other one.
    One router has an ethernet connection from the WAN socket to my network switch. There's no problem with connectivity there.
    I wonder if the IP addresses and subnet mask are the problem.
    Here's my setup:
    Router A = 192.168.1.5 client PC is 192.168.1.100
    Router B = 192.168.1.6 client PC is 192.168.1.200
    Subnet mask for both is 255255.255.0
    I have read through the  MSI forum and googled for tips on setting up WDS but cannot find anything 'wrong' in my setup.
    What could be wrong? How to determine the actual problem and fix it?
    Thanks
    Peter

    I have the same problem tried varoius configuration but nothing, have you solved your problem? how??

  • Trouble getting 1130AG LWAPP to Connect to Controller

    I'm having trouble getting any of my 1130AG LWAPPs to connect to my WLC.
    I have not configured my DHCP server to deliver option 43 or option 60.
    However, I have manually configured the LWAPP using the CLI. I have assigned a static IP address, the default-gateway, gave it a hostname, and gave it the controller ip address.
    When I issue the command:
    show lwapp ip config
    all of the information appears correctly.
    However, the controller never registers the LWAPP.
    This is a completely new setup, so there are no previous configs to contend with.
    If I issue the command on the LWAPP:
    debug lwapp client event
    Two debug messages appear consistently every 3-5 seconds. They are:
    *Mar 1 00:34:26.733: LWAPP_CLIENT_EVENT: spamResolveStaticGateway - gateway found
    *Mar 1 00:34:36.733: LWAPP_CLIENT_EVENT: spamHandleDiscoveryTimer: Could not discover any MWAR
    Any suggestions?
    ~ Vance R. Gregory

    You have to put option 43 in hexadecimal no. below you will find an example of DHCP configurations on router that act as a DHCP for LWAPP in different network:
    ip dhcp excluded-address 172.16.1.1 192.168.1.1
    ip dhcp pool WAP_DHCP_SCOPE
    network 192.168.1.0 255.255.255.0
    option 43 hex f104c0a814f0
    The hex string is assembled by concatenating the TLV values shown below:
    Type + Length + Value
    Type is always f1(hex). Length is the number of controller management IP addresses times 4 in hex. Value is the IP address of the controller listed sequentially in hex.
    WLC IP is 192.168.20.240 f1+1*4+ac10.14f0 = f104c0a814f0
    default-router 192.168.1.1

  • Trouble getting on wireless

    Posted same question in Snow Leopard at http://discussions.apple.com/thread.jspa?threadID=2221900&tstart=0
    Thought I'd try here too...
    I'm all of the sudden having trouble getting on my wireless networks at home and work. Home is an Airport Extreme Station (about 1.5 years old) and has worked like a champ for the longest time but as of the last couple weeks has been hard to get onto.
    Same at work wireless (don't know what kind of router). It'll let me on automatically and sometimes it won't. When it doesn't, the airport icon (in menu bar) sees the network and shows a decent signal strength but when I go to get on it it never locks on. This is the case at home too: sees network, there's a signal but won't lock on.
    All my passwords are correct so don't know what's going on.
    Is this my macbook pro having the problem?
    thanks

    +"Is this my macbook pro having the problem?"+
    First thought here is that the wireless card in the MBP is having trouble. Can you try it in another location like the coffee shop to see if you still have difficulties? If others seem to be able to connect fine and you can't, you might want to have the wireless card checked out at the repair place.

  • TS3276 I'm now having trouble getting mac mail to work on my mac. The mobile me account works great on iphone and ipad but it won't connect to my mail account. Password is correct. What else can I do? Using OS10.68

    I'm now having trouble getting mac mail to work on my mac. The mobile me account works great on iphone and ipad but it won't connect to my mail account. Password is correct. What else can I do? Using OS10.68

    HI,
    The Apple IDs from @mac.com and @me.com (Older MobileMe and more recent iCloud Names) are also Valid AIM Screen names.
    Any other sort of Apple ID is not a Valid AIM Name.
    A Google ID that is associated with Google Mail Account (And has "Talk" enable on your Google Settings) can be used in iChat as  Jabber Name/ID.  (Google Run  Jabber server).
    Jabber and AIM are different IM Services and it is not easy or straight forward to add Buddies from one Service to the Buddy List of another.  (As A Starting point consider it "impossible")
    iChat 4 and 5 have links to the registration page of @Mac.com here with a "Get an iChat Account" button in the add (Account) screen  (You select @mac.com or MobileMe and then press the Button - Choosing AIM and then pressing the button used to lead to the AIM registration page but AIM moved their page).
    Apple IDs can be any valid email (or an @mac.com or iCloud registration)
    Therefore you could make a Google ID into an Apple ID.
    However this will not be a valid AIM Screen Name the way @mac.com or MobileMe/iCloud ones are.
    Valid AIM Screen Names in Table (pic)
    7:46 PM      Monday; December 5, 2011
    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"
      iMac 2.5Ghz 5i 2011 (Lion 10.7.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Maybe you are looking for

  • Interactive Report - Download as xls giving empty report

    Hi, I have an interactive report where i have enabled all the available download formats from report attributes. Now, when I go to Actions -> Download  and select format as .csv, html, email, then it works fine. But when I select download format as X

  • Help! I can't print from an executable.

    I've written a vi which prints a barcode to a small brother label printer and compiled it into an executable.  Both the exe and vi print when the printer is connected to my computer, but when I move it to the target machine it won't print.  The progr

  • Settlement on tooling with AIAB

    Hello, I have an error when I run a settlement on tooling FXA with transaction AIAB The error detail is the following: what can be the reason ? Receiver categ. FXA is not allowed by settlement prof. NS for this sender Message no. KD031 Diagnosis The

  • Port replicator resolution

    I am using HP250 laptop with 2005pr usb port replicator. Using laptop stnad alone the screen is set to maximum resolution but when I attached the 2005pr the monitor res is dropped to 1280x720 max. It worked fine originally, this has only recently sta

  • Vendor Classification Details

    Hi, I have to write a Vendor classification report where I have to determine whether a vendor has been classified or not,by checking whether a 'class' has been assigned to the vendor master record. Which table will link the Vendor no(LIFNR) and the V