UCCE Custom Routing Using Queue To Agent

I have a customer interested in performing their own agent selection using a database lookup rather than selecting agents based upon skill group assignment. The suggestion has been made to perform the database lookup and use the queue to agent node. This would be used in a mid-sized environment, several thousand agents, and the there could possibly be hundreds of agents listed in the queue to agent node for a particular call. Has anyone had any experience on using queue to agent in this manner? I'm curious if pushing the queue to agent functionality beyond it's intended purpose would cause issues.

Queue to agent indirect with a DB lookup is workable - the result of the lookup must be their agent ID.
What would be the lookup criteria?
You need to establish an Enterprise Skill Group and an Enterprise Route using a skill group that will NEVER be removed from the agent (say by dynamic reskilling), so give it an artificial name like Q2Agent. Agents would also need to be in an overflow skill group.
You won't have to touch the script - there will be just one Queue to Agent node.
Don't queue if the agent is not logged in - overflow to a queue to skill group. Don't queue too long at the selected agent if they are logged in - again, oveflow to a queue to skill group.
You will have to manage the DB when an agent leaves, but it doesn't matter much because they won't be logged in. When a new agent arrives you will have to add an entry to the DB - but even if you don't it will be OK as the lookup willl fail and you will just queue to the overflow.
It's actually worth playing with.
Regards,
Geoff

Similar Messages

  • Custom routing agent based on sender's security group and subject

    I made a custom routing agent that routes mails contains the word [encrypt] in the subject and sent from domain test.com
    The part of the code is
    if (e.MailItem.FromAddress.DomainPart.Contains("test.com")
                    && e.MailItem.Message.Subject.Contains("[encrypt]"))
    now what i need is to route mails based on the membership of a certain security group like "securemail" not the whole domain. ie if the sender is a member in security group (securemail) and the subject contains the word [encrypt] route the mail
    Thanks

    Thanks for your answer Glen
    The following  code is on exchange 2010 but i need it to check for a security group membership if possible
    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Text;
    using Microsoft.Exchange.Data.Transport;
    using Microsoft.Exchange.Data.Transport.Email;
    using Microsoft.Exchange.Data.Transport.Smtp;
    using Microsoft.Exchange.Data.Transport.Routing;
    using Microsoft.Exchange.Data.Common;
    namespace RoutingAgentOverride
        public class SampleRoutingAgentFactory : RoutingAgentFactory
            public override RoutingAgent CreateAgent(SmtpServer server)
                RoutingAgent myAgent = new ownRoutingAgent();
                return myAgent;
    public class ownRoutingAgent : RoutingAgent
        public ownRoutingAgent()
            //subscribe to different events
            base.OnResolvedMessage += new ResolvedMessageEventHandler(ownRoutingAgent_OnResolvedMessage);
        void ownRoutingAgent_OnResolvedMessage(ResolvedMessageEventSource source, QueuedMessageEventArgs e)
            try
                // For testing purposes we do not only check the sender address but the subject line as well
                // If the subject contains the substring "REDIR" then the default routing is overwritten.
                // Instead of hard-coding the sender you could also perform an LDAP-query, read the information
                // from a text file, etc.
                if (e.MailItem.FromAddress.DomainPart.Contains("contoso.com")
                    && e.MailItem.Message.Subject.Contains("[encrypt]"))
                    // Here we set the address space we want to use for the next hop. Note that this doesn't change the recipient address.
                    // Setting the routing domain to "nexthopdomain.com" only means that the routing engine chooses a suitable connector
                    // for nexthopdomain.com instead of using the recpient's domain.
                    RoutingDomain myRoutingOverride = new RoutingDomain("nexthopdomain.com");
                    foreach (EnvelopeRecipient recp in e.MailItem.Recipients)
                        recp.SetRoutingOverride(myRoutingOverride);
            catch // (Exception except)

  • Working with Custom SQL Using Descriptor Query Manager Queries

    Hi All,
    I am Working on Descriptor Query Manager Queries
    Configuring Custom SQL Using Java and Workbench
    Using Java I wrote a static method as in the code given below.
    public static void insertEmployee(ClassDescriptor descriptor){
    descriptor.getQueryManager().setInsertSQLString(
    "insert into EMPLOYEE (EMP_ID, EMP_NAME, EMP_JOB, SAL, DEPTNO) values (#EMP_ID, #EMP_NAME, #EMP_JOB, #SAL, #DEPTNO)"
    I wrote a insert SQL Query in the custom SQL tab of the Toplink workbench .
    Using java and Using Toplink Workbench I had a problem how to call this insert query in the sessionEJBBean .
    Can any one suggest me in this regard.
    Thanks in advance
    regards,
    Satish

    What is the problem you are experiencing?
    Normally you can just execute the query by calling
    'executeQuery(queryName, domainclass) on the session.
    See also
    http://www.oracle.com/technology/products/ias/toplink/
    doc/10131/main/_html/qrybas003.htm#BCFIBGGJ
    Just out of curiosity: why do you need a custom SQL
    to insert something? Can't you use persist()?
    regards,
    LonnekeOr even UnitOfWork ? Why go down the route of using custom inserts to insert objects unless you have some business logic that Toplink's UnitOfWork API cannot provide ?

  • Porting varray data from one db to another remote db using queues and jms

    We are trying to port a varray from one db to another db using queues and java jms. The varray is embedded in an object type (necessary according to oracle docs). The varray, embed object, and the queues are identical between the 2 dbs. We have used the capabilities in jdeveloper to generate the necessary classes to access the embed object and its payload the varray.
    However, when we attempt this:
    public void publish( com.wgint.sql.EaiType payload )
    throws JMSException, SQLException
    Connection dbConnection = ((AQjmsSession)session).getDBConnection();
    AdtMessage message = ((AQjmsSession)session).createAdtMessage();
    message.setAdtPayload( payload );
    ( (AQjmsTopicPublisher) publisher ).publish( publisher.getTopic(),
    message,
    agents );
    we get a ora-00902 error, invalid datatype. I cannot find a single example on technet or the internet in which someone has done something similar. I do not know if it is feasible or not.
    Steve

    Do you really need JMS to do this? If not, just let the AQ layer propagate your messages from your local to your remote queue. See the online doc how to do this.

  • Gurented Delivery in PIP Using queue

    Its written in the oracle AIA integration developer guide that using queue and topics gurenteed delivery can be achieved. For that we should use queue before Requestor ABCS and EBS and queue/topic between EBS and provider ABCS. This architecture along with property setting for participating application, will make the services in transaction.
    But when I have gone through product hub PIP, the architecture used there is completely different. There is no queues in betweek source and requester ABCS as well as ESB and provider ABCS.
    Still it has mention that the PIP architecture provides the gurenteed delivery.
    Can any one please explain how PIP can gurenteed the delivery of message without using queue or topics? Also I would like to know that which architecture I should use if I want to develope customized PIP.

    Please find the following KB articles to assist you in external monitoring:
    Article #1339: SNMP best practices
    Link: http://tools.cisco.com/squish/9CF91
    Article #57: How do I monitor the health of my IronPort appliance?
    Link: http://tools.cisco.com/squish/92502
    Article #744: Where can I obtain the SNMP MIB and SMI files for Cisco Email and WebSecurity Appliances?
    Link: http://tools.cisco.com/squish/49E5e
    For full information regarding XML/SNMP monitoring:
    XML, as you have requested more on, is used to monitor the statistics of email processed through the appliance.
    For full documentation regarding XML – please see the Daily Management Guide (page 315).
    SNMP can be used to monitory overall system health, including the hardware.
    For full documentation regarding SNMP monitoring – please see the Daily Management Guide (page 306).
    The Daily Management guide can be located at the following link, as is recommended to be downloaded from there due to the size:
    http://www.cisco.com/en/US/products/ps10154/products_user_guide_list.html
    *If you do require further specifics for monitoring, thresholds – I would suggest that you open a dialog with your Sales/Account team – as they also have tools in place that can assist with threshold monitoring, best practices, or get you in touch with Advanced Services to help implement.

  • Participation In Customer Routing.

    Hello ,
    I am sending one question which I believe was wrongly answered on Cisco forum.In forum the answer guessed is A but I think the answer is B.I am also giving some explaination.
    Which one of the following is true?
    A. MPLS and traditional peer-to-peer VPNs require the service provider to participate in
    the customer routing.
    B. MPLS and traditional peer-to-peer VPNs require that the customer routing is
    transparent to the service provider.
    C. MPLS VPNs require the use of link-state routing protocols, traditional peer-to-peer
    VPN implementations require distance vector protocols.
    D. MPLS VPNs are constructed using dynamic routing protocols; traditional peer-topeer
    VPN implementations are constructed using static routes.
    Consider the scenario. BGP/MPLS VPN is considered as provider provisioned VPN, where the edge
    router takes part in provisioning VPN service.
    example: VPN A has three sites, 1, 2, 3 connected to PE1, PE2, PE3
    respectively.
    VPN A Customer routes from site 1 may or may not be directly reachable from
    site 2, and site 3, depending on how they are provisioned by the Service
    provider at PE. Infact customer has to depend on Provider for this
    configuration.
    But the core routers in the provider network, is not aware of existence of
    any VPN and does not process any route which belongs to customer network,
    outside the provider's network.
    That is what my interpretation is.
    In that respect, the customer routing is transparent to the provider.
    Request all of you to comment and come to the conclusion this is important question from Cisco 640-910 examination point of view also.
    Regards ,
    Ranjeet Badhe
    Engineer (Access Networks)

    Agreed, the answer should be B not A.

  • Using Forte Free Agent newsreader

    Purchased my iMac 27" about a week ago but just opened this morning. All has gone well until I tried using Forte Free Agent newsreader. The program worked fine on my Dell laptop, but on the iMac the executable file is listed as a document. When I try to run it it opens as a sort of text file. Is there a different way to use this program, or is it simply not capable of running on the Apple OS?
    Thanks!

    Crash777 wrote:
    I've heard a little about Parallel but nothing about Crossover and Bootcamp. What criteria would you recommend to help me decide which is the best choice? I use Forte Free Agent but it's not an essential item. I use MS Office 2003 quite a bit, especially Outlook, Excel and Word and so I'd like to be able to continue that. I've already begun looking at MS Office for Mac.
    One suggestion I got was partitioning the hard drive and installing Windows 7 so that I could run all those apps that are supported by Windows and MS, but not Apple. Does that make sense?
    IMHO it would be foolish to install MS Windows on your iMac for only MS Office duties for several reasons. First you if feel you have to have MS Office in order to be compatible with your co-workers then you will find MS Office 11 a very capable product. However if you have been using MS Office out of habit then iWork is a an extremely capable product line. Your iMac already has Mail, Address Book, and iCal which integrate beautifully together and replace Outlook and are robust products. In addition the iWork and iLife applications integrate very well together. And iWork documents can be shared with MS Office users. MS Office 11 is also a very capable product but for most people it's overkill.
    While you could run MS Windows on your Mac from what I can tell from your needs it's a waste of money, time and resources. Your iMac has Boot Camp built into it, Boot Camp allows you to turn your Mac into a machine that runs 2 operating systems, MS Windows and OS X. However if you take this route when you install Win 7 (which you would have to purchase unless you already own a license) that part of your Mac is susceptible to all the maladies (viruses and malware, funky drivers, etc...) you were probably trying to get away from. Also if you use Boot Camp you are running either Windows or OS X but you can't run them simultaneously. If you were a gamer or someone that has to have Windows only applications or were doing 3D CAD/CAM work then Boot Camp would be a good solution. However for MS Office duties it's a total waste!
    You could also use virtualization software like Parallels or Fusion or other alternatives. If you insist on running Win 7 on your iMac then for your needs this would be the route I'd recommend. However again whenever you run Windows you are susceptible to viruses and other malware. The reason being is you can run Windows and OS X side by side. When I switched to a Mac several years ago I did this and ran MS Office apps which I quickly weaned off of, I happened to use Fusion as my virtualization tool and found the performance good. However after I began using Mail, Address Book, iCal and iWork I found out how clunky, old fashioned and well to be blunt crappy MS Office really is so I abandoned Office! While i still have Fusion and Windows loaded on my machine I don't recall the last time it was used.
    My recommendation is spend more time with those links and learn how powerful your machine is the way it shipped. Play with the tools it already has (Mail, Address Book, iCal) and I think you may be not surprised but shocked how capable and easy to use they are. Macs aren't like PCs, what I mean by that is PC's come loaded with lots of useless software that is simply awful. However Macs come with extremely robust software which includes iLife (Garage Band, iMovie, iWeb) and Mail, Address Book, iCal. If you decide to take a look at iWork ($79 retail but easily found for much less) that includes Numbers (Excel replacement), Pages (Word replacement) and Keynote (PowerPoint replacement.)

  • MPLS Customer router physical interface

    My provider wants to sell me MPLS services but I can't seem to get a straight answer regarding what the physical interface on my customer router needs to be.  Some personnel tell me it will be a normal ethernet connection, other say it'll be a DS3 or T1 connection depending on the speed.
    Please give me some advice on what to expect regarding an MPLS circuit?  Or point me to some good documentation to maybe I can communicate better with the service provider.
    Thank you.

    Hi Tod
    Few points from my side for your query
    Access Link should be considered based on whether we are going for MPLS L3 VPN or MPLS L2 VPN Soilution
    MPLS L3 VPN from my understanding is independent of Access Media but the Access Media will definitely put different hardware requirements for your Customer Edge Router
    The Access Link Type and Bandwidth would vary depending upon the BW requirements for the network. The T1/T3 or a Subrate T3 Access Links would be a choice when we have BW requirements in that range(<45 Megs)
    Using FE as an Acces link would require SP to provide Colocation Services or rather go for spanning a Fiber out from their Colo and deploying Optical Mux at Customer Premises and again suitable for BW requirements more than 45 Megs
    MPLS L2 VPN
    Ethernet is the choice for taking MPLS L2 VPN Services to connect your different branches in a point-to-multipoint fashion using VPLS at SP end.
    You can go through the Cisco Doc - "Layer 3 MPLS VPN Enterprise Consumer Guide" which should help you gain more insight for choosing the PE-CE Routing Protocol and other points to consider for an MPLS L3 VPN Service.
    Thats from my understanding. Hope you will get more good advises on this.
    Regards
    Vaibhava Varma

  • Issue with creation of custom layouts using SAP Help Documentation

    Hi Experts,
    My requirement is to create a home custom page layout (using web dynpro) in Composite Environment. The default options available in CE are not useful for me. I set out to make a custom layout using the following this SAP Help Documentation: [          Creating a Web Dynpro Page Layout (SAP Library - Using the Portal as a Frontend)|https://cw.sdn.sap.com/cw/docs/DOC-102846]
    I have followed the instructions and followed all the steps, yet I fail to see the application in CE. The custom page layout is not displayed neither in options and is not available any where.
    Please let me know if anybody followed these steps and have got any success.
    Thanks in advance
    Srikant

    Hi
    Can somebody let me know if they have implemented a customised solution of creation of page layouts using Web Dynpro - as per the steps suggested by SAP.
    Thanks in advance
    Srikant

  • Cisco ASA 5505 - outside can't DHPC as router use same range

    Hi
    Im new to the ASA and is trying to setup at test net. The ASA is connected to my router on port zero using DHPC.
    (Or i guess its not as the router use the same ip range as ASA does inside).
    I tried to set a static IP in the same range (eg. 192.168.1.20) but then get the message "cannot overlap with the subnet of interface inside".
    So I belive that is why it dont get a IP from my router - it does show up in the router DHPC table as 192.168.1.5 but ASDM home says outside "no IP address".
    I tried to change the inside range of the ASA but if I change the inside IP i loose connection.
    (Had to restore factory-default useing the console).
    I guess I could setup another range using the console, but how?
    How can I setup this test net?

    If I need to save I did not. (I have not used the console before).
    Found the: "write memory" and reload command.
    I cant connect to the asa using ADSM-IDM Launcher (from PC connected to the inside lan).
    It seems that the asa DHPC server does not work.
    And: show running-config
    ciscoasa# show running-config
    : Saved
    ASA Version 8.2(5)
    hostname ciscoasa
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.2.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    no ip address
    ftp mode passive
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:5085ad55b43198c7490b2edfee450906
    : end

  • Custom Report using Metrics of Instance and Server

    Hello
    I need to create a custom report using different instance and server metrics like:
    File System Space Available
    Tablesapaces
    Database Spaces usage
    Sort in Memory
    library Cache Hit
    Data Dictionary Hit
    Buffer Cache Hit
    I already made the report, but I can´t change the size of the graphic (for a better presentation on my report)....
    Do you know how can I change the size of the report?
    I think that I´m using a "metric" so for that reason I Can´t change the size ... :(

    I am currently having a problem with this report and drilldown to KSB1, the cost centers selected int S_ALR_87013611 are not transferring to KSB1 and thus all the cost centers come up in the call to KSB1, are you experiencing this problem? I am on V4.7

  • Custom NetStream using netConnection in LCCS

    I want to send custom NetStream using LCCS service. I dont want to use LCCS components and Pods. I need netconnection for that. How can we do that.
    Also is it possible to use methods like netconnection.call() to pass messages between LCCS connected users?

    Hi Ysong,
    Please try posting your question to the ActionScript 3 forum: http://forums.adobe.com/community/flash/flash_actionscript3. It's the most appropriate forum for your question. You might also try the forums for Flash, Flash Builder, or Flex, depending on the authoring environment you are using to write your ActionScript code.
    Thanks,
    KALTechWriter

  • Custom Extractor using FM for Delta Upload

    Hi,
    I created a Custom Extractor using FM for Full Upload. The requirement now is that it should be able to handle Delta also.
    I used the standard FM RSAX_BIW_GET_DATA_SIMPLE to create my Z FM.
    Please suggest me the changes I have to make in this to be able to upload Delta also.
    Thanks
    Nageswara

    Hi Mahesh,
    You can selectively load from BI side (through Infopackage) and for that you should have those selection field defined as ranges in your FM.
    As per my genius friend Sidharth Gupta:
    FM RSAX_BIW_GET_DATA_SIMPLE is a funct. Mod having a simple interface in which I_UPDMODE is not used. Actually FM RSAX_BIW_GET_DATA_SIMPLE is used for a full update and uses an F2 extraction method. However through ABAP we can try to make it delta capable like below.
    *Declare
    DATA  I_UPDMODE.
    Now to capture delta on AUDAT
           I_UPDMODE = u2018 u2018.
    LOOP AT S_S_IF-T_SELECT INTO L_S_SELECT WHERE FIELDNM = 'AUDAT'.
                MOVE-CORRESPONDING L_S_SELECT TO L_R_AUDAT.
                 I_UPDMODE = u2018 D u2019.
                APPEND L_R_AUDAT.
              ENDLOOP.
    This code works however is not flexible as you do not use a CASE stmt on I_UPDMODE.
    CASE stmt gives more flexibility which is used in FM RSAX_BIW_GET_DATA.
    FM RSAX_BIW_GET_DATA is a funct. Mod having a complete interface in which I_UPDMODE is passed to funct mod during its call.FM RSAX_BIW_GET_DATA can be  used for all update types and uses an F1 extraction method. However after writing the funct mod the default extraction method is F2 in table ROOSOURCE which needs to b changed to F1 for ur mod to work.  This change from F2 to F1 can be done via test abap code.
    Part two of that Article is yet to be published so wait for sometime or follow above mentioned approach.
    Hope it helps.
    Regards,
    Ashish

  • Custom cursor using image gets resized bigger

    I have created a custom cursor using the following code:
    ClassLoader cl = this.getClass().getClassLoader();     
    Toolkit tk = Toolkit.getDefaultToolkit();
    Image im = tk.getImage( cl.getResource("images/wallcursor.gif"));
    Cursor Custom_Cursor = tk.createCustomCursor(im,new Point(9,9),"Drawing wall");
    draftGrid.setCursor( Custom_Cursor );The cursor is loaded and it works, however - the image I use for the cursor is resized so it gets too big. Any clues on why this happens?
    btw; draftGrid is one of my own classes that extends JComponent.
    - bjorn

    Thanks for your replies guys.
    I tried your code KPSeal, and it works in resizing the cursor image back to its original size. However, a gray square of size 32,32 (which is returned by getBestCursorSize()) is shown round the cursor.
    Here is the updated code (yours hade some minor bugs)
    Image im = tk.getImage( cl.getResource("images/wallcursor.gif"));
    try {
           tracker.addImage(im, 0 );
           tracker.waitForID(0);
    } catch( InterruptedException ie ) {
           ie.printStackTrace();
    int w = im.getWidth(this);
    int h = im.getHeight(this);
    int pw = Toolkit.getDefaultToolkit().getBestCursorSize(w, h).width;
    int ph = Toolkit.getDefaultToolkit().getBestCursorSize(w, h).height;
    System.out.println("w="+w+", h="+h+" - pw="+pw+", ph="+ph);
    Image cim = createImage(pw, ph);
    cim.getGraphics().drawImage(im,0,0, this);                     
    Cursor Custom_Cursor = tk.createCustomCursor(cim,new Point(0,0),"Drawing wall");
    draftGrid.setCursor( Custom_Cursor );The System.out.println statement prints: w=18, h=13 - pw=32, ph=32
    If I try to do the createImage with w and h instead of pw and ph the same gray square (32,32) is created, and in addition the cursor's size is too big which was the probem to begin with ...
    - bjorn

  • Custom cropping using pixel dimension

    The banner image module for my website requires images cropped to 940 x 400 pixels. When I use the Custom cropping function in PSE 12 (on a Mac OSX 10.9.2), it only shows a cm dimension. Can I do a custom crop using a pixel dimension?

    You should just be able to type 940 px and 400 px in the width and height fields
    Another way is to use the Rectangular Marquee Tool and use Aspect>Fixed Size then enter 940 px X 400 px

Maybe you are looking for