UFT 12.01-Unable to Identify objects inside grid table

We are automating a Window based application using UFT 12.01.
The Product and UFT Tool are installed in Client Network-Desktop and we are accessing through VPN connectivity.
Technology stack of the application are
.Net Framework 4.0
IIS6.0 or greater
Sql Server 2008 R2
DevExpress V11.2 (UI & Reports)
Janus Controls (UI)
AutoMapper used within Interfaces
Ciloci.Flee used for expression builder
Autofac used of IOC cache
The grid table is identified as SwfObject and  its dynamic table. Hence  we can’t perform any table operations inside table like get row() , get celldata() etc.,.We need to capture edit box inside a row which is enabled on clicking the particular row.  
How to Identify objects inside Grid table

Hello again,
Here you are the DDL of the offending table:
CREATE TABLE "DBADMEX"."T50SEC82"
"COD_EMPRESA" CHAR(4 BYTE) DEFAULT ' ' NOT NULL ENABLE,
"COD_EMPR_CONT" CHAR(4 BYTE) DEFAULT ' ' NOT NULL ENABLE,
"COD_SECT_CONT" CHAR(2 BYTE) DEFAULT ' ' NOT NULL ENABLE,
"NUM_CUEN_CONT" CHAR(18 BYTE) DEFAULT ' ' NOT NULL ENABLE,
"COD_PAIS" CHAR(4 BYTE) DEFAULT ' ' NOT NULL ENABLE,
"COD_SECTOR" CHAR(6 BYTE) DEFAULT ' ' NOT NULL ENABLE
PCTFREE 10 PCTUSED 40 INITRANS 50 MAXTRANS 255 NOCOMPRESS LOGGING STORAGE
INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645 PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT
TABLESPACE "TS_50" ;
CREATE UNIQUE INDEX "DBADMEX"."I5000082" ON "DBADMEX"."T50SEC82"
"COD_EMPRESA", "COD_EMPR_CONT", "COD_SECT_CONT", "NUM_CUEN_CONT"
PCTFREE 10 INITRANS 50 MAXTRANS 255 COMPUTE STATISTICS STORAGE
INITIAL 65536 NEXT 1048576 MINEXTENTS 1 MAXEXTENTS 2147483645 PCTINCREASE 0 FREELISTS 1 FREELIST GROUPS 1 BUFFER_POOL DEFAULT
TABLESPACE "TS_50" ;
We are using the following versions:
Oracle database: 11.1.0.7.0
Oracle Client: 11.2.0.1.0
Windows (where the client runs): XP SP3 (version 5.1 Build 2600_spsp_sp3_gdr.080814-1236) in spanish.
SQL Developer: 2.1.1.64 (MAIN-64.45)
I think I haven't forgotten anything.
Thanks in advance for your help!

Similar Messages

  • Codedui: Unable To Identify Objects Inside The Virtual Machine

    Hi
    We are unable to identify objects inside the virtual machine. We want to perform some tasks inside the virtual machine. The virtual machine object is getting identified as image. So when we perform tasks like creating a folder or opening any application
    inside that virtual machine, all actions are recorded as image.Need help on this ASAP.
    Thanks

    Hi Haripriya78,
    Thank you for posting in MSDN forum.
    >>Codedui: Unable To Identify Objects Inside The Virtual Machine
    Based on your issue, could you please tell me what operation you do and then get the error message?
    Whether you record and run this coded UI test and then get the error message?
    If possible, please tell me more detailed message about this issue.
    Generally, I know that if you want to identify objects for coded UI test, I know that the
    recorder needs to be present in the machine on which you are trying to record actions.
    For more information, please refer the Vinoth's suggestion to check this issue.
    https://social.msdn.microsoft.com/Forums/vstudio/en-US/1b7a328d-a9b6-48a6-9cb9-8ff8ac7dd435/codedui-unable-to-identify-objects-inside-the-virtual-machine?forum=vsautotest
    If I misunderstanding your issue, please tell me more message about your issue so that we will further help you support this issue.
    Best Regards,
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • QTP unable to identify objects in a flex application

    Hi,
    I am having an application that runs on flex 3.6 SDK. I am trying to automate the same using QTP 10.0, but, I am unable to identify the objects. I have installed the Flex 4.5 add-in, but still unable to recognize objects.
    Upon browsing some forums, i found that I need to compile the files "automation.swc, automation_agent.swc, automation_dmv.swc, qtp.swc, automation_flashflexkit.swc" by including them in <include-libraries> ...</include-libraries>  tags in "flex-config.xml" file present under "C:\Program Files\Adobe\Flex Builder 3 Plug-in\sdks\3.6.0\frameworks". We did that, but still, not able to identify objects.
    It would be of great help to me if any some one could tell if I am missing out anything ?

    hello,
    not only need the objects be enclosed by their parent frame, but they also need to be "on top of it" ... meaning if you imagine your report layout as a set of layers that you look at from the side, your "layout surface" would be the bottom most layer and then all objects would be layered on top of each other. in this view, only objects that are in layers above a particular frame can become its children. after that the relationship is determined whether or not an object is inside a frame or not.
    you might want to check your object navigator to see whether or not the particular objects are actually in the right place in the hierarchy.
    thanks,
    ph.

  • Openscript - adf   unable to identify object value

    Hi Everyone,
    Please find the screenshot in the below shared link, where the adf inputtext object value is not identified while doing object test.
    https://docs.google.com/file/d/0B0qqXKChgAG1VkRmR1Y0eEYyQlE/edit?usp=sharing
    Kindly suggest on this whether it is a bug .
    Regards,
    Mohan.

    Can we also get a screenshot of all the read-only attributes of that object?

  • ASA5520 AnyConnect SSL VPN Connected but unable to ping my inside LAN

    Hi there, please forgive if I have missed any forum protocols as this is my first post.
    I am trying to configure Anyconnect SSL VPN. I am able to connect to the VPN on a laptop, witch is able to download the anyconnect client from the ASA. I am unable to ping any of my IP's that are on the inside of my ASA. Before posting here I have spent many hours on forums and watching videos on anyconnect SSL VPN creation and I am following it to the T but still no ping. Any help would be very much appreciated.
    Inside              192.168.1.254/24
    Outside           dhcp
    VPN Pool        192.168.250.1-50/24
    Inside LAN     192.168.1.0/24
    : Saved
    ASA Version 8.4(4)1
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface GigabitEthernet0/1
    nameif inside
    security-level 99
    ip address 192.168.1.254 255.255.255.0
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 99
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns server-group DefaultDNS
    domain-name dock.local
    same-security-traffic permit inter-interface
    object network inside-network-object
    subnet 192.168.1.0 255.255.255.0
    object network management-network-object
    subnet 192.168.100.0 255.255.255.0
    object network NETWORK_OBJ_192.168.250.0_25
    subnet 192.168.250.0 255.255.255.128
    object-group network AllInside-networks
    network-object object inside-network-object
    network-object object management-network-object
    access-list inside_access_in extended permit ip any any
    access-list outside_access_in extended permit icmp any any echo-reply
    access-list split_tunnel standard permit 192.168.1.0 255.255.255.0
    access-list split_tunnel standard permit 192.168.100.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool vpn_pool 192.168.250.1-192.168.250.100 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-647.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source dynamic AllInside-networks interface
    nat (inside,any) source static any any destination static NETWORK_OBJ_192.168.250.0_25 NETWORK_OBJ_192.168.250.0_25 no-proxy-arp route-lookup
    access-group outside_access_in in interface outside
    access-group inside_access_in in interface inside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable 4433
    http 192.168.100.0 255.255.255.0 management
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 192.168.100.0 255.255.255.0 management
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
    webvpn
    enable outside
    anyconnect image disk0:/anyconnect-win-3.1.03103-k9.pkg 1
    anyconnect enable
    tunnel-group-list enable
    group-policy GroupPolicy_anyconnect internal
    group-policy GroupPolicy_anyconnect attributes
    wins-server none
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ssl-client ssl-clientless
    split-tunnel-policy tunnelall
    split-tunnel-network-list value split_tunnel
    default-domain value dock.local
    username test password JAasdf434ey521ZCT encrypted privilege 15
    tunnel-group anyconnect type remote-access
    tunnel-group anyconnect general-attributes
    address-pool vpn_pool
    default-group-policy GroupPolicy_anyconnect
    tunnel-group anyconnect webvpn-attributes
    group-alias anyconnect enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:24bcba3c4124ab371297d52260135924
    : end :

    : Saved
    ASA Version 8.4(4)1
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface GigabitEthernet0/1
    nameif inside
    security-level 99
    ip address 192.168.1.254 255.255.255.0
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 99
    ip address 192.168.100.1 255.255.255.0
    ftp mode passive
    dns server-group DefaultDNS
    domain-name dock.local
    same-security-traffic permit inter-interface
    object network inside-network-object
    subnet 192.168.1.0 255.255.255.0
    object network management-network-object
    subnet 192.168.100.0 255.255.255.0
    object network NETWORK_OBJ_192.168.250.0_25
    subnet 192.168.250.0 255.255.255.0
    object-group network AllInside-networks
    network-object object inside-network-object
    network-object object management-network-object
    access-list inside_access_in extended permit ip any any
    access-list outside_access_in extended permit icmp any any echo-reply
    access-list split_tunnel standard permit 192.168.1.0 255.255.255.0
    access-list split_tunnel standard permit 192.168.100.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool Anyconnect-pool 192.168.250.1-192.168.250.100 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-647.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source dynamic AllInside-networks interface
    nat (inside,outside) source static inside-network-object inside-network-object destination static NETWORK_OBJ_192.168.250.0_25 NETWORK_OBJ_192.168.250.0_25
    nat (inside,outside) source static management-network-object management-network-object destination static NETWORK_OBJ_192.168.250.0_25 NETWORK_OBJ_192.168.250.0_25
    access-group outside_access_in in interface outside
    access-group inside_access_in in interface inside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable
    http 192.168.100.2 255.255.255.255 management
    http 192.168.100.0 255.255.255.0 management
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh 192.168.1.0 255.255.255.0 inside
    ssh 192.168.100.0 255.255.255.0 management
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    management-access inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
    webvpn
    enable outside
    anyconnect image disk0:/anyconnect-win-3.1.03103-k9.pkg 1
    anyconnect enable
    tunnel-group-list enable
    group-policy GroupPolicy_Anyconnect_VPN internal
    group-policy GroupPolicy_Anyconnect_VPN attributes
    wins-server none
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ssl-client
    split-tunnel-policy tunnelall
    split-tunnel-network-list value split_tunnel
    default-domain value dock.local
    username sander password f/J.5nLef/EqyPfy encrypted
    username aveha password JA8X3IiqPvFFsZCT encrypted privilege 15
    tunnel-group Anyconnect_VPN type remote-access
    tunnel-group Anyconnect_VPN general-attributes
    address-pool Anyconnect-pool
    default-group-policy GroupPolicy_Anyconnect_VPN
    tunnel-group Anyconnect_VPN webvpn-attributes
    group-alias Anyconnect_VPN enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:4636fa566ffc11b0f7858b760d974dee
    : end:

  • Unable to rename objects

    In the OMWB, I am unable to rename objects. For example, in the Source Model under the Views folder, I have a view whose name is 100 characters long. I want to rename it to a 30 character name (something meaningful and not system generated.) The on-line help says to use the menu to click on Object > Rename, but that is grayed-out. The only available options are delete and parse. Both of those work, by the way.
    I just downloaded and installed OMWB last Thursday, so this is latest version of software. I also got the SQL Server 2000 plug-in, and it's installed correctly because I have been successful at migrating SQL Server 2000 to Oracle 10g.

    Hi Mark,
    You are quiet correct. The OMWB does not allow you to rename schema objects in the Source Model. The only objects which can be renamed manually are tablespaces and users in the Oracle Model.
    The workaround is to rename the view inside the Oracle Model PL/SQL editor. Then your view with get generated with the choosen name.
    I have found the following in the OMWB help
    "You can customize the Oracle Model by: Creating, deleting, and renaming objects "
    This will be logged as a bug as not all objects can be renamed. Could you provide a link to the on-line help document which states "click on Object > Rename" as I am having difficulty finding it, and I will add this to the bug report.
    Regards,
    Dermot.

  • Cant do setColor(Color.BLACK); to a graphic object inside a class

    i have a graphic object inside a class:
    JPanel panel = new JPanel();
    Graphic lienzo = areadibujo.getGraphic();
    and then i cant do this:
    lienzo.setColor(Color.BLACK);
    netbeans error:
    <identifier> expected
    i just can do that inside a method from the class...

    HI i found the problem.
    The problem is that when i create the graphic object i do this:
    Graphics lienzo = areadibujo.getGraphics();
    areadibujo.getGraphics(); returns null so when i try to do something like lienzo.drawline(1,1,200,200); it just says nullpointer error, i guess at the time i create graphic object the panel "areadibujo" is not still created because the frame doesnt still shows, i can correct this by copying Graphics lienzo = areadibujo.getGraphics(); inside a actionperfmoded or other event method , but i dont wanna do that, where does the panel object already is created in constructor?.... i dont know if i explain my self well or how can i force areadibujo.getGraphics() to return something...

  • How to get attribute value from an object inside an object in Xpress

    Does anyone know how to get an attribute value from an object in Xpress in a workflow? I have an object structured as follows:
    <ResourceInfo accountId='mj628' tempId='3483372b787ce7dd:-5d99a0c5:130cb238483:-3600'>
    <ObjectRef type='Resource' name='Google Apps'/>
    </ResourceInfo>
    I need if possible to get the name='Google Apps', which is inside the ObjectRef, so I guess its an attribute value of an object inside an object.

    If the ResourceInfo object is accessible in a variable, i.e. named "myResInfo", you just have to check the Java API and call the relevant method:
    <invoke name='getResourceName'>
      <ref>myResInfo</ref>
    </invoke>

  • How to get the values of the objects inside an object??

    Hi,
    I am trying to write code to display name and memory usage of all session attributes, in a recursive way.
    I suppose reflection is needed here, but I can’t figure out how to get the values of the objects inside an object...
    private void handleIt(String attributeName, Object attributeValue) {
         boolean isPrimitiveOrNull = ((null == attributeValue) ||
              (attributeValue.getClass().isPrimitive()));                                         
         if (isPrimitiveOrNull) {
              sb.append("{" + attributeName + ":" + sizeOf(attributeValue) + "}");
         } else {
              sb.append("{" + attributeName + ":" + sizeOf(attributeValue) + "{");               
              Field[] fields = attributeValue.getClass().getDeclaredFields();
              int lim = fields.length;
              String name;
              Object value = null;
              for (int i = 0; i < lim; i++) {
                   name = fields.getName();
                   //LOOK AT THIS LINE: !!!!!!!!!!!!!!!!!!!!!!!!!!!
                   value = fields[i].get(obj); //I don´t know what 'obj' should be??
                   handleIt(name, value);
              sb.append("}");               
    Any suggestions will be greatly appreciated...

    I realized that massive int objects called MAX_VALUE, MIN_VALUE and SIZE where causing the StackOverflow, so I removed them from the analysis.
    This is the resultant code. But I think it isn’t accurate in calculating the real size of objects being got using reflexion.
    Do you or somebody have any more suggestions?
    import java.io.ByteArrayOutputStream;
    import java.io.IOException;
    import java.io.ObjectOutputStream;
    import java.lang.reflect.Field;
    import java.util.Enumeration;
    import javax.servlet.ServletException;
    import javax.servlet.http.HttpServlet;
    import javax.servlet.http.HttpServletRequest;
    import javax.servlet.http.HttpServletResponse;
    import javax.servlet.http.HttpSession;
    public class SessionMeasurer extends HttpServlet {
         private static final long serialVersionUID = 1470488362727841992L;
         private StringBuilder sb = new StringBuilder();
         public void doGet(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException {
              performTask(request, response);
         public void doPost(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException {
              performTask(request, response);
         public void performTask(HttpServletRequest request, HttpServletResponse response) {
              HttpSession     session = request.getSession(false);     
              String attributeName = "";
              Object attributeValue = null;
              for (Enumeration<?> attributeNames = session.getAttributeNames(); attributeNames.hasMoreElements();) {
                   attributeName = (String)attributeNames.nextElement();
                   attributeValue = session.getAttribute(attributeName);
                   handleIt(attributeName, attributeValue);               
              System.out.println(sb.toString());
         private void handleIt(String attributeName, Object attributeValue) {           
              if (attributeValue != null) {          
                   boolean isPrimitive = attributeValue.getClass().isPrimitive();
                   if (isPrimitive) {
                        sb.append("{" + attributeName + ":" + sizeOf(attributeValue) + "}");
                   } else {
                        sb.append("{" + attributeName + ":" + sizeOf(attributeValue) + "{");               
                        Field[] fields = attributeValue.getClass().getDeclaredFields();
                        String name;
                        Object value = null;
                        int lim = fields.length;
                        for (int i = 0; i < lim; i++) {
                             name = fields.getName();                                                                                                         
                             if (!name.endsWith("_VALUE") && !name.equals("SIZE") && !name.equals("serialVersionUID")) {
                                  try {
                                       value = fields[i].get(attributeValue);
                                  } catch(Exception e) {
                                       //PENDIENTE: Tratamiento excepción
                                  handleIt(name, value);
                        sb.append("}");               
         private int sizeOf(Object obj) {
              //Valid only for Serializables
              ByteArrayOutputStream baos = new ByteArrayOutputStream();
              ObjectOutputStream oos = null;     
              byte[] bytes = null;               
              try {          
                   oos = new ObjectOutputStream(baos);
                   oos.writeObject(obj);
                   bytes = baos.toByteArray();
              } catch(Exception e) {               
                   //PENDIENTE: Tratamiento excepción
              } finally {
                   if (oos != null) {
                        try {
                             oos.close();
                        } catch(Exception e) {
                             //PENDIENTE: Tratamiento excepción                         
                   if (baos != null) {
                        try {
                             baos.close();
                        } catch(Exception e) {
                             //PENDIENTE: Tratamiento excepción                         
              int size = -1;
              if (bytes != null) {
                   size = bytes.length;
              return size;          

  • Unable to retrieve Object.  Failed to load database information

    I am getting the following error when trying to run my reports from Crystal XI with SQL Server 2005.
    CrystalReportViewer
    Error in File 180+DAYREP.EWARP: Failed to load database information.
    Unable to retrieve Object.
    Error in File 180+DAYREP.EWARP: Failed to load database information.
    I have done some research on this but no luck on resolving the issue.
    Any suggestions are welcome thanks.

    First thought is that the application cannot access the DSN or database driver that the report was designed on, this could be permissions.
    I tried to ping my database and was unable to find the host.  I was under the assumption it was using TNSNames which is able to resolve. 
    How can I validate the permissions?
    As I said I'm a little lost here.  Apologies if I ask stupid questions.

  • Unable to identify the exchange protocol of the message (sync AS2 MDN)

    Hi,
    We got the following error:
    Description: Unable to identify the exchange protocol of the message
    StackTrace:
    Error -: AIP-50080: Exchange protocol identification error
         at oracle.tip.adapter.b2b.engine.Engine.processIncomingMessage(Engine.java:1367)
         at oracle.tip.adapter.b2b.msgproc.Request.postTransmit(Request.java:2370)
         at oracle.tip.adapter.b2b.msgproc.Request.outgoingRequestPostColab(Request.java:1813)
         at oracle.tip.adapter.b2b.msgproc.Request.outgoingRequest(Request.java:968)
         at oracle.tip.adapter.b2b.engine.Engine.processOutgoingMessage(Engine.java:1152)
         at oracle.tip.adapter.b2b.xmlgwIntg.XMLGWIntegration.raiseOutboundMessage(XMLGWIntegration.java:168)
         at oracle.tip.adapter.b2b.xmlgwIntg.Outbound.onMessage(Outbound.java:297)
         at oracle.jms.AQjmsListenerWorker.dispatchOneMsg(AQjmsListenerWorker.java:316)
         at oracle.jms.AQjmsListenerWorker.run(AQjmsListenerWorker.java:129)
         at java.lang.Thread.run(Thread.java:534)
    Here is the Wire message (sync MDN)
    =======================
    Message-ID=<23033756.391232032071968.JavaMail.SYSTEM@INUBITTEST>
    Subject=Your ORDERS AS2
    [email protected]
    Content-Length=1347
    MIME-Version=1.0
    Server=Apache
    Date=Thu, 15 Jan 2009 15:07:52 GMT
    Content-Type=multipart/mixed;      boundary="----=_Part_53998_23619909.1232032071968"
    [email protected]
    ------=_Part_53998_23619909.1232032071968
    Content-Type: text/plain; charset=UTF-8; name=test.txt
    Content-Transfer-Encoding: 7bit
    Content-Disposition: attachment; filename=test.txt
    Message-ID: <17080722.371232032071906.JavaMail.SYSTEM@INUBITTEST>
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=disposition-notification;
         boundary="----=_Part_53997_14786767.1232032071906"
    AS2-Version: 1.1
    AS2-From: test_AS2
    AS2-To: as2me
    ------=_Part_53997_14786767.1232032071906
    Content-Type: text/plain; charset=us-ascii
    Content-Transfer-Encoding: 7bit
    MDN for Message ID: <33156:4:0:137@as2me>
    From: as2me
    To: test_AS2
    Received on: Thu, 15 Jan 2009 16:07:51 +0100
    Status: processed
    Comment: This is not a guarantee that the message has
    been completely processed or unterstood.
    ------=_Part_53997_14786767.1232032071906
    Content-Type: message/disposition-notification
    Content-Transfer-Encoding: 7bit
    Reporting-UA: inubit Integration Server
    Original-Recipient: rfc822; test_AS2
    Final-Recipient: rfc822; test_AS2
    Original-Message-ID: <33156:4:0:137@as2me>
    Disposition: automatic-action/MDN-sent-automatically; processed
    Received-Content-MIC: 5kFOLMXOUurpm6DUTA8IMRj5gcs=, sha1
    ------=_Part_53997_14786767.1232032071906--
    ------=_Part_53998_23619909.1232032071968--
    ============================
    The communication with our TP is going well, we are able to send, receive messages over AS2 and send back MDN, but we are not able
    to receive their MDN.
    Edit:
    It seems that after the latest MLR patch, the error changed to [IPT_HttpSendError] HTTP encounters send error :. Premature EOF encounter but the roots seem to lead to the problem with MDN as B2B is sending the message a couple of times now and gives the mentioned EOF error.
    Please advise,
    Thank you
    Edited by: Kamil Zadora on Jan 30, 2009 3:44 AM

    Hi Ramesh,
    Yes, agreement uses AS2 IDentifiers. Incoming messages are recognized correctly, and we send back sync MDN that is correctly received by our TP. They also recieve our messages correctly although Oracle B2B does not recognize the MDN from them. I think that this causes that, now after applying the latest MLR patch, B2B tries to send it around 6 times and gives the Unexpected EOF error.
    Thank you for your help in advance,
    Kind regards,

  • CrystalReportViewer Failed to Open the connection Unable to retrieve Object

    I am getting the following Error on trying to view a report in the CMC and the Infoview.
    CrystalReportViewer
    Failed to Open the connection. ReportName
    Unable to retrieve Object.
    Failed to open the connection. ReportName
    I have recently re-installed Crystal Reports Server XI  on a server after a disk failure. I had a backup of my CMS database. I reinstalled the Crystal Servwer without atttaching this database, however crystal did not create a new db so I attached my old one.
    I have deleted all my old ODBC connections and recreated them with new names and then reconnected my reports in Crystal Reports XI using the "Set Datasource Location" option and the report works fine.But as soon as I try to view it after uploading it as an object onto the server, I get the above error.
    Any help would be appreciated.

    I am tagging into this unanswered question as well because I think I have a similar issue.  In my case I have a report which runs correctly in Crystal Reports designer but when I move it to the scheduler it fails on a "Failed to connect" to the report.  In have used "Set data location" to no avail.  When I go to Admin Tools and look at the complete list of datasources for all my reports this particular datasource is listed twice.  The group of reports under one of the datasources works correctly.  The reports listed under the second datasource all fail.  The two datsources are spelled exactly the same and when I sompare the database details for a successfull and a failing report using this datasource they are the same (in the console and in infoview).
    I have also checked the ODBC connections on the Crystalserver and there is only one occureence.
    Any ideas?
    Thanks!

  • E5 - unable to open. object type not supported

    hi. 
    2 Month back i brought Nokia E-5 Mobile and after few weeks i upgraded the Memory from 2Gb to 8GB. After copying all files from 2gb to 8gb am not able to open or install any existing programs and files. Even maps are not working. When trying to open or install the files am getting this erro " unable to open object type not supported " . Kindly help on this error.
    Thanks
    Velavan

    I have never attempted what you did, so can't say for certain, but I don't think memory card data is meant to be copied from one card to another (unless we're talking about data files like pictures or mp3's).  I don't understand what you mean by being unable to install files.  Are you trying to reinstall the programs that aren't working?  If your 2GB card still works normally, I suggest you format the 8 GB card, reinstall the programs to the empty card, and re-download the maps data.  If the programs still give you trouble, you may need to uninstall them from the 2 GB card first, but I don't think that should be necessary.  I hope that helps.

  • Multiple SQL task objects inside a package object is not generating proper DTSX

    
    I am programmatically adding multiple ExecuteSQLtask objects inside a package. I am specifying all the required properties to the ExecuteSQLtask objects.  However, when I save the package object to dtsx, the package looses the properties of some
    of the ExecuteSQLtask object.
    In the below example, I have created 3 ExecuteSQL task objects using the function AddSqlTask. However, once you run it, one of the objects will loose its properties. What makes it more weird is the fact that sometimes, object 1 looses the properties,
    some times, its object number 2. Its random. I know that these objects are COM objects. Is there something I need to careful of when setting the properties ? Why are the values lost when I save them to DTSX ?
    using System;
    using System.Collections.Generic;
    using System.Configuration;
    using System.Data;
    using System.Data.SqlClient;
    using System.Globalization;
    using System.IO;
    using System.Linq;
    using System.Text;
    using System.Threading;
    using System.Threading.Tasks;
    using System.Timers;
    using Microsoft.SqlServer.Dts.Runtime;
    using Microsoft.SqlServer.Dts.Runtime;
    using Microsoft.SqlServer.Dts.Tasks.FileSystemTask;
    using Microsoft.SqlServer.Dts.Tasks.BulkInsertTask;
    using Microsoft.SqlServer.Dts.Runtime;
    using Microsoft.SqlServer.Dts.Pipeline;
    using Microsoft.SqlServer.Dts.Pipeline.Wrapper;
    using Microsoft.SqlServer.Dts.Tasks.ExecuteSQLTask;
    using Microsoft.SqlServer.Dts.Tasks.ExecutePackageTask;
    namespace PackageCreator
    class Program
    static void Main(string[] args)
    #region Package 1
    Package package1 = new Package();
    #region ConnectionString
    AddSqlConnection(
    package1,
    ConfigurationManager.AppSettings["ServerHostName"],
    ConfigurationManager.AppSettings["SqlServerDefaultDB"]
    #endregion
    AddSqlTask(package1, "P1 - Task1");
    AddSqlTask(package1, "P1 - Task2");
    AddSqlTask(package1, "P1 - TaskFinal");
    #region Add Dependencies
    package1.PrecedenceConstraints.Add(
    package1.Executables[0] as TaskHost,
    package1.Executables[1] as TaskHost
    package1.PrecedenceConstraints.Add(
    package1.Executables[1] as TaskHost,
    package1.Executables[2] as TaskHost
    #endregion
    #endregion
    #region Package 2
    Package package2 = new Package();
    #region ConnectionString
    AddSqlConnection(
    package2,
    ConfigurationManager.AppSettings["ServerHostName"],
    ConfigurationManager.AppSettings["SqlServerDefaultDB"]
    #endregion
    AddSqlTask(package2, "P2 - TaskFinal");
    #region ExecutePackageTaskClass
    Executable exec1 = package2.Executables.Add("STOCK:ExecutePackageTask");
    TaskHost th = exec1 as TaskHost;
    ExecutePackageTask myTask = th.InnerObject as ExecutePackageTask;
    myTask.PackageID = package1.ID;
    #endregion
    #region Add Dependencies
    package2.PrecedenceConstraints.Add(
    package2.Executables[0] as TaskHost,
    package2.Executables[1] as TaskHost
    #endregion
    #endregion
    //new Ispac(package1, package1.ID).DeployAndRun();
    SavePackage(package1);
    SavePackage(package2);
    var packageList = new List<Package>();
    packageList.Add(package1);
    packageList.Add(package2);
    new IspacPackageCollections(packageList).DeployAndRun();
    Console.Read();
    private static void AddSqlTask(Package package, string component)
    //Thread.Sleep(5000);
    package.Executables.Add("STOCK:SQLTask");
    ExecuteSQLTask executeSQLTask = (package.Executables[package.Executables.Count - 1]
    as TaskHost).InnerObject
    as ExecuteSQLTask;
    executeSQLTask.Connection = package.Connections[0].ID;
    executeSQLTask.SqlStatementSource = "insert into [dbo].[SupersetPackageDependencies] (Component) values ('" +
    component + @"')";
    private static void SavePackage(Package package)
    string packageNetworkLocation = @""
    + ConfigurationManager.AppSettings["packageNetworkLocation"]
    + @"\" + package.ID + ".dtsx";
    new Application().SaveToXml(
    packageNetworkLocation,
    package,
    null
    //new Application().SaveToSqlServer(
    // package,
    // null,
    // "ANUPN8470P",
    // null,
    // null
    #region AddConnectionManager
    private static ConnectionManager AddSqlConnection(Package package, string server, string database)
    return AddConnection(
    package,
    "OLEDB",
    String.Format(
    CultureInfo.InvariantCulture,
    "Provider=SQLOLEDB.1;Data Source={0};Persist Security Info=False;Initial Catalog={1};Integrated Security=SSPI;",
    server,
    database)
    private static ConnectionManager AddConnection(Package package, string type, string connectionString)
    ConnectionManager manager = package.Connections.Add(type);
    manager.ConnectionString = connectionString;
    manager.Name = String.Format(
    CultureInfo.InvariantCulture,
    "{0} Connection",
    type);
    return manager;
    #endregion
    public static void AddExecuteSqlTask(
    Package _package,
    string _componentId
    _package.Executables.Add("STOCK:SQLTask");
    // Get the task host wrapper
    ExecuteSQLTask executeSQLTask = (_package.Executables[_package.Executables.Count - 1]
    as TaskHost).InnerObject
    as ExecuteSQLTask;
    #region Set required properties
    executeSQLTask.Connection = _package.Connections[0].ID;
    executeSQLTask.SqlStatementSource = "insert into [dbo].[SupersetPackageDependencies] (Component) values ('" +
    _componentId + @"')";
    #endregion
    //return executeSQLTask;

    Why you do not tell what properties get lost?
    And why is the same get repeated (you want parallel?):
    package1.Executables[0] as TaskHost,
    package1.Executables[1] as TaskHost
    package1.PrecedenceConstraints.Add(
    package1.Executables[1] as TaskHost,
    package1.Executables[1]
    And why not to add them
    like
    package1.PrecedenceConstraints.Add(
    package1.Executables[0] as TaskHost);,
    package1.PrecedenceConstraints.Add( package1.Executables[1] as TaskHost
    Arthur
    MyBlog
    Twitter

  • How can I change the color of a object inside a symbol?

    Hello!
    I'm working on this study and I need to change the color of an object inside a symbol when I click another object.
    The object is called "bola", wich is inside the symbol "ponto" and the clicking object are the colored pencils (each pencil should change the color of the symbol's object, giving the impression you'd selecting a different pencil to draw).
    I think it's simple to understand what I mean when you see the files.
    I already tried this line on click event of the pencils, but it didn't work:
    sym.getSymbol("ponto").$("bola").css("color","#123456");
    Anyone knows how to make that work?
    I would like to improve the experience of drawing as well. I made it with the "mousedown" event. Is that a better way to get a similar effect?
    My files
    Thanks a lot,
    Clayton F.

    Ok here is another sample:
    http://www.meschrene.puremadnessproductions.net/Samples/HELP/LapisB/Lapis.html
    http://www.meschrene.puremadnessproductions.net/Samples/HELP/LapisB/Lapis.zip
    You need to create a var that changes the css background color..
    Hopefully you can understand what I did...
    The text I left showing so that you could see it change...
    I updated the files and all colors should work now.
    Message was edited by: ♥Schrene

Maybe you are looking for