URGENT! Setting QoS DSCP value on switches

Hi,
I desperately need replies to my problem below.
I tried to set DSCP values to 2 applications, video and video conference, on cisco 3560 and cisco 2950 swtiches based on the source ip address of the servers.
So on the switches, I created an access-list to identify the servers' ip addresses.
Then I use "class-map match-any video" followed by "match access-group" for the access-list.
Then I use "policy-map policy1", then "class video" then "set dscp ef".
Finally I apply the policy to the INPUTS of all ports "service-policy input policy1"
But when I use a sniffer to sniff the ports, I see that the DSCP value is not "EF", instead it is "0x20, class 4".
Why is this so?
Where have I done wrongly?
Finally, on routers, where do I apply QOS policy? On input ports or output ports of routers?
I urgently need help.
Thank you.
Regards,
Rachel

Rachel,
Without seeing what you have in place so far, I'll see if I can answer some of those questions. If the switch connects to a router, then the outbound (egress) interface would in fact be that interface on the switch that connects to a router. Best practices dictate that the classification and marking should be done on the inbound (ingress) interface which connects the switch to the network where the host resides.
If you wanted to implement an end-to-end QoS solution, then you should configure QoS on every interface between the source and destination. This is because even FastE/GigE ports can become congested due to worm outbreak or DOS attack. But if all you want to do right now is guarantee bandwidth to the video traffic across the WAN, that can be accomplished by a) classifying and marking the video traffic as close to the source as possible, and b) configuring queuing/scheduling on the outbound WAN interface based on those markings.
Once the switch has marked the traffic with a DSCP value per (a), that DSCP value should remain intact until it reaches the WAN router per (b), and all the way until it reaches its destination. That is, unless there is a device somewhere in between that is remarking traffic. If the switch you reference is not directly connected to the router you reference, there could be another switch or router in between marking everything back to DSCP 0, meaning that all traffic is untrusted.
I don't have a 2950 here with me, but without checking syntax this is basically what you should have, if you just want to mark video traffic EF and then guarantee bandwidth on the wan:
2950:
access-list permit
class-map match-any VIDEO
match access-group
policy-map POLICY1
class VIDEO
set ip dscp 46 !
interface
service-policy input POLICY1
Router:
class-map match-any EF_VIDEO
match ip dscp 46
policy-map VIDEO_OUT
class EF_VIDEO
priority 1600
interface
service-policy output VIDEO_OUT
If you are sniffing traffic on that switch to ensure that video traffic is being marked, make sure that you are sniffing the outbound interface toward the router, not the inbound interface from the host. That will ensure that your sniffer trace picks up the traffic after it has been marked DSCP 46.
Just in case this post is related to your post where you want to lock the router WAN interface so that the 1.6 megs of video gets through but other traffic is dropped when the video takes the full 1.6 megs of bandwidth...
QoS queuing/scheduling only kicks in when the interface experiences congestion. If there is no congestion on the interface, traffic will still be marked and policed per the service policy, but not queued/scheduled - it will just fly right through the interface with the new markings. The only way to force such congestion at 1.6 megs is to use traffic shaping. You would need to shape the entire interface down to 1.6 megs, and THEN apply the priority bandwidth. This can be accomplished with a hierarchical policy-map as follows:
Router:
class-map match-any EF_VIDEO
match ip dscp 46
policy-map VIDEO_OUT
class EF_VIDEO
priority 1600
policy-map SHAPE_OUT
class class-default
shape average 1600000
service-policy VIDEO_OUT
interface
service-policy output SHAPE_OUT
I really hope I am helping you out here, please let me know how this works out. Good luck!
Best Regards
Robert

Similar Messages

  • Mls qos trust dscp??? is setting my DSCP values to zero!?

    Hi,
    I was just doing some testing to ensure that the command 'mls qos trust dscp' is working on my 6509 switches before rolling out QoS.
    Before adding any configuration I could see using wireshark that traffic from my Avaya 9608 handset was coming through with a DSCP value of 46 (as it is supposed to).
    I then added the command 'mls qos' (at global level)
    on examining the wireshark output this time, the DSCP value had been set to zero (i.e. it defaulted it to best effort)
    I then expected by adding the commmand 'mls qos trust dscp' on the interface the phone is connected to that the DSCP value would would again be left alone?
    does anybody know why this is happening?
    Many thanks in advance.
    Andy

    Hi,
    thanks for your reply.
    mls qos
    interface GigabitEthernet3/34
    description *** DATA VLAN 35 - VOICE VLAN 34 ***
    switchport
    switchport trunk native vlan 36
    switchport trunk allowed vlan 34,36
    switchport mode trunk
    mls qos trust dscp
    no cdp enable
    spanning-tree portfast trunk
    If i don't include the global 'mls qos' command then the voice packets keep the dscp 46 value.  If I add the mls qos command this causes the switch to set the dscp values to zero.
    Thanks again 
    ps.  there are some other mls commands on the switch... i don't know if these could interfere but they were already on there so i'm reluctant to remove them..

  • Qos DSCP value 46 gone, after enabling Remote Desktop Services on Windows 2012 R2 Standard

    Hi,
    After installing a clean Windows Server 2012 R2 with
    all Windows updates I have setup Policy-Based QoS for tagging defined traffic,
    in the test case all traffic to one specific ip address. Whireshark logging
    displays the correct configured (46) dscp value so the group policy is
    working fine. After installing Remote Desktop Services the Policy-Based QoS is
    still in place but Wireshark results that the value is 0.
    Can somebody explain why this happens and how to solve
    it?
    Regards, Edward

    Hi Edward,
    Thank you for posting in Windows Server Forum.
    Did you find any related error for your case?
    By default, Windows traffic has a DSCP value of 0. Network routers use the DSCP value to classify network packets and to queue them appropriately. The number of queues and their prioritization behavior needs to be designed as part of your organization's QoS
    strategy. For example, your organization may choose to have five queues: latency-sensitive traffic, control traffic, business critical traffic, best effort traffic, and bulk data transfer traffic.
    More information, please see:
    Policy-based Quality of Service (QoS)
    http://technet.microsoft.com/en-us/library/dd919203(v=ws.10).aspx
    Hope it helps!
    Thanks.
    Dharmesh Solanki
    TechNet Community Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact [email protected]

  • Setting Negative Forecast Values to Zero

    In 7.0 we used a option - Setting Negative Forecast Values to Zero.
    But after upgrade to 7.3 this option is missing and I can find any information about this.
    Can we open the option in 7.3?
    Anatoly

    Hi,
    thanks for your reply.
    mls qos
    interface GigabitEthernet3/34
    description *** DATA VLAN 35 - VOICE VLAN 34 ***
    switchport
    switchport trunk native vlan 36
    switchport trunk allowed vlan 34,36
    switchport mode trunk
    mls qos trust dscp
    no cdp enable
    spanning-tree portfast trunk
    If i don't include the global 'mls qos' command then the voice packets keep the dscp 46 value.  If I add the mls qos command this causes the switch to set the dscp values to zero.
    Thanks again 
    ps.  there are some other mls commands on the switch... i don't know if these could interfere but they were already on there so i'm reluctant to remove them..

  • DCIteratorBinding : how to set the iterator value programatically,URGENT

    Hi all
    I have a af:selectOneChoice component bound to Iterator(DCIteratorBinding)
    I want to set the value of the af:selectOneChoice to specific value, I want to do so by setting the current row of the iterator to the value I want
    for example the iterator contains objects of class Dept which has two attributes deptno and deptName
    how can I set the Iterator to point at department with deptno=30, because the iterator deals only with keys

    do you mean setting a default value? If so, look at Re: Using af:selectOneChoice value in Router's case

  • Wireless QoS - DSCP to 802.11e translation

    Hi,
    Would appreciate some advice, I am using a 5508 controller, I have an SSID that has WMM enabled and platinum QoS profile applied, with default settings.  I have 802.11p set to none as we are not doing layer 2 QoS on the switches.
    I found that when pinging a wireless client with DSCP set to EF the packets (all packets in fact) are being sent from the AP to the client with 802.11e set to zero.  I verified this via AirPCAP.
    Can someone confirm why the AP is not taking the DSCP marking from the outer LWAPP IP header and translating it to an 802.11e value?
    My best guess is that I need to enable 802.11p on the QoS profile in order for the AP to start translating DSCP to 802.11e.  The thing is that I don't particularly want to mark 802.11p as we will not be enabling QoS on the switches, and my understanding is that it's not really required in order for DSCP to be translated from the outer LWAPP IP header to the 802.11e field.
    I've reviewed the Cisco documentation on wireless QoS, including the diagram showing the packet flow and copying of QoS markings at each step....
    Thanks in advance,
    Pete

    Hi Pete,
    If you are not enable QoS & disable re-write of DSCP on your switches, pretty much you will get the incoming packet DSCP when it leaves any switchport. Therefore WLC should get  DSCP EF packets & outer CAPWAP should have DSCP EF. I have done a quick test to simulate your issue. WLAN configured for platinum QoS profile with 802.1p set to none. Wired PC - RTP traffic mark to EF in my case (as windows 7 does not correctly classify traffic).
    1. Wired PC (IPCommunicator) ->Switch with no QoS -> AP -> Wireless client (7921 phone)
    2. Wired PC (IPCommunicator) ->Switch with no QoS -> AP -> Wireless client (Laptop with IPC)
    When I capture traffic for Cisco wireless phone I can see wireless frame is having UP value of "6-Voice". But when I do the testing for wirless laptop client I observed wireless frame are having UP of "0 - Best Effort" (as you observed as well). I would expected in both cases wireless frame UP to be zero. Not sure why  behaviour differnt for Cisco 7921 phone.
    Then I enabled QoS on the switch & trust DSCP on AP & wired PC connected port & CoS on WLC connected switch port. But left QoS profile 802.1p tag as " None".  This time in both scenarios I have observed WMM_UP value "0-Best Effort" in wireless frames even though the AP received outer CAPWAP as EF. This is normal behaviour as QoS profile set to 802.1p to none & therefore outer CAPWAP will not translate to UP=6 as it is. It will cap to max of 802.1p configured (presumed none mean 0)
    Finally when I set 802.1p tag to 6 on QoS profile & conduct the same test. I expected in both scenarios UP=6 for EF marked traffic to wireless client (cisco phone or wireless laptop). As expected Cisco phone received wireless frame had UP=6 Voice, but wireless laptop received frame had UP=0 best effort.
    I am geussing  this due to some kind of WMM incompatibility of different devices (not sure though). I will try to do this with some other clients ( jabber in iPhone & Galaxy SIII) & see any common behaviour.
    As per the VoWLAN 4.1 design guide (page 2-18,19) 802.1p classification in QoS profile controll two behaviours
    1. Determine what class of service (CoS) value is used for packets initiated from the WLC.
    2. Determine the maximum CoS value that can be used by clients connected to that WLAN.
    Regarding the QoS profile & traffic mapping, If you set your QoS profile to "Silver with 802.1p Tag of 3" & your wilreless clients'  EF marked traffic (ie WMM_UP of 6)  will translate into outer CAPWAP DSCP value of AF21 by AP. Same applicable to any video traffic from wireless clients (as it comes with WMM_UP of 4 or 5). But original packet's inner DSCP value remain as it is because of CAPWAP encapsulation from AP -> WLC. Due to this within wired network (at least from AP to WLC) you cannot differentiate Voice , Video packets as all having same DSCP value (AF21). Anyway in your case this won't matter as you do not do any prioratization of your traffic within your switch network.
    Just for curiosity why do not  you use qos on your switches ? is there any reason ?  How do you prioratize your voice traffic over any other type of traffic in your network ?
    I am running WLC 4402 with code 7.0.116. What is the software version you are running on your WLC ?
    When it comes to software version 7.4  code, cisco introduced "Application Visibilty & Control" feature where you can classify traffic at the WLC as you normally do in wired switches. This will allow reclassify, markdown, drop traffic according to traffic categories.
    HTH
    Rasika

  • Cisco 7600 MPLS and set Qos group

    Hi, i'm am trying to use to following class-maps and policy maps on a Cisco 7600. The same maps have been used on both 3700 series and 7200 series. However when i try to apply IP_TO_MPLS_OUT and MPLS_TO_IP_IN on the 7600 (with SUP32 and 48 port gigabit blade) i get a message on the console
    "set qos group" not supported.
    I used the QoS group to carry the MPLS EXP value (as label would is popped) and this works well.
    How can i get the QoS group to work on the 7600, if not is there a valid workaround?
    Many thanks for your help.
    policy-map IP_TO_MPLS_OUT
    class qosgrp5
    set mpls experimental topmost 5
    priority percent 10
    class qosgrp4
    bandwidth remaining percent 50
    set mpls experimental topmost 4
    class qosgrp2
    bandwidth remaining percent 20
    set mpls experimental topmost 2
    class class-default
    bandwidth remaining percent 30
    random-detect
    set mpls experimental topmost 1
    policy-map CE_OUT
    class qosgrp5
    set ip precedence 5
    class qosgrp4
    set ip precedence 4
    class qosgrp2
    set ip precedence 2
    policy-map MPLS_TO_IP_IN
    class MPLS_EXP5
    set qos-group 5
    class MPLS_EXP4
    set qos-group 4
    class MPLS_EXP2
    set qos-group 2

    Hi,
    I'm not aware that you can use qos groups on c7600 (LAN ports ?).
    For the MPLS_TO_IP direction you can use 'mpls propagate-cos' on the egress interface as workaround. This rewrites the egress IP ToS with the internal DSCP (which is inferred from the topmost MPLS label).
    For the IP_TO_MPLS direction you could just match on the original DSCP ?
    cheers,
    Stefan

  • What is the best way to trust DSCP values on 6509 interfaces?

    I have 6509's with 2 Ten-gig interfaces configured into a Port Channel (routed with IP addressing) - the IOS is 12.2(18)SXE3. I want to trust the DSCP values of packets traveling through the interfaces and have applied 'mls qos trust dscp' on both the physical Ten-gig interfaces as well as the L3 Port Channel interface.
    1.Is it necessary to have the statement on all the interfaces, or is just having it on the Port channel enough?
    Here is the config right now:
    interface Port-channel4
    description to 6509-Core-A P4 (T1/3, T2/3)
    ip address 164.xxx.xx.xx 255.255.255.252
    ip pim sparse-mode
    ip route-cache flow
    mls qos trust dscp
    interface TenGigabitEthernet1/1
    description to 6509-Core-A T1/3 (P4)
    no ip address
    ip route-cache flow
    mls qos trust dscp
    channel-group 4 mode desirable
    interface TenGigabitEthernet1/2
    description to 6509-Core-A T2/3 (P4)
    no ip address
    ip route-cache flow
    mls qos trust dscp
    channel-group 4 mode desirable
    Also, what command can I use to see the dscp counters? In the 3560/3750 catalyst line you can enter: 'sh mls qos int f0/1 statistics' and get a display of all the dscp/cos input/output packet counts, but I can't find a comparable command in the 6509.
    2. Is there one?

    I think you do this on the individual port interfaces, not the port-channel interface, becasue the queueing mechanisims associated with DSCP values are port based.
    By doing this, if you have policy maps you want to use, you attach them to the ports not the port-channel.
    For the command on 6509, you can use:
    sh mls qos ip gigabitEthernet 1/1
    Hope this helps and let me know how that works out.
    Gary

  • User defined function to set a default value of a column

    Hi All
    Can we use user defined function to set a default value of a column ??
    for example:
    create or replace  function test1  return number is
    begin
    return 10;
    end;
    create table testt
    (id  as test1,
      name varchar2(20));
    error:
    ORA-02000: missing ( keywordThanks
    Ashwani

    174313 wrote:
    MichaelS for showing example to use function in table ddl , otherwise i was thinking we cannot use function in table ddl as per error I received.That was an example of a virtual column.
    ORA-04044: procedure, function, package, or type is not allowed hereUsing PL/SQL code like that raises 2 basic problems. If that PL/SQL code for the calculating the column default breaks, what happens to the SQL insert statements against that table. These will need to fail as the table definition depends on the PL/SQL code. This is problematic as this dependency simply increases the complexity of the SQL object.
    The 2nd issue is performance. PL/SQL code needs to be executed by the PL/SQL engine. This means a context switch from the SQL engine to the PL/SQL engine in order to determine the default value for that column. Context switching is a performance overhead.
    So even if it was possible to use a PL/SQL function as parameter for the SQL default clause, I would not be that keen to use it.

  • Set default dscp on ingress, while doing policer markdown

    I'm using C3850, and want to set dscp AF21 for the first 100 mbps of input traffic on a L3 port ("no switchport"), and set AF11 for the remainder (any traffic >100mbps).  I am not trusting DSCP of ingress packets, but generally they are dscp 0.
    I see that I can use a 2-color policer, with "conform action transmit" and "exceed action set dscp table my-markdown".  Within that table, it looks like I can rewrite all matching traffic (>100mbps) to AF11 ("default 10", or "from 0 to 10"). 
    But I'm not sure how to set DSCP for the "conforming" traffic.

    can "set qos-group" be used for this?
    table-map set-af21
     default 18
    table-map set-af11
      default 10
    policy-map myMap
      class class-default
      police 100m exceed-action set-dscp-transmit dscp table set-af11
      set qos-group dscp table set-af21
    interface gi1/0/1
      service-policy input myMap
    ...would that first set all traffic received using table set-af21, then let the policer markdown traffic out of profile (>100mbps) to AF11?

  • Unable to set DFF context value

    Hi,
    i want to set DFF context value with a variable, so i tried first to set it with a constant.
    in the controller's PR
    super.processRequest(oapagecontext, oawebbean);
    // first, find the flexfield's handle
    OADescriptiveFlexBean oaDFF;
    oaDFF = (OADescriptiveFlexBean)oawebbean.findIndexedChildRecursive("DescFF");
    oapagecontext.writeDiagnostics(this,"oaDFF=>"+oaDFF ,1);
    // default the Attribute Category (DFF context)
    oaDFF.setFlexContext(oapagecontext,"QuietanzaErarioStato");
    oaDFF.processFlex(oapagecontext);
    but it doesn't take any effect, the context's pickilist remains blank.
    However i tried the same code with another DFF and it worked. i am wondering if there is some differences between the two DFF.
    Any help will be appreciated, it'quite urgent
    Thanx

    Hi,
    Please create a new region thru personalization before the region where u r DFF is present. Use re-order to take the new region before the DFF region.
    Set the controller to that new region and the code that you mentioned. This process will sets the context.
    Kindly refer the dev guide as i found the above solution from devguide it self.
    Thanks
    Raghava

  • Windows 7 64 bit Home Premium DSCP value 0x00

    I am trying to mark my traffic with DSCP values both with some built in options in the programs and with the Windows 7 Group Policy QOS options.
    I have looked around and found the two regedit items that need to be changed and have changed them.  Additionally rebooted the machine. I also verified that the interface had the QOS section marked.  
    Outside of that nothing is maintaining a tag when it leaves the interface.  On the far side all traffic that arrives at my router is 0x00.

    Hi,
    Have you tried this step in the registry.
    1. Go to HKLM\System\CurrentControlSet\Services\Tcpip\QoS. If "QoS" folder doesn't exist there - create it.
    2. Add a DWORD parameter named "Do not use NLA" and assign "1" as its value.
    3. Reboot.
    Meanwhile, please refer to the similar thread.
    Why is DSCP always 0 on Windows 7?
    http://ask.wireshark.org/questions/1188/why-is-dscp-always-0-on-windows-7
    Please note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.
    Hope this helps,
    Ada Liu
    TechNet Community Support

  • QoS - DSCP - Classifying the packets

    Hi,
    I have set up a practice lab in GNS3 for understanding "Classifying & Marking" DSCP values.  The topology is like this:
    (R2)---------f0/0(R1)f0/1----------(R3)
    R2 has two loopback interfaces with IP addresses 172.1.2.100/25 for loopback0 & 172.1.2.200/25 for loopback1
    R3 has tow loopback interfaces with IP addresses 172.1.3.100/25 for loopback0 & 172.1.3.200/25 for loopback1
    When Telnet Session is initiated from R2's 172.1.2.100 to R3's 172.1.3.100, R1 should mark the egress IP packet out of fa0/1 with DSCP value of 10(AF11).
    The truncated configuration is as follows:
    ip access-list extended MyTraffic
     permit ip 172.1.2.0 0.0.0.127 172.1.3.0 0.0.0.127
    class-map match-all test3
     match access-group name MyTraffic
     match protocol telnet
    policy-map p3
     class test3
      set ip dscp af11
    interface FastEthernet0/1
     ip address 10.1.3.1 255.255.255.128
     duplex auto
     speed auto
     service-policy output p3
    The configuration works all right, but when telnet session is initiated from R2's 172.1.2.200 to R3's 172.1.3.200, the egress IP Packet out of fa0/1
    is found with the DSCP value of 110000 (Class selector 6), where it should be 000000 (Best Effort Delivery) isn't it..???
    This is the first time I'm posting on forums, kindly help me in understanding this..!!

    Hi - this forum is for Cisco Modeling Labs. Please refer to the GNS3 forum for answers to those questions.

  • Setting an item value before print report in BI Publisher

    Hi,
    I am having an issue with setting a page item's value once a button (that prints a BI Publisher report) is pressed. The session state for the item is set, however because the page does not re-load no value appears in the item on the page.
    I am using a button as a page Item and using a Page Branch with the Branch Point set as On Submit: After Processing(After Computation, Validation, and Processing) with the Page set to 0 and the Request set to PRINT_REPORT=REPORT
    Is there any way to set the item value on the page before branching to the report?
    Your help is greatly appreciated.
    -Marsha

    Marsha,
    You can do that as follows:
    1- create a hidden text item (P20_date_hidden) with default value set to sysdate.
    2- for your button >> edit >> Buttom display attributes >> attributes >> type in : onFocus= "set_date();" (( note: am using onFocus because it takes places before onClick ))
    3- In your page >> edit >> HTML header >> type in :
    <script language="JavaScript" type="text/javascript">
    function set_date()
    v_date = $x('P20_DATE_HIDDEN').value;
    $x('P20_DATE_LETTER_SENT').value = v_date;
    </script>
    Hope this helps,
    Sam
    Please reward good answers by marking them correct or useful!

  • Unable to set the selected value for a ADF LOV

    Hi,
    I am developing an application using jdeveloper 10.1.3 and Struts.
    I have created a ADF LOV on my JSP Page as given below:
    <html:select property="lob" onchange="javascript:selectLOB(this.form)">
    <html:optionsCollection label="prompt" value="index" property="lob.displayData"/>
    </html:select>
    When i submit the form, i am able to get the value of the selected Value in the List.
    JUCtrlListBinding listBinding = (JUCtrlListBinding) formBean.get("Lob");
    Row r = (Row) listBinding.getSelectedValue();
    String SoLob = (String) r.getAttribute("LobLob");
    But i am unable to set the selected value back in the list when i return to the form again.
    I tried the following:
    int x = listBinding.getSelectedIndex();
    listBinding.setSelectedIndex(x);
    It would be really helpful if some one could let me know what needs to be done.
    Thanks,
    Subashini

    Gyan,
    I tried with the code you suggest , its trying to set the value of a field, but my requirement is to change the property for
    "Rendered" on the field so that based on search parameters we can hide result table column.
    After searching online, I modified the controller code as follows
    1.Created a new transient attribute (Testrender) with type "Boolean" and always updateable.
    2.changed the "Rendered" property value on the field I want to hide as ${oa.PoSearchVO1.Testrender}.
    3. Modified the controller code as follows :
            OAApplicationModule am = pageContext.getApplicationModule(webBean);
            OAViewObject testvo = (OAViewObject)am.findViewObject("PoSearchVO1");
            OADBTransaction txn = am.getOADBTransaction();
            if (testvo != null)
              OARow row = (OARow)testvo.first();
                if (a.equalsIgnoreCase("Approved"))
                     row.setAttribute("Testrender", Boolean.FALSE);
                else
                     row.setAttribute("Testrender", Boolean.TRUE);
            } But now when i run the page and populate the search field and click "Go" its hiding the field but throwing the following error and the search results are also bad.
    Its using only the value of one search parameter but not the second one .
    The search cannot be executed because the table has pending changes that would be lost. I think the vo is getting dirty when I update the transient attribute value. So I used txn.rollback ,then search is working fine but its not hiding the field.
    So can you please let me know how to proceed from here ?

Maybe you are looking for

  • About third party process

    hi friends, in third party order processing what is the need of creating purchase requisition, cant we create purchase order with out refrence to puchase requisition? Thanks and regards sudhakar

  • Float Video over web page

    Hello all - I would like to float a video over a web page, so that when the web pages is scrolled the video remains on the screen. I have contacted technical support and was told this involved Div tags, and CSS. Both of which I'm fairly familiar with

  • ADT error with comodo code signing certificate

    Hello, I'm trying to sign an AIR app with a Comodo code signing cert. - SHA-256 with RSA Encryption - Java 1.8 (same problem with 1.6) - AIR 15 (same problem with older versions) My command : java -jar -Xmx1024m /data/sdk/AIRSDK_Compiler15/lib/adt.ja

  • T-60 - Error: Blue Tooth Stack

    T-60 2623D6U with XP Professional. I was recently hit with the trojan from ... well wherever trojans come from other than USC.  Anyway, it forced me to reformat and reload.  Since I bought a few new programs and updated a few others there was a bit o

  • Where can I find Marketing Templates  Oracle Cloud Solutions and Services?

    Where can I find Marketing Templates  Oracle Cloud Solutions and Services?