VM experts, please resolve dispute re

Over in "Advanced Topics",
http://forum.java.sun.com/thread.jsp?forum=4&thread=167222
dnoyeB and I are having a spirited discussion about the mechanics of thread working copies vs. main mem's master copy. It's a very long discussion that spawned off from somebody else's simple question "When do you use volatile vs. synchronized." Our disagreement doesn't start until about message 30 or 40, but here are the main points of contention:
* dnoyeB says that a thread's working copy of a variable is by necessity on the stack, and that therefore, every time a method exits, that thread's working copies (or at least those used by the method) are flushed back to the master copy.
* I claim that this is not the case, and that one legal model is for a thread's working copy to be in a CPU's cache. I think that dnoyeB's model is unwieldy at best, and not doable at worst.
* I claim that a thread can directly access variables on the heap.
* dnoyeB claims that a thread cannot access the heap directly and must alway access variables via the stack.
Chapter 3 of the VM spec and Chapter 17 of the JLS are involved heavily in this discussion.
Please set us straight. :-)
Thanks,
Jeff

I am beginning to think we were both right and wrong.I disagree. See below for why.
1. the only thread local copies of variables are in
the operand stack, not in a frame. This is still the
stack so method ending does flush the stack var.I am using the terminology from the JVM spec and Venners' book. When I said operand stack and thread stack I meant essentially the same thing.
void func()
obj.x +=2;
obj.x +=2;
}according to the spec
if x is not volatile, after the first add, x is still
on the operand stack, and can be used directly from
the operand stack. If x were volatile, it would have
to be written back to main mem after the first write,
and reloaded for the second.You are completely wrong. You are equating memory used for holding the stack frames (which holds: local vars, operand stack, and frame data) with thread-local memory view. obj.x can live in this thread's local memory (which holds: class and instance fields, array elements that are used by methods in this thread; they live there in-between method calls, if you want).
What you seem to be saying is that if you have a method implemented as
int getX ()
    return obj.x;
}then [in your opinion] this method will automatically return the most-up-to-date, out-of-main memory value of obj.x even if x is not volatile?
If x were volatile, it would have
to be written back to main mem after the first write,
and reloaded for the second.In other words, you are saying that in the scenario
thread 1                                     thread 2
getX();                                      ...
...                                             obj.x = new_value
getX();                                      ...         the second getX() by thread 1 is guaranteed to see the new_value for obj.x even if it is not volatile, just because the operand value had to be popped off the operand stack in between the calls to getX()?
This is clearly incorrect. As has been stated several times already, you are incorrectly assuming that method boundaries act as memory barriers in the JMM sense. They do not.
You trying to imply that the acts of pushing and popping values to/from the operand stack are the actual events of reconciling thread-local memory with main memory. This is incorrect. If Java bytecode was designed around the usual register-only abstract architecture then where would you be? There would be no stack frames but there would still be a need for a memory reconciliation model across threads/CPUs.
Why can't you acknowledge than a thread-local memory can actually map onto the CPU's local memory and Java is the first common programming language that attempted to define a memory coherency model for a concurrent runtime? All other langugages silently assume that you inherit the memory model from the underlying hardware.
Vlad.

Similar Messages

  • PLEASE RESOLVE THE MIRO ERROR

    Hi gurus,
    please resolve the problem urgent.
    while doing MIRO Iam getting the following error.
    after given PO number in MIRO I getting the following error. please how to resolve the problem.
    Error in account determination: table T030K key ASHA VST V0
    Message no. FF709
    Diagnosis
    In the chart of accounts to be posted to, no accounts are defined for the tax code you used.
    Procedure
    Contact your system administrator.
    Define the accounts to which a tax posting is to be made with the tax code entered in Customizing for taxes on sales/purchases.
    To do this, choose Maintain entries (F5).
    where i can determin the accounts, which accounts will be effect.
    Thank you & Regards
    Anil

    Dear Anil,
    Go to the transaction code FTXP. Give the country code and then the tax code.
    Now on the top, there would be a tab for the "Accounts". Click on it and for the chart of accounts, give the GL accounts.
    Alternatively, go to OB40, for the accounting key V0, give the GL accounts.
    Assign points if useful.
    Regards
    Venkatesh

  • MIRO error please resolve the problem

    Hi gurus,
    please resolve the problem urgent.
    while doing MIRO Iam getting the following error.
    after given PO number in MIRO I getting the following error. please how to resolve the problem.
    Error in account determination: table T030K key ASHA VST V0
    Message no. FF709
    Diagnosis
    In the chart of accounts to be posted to, no accounts are defined for the tax code you used.
    Procedure
    Contact your system administrator.
    Define the accounts to which a tax posting is to be made with the tax code entered in Customizing for taxes on sales/purchases.
    To do this, choose Maintain entries (F5).
    where i can determin the accounts, which accounts will be effect.
    Thank you & Regards
    Anil

    Hi,
    You have to maintain the GL accounts for the correct combination of country, tax code, chart of accounts etc in the tcode FTXP for the transaction VST.
    I hope either the transaction VST or the tax code V0 was newly added
    You can get the correct GL account by askign the person who has initiated this change. May be your FI team member also can help.
    T030K is the table which gets updated while you maintain teh entries through FTXP tcode.
    Hope this helps you

  • Is this BUG or Feature of APEX 4.0.1 - Any expert please help to answer

    Try this to stimulate the BUG or Feature
    - Development -
    1. Create Basic Master Detail with tabular form
    2. Create a basic LOV and display NULL -> RETURN NULL
    - Run -
    1. Run the Page click "ADD ROW"
    2. Do not enter any data into the tabular
    3. Click on Apply Changes
    Apex smart enough to know user do not want to add anything very nice....
    now... observe this
    - Development -
    1. Modify the LOV, remove the display NULL, so it will show first value of the LOV
    - Run -
    1. Run the Page click "ADD ROW"
    2. Do not enter any data into the tabular
    3. Click on Apply Changes
    Apex don't bother to test all validations straight to GIGO and end user see those ORA-.
    I have a page that the tabular form has a default value (not LOV but default value) the validation is not working, GIGO....
    Any expert please explain is this suppose how Apex work? or do we need to handle those default value.
    I try to debug the page with good one and bad one, I think I still have a lot to learn I don't understand the debug message. I guess is something about Branching....
    Siere

    Hi,
    Unfortunately there isn't really much that could be done to work around this issue in 4.0.x. The validation logic treats these new rows as not having been touched by the user, hence they are ignored. But the DML (update/insert) logic thinks the data did change due to that default value, and thus attempts an insert for the new row. There might be a way to trick APEX into doing the right thing with some JavaScript, but I would advice against that, considering that this might break after a future upgrade.
    Regards,
    Marc

  • ONCE I CHAT WITH APPLE EXPERT TO RESOLVE MY PROBLEM BUT NOW I WAS UNABLE TO FIND FROM WHERE TO START CHAT. KINDLY TELL ME HOW I CAN CHAT WITH APPLE EXPERT

    once i chat an apple expert to resolve my issue. but now i am unable to find the place on apple website from where i start chat.kindle tell me from where i can find that chat section..

    This is one route.   Apple - Support - Contact Apple Support    But I am wondering if your previous chat was within the 90 days allowed in the guarantee period ... a different situation entirely to what you now want.   Why not Google Kindle to see if your interests appear there.

  • TS3694 i have i phone 3g ios 4.2.1 so i wana to restore so now it is showing an error 1015 so please resolve my problem

    i have i phone 3g ios 4.2.1 so i wana to restore so now it is showing an error 1015 so please resolve my problem

    Shiv lal wrote:
    i have i phone 3g ios 4.2.1 ..  now it is showing an error 1015
    Unauthorized modification of iOS  >  http://support.apple.com/kb/HT3743
    ERROR 1015...
    This Error Code is indicative of the Device being jailbroken / Hacked...
    Sorry... But...
    The discussion of Jailbroken Devices is against the Terms of Use of this Forum.
    You will need to look elsewhere.

  • BDC - table control - experts please help

    Hi experts,
    Please help. I am in need of your help.
    I am working with BDC and I have a table control in one of the screen. Table control has a check box in the first column. While recording how I entered the data is : I select the check box in a row, enter two values in next two columns of that row and then hit enter then the other columns in that row turn from grey to white (initially these columns are greyed out).
    NOw in BDC when I run my session in foreground, I am able to check(select) the check box and enter the values in next two columns and then I have a Enter OKCODE. But when I hit enter it is not able to recognize the row and its unable to turn the greyed out columns in that particular row to white.
    Is there a way to specify in my program that I am hitting enter in one particular row.
    Please help. Let me know if something is not clear. Very urgent . Pleasee respond. Thanks

    Hi Rich,
    Thanks for the replies. I will try that. I got one more doubt. While manually creating the recipes using C201, there is a screen Recipe header. When I record this transaction, I see a different screen for the Recipe header. Fro example the screen numbers are like 4210(manual) and 4211(recording).
    But my problem is there are two fields which are missing in the screen which I am getting while recording C201. These two fields are present on the screen for manual creation. I need to enter those two fields while I record. But how can I do this.
    Please help.

  • SQL experts please help for a query

    I have following table1.
    What query can give the result as given below, SQL experts please help on this.
    TABLE1
    Event DATETIME
    in 2/JAN/2010
    out 2/JAN/2010
    in 13/JAN/2010
    out 13/JAN/2010
    in 5/JAN/2010
    out 5/JAN/2010
    RESULT REQUIRED FROM THE SQL QUERY
    COL1_IN COL2_OUT
    2/JAN/2010 2/JAN/2010
    13/JAN/2010 13/JAN/2010
    5/JAN/2010 5/JAN/2010

    I tried to help, but this puzzles me.
    Why is this not returning pre-selected set of rows, why it's doing some merge join cartezian ?
    SQL> select * from v$version;
    BANNER
    Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Prod
    PL/SQL Release 10.2.0.4.0 - Production
    CORE    10.2.0.4.0      Production
    TNS for Linux: Version 10.2.0.4.0 - Production
    NLSRTL Version 10.2.0.4.0 - Production
    SQL> select * from table1;
    EVENT      DATETIME
    in         2/JAN/2010
    out        2/JAN/2010
    in         13/JAN/2010
    out        13/JAN/2010
    in         5/JAN/2010
    out        5/JAN/2010
    6 rows selected.
    SQL> explain plan for
      2  with a as
    (select datetime from table1 where event='in'),
    b as
    (select datetime from table1 where event='out')
    select  a.datetime COL1_IN ,b.datetime COL2_OUT from a,b ;
    Explained.
    SQL> set wrap off
    SQL> set linesize 200
    SQL> select * from table(dbms_xplan.display);
    PLAN_TABLE_OUTPUT
    Plan hash value: 185132177
    | Id  | Operation            | Name   | Rows  | Bytes | Cost (%CPU)| Time     |
    |   0 | SELECT STATEMENT     |        |     9 |   288 |     8   (0)| 00:00:01 |
    |   1 |  MERGE JOIN CARTESIAN|        |     9 |   288 |     8   (0)| 00:00:01 |
    |*  2 |   TABLE ACCESS FULL  | TABLE1 |     3 |    48 |     3   (0)| 00:00:01 |
    |   3 |   BUFFER SORT        |        |     3 |    48 |     5   (0)| 00:00:01 |
    |*  4 |    TABLE ACCESS FULL | TABLE1 |     3 |    48 |     2   (0)| 00:00:01 |
    PLAN_TABLE_OUTPUT
    Predicate Information (identified by operation id):
       2 - filter("EVENT"='in')
       4 - filter("EVENT"='out')
    Note
       - dynamic sampling used for this statement
    21 rows selected.
    SQL> with a as
    (select datetime from table1 where event='in'),
    b as
    (select datetime from table1 where event='out')
    select  a.datetime COL1_IN ,b.datetime COL2_OUT from a,b ;
    COL1_IN         COL2_OUT
    2/JAN/2010      2/JAN/2010
    2/JAN/2010      13/JAN/2010
    2/JAN/2010      5/JAN/2010
    13/JAN/2010     2/JAN/2010
    13/JAN/2010     13/JAN/2010
    13/JAN/2010     5/JAN/2010
    5/JAN/2010      2/JAN/2010
    5/JAN/2010      13/JAN/2010
    5/JAN/2010      5/JAN/2010
    9 rows selected.
    SQL>

  • I bought an iphone 5 from one of my friends and unluckily I had yet lost his contact, I had update this iphone to IOs 7 and now it's be locked at iCloud because there was no password . Actually I dont know what I must do for its. Experts, please help me!

    I bought an iphone 5 from one of my friends and unluckily I had yet lost his contact, I had update this iphone to IOs 7 and now it's be locked at iCloud because there was no password . Actually I dont know what I must do for its. Experts, please help me!

    The friend who sold it to you needed to clear his Apple ID off the phone before he sold it to you. Of course if it wasn't his phone in the first place then he could not do so. He is your friend but you don't know where he is?
    There is nothing that will help you short of getting the password for the Apple ID from your friend. If you cannot obtain that there is no workaround.

  • Please resolve ASAP

    Hello.
    I was billed twice for my SUBSCRIPTION to Creative Cloud Student. I am now paying for two subscription and I only want one on my current account (obviously). Please resolve this ASAP, before the first month is over and I am forced to pay this twice.
    Thank you. -Kyle

    I doubt posting here will resolve your issue, why don't you phone Adobe?
    https://helpx.adobe.com/creative-cloud/team/creative-cloud-teams.html

  • Routing Experts please help with below LAN routing issue with NAT

    Hello Experts,
    I have a weird situation and requirement.
    The existing setup is -
    We have email/ticketing server hosted in the LAN which is reachable on the publicly NAT'ed IP with respective port numbers of 89 & 443. We have LAN & servers on the same subnet. The internet is with public DHCP IP assigned by ISP (/29). We use linksys router GUI for NAT settings (attached).We are using the same public IP for the server NAT & user NAT.
    We tried to refresh our network by separating the subnets for LAN users & servers. We used the Cisco 3845 router to create sub-interfaces in the LAN and configure respective subnets. Now both user subnet and server subnet are connecting to the Internet with same public IP (static NAT for servers & dynamic for users). We can connect to the server IP from the Internet and it resolves fine. However user LAN subnet cannot connect to the server if we try the URL. Users can access the Internet fine.
    Please find attached short diagram and below configuration and please give your inputs to solve this.
    Cisco 3845 router
    access-list 1 permit 10.155.60.0 0.0.0.255
    access-list 2 permit 10.155.61.0 0.0.0.255
    access-list 3 permit 10.155.62.0 0.0.0.255
    ip nat inside source list 1 int g0/0 overload
    ip nat inside source list 2 int g0/0 overload
    ip nat inside source list 3 int g0/0 overload
    int g0/0
    ip add 8.8.8.8 255.255.255.248
    ip nat outside
    no shut
    int g0/1
    description Trunk-to-Switch
    no shut
    int g0/1.60
    description User vlan
    ip add 10.155.60.1 255.255.255.0
    encapsulation dot1q 60
    ip nat inside
    int g0/1.62
    description Server vlan
    ip add 10.155.62.1 255.255.255.0
    encapsulation dot1q 62
    ip nat inside
    exit
    aaa new-model
    aaa authentication login default local
    aaa authentication login vpn_xauth_ml_1 local
    aaa authentication login sslvpn local
    aaa authorization network vpn_group_ml_1 local
    aaa session-id common
    acl 120
    max-users 10
    exit
    !access-list 120 remark ==[Cisco VPN Users]==
    access-list 120 permit ip any host 192.168.0.10
    access-list 120 permit ip any host 192.168.0.11
    access-list 120 permit ip any host 192.168.0.12
    access-list 120 permit ip any host 192.168.0.13
    access-list 120 permit ip any host 192.168.0.14
    access-list 120 permit ip any host 192.168.0.15
    access-list 120 permit ip any host 192.168.0.16
    access-list 120 permit ip any host 192.168.0.17
    access-list 120 permit ip any host 192.168.0.18
    access-list 120 permit ip any host 192.168.0.19
    no access-list 100
    access-list 100 remark [Deny NAT for VPN Clients]=-
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.10
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.11
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.12
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.13
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.14
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.15
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.16
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.17
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.18
    access-list 100 deny ip 192.168.0.0 0.0.0.255 host 192.168.0.19
    access-list 100 remark
    access-list 100 remark -=[Internet NAT Service]=-
    access-list 100 permit ip 192.168.0.0 0.0.0.255 any
    exit
    ip nat inside source static tcp 10.155.62.55 21 8.8.8.8 21
    ip nat inside source static tcp 10.155.62.55 88 8.8.8.8 88
    ip nat inside source static udp 10.155.62.55 88 8.8.8.8 88
    ip nat inside source static tcp 10.155.62.84 3389 8.8.8.8 3389
    ip nat inside source static udp 10.155.62.84 3389 8.8.8.8 3389
    ip nat inside source static tcp 10.155.62.98 80 8.8.8.8 80
    ip nat inside source static udp 10.155.62.98 80 8.8.8.8 80
    ip nat inside source static tcp 10.155.62.98 443 8.8.8.8 443
    ip nat inside source static udp 10.155.62.98 443 8.8.8.8 443
    ip nat inside source static tcp 10.155.62.98 25 8.8.8.8 25
    ip nat inside source static udp 10.155.62.98 25 8.8.8.8 25
    ip nat inside source static tcp 10.155.62.84 8080 8.8.8.8 89
    ip nat inside source static udp 10.155.62.84 8080 8.8.8.8 89
    ip nat inside source static tcp 10.155.62.84 9005 8.8.8.8 9005
    ip nat inside source static udp 10.155.62.84 9005 8.8.8.8 9005
    ip nat inside source static tcp 10.155.62.84 135 8.8.8.8 135
    ip nat inside source static udp 10.155.62.84 135 8.8.8.8 135
    ip nat inside source static tcp 10.155.62.84 139 8.8.8.8 139
    ip nat inside source static udp 10.155.62.84 139 8.8.8.8 139
    ip nat inside source static tcp 10.155.62.84 445 8.8.8.8 445
    ip nat inside source static udp 10.155.62.84 445 8.8.8.8 445
    ip nat inside source static tcp 10.155.62.84 90 8.8.8.8 465
    ip nat inside source static udp 10.155.62.84 90 8.8.8.8 465
    ip nat inside source static tcp 10.155.62.143 3381 8.8.8.8 3381
    ip nat inside source static udp 10.155.62.143 3381 8.8.8.8 3381
    ip nat inside source static tcp 10.155.62.46 8081 8.8.8.8 91
    ip nat inside source static udp 10.155.62.46 8081 8.8.8.8 91
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:/cme-gui-7.1.0.1
    file privilege 0
    telephony-service
    dn-webedit
    time-webedit
    transport input ssh
    line con 0
    line vty 0 15
    login local
    ntp server ntp.first2know.net
    clock timezone gmt 0
    clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 2:00
    ntp update-calendar
    ntp master
    =========================================================================================================================================
    Cisco 3750 Config;
    vlan 60
    name User
    vlan 61
    name Voice
    vlan 62
    name Server
    exit
    interface g1/0/1
    description Trunk-to-Router
    switchport trunk encapsulation dot1q
    switchport mode trunk
    spanning-tree portfast trunk
    interface vlan 60
    description User Vlan
    ip add 10.155.60.2 255.255.255.0
    interface vlan 61
    description Voice Vlan
    ip add 10.155.61.2 255.255.255.0
    interface vlan 62
    description Server Vlan
    ip add 10.155.62.2 255.255.255.0
    service dhcp
    ip dhcp pool Users
    network 10.155.60.0 255.255.255.0
    default-router 10.155.60.1
    dns server 4.2.2.2
    ip dhcp pool Voice
    network 10.155.61.0 255.255.255.0
    dns server 4.2.2.2
    exit
    ip dhcp excluded-address 10.155.60.1 10.155.60.2 10.155.60.3
    ip dhcp excluded-address 10.155.61.1 10.155.61.2
    interface range g1/0/2 - 1/0/21
    switchport mode access
    switchport access vlan 60
    switchport access vlan 61
    exit
    exit
    interface range g1/0/22 - 1/0/26
    switchport mode access
    switchport access vlan 62
    exit
    Thanks,
    Deepak

    One more thing I should clarify the route I am putting into the 10.10.1.9 server is
    route add 10.1.6.0 mask 255.255.255.0 10.10.1.250 which tells the server to bypass the ASA and go directly to the ISP router.(then i can successfully tracert everything).  The big question here is how to make the inside ASA connection 10.10.1.1 to force all traffic to 10.10.1.250.
    Thanks in advance.

  • Dear experts please help me~

    Hello,
    i bought a blackberry 9220 after a week it broke.. i usually put it in my pocket. one time i want to check my bbm's but somehow i can't turn it on, i tried charging it but it only shows a battery with a red "X" mark on it.. i tried charging it for hours but no use, i used my friends battery no use, my friend used my battery but it worked.. can someone please help me with my problem ASAP! thank you!

    Hi gerardedwards4
    Welcome to BlackBerry Support Forums
    I am not the Expert   Our expert will look into your post , but for the time can you tell what happen when you connect your device to a PC ? Do you hear any sound for anything !
    let us know.
    Click " Like " if you want to Thank someone.
    If Problem Resolves mark the post(s) as " Solution ", so that other can make use of it.

  • Hello Experts Please help me to solve this problem.

    Hello Experts,
    I am getting a problem while installing the SOLUTION MANAGER 4.0.
    in step 17/45 IMPORT ABAP :
    the problem is :
    ERROR 2008-04-29 03:10:28.110
    CJS-30023  Process call '/usr/sap/SLM/SYS/exe/run/R3load -testconnect' exits with error code 2. For details see log file(s) R3load.exe.log.
    when i saw R3load.exe.log file it has the following contain :
    sapparam: sapargv( argc, argv) has not been called.
    sapparam(1c): No Profile used.
    sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
    /usr/sap/SLM/SYS/exe/run/R3load: START OF LOG: 20080428095833
    /usr/sap/SLM/SYS/exe/run/R3load: sccsid @(#) $Id: //bas/700_REL/src/R3ld/R3load/R3ldmain.c#13 $ SAP
    /usr/sap/SLM/SYS/exe/run/R3load: version R7.00/V1.4 [UNICODE]
    Compiled Jul 14 2007 02:19:03
    /usr/sap/SLM/SYS/exe/run/R3load -testconnect
    DbSl Trace: OCI-call 'OCIServerAttach' failed with rc=12505
    DbSl Trace: CONNECT failed with sql error '12505'
    DbSl Trace: OCI-call 'OCIServerAttach' failed with rc=12505
    DbSl Trace: CONNECT failed with sql error '12505'
    (DB) ERROR: db_connect rc = 256
    DbSl Trace: OCI-call 'OCIServerAttach' failed with rc=12505
    DbSl Trace: CONNECT failed with sql error '12505'
    DbSl Trace: OCI-call 'OCIServerAttach' failed with rc=12505
    DbSl Trace: CONNECT failed with sql error '12505'
    (DB) ERROR: DbSlErrorMsg rc = 99
    /usr/sap/SLM/SYS/exe/run/R3load: job finished with 1 error(s)
    /usr/sap/SLM/SYS/exe/run/R3load: END OF LOG: 20080428095834
    Please can any body help me to solve this problem.
    waiting for fast response, as my installtion is pending due to this problem.
    have a nice day.
    Regards,
    Shivendra.

    Hi,
    The following should be verified:
    (1) check what DB instances the listener currently is aware of.  This can be done with the command 'lsnrctl services'.
    (in case you listener does not have the default name LISTENER, then use 'lsnrctl services <listener name>' )
    (2) Perhaps there is an issue with the dynamic instance registration, even though the error code is different, you should nevertheless check the points from note #563574.
    (3) Verfiy the value of the parameter local_listener (see mentioned note). Since you have changed the listener, the parameter might still be wrong.
    In case local_listener is correcly set you should give the command
      ALTER SYSTEM REGISTER;
    a try.
    Best Regards,
    Michael

  • Urgent Help is needed : Experts please help

    Does modification of Transfer rule and update rule require data deletion from all the dependent data targets?
    Hi Experts,
    Two new key figures have been added in data source and subsequently in transfer rules, updated rules, ODS and cubes there in data flow.
    The changes are supposed to move in production on this weekend. I am afraid; does this activity require data deletion from the data targets before moving the transports?
    With out deletion of the data can these transports be moved in prod?
    Please reply with your valuable advice.
    Points will be rewarded.
    Thanks,
    BW USER

    hi,
    hope u might have to do changes in the cube and ods also rite?
    and you need to have data for the added key figure in the cube/ods for the already existing records in the cube/ods.for this you copy content in other cube/ods and do delete and reload the data to the new changed cube/ods.
    Ramesh

  • TS2446 Hi, please resolve my problem with my apple ID

    Hi
    I just redeem itunes gift card $100 and purchasing gems on game Clash of Clan, but i received alert can't purchased and contact support
    Please resond me soon
    Thank you so much for help

    Welcome to the Apple Community.
    Did you follow the instructions in the message and contact Apple, which you can do through iTunes Store Support. If Apple have asked you to contact them, then the issue can only be resolved by them.

Maybe you are looking for

  • Why the message " ... not a valid PDF document ..."?

    Am using PSE 9 on a Mac OS 10.7 when suddenly an error message started appearing 3 (and more) times in a row every time I tried to edit a photo.  (I had been editing 100's of photos with no problem.)  Now, even if I just open up Elements with no phot

  • Goods Issue to Subcontractor at MAP or Price of Purchase which ever is high

    Dear Sir/Madam, The scenario is like this : I have raised a Purchase Order  for a material (say ABC) to be kept in stock and to be issued as and when requisitioned by the user. Quantity of PO 100 nos. Unit Price : Rs. 10 per no. and Total Price of PO

  • Photo resolution & zooming

    Getting ready to get myself an ipod photo & I was wondering... 1)When I copy my pics to the ipod do they retain their original resolution or are they reduced to a pre-set (lower) resolution?? 2)When I connect the ipod to my tv to view them can I zoom

  • Bridge configuration at ISR 4000

    Hi. I´m configuring a new router ISR 4000, but i cannot find all needed commands for bridge feature. Please your help if somebody know the equivalent commands for ISR 4000 series. Thanks in advance. Step by Step Bridge Group Virtual Interface (BVI) C

  • Exits in authorization checking (FI module)

    Hello all, I am using SAP R/3 version 4.7 and FI module. I would like to know are there any exit can be called automatically when performing authorization checking. I need to create some roles to control to authority for different users from differen