Why 9 connections are automatically created per one jms topic?

Why 9 connections are automatically created per one jms topic?
Is it possible for one topic to have one connection, rather nine connecions?
If so, any drag concerning having one connection of one topic?
Let me know asap, it would be really appreciated.
<code>
public void connectJMS() {
try {
if (RTConst.getInstance().getConnectMode() != RTConst.NOTCONNECT) {
targetTCF = ServerDelegate.getTopicFactoryComm();
targetT = ServerDelegate.getTopicNameComm();
connection = targetTCF.createTopicConnection();
session = connection.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
topicSubscriber = session.createSubscriber(targetT);
topicSubscriber.setMessageListener(this);
connection.start();
System.out.println("[CommJMSReceiver] Common Topic Connection successed");
} catch (Exception ex) {
System.out.println("[CommJMSReceiver] Common Topic Connection failed");
ex.printStackTrace();
</code>
Message was edited by:
PaulSheldonII_Screen

Why 9 connections are automatically created per one jms topic?
Is it possible for one topic to have one connection, rather nine connecions?
If so, any drag concerning having one connection of one topic?
Let me know asap, it would be really appreciated.
<code>
public void connectJMS() {
try {
if (RTConst.getInstance().getConnectMode() != RTConst.NOTCONNECT) {
targetTCF = ServerDelegate.getTopicFactoryComm();
targetT = ServerDelegate.getTopicNameComm();
connection = targetTCF.createTopicConnection();
session = connection.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
topicSubscriber = session.createSubscriber(targetT);
topicSubscriber.setMessageListener(this);
connection.start();
System.out.println("[CommJMSReceiver] Common Topic Connection successed");
} catch (Exception ex) {
System.out.println("[CommJMSReceiver] Common Topic Connection failed");
ex.printStackTrace();
</code>
Message was edited by:
PaulSheldonII_Screen

Similar Messages

  • Photos are automatically rated with one star upon import

    Hi. I've noticed recently that everytime I connect my camera and import my photos into LR that all of the photos are automatically rated with one star. Even when I go to select all, set rating to zero, nothing changes. What am I missing here and how does all of my photos automatically get rated upon import? It's annoying that I have unrate each and every single photo. I have looked all over and I can't find anything that mentions photos being rated automatically. Any advice is greatly appreciated.

    Check your import presets to see if one is selected that contains the one star assignment.

  • Why there are overloaded create methods in Statful bean?

    Hi all,
    I have a question ...!
    Why there are overloaded create methods for Statefule beans? and why not for Stateless bean?
    because any way these create methods are for giving referneces of EJB objects.hence, what is use of overloaded methods in stateful bean?
    Thanks in advance.
    Regards,
    Rahul

    Hi Rahul,
    Each stateful session bean is tied to a particular client. That means whatever state is passed in during create() is guaranteed
    to be available on subsequent invocations. Allowing multiple create methods is a convenience.
    For stateless session beans there is no prescribed relationship between the caller and which bean instance is used to handle
    an invocation. It wouldn't make sense to allow creation parameters since there would be no guarantee that a subsequent
    invocation is handled by an instance containing that particular initialization state.
    All of this only applies to the EJB 2.1 and earlier API. Starting in EJB 3.0, there are no longer explicit create() methods.
    As you've seen there isn't any benefit to having them in the stateless case. For stateful session beans in EJB 3.0, the
    developer can perform initialization by just declaring a particular business method and calling that after first acquiring a
    new stateful session bean reference.
    --ken                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

  • Why objects are  dynamically created in java

    Why objects are dynamically created in java even if dynamically created object requires more space & more memory references as compared to static object?

    I don't even know where to start...
    KAMAL.MUKI wrote:
    Why objects are dynamically created in javaWhat is the alternative?
    even if dynamically created object requires more space & more memory referencesCan you prove that?
    as compared to static object?Can you define "static object"?
    I vote "troll".

  • When recording a midi track, why is it automatically creating a loop whenever I stop?

    When recording a midi track, why is it automatically creating a loop whenever I stop?
    I am using Logic Pro 9 on a MacBook Pro and Yosemite 10.10.1

    Hi
    Probably because you have the MIDI Thru parameters set to loop?
    Click in the background of the Arrange window, and in the Region Inspector (MIDI THRU) deselect 'Loop'
    CCT

  • Why my iPhone automatically create a WiFi Ad Hoc ?

    Why my iPhone automatically create a WiFi Ad Hoc with Free Public WiFi or with the last SSID I have been using ?
    Is it possible to disable this feature , if it's really a feature ?
    JP

    FaceTime calls can only be done over WiFi, that's why.

  • Why 2BDOCS are getting created for sending Sold to Party to ECC.

    Hi,
    I have a question, when BP (Sold to) gets create in CRM & replicates in successfully ECC.When I see Tran SMW01, I found two bdocs are getting created for same Sold to. Why this is happening!! How I can remove the another Bdoc type (VEND_MAIN).
    Please suggest.

    Hello Developer,
    Yes, I've checked the combinations of webshop(In Shopadmin) and Product Catalog.(Sales Area) 
    All of them are compatible.
    Hey DJ,
    When you say: u201Cthe first entry maintained in the USAPPLREF tableu201Du2026.in our case, there are 2 entries for my user (PPELA3). The first one is for object type BUS1006001 and object key nr° 23263-my contact person, linked to sold-to nr° 1000003), which is the employee that I 've created in the ISAUSERADMIN.
    The second entry is with object type KNA1 with object key nr° 1000003 (which is the sold-to).
    Those are the only entries for my user in this table.
    Does this sequence have the influence described by you? Is that what you want to say?
    Other point: Does the REFERENCE CUSTOMER is important for the B2B scenario? (Our case) Since I thought it was important just for B2C scenarios, It was the same number in SHOPADMIN Webshop creation.
    In the meantime, I will create a new reference customer and change the webshop parameters.
    Thanks for your inputs.
    Regards,
    Paulo Pela

  • Why is LR automatically creating a "test" subfolder

    When I import images to a folder that already exists or I create a new folder, LR automatically creates a "test" subfolder with the same images in it. If I delete the "test" folder it also deletes the folder that I want to keep

    Hi
    Probably because you have the MIDI Thru parameters set to loop?
    Click in the background of the Arrange window, and in the Region Inspector (MIDI THRU) deselect 'Loop'
    CCT

  • Why is itunes automatically creating playlists!!!! Really annoying

    I just got gifted an album and downloaded - itunes created an automatic playlist - which is totally uncessary - anyone know who to turn this off! Happens when I get something from itunes store.

    Hi Katy,
    Could you please, give us more information about your problem? What's the name of this podcast automatically created by iTunes? Is it named "Purchased"?
    Thanks

  • New events in iCal are automatically created with an Email alert

    How do I change the default alert method?

    Thanks Barney. To answer your first idea, these aren't alerts of the "alert me 15 minutes before the start of the event" type. Subscribers can switch those off by selecting "Ignore Alerts" in the calendar's Info pane:
    My problem is that email alerts are being raised after any and all activity in my calendar:
    If I create an event, subscribers receive an immediate email (like the one below)
    If I change the title of an event (i.e. 100% of the time), subscribers receive another an immediate email. This clearly wrong behaviour makes me wonder if we've encountered a bug.
    If I edit an event, subscribers receive an immediate email.
    If I delete an event, subscribers receive an immediate email.
    Secondly, these messages are apparently coming from iCloud. Here's what the subscriber sees when I create an event (I created this without editing the title, hence "New Event"):
    I deleted my calendar from my wife's iCal calendar list and added it again. No change. I created a new calendar, and subscribed her to it, no change. Oh, and I am subscribed to her calendar, but I receive no email alerts (which is what we want).
    She has an iPhone but I can't find any setting there that demands an email update for all calendar activity.
    Finally, I'd add that it hasn't always been like this. These alerts only appeared recently.

  • Why slicer are automatically converted to Filter in Power BI apps?

    I have Excel 2013 Power Pivot chars and I have added slicers.
    Slicers looks good in Excel and in SharePoint online, but slicers are automally converted as Filters in Power BI apps on workstation and Tablet.
    How to add slicer correctly to Power Pivot charts so that slicer works in Power BI apps?
    Kenny_I

    Kenny,
    Is this still an issue?
    Thanks!
    Ed Price, Power BI & SQL Server Customer Program Manager (Blog,
    Small Basic,
    Wiki Ninjas,
    Wiki)
    Answer an interesting question?
    Create a wiki article about it!

  • Why packets are being translated by one route-map and not the other?

    Hi,
    I have 2 NAT rules, each with a route-map to determine which packets are translated. What I don't understand is how to control which NAT rule is applied first..?
    In my config, the first of the following rules is applied first, and then the other. I would like to have it the other way round, the second being applied first, and the first being applied second.
    ip nat inside source route-map NAT_INTERNET_ACCESS_RMAP interface GigabitEthernet0/1 overload
    ip nat inside source static 172.16.101.1 10.10.11.1 route-map NAT_RADIANZ_PIXACCESS_RMAP
    The reason why I want it this way round is because the first rule NAT's almost everything so that I can access the Internet. The second rule NAT's specific traffic to a different address.
    If I want traffic to be NATTED according to the second rule, I have to deny traffic in the first associated ACL, and permit it in the second ACL. That means I basically have to configure each ACL each time I want packets to be matched by the second NAT rule - there must be a better way of doing it!!!
    Any help would be most appreciated.
    Many thanks,
    Michael.

    Hello, here's the basic (shortened list). If I want packets to be matched by NAT_RADIANZ_PIXACCESS_ACL I have to put a deny in NAT_INTERNET_ACCESS_ACL. If I could make sure that the first list is used first, and then anything left over compared against the second, then it would make life/editing much easier...
    Cheers,
    Michael
    ip nat inside source route-map NAT_INTERNET_ACCESS_RMAP interface GigabitEthernet0/1 overload
    ip nat inside source static udp 10.10.11.1 500 10.10.11.1 500 extendable
    ip nat inside source static udp 10.10.11.1 4500 10.10.11.1 4500 extendable
    ip nat inside source static 172.16.101.1 10.10.11.1 route-map NAT_RADIANZ_PIXACCESS_RMAP
    ip access-list extended NAT_INTERNET_ACCESS_ACL
    remark Traffic to Branch A (over VPN)
    deny ip 172.16.101.0 0.0.0.255 192.168.1.0 0.0.0.255
    remark Traffic to Branch B (over VPN)
    deny ip 172.16.101.0 0.0.0.255 172.16.0.0 0.0.0.255
    deny ip 172.16.101.0 0.0.0.255 172.16.1.0 0.0.0.255
    deny ip 172.16.101.0 0.0.0.255 172.16.2.0 0.0.0.255
    deny ip 172.16.101.0 0.0.0.255 172.16.3.0 0.0.0.255
    remark Traffic to Cust A (over VPN)
    deny ip host 172.16.101.1 host 192.168.0.1
    deny ip host 172.16.101.2 host 192.168.0.1
    remark Traffic to Cust B (over VPN)
    deny ip host 172.16.101.1 host 192.168.0.2
    deny ip host 172.16.101.2 host 192.168.0.2
    remark Traffic to Cust C (over Radianz VPN)
    deny ip host 172.16.101.1 host 192.168.0.3
    deny ip host 172.16.101.2 host 192.168.0.3
    remark Traffic to Cust D (over Radianz VPN)
    deny ip host 172.16.101.1 host 192.168.0.4
    deny ip host 172.16.101.2 host 192.168.0.4
    permit ip any any
    ip access-list extended NAT_RADIANZ_PIXACCESS_ACL
    remark Manangement Traffic to Cust C
    permit icmp host 172.16.101.1 host xxx.xxx.xxx.xxx
    permit icmp host 172.16.101.2 host xxx.xxx.xxx.xxx
    permit tcp host 172.16.101.1 host xxx.xxx.xxx.xxx eq 22
    permit tcp host 172.16.101.2 host xxx.xxx.xxx.xxx eq 22
    remark Manangement Traffic to Cust D
    permit icmp host 172.16.101.1 host xxx.xxx.xxx.xxx
    permit icmp host 172.16.101.2 host xxx.xxx.xxx.xxx
    permit tcp host 172.16.101.1 host xxx.xxx.xxx.xxx eq 22
    permit tcp host 172.16.101.2 host xxx.xxx.xxx.xxx eq 22
    route-map NAT_RADIANZ_PIXACCESS_RMAP permit 10
    match ip address NAT_RADIANZ_PIXACCESS_ACL
    set ip next-hop 10.10.11.14
    route-map NAT_INTERNET_ACCESS_RMAP permit 40
    match ip address NAT_INTERNET_ACCESS_ACL
    set ip next-hop xxx.xxx.xxx.xxx

  • Why connections automatically created??

    Hi,
    database: sqlserver 200
    driver: sqlserver jdbc driver from microsoft
    web applications and database are running on two separate window boxes.
    database connections are retrieved from our own connection pool and then released back to the pool.
    After the application runs about half a day or more, the server crashes and netstat shows that much more tcp/ip database connections are created than the number of connections in the pool.
    debugging found that in the following case connections are automatically created outside of the pool.
    connection con = pool.getConnection()
    statement st = null;
    for(int i=0; i<3; i++)
    st = con.createStatement();
    st.executeUpdate("updatestring");
    if(st != null){st.close();}
    pool.release connection;
    In the above code, 2 more connections are created outside of the pool. after we added 'st.close();' behind the ste.excuteUpate(), the problem is solved. However, there are still some connections created without calling getconnection from the database.
    The weird thing is that this kind of problem did not happen when the database and java application were running on the same windows box.
    Any idea will be appreciated.

    According to the "SQL Server 2000 Driver for JDBC User's Guide and Reference" (which comes bundled with the MS driver), page 26:
    >
    SelectMethod - SelectMethod={cursor | direct}. Determines whether database cursors are used for Select statements. Performance and behavior of the driver are affected by the SelectMethod setting.
    Direct - The direct method sends the complete result set in one request to the driver. [...] You should avoid using direct when executing queries that produce a large amount of data, as the result set is cached completely on the client and constrains memory. In this mode, each statement requires its own connection to the database. This is accomplished by "cloning" connections. [...]because transactions must occur on a single connection, auto commit mode is required. [...]
    Cursor - When the SelectMethod is set to cursor, a server-side cursor is generated. The rows are fetched from the server in blocks. the JDBC Statement method setFetchSize can be used to control the number of rows that are fetched per request. [...]
    The default is direct.
    There are a few things you should pay attention here. First, when using the default settings, the MS driver (and it's parent, the DataDirect driver) doesn't support transactions. Also, for some reason, it seems to be caching all the ResultSet on the client, although it doesn't have to; it could just read one row at a time and buffer it (which it doesn't do right either, because it doesn't support reading the columns out of order).
    Then, moving on to cursor mode, although it doesn't say it the default fetch size is of 1 (one) row. This means that a request has to be made for each row returned by a ResultSet. A very serious performance drop (depending on network latency). I haven't tested setFetchSize, I thought it only fetches one row at a time, regardless of this, I could be wrong.
    Now, about jTDS. jTDS used an approach similar to the direct mode of the MS/DataDirect driver up to jTDS 0.8 or so. It wasn't a good idea, as it also tried to support transactions, so you can imagine the mess.
    Currently jTDS has a socket multiplexer, which makes each Statement "think" it's the only one using the physical connection. This is how most other drivers that support concurrent statements do it. The multiplexing means that in some cases server response has to be cached to memory (or disk, after a certain limit is reached), this is why concurrent Statements should be avoided even if supported by the driver. As you can see it's not a limitation of the protocol or, to be more exact, it is but the driver usually does something to work around it. DataDirect choose to take the easy road.
    Then there are scrollable/updateable Statements. For these, drivers can use either server-side or client-side cursors. jTDS implements both: server-side for SQL Server and client-side for Sybase (which doesn't support server-side cursors) and cases when SQL Server can't create a server-side cursor (such as stored procedures consisting of more than a single SELECT). The default fetch size of jTDS is of 100 rows; this ensures a good compromise between performance (one request-response for each 100 rows) and memory overhead (unless the ResultSet contains LOBs, the maximum row size for SQL Server is 8000 and something bytes; this means at most 800KB of memory + the overhead of Java objects).
    So, to sum it up, jTDS uses direct selects (also known as fire-hose cursors) for forward-only read-only ResultSets (which is pretty much the only type of ResultSet used in server applications) and server-side cursors for scrollable and/or updateable ResultSets (with a default fetch size of 100 rows). All this on a single network connection.
    HTH,
    Alin,
    The jTDS Project.

  • Why can't I create UDLs?

    Greetings everybody,
    I'm developing an application with LV7.1 that should communicate (read/write) with Oracle Database.
    Anyway, I did it succesfully using database connectivity toolset (using Universal Data Link "UDL")
    So what is the problem?
    The very strange problem is that when I tried to create a UDL in another machine,simply I couldn't !!!
    Usually I Right-click on any area on the desktop, then click New, then select Microsoft Data Link and it's done
    Now, I can't see the "Microsoft Data Link" option on the menu ?! (Please see the screen shot attatched).
    Isn't this strange? And how can overcome this?!
    Thanks in advance.
    Ayman Mohammad Metwally
    Automation Engineer
    Egypt - Cairo
    Attachments:
    UDL.JPG ‏44 KB

    Thanks tst for your reply,
    Well, I just copied the UDL file form the other machine and it works well in the current machine, I can modify it also to what ever I need.
    I just don't want to move to DSNs (ODBC) is that I saw many Data Base experts ( from other VB forums) saying that using OLE DB (Which uses UDLs) is better that ODBC (which uses DSNs). They said that it's faster and more efficient.
    I really don't have a problem now (by coping the UDL and maybe later I'll include it in my exe package) but I wanted to know why I can't create new ones from the scratch. Well, as you said, a Windows's feature.
    Thanks again for reply
    Ayman Mohammad Metwally
    Automation Engineer
    Egypt - Cairo

  • Two shipments getting created by one delivery

    Hi,
    I have a problem in which 2 shipments are getting created for one Delivery document, whereas only 1 Shipment document should be there. When I analysed the shipment documents, I found that the shipment route and forwarding agent are different in both the documents.
    Any idea why this is happening? Also, want to know-
    1. Is it possible to combine deliveries of different Routes and Fwd agents into one shipment document (VT01N) ?
    Thanks.

    hello, friend.
    it is possible to have 2 or more routes and 2 or more agents in a collective shipment.  in this case, there is a main route and the sub-routes become stages.  it is possible that each stage could have a different agent.
    in your case as originally stated, you may not combine more than 1 route or agent in an individual shipment.  if your items in the delivery document have different routes or agents, then these items will be split into different shipments.
    regards.

Maybe you are looking for

  • How To: create legaleze pop up window in pdf form?

    Hello all. I would like to incorporate a pop up window with my company's legaleze for authorization to use our images in our customers marketing materials. The purpose of the legaleze is to inform the customers our policy on using our images in their

  • How to activate iPhone when it is linked to a different account?

    My original goal was to get rid of the "other" that was taking up so much space on my phone, but when I reset it, it asked for me to activate it. However, the phone is still linked to my old account that I no longer use. There is no way for me to res

  • SCOM 2012 R2 Post upgrade issues

    Hey all, yesterday we upgraded our SCOM environment from 2012 SP1 to R2.  All of the installers ran fine without any issues.  After a couple reboots it was back up however we have run into some issues. Issue 1:  The ACS seems to be broken.  I can usu

  • Two Socket errors: Socket write and Socket reset

    does anyone know the reasons and remedies for the error java.net.SocketException: Software caused connection abort: socket write error and java.net.SocketException: Connection reset by peer: socket write error please reply if someone knows thanks

  • Cant go past the gray apple startup screen

    I've reset my computer many times and can't get past that gray screen I have no clue what to do. Help please!