WScript exec method on windows server 2012

Hi.
A few years ago I coded an app that runs continuously on a reporting server that we have.
It's job is basically access our ERP's software database and send emails originated from selected actions performed on the information system and provide some end of the day emails with a compilation of daily information.
The sending email part of the app runs perfectly on my newly deployed Windows Server 2012. However, so the app can keep alive when we dont have internet connection, i rigged it with some code issuing a ping command to check if the outside world is reachable.
And this is where everything goes south! The only message i get when the ping command is issued through the script is "Unable to contact IP driver. General Failure." This is a bummer since if use a command prompt window, the server pings perfectly.
Previously the app ran fine on a windows server 2008 R2, so i'm guessing this is some kind of auth/security problem. However, i dont know how to fix it, hence this post.
Does any of you can help? Feel free to ask any question you may think it would help to solve the problem.
Thanks in advance.

It would be helpful if you provided information about how you 'coded' this solution.  Is this running as a scheduled task?  If so, remember that the account it runs under is most likely different from the account you are running interactively. 
Check permissions.
2012 by default does not allow ping.  You need to enable the ICMP rule in the firewall.
. : | : . : | : . tim

Similar Messages

  • The remote desktop session host configuration & Remote session shadowing options missing in Windows server 2012.

    Hi All,
    I am using a Windows server 2012 Standard. When i leave my session idle for more than 20 min it disconnects and post more 20 minutes my session is logged off.
    I know this setting can be changed from Remote desktop session host configuration in Windows server 2008 R2. But this option "Remote desktop session host configuration" is not there in Windows server 2012. Does any one have an idea where do i go
    and edit these settings in the Server 2012 o/s ?
    Also the Remote session shadowing option is also not available when i right click a user in the task manager. Any idea on an alternate method in Windows server 2012 ?
    Gautam.75801

    Exactly WHERE are the W2K12 R2 equivalent GPO settings to W2K8 R2 GPO settings of "Set time limit for disconnected sessions" and "set time limit for active but idle Remote Desktop Services
    sessions"?  Microsoft changed the remote desktop/terminal services around.  
    Appreciate it.
    Matt
     Policy Path 
     Scope 
     Policy Setting Name 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     User 
     End session when time limits are   reached 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     Machine 
     End session when time limits are   reached 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     User 
     Set time limit for disconnected   sessions 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     Machine 
     Set time limit for disconnected   sessions 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     User 
     Set time limit for active but idle   Remote Desktop Services sessions 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     Machine 
     Set time limit for active but idle   Remote Desktop Services sessions 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     User 
     Set time limit for active Remote   Desktop Services sessions 
     Windows Components\Remote Desktop   Services\Remote Desktop Session Host\Session Time Limits 
     Machine 
     Set time limit for active Remote   Desktop Services sessions 
    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

  • MSXML6.dll method"SEND" don't work in Windows Server 2012 and SQL 2008R2

    Hi all,
    I have a SP to send a WebService data
    It works fine on Windows 2008R2 server and also on Windows Server 2003.
    moving it on Windows Server 2012 with SQL 2008R2 express (32bit) or SQL 2012 express (32bit), it doesn't work anymore.
    Below the SP.
    -- =============================================
    -- Author: Giancarlo MADA Service 2008
    -- Create date: 09/09/2008
    -- Description: Web Service Interface
    -- =============================================
    CREATE PROCEDURE [dbo].[spmd_HTTPRequest]
    @URI varchar(2000) = '',
    @methodName varchar(50) = '', -- POST, GET
    @requestBody varchar(8000) = '', -- XML Document envelope
    @SoapAction varchar(255),
    @UserName nvarchar(100), -- Domain\UserName or UserName
    @Password nvarchar(100),
    @responseText varchar(8000) output
    as
    SET NOCOUNT ON
    IF @methodName = ''
    BEGIN
    select FailPoint = 'Method Name must be set'
    return
    END
    set @responseText = 'FAILED'
    DECLARE @objectID int
    DECLARE @hResult int
    DECLARE @source varchar(255), @desc varchar(255)
    EXEC @hResult = sp_OACreate 'MSXML2.ServerXMLHTTP.6.0', @objectID OUT
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'Create failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    -- open the destination URI with Specified method
    EXEC @hResult = sp_OAMethod @objectID, 'open', null, @methodName, @URI, 'false', @UserName, @Password
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'Open failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    -- set request headers
    EXEC @hResult = sp_OAMethod @objectID, 'setRequestHeader', null, 'Content-Type', 'text/xml;charset=UTF-8'
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'SetRequestHeader failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    -- set soap action
    EXEC @hResult = sp_OAMethod @objectID, 'setRequestHeader', null, 'SOAPAction', @SoapAction
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'SetRequestHeader failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    declare @len int
    set @len = len(@requestBody)
    EXEC @hResult = sp_OAMethod @objectID, 'setRequestHeader', null, 'Content-Length', @len
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'SetRequestHeader failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    -- send the request
    EXEC @hresult = sp_OAMethod @objectID, 'send', NULL, @requestBody
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'Send failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    declare @statusText varchar(1000), @status varchar(1000)
    -- Get status text
    exec sp_OAGetProperty @objectID, 'StatusText', @statusText out
    exec sp_OAGetProperty @objectID, 'Status', @status out
    select @status, @statusText, @methodName
    -- Get response text
    exec sp_OAGetProperty @objectID, 'responseText', @responseText out
    IF @hResult <> 0
    BEGIN
    EXEC sp_OAGetErrorInfo @objectID, @source OUT, @desc OUT
    SELECT hResult = convert(varbinary(4), @hResult),
    source = @source,
    description = @desc,
    FailPoint = 'ResponseText failed',
    MedthodName = @methodName
    goto destroy
    return
    END
    destroy:
    exec sp_OADestroy @objectID
    SET NOCOUNT OFF
    The underlined portion is the one that gives error, reported below.
    "Msxml6.dll 0x80070057 The parameter is incorrect. Send failed POST"
    Previously the SP used MSXML3.dll and also with that it gives the same problem.
    I can't understand what the wrong parameter is.
    Even because, as mentioned at the beginning, everything works fine on windows server 2008R2 and Windows Server 2003
    Some ideas?

    Hello, 
    We have built a dll via CLR on the database. 
    Below is the code.
    If you want to send the file SOAP.dll. Give me an e-mail ..
    USE MydatabaseGO
    /****** Object: SqlAssembly [SOAP] Script Date: 03/05/2014 12:59:14 ******/
    CREATE ASSEMBLY [SOAP]
    AUTHORIZATION [dbo]
    FROM MyPath\SOAP.dll
    WITH PERMISSION_SET = EXTERNAL_ACCESS
    GO
    USE Mydatabase
    GO
    /****** Object: StoredProcedure [dbo].[spmd_HTTPRequest3] Script Date: 03/05/2014 12:53:32 ******/
    CREATE PROCEDURE [dbo].[spmd_HTTPRequest3]
    @URI [nvarchar](4000),
    @methodName [nvarchar](4000),
    @requestBody [nvarchar](4000),
    @SoapAction [nvarchar](4000),
    @UserName [nvarchar](4000),
    @Password [nvarchar](4000),
    @responseText [nvarchar](4000) OUTPUT
    WITH EXECUTE AS CALLER
    AS
    EXTERNAL NAME [SOAP].[StoredProcedures].[spmd_HTTPRequest3]
    GO
    Now call the new SP called spmd_HTTPRequest3
    By..

  • ASA and RADUIS on Windows server 2012

    hi i have ASA5505 i want to get the Authentication from Raduis Server using NPS on windows Server 2012 i test the Raduis Server over "Kerio Control VMware Virtual Appliance" its work Perfect for testing my Setting on Raduis  but with the ASA5505 i get this message "Error authentication rejected aaa failure" 
    Running Config
    : Saved
    ASA Version 9.1(3)
    hostname NazcoFW
    domain-name default.domain.invalid
    enable password XgEKS9WizHnI9IUJ encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd XgEKS9WizHnI9IUJ encrypted
    names
    interface Ethernet0/0
    switchport access vlan 22
    interface Ethernet0/1
    interface Ethernet0/2
    switchport access vlan 12
    interface Ethernet0/3
    interface Ethernet0/4
    shutdown
    interface Ethernet0/5
    shutdown
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    switchport access vlan 32
    shutdown
    interface Vlan1
    nameif NAZCO
    security-level 100
    ddns update hostname OSI
    dhcp client update dns server both
    ip address 172.16.200.1 255.255.255.0
    interface Vlan12
    nameif outside4
    security-level 0
    ip address 172.16.4.254 255.255.255.0
    interface Vlan22
    nameif Outside20
    security-level 0
    ip address 172.16.20.254 255.255.255.0
    boot system disk0:/asa913-k8.bin
    ftp mode passive
    dns domain-lookup NAZCO
    dns server-group DefaultDNS
    name-server 10.1.1.1
    name-server 10.1.2.1
    domain-name default.domain.invalid
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network HP5220
    host 10.10.10.105
    object network ak20
    host 10.10.10.110
    object network hp5520
    host 192.168.2.105
    object network HP7000
    host 192.168.2.106
    object network HP5520
    host 192.168.2.105
    object network ak04
    host 10.10.10.110
    object network HP400
    host 192.168.2.107
    object network out04
    range 192.168.2.200 192.168.2.220
    object network AK04
    host 10.10.10.110
    object network oooo
    subnet 10.10.10.0 255.255.255.0
    object network 444
    host 10.10.10.110
    object network OSITOINT
    subnet 10.10.10.0 255.255.255.0
    object-group network OSItoOUT04
    network-object object out04
    access-list outside20_access_in extended permit icmp any4 any4
    pager lines 24
    logging enable
    logging asdm-buffer-size 512
    logging trap informational
    logging asdm informational
    logging host NAZCO 10.10.10.10 17/6161
    logging debug-trace
    logging permit-hostdown
    mtu NAZCO 1500
    mtu Outside20 1500
    mtu outside4 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-721.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (NAZCO,outside4) source dynamic any interface dns
    nat (NAZCO,Outside20) source dynamic any interface dns
    route Outside20 0.0.0.0 0.0.0.0 172.16.20.1 1
    route outside4 0.0.0.0 0.0.0.0 172.16.4.1 11
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server Keefa-Raduis protocol radius
    aaa-server Keefa-Raduis (NAZCO) host 172.16.200.10
    key *****
    radius-common-pw *****
    user-identity default-domain LOCAL
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 NAZCO
    snmp-server host NAZCO 10.10.10.196 community ***** version 2c
    no snmp-server location
    no snmp-server contact
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown
    snmp-server enable traps syslog
    snmp-server enable traps ipsec start stop
    snmp-server enable traps entity fru-insert
    snmp-server enable traps remote-access session-threshold-exceeded
    snmp-server enable traps connection-limit-reached
    snmp-server enable traps cpu threshold rising
    snmp-server enable traps ikev2 start stop
    snmp-server enable traps nat packet-discard
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca trustpool policy
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
    quit
    telnet timeout 5
    ssh scopy enable
    ssh 172.16.200.0 255.255.255.0 NAZCO
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    management-access NAZCO
    dhcp-client update dns server both
    dhcpd dns
    dhcpd update dns both
    dhcpd address 172.16.200.20-172.16.200.89 NAZCO
    dhcpd dns 172.16.20.1 172.16.4.1 interface NAZCO
    dhcpd lease 1048575 interface NAZCO
    dhcpd update dns both interface NAZCO
    dhcpd enable NAZCO
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ssl encryption rc4-sha1 aes128-sha1 aes256-sha1 3des-sha1
    username admin password bZmVDHuxUzzxS3yz encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum client auto
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    inspect ip-options
    inspect icmp
    inspect icmp error
    class class-default
    user-statistics accounting
    service-policy global_policy global
    prompt hostname context
    service call-home
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
    no active
    destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
    destination address email [email protected]
    destination transport-method http
    subscribe-to-alert-group diagnostic
    subscribe-to-alert-group environment
    subscribe-to-alert-group inventory periodic monthly
    subscribe-to-alert-group configuration periodic monthly
    subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:357b7c6f861e8aa9bb3a3674a789b39b
    : end
    asdm image disk0:/asdm-721.bin
    no asdm history enable

    Hi
      Looks like the AAA configuration is set for local
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    Change it to Radius
    aaa-server Keefa-Raduis protocol radius
    aaa-server Keefa-Raduis (NAZCO) host 172.16.200.10
    key *****
    radius-common-pw *****
    for example :
    aaa authentication telnet console Keefa-Raduis LOCAL
    Now when you will do telnet to using Radius credentials, Its Should work, If radius goes down you can use LOCAL username and password as fallback method.
    Cheers!
    Minakshi(Do rate the helpful post)

  • Error in Installing Exchange Server 2013 (w SP1) Mailbox Role on Windows Server 2012 R2

    Hi Team,
    Need urgent help in resolution of following error:
    Environment Details: VMware ESXi 5.5 (vMotion)
    Migration from Exchange Server 2007 (SP3 + RU13) to Exchange Server 2013
    Exchange Server: Exchange Server 2013 with SP1 (Latest Installation Media)
    OS: Windows Server 2012 R2 - Standard (Latest Installation Media)
    Exchange 2013 Roles: Seprated (Mailbox and CAS on Different VMs)
    Prerequisites: Installed
    Error: Installation gives Error at Step 10 during installation of Mailbox Service
    Error Details Below:
    Error:
    The following error was generated when "$error.Clear();
    if ([Environment]::OSVersion.Version.Major -ge 6)
    $WsbBinPath=$RoleInstallPath+"bin\wsbexchange.exe";
    $reg= join-path (join-path $env:SystemRoot system32) reg.exe;
    $servicecmd = join-path (join-path $env:SystemRoot system32) sc.exe;
    if ((get-service wsbexchange* | where {$_.name -eq "wsbexchange"}))
    if ((get-service wsbexchange).Status -eq "Running")
    Start-SetupProcess -Name:"$servicecmd" -Args:"stop wsbexchange";
    Start-SetupProcess -Name:"$servicecmd" -Args:"delete wsbexchange";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\CLSID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /t REG_SZ /d `"CExchangeHelper Class`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\CLSID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /v AppId /t REG_SZ /d `"{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\CLSID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}\LocalServer32`" /t REG_SZ /d `"$WsbBinPath`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\APPID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /t REG_SZ /d `"CExchangeHelper Class`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\APPID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /v LocalService /t REG_SZ /d `"wsbexchange`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\APPID\{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /v LaunchPermission /t REG_BINARY /d `"010004806000000070000000000000001400000002004c0003000000000014001f000000010100000000000512000000000018001f000000010200000000000520000000200200000000180003000000010200000000000520000000270200000102000000000005200000002002000001020000000000052000000020020000`"
    /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKCR\APPID\wsbexchange.exe`" /v AppId /t REG_SZ /d `"{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`" /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKLM\Software\Microsoft\windows nt\currentversion\WindowsServerBackup\Application Support\{76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}`" /v `"Application Identifier`" /t REG_SZ /d
    Exchange /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKLM\Software\Microsoft\windows nt\currentversion\WindowsServerBackup\Application Support\{76fe1ac4-15f7-4bcd-987e-8e1acb462fb7}`" /v CLSID /t REG_SZ /d `"{D8A2E312-3B17-4293-B71E-CD72A7C04BF3}`"
    /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKLM\Software\Microsoft\windows nt\currentversion\WSBAppExchangeHelper`" /v AutoMarkDbRecoverable /t REG_DWORD /d 1 /f";
    Start-SetupProcess -Name:"$reg" -Args:"add `"HKLM\Software\Microsoft\windows nt\currentversion\WSBAppExchangeHelper`" /v AutoMountOnPITRecovery /t REG_DWORD /d 1 /f";
    Start-SetupProcess -Name:"$servicecmd" -Args:"create wsbexchange binpath= `"$WsbBinPath`" type= own start= demand error= ignore obj= LocalSystem DisplayName= `"Microsoft Exchange Server Extension for Windows Server Backup`"";
    Start-SetupProcess -Name:"$servicecmd" -Args:"description wsbexchange `"Enables Windows Server Backup users to back up and recover application data for Microsoft Exchange Server.`"";
    " was run: "Process execution failed with exit code 1.".

    Resolved ! :)
    Root Cause: The user account I was using had all the required privileges for Exchange Installation but was not having access to edit the registry of the server. Enable access to registry edit tools and you are good to go.
    As an alternate you can also try installing using Domain Administrator account if in case there is an IT Policy constraint in the former method.
    Thanks to all.

  • Storport.sys BSOD on Windows Server 2012 R2

    I recently purchased a Server that houses 45 4TB drives to use as my backup to disk solution. I installed Windows Server 2012 R2 Standard so that I could take advantage of Microsoft's Storage Spaces. I have configured the Storage Pool
    with Dual Parity with 3 hot spares. I have also updated every thing to the most current firmware, drivers and Windows Updates that I could find but I am still getting the BSOD. I am using Symantec Backup Exec 2010 R3 to backup my file server to this server.
    It will run for anywhere between 12 to 31 hours transferring 1.5 to 3TB and then my server will Blue Screen and every time it Blue Screens it says it is caused by the storport.sys Driver. I've found articles talking about the storport.sys driver causing nonpaged
    pool leaks but that was for Windows Server 2008 R2, I can't find anything for Windows Server 2012 R2. If you need additional information just let me know and I will provide it. Any help you can give would be greatly appreciated.

    Hi,
    This article provided the limitation of Storage Pool in Windows Server 2012 R2:
    https://social.technet.microsoft.com/wiki/contents/articles/11382.storage-spaces-frequently-asked-questions-faq.aspx#What_are_the_recommended_configuration_limits
    Yor current situation is still in supported configuration.
    Also there is no hotfix for Windows Server 2012 R2 regarding storport.sys yet. Which means your current issue is not a known issue.
    For further troubleshooting purpose you may need to collect dump files for analysis. However it will take a long time to do the troubleshooting process on forum. Thus it is recommended to submit a ticket to Microsoft online support for a professional troubleshooting.
    To obtain the phone numbers for specific technology request please take a look at the web site listed below:
    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS
    If you have any feedback on our support, please send to [email protected]

  • Windows Server Backup scheduled task run successfully but backup do not start (not running) on Windows Server 2012

    Hi,
    A backup job has been setup on Windows Server 2012 (Platform: Win32NT; ServicePack: ; Version: 6.2.9200.0; VersionString : Microsoft Windows NT 6.2.9200.0) via Windows Backup Software UI (Local Backup 1.0).
    It is appearing as a scheduled task "\Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup" belonging to user 'nt authority\system' in task scheduler.
    The problem is that the Backup job never start despite the scheduled task running and completing successfully (when run automatically or manually)!
    Would you be able to explain why and assist in resolving that issue?
    Here is what we know:
    When the backup is run manually via the Windows Backup Software UI, it works fine.
    When the backup is run via command line (as set in schedule task) in a cmd command prompt (as local/domain 'administrator' or as 'nt authority\system' which is possible by running command prompt via 'PsExec.exe -i -s cmd'), something like "%windir%\System32\wbadmin.exe
    start backup -templateId:{f11eb3aa-74e7-4ff4-a57b-d8d567ee3f77} -quiet", it works fine.
    If you manually run the preset scheduled task while logged in as administrator, the task run and complete successfully but the backup job does not start.
    Idem if you schedule task is run automatically at scheduled time.
    The schedule task run and complete successfully but the backup job does not start.
    It is confirmed by running the following in a command prompt as 'nt authority\system':
    schtasks /run /tn "\Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup"
    SUCCESS: Attempted to run the scheduled task "\Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup".
    Despite success result, the Backup job does not start running...
    No errors or warning appears anywhere in Event Logs (Microsoft > Windows > Backup or Task Scheduler) nor in the scheduled task History tab. The schedule task complete successfully but no Backup job is run...
    If scheduled task automatically set by Windows Backup software is duplicated (copied) and set manually it runs fine as 'administrator' and as 'nt authority\system' (subject that 'nt authority\system' is added to the 'Backup Operators' AD group).
    Here is an export of the current pre-set schedule task, is there any settings that need to be changed to make it works?
    <?xml version="1.0" encoding="UTF-16"?>
    <Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
      <RegistrationInfo>
        <Author>MYDOMAIN\SERVER1</Author>
        <SecurityDescriptor>D:AR(A;OICI;GA;;;BA)(A;OICI;GR;;;BO)</SecurityDescriptor>
      </RegistrationInfo>
      <Triggers>
        <CalendarTrigger id="Trigger 1">
          <StartBoundary>2014-07-14T21:00:00</StartBoundary>
          <Enabled>true</Enabled>
          <ScheduleByDay>
            <DaysInterval>1</DaysInterval>
          </ScheduleByDay>
        </CalendarTrigger>
      </Triggers>
      <Principals>
        <Principal id="Author">
          <UserId>S-1-5-18</UserId>
          <RunLevel>HighestAvailable</RunLevel>
        </Principal>
      </Principals>
      <Settings>
        <MultipleInstancesPolicy>Parallel</MultipleInstancesPolicy>
        <DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
        <StopIfGoingOnBatteries>false</StopIfGoingOnBatteries>
        <AllowHardTerminate>true</AllowHardTerminate>
        <StartWhenAvailable>true</StartWhenAvailable>
        <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
        <IdleSettings>
          <StopOnIdleEnd>false</StopOnIdleEnd>
          <RestartOnIdle>false</RestartOnIdle>
        </IdleSettings>
        <AllowStartOnDemand>true</AllowStartOnDemand>
        <Enabled>true</Enabled>
        <Hidden>false</Hidden>
        <RunOnlyIfIdle>false</RunOnlyIfIdle>
        <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
        <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>
        <WakeToRun>false</WakeToRun>
        <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
        <Priority>7</Priority>
      </Settings>
      <Actions Context="Author">
        <Exec>
          <Command>%windir%\System32\wbadmin.exe</Command>
          <Arguments>start backup -templateId:{f11eb3aa-74e7-4ff4-a57b-d8d567ee3f77} -quiet</Arguments>
        </Exec>
      </Actions>
    </Task>
    Thank you in advance for your feedback.

    Once again, the issue is not to run the backup manually from the command line but to have it run via the scheduled task setup by the Windows Backup software.
    By default, the schedule task is to be run as NT Authority\System, and when run under this account, the backup does not start (even though account is member of Backup Operators) and job can manually be run via elevated command prompt. This is not a normal
    behavior and constitute a major bug in Windows Server 2012.
    From my understanding the NT Authority\System account is a built-in account from Windows that should by default be part of the Administrators group (built-in) even though it does not explicitly appears like it in AD by default.
    This account shall have by default Administrators rights and Backup Operators rights (via the Administrators group) without being explicitly added to those groups (http://msdn.microsoft.com/en-gb/library/windows/desktop/ms684190%28v=vs.85%29.aspx). By design
    it is supposed to be the most powerful account which has unrestricted access to all local system resources. If that is not the case (as it seems) then this would constitute a major bug in Windows Server 2012 edition.
    As said previously and as you confirmed, currently by default NT Authority\System on Windows 2012 server cannot start backup manually via an elevated command prompt unless it is manually added to Backup Operators (or Administrators) group. But wouldn't that
    constitute a bug of Windows Server 2012?
    Our server has not yet been restarted since I added NT Authority\System account to the Administrators group explicitly manually so I cannot yet confirmed it would sort the issue. Indeed it is heavily in use so cannot easily be restarted. Will confirm when
    done.
    We also have an additional problem where after a while of last reboot, part of the Exchange ECP can no longer be properly loaded in the web browser due to compilation error (compilation is done via NT Authority\System account which seems to no longer have
    sufficient right to compile .NET code). What is strange is that it works at first and then stop working at some point... I am hopeful that adding NT Authority\System to the Administrators group would sort this issue as well but once again, that shall not be
    needed!!!
    Could a Windows Server 2012 update introduced some security policy changes or else that prevent NT Authority\System to have full power?

  • How do I change the URL to the Remote Web Access server in Windows Server 2012?

    Hallo!
    I have set up a Remote Dexktop Service using the "Quick" deployment method in Server Manager and everything is working greate internally, but I cannot start an app published in Remote Web Access from outside our network.
    The problem is that it wants to start the using the internal URL, for example, server.domain.local, instead of the external one, for example remote.server.com.
    I therefore want to know how I can change the default URL for the Remote Web Access server and all the Remote Web Apps in Windows Server 2012?
    I have allready looked in Server Manager and I can change some of the deployment settings in server manager, but there is no way to alter the URL of the Remote Web Access server. See below images:
    Pressing the internal URL only results in opening the internal URL.
    This was very simple to do in Windows Server 2008 R2 using the tsconfig tool, but it does not seam to be any way of solving this in server manager.
    A possible sollution would be to alter the registry someware in HKLM->Software->Microsoft->Windows NT->Terminal Services. But this can easaly lead to problems due to wrong format, etc. and is probably not supported.
    Is there a simpler and supported way?

    That option can be used to connect to any machine that you want.  The error message indicates that the client machine cannot resolve the name "server.domain.local" to an IP address that it can connect to.
    You have several options for configuring that tab on the RDweb site.  You can even remove it entirely. 
    Customization of RD Web Site
    RD Web provides a number of customization options for the RD Web interface, including the ability to control default Gateway server settings and redirection settings. These settings
    are controlled by editing the web.config file located in %SYSTEMROOT%\Web\RDWeb\Pages.
    Displaying Local Help
    To display local help for users instead of the web-based help, edit the LocalHelp value and change the value from false to true.
    <!-- LocalHelp: Displays local help for users, instead of the web-based help. Value must be "true" or "false" -->
    <add key="LocalHelp" value="false" />
    When this value is changed, a user that clicks on Help in the upper right corner of the RD Web login page will open the local help file instead of web-based help.
    Hiding the Connect to a Remote PC Tab
    The RDWeb page
    Connect to a Remote PC tab can be hidden from users to prevent connections to any servers through RD Web other than the servers configured in a collection. By default, this setting is set to true and the
    Remote Desktops tab is displayed. To hide the tab, set the value to false.
    <!-- ShowDesktops: Displays or hides the Remote Desktops tab. Value must be "true" or "false" -->
    <add key="ShowDesktops" value="true" />
    When the value is set to false, a user will not see the Connect to a Remote PC tab when logged on to the RD Web page
    RD Gateway Settings
    If the Connect to a Remote PC tab is enabled, an administrator can configure RD Web to use a Gateway server when connecting to remote computers. To specify a gateway, edit the below
    value with the name of the RD Gateway server:
    <!-- DefaultTSGateway: Admin can preset this to a given Gateway name, or set to "" for no gateway. -->
    <add key="DefaultTSGateway" value="" />
    The default authentication method for the RD Gateway server can also be configured by editing the following section of the web.config:
    <!-- GatewayCredentialsSource: TS Gateway Authentication Type.
    Admins can preset this.
    0 = User Password
    1 = Smartcard
    4 = "Ask me later"
    -->
    <add key="GatewayCredentialsSource" value="0" />
    Devices and Resources
    By default, only Printers and Clipboard are redirected on connections made using the Connect to a Remote PC tab. If the user clicks the
    Options << button, the redirection settings for a specific connection can be modified
    To configure each specified redirection option to be enabled or disabled by default, edit the following section in the web.config file:
    <!-- Devices and resources: Preset the Checkbox values to either true or false -->
    <add key="xPrinterRedirection" value="true" />
    <add key="xClipboard" value="true" />
    <add key="xDriveRedirection" value="false" />
    <add key="xPnPRedirection" value="false" />
    <add key="xPortRedirection" value="false" />
    LAN Experience Defaults
    Windows Server 2012 RD Web Access can display a new user selectable option for optimizing the connection for a LAN experience. This option is displayed at the bottom of the RD Web
    page and can be controlled by the administrator using the following section of the web.config file:
    <!--  Checkbox to opt for optimized LAN experience -->
    <add key="ShowOptimizeExperience" value="false" />
    <add key="OptimizeExperienceState" value="false" />
    This value is set to false by default, but when changed to true, the following checkbox will display at the bottom of the webpage. The LAN experience
    checkbox can also be set as enabled by default.
    Each setting can also be modified using the IIS Manager user interface:
    Don Geddes - SR Support Escalation Engineer - Remote Desktop Services - Printing and Imaging

  • Remote desktop connection manager on windows 8.1, can't connect to windows server 2012 R2, Socket closed

    remote desktop connection manager on windows 8.1, can't connect to windows server 2012 R2, Socket closed each time i try to open remote connection to the server,
    does remote desktop connection manager V2.2 not compatible with windows 8.1, and if so, is there are any other compatible versions
    or what's the problem,
    Mahmoud Sabry IT System Engineer

    this issue maybe will be fix by latest version, we still waiting for it
    maybe your issue can be fix using this methods
    https://social.technet.microsoft.com/Forums/windowsserver/en-US/61f218a5-5ef8-49da-a035-90cdd64fc9a0/problem-with-remote-desktop-connection-manager-error-3334?forum=winserverTS
    http://shawn.meunier.com/?p=1#comment-43

  • Unable to install Device CALs on Windows Server 2012 after OS Reinstall

    Due to a hardware fault we had to reinstall Windows Server 2012. I have activated the Terminal Services licensing Server but I am unable to install Device CALs that we have purchased.
    The error is as follows:
    "Remote Desktop Services Licensing is unable to process your request. Make sure you provided correct information. If the problem persists, try other methods of activation. Error code is 800"
    I tried contacting technical support over phone - they are also unable to resolve the issue.

    Hi, thanks for response.
    I contacted Clearing House over phone and provided them with all the details regarding authorization
    number(s), license number(s) et al. However they also mentioned that there is some technical error from their "tool" and directed me to Technet Forum.
    I shall try the Hotfix

  • How to import a virtual machine to a Hyper-V server by programme on Windows server 2012 ?

    Hi
    As we know, Hyper-V of Windows server 2012 can support importing a VM without exporting it first manually now.
    So I try to code a programme to do it.
    I use the method "ExportVirtualSystemEx" of  "Msvm_VirtualSystemManagementService". referenced by
    http://msdn.microsoft.com/en-us/library/dd379583(v=vs.85).aspx
    But the error said that "You can import a virtual machine only if you used Hyper-V to create and export it."
    Since we can import an unexported virtual machine in Hyper-V of windows server 2012 manually, so is there any API to support to do it by programme ?

    Hi vincent
    Thanks for your infomation. It is really useful for us.
    I 'd like to know How to adjust path ?
    When I use command 'import-vm' to import VM, I got the error "import-vm : Unable to import virtual machine due to configuration errors.  Please use Compare-VM to repair the virtual machine."
    I  try to fix this error referenced by
    http://technet.microsoft.com/en-us/library/hh848612.aspx
    I ran the commands as bellow :
    $report = compare-vm -path 'J:\HyperV\VM2008R2_1\Virtual Machines\6D2B5BF6-0BC0-4B1C-86BA-5A28DAB3DFCF.xml'
    $report.Incompatibilities | fl
    and got the information:
    Message : Virtual Hard Disk file not found.
    MessageId : 40010
    Source : Microsoft.HyperV.PowerShell.HardDiskDrive
    Message : Could not find Ethernet switch 'Broadcom BCM5709C NetXtreme II GigE (NDIS VBD Client) #54 - Virtual
    Switch'.
    MessageId : 33012
    Source : Microsoft.HyperV.PowerShell.VMNetworkAdapter
    Message : Virtual Hard Disk file not found.
    MessageId : 40010
    Source : Microsoft.HyperV.PowerShell.HardDiskDrive
    Message : Virtual Hard Disk file not found.
    MessageId : 40010
    Source : Microsoft.HyperV.PowerShell.HardDiskDrive
    Message : Could not find Ethernet switch 'Broadcom BCM5709C NetXtreme II GigE (NDIS VBD Client) #54 - Virtual
    Switch'.
    MessageId : 33012
    Source : Microsoft.HyperV.PowerShell.VMNetworkAdapter
    Message : Virtual Hard Disk file not found.
    MessageId : 40010
    Source : Microsoft.HyperV.PowerShell.HardDiskDrive
    Message : Virtual Hard Disk file not found.
    MessageId : 40010
    Source : Microsoft.HyperV.PowerShell.HardDiskDrive
    Message : Could not find Ethernet switch 'Broadcom BCM5709C NetXtreme II GigE (NDIS VBD Client) #54 - Virtual
    Switch'.
    MessageId : 33012
    Source : Microsoft.HyperV.PowerShell.VMNetworkAdapter
    Message : Could not find Ethernet switch 'Broadcom BCM5709C NetXtreme II GigE (NDIS VBD Client) #54 - Virtual
    Switch'.
    MessageId : 33012
    Source : Microsoft.HyperV.PowerShell.VMNetworkAdapter
    But this web page don't mentioned how to fix the "Virtual Hard Disk file not found" error.
    and I don't want to fix the VMNetworkAdapter issue by disconnect it.
    So could you told me how to modify the virtual hard disk file path and VMNetworkAdapter to make sure that I can import the virtual machine successfully?

  • SQL 2000 LINKED SERVER ERROR 7303 WITH SQL 2012 ON WINDOWS SERVER 2012 R2

    Hi all,
    I have a problem with SQL Server 2012 and a linked server for SQL 2000 database.
    System specification:
    Windows server 2012 64 bit
    SQL SERVER 2012 64 bit
    REMOTE SERVER SQL 2000 32 bit
    I've installed sql native client 32bit,create a SYSTEM DSN odbc connection with "SQL Server" driver named "MYSERVER".
    Create a linked server with the query below in SQL 2012:
    EXEC master.dbo.sp_addlinkedserver @server =N'MYSERVER', @srvproduct=N'MYSERVER', @provider=N'MSDASQL', @datasrc =N'MYSERVER', @location=N'System';
    EXEC master.dbo.sp_addlinkedsrvlogin @rmtsrvname=N'MySERVER',@useself=N'True',@locallogin=NULL,@rmtuser=NULL,@rmtpassword=NULL
    GO
    but when i browse the linked server i receved error 7303.

    You need 64-bit MSDASQL. It is the bitness of the server you are connecting from that matters. 64-bit executables cannot hook into 32-bit DLL.
    However, I suspect that you will not get things to work anyway. At least I have not seen anyone this far who has been able to set up a linked server from SQL 2012 to SQL 2000. I know that when I tried this, the following providers had this result:
    SQLNCLI11 - does not support connections to SQL 2000.
    SQLNCLI10 - failed with some obscure message that I don't recall.
    SQLNCLI - Don't recall that the problem was here.
    SQLOLEDB - SQLOLEDB is always replaced with the most recent version of SQLNCLI, so this fails because of lack of support.
    I don't think I got through all version of the ODBC drivers, though.
    Erland Sommarskog, SQL Server MVP, [email protected]

  • Windows Server 2012 R2 eval refuses to install

    I have downloaded Windows Server 2012 R2 evaluation ISO twice. I have tried installing it in VMWare Workstation 10, in VirtualBox 4.3.12 as well as on a Core2Duo E4200 test box w 4GB RAM. All 3 of these methods fail to install. They all result with the same
    error:
    There are no MD5Sums posted on the Eval page but both download attempts generate the same checksums:
      File: 9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_SERVER_EVAL_EN-US-IR3_SSS_X64FREE_EN-US_DV9.ISO
    CRC-32: 3221785b
       MD4: 2abe3e1c6dfdcd8f6bdaa779baf011e3
       MD5: b391a267949518ed6bb69f908f252076
     SHA-1: 5e2ddcaecc91e80a8ce3ec7ae7838f8a3967ed7f
    I am stumped. Can anyone at MS or those who were able to install this ISO properly can you verify these checksums? I have tried installing it on the Core2Duo box via USB key and DVD with same result.

    That page is a link to the Datacenter version of Server 2012 R2 and the one I am attempting to install numerous times is the non data center version. Anyways I selected Datacenter ISO version, registered and then proceeded to the next page where I seen the
    following error:
    The webpage at http://care.dlservice.microsoft.com/dl/download/6/2/A/62A76ABB-9990-4EFC-A4FE-C7D698DAEB96/9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_SERVER_EVAL_EN-US-IR3_SSS_X64FREE_EN-US_DV9.I might
    be temporarily down or it may have moved permanently to a new web address.
    Can anyone who has successfully installed Server 2012 R2  (non DataCenter) version from ISO on to a temp system generate
    a check sum of the ISO file?
    I am going around in a circle here after attempting to install it on 2 systems as a standalone install and on two additional
    systems in VirtualBox and VMWare Workstation on one system and VirtualBox on a second system all of which resulted in the all too familiar error.

  • [Forum FAQ]How to upgrade Windows Server 2008 R2 with a GUI to Windows Server 2012 Server Core

    We found that some customers willing to upgrade Windows Server 2008 R2 GUI to Windows Server 2012 Server Core recently. This article provides detailed steps to perform the upgrade.
    Analysis
    Upgrading from Windows Server 2008 R2 with a GUI installation to Windows Server 2012 with Server Core directly
    is not supported. If you do that, you will receive the error message below(Figure 1) in Compatibility report: 
    Figure 1.
    In these scenario, you can upgrade to Windows Server 2012 firstly. After the upgrade process is completed, you can switch freely between Server Core and Server with a GUI modes.
    Produces
    You can follow the steps below to perform an upgrade from Windows Server 2008 R2 with a GUI installation to Windows Server 2012 Server Core mode:
    1. Upgrade to Windows Server 2012 with a GUI mode
    1) Firstly, please boot into Windows Server 2008 R2 with a Windows Server 2012 installation DVD inserted.
    2) Select the operating system you want to install with a GUI mode.
    We can see 2 options (Server Core Installation or Server with a GUI) for each operating system version. (Figure 2)
    Figure 2.
    Note: Please make sure you have enough disk space on system partition. Or you will get such an error in Compatibility report.(Figure 3)
    Figure 3.
    After the Compatibility check, the installation will continue. It will take several minutes until upgrading is done.(Figure 4)
    Figure 4.
    2. Switch the GUI mode to Server Core
    Method 1: Using Server Manager
    1) Open Server Manager, click
    Manger and select “Remove Roles and Features” to start the
    Remove Roles and Features Wizard.
    2) In Features,
    uncheck the box next to the “User Interfaces and Infrastructure” option, and then click “Next”. (Figure 5)
    Figure 5.
    Now tick the “Restart the destination Server automatically if required” box, then click “Remove”. (Figure 6)
    Figure 6.
    Method 2: Using Windows PowerShell
    There are multiple ways to remove the GUI via Windows PowerShell, we introduce the way of using the ServerManager module.
    You can also run the commands in Windows PowerShell with an administrator to remove the GUI feature:
    “Import-Module ServerManager”
    “Uninstall-Windowsfeature Server-Gui-Shell –Restart”
    or
    “Uninstall-WindowsFeature Server-Gui-Shell, Server-Gui-Mgmt-Infra –Restart”
    It will take a period of time to remove the GUI feature and reboot. When the system boots up, you will get into the Windows Server 2012 with Server Core mode. (Figure 7)
    Figure 7.
    More information:
    Switch between Full and Server Core in Windows Server 2012 using PowerShell 3.0
    http://blogs.technet.com/b/puneetvig/archive/2012/10/16/switch-between-full-and-core-in-windows-server-2012-using-powershell-3-0.aspx
    Windows Server Installation and Upgrade
    http://technet.microsoft.com/en-us/windowsserver/dn527667.aspx
    Please click to vote if the post helps you. This can be beneficial to other community members reading the thread.

    Hi,
    Brian is right, for mange the Server 2008r2 sp1 we recommend use the Windows 7 or 7.1 platform.
    More information:
    Remote Server Administration Tools for Windows 7 with Service Pack 1 (SP1)
    http://www.microsoft.com/en-us/download/details.aspx?id=7887
    Hope this helps.
    We
    are trying to better understand customer views on social support experience, so your participation in this
    interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

  • How to install device cals on Windows Server 2012 standard edition

    Hello i have a windows server 2012 standard edition licence that i have taken on rent from an ISP.
    i have created a domain controller on that.
    By default only two users can use remote desktop to the server simultaneously.
    My Requirement is 20 users can use remote desktop to the server at the same time.For that i have purchased 20 Delive CALs licences like volume licencing.
    i have the licence number noted on the paper.
    do i need to install remote desktop services first etc ?
    Could anyone guide me step by step how can i install or configure so that 20 users can use remote desktop on the same time.

    Hi,
    Any update about the issue?
    I would agree with others, you need to install Remote Desktop Services Client Access Licenses.
    There are three methods by which you can install Remote Desktop Services client access licenses (RDS CALs) onto your license server:
    • Install Remote Desktop Services Client Access Licenses Automatically
    • Install Remote Desktop Services Client Access Licenses by Using a Web Browser
    • Install Remote Desktop Services Client Access Licenses by Using the Telephone
    https://technet.microsoft.com/en-us/library/cc725890.aspx?f=255&MSPPError=-2147217396
    Then you can install both Per User and Per Device CALs onto the same license server.
    Regards.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact [email protected]

Maybe you are looking for