Accessing Xcode build configuration within code

HI, I'm trying to get the Xcode build configuration in code to insert debug messages, eg like in C i would do:
#ifdef DEBUG
printf("some debug");
#endif
Is there a preprocessor variable for Xcode (DEBUG or Debug) doesn't seem to work

I don't believe there is such as thing, at least there wasn't a couple years back when I last looked. But you can create your own preprocessor directive. In your target settings and for the Debug configuration only, create a GCCPREPROCESSORDEFINITIONS value of DEBUG=1. (Search for GCCPREPROCESSORDEFINITIONS or Preprocessor Macros to find it in the settings. It's in the GCC Preprocessing section.)
Or copy the following line and paste it into your target settings window:
GCCPREPROCESSORDEFINITIONS = DEBUG=1
The you can use code like this:
#if DEBUG
blah
#endif

Similar Messages

  • Using BASH environment variables in xCode build configuration

    Hi All,
    Is it possible to use BASH environment variables (exported from /etc/profile, for example) in xcode build settings?
    Specifically, I am exporting a "BOOST_HOME" variable, and would like to referencing this variable in "User Header Search Path", but the obvious $BOOST_HOME doesn't seem to work?
    Thanks,
    Andrew

    I don't know much about XCode -- but to set environment variables for GUI applications you need to edit ~/.MacOSX/environment.plist. There's a description here:
    http://wiki.lyx.org/Mac/Environment
    After editing that file I believe you have to logout and back in for the changes to take effect.
    I swear I saw a GUI app to help edit that file, but I can't find it now...

  • Cisco 1242AG Access Point proper configuration

    Hello everyone,
    Here is the situation:
    Recently we decide to create a small WLAN in our business.We choose the Cisco AIR-AP1242AG-E-K9 with 2x2.4GHz 2.2dbi Swivel Dipole Antenna.
    For better managability a new routable VLAN (ID:20) added to our Router with IP 192.168.55.1 and SNET 255.255.255.0
    Next, I made the followings configurations in the autonomous AP through WEB Console:
    Static IP:192.20.10.35, SNET:255.255.254.0, GWY:192.20.10.200
    VLAN1 (Native) and VLAN20 (Radio0-802.11g) added into Services.
    I set the Encryption Mode to None for VLAN1 and Cipher AES CCMP for VLAN20
    Into Server Manager I defined a new RADIUS server 192.20.10.35 (AP IP) and a shared secret and left the default ports for Authentication and Accounting (1645 and 1646). Also, in Default Server Priorities section I set as Priotity 1 both for EAP and MAC authentication the Access Point IP (Radius Server) 192.20.10.35.
    In Local RADIUS Server General Set-Up, I add as current network access server (AAA client) the same IP and shared secret like the ones I use during RADIUS server configuration above. Into Enable Authentication Protocols I left checked only the LEAP and MAC. Also, into Individual Users section 2 new users created with text passwords.
    Into SSID Manager a new hidden SSID created for interface Radio0-802.11g, associated with VLAN20 and into Client Authentication Settings section I left as accepted Method Open Authentication with MAC authentication and EAP. Also, I left the Use Defaults option both for EAP and MAC Authentication Servers in Server Priorities Section and finally into Client Authenticated Key Management section I choose Mandatory for Key Management and checked the Enable WPA option.
    I can ping both the AP and VLAN20 IPs from any PC which is a member of the native VLAN
    As wireless clients I use 2 Motorola MC5574 with Windows Mobile 6.1 professional. Both of them have a Jedi WLAN adapter configured with the followings:
    IPs:192.168.55.10 and 192.168.55.11
    SNET:255.255.255.0
    GWY:192.168.55.1
    Also, a unique profile has been created on each one of them to be used for AP association-authentication. Each profile has been configured for WPA2 Enterprise with AES and LEAP and the predefined user credentials (those defined into AP for Individual Users)
    The problem:
    Clients association with AP is always succesful but, Authentication fails and I can't ping from the clients AP IP,  VLAN20 IP, neither each other.
    What am I missing here? I'm sure that it is somenthing quite simple but although I tried several different setups (i.e. WPA2-PSK, WPA-PSK even with TKIP) I always end up without a proper solution for ping inability.
    Thank you in advance for any help

    Hello Madhuri,
    below is the latest run config output from the access point
    Building configuration...
    Current configuration : 3743 bytes
    ! Last configuration change at 03:56:04 +0200 Sun Nov 28 2010 by Cisco
    ! NVRAM config last updated at 03:58:07 +0200 Sun Nov 28 2010 by Cisco
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname RCT_THP_AP1
    enable secret 5 $1$26u0$emaUzNvvihCCZeKeooQ8M0
    aaa new-model
    aaa group server radius rad_eap
    server 192.20.10.35 auth-port 1645 acct-port 1646
    aaa group server radius rad_mac
    server 192.20.10.35 auth-port 1645 acct-port 1646
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    clock timezone +0200 2
    ip name-server 192.20.11.2
    dot11 ssid RCTHP
       vlan 20
       authentication open mac-address mac_methods eap eap_methods
       authentication key-management wpa
    power inline negotiation prestandard source
    username Cisco password 7 00271A150754
    username 00236867a192 password 7 101E594B56414A5D5B057B7276
    username 00236867a192 autocommand exit
    username 00236867a19b password 7 091C1E5B4A534F445C0D557329
    username 00236867a19b autocommand exit
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 20 mode ciphers aes-ccm
    ssid RCTHP
    channel 2462
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.20
    encapsulation dot1Q 20
    no ip route-cache
    bridge-group 20
    bridge-group 20 subscriber-loop-control
    bridge-group 20 block-unknown-source
    no bridge-group 20 source-learning
    no bridge-group 20 unicast-flooding
    bridge-group 20 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    shutdown
    no dfs band block
    channel dfs
    station-role root
    interface Dot11Radio1.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface FastEthernet0.20
    encapsulation dot1Q 20
    no ip route-cache
    bridge-group 20
    no bridge-group 20 source-learning
    bridge-group 20 spanning-disabled
    interface BVI1
    ip address 192.20.10.35 255.255.254.0
    no ip route-cache
    ip default-gateway 192.20.10.200
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    snmp-server view dot11view ieee802dot11 included
    snmp-server community public view dot11view RO
    snmp-server contact IS
    radius-server local
      no authentication eapfast
      nas 192.20.10.35 key 7 03130807055F2C1F
      user motomob1 nthash 7 15315B29557B0D767E111074455E332022000F0D0A725C223B300C7A0E760A0371
      user motomob2 nthash 7 075E716D6C2F49514636532A5C0B0A067C1567003224335553047F0C710058263E
    radius-server attribute 32 include-in-access-req format %h
    radius-server host 192.20.10.35 auth-port 1645 acct-port 1646 key 7 120E561B115B0157
    radius-server vsa send accounting
    bridge 1 route ip
    line con 0
    line vty 0 4
    sntp server 192.20.10.2
    sntp broadcast client
    end
    Regards
    Vasilis

  • Integration Builder: Configuration Integration Directory not start.

    Hello,
    After we patch PI from sp14 to sp 23 while we starting the Integration Directory, it result in the error "Unable to launch the application"while verifying the application:
    com.sun.deploy.net.JARSigningException: Could not verify signing in resource: http://<hostname>:port/dir/directory/aii_ibdir_sbeans.jar.
    we have jre 1.6.0_24.
    I get this error:
    com.sun.deploy.net.JARSigningException: Could not verify signing in resource: http://pint1.dlg.dk:50000/dir/directory/aii_ibdir_sbeans.jar
         at com.sun.deploy.cache.CacheEntry.writeManifest(Unknown Source)
         at com.sun.deploy.cache.CacheEntry.access$2000(Unknown Source)
         at com.sun.deploy.cache.CacheEntry$9.run(Unknown Source)
         at java.security.AccessController.doPrivileged(Native Method)
         at com.sun.deploy.cache.CacheEntry.writeFileToDisk(Unknown Source)
         at com.sun.deploy.cache.Cache.downloadResourceToTempFile(Unknown Source)
    Regards

    Hi,
    When I start Internet Explorer with this url http://port:50000/rep/start/Main.jsp
    I get this massage: on Additional Information   
    Webpage error details
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
    Timestamp: Mon, 28 Mar 2011 09:20:36 UTC
    Message: 'parent.InnerFr' is null or not an object
    Line: 61
    Char: 15
    Code: 0
    URI: http://port:50000/rep/start/XI.js
    Can it be reason I can not start * Integration Builder: Configuration Integration Directory*. And get this massages:
    com.sun.deploy.net.JARSigningException: Could not verify signing in resource: http://port:50000/dir/directory/aii_ibdir_sbeans.jar
    Any Help
    Regards

  • XCode wont find source code during debug

    My XCode project (an exernal target initially generated using GNU autotools, and imported into XCode) won't find the source code during debug.
    I'm sure this is a project setup issue, but i can't seem to figure out which setting i need to change.
    Any help is appreciated.
    Thanks

    Hi,
    make sure Debug symbols are generated! If you for example choose to debug while the project is set to "Release" mode (Project->Set Active Build Configuration), you will not get your code displayed and instead have to use the asm output of the debugger.
    If set to "Debug", XCode switches all necessary gcc... parameters for debugging.
    Volker

  • XCode target not displaying Code Signing Provisioning Profile

    Hello experts,
    I am first time uploading my application on the apple store. I downloaded distribution provisioning profile and placed that into home/library/Mobile Device/Provisioning Profiles.
    Opened xcode, created distributed configuration by duplicating release configuration.
    changed CODE SIGNING IDENTITY to IPhone Distribution: My company name
    next step is to set the CODE SIGNING PROVISIONING PROFILE but xcode not showing this option.
    The four options that i can see are:
    1) Code signing Entitlements
    2) Code signing identity
    3) Code signing resource rules path
    4) Other code signing flags
    NOT the "CODE SIGNING PROVISIONING PROFILE" parameter to set.
    What i need to check for this.
    I tried to upload my app without this setting but as i expected got the error:
    "The binary you uploaded is not valid or it was not signed by Apple Submission Certificate."
    Please help me to resolve this.
    Thanks in advance.

    thanks for replying
    i checked all the above mentioned steps.
    -> My Distibution Profile is present in Mobile Devices/Provisioning Profiles.
    -> Active SDK is Device
    -> Active Configuration is Distribution
    -> Bundle Identifier name is a simple five letter word without white spaces and special characters.
    The only thing my application is not having is the "Code Signing Provisioning Profile" option to set in the top-level getinfo window->build.
    here i am giving the link of my build settings for Distribution Configuration:
    http://reportingmanager.com/NevaGarments/ScreenShot/Picture.png
    please let me know what needs to be done.
    Thanks

  • Access/set dynamic configuration in client/server abap proxy

    Hi,
    I have 2 question regarding reading/setting dynamic configuration in ABAP proxies:
    1) Is it possible to set dynamic configuration objects in a server abap proxy (SAP --> XI)?
    When looking at the class CL_PROXY_FRAMEWORK is looks as if it is possible. This class has en attribute IF_XMS_MAIN~DY which is a reference to the class CL_XMS_MSGHDR30_DYNAMIC.
    I'm not sure if I'm supposed to try and access the dynamic configuration objects via this class or if I'm supposed to use the GET_PROTOCOL method in some manner as suggested by:
    http://help.sap.com/saphelp_nw04s/helpdata/en/51/d5cd16235e4643ae8ec92395c4ad97/frameset.htm
    Above link is for client proxies not server, and I've been unable to find any documentation on this for server proxies.
    2) The same question goes for server proxies (XI --> SAP), though now I would like to set some dynamic configuration data.
    This I believe should be done using get_protocol( if_wsprotocol=>ws_header ) as indicated by before mentioned link.
    However in both cases I'm not sure of if it is indeed possible and which road to choose for sure. So a hint or 2 would be really nice.
    Best Regards,
    Daniel
    ps. maybe I should just mention that I am pretty new to the ABAP world, so bear with me.

    The link that you gave does give you an example for both server and client proxies:
    Accessing Protocol Classes for Client Proxies
    In client proxies, you access the protocol class by using the GET_PROTOCOL method. Below is an example for the IF_WSPROTOCOL_PAYLOAD protocol:
    DATA:
    lo_clientProxy      TYPE REF TO co_clientProxy,
    lo_payload_protocol TYPE REF TO if_wsprotocol_payload
    lo_payload          TYPE REF TO if_ws_payload.
    CREATE OBJECT lo_clientProxy.
    Get Protocol Class Using Method GET_PROTOCOL
    lo_payload_protocol ?=
           lo_clientProxy->get_protocol( if_wsprotocol=>payload ).
    CALL METHOD lo_clientProxy->execute_synchronous
                EXPORTING output  = ls_request
                IMPORTING input   = ls_response.
    Use Protocol Methods
    lo_payload = lo_payload->get_sent_request_payload( ).
    Accessing Protocol Classes for Server Proxies (XI Only)
    Within the implementation of a server proxy, you get the protocol class by using the CL_PROXY_ACCESS=>GET_SERVER_CONTEXT( ) method:
    DATA:  lo_server_context   TYPE REF TO if_ws_server_context,
           lo_payload_protocol TYPE REF TO if_wsprotocol_payload.
    lo_server_context   = cl_proxy_access=>get_server_context( ).
    lo_payload_protocol =
         lo_server_context->get_protocol( if_wsprotocol=>payload ).

  • "error in accessing Star office configuration data"

    Hi I'm posting this on behalf of someone who has Star Office 7 pre-installed on their PC. They are no longer able to open Star Office and are getting the message in the title above. Their message to me is below:
    the exact message is Star office cannot be started due to
    an error in accessing Star office configuration data
    It is not a trial version it was with the comuter when I bought it from Aldi.
    It is Version 7 Star Office. I have not recently added any more programs, or changed the way i am running the computer.
    I cannot find this issue reported in the forum. i have found a similar open office issue in the faq.
    OpenOffice.org fails to start, and the following error message appears:
    OpenOffice can not be started due to an error in accessing the OpenOffice.org configuration data.
    Please contact your system administrator.
    The following internal error has occurred: Get Storage: "No Content".
    The message often occurs because a file named Common.xcu becomes corrupted. In most cases, this file becomes filled with 0s. The problem seems to occur most often in Windows, possibly as a result of a crash or an improper exit while OpenOffice.org was open.
    http://documentation.openoffice.org/faqs/various_topics/019.html
    are they comparable? if so, could someone advise on transfering the recommended action to Star Office 7? Thanks! Nick

    Thursday 15 February 2007
    I am assuming that you are referring to a Windows system.
    SO7 and OOo1.1.x are based on the same OOo build series - 645. Most of the time comments about one apply to the other, except in the case of SO7 commercial addons. (SO8 is 680).
    The error message indicates that their is corruption in some kind in the User data found in
    \StarOffice7\User.
    The easy way to fix it is to back up the User folder, then delete it and let SO7 rebuild the user data.
    You can try backing up and deleting Common.xcu only--it's found in two places, in both the Share and User folders.
    \registry\data\org\openoffice\Office
    I suspect the one in Share is used for the creation of the one in User, but I am not sure.
    Phil

  • Accessing JAXR registry from within web service

    Hi I'm having trouble accessing the registry from within a web service running in the tomcat server.
    The service should register with the registry at startup, but in the logs from the tomcat server I can see that a JAXRException is thrown:
    javax.xml.registry.JAXRException: Unable to create ConnectionFactory: Provider com.sun.xml.registry.common.ConnectionFactoryImpl not found
         at javax.xml.registry.ConnectionFactory.newInstance(Unknown Source)
    If I run the program from outside the tomcat server as a standalone program, it registers perfectly.
    I believe the problem is that it is missing one or more jars.
    I have tried to put the jaxr-jars under shared/libs but that hasn't solved the problem.
    Has anyone an idea of what I'm doing wrong?
    Help is greatly appreciated!
    / Bo

    Hi swatdba
    I know that the build file states alle the packages that I need, and as I said, if I run my program like the regular JAXR examples, it works fine.
    The thing is, the JAXR examples are not web services on their own. They are merely Java programs that access the registry.
    In my case I am building a web service that should run in the tomcat server. When it initialises, it should register with the register, and also be able to search for other web services.
    I thought this would be possible per default, ie. the jars that the web service needs should already be available in the tomcat server, but it doesn't work. I have tried to put the jars that I've found in the build script in the folder C:\jwsdp-1.3\shared\lib, which according to the tomcat manual should be used to put jars that you want to share between your web services.

  • Access Report Custom Functions from code

    Post Author: leedo
    CA Forum: .NET
    Hello,
    I am using VS2005 (VB) and was able to change formula text from within code using the "FormulaFieldDefinitions" object. However, I am having problems finding out how I can do the same to Report Custom Functions.  The reason I am doing all this is that I noticed during my Windows app is running the source of my .rpt file is thrown in the user "Local Settings\Temp" folder and all code is revealed by simply opening that file. Please help. ThanksLeedo

    Post Author: MJ@BOBJ
    CA Forum: .NET
    It looks like it is not possible to access the custom functions within a report using the CR .NET SDK.  However, to address the potential security issue that you may be concerned about, is this a Windows or ASP.NET application?  If this is an ASP.NET application, then you shouldn't have to worry about the security as the end-user (client) will not be able to access that folder since the rest of the web server is typically unaccessible by the client. 
    Another way to secure your reports is to use what we call "managed reporting" solutions such as Crystal Report Server or Business Objects Enterprise, which manages reports securely and your users are only allowed to access/see what you allow them to.  These solutions also provide public SDKs so you could incorporate the system into your own applications.  For more information, go to www.businessobjects.com/products.

  • Build blazeDS source code

    After I set the dev-environment, I started build the source code.
    >> ant main
    BUILD FAILED
    F:\tmp\blazeds_src_3-0-0-544\build.xml:68: The following error occurred while executing this line:
    F:\tmp\blazeds_src_3-0-0-544\modules\common\build.xml:100: Unable to rename old file (F:\tmp\blazeds_src_3-0-0-544\lib\flex-messaging-common.jar) to temporary file
    But it successed when I built the code in other way.
    >> ant clean
    >> ant sdk
    >> ant common
    >> ant common
    What's wrong?

    The problem is not with Ant, but with Windows, which is more strict in allowing files to be deleted that Unix.  Seems that the build script isn't being tested very thoroughly in Windows.  Something is still accessing that jar (possibly ant itself) while ant is trying to rename the jar.
    My workaround was to break the build process up into 3 steps, to allow whatever is holding the jar up to let go of it.  I added these targets to the main build file, and removed the dependency on the jar target from the postbuilds target in both common and core build files.  Then you have to manually call ant main1, ant main2, ant main3 and seems to work fine.

  • TS3899 I recently discovered that I can no longer access websites pointed to within the content of an email message on my iPad Air by clicking on the highlighted HTML text or symbols. What should I do to correct this issue?

    I recently discovered that I can no longer access websites pointed to within the content of an email message on my iPad Air by clicking on the highlighted HTML text or symbols. What have I done to create, and what should I now do to correct, this issue?

    Or you could include a width to your body style:
    body {
    background-image: url(Logo/sky1.jpg);
    background-position: center center;
    background-attachment: fixed;
    width: 75%;}
    It might work or not depending on your other color scheme.

  • Safari Error:cannot connect to server.Was able to click on all tabs within website many times,no issues.Now can't access the"shop" tab within website-What do I do Now?

    Safari and/or internet question:
    I have MacDeskTop W/Intel/OS X Lion 10.8.2   and Safari:Ver6.0.2(8536.26.17)
    Currently I am having a big issue to access within this website's the "SHOP section(tab)" I ca click on the tabs and read the info in each section, except for the "Shop" Tab.
    While in the process of paying for my items in my cart, I received a website message saying something
    To the affect that this website is being updated. Your items in your cart will be in your cart.
    Then the website's screen kicked me out the door.
    A few days later I accessed the main page of this website with no problem.
    I can read the information on the main web page pertaining to items I need to purchase, etc., with no problems.
    I click and maneuver from on one tab to another from the main page within this website with no issues.
    When I click on the "SHOP section(tab)" within this website to complete my purchase.
    Part of this website an error occurs on this "SHOP tab".
    "Safari can't connect to the server".
    Safari can't open the page "https://and the name of this website" because Safari can't connect to the server "www.the name of this website".
    I click on the reload from the view of the toolbar and I can't access this website's"Shop section(tab) at all.
    I e-mailed the webmaster of this website a few times, but no response.
    In the past I was able to access the "Shop section(tab") within this website many times to purchase items with no issues.
    Now I am at my wits end as I really need to complete my purchase from this website.
    I cannot purchase these items from other websites. Only this website.
    So, I really need anyone's tech expertise to help me access the "SHOP" tab within this website.
    I also have another website that i have visited numerous times within the last 6 months with no issues.
    Now I can't access this website at all.
    Safari error: "Safari can't connect to the server".
    I can't figure this out
    No issues with:
    * Comcast tech says that My modem, Wi-Fi connections are fine.
    * Cables and wires and Power strip unit to protect my electronics are fine
    * Utility bill is up to date.
    I have a Mac Desktop 23 inch screen (Purchased 01-01-2013)
                                                      Lion: OS X
                                                      Version 10.8.2
                                                      Processor: 2.7 GHz Intel Core i5
                                                      Memory: 8 GB 1600 MHz  DDR3
    I use Safari: Version 6.0.2 (8536.26.17)
    I use the Mail app that shows a postage stamp with the picture of an eagle 
                                                      It is the Version 6.2 (1499)
    I really need help access the "Shop section(tab)" of the website to complete my purchase.
    What is the next step to fix my dilemma?
    Thank-you all in advance with your expertise, and patience.
    Very Much Appreciated.
    With Kindest Regards
    Mac Desktop, OS X Mountain Lion (10.8), Safari: Version 6.0.2 (8536.26.17)

    Hi There Linc Davis,
    Wow, you are the best.
    Yip this is what the website looks like. Great job Linc Davis.
    Not surprised that the "Shop" tab is missing. Darn.
    Well can you try to access it's "sister" website: astralmusic.com and astralmusicshop.com?
    Since you are awesome with the "Flash" can you investigate if this website has a issue withis this "Flash" too?
    Please Linc Davis

  • Access Sequence for Plant/Tax code Combination  for JTAX

    Dear All
    i want to create a new access sequence for "Plant/Tax code" Combination.
    Please let me know the process for the same
    Regards
    Amey

    Hi,
    Goto- M/05.
    Create the condition table by selecting the fields Plant & Tax code.
    Assign this condition table in the Access sequence JTAX as per ur requirement.
    Create condition records (FV11) by choosing the requirec access sequence.
    Regards,
    Satpal

  • PI 7.1 Access to Dynamic Configuration through Java Class

    My Current scenario involves IDCO -> FILE communications in PI 7.1 using XSL where the file name is dynamic.
    I have attempted calling a Java Class from XSL with the use SAPXMLTOOL kit option set in the adaptor and it works but I need to be able to call the transform method
    public void transform(TransformationInput arg0, TransformationOutput arg1)
    from XSL so I can access the message and update the File Name via Dynamic Configuration.
    Whilst I can call a static class with in the object I can not call transform with the correct arguments (arg0, arg1). I need access to arg0 (payload) to set/figure out the filename. I can calculate the filename in XSL and pass it to the Java but in a static method it is useless as it need to access the arg0 which is a object and obviously non-static context.
    Is this possible ? How do I get access to Dynamic Configuration from XSL through Java in 7.1 ?
    I have successfully called a static method but that is no help.
    Thanks in advance.

    Suraj,
       Unfortunately you link isnt operational but thankyou anyway, I have managed to call as Java class as per my original post, but a static method does not allow me to get a handle to the Dynamic Configuration Variables in the message.
    It seems importing the 7.0 LIBS may be an option and Im not entirely sure I have that option.
    It certainly isnt possible to use the JDK5 XML implementation to even call a static method on an Java OBJ from XSL (obviously the USE SAPXMLTOOLKIT option is there for a reason).
    I think and again I could be wrong but direct access via XSLT..
    LINK:http://help.sap.com/saphelp_nwpi71/helpdata/EN/e2/e13fcd80fe47768df001a558ed10b6/frameset.htm
    Is what Im looking for, I shall report back success or failure but the doco seems to fit the bill. Im not sure why I wanted to instatiate a sperate Java class when it can all exist in the XSLT.

Maybe you are looking for