Address-family ipv4

Hi,
I want to understand VPNV4 and IPV4 address family.
when looking our PE router under the VPNV4 address family we have 4 commands
address-family vpnv4
 neighbor partial-table send-community both
 neighbor 1.1.1.1 activate
 neighbor 2.2.2.2 activate
 neighbor 3.3.3.3 activate 
The address’s above are our route reflectors obviously on different ip’s
Do you need this command to bring up the IPV4 address family? so the first thing to do is create your address-family vpnv4 then your IPV4 address family?

Hi James,
There are multiple options available when you configure BGP on cisco routers.
(config-router)#address-family ?
  ipv4   Address family
  ipv6   Address family
  nsap   Address family
  vpnv4  Address family
More options on new codes---
IPV4 is for V4 address,IPv6 for V6 address and VPN4 is to carry VPN routes when using MPLS. This is basically gives you more options to manage bgp configuration. By default all the neighbors under address family are disabled hence activate command is required.
You can define yours neighbors under normal BGP process with no bgp default ipv4-unicast which will disable default behavior of IOS to exchange IPV4 routes and later on you can activate that neighbor in address family you want to use for route exchange.
Thanks
Ajay

Similar Messages

  • Address family vpn4/ipv4 for EBGP

    What is the difference between "address family vpnv4" and address family ipv4", do I have to configure both for an EBGP session ?
    Thanks
    NK

    VPNv4 is used for the support of MPLS VPN as described by draft-ietf-l3vpn-rfc2547bis-03.
    http://www.ietf.org/internet-drafts/draft-ietf-l3vpn-rfc2547bis-03.txt
    IPv4 is for the support of regular ipv4 addresses.
    You may need to enable vpnv4 or/and ipv4 depending on what you want to do.
    Let me know if I answered your question,

  • Difference between address-family ipv6 and address-family ipv6 labeled unicast

    Hello Experts,
    Can someone explain me the difference between address-family ipv6 and address-family ipv6 labeled unicast. Per my understanding, i think both of them are used to send labelled IPv6 prefix advertisements through BGP..If so, are the following configs same?
    address-family ipv6
    neighbor 192.168.0.1 activate
    neighbor 192.168.0.1 send-label
    router bgp 10
    neighbor 192.168.0.1
    address-family ipv6 labelled unicast
    Please let me know if my understanding is correct
    Thanks
    Mukundh

    Thanks for the reply Nagendra...
    I have another related query regarding this. We have BGP neighborship flapping between 2 routers ...One is Cisco 7204 and another is Juniper M120 I think.... The Juniper logs show that BGP is flapped due to family inet6 not configured on the Juniper end and Juniper is receiving BGP advertisements with native IPv6 as next hop from Cisco when it shouldn't be receiving that.. The following are commands on Cisco and Juniper...
    ##### CISCO####
    outer bgp 5603
    neighbor 95.176.254.10 inherit peer-session LAR  neighbor 95.176.254.10 description --- M320-LAB-LJ-CIGALETOVA  address-family ipv4
      neighbor 95.176.254.10 activate
      neighbor 95.176.254.10 inherit peer-policy LAR-ipv4  address-family ipv6
      neighbor 95.176.254.10 activate
      neighbor 95.176.254.10 send-community both
      neighbor 95.176.254.10 route-reflector-client
      neighbor 95.176.254.10 send-label
    template peer-session LAR
      remote-as 5603
      update-source Loopback0
      timers 30 90
    exit-peer-session
    template peer-policy LAR-ipv4
      route-map LAR-ipv4-out out
      route-reflector-client
      soft-reconfiguration inbound
      send-community both
    exit-peer-policy
    ####JUNIPER####
    protocols{bgp{
    group I-BGP-IPV4 {
                type internal;
                family inet {
                    unicast;
                family inet6 {
                    labeled-unicast {
                        explicit-null;
                export RR-Export-All;
                neighbor 95.176.255.254 {
                    description C7201-RR-IP-CIGALETOVA;
                    local-address 95.176.254.10;
                neighbor 95.176.255.252 {
                    description C7201-RR-IP-CIGALETOVA;
                    local-address 95.176.254.10;
    By the cisco command above, shouldn't cisco be sending only labelled ipv6 prefixes or am I wrong in this. And if Cisco sends both unlabelled and labelled prefixes, is there a way to make it send only ipv6 prefixes?
    Thanks
    Mukundh

  • Conditional Route Advertisement - VRF Address Family?

    I would like to do conditional route advertisement within an IPv4 vrf address family but the "neighbor x advertise-map" command is not available within the vrf address family (at least in the code version I have). It is available in non-vrf address families.
    Command/Config reference guides do not show any limitations regarding the command. Before I upgrade code (which may not be possible with my current platform) I wanted to see if anyone is doing this or if there is another way to accomplish the same task.
    Thanks
    -Ed-

    Hi,
    are you talking about PE->CE or PE->PE/RR ?

  • Address family not supported by protocol family: bind

    Over the past few days a number of users have reported connection issues with our application. We've been able to track the problem to this line of code:
    ServerSocketChannel sc = ServerSocketChannel.open();
    sc.socket().bind(new InetSocketAddress("localhost", 0)); <- error thrown
    The following error is thrown:
    java.net.SocketException: Address family not supported by protocol family: bind
    sun.nio.ch.Net.bind(Native Method)
    sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
    sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
    sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
    I've read this is something to do with an IPv4 / IPv6 issue. But what I don't understand is that our users have had this working fine for months and we've never had any problems in the past, but within the last couple of days 10 people have contacted us, all with the same issue. We've not released any patches so we've not introduced the problem. Does anyone know what might have changed in the past few days? Did Microsoft release a patch to modify the IPv 4 / 6 protocols?
    Apparently the issue might be resolved in Java7, but we have thousands of users, and rolling out a new version of Java is a big upheaval.
    Any ideas???
    BBB

    It uses a JRE that is isolated for our application, so Java updates 'shouldn't' affect it. I have a sneaking suspicion that a Vista update may have changed something, but I can't be sure.
    I'm working through the problem with one of our users, and I've changed the code from:
    ServerSocketChannel sc = ServerSocketChannel.open();
    sc.socket().bind(new InetSocketAddress("localhost", 0));To
    ServerSocket sc = new ServerSocket();
    sc.bind(new InetSocketAddress("localhost", 0));This works and I'm able to get an available port. However, later in the code it runs this section of code to connect the socket:
         void connect() throws IOException, InterruptedException {
              int retry;
              for (retry = 0; retry < MAX_RETRY; retry++) {
                   try {
                        channel = SocketChannel.open();
                        channel.configureBlocking(false);
                        //connect to server
                        channel.connect(serverAddr);
                        //register events to listen
                        channel.register(selector, SelectionKey.OP_CONNECT);
                        while (!channel.isConnected()) {
                             if (selector.select(1) > 0) {
                                  Set readyKeys = selector.selectedKeys();
                                  Iterator i = readyKeys.iterator();
                                  while (i.hasNext()) {
                                       SelectionKey key = (SelectionKey) i.next();
                                       i.remove();
                                       SocketChannel keyChannel = (SocketChannel) key
                                                 .channel();
                                       if (key.isConnectable()) {
                                            if (keyChannel.isConnectionPending()) {
                                                 keyChannel.finishConnect();
                                            break;
                        break;
                   } catch (Exception e) {
                        channel.close();
                        channel = null;
                        try {
                             Thread.sleep(150);
                        } catch (Exception ex) {
              if (retry == MAX_RETRY) {
                   throw new InterruptedException("Maximum retry number reached!");
              channel.register(selector, SelectionKey.OP_READ);
         }It's now falling over on this line:
    channel.connect(serverAddr);
    java.net.SocketException: Address family not supported by protocol family: connect
    serverAddr is a InetSocketAddress, channel is a SocketChannel, which appears not to be supported on the machine that are having these connection issues.
    I'll be honest, I have little or no experience of implementing Sockets, and since I can't replicate the actual problem that our users are having it makes it even hard to fix it or try to code a workaround. The code above is from an OpenSource project, i.e. it's not something I wrote. In other words, I'm kinda up the 'proverbial creek'!
    Could anybody be kind enough to steer me in the right direction for a workaround that doesn't use a SocketChannel? It really would be appreciated!
    BBB

  • Difference between SAF service-family & address-family

    Hello, I cant seem to find a simple definition of the difference between SAF service-family & address-family.
    Could someone please explain these two terms.
    Thanks kindly.

    In addition to the above ...
    Rollup Patch (RUP): An aggregation of patches that may be at the functional level, or at a specific product/family release level. For example, a Flexfields rollup patch contains all the latest patches related to Flexfields at the time the patch was created. A Marketing Family 11.5.10 rollup patch contains all the latest Marketing patches released since, and applicable to 11.5.10
    Family Pack: An aggregation of patches at the product family level. Family product codes always end in "_PF" and family packs are given alphabetical sequence such as 11i.HR_PF.B, 11i.HR_PF.C, and 11i.HR_PF.D. Family packs are cumulative. In other words, Discrete Manufacturing Family Pack G (11i.DMF_PF.G) contains everything in 11i.DMF_PF.F, which contains everything in 11i.DMF_PF.E, and so on.
    If you search the rollup patch thru Metalink, it would tell you whether it is included in any other patchset (i.e. Family Pack) or not.

  • Ffserver can't start. (Address family not supported by protocol)

    Does anyone can successfully use the latest ffserver from Arch ? It refuse to start and give me the "Address family not supported by protocol"  on my system.
    The ffserver error message is:
    $ ffserver -f ./ffserver.conf
    ffserver version 0.7.6, Copyright (c) 2000-2011 the FFmpeg developers
    built on Oct 3 2011 13:04:32 with gcc 4.6.1 20110819 (prerelease)
    configuration: --prefix=/usr --enable-libmp3lame --enable-libvorbis --enable-libxvid --enable-libx264 --enable-libvpx --enable-libtheora --enable-postproc --enable-shared --enable-x11grab --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libschroedinger --enable-libopenjpeg --enable-librtmp --enable-gpl --enable-version3 --enable-runtime-cpudetect --disable-debug
    libavutil 50. 43. 0 / 50. 43. 0
    libavcodec 52.122. 0 / 52.122. 0
    libavformat 52.110. 0 / 52.110. 0
    libavdevice 52. 5. 0 / 52. 5. 0
    libavfilter 1. 80. 0 / 1. 80. 0
    libswscale 0. 14. 1 / 0. 14. 1
    libpostproc 51. 2. 0 / 51. 2. 0
    bind(port 8090): Address family not supported by protocol
    and the ffserver.conf is just as simple as follows:
    Port 8090
    # bind to all IPs aliased or not
    BindAddress 127.0.0.1
    # max number of simultaneous clients
    MaxClients 1000
    # max bandwidth per-client (kb/s)
    MaxBandwidth 10000
    # Suppress that if you want to launch ffserver as a daemon.
    NoDaemon
    <Feed feed1.ffm>
    File /tmp/feed1.ffm
    FileMaxSize 800M
    </Feed>
    <Stream status.html>
    Format status
    </Stream>
    <Stream test.swf>
    Feed feed1.ffm
    Format swf
    VideoCodec flv
    NoAudio
    # Audio bit rate at 16 instead of 44 reduces bandwidth a lot! ;)
    # AudioBitRate 16
    # idem for sample rate
    # AudioSampleRate 22050
    # Bitrate for the video stream: QUADRATAZZI
    VideoBitRate 90
    # Ratecontrol buffer size, non esagerare, meno e' meglio (?!?)
    VideoBufferSize 1000
    # Number of frames per second: SCATTICAZZI
    VideoFrameRate 3
    #VideoQMin 1
    #VideoQMax 5
    VideoSize 352x288
    PreRoll 15
    #Noaudio this if you want video only
    </Stream>
    some basic info on my system is:
    $ pacman -Q ffmpeg linux glibc
    ffmpeg 20111003-1
    linux 3.0.6-2
    glibc 2.14-6
    Any help is welcome.

    Does anyone can successfully use the latest ffserver from Arch ? It refuse to start and give me the "Address family not supported by protocol"  on my system.
    The ffserver error message is:
    $ ffserver -f ./ffserver.conf
    ffserver version 0.7.6, Copyright (c) 2000-2011 the FFmpeg developers
    built on Oct 3 2011 13:04:32 with gcc 4.6.1 20110819 (prerelease)
    configuration: --prefix=/usr --enable-libmp3lame --enable-libvorbis --enable-libxvid --enable-libx264 --enable-libvpx --enable-libtheora --enable-postproc --enable-shared --enable-x11grab --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libschroedinger --enable-libopenjpeg --enable-librtmp --enable-gpl --enable-version3 --enable-runtime-cpudetect --disable-debug
    libavutil 50. 43. 0 / 50. 43. 0
    libavcodec 52.122. 0 / 52.122. 0
    libavformat 52.110. 0 / 52.110. 0
    libavdevice 52. 5. 0 / 52. 5. 0
    libavfilter 1. 80. 0 / 1. 80. 0
    libswscale 0. 14. 1 / 0. 14. 1
    libpostproc 51. 2. 0 / 51. 2. 0
    bind(port 8090): Address family not supported by protocol
    and the ffserver.conf is just as simple as follows:
    Port 8090
    # bind to all IPs aliased or not
    BindAddress 127.0.0.1
    # max number of simultaneous clients
    MaxClients 1000
    # max bandwidth per-client (kb/s)
    MaxBandwidth 10000
    # Suppress that if you want to launch ffserver as a daemon.
    NoDaemon
    <Feed feed1.ffm>
    File /tmp/feed1.ffm
    FileMaxSize 800M
    </Feed>
    <Stream status.html>
    Format status
    </Stream>
    <Stream test.swf>
    Feed feed1.ffm
    Format swf
    VideoCodec flv
    NoAudio
    # Audio bit rate at 16 instead of 44 reduces bandwidth a lot! ;)
    # AudioBitRate 16
    # idem for sample rate
    # AudioSampleRate 22050
    # Bitrate for the video stream: QUADRATAZZI
    VideoBitRate 90
    # Ratecontrol buffer size, non esagerare, meno e' meglio (?!?)
    VideoBufferSize 1000
    # Number of frames per second: SCATTICAZZI
    VideoFrameRate 3
    #VideoQMin 1
    #VideoQMax 5
    VideoSize 352x288
    PreRoll 15
    #Noaudio this if you want video only
    </Stream>
    some basic info on my system is:
    $ pacman -Q ffmpeg linux glibc
    ffmpeg 20111003-1
    linux 3.0.6-2
    glibc 2.14-6
    Any help is welcome.

  • Need Configuration example for DS-LITE ( Tunneling IPv4-IPv6)+NAT44.

    Hi,
    I need to understand DS-LITE with configuration example. Can anyone please help me out?
    Regards,
    RA

    Hi Rahul,
    DS-Lite is only supported on the CGSE in CRS and on the ISM in the ASR9k. Here is a sample config that might help you to understand.
    RP/0/RSP0/CPU0:router(config)#
    interface te0/0/0/0
    ipv6 add 2001:db8:ff00::1/64
    interface te0/1/0/0
    ipv4 add 192.168.100.1/24
    interface ServiceApp61
    ipv6 address 2001:db8:1::1/64
    service cgn demo service-type ds-lite
    interface ServiceApp41
    ipv4 address 192.168.1.1 255.255.255.252
    service cgn demo service-type ds-lite
    service cgn demo
    service-type ds-lite dslite-1
    map address-pool x.y.z.0/24
    aftr-tunnel-endpoint-address 2001:db8:ffff::1
    address-family ipv4
       interface ServiceApp42
    address-family ipv6
       interface ServiceApp41
    router static
    address-family ipv4 unicast
    x.y.z.0/24 ServiceApp42
    address-family ipv6 unicast
    2001:db8:ffff::1/128 ServiceApp41
    regards

  • MPLS migration from IPv4 and IPv6

                       Hello,
    i have existing MPLS VPN setup using IPv4 between all devices (P,PE,CPE), i want to start to migrate to IPv6 but i want to start the migration for one link between P and PE and all other devices will be the same (IPv4). Can you please tell me how i can acheive this scenario without impcat the services because is life.
    Thanks

    Dear All,
    when i configured IPv6 between PE and CPE the neighbor between them is idle the following the configuration between PE and CPE:
    PE:
    router bgp 100
    bgp router-id 10.200.200.3
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor MPLS-Group peer-group
    neighbor MPLS-Group remote-as 100
    neighbor MPLS-Group update-source Loopback0
    neighbor MPLS-Group-IPV6 peer-group
    neighbor MPLS-Group-IPV6 remote-as 100
    neighbor MPLS-Group-IPV6 update-source Loopback0
    neighbor 10.200.200.5 peer-group MPLS-Group
    neighbor 2002:10:200:200::5 peer-group MPLS-Group-IPV6
    address-family ipv4
      no synchronization
      no auto-summary
    exit-address-family
    address-family vpnv4
      neighbor MPLS-Group send-community both
      neighbor MPLS-Group next-hop-self
      neighbor 10.200.200.5 activate
    exit-address-family
    address-family vpnv6
      neighbor MPLS-Group-IPV6 send-community both
      neighbor MPLS-Group-IPV6 next-hop-self
      neighbor 2002:10:200:200::5 activate
    exit-address-family
    address-family ipv4 vrf TEST
      no synchronization
      redistribute connected
      neighbor 10.225.0.2 remote-as 101
      neighbor 10.225.0.2 activate
    exit-address-family
    address-family ipv6 vrf TEST
      redistribute connected
      no synchronization
      neighbor 2002:10:225::2 remote-as 101
      neighbor 2002:10:225::2 activate
    exit-address-family
    ipv6 router ospf 200
    router-id 10.200.200.3
    log-adjacency-changes
    mpls ldp router-id Loopback0
    CPE:
    interface Loopback0
    ip address 10.225.100.1 255.255.255.255
    ipv6 address 2002:10:225:100::1/128
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex half
    interface GigabitEthernet1/0
    ip address 10.225.0.2 255.255.255.252
    negotiation auto
    ipv6 address 2002:10:225::2/126
    router bgp 101
    no synchronization
    bgp router-id 10.225.100.1
    bgp log-neighbor-changes
    network 10.225.100.1 mask 255.255.255.255
    neighbor 10.225.0.1 remote-as 100
    neighbor 2002:10:225::1 remote-as 100
    no auto-summary
    address-family ipv6
      no synchronization
      network 2002:10:225:100::1/128
      neighbor 2002:10:225::1 activate
    exit-address-family
    CPE-1#show ip bgp summary
    BGP router identifier 10.225.100.1, local AS number 101
    BGP table version is 4, main routing table version 4
    2 network entries using 242 bytes of memory
    2 path entries using 104 bytes of memory
    3/2 BGP path/bestpath attribute entries using 228 bytes of memory
    1 BGP AS-PATH entries using 24 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 598 total bytes of memory
    BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.225.0.1      4   100       6       5        4    0    0 00:01:50        1
    2002:10:225::1  4   100       0       0        0    0    0 never    Idle
    and i received this error:
    *Nov 24 15:40:17.715: %BGP-5-ADJCHANGE: neighbor 2002:10:225::2 vpn TEST                                                                                        Up
    *Nov 24 15:40:19.079: %BGP-5-ADJCHANGE: neighbor 10.225.0.2 vpn vrf TEST Up
    *Nov 24 15:40:23.067: %BGP-3-NOTIFICATION: sent to neighbor 2002:10:225::2 passi                                                                                        ve 2/8 (no supported AFI/SAFI) 3 bytes 000101
    Thanks

  • VPNv4 aggregate address

    Hi,
    I am trying to reduce the routing table to our PE's which are currently 3750ME's. The 3750ME's only come with 128MB of DRAM so I am keen to reduce the size of the routing table amongst other things. Is there an equivalent to the aggregate-address ipv4 address family (within bgp) command for vpnv4 routes? Essentially I would like to filter, summarise or add default routes facing the PE's where possible. Being able to perform this level of granularity per vrf instance would be ideal.
    I had read somewhere that vpn4 automatically summarises between P's and PE's but I wasn't 100% confident on the source of this information.

    there's no auto summarization, in fact your P routers shouldn't be running BGP and they shouldn't see any VPNv4 prefixes. There's no aggregate-address command under "address-family vpnv4", you put it under "address-family ipv4 vrf x". In other words, you summarize routes coming in from CE's in a VRF. Use "summary-only" keyword. It will result only in a summary vpnv4 route sent to other PE's

  • I need an advice in full connectivity between IPV4-IPV6 network

    Hi , 
    i have a network topology as attached.
    as you see it has both ipv4 & ipv6
    i just need an ideas here about how let all pcs (ipv4 & ipv6) to talk together based on the topology attached.

    Hello Ahmed,
    You can use BGP with address-family ipv4 to provide routing for ipv4 and address-family ipv6 for ipv6.
    This means between your router's you will have 2 BGP peerings, one for v4 one for v6.
    If you use the ipv4 address for bgp address-family ipv6, you will have to apply a route-map on neighbor to change the next hop address to the relevant ipv6 interface address.
    hth
    Bilal
    CCIE #45032

  • BGP IPV4 soo community

    Hi Guys ,
    how can i configure bgp soo community in IPV4 network enviorment ? i have BGP IPv4 running in my network . no vrf's no vpnv4 bgp.. Simple IPv4 BGP with some IBGP and EBGP peers.i wanna advertise a network with soo community . how could i do this. any ideas please. and how can i verify that soo community is being advertised ..
    here is what i tried.
    address-family ipv4
    neighbor x.x.x.x activate
    neighbor x.x.x.x send-community both
    neighbor x.x.x.x next-hop-self
    neighbor x.x.x.x activate
    neighbor x.x.x.x send-community both
    neighbor x.x.x.x route-map med out
    no auto-summary
    network 10.1.75.0 mask 255.255.255.0 route-map extendcom
    exit-address-family
    route-map extendcom permit 30
    set extcommunity soo 1001:1001
    regards
    amit

    hello Amit,
    see the answers in WAN ... forum
    Best Regards
    Giuseppe

  • Advertising ipv4 routes via ipv6 bgp peers

    Hello,
    I have established IPV6 bgp sessions with ipv6 prefix-list filter. But ipv4 routes were advertised over this bgp session. Do I I need special configuration under address family or ipv4 prefix-list filters required ?
    Note : the config was  IBGP between 7200 routers and 6509 core switches.
    Thank you all
    Nael

    Hi Nael,
    This is because address-family ipv4 unicast gets activated by default when you configure a new neighbor in BGP. You either need to configure "no bgp default ipv4-unicast" or go under address-family ipv4 unicast and do a "no neighbor" for the ipv6 neighbor.
    Hope this helps

  • InterAS MPLS Option C (BGP IPv4 + Labels) IOS XR with eBGP multihop session

    Hello,
    Right now we have InterAS MPLS Option C configured between 2 autonomous systems.
    Now we need to add more bandwith and would like to add another interface between the two routers establishing a multihop session using loopbacks to load share traffic.
    I know that IOS-XR does not automatically learn directly connected host routes so for the XR router to assign labels you'll need to configure a static host route to ensure MPLS forwarding to the neighboring AS.
    This works with directly connected neighbors but when I try to enable the multihop session, the XR does not assign labels even configuring the staic host route.
    Does anybody has a configuration like that working?
    Thanks!!
    Jose.

    Hello Jose
    There are basically two options in Option C L3VPN setup. I will discuss the first option for Multihop.
    Following are the key points that distinguish the InterAS Option C from previous options.
    1) External Multihop BGP address families are invoked between two different autonomous systems; however, these eBGP sessions are invoked between the route reflectors in each AS and not on the ASBR. The route reflector in each AS thus passes labeled ipv4 unicast VPN routes to the other AS. Note:- The route reflector in this case will have PE clients in the vpnv4 address family within that Autonomous System.
    2) ASBRs facilitate the creation of InterAS LSP by providing labeled /32s for PE and Route Reflector loopback.
    3) This option enhances scalability because ASBRs do not handle VPNv4 routes in fact this option gets rid of the extra L3VPN LFIB that is created as a result of option B . The LFIB size is minimal as we control the redistribution to the only 2 needed loopback addresses (remote ASBR and remote RR)
    Sample config of the RR:
    router bgp 102
    address-family ipv4 unicast
    address-family vpnv4 unicast
    neighbor-group ibgp
      remote-as 102
      update-source Loopback0
      address-family ipv4 unicast
       route-reflector-client
      address-family vpnv4 unicast
       route-reflector-client
    neighbor 192.168.253.3
      remote-as 101
      ebgp-multihop 255
      description eBGP-RR-PEER-AS101
      update-source Loopback0
      address-family vpnv4 unicast
       route-policy allow-all in
       route-policy allow-all out
       next-hop-unchanged
    neighbor 192.168.254.1
      use neighbor-group ibgp
    neighbor 192.168.254.3
      use neighbor-group ibgp
    neighbor 192.168.254.4
      use neighbor-group ibgp
    On the PE router, the config will look something like this:
    router bgp 102
    address-family ipv4 unicast
      redistribute ospf 1 metric 3333 route-policy interAS-optionc-out
      allocate-label route-policy interAS-optionc-out
    neighbor 65.10.20.1
      remote-as 101
      address-family ipv4 labeled-unicast
       route-policy interAS-optionc-in in
       route-policy interAS-optionc-out out
    neighbor 192.168.254.2
      remote-as 102
      update-source Loopback0
      address-family ipv4 unicast
    router static
    address-family ipv4 unicast
      65.10.20.1/32 TenGigE0/0/0/1
      192.0.2.0/24 Null0 tag 10
    route-policy interAS-optionc-in
      if destination in remote-RR-PE then
        pass
      else
        drop
      endif
    end-policy
    route-policy interAS-optionc-out
      if destination in local-RR-PE then
        pass
      else
        drop
      endif
    end-policy
    prefix-set local-RR-PE
      192.168.254.2/32,
      192.168.253.6/32,
      192.168.253.5/32
    end-set
    prefix-set remote-RR-PE
      192.168.253.2/32,
      192.168.253.3/32,
      192.168.253.3/32
    end-set
    Just for your clarification, 192.168.253.0/24 is the Remote AS networks and 192.168.254.0/24 is the local AS networks.
    Hope this clarifies your doubts.
    Cheers ... !!!
    Vinit

  • Multi-Instance BGP

    BGP Multi-instance was supposed to be released in XR 4.2, I could not find any mention of it in the Release notes for 4.2, 4.3, & 5.1?
    How do I find out if it was implemented and if so how to configure it, if not if it is still on the road map?
    Thanks,
    John

    Hello,
    It is in release note XR .4.2:
    http://www.cisco.com/en/US/docs/routers/asr9000/software/asr9k_r4.2/general/release/notes/reln_a9k_42.html
    And some writing on Cisco doc:
    http://www.cisco.com/en/US/docs/routers/crs/software/crs_r4.2/routing/configuration/guide/b_routing_cg42crs_chapter_01.html#concept_E6B1D3D6B8CA4742AED837B3A94E826F
    Below is the example what i did in my lab running 4.2.3:
    RP/0/RSP1/CPU0:ASR-9006-01#show run router bgp
    Fri Jan 31 21:05:02.170 UTC
    router bgp 1 instance IPV4
    bgp router-id 72.15.48.5
    bgp graceful-restart
    ibgp policy out enforce-modifications
    address-family ipv4 unicast
      redistribute connected
      allocate-label all
    address-family vpnv4 unicast
      retain route-target all
    neighbor 172.16.8.3
      remote-as 1
      update-source Loopback0
      address-family ipv4 labeled-unicast
       route-policy PASS in
       route-policy PASS out
    router bgp 1 instance IPV6
    bgp router-id 99.2.3.4
    address-family ipv6 unicast
      redistribute connected
    thanks,
    rivalino

Maybe you are looking for

  • Encountered an unexpected error

    Hi to All, I m using jdeveloper 10.1.3.3.0.3 version. And, i m beginner for jdeveloper, currently i design Hello Page and when i run it gives error "You have encountered an unexpected error. Please contact the System Administrator for assistance. " a

  • Xorg.conf trouble

    List of my xorg.conf: Section "Device" Identifier "AMD LX800 onboard video card" Driver "geode" BusID "PCI:0:1:1" Option "FlatPanel" Option "NoCrtEnable" Option "Accel" Option "ShadowFB" EndSection Section "Screen" Identifier "Default Screen" Device

  • ABAP / Query to Identify Duplicate Rows in Cube

    Dear Experts, We have a situation were some of our Cubes (due to compression and varying levels of forceful reloads) now contain duplicate rows. What I need to know is :- 1) Is there a way to identify duplicate rows where one of the characteristics a

  • Is there any documentation that explains CUCM version nomenclature?

    That is what is the difference between CUCM 6.1.3(b) and CUCM 6.1.3.3000 -1 ?

  • While using email why won't the cursor drop down into the compose area of the email

    While using my default browser firefox, I am unable to type in the "compose" section. I can type the address I want to send to and the subject but after that my cursor will not show up in the compose section. The cursor just will not go there. If I c