Bandwidth managment/limiting on ME3400

This is crazy long, but please bear with me.
My goal is basically to provide tiers of service ie. 3Mb down 512k up or 1Mb down 256k up.
I'm able to set the upload rate just fine by applying the following.
ip access-list extended matchanyacl
permit ip any any
class-map match-all alltraffic
match access-group name matchanyacl
policy-map 384up
class alltraffic
police cir 384000
conform-action transmit
exceed-action drop
interface range FastEthernet0/2 - 24
service-policy input 384up
However when I'm working with setting the user's download speed I've attempted to use a similar setup
policy-map 1540down
class alltraffic
police cir 1576500
conform-action transmit
exceed-action drop
but when I apply it to the interface it gives me this error.
Configuration Failed. Can not have ACL based classification in a class-map within an output policy-map
So I changed from matching an ACL to just having the class-map match anything
class-map match-all alltraffic
match any
policy-map 1540down
class alltraffic
police cir 1576500
conform-action transmit
exceed-action drop
but after I apply it to an interface I get this error.
QoS: Configuration failed. Priority action is required with a policer in an output policy 1540down
So I added the priority command so that the policy looks like this.
policy-map 1540down
class alltraffic
police cir 1576500
conform-action transmit
exceed-action drop
priority
but when I apply it to the interface I get the following error
Match any is not supported for this interface
So I change the match any to a match protocol ip (which to me is basically any)
class-map match-all alltraffic
match protocol ip
policy-map 1540down
class alltraffic
police cir 1576500
conform-action transmit
exceed-action drop
priority
but I get this message
Match protocol is not supported for this interface
So I changed my tactics and tried to use shaping instead of policing.
policy-map 1540down
class class-default
shape average 1576500
but when I apply this as an output policy to the interface I receive the following error.
QoS: Configuration failed. The configured rate 1576500 bps is not achievable in hw within 1% of configuration.
Closest value(s) are: 11111120 bps, 5882368 bps
So I switched back to policing for one final go at it. And I seem to have made it to a working configuration, but I wanted to get some extra input about whether or not this is even the best way to accomplish this. I switched to tagging traffic when it comes in on my uplink interface and setting it to a qos-group x and then matching that qos-group in my policy for later policing as an output policy.
ip access-list extended matchanyacl
permit ip any any
class-map match-all uplink
match access-group name matchanyacl
class-map match-all alltraffic
match qos-group 75
policy-map 1540down
class alltraffic
police cir 1576500
conform-action transmit
exceed-action drop
priority
policy-map uplinktag
class uplink
set qos-group 75
interface FastEthernet0/1
desc ## uplink port ##
service-policy input uplinktag
interface range f0/2 - 24
Desc ## User ports ##
service-policy output 1540down
Does anyone have any input or know of a better method to achieve my goal? Thanks for looking.

The egress side has got some problems with it. The way I worked it out was, I did Ingress/Ingress policing only with a child parent relationship of policies.
This allows me to get as granular as I want, without having to worry about out of hardware spec or port speeds. I can have a 1gig handoff, and rate shape down as low as I want. Just also as a side note, Cisco scolded me for limiting below 5mbs and said the box wasnt really designed to go that low.
Anyways, here is a sample config. Just change the values as you want:
class-map match-all cust-vlan
match vlan 201
class-map match-all mgmt-vlan
match vlan 1
policy-map MGMT
class class-default
police cir 10000000
conform-action transmit
exceed-action transmit
policy-map cust-child
class class-default
police cir 6000000
conform-action transmit
exceed-action drop
policy-map provider
class mgmt-vlan
service-policy MGMT
class cust-vlan
service-policy cust-child
interface GigabitEthernet0/4
description uplink
service-policy input provider
interface gig0/1
description customer interface
service-policy input cust-child
Hope this helps!

Similar Messages

  • ME3400E egress bandwidth management

    With help from this site, I was able to figure out ingress bandwidth management on a per port basis, but now I need to be able to configure egress bandwidth management.  I think I need to do traffic shaping but am not sure.  I was told that if you configure the bandwidth management using a percentage, that it doesnt' use the actual negotiated (or configured) port speed, but looks at the bandwidth interface command - is this true?  If a port is set to autonegotiate, and comes up as a GigE port, but the bandwidth command is set to 100Mbps, if you configured the egress shaping to 10% would that set it to 100Mbps or 10Mbps?  We are using the ME3400E to provide internet access to our customers - egress bandwidth management is very important !

    We had the same problem. Rate Control didn't seem to work.
    I discovered that after changing the rate control settings and saving these settings the router needs a reboot.
    Otherwise the rate control does not work anymore and the bandwidth is not managed.
    Whenever something is modified in the rate control settings you have to reboot the router.

  • Bandwidth Management for Software

    Is there a utility out there that would allow you to allocate specific amounts of bandwidth any software could use? In many download managers (such as Speed Download, Limewire, Azul, etc.) you can easily set the total amount of bandwidth and even per file download parameters. I have always been surprised that browsers such as Safari and even iTunes does not allow you to control the amount of bandwidth it is to use when downloading.
    I often find myself in situations where I need to download a large file, and yet be able to continue to surf for example, or else I would like to keep the setting in my iTunes to download podcasts automatically when I launch it. Both Safari and iTunes, will take as much bandwidth as you can throw at them which means that it can grind every other on line activity to a halt (specially when you do not have a blazing fat connection).
    Anyone know of any such software?
    Thanks.

    Shahin wrote:
    Thanks, but I don't understand what this has to do with bandwidth management? Perhaps I do not understand the capabilities of nice, but isn't nice just a way to prioritize applications and services? How would you use it to allocate bandwidth?
    By giving various jobs different priorities, the effective bandwidth is limited. If you use 100% of the bandwidth for 1% of the time and 0% of the bandwidth for 99% of the time, you are effectively giving the "niced" app only 1% of your bandwidth. And since a computer is digital, there is really no such thing as "instantaneous" bandwidth, as there is in other areas of communication.
    If you have 10 processes running and each consumes 10% of your total bandwidth, it does not matter whether the processes are time-shared or bandwidth-limited, when considered over any reasonable period of time.

  • Bandwidth Management(Rate Limit) Using QoS Policies

    Hello,
    I need some advice. We have an ASA 5525 running version 8.6(1)2 and a 10 MG pipe. I have execs that want to limit bandwidth on users for stuff like youtube, stream media, and downloads. I found the article on ‘Bandwidth Management(Rate Limit) Using QoS Policies’ so it appears our firewall can do what we want. I’m not a cisco person. My knowledge is limited when it comes to configuration – that’s why we have SmartNet :). The advice I need is what to ask for, so to speak, when I put a case in. Can bandwidth be limited on end users and/or can they limit the ‘bandwidth rate limit’ to just youtube, steaming media, and downloads? If so, what should the limit be? and I’m assume this would be for ‘incoming’ traffic only? we’re running into some bandwidth hogs – usually youtube and/or streaming media. We have a Barracuda web filter which we’ve used to block and monitor activity but I simply do not have time to babysit this all day. I should also mention we do have critical data running up and down the pipe; such as credit card processing, DB replication between in house DB and hosted website, TPCx and EDI, FTP, and such that we don’t want restricted.
    Need input please,
    Thanks,
    D

    Hello,
    That's a question that you as the network admin of that organization could answer.
    How much traffic for business purposes must travel via HTTP/HTTPS?
    How much bandwith are you willing to provide to this 2 protocols?
    Those are the kind of answers you need to answer before setting the number
    Regards
    Remember to rate all of the helpful posts, Just click the 5 stars at the left of each post
    Julio

  • ISA 550 Bandwidth Management.

    I wanted to know an automated or manual method of bandwidth management for ISA 550 with 1.2.x.x firmware. I currently have 30 nodes on a 2mbps link and if one host starts downloading others are left with very little or no bandwidth at all. Is there a way I can regulate this automatically or manually?           

    Sounds like Ciscomax got you fixed up.  Also wanted to mention, should the need arise, you can do bandwidth throttling.  We do this in some circumstances on Guest Wireless networks to prevent guests from hogging to much bandwidth.  So, for example, if you wanted to limit bandwidth on a GuestWiFi to 512K/128K, you would do the following.
    From within the ISA500 Config Utility, select Networking on the left
    Expand QoS and select General Settings
    Select to Enable WAN QoS and select Save
    Expand WAN QoS and select Traffic Selector (Classification)
    Select Add
    Class Name:                   G-WiFi (In)
    Source Address:                        Any
    Destination Address:      Guest_Network
    Select OK
    Select Add (again)
    Class Name:                   G-WiFi (Out)
    Source Address:                        Guest_Network
    Destination Address:      Any
    Select OK
    Select Save
    Select QoS Policy Profile under QoS, WAN QoS in the Networking section on the left
    Select Add
    Policy Name: G-WiFi (In)
    Select the Inbound Traffic radio button
    Select Add
    Select G-WiFi (In) from the Class drop down menu
    DSCP Marking:  None
    CoS Marking:     7
    Rate-limiting:      512
    Select OK
    Select OK
    Select Add (again)
    Policy Name: G-WiFi (Out)
    Select the Outbound Traffic radio button
    Select Add
    Select G-WiFi (Out) from the Class drop down menu
    Queue:               Q1
    DSCP Marking:  None
    Rate-limiting:      128
    Select OK
    Select OK
    Select Save

  • We got a new Apple TV for Christmas and it works wonderful. However, my question is this. We are on a satelitte internet system and our bandwidth is limited. Can anyone tell me what effect it will have on using up my 10 megs of bandwidth?

    We got a new Apple TV for Christmas and it works wonderful. However, my question is this. We are on a satelitte internet system and our bandwidth is limited. Can anyone tell me what effect it will have on using up my 10 megs of bandwidth? If I run over the 10 mgs, the service either slows way down until it is reset on the first of the next month or I have to purchase additional bandwidth and it can get expensive.
    Any information would be greatly appreciated.

    If you only have a 10MB limit on the Internet connection you might as well not have Internet access and certainly should not attempt to stream anything.
    If the limit is 10GB, then you will need to be careful with streaming as most video is 1-3GB for a one hour show.

  • Bandwidth seems limited to 10M on Cisco RV320

    Just installed a RV320 to a 50Mb downstream 5Mb upstream switch. With previous wireless routers I can get 30-50MB downstream speed and 5M upstream. The same happens when I connect directly to the switch. However when I try to access with the same computer through the RV320 I am throttled it seems to very close to 10Mb bandwidth. Connection from router to switch is 1000Mb, connection to the computer is 100Mb so this shouldn't be the problem. Bandwidth management is set to 6000 upstream and 60000 downstream. Any suggestions? Thanks. (firmware upgraded to latest)

    It must be a configuration issue, or a faulty unit, as I'm getting 56Mbps down and 9Mbps with the RV320 here on my desk (should be put into production use later today) on a FTTC/VDSL line that we've had rated at 60Mbps down and 10Mbps up. I'm also running the latest firmware.
    Dan

  • Bandwidth manager with Solaris

    Hi all !
    Is there a tool for bandwidth manager like pf-altq in BSDs or other in Linux ?
    Thanks in advance.
    roberto

    Download and install:
    ntop:
    http://www.ntop.org/
    iftop:
    http://www.ex-parrot.com/~pdw/iftop/
    Gary

  • WAAS - Bandwidth Management support?

    WAAS - Bandwidth Management support?

    Sorry, I had a problem with the web. My comment was:
    I know that other products such as Juniper's WXC supports Bandwidth Management. Does Cisco WAAS support it too?
    Bandwidth Management means:
    - Guarantee a minimum bandwidth for your most critical applications.
    - Set maximum bandwidths to limit (or drop) low-priority traffic.
    - Set priorities to determine how the “excess” bandwidth is allocated.
    Thanks in advance.
    José Luis

  • Solaris Bandwidth Manager

    Hi every one.
    I just Installed the Solaris OS 5.10 10/08 on a new Dell Vostro 200. I downloaded the Solaris Bandwidth Manager Documentations but can't find the software itself in solaris.
    Does the software come bundled in solaris 10 or does one get it separate?

    I have moved this question to the Network Configuration Forum here [http://forums.sun.com/thread.jspa?threadID=5354258|http://forums.sun.com/thread.jspa?threadID=5354258]. Please follow the link.
    Sorry for any inconveniences.
    Regards
    Nyantos.

  • Qos/bandwidth management possible from 2950?

    Hello,
    I was curious as to how granular I can be with bandwidth management on a C2950 switch. What I would like is to be able to restrict any SESSION to 300 kilobits or less depending on the IP Traffic type. Basically what I have is MS Terminal Servers connected to a C2950 switch in turn connected to a c2621 router which in turn sends RDP,Printing and Web Traffic back to clients, who are connected using PPPoe w/ C837's. Is it even possible to be able to restrict bandwidth by session, anywhere in this setup?
    Thanks for any help. I just started researching QOS, Bandwidth Management and am lost as to where I should be looking for help. Due to the fact that I want to restrict by single sessions not by total amount of traffic, its confusing trying to get help.

    You can do this with a 2950, as long as you run the EI image (enhanced). Check the QOS section where it says Policing in this document. Its in pdf format.
    http://www.cisco.com/application/pdf/en/us/guest/products/ps628/c2001/ccmigration_09186a00801cde4b.pdf
    HTH
    Sankar
    PS: please remember to rate posts!

  • LRT214 - Bandwidth Management Rate Control Rule

    I have an LRT214 that is configured with 3 VLANs. VLAN 1 just for management, VLAN 10 for internal devices, VLAN 20 for guest devices. Everytime i try to add Bandwidth Management Rate Control Rules for my VLAN 20 IP Range, the router stops responding within 10 seconds to 5 minutes. If I remove the rules, I am able to keep the network up for days. I have even had someone from Linksys Support remotely login to my computer then the router and remove my rules, then add them just like I had. It stayed up for about 3 minutes and then I lost network connections to all devices and couldnt even login to the router. Once I power cycle the router, i am able to get into the router long enough to remove the rules and then everything functions normally. Is anyone else having issues with Rate Control Rules or are there other steps that need to be done as well?
    Just as an FYI, I do have an open case with Linksys but havent heard back from them since Wednesday the 21st. I have tried configuring another LRT214 and even a LRT224, the same issue happens when I add the rules on both of those as well.

    QOS does a calculation based on the up\down Maximum bandwidths. Then applies that against the rules you set. It's critical that the values be accurate.
    Rate control is like pie slices. Leave enough for the rest of the network.
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • RDP Via Essentials Server - Bandwidth Management

    The RDP Gateway hosts a secure connection between the client and the RD server. It opens the tunnel on port 443 and verifies that the user has permissions to access the requested RD server. Other than that, speed is almost completely on your internet connection and the RDS host.

    Does an RDP connection via a Remote Desktop Gateway route all traffic through the gateway server? Or does the gateway just secure the connection and let the two clients talk together? I am trying to optimize my bandwidth management as the RDP connection seems to get weak at random times.
    This topic first appeared in the Spiceworks Community

  • Bandwidth management on 3650 configuration example

    in the 3650 datasheet, he says
    The 3650 switch has advanced wired plus wireless QoS capabilities. It uses the Cisco modular QoS command line interface (MQC). Theswitch manages wireless bandwidth using unprecedented hierarchical bandwidth management starting at the per-access-point level and drilling further down to per-radio, per-service set identification (SSID), and per-user levels. This helps manage and prioritize available bandwidth between various radios and various SSIDs (enterprise, guest, and so on) within each radio on a percentage basis. The switch is also capable of automatically allocating equal bandwidth among the connected users within a given SSID. This makes sure that all users within a given SSID get a fair share of the available bandwidth while being connected to the network. The UADP ASIC enables the hierarchical bandwidth management and fair sharing of bandwidth, thereby providing hardware-based QoS for optimized performance at line-rate traffic.
    In addition to these capabilities, the switch is able to do class of service (CoS) or differentiated services code point (DSCP) based queuing, policing, shaping, and marking of wired plus wireless traffic. This enables users to create common policies that can be used across wired plus wireless traffic. The 3650 also supports downloadable policy names from the Cisco Identity Services Engine (ISE) when a user successfully authenticates to the network using the ISE.
    We are having repeated issue of a single user taking up all the WAN bandwidth.  We are trying to figure out a way to limit the user from taking up all the bandwidth    My leadership see the datasheet and attended the webinar and they mention bandwidth management and think that the 3650 is the solution.   From wireless, maybe, but from wired, ???
    How could accomplish this goal from a wired side?     or should I take a different approach? 
    I can discuss further if needed.

    Hello,
    That's a question that you as the network admin of that organization could answer.
    How much traffic for business purposes must travel via HTTP/HTTPS?
    How much bandwith are you willing to provide to this 2 protocols?
    Those are the kind of answers you need to answer before setting the number
    Regards
    Remember to rate all of the helpful posts, Just click the 5 stars at the left of each post
    Julio

  • Bandwidth managment

    This is a pre-sales question I am running a small satellite internet network of 20 users. I would like to know if there is a bandwidth management feature on the TC. We have a daily usage allowance on our system and I would like to track usage by IP address. Also does the TC support static IP addresses by mac address? If so up to how many users? Our current router only allows eight.
    Thanks,
    Jerry

    There is no "bandwidth management" feature built into the Time Capsule.
    Time Capsule does support IP address reservation on the basis of client MAC address. I am not aware of any hard limit on the number of reservations that can be made.

Maybe you are looking for

  • Sync a BlackBerry Remember Folder AFTER it's been created

    I can imagine in the urgency of planning a BB "LACKberry" 10 native app IN THE EARLY DAYS (in truth, not too long ago) with designated people planning the roadmap of an app native to the upcoming BB 10, yet the with pressure from the higher-ups to CR

  • Problems with Candidate Selection

    Hi experts, I'd like some help about something I'll have to do here in my current customer. Today, when the recruiter wants to select an internal canidate he/she can select the internal candidates who applied for a job and can see a CV with some info

  • Deleted calendar event alert

    Hi all,          I deleted a calendar event from my iPhone 4S after the event but it keeps popping up on my phone as an alert every single day. I might have set it to recurring which I dont remember but even if I did I deleted the event itself. I syn

  • Rebuilding iTunes Library File

    I have been using iTunes since the beginning and would like some feedback about the itunes Library file. I have been using the same iTunes Library file since the beginning of the program and as my library grows and the version upgrades continue to mo

  • Acrobat won't load on my galaxy tablet

    How do I get Acrobat on my Galaxy tablet.