Cannot source /etc/profile from within the PKGBUILD anymore

Hi,
Short story: the command
source /etc/profile
within the build() section of my PKGBUILD now returns a build() error. It used to work before, is there a reason for this? Should it be executed in another section than build()? (Note source /etc/profile works properly in console, within the build directory)
Long story:
I need to use $JAVA_HOME in my PKGBUILD (to patch a lua source file with the current JDK path, which can be detected with $JAVA_HOME. Patching is done with a sed command). However, if java-environment is installed for the first time (as a makedepends) along with my package, then I need to source /etc/profile first to set the $JAVA_HOME environment variable, before being able to use it within my build() section. Otherwise it is not set yet and building fails.
Many thanks for your help.
Last edited by zebulon (2012-12-28 14:57:23)

Hi,
Many thanks for the advice. I was unclear though: I maintain the aacskeys package in AUR, not the lua package. However, the file I am patching in aacskeys is named premake.lua, used for the project file generator premake.sourceforge.net.
I'll try your first suggestion, since this is the only one which may work without touching the system. Another alternative would be to directly source the /etc/profile.d/jdk.sh file. EDIT: nope, because there could be openjdk6.sh instead. I really need to be able to source the correct file. The maintainer of opencascade uses:
if [ -z $JAVA_HOME ]; then
[ -e /etc/profile.d/openjdk6.sh ] && source /etc/profile.d/openjdk6.sh
[ -e /etc/profile.d/jdk.sh ] && source /etc/profile.d/jdk.sh
fi
which is efficacious but less generic.
Besides, is it normal that we get this error code, since the Arch documentation only recommends to set LANG in /etc/locale.conf? SHould I report it as a bug or request a design change for /etc/profile.d/locale.sh there (as suggested in your (b) entry)? I am asking this because my PKGBUILD is not the only one to use this trick, and this problem breaks them all.
Thanks.
Last edited by zebulon (2012-12-30 06:14:58)

Similar Messages

  • I cannot upload to youtube from within the iMovie or the files exported to the finder. Any ideas?

    Upgraded to Mavericks and iMovie 10 on a mid 2012 MBP. I cannot upload to youtube from within the app or the files exported to the finder. Any ideas?

    Upgraded to Mavericks and iMovie 10 on a mid 2012 MBP. I cannot upload to youtube from within the app or the files exported to the finder. Any ideas?

  • I cannot ping any VIP from within the ACE or from rservers

    I cannot ping any VIP from within the ACE or from rservers.  Is this expected?  I have rservers in other serverfarms that need to be able to communicate with the VIP of other serverfarms.  Any help is greatly appreciated.

    Thanks for you reply.  here is the config.  I removed other rserver and serverfarm config that does not have to do with this issue.
    logging enable
    logging fastpath
    logging standby
    logging console 4
    logging timestamp
    logging trap 4
    logging history 4
    logging buffered 4
    logging persistent 4
    logging monitor 4
    logging device-id hostname
    logging host 172.26.254.185 udp/514
    logging host 172.26.221.25 udp/514
    access-list INBOUND line 8 extended permit ip any any
    access-list INBOUND line 16 extended permit icmp any any
    access-list INBOUND line 24 extended permit tcp any any
    access-list INBOUND line 32 extended permit udp any any
    access-list ORADB line 8 extended permit tcp any any
    probe http CITRIX
      interval 30
      passdetect interval 15
      passdetect count 6
      open 1
    probe tcp HYPERION
      port 19000
      interval 2
      faildetect 2
      passdetect interval 2
      passdetect count 2
      receive 2
      open 1
    probe icmp PROBE_SERVICE_ICMP
      interval 5
      passdetect interval 5
    probe tcp W15SPSWFET001_PROBE
      interval 5
      passdetect interval 5
      connection term forced
      open 1
    parameter-map type connection TIMEOUT
      set timeout inactivity 43200
    parameter-map type http test
      persistence-rebalance
      set header-maxparse-length 2006
    rserver host w0bairwatch003
      description MDM-SEG
      ip address 172.20.60.73
      inservice
    rserver host w0bairwatch004
      description MDM-SEG
      ip address 172.20.60.74
      inservice
    rserver host w0bairwatch005
      description MDM-DEVICE
      ip address 172.20.60.75
      inservice
    rserver host w0bairwatch006
      description MDM-DEVICE
      ip address 172.20.60.76
      inservice
    rserver host w0bhamobile001
      description Lotus Notes Traveler Server
      ip address 172.20.60.57
      inservice
    rserver host w0bhamobile002
      description Lotus Notes Traveler Server
      ip address 172.20.60.58
      inservice
    serverfarm host MDMDEVICE
      predictor leastconns
      probe PROBE_SERVICE_ICMP
      rserver w0bairwatch005
        inservice
      rserver w0bairwatch006
    serverfarm host MDMSEG
      predictor leastconns
      probe PROBE_SERVICE_ICMP
      rserver w0bairwatch003
        inservice
      rserver w0bairwatch004
        inservice
    serverfarm host TRAVLR
      predictor leastconns
      probe PROBE_SERVICE_ICMP
      rserver w0bhamobile001
        inservice
      rserver w0bhamobile002
        inservice
    class-map match-all MDMDEVICE-VIP
      2 match virtual-address 172.20.48.35 any
    class-map match-all MDMSEG-VIP
      2 match virtual-address 172.20.48.33 any
    class-map type management match-any REMOTE_ACCESS
      description Remote access traffic match
      201 match protocol ssh any
      202 match protocol telnet any
      203 match protocol icmp any
      204 match protocol https any
      205 match protocol http any
      206 match protocol xml-https any
      207 match protocol snmp any
    class-map match-all TRAVLR-VIP
      2 match virtual-address 172.20.48.34 any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
      class REMOTE_ACCESS
        permit
    policy-map type loadbalance first-match MDMDEVICE
      class class-default
        serverfarm MDMDEVICE
    policy-map type loadbalance first-match MDMSEG
      class class-default
        serverfarm MDMSEG
    policy-map type loadbalance first-match TRAVLR
      class class-default
        serverfarm TRAVLR
    policy-map multi-match CLIENTS-VIPS
      class MDMDEVICE-VIP
        loadbalance vip inservice
        loadbalance policy MDMDEVICE
        loadbalance vip icmp-reply active
      class MDMSEG-VIP
        loadbalance vip inservice
        loadbalance policy MDMSEG
        loadbalance vip icmp-reply active
      class TRAVLR-VIP
        loadbalance vip inservice
        loadbalance policy TRAVLR
        loadbalance vip icmp-reply active
    interface vlan 48
      ip address 172.20.48.10 255.255.255.0
      access-group input INBOUND
      access-group output INBOUND
      service-policy input REMOTE_MGMT_ALLOW_POLICY
      service-policy input CLIENTS-VIPS
      no shutdown
    interface vlan 60
      ip address 172.20.60.10 255.255.255.0
      access-group input INBOUND
      access-group output INBOUND
      service-policy input REMOTE_MGMT_ALLOW_POLICY
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.20.48.1

  • Cannot open iwork documents from within the iwork program

    I am running OSX Mountain Lion on an imac 3.06 GHz core duo. Everything is uptodate. I have documents from Numbers, Pages and Keynote stored on icloud. I can see them when I go to icloud.com. When I try to open them from within any of the iwork programs, all I can see is greyed out document icons.

    Hello
    It seems that Pages is coded to save an imported file (which is the case for a .doc one) in the folder from which it was imported.
    When the folder belongs to a CD, this can't be done and Pages refuses to import the doc.
    I's not a bug, it's a feature.
    Delberate or not is an other question.
    If this feature is annoying from your point of you, described the problem to the official channel because here we are users trying to help other users.
    We are not members of the Pages team.
    So, *go to "Provide Numbers Feedback" in the "Pages" menu* and describe what you wish.
    Yvan KOENIG (from FRANCE samedi 24 novembre 2007 18:53:10)

  • What is the best process for creating, opening, editing, etc PDFs from within Visual Studio 2008?

    I am the project manager on a web-based application that will need to:
    Create, open, edit, save, etc PDFs from within a Visual Studio 2008 web application (Visual Basic).
    Populate PDFs from SQL server 2010 database.
    Allow users to use PDF editing tools from within the website.
    BTW, the application is being written in Visual Basic.
    Will the SDK allow us to do this? What licenses do we need to purchase?
    Are there 3rd party plugins that make doing these things much faster and simpler?
    Any input is GREATLY appreciated!!!
    Sincerely,
    Mike

    I don't think Acrobat, or the Acrobat SDK can help you. Acrobat cannot be run on a server.

  • Just upgraded to Lion an am discovering that I cannot send email photos from within iPhoto. Error message says bad Internet connection or server not working, when that's not the case. Never happened in Snow Leopard! Help!!!

    Just upgraded to Lion an am discovering that I cannot send email photos from within iPhoto. Error message says bad Internet connection or server not working, when that's not the case. Never happened in Snow Leopard! Help!!!

    what email service - Yahoo mail have been acting up lately
    you can try setting Mail as your email client - it resolves this pfoblem for some people
    LN

  • Any way to know where a clip came from within the source clip?

    Using Premiere Pro CS4, Version 4.2.1, on an i7 based PC.
    I would like to be able to see where a clip on the timeline came from within the clip in the source monitor. Where ever there is information about the clip on the timeline, it only seems to tell me it's 'Start', 'End' and 'Duration' in relation to the current Sequence, but nothing relating to the 'In' or the 'Out' points within the source clip.
    Is it possible to read this somewhere, rather than having to replay the clip in the source monitor to discover the in and out points? It tends to be tedious doing this too often.
    Thanks in advance, hopefully.
    Peter.

    Awesome sauce Shooter 
    That is exactly what I wanted to know.
    Much appreciated!!!
    Peter

  • Had to restore iphone from a backup that was done 1 week ago.  any way to get back the texts, call logs, etc. that happened within the last week?

    this morning, i had to restore iphone from a backup that was done 1 week ago.  is there any way to get back the texts, call logs, etc that happened within the last week?

    No

  • Making an RFC call from within the VM container

    Hi all,
    since a long time I am searching for information on how to implement an RFC call from within the VMC. The problem is that we have implemented several (p)functions in ABAP and we need to implement them in JAVA.
    Now I am searching for a way how to just call the already existing pfunctions???
    Is it possible to read CRM DB tables too?
    Thank you in advance
    Boris

    Hi Freeto,
    This may be due to the Network Failures.
    If you have triggered a job then because of the Network fluctuations the system may not respond properly and cannot execute the job.
    So, this is the cause for the failure.
    Hope you understood.
    With Regards,
    Ravi Kanth

  • I have CS 6 installed on a Win 7 OS machine. I can not connect to the internet to get updates from within the program. How do I fix this?

    I have CS 6 installed on a Win 7 OS machine. I can not connect to the internet to get updates from within the program. How do I fix this?

    IP routing doesn't work the way many folks might initially think it does; functional IP routing requires manual configuration and the establishment of static routes and default routes specific to the local network configurations, and it's very easy to get it wrong, or to get the default route swapped. Multiple NIC boxes don't magically work, either. (Been there, done that, wondered what happened to my network when the paths got reordered or my route settings were messed up, etc.)
    Routing configuration errors can be quite subtle, too. (Again, voice of experience. Ever had a thousand-seat office LAN accidentally routing through your desktop? As the, um, unnamed guilty party discovered, getting into that configuration was subtle. Seeing the performance crater on the fellow's box and on the LAN was obvious.)
    Knowing how IP routing works is a prerequisite to getting this configuration to work; there's manual configuration required. Clearly something has gone weird here.
    What to do? Read up on IP routing. I'll again suggest the threads and the manual mentioned earlier.
    And in general, I prefer to avoid using my comparatively expensive Mac boxes as sub-optimal IP routers or as firewall boxes. General-purpose operating systems and generic x86 boxes are going to be inherently poor IP routers. Dedicated routers (or embedded or surplus x86 boxes with routing software loaded) offload the Mac boxes here, and are also typically easier to configure manage. And "real" IP routers can have hardware specific to efficiently routing packets. Use of an outboard firewall or firewall-router box also greatly simplifies gateway routing, too; it's a configuration that many folks and many businesses tend to use.

  • Whenever I use the trackpad on my 17" Macbook Pro (2010 model) there is a small, trebly processor sound coming from within the enclosure.

    Whenever I use my trackpad, there is a whirring, trebly sound coming from within the computer itself. It happens also when webpages are loaded or programs are compiled, but not when I use the keyboard or when the computer is in disuse. It has become louder over time, and it is obvious that when the computer senses input from the trackpad and must translate it, the sound is produced. Is there any way to reset the firmware or an option on the Settings menu that could perhaps help? I am concerned that it is a symptom of a larger problem. Thanks.

    The question mark means the computer cannot find a bootable volumes so can;t do anything, That, combined with annoying sounds, strongly suggests a failed hard drive.
    You can ask a "genius" at an Apple Rtail Store to test it but I'm pretty sure the drive is kaput. I'm hoping you had your data backed up.

  • Possibility to abort the execution from within the PreUUT and MainSequence

    Hello,
    This is probably a TS newbie question that most of you can answer right away!
    I'm using the sequential model to develop my test. I cannot figure out how to do terminate the execution from within the PreUUTLoop or MainSequence callback.
    In the PreUUT you can manipulate the parameter ContinueTesting to indicate to the process model that you want to stop testing.
    For the PreUUTLoop and MainSequence callback this parameter is not available.
    I could modify the process model itself to also supply me this parameter for the PreUUTLoop and the MainSequence. (and check for it on return from these callbacks)
    But, I was wondering, is there another (maybe even better) way to do this?
    Thanks for the help!
    noxus.

    Thanks, that's what I was looking for.
    One extra question:
    - From the PreUUTLoop callback it is working fine. (immediately stops the execution)
    - From the MainSequence callback I still get the popup message "Next UUT" or "Terminate". Can I avoid this popup message and just Terminate the execution? (preferably without modifying the process model)
    or, another alternative is that I disable the "Test UUT" entry point and only allow the user to select "Single Pass". Is that possible? Is it possible to disable the "Test UUT" entry point for the sequential process model?
    Message Edited by noxus on 02-22-2007 04:17 AM

  • Aterm now opens with source /etc/profile

    I was in aterm when I did source /etc/profile, but now whenever I open aterm I get the results of source /etc/profile. Xterm doesn't do this, only aterm. Why is it doing this and how can I fix it?

    just add "source /etc/profile" (without the quotes) to .bashrc (thats located in ur home directory)

  • Find out current old heap usage from within the process

    Hello!
    We use the CMS garbage collector and need a way to find out how much memory is used of the old heap by reachable objects. This we have to do from within the process (not using jvmstat or jstat etc.).
    Since there is no way to distinguish between reachable and non-reachable objects (except for traversing the entire heap... -- or are there other possibilities?) our idea is to get the amount of used memory right after a garbage collection in the old heap.
    Using Java 1.5, this can be done by
    java.lang.management.MemoryPoolMXBean pool = <Pool for Old Generation>;
    pool.getUsage().getUsed();However, java.lang.management is only available in Java 1.5.
    Therefore my first question: Is there a similar way of finding out old heap usage in Java 1.4?
    There is another problem with this method: By calling pool.getUsage().getUsed();, one has to know when a GC has occurred (this could be done by calling it in an interval of x seconds -- if the current value is lower than the one before, a GC must hava occurred). A better way would be to use pool.getCollectionUsage().getUsed();, but this seems not to work for the CMS collector.
    Second question: Is pool.getCollectionUsage().getUsed(); really not working with CMS, or are we just doing it in a wrong way? Are there other ways of finding out the used memory in the old heap after a GC even when using the CMS?
    Thanks for any help!
    Regards,
    Nicolas Michael

    Hi Nicolas,
    There is no API in 1.4 to get the after GC memory usage of the old generation. The only thing close to it is (Runtime.totalMemory - Runtime.freeMemory) but it is the approx amount of memory used for the heap (not just the old generation).
    MemoryPoolMXBean.getCollectionUsage() returns the after GC MemoryUsage. This method should work for all collectors. I have a simple test case that shows it working fine with CMS. It shows the same value as the -XX:+PrintGCDetails shows.
    If you have a test case showing that this method doesn't work correctly, please submit a bug along with the test case. We'll investigate it.
    Thanks
    Mandy

  • Can I add or edit Keywords and captions from within the Map module?

    I frequently find a need to edit or add to the caption while reviewing  and geotagging photos in the Map module.  Constantly toggling between modules is inconvenient.  Is there a way to add/edit captions or keywords while working in the Map module  (or view the map module while working in the Library?
    Thanks!
    Steve

    thank you
          From: Modesto Vega <[email protected]>
    To: Steve Murray <[email protected]>
    Sent: Thursday, January 29, 2015 3:27 PM
    Subject:  Can I add or edit Keywords and captions from within the Map module?
    Can I add or edit Keywords and captions from within the Map module?
    created by Modesto Vega in Photoshop Lightroom - View the full discussionYou should be able to change the title, the caption, the sublocation, the city, the state/province, the country, the ISO country code, the altitude, the direction, and a few other fields. However, you cannot add keywords. It would be real nice if Adobe could add this to the Map module. If the reply above answers your question, please take a moment to mark this answer as correct by visiting: https://forums.adobe.com/message/7145077#7145077 and clicking ‘Correct’ below the answer Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: Please note that the Adobe Forums do not accept email attachments. If you want to embed an image in your message please visit the thread in the forum and click the camera icon: https://forums.adobe.com/message/7145077#7145077 To unsubscribe from this thread, please visit the message page at , click "Following" at the top right, & "Stop Following"  Start a new discussion in Photoshop Lightroom by email or at Adobe Community For more information about maintaining your forum email notifications please go to https://forums.adobe.com/thread/1516624.

Maybe you are looking for

  • How do I set this up FIOS tv verizon pop up suggest widgets to view youtube tv sceen?

    How do I get my laptop which is on wi-fi to view youtube on tv flat screen, which I see fios widgets will allow above to transmit from PC to TV screen . What needs to be done .?

  • IPhoto editing problems

    I'm have an iPhoto problem. I'm currently in version5.0.4 (263). In edit mode when I try to bring up a photo with a date before October 2005 I get the spinning gear wheel and the image never loads. The thumb nail is at the top of the page but the lar

  • Part of my screen is white with lines?

    My computer was fine a couple of days ago. I had not used it for a few days, and when i powered it up just now, a small portion of the screen is white with a few lines. It annoyingly covers a part of my screen and i hate it. I have already tried rest

  • Mid 2007 macbook no chime dark screen.

    my mid 2007 macbook will not chime on startup and I am getting no picture. already tried resetting pram, SMC or whatever and removed and replaced the battery. Tried booting from a disk and got nothing, tried booting from my backup and got nothing. It

  • I accidentally clicked a link on iphone twitter. It said my SMS and Emails are now monitored. Help!

    I was on twitter from my iphone and stupidly clicked a link. A page came up saying my phone was now hacked and SMS,e-mails and such are now being watched. I immidently exited out of the page. cleared history, cookies, turned my phone off then back on