EIGRP vs BGP route path selection scenario

I am looking for a routing solution to the following scenario.  It is a fairly simple design. 
I have two WAN connections between sites A and B.  One is a 20 Meg Metro Ethernet Circuit running EIGRP.  The other is a 10 Meg MPLS running BGP.  What do I need to do in my configuration to make sure that the 20 Meg connection is the chosen path based off the fact that it has better speed and bandwidth?  It appears to me that the MPLS is the preferred path even though it is slower.
See attached Diagram:
Site A Config
interface GigabitEthernet1/0/12
 description PADC COX P2P 20 Meg
 no switchport
 bandwidth 20480
 ip address 172.20.1.1 255.255.255.252
interface GigabitEthernet2/0/2
 description LEVEL 3 MPLS
 no switchport
 bandwidth 10240
 ip address 172.22.0.2 255.255.255.252
router eigrp 1
 network 10.0.1.0 0.0.0.255
 network 172.20.1.0 0.0.0.3
 network 192.168.76.8 0.0.0.3
  redistribute bgp 65003 metric 100 1 255 1 1500 route-map MPLS_NETWORKS
 redistribute static route-map DEFAULT_ROUTE
router bgp 65003
 bgp log-neighbor-changes
 redistribute static
 redistribute eigrp 1
 neighbor 172.22.0.1 remote-as 1
 default-information originate
Site B Config
interface GigabitEthernet0/1
 description COX Communications 10 Meg to Venyu
 bandwidth 20480
 ip address 172.20.1.2 255.255.255.252
 duplex auto
 speed auto
 service-policy output VOIP
interface GigabitEthernet0/2
 description Level 3 MPLS
 bandwidth 10240
 ip address 172.22.1.2 255.255.255.252
 duplex full
 speed 100
router eigrp 1
 network 10.3.1.0 0.0.0.31
 network 10.52.1.0 0.0.0.255
 network 10.76.6.0 0.0.0.255
 network 172.20.1.0 0.0.0.3
 network 192.168.63.64 0.0.0.63
 network 192.168.76.249 0.0.0.0
 passive-interface default
 no passive-interface GigabitEthernet0/0
 no passive-interface GigabitEthernet0/1
router bgp 65003
 bgp log-neighbor-changes
 network 10.3.1.0 mask 255.255.255.224
 network 10.52.1.0 mask 255.255.255.0
 network 10.76.6.0 mask 255.255.255.0
 network 192.168.76.249 mask 255.255.255.255
 neighbor 172.22.1.1 remote-as 1

If each router is receiving advertisements for the same networks/subnet masks from both BGP and EIGRP it will always choose the BGP routes because they have a lower AD ie. 20 vs EIGRP 90.
Doesn't matter what the bandwidth is.
If you want to prefer the 20Mbps links then there are a number of options -
1) if you can summarise each sites subnets then advertise the summary via BGP and the more specific via EIGRP.  More specific will be chosen even before AD is taken into account.
2) change the AD of either BGP or EIGRP so EIGRP ends up with the lower AD
3) run BGP on both links although you would still need to manipulate the attributes to make sure the link you want is used.
Jon

Similar Messages

  • BGP Best Path Selection Algorithm

    How is the administrative distance positioned in the bgp route decision ?
    i.e If a route is learned from iBGP with higher "local prefernece" and eBGP with lower "local prefernece" - which path will be installed in the routing table
    the path learned from eBGP or the path with higer local prefernce ?

    For your scenario the path with the higher local pref will be installed in the routing table althogh its ibgp.
    if a router recieves the same prefix from 2 neighbors 1 from ibgp and the other from ebgp
    the router will compare them with the bgp path selection algorithm
    the one that wins will be installed in the routing table with the admin distance of the kind of route it is so if the ibgp route won the path selection you will see in the routing table the admin distance of 200,if the ebgp route won you'll see 20 in the admin distance.
    so remember the ibgp/ebgp comparision is the 9th in the path selection algorithm so an ibgp route can win the path selection by (local pref weight....)
    and if the ibgp won then you'll see the ibgp admin dstance in your routing tables.

  • Lesson BGP & OSPF path selection in VSS routing environment

    Hi, I would like a lesson on how traffic is passed in the following environment:
    One 3945 router with interfaces connected to a pair of 4500X switches configured as VSS pair. One link into each of the 4500 running as routed interfaces using separate IP subnets meaning there are two equal cost paths between the router and the 4500X.
    We are running a single OSPF area and iBGP between the devices. 
    I would like to find out, in normal circumstances where both equal cost links are operating normally, how the 4500 selects the path to send a packet to the router.  We would be trying to avoid traffic passing through the VSL but want to know if the system is smart enough to do that.
    Is there somebody out there who can tell me if the VSS process will select the path directly to the router or if it cannot be guaranteed to do so.
    I also would like to get opinions on whether it is best to create two iBGP neighbour relationships on the link addresses or one relationship between the loopback addresses.
    Thanks 
    LP

    Hi,
    The OSPF traffic would not pass through the VSL link.  The path would directly go from each 4500 to the 3945 (Equal cost load balancing). I think, the 3900 series supports Etherchannel, if this is the case you can also create a L-3 Portchannel between the VSS and 3945 router.  This way you use one /30 instead of 2 and you still have redundancy.  For BGP, I would do one peering with Loopbacks.
    HTH

  • BGP Path Selection

    With reference to cisco's document on BGP Best Path Selection Algorithm (http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13753-25.html).
    Out of given 9 paths why 6th has been selected even though AS_PATH for 8th route is better.
    Can anyone explains here, as this document has not considered the AS-PATH during path selection and used lowest ROUTER ID only.
    Thanks in advance and expect technical explanation here.

    Hey Buddy
    The AS_PATH for both is only 1, don't get confused by (AS_SET) which only counts as 1 no matter how many AS are in the set.  Refer to section "How the Best Path Algorithm Works"
    4.Prefer the path with the shortest AS_PATH.
    Note: Be aware of these items:
    ◦An AS_SET counts as 1, no matter how many ASs are in the set.
    So bearing the above in mind
    Example: BGP Best Path Selection
    Path6
      (64955 65003) 65089 --- this equals 1
        172.16.254.226 (metric 20645) from 10.57.255.11 (10.57.255.11)
          Origin IGP, metric 0, localpref 100, valid, confed-external, best
          Extended Community: RT:1100:1001
          mpls labels in/out nolabel/362
    !--- BGP selects this as the Best Path on comparing
    !--- with all the other routes and selected based on lower router ID.
    Path8
      (65003) 65089 --- this equals 1
        172.16.254.226 (metric 20645) from 172.16.254.234 (172.16.254.234)
          Origin IGP, metric 0, localpref 100, valid, confed-external
          Extended Community: RT:1100:1001
          mpls labels in/out nolabel/362
    Comparing path 6 with path 8:
     Both paths have reachable next hops
     Both paths have a WEIGHT of 0
     Both paths have a LOCAL_PREF of 100
     Both paths are learned
     Both paths have AS_PATH length 1 --- because the (AS_SET) always equals 1
     Both paths are of origin IGP
     Both paths have the same neighbor AS, 65089, so comparing MED.
     Both paths have a MED of 0
     Both paths are confed-external
     Both paths have an IGP metric to the NEXT_HOP of 20645
    Path 6 is better than path 8 because it has a lower Router-ID.
    Hope it helps (:

  • BGB Best path selection

    Hi,
    Could someone tell me why second path remains as best?
    MPLS_CORE#show ip bgp 192.168.1.0
    BGP routing table entry for 192.168.1.0/24, version 27
    Paths: (2 available, best #2, table default)
      Advertised to update-groups:
         1         
      Refresh Epoch 1
      64513
        2.2.2.1 from 2.2.2.1 (10.201.240.2)
          Origin incomplete, metric 156160, localpref 100, valid, external
          rx pathid: 0, tx pathid: 0
      Refresh Epoch 1
      64512
        1.1.1.1 from 1.1.1.1 (192.168.4.253)
          Origin incomplete, metric 1415680, localpref 100, valid, external, best
          rx pathid: 0, tx pathid: 0x0
    Regards
    Michal 

    Hi Michal,
    Please refer below CCO document for BGP best path selection criteria on cisco routers
    http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13753-25.html
    If everything attribute is same then it comes to router-id and lowest router-id is preferred.
    11. Prefer the route that comes from the BGP router with the lowest router ID.
    The router ID is the highest IP address on the router, with preference given to loopback addresses. Also, you can use the bgp router-id command to manually set the router ID.
    In your case, second route is having lowest router-id (1.1.1.1)
    --Pls dont forget to rate helpful posts--
    Regards,
    Akash

  • BGP Path Selection - Favor Oldest Routes

    I've been poking around in a few test routers trying to find where BGP states how long a route has been known from a neighbor. Based on Cisco's BGP path selection article: http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/13753-25.html, #10 states BGP prefers the oldest known route. 
    What command shows the amount of time a route has been known via BGP?

    Thanks for your reply, Paul.
    The first command just shows the same timer as the sh ip bgp summary timer. It's just the timer of the neighbor relationship.
    The second command just displays how long the route has been in the routing table. I've tested this and found that when BGP loses a route to a network and then selects a different path that it had known about, the timer resets to 0. Even though it had known about the path for a while, it still resets to 0. 
    So thanks to everyone for your responses, but I'm still looking for some way to see the age of a BGP-learned route.

  • Inject BGP Default Routes into Multiple VRF before Best Path Selection

    Hello, 
    I have the following setup:
    Multiple Border Routers with eBGP sessions to external AS. We receive a default route from this multiple AS to keep the Table manageable. We noticed an important part of our traffic was been SW routed instead of CEF when we had the Full Internet table. Router Resources came to the ground when we changed to a default. 
    Now I want to separate this default routes into different VRF. Attached is the Diagram. 
    My question is,  the multiple default route all go into the BGP Table. The BGP table then select the best route and place it on the RIB and then to the FIB. 
    I want to redistribute the different Route on the BGP table prior to the Best path selection algorithm and placed on the RIB. 
    How can I achieve this?

    Hi,
    Redistribution of multiple routes to same prefix is not possible. Even if you have configured BGP multipath and all different bgp routes got installed into routing table, during redistribution only route will be redistributed. 
    Also would like to understand the requirement of redistributing multiple BGP routes in to IGP. As per your diagram, 3 different eBGP sessions are on three different routers, so you can prefer eBGP route over iBGP received from other routers and can distribute eBGP route to IGP from each router. Thus you will have three different default routes in to IGP in core.
    Please don't forget to rate this post if it has been helpful
    - Akash

  • Weird BGP path selection problem

    Hi, all,
    I am seeing a weird BGP path selection problem on 4948 switch running cat4500-entservicesk9-mz.122-46.SG.bin code, this switch has two uplinks to the same ISP's different edge router, one circuit is primary the other one is strict backup, only default route is accepted from ISP. I am setting both local preference and weight to the default route advertised over backup link, however neither one is taking effect, BGP still thinks the backup link is better, what could be wrong?
    rtr#sh ip bgp 0.0.0.0/0
    BGP routing table entry for 0.0.0.0/0, version 105
    Paths: (3 available, best #2, table Default-IP-Routing-Table, not advertised to EBGP peer)
      Not advertised to any peer
      17675, (received & used)
        203.169.8.37 from 203.169.8.37 (61.211.160.150)
          Origin IGP, localpref 100, valid, external
          Community: 65001:0 no-export
      17675
        203.169.8.45 from 203.169.8.45 (61.211.160.151)
          Origin IGP, localpref 90, weight 90, valid, external, best <====
          Community: 65001:0 no-export
      17675, (received-only)
        203.169.8.45 from 203.169.8.45 (61.211.160.151)
          Origin IGP, localpref 100, valid, external
          Community: 65001:0 no-export
    Thanks

    Hi,
    On cisco routers , weight is having highest preference to decide best path. By default for received route, weight is 0 but you are setting weight 90 to backup path and that is why it is getting preferred (higher is better). Please remove weight and let local preference be 90 (lesser than route on primary path)
    --Pls dont forget to rate helpful posts--
    Regards,
    Akash

  • Bgp path selection issue

    hi,
    i have the following cli show command output,
    R2#show bgp ipv4 unicast
    BGP table version is 11, local router ID is 192.168.220.252
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
       Network          Next Hop            Metric LocPrf Weight Path
    * i192.168.30.0     192.168.110.70           0    100      0 63000 i
    *>                  192.168.220.70           0             0 63000 63000 i
    * i192.168.40.0     192.168.110.70           0    100      0 63000 63000 i
    *>                  192.168.220.70           0             0 63000 i
    R2#
    why isn't the route through the shortest AS path not selected as the best route for 192.168.30.0. ?
    thanks,
    uddika

    R2#
    R2#
    R2#show ip bgp 192.168.30.0
    BGP routing table entry for 192.168.30.0/24, version 7
    Paths: (2 available, best #2, table Default-IP-Routing-Table)
      Advertised to update-groups:
         2         
      63000
        192.168.110.70 (inaccessible) from 192.168.111.251 (192.168.111.251)
          Origin IGP, metric 0, localpref 100, valid, internal
      63000 63000, (received & used)
        192.168.220.70 from 192.168.220.70 (192.168.220.70)
          Origin IGP, metric 0, localpref 100, valid, external, best
    R2#
    R2#
    thanks, i noticed that R2 does not have the route for the next hop, 192.168.110.70.

  • Monitoring a BGP route and AS-PATH.

    Hello.
    I need to receive a SNMP trap when a BGP route, received with a specific AS-PATH, disappears from routing table.
    Any ideas?
    Thanks.
    Andrea

    You can use EEM for this. Check out the cisco beyond web site for sample scripts that may help you do this.
    A company that I used to work for, www.magnus.net had a mature EEM solution for doing this for large network environments. They took a standalone router and using EEM turned it into a route monitor.  It would send out notifications when BGP routes of defined attributes like AS-Path diasappeared from routing tables.  It was driven by an excel spreadsheet as inputs. It was written by a super CCIE engineer.

  • DMVPN + MPLS best-path selection

    Dear Community
    We're in the process of deploying DMVPN as a backup solution to MPLS. All that is working great!
    The DMVPN wan is dual-cloud, with 2 hub routers in each cloud. Phase 3 (nhrp shortcut) is enabled on all the spokes.
    For routing, all the customer subnets are advertised in MPLS, whereas for DMVPN hub advertises only a summary to 10.0.0.0/8. The protocol for both is BGP. For DMVPN, the hub routers resides in one AS (65002) and all the spokes another common AS 65102. DMVPN is therefore peered eBGP hub > spoke.
    For customers connected to MPLS, the DMVPN serves as backup only solution. Best-path selection by longest prefix match.
    We have other customers coming on board who wish to join the same WAN but don't have the $$$ for MPLS so are opting for DMVPN only.
    Now, I have a requirement to enable spoke-to-spoke for a DMVPN only site (spokeA) to an MPLS site (spokeB). The problem is it doesn't seem to work properly as the hub router sees the best path to spokeB site via MPLS, not via DMVPN. The spoke-to-spoke is never formed, and remains spokeA > hub > mpls > spokeB. The return path is better = spokeB > DMVPN > hub > spokeA (this is because spokeB sees no route from MPLS for spokeA, so follows 10.0.0.0/8) route.
    I look for any feedback that can help to meet this requirement?
    And if any advice on the general design would be really appreciated.
    Thanks a lot!
    Phil

    Phil, 
    I did a short lab around this ... wanted to make sure I'm not saying something stupid. 
    While I can't claim it's the _optimal_ solution for your setup it seems to work in my lab.
    Spoke1 LAN 192.168.101.0/24 (AS 65001)
    Spoke2 LAN 192.168.102.0/24 (AS 65002)
    HUB LAN 192.168.111.0/24 (AS 65000)
    192.168.1.0/24 DMVPN subnet. 
    A single (i)VRF - DMVPN exists on hub, only and is assigned only to DMVPN tunnel interface. 
    Excuse a few hacks a had to use... default routed via default-originate for example :-)
    Hub
    R10-P#sh run int tu0
    Building configuration...
    Current configuration : 281 bytes
    interface Tunnel0
    vrf forwarding DMVPN
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp shortcut
    ip nhrp redirect
    tunnel source Loopback0
    tunnel mode gre multipoint
    tunnel protection ipsec profile PRO
    end
    R10-P#sh run | s r b
    router bgp 65000
    bgp log-neighbor-changes
    network 192.168.111.0
    redistribute static
    neighbor 10.112.112.1 remote-as 65001
    neighbor 10.112.112.1 route-map SPOKES_MPLS in
    default-information originate
    address-family ipv4 vrf DMVPN
    neighbor 192.168.1.101 remote-as 65001
    neighbor 192.168.1.101 activate
    neighbor 192.168.1.102 remote-as 65002
    neighbor 192.168.1.102 activate
    exit-address-family
    R10-P#sh run | s vrf defini
    vrf definition DMVPN
    rd 1:1
    route-target export 100:1
    route-target import 100:1
    address-family ipv4
      import ipv4 unicast map DEFAULT
      export ipv4 unicast map SPOKE_SUBNETS
    route-target export 100:1
    route-target import 100:1
    exit-address-family
    address-family ipv6
    route-target export 100:1
    route-target import 100:1
    exit-address-family
    Result on spoke
    R1-PE#traceroute 192.168.102.1 source e2/0
    Type escape sequence to abort.
    Tracing the route to 192.168.102.1
    VRF info: (vrf in name/id, vrf out name/id)
    1 192.168.1.1 [AS 65000] 5 msec 10 msec 2 msec
    2 192.168.1.102 [AS 65000] 4 msec * 5 msec
    R1-PE#traceroute 192.168.102.1 source e2/0
    Type escape sequence to abort.
    Tracing the route to 192.168.102.1
    VRF info: (vrf in name/id, vrf out name/id)
    1 192.168.1.102 [AS 65000] 6 msec * 6 msec
    routing on hub 
    (sanitized)
    R10-P# sho ip route
    Gateway of last resort is 10.100.100.2 to network 0.0.0.0
    S* 0.0.0.0/0 [1/0] via 10.100.100.2
    10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
    B 192.168.101.0/24 [20/0] via 10.112.112.1, 00:06:40
    B 192.168.102.0/24 [20/0] via 192.168.1.102 (DMVPN), 00:00:03
    192.168.111.0/24 is variably subnetted, 2 subnets, 2 masks
    R10-P# sho ip route vrf DMVPN
    Routing Table: DMVPN
    Gateway of last resort is 10.100.100.2 to network 0.0.0.0
    B* 0.0.0.0/0 [20/0] via 10.100.100.2, 00:06:40
    192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C 192.168.1.0/24 is directly connected, Tunnel0
    L 192.168.1.1/32 is directly connected, Tunnel0
    B 192.168.101.0/24 [20/0] via 192.168.1.101, 00:06:40
    B 192.168.102.0/24 [20/0] via 192.168.1.102, 00:06:25

  • Importing not-just-1-best bgp route to VRF in XR in case of unique RD per PE

    I'm trying to import  BGP prefix from several different sources into VRF for fast convergence. When RD on local and remote PE match, it works right away. But if RDs are different, then I can see many different routes in "sh bgp vpnv4 unicast rd x:x (remote PE's RD)" with NOT-IN-VRF flag, but only best one is present in "sh bgp vpnv4 unicast vrf YYY" or  "sh bgp vpnv4 unicast rd y:y (RD of local PE)". 
    As I understand, in IOS it is handled like this:
    router bgp 1
    address-family ipv4 vrf YYY
      import path selection all
      import path limit 4
    But can not figure out how to do it in XR. Any suggestions? Do not want to roll back to same-RD-on-all-PEs approach, as IOS doesn't do much of add-paths for VPNv4 ;(. 

    I dont know if this will exactly suit your needs but you can enable PIC (Prefix independent convergence) with the additional-paths command.
    The exact command depends on your XR version (additional-paths install backup or additional-paths election)
    Refer to the document:
    http://www.cisco.com/c/en/us/td/docs/routers/crs/software/crs_r4-1/routing/command/reference/b_routing_cr41crs/b_routing_cr41crs_chapter_01.html#wp2841279186

  • Query on BGP route distribution

    Hello Everyone
    In the below scenario (GNS3), IBGP peering enabled between R1-R2, R1-R3, R2-R3 and EBGP peering enabled between R2-R4,R3-R5,R4-R6,R5-R7. OSPF enabled as IGP. Scenario attached for reference.
    The problem I've observed in R1 is not getting entire BGP routing table for destinations 30.x.x.x/40.x.x.x.
    I'm able to see only best routes in R1 BGP routing table, but alternate valid routes are not visible in its topology table.
    R1#sh ip bgp
    BGP table version is 81, local router ID is 100.100.2.1
    *>i30.30.1.0/24     10.10.1.2                0    100      0 200 300 ?
    *>i30.30.2.0/24     10.10.1.2                0    100      0 200 300 ?
    *>i40.40.1.0/24     10.10.2.2                0    100      0 200 400 i
    *>i40.40.2.0/24     10.10.2.2                0    100      0 200 400 i
    *> 100.100.1.0/24   0.0.0.0                  0         32768 i
    *> 100.100.2.0/24   0.0.0.0                  0         32768 i
    More confusing part to me is when I disable IBGP peering between R2-R3 or shutdown interface between R2-R3 or else if I disable ospf in R1,R2 & R3 routers , I'm able to see both best route and alternate valid route in BGP topology table.
    R1#sh ip bgp

    Hi Milin & Renan,
    Thanks for your replies. To narrow down the problem, I’ve shut down the 40.40.x.x network.
    Now between R2-R3, R3 is not advertising 30.30.X.X network to R2, but whereas R2 is advertising 30.30.X.X network to R3. Why R3 is not advertising 30.30.X.X (route via 200 400 300) to R2.
    R2#sh ip bgp ( No alternate route)
     Network          Next Hop            Metric LocPrf Weight Path
    *> 30.30.1.0/24     10.10.4.2                              0 200 300 ?
    *> 30.30.2.0/24     10.10.4.2                              0 200 300 ?
    *>i100.100.1.0/24   10.10.1.1                0    100      0 i
    *>i100.100.2.0/24   10.10.1.1                0    100      0 i
    R2#sh ip bgp summary
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.10.1.1       4   100      96      98        5    0    0 01:05:50        2
    10.10.3.2       4   100      98     100        5    0    0 01:05:54        0
    10.10.4.2       4   200     100      98        5    0    0 01:05:39        2
    R3#sh ip bgp  ( only in R3 we can see both best route & alternate route)
       Network          Next Hop            Metric LocPrf Weight Path
    *>i30.30.1.0/24     10.10.3.1                0    100      0 200 300 ?
    *                   10.10.5.2                              0 200 400 300 ?
    *>i30.30.2.0/24     10.10.3.1                0    100      0 200 300 ?
    *                   10.10.5.2                              0 200 400 300 ?
    *>i100.100.1.0/24   10.10.2.1                0    100      0 i
    *>i100.100.2.0/24   10.10.2.1                0    100      0 i
    R3#sh ip bgp summary
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    10.10.2.1       4   100      54      57       19    0    0 00:50:17        2
    10.10.3.1       4   100      62      60       19    0    0 00:27:22        2
    10.10.5.2       4   200      58      58       19    0    0 00:50:08        2

  • Path Selection between 10 gig fiber and microwave

    Hello everyone,
    my network is running OSPF as an IGP, i have a 10 gig Ethernet  fiber connected between two sites and a microwave link as a redundant connection.
    since ospf metric is cost ( or bandwidth ), the 10 gig ethernet connection is always preferred. however, sometimes the 10 gig link is flapping or the bit error rate is bad, is there anyway to change the path selection to go through the microwave when the bit error rate in the 10 gig link is bad or the link flaps ?
    basically can we make the path selection based on anything than the speed or cost ?

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    Bandwidth can be a metric to OER/PfR.  Much else can be used by OER/PfR.
    The intent of this technology is sort of described by the names, Optimized Edge Routing (v1) and Performance Routing (v2).
    Both can account for path bandwidth and/or analyze performance.
    Understand typical dynamic routing protocols keep track of paths between source and destination and some have a way to "weight" paths  (for example, OSPF link cost [which by RFC, hasn't nothing to do with bandwidth, but is often based on that]).
    OER/PfR, for example, can run their own SLA tests.
    Years ago, I set up OER in large dual MPLS/VPN environment.  Our initial "problem", after activation, our WAN performance monitoring tools (and our users!) no longer "saw" any WAN performance issues.  They were still happening, but OER "saw" them first, and worked around them before the monitoring tools saw them.

  • Cisco dial-peer path selection with "preference"

    Hi everybody,
    for a test lab environment i'm testing the integration between cisco voice gateway 3925 and third party voice gateway by means of isdn PRI.
    here the connection schema:
    PSTN (emulated)-----> port0/0/0-Cisco3925-port0/0/1 <------- Third party Voice Gateway
                                                                  |     (ethernet)
                                                          Cisco CUCM  (172.23.112.20) 
    in brief:
    - i'm emulating PSTN with a cisco voice gateway, this gateway is connected to cisco3925's port 0/0/0.
    - cisco3925's port 0/0/1 is connected to Third party Voice Gateway.
    - cisco 3925 speaks with Cisco CUCM in H323.
    Now let's go for an incoming call from the PSTN when 3925 has no connection to CUCM, with called number 321672711 (321672... is the GNR of the site):
    1. inbound: dial-peer 110 finds match so the called number is transformed to 591711 (it is a DN not registered to SRST cisco gateway)
    2. outbound: i expect dial-peer 100 to be matched, because 172.23.112.20 is no more reacheable. From the show call active voice dial-peer 1 is matched as the attached. I need to set preference 1 in dial-peer 100 because when WAN is UP i don't want dial-peer 100 to be matched (and it works). But when WAN is down dial-peer 100 must match. If i remove preference 1, dial-peer 100 finds match; but for correct path selection i cannot remove it.
    What am I forgetting?
    thanks for support
    voice translation-rule 1
     rule 1 /^321672/ /591/   
    voice translation-profile ENTRANTE
     translate called 1
     (translate calling omitted)
    dial-peer voice 1 voip
     description Inbound per USCENTI - Outbound per ENTRANTI
     corlist incoming CSSSRSTInternazionali
     tone ringback alert-no-PI
     destination-pattern 591...
     session target ipv4:172.23.112.20
     voice-class codec 1
     dtmf-relay h245-alphanumeric
     no vad
    dial-peer voice 100 pots           
     preference 1
     translation-profile outgoing NOMIG
     destination-pattern 591...               
     port 0/0/1:15
    dial-peer voice 110 pots
     corlist incoming CSSSRSTInternazionali
     description Inbound per ENTRANTI
     translation-profile incoming ENTRANTE
     incoming called-number 321672...        
     direct-inward-dial
     port 0/0/0:15

    Hello Marco,
    There could be two possibilities:
    1. To avoid dial-peer 1 being selected in the dialplan match, when gateway is trying to route the call, you can configure ICMP Probe , which would mark dial-peer as down, in case of WAN failure. So call will use dial-peer 100, automatically, as that will only be an possible match.
    Here is document , in case you are interested in ICMP Probe:
    http://www.cisco.com/c/en/us/td/docs/ios/voice/command/reference/vr_book/vr_m3.html#wp1397581
    2. Ideally default dial-peer hunting mechanism is, Longest - Preference - Random , so as both the dial-peer has same destination pattern, in terms of specific digits and number of wild cards. So it should be looking as preference value of two possible matches, so in this test dial-peer 1 would win. Router will try to route the call using that dial-peer, if fails it should automatically fall back to dial-peer 100 as next choice.
    But please note that it will still use dial-peer 1 at first attempt, as dial-peer status is not linked to interface status or WAN status. To verify this theory , you can remove session target command, and you will see that dial-peer 1, is not even selected in match, that's because removing session target command, will mark is as DOWN for outgoing status.
    Taking below said debugs would help further, in case configuring ICMP probe is not viable option.
    debug voip ccapi inout ( it will help understand , dial-peer match and hunting process ).
    debug voip dialpeer inout
    Hope that helps.

Maybe you are looking for

  • New MacBook Pro - admin password Help

    There is no start up disk w the new MacBook Pro. I recently changed my admin password when it goes to sleep. Must have hit a wrong key, possible w me....nothing is working.  I have to reset it. I was going to register my Mac, had it for a few days, s

  • Boot camp outside mac

    Hi, Does anyone know if bootcamp can create a partition on an external hard drive so i don't need to sacrifice any mac space? Also i have a new macbook which has no sign of boot camp in utilities folder,what is the best route to get it? a down load o

  • Displaying multiple language

    Hi! How can i display two langauges in report, english and urdu? in forms two languages are displaying but in reports urdu character are not displaying correctly my clent character set is WE8MSWIN1252 thanks

  • Creation of DTP - Development in BI

    Hi , There is a function module 'BAPI_IPAK_CREATE' to create Infopackages. Similarly is there a FM to create DTP also. This is for an ABAP development. Or any classes/objects can be used to do this. There is one FM "RSBK_DTP_CREATE_INTERNAL". The out

  • Copy std. Fiori app into Z

    Hi, I want to copy std. Fiori app (Create sales order - SD_SO_CRE) into my new Z (I don't want to modify the standard one), but I realized that there is no starting point, because Fiori app is started from Launchpad, so what I need to add? I think I