FPGA simulation doesn't match actual performance

I am trying to write a verilog code that will trigger on the positive edge and negative edge of an input signal (which I've called 'async'). My desired output is a short blip (when compared to the frequency of async) on each edge of async, which is slightly delayed from the edge ('t1' and 't3') and whose duration can be controlled ('t2' and 't4'). The comments say what I think my code is doing, but I am new to Verilog, and don't really understand anything. Any help is appreciated.
Here is my code:
`timescale 1ns / 1ps
module attempt5(async, clk, o);
input async;
input clk;
reg switch = 1'b0; //will tell me when async changes
reg [1:3] resync = 3'b000;
reg counter = 1'b0; //keeping track of which edge of async we're on
output reg o = 1'b0;
parameter t1 = 0;
parameter t2 = 100000000;
parameter t3 = 0;
parameter t4 = 100000000;
always @ (posedge clk)
begin
switch <= resync[2] & !resync[3];
switch <= resync[3] & !resync[2];
resync <= {async, resync[1:2]};
end
//^^I'm pretty sure this makes the 'switch' register switch very quickly when 'async' changes
//I've included this always block because I wanted to sync my input signal to the clock, because I read that FPGAs don't do well with asynchronous stuff
always @ (posedge switch)
if (counter == 1) begin
counter = 0;
#t1 o <= ~o;
#t2 o <= ~o;
end else begin
counter = 1;
#t3 o <= ~o;
#t4 o <= ~o;
end
//^^ When the 'switch' register changes, start the the short blip
endmodule
and my constraints file:
NET "clk" TNM_NET = "clk";
TIMESPEC TS_clk = PERIOD "clk" 20 ns HIGH 50 %;
NET "switch" TNM_NET = "switch";
TIMESPEC TS_switch = PERIOD "switch" TS_clk HIGH 50 %;
NET "async" LOC = A2;
NET "o" LOC = C1;
INST "clk_BUFGP" LOC = F1;
NET "clk" LOC = F1;
NET "o" SLEW = FAST;
The code works in the synthesizer, but when I try to test the code using a 1 Hz square wave for the "async" signal and monitoring the "o" using a oscilloscope, nothing happens.
Other details: using a Xilinx XEM 6001 FPGA, and ISE Design Suite 14.4 The way I've tested is to hook up a function generator to pin A2 and a oscilloscope to pin C1, and all I see is noise. Is there any obvious problem here, maybe something like I am not actually connecting to the physical pins properly or something?

There are several things wrong for your code to synthesize properly, but I would still expect that your "o" output would toggle at one edge of the input signal if your clock is really running, and your async input from the signal generator is driving the correct logic levels.  I would try a couple tests to make sure this isn't a hardware issue:
1) Change "o" to simply follow the async input.  This will verify that your input and output pins are correct and your input waveform has good logic levels.
2) Build a counter that counts up on evey posedge of clk and run its MSB to the "o" output.  See if this toggles at the expected frequency.  This will show if your clock input is really hooked up correctly and running.
Errors in the code:
switch <= resync[2] & !resync[3];
switch <= resync[3] & !resync[2];
These two lines run in parallel, so switch will really only sense one edge of the input signal.  That's because the second assignment statement "wins" over the first, so it's the same as just writing:
switch <= resync[3] & !resync[2];
If you really wanted to detect both edges, you could OR the two conditions together like:
switch <= resync[2] & !resync[3] | resync[3] & !resync[2];
You could also do this using "if" statements like:
if (resync[2] & !resync[3]) switch = 1;
else if (resync[3] & !resync[2]) switch = 1;
else switch = 0;
There are probably other ways to do this.
Then in the second process you use "switch" as a clock, which is a bad practice.  It's better to use
it as a clock enable like:
always @ (posedge clk)
  if (switch)
    begin
    end
Finally those time delays are ignored for synthesis, so these lines:
#t1 o <= ~o;
#t2 o <= ~o;
are the same as:
o <= ~o;
o <= ~o;
and again, they happen in parallel (non-blocking assignments), so it's the same as
o <= ~o;
Which is why I would assume the output would toggle once per input async period.  If you don't see that you need to verify your connections.
 

Similar Messages

  • Error FFFFFFFE: FPGA Signature doesn't match

    Hi,
    I am using 5640R. When I tried to run the "ni5640R Analog Input" example, the first time would be okay, but the next time will fail with an error FFFFFFFE. The source is "private_5640_signature Register Verify.vi" and the message is "FPGA Signature doesn't match". What can I do to eliminate this error?
    Thanks very much!
    Best Regards,
    Tim Kuo

    hello Sir,
    I want to Generate the Single Side bands (LSB,USB). I got the Am Modulation output but failed in to get side bands.
    I am using PCI 5640R card, i have to check these signals on external oscillsocope.
    please guide me to get these signals.
    Thanks.

  • Simulator doesn't match disk created for menus

    Hi,
    I have created a multimenu, 2 track DVD. I have set all the menu connections in the tracks to go back to the menu button that corresponds to the marker on the track. This works fine in the simulator and all the menu button pushes go back to the correct menu buttons. However, when I build the project and use DVD player to view it, pushing the menu button for track 1 always takes me back to the Chapters 1-6 menu I have created and it always highlights button 1 to matter where I am in track 1. I tried this over and over after deleting preferences, reinstalling DVD studio, restarting and I always get the same result. Is there something else I can try? Is there anyway to examine the build results to see where the error may be? Is there anyway to correct the build results?
    Thanks

    Welcome to the discussions...
    Just to be clear, you have set a different menu call on each chapter marker so that when the track is played, pressing the 'menu' button should take the viewer to the menu which holds the button for that particular chapter marker, regardless of where they started playback from? So in effect they could start from menu 1, watch a bit of the track and then go to menu 5 if they are at a marker late in the track?
    This should work and I would urge you to check your connections in the connections tab. The alternative is to make a simple script and point the menu call at it instead. If I assume that you have got five buttons per menu that play a marker, and four menus (so 20 markers in total), the script is this:
    mov GPRM0, SPRM7
    goto 6 if GPRM0 >5
    goto 8 if GPRM0 >10
    goto 10 if GPRM0 >15
    Jump Menu1 \[GPRM0\]
    Sub GPRM0, 5
    Jump Menu2 \[GPRM0\]
    Sub GPRM0, 10
    Jump Menu3 \[GPRM0\]
    Sub GPRM0, 15
    Jump Menu4 \[GPRM0\]
    So if you are on a marker 1 through to five, line five jumps you to the first menu. Otherwise line 6 (markers 6 through to 10) takes you to menu 2. Line 8 (markers 11 through to 15) go to menu 3 and beyond marker 15 you go to line 10, and thus menu 4.
    The square brackets are GPRM based button jumps, meaning you will land on the button with the number value the same as the marker on that menu. To make sure that the marker values equal the button values (i.e. 1 through to 5 on each menu) I've subtracted a value accordingly each time.
    The scripted solution is probably overkill, but will work reliably. You should check your connection settings first, and remember that the simulator is NOT a good indication of what will actually happen, only an approximation.
    Good luck!

  • Source list "PODCASTS" # doesn't match actual # of Podcasts

    The sourcelist under "Podcasts" indicates I have 29 Podcasts. When I highlite the item, I see only 7 blue dots and actual podcasts. I watched several downloads progress and complete. Why aren't they in my library?

    In case anyone experiences this problem, I thought I should close this by reporting that, having installed a recent software update, the problem is now fixed.  In other words, it was a bug.  iTunes now shows me only the PDFs which are in iBooks (on the Mac) and my grouping in Collections now syncs correctly with my iPhone and iPad.

  • Thumbnail doesn't match actual photo

    Something very strange is going on with my iPhoto. I have just imported some photos but when you click on the thumbnail, it expands to a completely different photo! Its therefore impossible to see the full size photo of a particular thumbnail/preview. Any ideas what has happened? help!

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Include the option to rebuild the thumbnails. It can take 3 or 4 goes for this to work

  • Error: The decapsulated inner packet doesn't match the negotiated policy in the SA

    I upgraded my ASA from 8.2(1) to 8.4(3) as I wanted to try to get Android devices to properly connect via VPN.
    After some effort, I was able to get the Android devices to connect via VPN.  However, my syslog server has a number of errors recorded that look this this:
    %ASA-4-402116: IPSEC: Received an ESP packet (SPI= 0x1E76EFA6, sequence number= 0x1F0) from x.x.x.x (user= testuser) to y.y.y.y.  The decapsulated inner packet doesn't match the negotiated policy in the SA.  The packet specifies its destination as z.z.z.z, its source as a.a.a.a, and its protocol as tcp.  The SA specifies its local proxy as y.y.y.y/255.255.255.255/udp/42246 and its remote_proxy as x.x.x.x/255.255.255.255/udp/0.
    Digging further, it seems this error might be due to a NAT issues with the VPN connections.  VPN previously worked with Cisco's VPN client on Windows, though I did not test to see if that is no longer working.  However, I made no changes in the config, except for those related to additions needed to support L2TP.  With the below config, Android clients can connect to the ASA and access the internal network, but they cannot connect to external addresses.  I'm at a loss.
    The addresses used in the config: 192.168.1.0/24 are on the internal LAN and 192.168.3.0/24 are addresses assigned to VPN clients.
    I noted in the config this line:
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    The access list is not referenced anywhere, though it was referenced in the 8.2(1) config like this:
    nat (inside) 0 access-list inside_nat0_outbound
    I'm not sure what else changed, but I've looked over the config and I just cannot see what the issue might be.  I'm hoping somebody might be able to point out my error.
    Here's the config file (at least the parts that might be of interest):
    : Saved
    ASA Version 8.4(3)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    boot system disk0:/asa843-k8.bin
    object network obj-192.168.3.0
    subnet 192.168.3.0 255.255.255.0
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    access-list outside_access_in extended permit icmp any interface outside time-exceeded
    access-list outside_access_in extended permit icmp any interface outside echo-reply
    access-list outside_access_in extended permit icmp any interface outside unreachable
    access-list outside_mpc extended permit ip any interface outside
    access-list inside_mpc extended permit ip 192.168.1.0 255.255.255.0 any
    access-list testVPN_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    ip local pool VPN-Pool-1 192.168.3.1-192.168.3.254 mask 255.255.255.0
    ip verify reverse-path interface outside
    nat (inside,any) source static any any destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
    object network obj-192.168.3.0
    nat (outside,outside) dynamic interface
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group outside_access_in in interface outside
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    group-policy testVPN internal
    group-policy testVPN attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value testVPN_splitTunnelAcl
    default-domain value test.us
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    group-policy testVPNns internal
    group-policy testVPNns attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    username testuser password PASSWORD encrypted privilege 15
    username testuser2 password PASSWORD nt-encrypted privilege 15
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group testVPN type remote-access
    tunnel-group testVPN general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPN
    tunnel-group testVPN ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNns type remote-access
    tunnel-group testVPNns general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNns
    tunnel-group testVPNns ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp type remote-access
    tunnel-group testVPNnsl2tp general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group testVPNnsl2tp ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp ppp-attributes
    authentication ms-chap-v2
    One last question: in order to get the connection from Android to work, I was forced to use "tunnel-group DefaultRAGroup".  Is that actually a limitation, or did I make an error that forced that requirement?  I wanted to use "tunnel-group testVPNnsl2tp".
    Thanks!

    Chris,
    This is still a bit off the mark.  I think I might be confusing the issue by including some of the VPN configuration that I had previously installed and working (e.g., two other VPN tunnel groups with split tunneling on one of them).  Let's just remove that stuff from consideration.  I actually tested the current configs just to see if they are working since the upgrade.  testVPN is working with the split tunneling, but testVPNns (no-split tunneling) does not allow external access.  I guess there is a NAT config issue there, too, but not sure what it is, yet.  I've not investigated that closely.
    I want to solve one problem at a time, though I understand there are some interdependencies.
    What I'd like to focus on right now is just the L2TP VPN connection.
    From what I've been able to understand from the documentation, what I need are these lines:
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key P74bmqL6rT40bl5
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    I still want to assign the IP addresses to VPN clients out of 192.168.3.0/24.
    The tricky part is understanding exactly what NAT rules to insert and to avoid that error message I'm getting relatred to the encapsulated packets.  I tried to introduce the commands you had, but it's missing stuff that I would need for L2TP/IPSec (e.g., "mode transport").  I also don't think I want "pfs group5".  The above config "works" in that I get connected -- all negotiation is done.  It's just that packets from the VPN client are not able to go out to the Internet and I'm seeing that encapsulation error messages when I try to send a packet.
    Paul

  • Bounding Box Doesn't Match Object (Illustrator CS4)

    I'm not sure if this is an error on my part or a bug, but for the last week or so, the bounding box for my objects hasn't actually matched the objects. This is really problematic when I try to transform the object using the bounding box handles.
    On occasion, after I transform the object the bounding box will match it again and will transform correctly. Sometimes it will stay off. If it does reorient itself, undoing the transformations back the original size will cause the bounding box to reset back to it's mismatched state.
    Things I have tried to resolve the issue:
    Reset the Bounding Box
    Copying and pasting the shape to a different document
    Starting a new document from scratch (I thought it was possible I corrupted the file)
    Return Keyboard Shortcuts to the Default
    Restarting Illustrator
    Restarting my System
    To my knowledge, my system hasn't been updated in the last week nor has anything new been installed. However, IT does push out maintenance so there is a possibiltiy that it was updated and I don't know about it. The only programs open while working in Illustrator are Bridge, Outlook 2007, IE8, Explorer, InDesign CS4, Word 2007, Photoshop CS4, Acrobat Professional 9, Dreamweaver CS4, PowerPoint 2007, Previewer and possibly FireFox 3.something (though not necessarily all at once - generally about 7 of the above listed). My system runs XP Professional SP3 with an Intel Core2 Quad @ 2.66GHz and 3.25 GB of RAM. The objects are not grouped, do not contain clipping masks, do not contain transparency masks and are not compound paths. They are simple paths/shapes, often rectangles.
    I have included some pictures to better explain my issue. This first image indicates how the bounding box doesn't match the rectangle.
    The second image shows the process of transforming the shape via dragging.
    The third image shows the result.
    Thanks for any help you can provide!

    Mr. Bugge:
    Thank you for your response and I apologize for the delay in mine. I couldn't try all of the fixes immediately because I had to complete some job duties before I could tinker with this issue.
    Things that did not work:
    Closing Firefox
    Clearing the Preferences
    Moving the Preferences Folder
    Deleting Temp Files
    Closing Other Adobe Programs (Including Bridge Running in the Background
    Things I cannot do for various reasons:
    Re-installing Acrobat
    Turning Off the Firewall (My Company Only Uses 1 Anyway)
    Things I haven't tried yet but hope to try later:
    Update Printer Definition or Change Default Printer
    Check for Corrupt Fonts
    Clear My Font Cache
    Things I learned:
    The issue is most easily recreated by transforming an object to a smaller object. However, zooming in will realign the bounding box but it will only stay aligned when zoomed in. I find it very curious.
    Even if I don't end up finding an answer, I do appreciate your time and help.

  • HT2484 How do I actually PERFORM a sync, AFTER I set up syncing?

    AFTER setting up syncing (via iTunes to sync iCal with my iPad and other devices), do I have to MANUALLY sync iCAL each time to my devices OR can I set it up to SYNC AUTOMATICALLY; and if I can sycn automaticall, then HOW OFTEN will a sync be done automatically and can I set the frequency?  I am not asking how to SET UP to sync.   I have already done that.   I am asking HOW TO ACTUALLY PERFORM THE SYNC and CAN I GET devices such as my iPAD to SYNC with iCAL automatically?   Thank you.

    Hello there, SethC33.
    dleaonhardt offers a good option. If that doesn't work for you, the following Knowledge Base article offers up some additional steps for troubleshooting Touch ID:
    iPhone 5s: Using Touch ID
    http://support.apple.com/kb/HT5883
    Particularly:
    Troubleshooting Touch ID
    Ensure that your fingers and the Home button are clean and dry.*
    Note: Cover the Home button completely. Don't tap too quickly, don't press down hard, and don't move your finger while Touch ID is scanning.
    Tap Settings > General > Passcode & Fingerprint > Fingerprints and verify:
    Passcode Unlock or iTunes & App Store is enabled.
    One or more fingerprints have been enrolled.
    If one finger isn't working, tap Edit in Settings > General > Passcode & Fingerprint > Fingerprints > Editto delete and then reenroll the finger.
    If that finger still isn't working, try enrolling a different finger.
    If you are unable to enroll any of your fingers, take your iPhone 5s to an Apple Retail Store, Apple Authorized Service Provider, or contact AppleCare for further assistance.
    If you are unable to complete Touch ID registration in iOS Setup Assistant, restart your iPhone 5s.
    * Moisture, lotions, sweat, oils, cuts, or dry skin may affect fingerprint recognition. Certain activities can also temporarily affect fingerprint recognition, including exercising, showering, swimming, cooking, or other conditions or changes that affect your fingerprint.
    Thanks for reaching out to Apple Support Communities for answers to your issue.
    Cheers,
    Pedro D.

  • Closing Stock Valuation doesn't matched physicallly

    Hi SAP Gurus.,
        Can you please assist me reg this issue"Closing Stock Valuation doesn't matched physicallly".
    May I know the possible rectification ways to solve this problem.
    Thanks in Advance,
    Regards,
    Balaji Bhonsle

    Physical Inventory...
    http://www.sap-img.com/materials/physical-inventory-process.htm

  • Iphone 5 system serial no doesn't match with outer box? Case of misprint? i see only one latter is serial no doesn't match

    I recently bought iphone 5 32gb white. Was surprise to see the outer box serial no doesn't match with iphone 5 system.
    They have print XXXXXXTXXXX on box and on phone its XXXXXX7XXXXXX. Only one latter is mixprint though.
    I check coverage status at apple site. The box serieal no is not found in apple system while the iphone 5 inside serial no i can see warrenty.
    plz help is it normal to have serial no unmatched on phone and box or the phone is not genuine

    You are correct. The SIM Tray of iPhone 5 does not have the Serial #  printed on it. So your Serial # is the one in the Settings app About. This is your true Serial #. A 7 and a T from a box label are not distinct enough to matter. Apple will only honor the Settings About Serial # and the ones located inside the iPhone 5, which will be the same as the About Serial #.

  • Itunes will no longer accept any of my credit cards.  Says security code doesn't match with any card I use.  I have inputted new card info in the apple store area and it still says the same thing in itunes.  Customer service is no help at all.

    Itunes will no longer accept any of my credit cards.  It says vcode doesn't match when it does.  Customer service is no help.  I have re-inputted the info in the account section of the apple store and in itunes--still says vcode doesn't match.

    Itunes will no longer accept any of my credit cards.  It says vcode doesn't match when it does.  Customer service is no help.  I have re-inputted the info in the account section of the apple store and in itunes--still says vcode doesn't match.

  • HT1758 Are all Intel 24" iMacs w/Snow Leopard OK for Mountain Lion?  My serial number doesn't match any of the one in the iMac ID list; they all start with "MA" or "MB", mine starts with a "W." Purchased direct from Apple August 2007.

    Are all Intel 24" iMacs w/Snow Leopard OK for Mountain Lion?  My serial number doesn't match any of the one in the iMac ID list; they all start with "MA" or "MB" and mine starts with a "W." Purchased direct from Apple August 2007.

    Macs that can be upgraded to OS X Mountain Lion
    iMac (Mid 2007 or newer)
    MacBook (Late 2008 Aluminum, or Early 2009 or newer)
    MacBook Pro (Mid/Late 2007 or newer)
    MacBook Air (Late 2008 or newer)
    Mac mini (Early 2009 or newer)
    Mac Pro (Early 2008 or newer)
    Xserve (Early 2009)
    Open System Profiler and report what you find displayed for the Model Identifier.

  • Image in Lightroom doesn't match exported image viewed in Photoshop

    After all my hard work in Lightroom, I export the image to a folder on my hard drive. When I open this exported image in Photoshop and view it alongside the Lightroom version of its "twin" in Lightroom, there is a significant difference. Why is this? I want to use these images in my books, but my time is wasted if I end up with anything other than what I created in Lightroom. Shouldn't these images match exactly?

    Thanks Jao and Michael...the color management idea makes a lot of sense.
    Adding to this idea, when I open the Pshop file I get a message about the doc having an embedded profile that doesn't match current RGB working space, and the usual 3 options: Use the embedded profile, Convert color to the working space, or discard embedded profile. No matter which option I choose, none of the opened docs match the Lightroom version.
    The color balance is fine, but the colors aren't as vibrant. The Pshop photo is dull and lifeless compared to the Lightroom version. I used Clarity which added subtle brightness, and Vibrance to crank up the color in LR which added wonderful dimensionality and punch to the landscape scene, but the Pshop version has dulled these back down.

  • I want to email a photo through iPhoto but it says I need a password... I entered my password but it says it doesn't match - what password do they want and how do I fix? (Facebook and other social media iPhoto posts work - just email asking for pass)

    I want to email a photo through iPhoto but it says I need a password... I entered my password but it says it doesn't match - what password do they want and how do I fix? (Facebook and other social media iPhoto posts work - just email asking for password)

    Your email password.
    iPhoto '11: Email your photos
    Open Mac Mail. From the Mac Mail menu bar click Mail > Preferences then select the General tab.
    Make a selection from the:  Default email reader   pop up menu.

  • Video copied to DVD doesn't match project I can see

    Okay,
    Probably another basic question but I can't find an answer in the Adobe manual. I just discovered (after burning 8 copies of the same file) that the movie on the DVD doesn't match what I see in the Project screen. The dropdown of the Organize>Project looks like what I want to see except that it seems to have the original avi file that I subsequently edited as well as the edited file. The sceneline looks correct. The timeline looks correct. I have tried eliminating the "markers" but there weren't any to eliminate - the menu drop down only gave me the option to add markers. One hint is that the DVD is picking up a menu template that I was playing with but couldn't get to work and then deleted. I ended up using the very basic title screen with black video from the top line Title dropdown menu instead of the Template option in Edit. I can see the new title in scene and timelines. Again, per previous question just posted, I see nothing in the clip screen
    (i.e. th boxes) under "organize". Also, the video clip on the DVD appears truncated by approx. half the play time.
    At one point I could get only the old menu template clip  to show up just below the montor screen but couldn't figure out how to delete.
    thx

    Camcorder is a Sony Handcam D8 Digital Video, not minidvd. Tape was transferred using Adobe Premiere elements 9 with brand new firewire.
    First screen capture below shows only one of two black screen titles upon opening program. Nothing in media boxes. Second Capture shows frame of video clip as a result of double clicking on the third sceneline box. Third screen capture shows what the DVD opens with when played after burning. I have tried to create this from scratch but can't get rid of the fancy menu screen in the third screen capture below. Replaying the movie using the sceneline or timeline prior to burning the DVD doesn't show the "fancy picture frame" with the "play movie" option shown in the dvd playing in the third capture below. Does this help? It seems to be something like an invisible preset that I can't get rid of.
    C

Maybe you are looking for

  • Problems with deploy on OC4J 10.1.3.2 with hibernate persistence.xml

    Hi all, I can't deploy an EAR/WAR into oc4j 10.3.2.0 stand-alone, I have the following error message : 2008-03-26 19:50:38.721 NOTIFICATION Binding opsky-webapp-1.0-SNAPSHOT web-module for application opsky to site default-web-site under context root

  • Importing users into WGM from csv file issues/crash

    Hi, i've been importing user information from csv files into WGM via the +server >  import+ function . It worked the first few times but now when i try the import progress bar pops up and promptly disappears without any thing importing. i've tried re

  • How to install Windows 7 from a bootable usb in Mavericks

    I updated to Mavericks (os x 10.9) a few days ago and finding it near impossible to install windows 7 on my macbook pro mid-2010.  I put Windows 7 64 bit on a bootable usb using a windows pc.  Any time I try and use the Boot Camp assistant it gives m

  • In Finder since 10.8.3 – delay when quickly moving items around

    I think this is new since the Finder of OS X 10.8.3. It's kind of hard to explain, but here goes: If one triest to move items around quickly after each other, there's like a second delay before you can do the second "grab". Like this: click and drag

  • Billing error, billing error

    Dears, After buy the Mountain Lion SW, when reaching to billing window and fill all required bill info, there was an error occured that says " Forr assistance contact iTuns support at www.apple/support/iTunes.