Hardware HANDLE in CIN

I want to use the following code to open a device and return a HANDLE. How do I program my code to do this with a CIN.  I did manage to write a wrapper DLL for the same device and that is working fine, but I trying to do the same with a CIN.
HANDLE PortOpen(VOID)
 hPort = CreateFile ("\\\\.\\SDCI0\\0",
      GENERIC_READ | GENERIC_WRITE,
      0,
      NULL,
      OPEN_EXISTING,
      FILE_ATTRIBUTE_NORMAL,
      NULL);
 return hPort;
Please note I'm a beginner, unfortunately the explanation in the Labview documents is not clear enough for me.

CEE,
I may be missing some of what you're trying to communicate but I still think you could use the CLFN to accomplish the "modular" function calls (open, read, write, close). In the CLFN, you can add dll functions to each instance of the node. So make a vi that calls the "open" function of the dll. Then make another vi that calls the "close" function of the dll. I assume that you already have functions inside the dll that preform the desired actions.
However, if you're still set on using CINs, the "Using External Code In LabVIEW" help is a great resource. (I assume you're using LabVIEW8). If you go to Help>>Fundamentals>>Calling Code Written in Text-Based Programming Languages, I think you'll find some really good information in there. See the attached picture.
Chris C
Message Edited by Chris_C. on 05-30-2006 10:55 AM
Chris Cilino
National Instruments
LabVIEW Product Marketing Manager
Certified LabVIEW Architect
Attachments:
external code help.JPG ‏108 KB

Similar Messages

  • External I/O devices (Hardware) handling in ABAP

    Hi,
        I just want to use my Webcam in ABAP .plz help me in this regard.
    Thanks

    Thanx François.Will u plz help me doing this?Please explain in details.Actually i havent decided for what i want to use this,but if such case is there then what should be done?

  • CIN: Return STO process

    Hi All,
    I have the scenario regarding to Return STO process.
    Step1: Creating the return STO process.
    Step2: Negative goods receipt through MIGO. The movement type is 161.
    Step3: Creating delivery through VL10B. When iam doing the Post goods receipt (Negative post goods issue) through VL02N iam getting below error.
    Error: Purchase Order XXXX does not contain items for a stock transfer
    CIN related issue: How to handle the CIN ACTIVITIES. What transactions we have to use for updating or adjusting the Cenvat accounts. And what documents we have to use as references.
    Please help me to solve these issues.
    Thank you
    Regards
    Lakshmikanth

    Hi All,
    Any ideas please?
    Regards
    Lakshmikanth

  • Process for material returns from Customer, mapped in CIN

    Hi Gurus,
    I have some queries (below) pertaining to CIN.
    1. How is the Customer Materials returns is handled in CIN? What is the process flow (transactions)? Since, the goods are returned we can avail the excise duty paid earlier? So, is the RG23A Part 2 and RG1 register updated? How?
    2. Due to incorrect excise values, if cancel the excise invoice, then is the RG23A Part 2 updated? What about RG1 updation? After cancellation of the existing excise invoice, if we create a new excise invoice is the RG1 updated with new Excise duty values?
    Please share your inputs.
    Appreciate a process flow document for above, if anybody has. Please mail at [email protected]
    Thanks,
    Amit

    Hi amith,
    for return process you have to follow RE document type and LR for pgr
    while coming to excise you should have to do J1IEX without purchase order the the values of excise will be reversed .
    it should resolve your issue
    bvdv

  • Stock adjustment in CIN part

    Hi all,
    We are working in CIn client.
    Now we have done Physical inventory for a material.
    We done MI01, MI04 and MI07 and adjusted IM part.
    To cover excise part in which tcode we need to do excise adjustments in case of shortage and excess? The material are excisable and we have paid exicse duties during procurement.
    I also need to know in case of issue to cost center and scrap handling in CIN part.
    Request your help.
    Thanks
    A.Gururajan

    Hi,
    I hope there is no link between physical inventory & excise.
    Normally we do physical inventory to make sure that Book Qty & physical Qty are the same.
    As you said, when you procure you have already paid the excess duties. So incase of any excess or shortage in stock if needed you can pass a excise JV using J1IH.
    I am not sure whether we need to do an excise adjustment as part of the physical inventory activity.
    Thanks & Regards,

  • CIN - Customer Material returns

    Hi Gurus,
    I have some queries (below) pertaining to CIN.
    1. How is the Customer Materials returns is handled in CIN? What is the process flow (transactions)? Since, the goods are returned we can avail the excise duty paid earlier? So, is the RG23A Part 2 and RG1 register updated? How?
    2. Due to incorrect excise values, if cancel the excise invoice, then is the RG23A Part 2 updated? What about RG1 updation? After cancellation of the existing excise invoice, if we create a new excise invoice is the RG1 updated with new Excise duty values?
    Please share your inputs.
    Appreciate a process flow document for above, if anybody has. Please mail at [email protected]
    Thanks,
    Amit

    Hi,
    Expect comments / inputs from other experts as well.
    Thanks,
    Amit

  • Can I automate a VI to test hardware through CAN with some sort of script?

    I am trying to automate some hardware testing over the CAN bus.   I have started a basic VI that I can manually run these tests, but there are testing scripts available to me and I was wondering if there is a way to import some sort of scripts (or similar) into LABView to automatically run my VI to perform the test.  I've done some searches, but looking for scripting only comes up with MathScript that MATLAB related information.
    Thanks for the help.

    stupidlogic wrote:
    Thank you very much for the help.  To be honest, I'm new to LabVIEW development and so I don't have any experience in importing scripts whatsoever.  Assuming I have the script written in the suggested format...
    Do I keep it saved as a .xls?
    What subVI block do I import it into LabVIEW with?
    Also, I haven't looked at every script I'll be dealing with (only a couple) and therefore, I don't know how complex it may get.  Do you know where I can access some resources on learning to use TestStand?  I've never used it before.  Even just answering the basic, what does it do/how does it work would be helpful.
    Once again, I appreciate all the assistance.
    We may be calling it as script,but to the core,you are developing an appication to read excel sheet,your logic should segragate each steps action and you should have LabVIEW code wherever an action is required. If you are planning to do this task in LabVIEW, you need following steps to finish.
    VI to read your excel sheet and format it to a 2-Dimensional array(Format the array to remove unnecesary characters).
    A state machine(code architecture) which will be guided as per the states in your excel sheet.
    A hardware handling loop to generate and acquire data for your main code(state machine).
    Use CAN Channel API in case you have a defined CAN dbc file.
    If no dbc file, go for frame API.
    In case you are using TestStand, you need go for an architecture where your CAN periodic data transmission is taken care using LabVIEW.
    Honestly it's not the task of a novice LabVIEW\TestStand programmer if you have less time ro learn. If you provide your e-mail address, I can send you a scaled down code after removing proprietary stuff. 
    Following link is an introductuction to Teststand:
    http://zone.ni.com/devzone/cda/tut/p/id/6073
    Regarding availability of resources to learn LabVIEW and TestStand,Can any one who is following this thread can suggest any materials ?

  • How can I permit all traffic from inside-dmz-outside on asa5505

    Scenario :
    Servers are in DMZ, Internal LAN Users should access ports Specified (5000 & 2048). Router 2801 is facing Leased line; from there it’s connected to firewall.
    Router LAN IP: 83.111.X.X - 255.255.255.X
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password 2KFQnbNIdI.2KYOU encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.X.X 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 83.111.X.X 255.255.255.240
    interface Vlan3
    nameif dmz
    security-level 100
    ip address 192.168.100.1 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    switchport access vlan 3
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    switchport access vlan 3
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 83.111.x.x
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.1.2-192.168.1.254 inside
    dhcpd enable inside
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:5663409d6ba3ad0bcd163e691f032f76
    : end

    Hi Ben,
    Thank you for the response. I followed the link and tried reading everything you posted on AEs but I'm afraid that I didn't understand it all. It seems that each AE example had a single input and a single output (e.g. a double). Is this the case? 
    What I have is a couple of front panel clusters containing (approximately) 18 control doubles, 8 indicator doubles, 5 boolean radio button constructs and 26 boolean control discretes. I clusterized it to make it readable. In addition I'll eventually have a cluster of task references for hardware handles.
    All I want to do is update the front panel values like I would do in a C, VB or any other language. I've tried referencing the cluster and using the reference from inside the loops. I've tied using local variables. Neither works. I'm experimenting with globals but it seems that I have to construct the front panel in the gloabal and then I wouldn't know how to repoduce that on the front panel of the main VI.  Sometimes it seems that more time is spent getting around Labview constructs than benefitting from them.
    I hope the 'Add Attachment' function actuals puts a copy of the VI here and not a link to it.
    Thanks again for the suggestion,
    Frank 
    Attachments:
    Front Panel Reference.vi ‏33 KB

  • How can I update cluster items from inside a while loop that does not contain the cluster?

    I have a VI that contains front panel clusters and two while loops. The main cluster contains items such as a doubles "distance" and "stepsize" and boolean "step" (a whole buch of this type stuff). The first loop contains an event structure to detect front panel changes and the second contains code and sub VIs to perform operations based on detected events.
    The operator can enter data into either double or click the boolean. If distance is changed the second loop does what is required to process the change. The same happens with stepsize. If step is clicked the ±stepsize value is added to distance and the result is processed. In each case the front panel should track the result of the input and subsequent processing.
    Because the clusters are outside the while loop, they are not updated unless I click 'highlight execution' which seems to allow updating each time the execution highlight is updated. There are other issues if I move the clusters into one of the loops.
    I've tried referencing the clusters and using local variables and nothing works. It looks like overkill to use shared variables for this.
    Any ideas would be greatly appreciated.
    Thanks,
    Frank    

    Hi Ben,
    Thank you for the response. I followed the link and tried reading everything you posted on AEs but I'm afraid that I didn't understand it all. It seems that each AE example had a single input and a single output (e.g. a double). Is this the case? 
    What I have is a couple of front panel clusters containing (approximately) 18 control doubles, 8 indicator doubles, 5 boolean radio button constructs and 26 boolean control discretes. I clusterized it to make it readable. In addition I'll eventually have a cluster of task references for hardware handles.
    All I want to do is update the front panel values like I would do in a C, VB or any other language. I've tried referencing the cluster and using the reference from inside the loops. I've tied using local variables. Neither works. I'm experimenting with globals but it seems that I have to construct the front panel in the gloabal and then I wouldn't know how to repoduce that on the front panel of the main VI.  Sometimes it seems that more time is spent getting around Labview constructs than benefitting from them.
    I hope the 'Add Attachment' function actuals puts a copy of the VI here and not a link to it.
    Thanks again for the suggestion,
    Frank 
    Attachments:
    Front Panel Reference.vi ‏33 KB

  • Mac Book Pro - SATA vs FW800 external drives

    I am pruchasing a MBP this week for road editing and I have a few storage questions for those in the know.
    In the past I have always blindly trusted a single external FW drive to capture, store and edit my projects. Since these jobs would be 5-10 days straight work and then playback at the end, there is little time for backup during a project. You hardly have enough time to sleep. Thankfully, I have never experience a hard drive failure and have always completed the dedline. But, I have collieges that have run into nightmare harware failure and lost everything one night before playback. So, with the cost of external drives so cheap right now there are several options to explore for my new road system so that I never experience this, EVER.
    Which one is best method for FCP editing in DVNTSC, DVCAM or HDV for reliabily and mirrorer backup during a quick, but always important job on-location job?
    1. Just continue to buy multiple individual external FW800 or 400 drives and mirror them using software, like chronosync ...This is what I do now and this works for nightly backups in house, but what about for jobs that last for days and store 100's of gigs of video? There is no time for this daily backup...
    2. Buy multiple FW 800 drives and set up a RAID 1 using software...? I have not done this and have heard it can be CPU intensive since it's software based. Can this be done and still be able to capture hours of footage on the fly without a dropped frame or problem?
    3. Buy a large RAID 0 or 1 system like the 1TB Two Big from Lacie or the G-SATA RAID system from g-technology so that the hardware handles the RAID mirroring between the 2 drives in one housing... or does this method also come with software to do the RAID 1 configuration?
    Basically, I don't ever want to get into a spot in the future where a client on the road didn't get their finished product because of a failure on my drives part. So, I feel that the RAID 1 system setup, with swappable drives is best, but since I have not successfully done this before, does anyone have any suggestions or have this successfuly set up now using FCP?
    And... which drives are better over all for this FW 800 or SATA drives? I even saw some drives with quad interface... that's cool.
    Thanks for any help.
    Tom

    Keep in mind a RAID 1 only protects you from hardware failure of one of the drives. It does not protect you if the hardware raid/chip set decides to take a vacation. Also, if FCP corrupts a file, it is written as corrupt to both drives.
    I'm a big fan of separate but equal. Two drives. One goes to the site, the other remains at the hotel. At night, you back up the site disk to the the hotel disk. If something happens to the computer and the disk at the site the next day, you at least have the material back at the hotel.
    eggs. baskets. that sort of thing.
    good luck.
    x

  • Indesign server web service - where is the support to upload a file with the script and download the result?

    Hi,
    I am working on a POC that is supposed to convert indd files to pdf (i.e. using of course the indesign server). Basically I want to call the IDS Web Service (located on a different machine perhaps), pass in the input file, the conversion script and retrieve the result as part of the WebService call? 
    Browsing the documentation, examples, etc in the SDK, I couldn't see how the above can be achieved without the client handling the file transfer. Surely I must be missing something ...
    thanks
    Chris

    What do you mean with POC?
    InDesign Server is too precious (i.e. license cost) to waste its time with file transfers.
    For a smaller scale, let a separate process (some http or smb server) on the same server hardware handle the files - so that the InDesign Server can access them on the fastest local volume.
    If you plan for bigger, use a dedicated server for file sharing (your choice of SMB, NFS or whatever), where the input files are prepared by the client process, so that your load balancer can immediately point the next free instance of the InDesign server farm to the file. In that case be prepared for some try and error - high speed file sharing can be tricky with files written from one side not yet visible or incomplete to the other side, locking problems, Unicode file name trouble, unexpected time stamps and so forth.
    Btw, there is also an InDesign Server forum which would be more appropriate for such discussions.
    Dirk

  • External display sound delay

    Hello all - Surprisingly I couldn't find this in searches on the forum, so looking for input. I've got an external monitor hooked up via firewire through an HDV deck. There's the expected sound delay (about 5 frames), but how do I get rid of it? Can I buy a video card to put in the G5 with analog outputs to take care of the transcoding delay? Or is there a setting to delay the audio like in Avid? Thanks!
    J

    That's a better way to ask my question: How can I get video and audio to follow each other in sync to an external display and have both my computer and external monitor all play in sync?
    Right now I'm monitoring audio strictly from computer line out speakers, and I'm monitoring video out through firewire via an HDV deck, so I understand why there is a delay. However, it's unrealistic for me to turn down my computer line out speakers and turn up my external monitor speakers every time I need to play back for clients.
    I've tried fuddling with the Playback Controls Frame Offset, but it only delays my video playback on the computer, not the external monitor.
    Surely there is a hardware solution for professional editors? A board I can purchase to install in the G5? I could throw a mixer into the mix for quick mute access, but not sure what hardware even to purchase to output from the computer for that. I'm accustomed to Avid hardware handling this, but I don't know where to find FCP hardware recommendations. Is this the right route?

  • Build and test Flex 4 in Hudson?

    Hi
    May I know how to build and test Flex 4 web application in the continuous integration server like Hudson?
    I think tutorials have been describing of how to develop Flex 4 application using Flash Builder. Is it possible to build Flex application from command line (so that it can also be called from Hudson)?

    I was able to convert a VI that contains a call to a library function (in this case, a DLL) into a DLL.  I have isolated my problem to passing a hardware handle through multiple layers of library calls...  My handle is a U32 that I am passing as a value at each layer. 
    I talk to my hardware via a DLL provided by my third party vendor.  I have some LV code and a call library function in a subVI.  When I convert my subVI to a DLL, my hardware does not respond as it should -- it behaves as if I have not opened a session with it even when I have already opened a session.
    I remember reading somewhere that handles had to be initiated from the same process...  does anyone know the details of how this works?
    Regards,
    mlloyd

  • Blackberry Curve 8330 OS 4.5 sound "crash"(all sound stops)

    Issue:  No sound of any kind for anything.  When calls, messages, or notifications are recieved the LED blinks as normal and the phone will vibrate if it is set to.  Sounds do not play for any notification or in the media player;  All sounds show up properly and their lengths display as normal however when play is pressed almost nothing happens.  The play button changes to pause(as it should during playing) and a progress bar appears, but the player stops almost immediately and without playing any part of the sound(the changes are only visible for a moment).
    What causes the issue:  Unsure.  I believe whatever underlying portion of the OS that controls sounds is crashing when it is called to play a sound, but I don't think it's any sound in particular.  The first time I encountered this issue I was changing notification tones and browsing through the list of sounds.  The sounds were playing as normal and then simply stopped upon selecting a tone from the list(there was the normal delay as if it would play the sound, and then nothing).  I had played the sound before, and it was a default sound.  This time(the second time) sound stopped as I recieved a notification.
    How to solve: Temporarily, popping the battery out and putting it back in seems to reset the issue.  It doesn't happen very often, but I haven't found a consistent trigger other than trying to play a sound(any sound).  For good?  That's what I'm hoping you can tell me.  Could this be a bug with the way the current OS version on the 8330 hardware handles audio?  I hope this is something that can be fixed, or will be in the future.
    Message Edited by Spewn on 09-11-2009 07:25 PM

    You can download the software from Alltel's webpage. For assistance upgrading please see the link below.
    http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=ex&bbid=TSEBB_1206041566938&url=&stat...
    Feel free to give Kudos if I have helped you.

  • Hi   Is it possible to divert a single number on my contact list without diverting all calls  iphone 3gs 32.  Thanks

    Hi   Is it possible to divert a single number on my contact list without diverting all calls??  iphone 3gs 32.
    Thanks  
    Andy.

    Do you mean forward one number only?  If that's what you want then no, you cannot.  You can use call forwarding to forward all calls, but not selected contacts only.  I'd add that would be a function of the carrier to, as when you activate call forwarding it sets the switch on your account with the carrier, and their hardware handles the call forwarding (i.e. the phone itself has nothing to do with actually forwarding calls or not - it is the carriers equipment that manages that - all the phone can do is tell the carriers system to forward calls, or not).

Maybe you are looking for

  • Error while updating to target type INFOCUBE

    Hi, After BI SP16 Upgrade, we noticed that data load to a cube with DTP (7X DS) with partioning active, it would error out saying, "Error while updating to target " " type INFOCUBE....we applied note '1148007' and did reactivation of related structur

  • Usb 2.problem on ms-6830 kt3 ultra aru v1.0

    I have a strange problem with my kt3 ms06830 ultra aru v1.0 When i connect a usb 2.0 hd bracket to the d-bracket (usb 2.0 highspeed bracket) It runs slow as hell my config windows xp pro sp2 amd 2100xp ms-6380 v1.0 hd 2 x 80 striped (raid) 512 mb mem

  • Image quality in ImageIO.write();

    Hello, Ive made a prog to convert a BufferedImage into a jpeg and write the jpeg to file: ImageIO.write(image, "jpg", file); does anyone know how i can specify the encoding quality? Thanks, Jim

  • Fonts and letter size on iCloud mail

    I want to change the font and letter size in my emails but every time I want to send a new email, it has gone back to the default setting so I have to change it for every email - a real nuisance. Is there any way to set it and make it stay? It even h

  • Acquire 2 digital signal with custom scaling (Engg Units)

    I am a newbie to DIO world. I have write a VI to acquire 2 digital signals. one from a load cell and other for motor rpm (pulses). I need to acquire these two signals and then convert them into engg units using custom scaling and write them to a txt