How do I configure a counter to generate pulses using DAQmx?

How do I configure a counter to generate pulses using DAQmx?
Is says in the DAQmx C reference help
"CtrnInternalOutput—The signal at this internal terminal is where the pulsed or toggled output of the counter appears. The output of a counter pulses or toggles when the counter reaches terminal count. When counting down, the counter reaches terminal count when the count reaches zero. When counting up, the counter reaches terminal count when the counter rolls over. To configure the counter to toggle or generate pulses, use the Export Signal function/VI with Counter Output Event as the signal name."
I've tried this but can't get it to work, I may have the parameters wrong or something. The DAQmxExportSignal() function is very unintuitive to me. Here is my counter config code...
int ret = 0;
ret = DAQmxCreateTask("",&task_);
errorMsg(ret);
if (ret != 0)
throw ret;
// Configure the counter
ret = DAQmxCreateCOPulseChanTicks( task_, "Dev1/ctr0", "", "/Dev1/PFI8", DAQmx_Val_Low, 0, divider, divider );
errorMsg(ret);
ret = DAQmxCfgImplicitTiming( task_, DAQmx_Val_ContSamps, 1000 );
errorMsg(ret);
// Change to pulse mode
ret = DAQmxExportSignal( task_, DAQmx_Val_CounterOutputEvent, "/Dev1/Ctr0InternalOutput" );
errorMsg(ret);
// Start the counter
ret = DAQmxStartTask(task_);
errorMsg(ret);
The above code works fine, in toggle mode, if I just comment out the DAQmxExportSignal() part.
HELP!!!
Stefan

The problem is due to the DAQmxExportSignal call.  By default, when you create a counter output pulse train task, the driver will automatically set the output of the counter to toggle when the count for each high ticks and low ticks expire.  The driver also automatically routes the signal present at Ctr0InternalOutput terminal (the output of the counter internal to the device) to the Ctr0Out terminal (the I/O pin available externally).  Using the line
 ret = DAQmxExportSignal( task_, DAQmx_Val_CounterOutputEvent, "/Dev1/Ctr0InternalOutput" );
will tell the driver to tristate the Ctr0Out terminal and not output the signal to the external I/O pin.  Using the DAQmxExportSignal function is generally only useful if you want to route the signal to some other terminal internal to the board without having the output show up on the external connector, route the signal to some other external pin other than the default pin, or if you want to have the output show up at multiple locations. 
If you want to change the output behavior from toggle to pulse, you need to use the DAQmxSetExportedCtrOutEventOutputBehavior function.  However, this is generally only useful if all you care about are edges (not the duty cycle of the pulse train), and you want to generate higher frequency signals.  For example, with a 20 MHz timebase as the source of your counter, you can only generate a 5 MHz pulse train by default.  This is because the minimum value for the low and high ticks parameter is 2 (20 MHz / 4 = 5 MHz).  By changing the output behavior form toggle to pulse, you can generate a pulse train at 10 MHz since the output is now pulsing instead of toggling.  However, the width of each pulse is not programmable so you will no longer have a 50% duty cycle signal.  I don't remember exactly what the width of each pulse is, but I believe it's in the neighborhood of 50 - 100 nanoseconds in width.  I hope this information helps.

Similar Messages

  • How to append the declaration tags to generated xml using Xquery

    Hi,
      How to append the declaration tags to generated xml using Xquery.generated XML is like
    <ROOT>
      <CHILD1></CHILD1>
      <CHILD2></CHILD2>
    </ROOT>
    Here I want to append the <?xml version="1.0" encoding="ISO-8859-1"?> and the result xml should be
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <ROOT>
      <CHILD1></CHILD1>
      <CHILD2></CHILD2>
    </ROOT>
    Can anybody help to do this.
    Thanks
    Mani

    First assign this element to a temp variable
    <ROOT>
      <CHILD1></CHILD1>
      <CHILD2></CHILD2>
    </ROOT>
    Now in XQuery expression create a new variable
    <?xml version="1.0" encoding="ISO-8859-1"?>
    $temp

  • How do I configure Soundtrack Pro2 to play audio using Digidesign 002 Rack?

    How do I configure Soundtrack Pro2 to play audio using Digidesign 002 Rack? I have no problem using Logic 8 with the 002 Rack?
    Can somebody explain the necessary process to make this work. Thanks

    Add is probably not the best choice of terminology.
    Going from memory (since I'm at home), you need to launch digiCoreAudio, then select your output in the System prefs as your digi hardware. After that you would see the digi hardware as an output in STP.

  • How to make a good UI for channel selection using DAQmx

    A lot of my Labview programming was with earlier verisons of labview (pre Labview 7), and there are a ton of new features that I'm trying to digest (currently using Labview 8.2).
    My question is (in general terms), how are people programming their UI for selecting channels and such when using DAQmx hardware?  What I have in mind is a compacDAQ system with a number of modules.  The user would be able to pick and choose which channels to monitor.  Using MAX as part of that process seems counter intuative, and somewhat static (yeah I know you can change it there, but it feels more like something you would use for something that really doesn't change much).  I'd like all the UI to be within the VI.
    Are programmers using the create task VIs for that or something else?
    Thanks in advance.
    Solved!
    Go to Solution.

    I wholeheartedly second the motion to keep MAX out of the picture as far as users are concerned.
    Setting up UI's for channel selection is a breeze in DAQmx when you create channels on the block diagram. The control you create off the Channels input will populate itself with the inputs that it knows are capable of performing the desired task...
    <<< My configuration knows that my Module 5 is capable of doing Analog Input.
    So... Just create a panel that waits for the user to select the proper channel. I also run a quick check of the user's selection before creating / starting the task. For example, if they choose ai30 or higher, and I know that the system isn't wired for those inputs, I'll not allow that selection. Also check for using two of the same input, etc.
    Richard

  • Counter miss TELL pulses, NI DAQmx 9181 with NI 9402

    Hi,
    I am trying to read TTL pulses from a function generator using a counter. I am applying a 1KHz signal to the counter. Every time counter reads the pulses correctly in first cycle of measurement, but it miss some counts in all following cycles.
    I am using NI cDAQ 9181 Chassis and NI 9402 module with LabVIEW 2014 and NI Max 14.0.
    My computer has Windows 8.1 operating system.
    Please find the attached VI and images of Front Panel after run.
    What could be the reason for that, please guide.
    Thanks !
    B. Sharma
    Attachments:
    Counter cDAQ Testing-LV 2014.vi ‏44 KB
    Counter cDAQ Testing-LV 2014_Front Panel.png ‏68 KB
    Counter cDAQ Testing-LV 2014_Block Diagram.png ‏70 KB

    1.  The Elapsed Time VI starts counting when you first call it, so the first loop will take about the desired amount of time (although OS timing is not very reliable anyway).  The Express VI will reset itself as soon as you hit the time target.  Then, you wrap back around and reconfigure your task.  This takes time (during which the DAQ task is not counting, but the Elapsed Time VI has already been reset), and so all subsequent acquisitions will actually run some time less.  For example, if the configuration took 100 ms and you wanted to acquire 1 second of data, you would only get ~90% of the count.
    2.  The time it takes to reconfigure the task is going to vary dramatically with the bus you are using due to latency (ethernet > USB > PCI/PCIe).  So it makes sense that the problem was not noticeable with PCI, and it was most severe with ethernet (9181) compared to USB (9171).
    3.  Discarding the first sample on buffered counter measurements is a behavior change with STC3-based DAQ products (e.g. X Series, C Series, 621x) compared to older NI DAQ products (e.g. E Series, M Series, 9172).  In your case, when you use the E Series card the first measurement represents the count measured between the arming of the task and the first edge of the gating counter (which toggles almost immediately, you are very unlikely to receive an external 1 kHz clock edge during this time).  Since this measurement is often not desired and can be confusing, it is discarded in the newer NI hardware.
    Here is the behavior from the M Series and X Series user manuals (I know not your exact hardware, but I know that the diagrams are in these manuals and your E Series and cDAQ systems respectively will behave the same).
    From M Series User Manual:
    From X Series User Manual:
    Best Regards,
    John Passiak

  • How can I get properties of global virtual channels using DAQmx?

    I'm using DAQmx with VB6. In my app, I would like to be able to present the user with a list of available predefined channels to select from. I can use DAQmxGetSysGlobalChans to get a list of the channels, but I need a way to sort out which of these channels are defined as inputs, and which are outputs. It would also be nice to be able to query other properties of the virtual channel (for example, the device and physical channel being used). These all seem very simple things, but I haven't found anything like this in the documentation so far.
    Thanks.

    Try using  DAQmxGetChanType(TaskHandle taskHandle, const char channel[ ], int32 *data)DAQmxGetChanType(TaskHandle taskHandle, const char channel[ ], int32 *data).  This will return one of the following types:
    DAQmx_Val_AI
    10100
    Analog input channel.
    DAQmx_Val_AO
    10102
    Analog output channel.
    DAQmx_Val_DI
    10151
    Digital input channel.
    DAQmx_Val_DO
    10153
    Digital output channel.
    DAQmx_Val_CI
    10131
    Counter input channel.
    DAQmx_Val_CO
    10132
    Counter output channel.
    Let me know if this works. 
    Regards,
    L. Allen

  • How can I configure characters count per row in photoshop touch?

    how or where can I configure characters match per row in photoshop touch?

    You should ask that question over in the companion app forum http://forums.adobe.com/community/photoshop/touchapps?view=all

  • How do you configure the set of port to use for FTP passive data connection

    I was able to start the ftp server xml db and connect to it locally. When I tried to connect to it from home, I was able to log in but when i do a "get" command the sessions hangs. I also tried passive mode and do a "get" command and it gives me a connection refused error. I am using the default port 2100. I think this might be a firewall issue with the data connection port. I am not sure which range of ports to open for the passive ftp connection on the server side or where to go and set them for for the ftp server to use? Or this issue might not be firewall related??? Any thoughts. Thanks.

    This is a typical problem with VPN/Firewall software and FTP on ports other than 21.
    When you open the FTP data connection the FTP Server identifies which port the data will be sent on using the PORT command which is sent on the command port (typically 21 with a normal FTP server, 2100 by default with XDB). THe client then opens that PORT to accept the data (file, output of an ls etc).
    As I understand it most VPN/Firewall are configured to monitor 21 for 'PORT' requests. They then understand to allow connection on the PORT number passed on the command PORT. Hence with Port 21 firewall / VPN software is not a problem. However since the XDB command PORT is something other than 21 they do not see / honour the PORT commands from the server and hence the client cannot open the data connection on the specified PORT
    As to how to solve it, I wish I knew (After 5 years I still can't use XDB FTP from home to a machine in the office once the VPN tunnel is open :( ). I'm sure it's going to be firewall / VPN software specific and may need the VPN servers to be configured.
    The best bet would be to run the FTP server on 21...
    Add the following line to your listener.ora file
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP) (HOST = hostname) (PORT = 21))
    (PROTOCOL_STACK = (PRESENTATION = FTP) (SESSION = RAW)))
    and then restart the listener as root
    Start the listener as root.
    At the operating system prompt, enter tnslsnr with optional command line arguments. The usage is as follows:
    tnslsnr [listener_name] [-user user] [-group group]
    where:
    Table 4-3 tnslsnr Utility Options
    Option Description
    listener_name
    Specify the name of the listener. If omitted, the default name LISTENER will be used.
    -user user
    Specify the user whose privileges the listener will use when super user (root) privileges are not needed. After performing the privileged operations, the listener will give up root privileges irreversibly.
    -group group
    Specify the group whose privileges the listener will use when super user (root) group privileges are not needed. After performing the privileged operations, the listener will give up root group privileges irreversibly.
    The listener will temporarily switch to the provided user and group immediately after startup. All subsequent operations will be done with the specified user and group privileges, except the system calls necessary to listen on configured endpoints. The listener will revert to super user (root) for a short period of time to listen on reserved addresses, such as TCP ports less than 1024. After the listener starts listening on all of its endpoints configured in listener.ora, it will switch to the specified user and group irreversibly. Therefore, the listener will give up the root privilege that it initially had. In the current release, -user and -group command line arguments only accept user and group identifiers specified in numeric form.
    For example, to execute a root listener called mylsnr and have it use privileges of a user identified

  • HT5697 How do i configure os x server wiki to use the external web server?

    I have a Mac mini Server with OS X 10.10 and Server 4.0 running in a DMZ behind a firewall. The firewall passes a select few ports through to this server, exposing services to the Internet.
    I use two domains, one dummy domain only available on my local networks, and one proper domain available globally. Lets call them «example.lan» and «example.com». These domains are not hosted on the Mac mini, btw.
    In the external domain, I have «server.example.com» registered on my firewalls official IP address.
    In my internal domain, I have «server.example.lan» registered to my Mac mini internal (rfc1918) IP address.
    Server 4.0 -> Websites seem to work as expected. I have three servers configured: «Server Website - All IP addresses», port 80 + 443. These serve the local networks. Then there is «server.example.com», port 443, serving the internet.
    Now to my question: How to I control which of these websites we Wiki uses?
    When I activate the Wiki, it is published on «server.example.lan/wiki», which seems rather pointless. In order for the wiki to be available to the internet, it needs to be published on «server.example.com/wiki», but I see no way of doing this. What am I missing here?
    Regards,
    Gakke

    it does look like you can add virtual domains in the GUI of Server.app on at least some versions, but I don't have an OS X Server 10.8 version handy to check.
    I'd encourage spending some time to learn the command line.  In general, the payoff for learning the command line will be worth the effort expended.  You're running a mail server here and sooner or later the capabilities of the GUI will fail you.  This whether due to a configuration omission in the GUI itself, or due to the need to troubleshoot a malfunctioning mail server, a need to automate one or more of the Postfix-related sequences, or some other IT-related task.  Entirely FWIW, of course.
    Here's a cut-and-paste of the sequence just used to test the command line access to the Postfix configuration, first fetching the current value, appending example.com as the second domain, then displaying the new value, then restarting the Postfix server.  Don't enter the dollar signs; just the postconf command and following.  Adjust example.com to match your domain...
    $ postconf mydestination
    mydestination = $myhostname, localhost.$mydomain, localhost
    $ sudo postconf -e 'mydestination = $myhostname, localhost.$mydomain, localhost, example.com'
    Password: {your admin password here}
    $ postconf mydestination
    mydestination = $myhostname, localhost.$mydomain, localhost, example.com
    $ sudo postfix reload
    The Postfix and Postconf commands work irrespective of the OS X Server version; the tools reference the data files as needed.

  • How can i configure DAQ card other then NI using MAX

    Hi,
    I am using Advantech DAQ pci1711, can i configure this card using NI MAX. I am getting problem with its port specification while writing VI's because could get channel port addresses.

    MAX can only configure cards that use the Traditional NI DAQ and DAQmx.  Advantech uses their own drivers.  Does Advantech have a utility for setting up their PCI cards?
    There are only two ways to tell somebody thanks: Kudos and Marked Solutions
    Unofficial Forum Rules and Guidelines

  • How do I configure a cisco 1131 AP to use WPA2 enterprise and authenticate to Active Directory

    I have a Win2008 server set up as a radius server (192.168.32.71) and a stand alone AP (192.168.201.9) The AP is config is below:
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$IdUV$UvE2IJTNzHX6mW6Mmh3At0
    ip subnet-zero
    ip domain name TKGCORP.local
    ip name-server 192.168.32.71
    aaa new-model
    aaa group server radius rad_eap
    aaa group server radius rad_mac
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa group server radius rad_eap1
    server 192.168.201.9 auth-port 1812 acct-port 1813
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authentication login eap_methods1 group rad_eap1
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    dot11 ssid ka_test
       vlan 201
       authentication open eap eap_methods1
       authentication network-eap eap_methods1
       guest-mode
    power inline negotiation prestandard source
    username Cisco password 7 112A1016141D
    username tkgadmin privilege 15 password 7 022D167B06551D60
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 201 mode ciphers aes-ccm tkip
    encryption key 1 size 128bit 7 673B0AA56FCB4E630D8E4856427E transmit-key
    encryption mode wep mandatory
    broadcast-key change 150
    ssid ka_test
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.201
    encapsulation dot1Q 201
    no ip route-cache
    bridge-group 201
    bridge-group 201 subscriber-loop-control
    bridge-group 201 block-unknown-source
    no bridge-group 201 source-learning
    no bridge-group 201 unicast-flooding
    bridge-group 201 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    shutdown
    encryption key 1 size 128bit 7 B711059074E30B1E1D4E3EC038BB transmit-key
    encryption mode wep mandatory
    broadcast-key change 150
    speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    hold-queue 160 in
    interface FastEthernet0.201
    encapsulation dot1Q 201
    no ip route-cache
    bridge-group 201
    no bridge-group 201 source-learning
    bridge-group 201 spanning-disabled
    interface BVI1
    ip address 192.168.201.9 255.255.255.0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    radius-server local
      no authentication eapfast
      no authentication mac
      nas 192.168.201.9 key 7 010703174F
    radius-server attribute 32 include-in-access-req format %h
    radius-server host 192.168.32.71 auth-port 1645 acct-port 1646 key 7 0835495D1D
    radius-server host 192.168.201.9 auth-port 1812 acct-port 1813 key 7 0010161510
    radius-server vsa send accounting
    control-plane
    bridge 1 route ip
    line con 0
    line vty 0 4
    end

    Sorry for the late reply Steve. The link you provided was extremely helpful here is what my config  looks like now:
    ersion 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname ap
    enable secret 5 $1$7vHS$YWCMbrlAgDUayKlOHhMlF1
    ip subnet-zero
    ip domain name TKGCORP.local
    ip name-server 192.168.32.71
    aaa new-model
    aaa group server radius rad_eap
    server 192.168.32.71 auth-port 1645 acct-port 1646
    aaa group server radius rad_mac
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    dot11 ssid wap_test
       authentication open eap eap_methods
       authentication network-eap eap_methods
       authentication key-management wpa
       guest-mode
       infrastructure-ssid optional
    power inline negotiation prestandard source
    username Cisco password 7 047802150C2E
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption mode ciphers tkip
    ssid wap_test
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio1
    no ip address
    no ip route-cache
    shutdown
    speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    hold-queue 160 in
    interface BVI1
    ip address 192.168.201.9 255.255.255.0
    no ip route-cache
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    radius-server attribute 32 include-in-access-req format %h
    radius-server host 192.168.32.71 auth-port 1645 acct-port 1646 key 7 071B245F5A
    radius-server vsa send accounting
    control-plane
    bridge 1 route ip
    line con 0
    line vty 0 4
    end
    I get a login screen but it will not let me connect, on my radius server I have it set to allow a group that my username is in. Here are some debugs from when I try to connect to the AP:
    ap#debug aaa  authentication
    AAA Authentication debugging is on
    ap#
    *Mar  2 01:11:53.284: AAA/BIND(00000006): Bind i/f 
    *Mar  2 01:11:53.355: AAA/AUTHEN/PPP (00000006): Pick method list 'eap_methods'
    *Mar  2 01:11:54.556: %DOT11-7-AUTH_FAILED: Station c0cb.3835.a102 Authentication failed
    *Mar  2 01:11:55.280: AAA/BIND(00000007): Bind i/f 
    *Mar  2 01:11:55.404: AAA/AUTHEN/PPP (00000007): Pick method list 'eap_methods'
    *Mar  2 01:11:56.349: AAA/BIND(00000008): Bind i/f 
    *Mar  2 01:11:56.525: AAA/AUTHEN/PPP (00000008): Pick method list 'eap_methods'
    *Mar  2 01:11:57.300: AAA/BIND(00000009): Bind i/f 
    *Mar  2 01:11:58.070: AAA/BIND(0000000A): Bind i/f 
    *Mar  2 01:11:58.812: AAA/BIND(0000000B): Bind i/f 
    *Mar  2 01:12:15.470: AAA/AUTHEN/PPP (0000000B): Pick method list 'eap_methods'
    *Mar  2 01:12:15.492: %DOT11-7-AUTH_FAILED: Station c0cb.3835.a102 Authentication failed
    ap#undebug all
    All possible debugging has been turned off

  • How do you configure a newer Mac mini to use a VGA adapter?

    I don't know what could be wrong the computer was fine with DVI but my tv isn't hdcp compliant and won't play rentals or netflix over dvi, so I need to use VGA adapter. My Panasonic display is set to rgb mode, but I tried all modes. Already tried rebooting. Any advanced settings for changing the Mac mini output to rgb? Any other ideas on why no picture at all?

    Thanks tried that already-gonna try on a newer monitor. Probably time to let go of my old time plasma display but it's hard-still looks great and it cost 4 grand but I could get something comparable for 6-8 hundred now

  • I have a Dell AIO 944 printer, how can I configure my Mac, running Lion, to use it?

    Where can I find a down driver so I can use my Dell  printer with the Mac?

    Hey viviane,
    The first thing check with the Dell printer Support Site with the printer specific Model.
    If it display's any software for the Mac OS X, Download it from the www.dell.com/support .
    If the Dell printer does not have software on Dell site itself.
    It means the specific Dell Printer does not support Apple Mac OS X.
    In Apple some specific Dell printers are not supported by Apple.
    OR
    Try Searching for software in Apple Downloads from from Apple site.
    and check this Link to.
    http://support.apple.com/kb/HT3771

  • How can I configure latest Lightroom to FTP upload using explicit FTP over TLS?

    ?

    It would help to know which plugin you're using, but in general: ftp preset includes 'Protocol' which can be FTP or SFTP.
    I *think* SFTP will use TLS if possible.
    Whether it actually uses TLS vs SSL2... - I dunno: I suspect it will use TLS if supported on server, then down-shift to reglar SSL if need be, but I'm guessing. If you need to assure that only TLS is used (no down-shifting), you'll need some input from somebody else in the know - consider asking question direct to adobe:
    http://feedback.photoshop.com/photoshop_family/topics/new
    My guess: only way to assure specific security protocol is to go through 3rd party app.
    Rob

  • How can I quickly sample data from 200 channels using DAQmx?

    Hello,
    I am trying to sample thermocouple data using a SCXI 1000 chassis with two SCXI 1100 modules and one SCXI 1102B, all of which have a 1300 isothermal terminal block. The computer I am using has a PCI-6052E DAQ card and 1 GB of RAM. I will eventually need to upgrade to a SCXI 1001 chassis with enough modules to collect about 175-200 different signals. The problem is I am testing with just the 96 channels I have available and the program runs super slow, with the maximum sample rate only .026 Hz. Currently I have all the channels being read by one DAQmx VI. I've looked through the example programs and tutorials, but nothing there deals with large numbers of channels. Is there a way to improve the sample rate to around 1 Hz with so many channels?
    Thanks in advance

    Check the filter configuration for your SCXI-1100.  The product page says that if you set the filter for 4Hz, you'll only get 3 Samples/second.  The slowest module in the chassis determines the sample rate.  If one of your modules is configured that way, you'll get a maximum rate of approximately 3 hz / 96 channels = 0.031 hz/channel, which is pretty close to what you've reported.  The filter is set by a jumper on the module, see the manual under "filter selection."
    You might want to look at "Determining Maximum Scan Rate for Multiple SCXI Modules" as well.

Maybe you are looking for