Issue with ACE HTTP class map

This is what I want to achieve USING the ACE as a reverse proxy.
User uses the url https://abc/password - gets to the destination server & the web page
If user tries to use any thing additional then the connection is dropped at the ACE such as
https://abc/password/test or any such variation.
Following is the config I have to achieve this
class-map type http loadbalance match-any L7-CLASS-TEST
  match http url /password
  match http url /password/
class-map type http loadbalance match-any L7-CLASS-TEST-deny
  2 match http url .*.*
policy-map type loadbalance first-match LBP-TEST
  class L7-CLASS-TEST
    serverfarm FARM-TEST
    ssl-proxy client TEST
  class L7-CLASS-TEST-deny
    drop
  class class-default
    serverfarm FARM-TEST
    ssl-proxy client TEST
The problem with this is when the page opens I get broken links on all the images. If I use the following line
match http url /password.*
I get the images to work but the user can use the https://abc/password/test which is not what I want.
Has any one faced this issue ?
Any help will be appreciated.
Thanks in advance
Prasanna

Prasanna,
What about if you try it in HTTP and apply the following change?
class-map type http loadbalance match-any L7-CLASS-TEST-deny
  2 match http url /.*
This should work in HTTP but not with HTTPS
Anyway, it should not work since everything seems to be encrypted, you may require either SSL-termination or END-TO-END SSL for this then the ACE can decrypt the request see what it needs to do and take the load balance decision.
Jorge

Similar Messages

  • ACE - HTTPS CLASS MAP CONFIGURATION

    Hi,
    We have a secured web site (HTTPS) currently fronted by Cisco ACE 4170, running version A5(1.2). We are trying to use the http class map to manipulate the traffic flow in the following manner:
    https://abc.com/ABC/* -> serverfarm#1
    https://abc.com/* -> serverfarm#2           (Default)
    Tecnically this should not be difficult and below is a sample of our configuration. We have similar configuration working on our non-secured web site (HTTP) However for the secure web site, the https request https://abc.com/ABC/xxx is continued being routed to serverfarm#2 instead of serverfarm#1 which is very frustrating.
    We can easily get this working on my F5 LTM within 5 minutes but this Cisco ACE continue to frustrate me...Appreciate if any expert on Cisco ACE can help to advise on our configuration.. Thanks.
    =========================================================
    serverfarm host serverfarm#1
    predictor leastconns
    probe https_probe
    rserver rs_server#1
      inservice
    rserver rs_server#2
      inservice
    serverfarm host serverfarm#2
    predictor leastconns
    probe https_probe
    rserver rs_server#3
      inservice
    rserver rs_server#4
      inservice
    sticky http-cookie STICKY_HTTPS_serverfarm#1
    cookie insert browser-expire
    timeout 15
    replicate sticky
    serverfarm serverfarm#1
    sticky http-cookie STICKY_HTTPS_serverfarm#2
    cookie insert browser-expire
    timeout 15
    replicate sticky
    serverfarm serverfarm#2
    class-map type http loadbalance match-any class-map-serverfarm#1
    2 match http url /ABC/.*
    policy-map type loadbalance first-match vs_serverfarm_https
    class class-map-serverfarm#1
      sticky-serverfarm STICKY_HTTPS_serverfarm#1
      insert-http x-forward header-value "%is"
      ssl-proxy client ssl_serverfarm
    class class-default
      sticky-serverfarm STICKY_HTTPS_serverfarm#2
      insert-http x-forward header-value "%is"
      ssl-proxy client ssl_serverfarm
    =========================================================

    Kanwaljeet,
    Yes, we are using ACE for SSL termination i.e. front end is https and back-end is also https.
    We are doing end-to-end encryption as our IT security and audit wanted end-to-end encryption between the client and servers. ACE should be able to look at the HTTP header at the front end since the client SSL session is terminate on the ACE.
    Below is an extract of the configuration, I've leave out the remaining configuration which is not required.
    =========================================================
    serverfarm host serverfarm#1
    predictor leastconns
    probe https_probe
    rserver rs_server#1
      inservice
    rserver rs_server#2
      inservice
    serverfarm host serverfarm#2
    predictor leastconns
    probe https_probe
    rserver rs_server#3
      inservice
    rserver rs_server#4
      inservice
    sticky http-cookie STICKY_HTTPS_serverfarm#1
    cookie insert browser-expire
    timeout 15
    replicate sticky
    serverfarm serverfarm#1
    sticky http-cookie STICKY_HTTPS_serverfarm#2
    cookie insert browser-expire
    timeout 15
    replicate sticky
    serverfarm serverfarm#2
    class-map match-all vs_serverfarm
      2 match virtual-address 10.178.50.140 tcp eq https
    class-map type http loadbalance match-any class-map-serverfarm#1
    2 match http url /ABC/.*
    policy-map type loadbalance first-match vs_serverfarm_https
    class class-map-serverfarm#1
      sticky-serverfarm STICKY_HTTPS_serverfarm#1
      insert-http x-forward header-value "%is"
      ssl-proxy client ssl_serverfarm
    class class-default
      sticky-serverfarm STICKY_HTTPS_serverfarm#2
      insert-http x-forward header-value "%is"
      ssl-proxy client ssl_serverfarm
    policy-map multi-match PRODWEB_POLICY
      class vs_serverfarm
        loadbalance vip inservice
        loadbalance policy vs_serverfarm_https
        loadbalance vip icmp-reply active
        nat dynamic 100 vlan 100
        ssl-proxy server ssl_serverfarm
    =========================================================

  • Issue with xsd Data type mapping for collection of user defined data type

    Hi,
    I am facing a issue with wsdl for xsd mapping for collection of user defined data type.
    Here is the code snippet.
    sample.java
    @WebMethod
    public QueryPageOutput AccountQue(QueryPageInput qpInput)
    public class QueryPageInput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class QueryPageOutput implements Serializable, Cloneable
    protected Account_IO fMessage = null;
    public class Account_IO implements Serializable, Cloneable {
    protected ArrayList <AccountIC> fintObjInst = null;
    public ArrayList<AccountIC>getfintObjInst()
    return (ArrayList<AccountIC>)fintObjInst.clone();
    public void setfintObjInst(AccountIC val)
    fintObjInst = new ArrayList<AccountIC>();
    fintObjInst.add(val);
    Public class AccountIC
    protected String Name;
    protected String Desc;
    public String getName()
    return Name;
    public void setName(String name)
    Name = name;
    For the sample.java code, the wsdl generated is as below:
    <?xml version="1.0" encoding="UTF-8" ?>
    <wsdl:definitions
    name="SimpleService"
    targetNamespace="http://example.org"
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
    xmlns:tns="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"
    >
    <wsdl:types>
    <xs:schema version="1.0" targetNamespace="http://examples.org" xmlns:ns1="http://example.org/types"
    xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://example.org/types"/>
    <xs:element name="AccountWSService" type="ns1:accountEMRIO"/>
    </xs:schema>
    <xs:schema version="1.0" targetNamespace="http://example.org/types" xmlns:ns1="http://examples.org"
    xmlns:tns="http://example.org/types" xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:import namespace="http://examples.org"/>
    <xs:complexType name="queryPageOutput">
    <xs:sequence>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="accountEMRIO">
    <xs:sequence>
    <xs:element name="fIntObjectFormat" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageType" type="xs:string" minOccurs="0"/>
    <xs:element name="fMessageId" type="xs:string" minOccurs="0"/>
    <xs:element name="fIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fOutputIntObjectName" type="xs:string" minOccurs="0"/>
    <xs:element name="fintObjInst" type="xs:anyType" minOccurs="0" maxOccurs="unbounded"/>
    </xs:sequence>
    </xs:complexType>
    <xs:complexType name="queryPageInput">
    <xs:sequence>
    <xs:element name="fPageSize" type="xs:string" minOccurs="0"/>
    <xs:element name="fSiebelMessage" type="tns:accountEMRIO" minOccurs="0"/>
    <xs:element name="fStartRowNum" type="xs:string" minOccurs="0"/>
    <xs:element name="fViewMode" type="xs:string" minOccurs="0"/>
    </xs:sequence>
    </xs:complexType>
    </xs:schema>
    <schema xmlns="http://www.w3.org/2001/XMLSchema" targetNamespace="http://example.org"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:tns="http://example.org" xmlns:ns1="http://example.org/types">
    <import namespace="http://example.org/types"/>
    <xsd:complexType name="AccountQue">
    <xsd:sequence>
    <xsd:element name="arg0" type="ns1:queryPageInput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQue" type="tns:AccountQue"/>
    <xsd:complexType name="AccountQueResponse">
    <xsd:sequence>
    <xsd:element name="return" type="ns1:queryPageOutput"/>
    </xsd:sequence>
    </xsd:complexType>
    <xsd:element name="AccountQueResponse" type="tns:AccountQueResponse"/>
    </schema>
    </wsdl:types>
    <wsdl:message name="AccountQueInput">
    <wsdl:part name="parameters" element="tns:AccountQue"/>
    </wsdl:message>
    <wsdl:message name="AccountQueOutput">
    <wsdl:part name="parameters" element="tns:AccountQueResponse"/>
    </wsdl:message>
    <wsdl:portType name="SimpleService">
    <wsdl:operation name="AccountQue">
    <wsdl:input message="tns:AccountQueInput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    <wsdl:output message="tns:AccountQueOutput" xmlns:ns1="http://www.w3.org/2006/05/addressing/wsdl"
    ns1:Action=""/>
    </wsdl:operation>
    </wsdl:portType>
    <wsdl:binding name="SimpleServiceSoapHttp" type="tns:SimpleService">
    <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
    <wsdl:operation name="AccountQue">
    <soap:operation soapAction=""/>
    <wsdl:input>
    <soap:body use="literal"/>
    </wsdl:input>
    <wsdl:output>
    <soap:body use="literal"/>
    </wsdl:output>
    </wsdl:operation>
    </wsdl:binding>
    <wsdl:service name="SimpleService">
    <wsdl:port name="SimpleServicePort" binding="tns:SimpleServiceSoapHttp">
    <soap:address location="http://localhost:7101/WS-Project1-context-root/SimpleServicePort"/>
    </wsdl:port>
    </wsdl:service>
    </wsdl:definitions>
    In the above wsdl the collection of fintObjInst if of type xs:anytype. From the wsdl, I do not see the xsd mapping for AccountIC which includes Name and Desc. Due to which, when invoking the web service from a different client like c#(by creating proxy business service), I am unable to set the parameters for AccountIC. I am using JAX-WS stack and WLS 10.3. I have already looked at blog http://weblogs.java.net/blog/kohlert/archive/2006/10/jaxws_and_type.html but unable to solve this issue. However, at run time using a tool like SoapUI, when this wsdl is imported, I am able to see all the params related to AccountIC class.
    Can some one help me with this.
    Thanks,
    Sudha.

    Did you try adding the the XmlSeeAlso annotation to the webservice
    @XmlSeeAlso({<package.name>.AccountIC.class})
    This will add the schema for the data type (AccountIC) to the WSDL.
    Hope this helps.
    -Ajay

  • SIP load balancing issue with ACE 4710

    SIP Load balancing Issue with ACE 4710
    I have a Cisco ace 4710 with vesion Version A4(2.2). i configued simple SIP load balancing first without stickiness. without stikeiness we are having a problem because bye packet at the was not going to the same server all the time that left our port in used even though user hang up the phone. its happen randmly. i have a total 20 licenced ports and its fill out very quickly. so i dicided to use the stickiness with call-ID but still same issue. below is the config
    rserver host CIN-VOX-31
      ip address 172.20.130.31
      inservice
    rserver host CIN-VOX-32
      ip address 172.20.130.32
      inservice
    serverfarm host CIN-VOX
      probe SIP-5060
      rserver CIN-VOX-31
        inservice
      rserver CIN-VOX-32
        inservice
    sticky sip-header Call-ID VOX_SIP_GROUP
      timeout 1
      timeout activeconns
      replicate sticky
      serverfarm CIN-VOX
    class-map match-all CIN_VOX_L4_CLASS
      2 match virtual-address 172.22.12.30 any
    class-map match-all CIN_VOX_SIP_L4_CLASS
      2 match virtual-address 172.22.12.30 udp eq sip
    policy-map type loadbalance sip first-match CIN_VOX_LB_SIP_POLICY
      class class-default
        sticky-serverfarm VOX_SIP_GROUP
    policy-map multi-match GLOBAL_DMZ_POLICY
       class CIN_VOX_SIP_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
      class CIN_VOX_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
    interface vlan 20
      description VIP_DMZ_VLAN
      ip address 172.22.12.4 255.255.255.192
      alias 172.22.12.3 255.255.255.192
      peer ip address 172.22.12.5 255.255.255.192
      access-group input PERMIT-ANY-LB
      service-policy input GLOBAL_DMZ_POLICY
    could you please help me on this...
    thanks
    Rakesh Patel

    I mean there should be one more statement-
    class-map type sip loadbalance match-any CIN_VOX_LB_SIP_POLICY 
    match sip header Call_ID header-value sip:
    and that will be called under-
    policy-map multi-match GLOBAL_DMZ_POLICY
       class CIN_VOX_SIP_L4_CLASS
        loadbalance vip inservice
        loadbalance policy CIN_VOX_LB_SIP_POLICY
        loadbalance vip icmp-reply
    is that missing in your config ?

  • ACE: a class-map with multiple ports... what about the probe/serverfarm?

    Hello Gilles,
    One question about something I was not able to find in the documentation.
    Lets say I have one class-map which includes 2 ports (in this case https and 5061).
    Can I associate this class-map to just 1 generic serverfarm and probe for both ports or I have to specify 2 serverfarms/rservers/probes?
    So, by not specifying the ports on the rserver, if a request is received on port 443 (or 5061), it is sent to the same respective port on the rserver?
    The same way is valid for the generic probe.  ACE module is able to probe both ports based on the class-map?
    Thanks and have a great day!!
    Giulio.
    probe tcp PROBE_GENERIC_TCP
      description This probe works for all TCP services by inheriting the VIP port.
      interval 15
      faildetect 2
      passdetect interval 15
      passdetect count 2
      open 2
    rserver host SERVER1_ACCESS
      ip address <1AC>
      inservice
    rserver host SERVER2_ACCESS
      ip address <2AC>
      inservice
    serverfarm host ACCESS-SFARM
      probe PROBE_GENERIC_TCP
      rserver SERVER1_ACCESS
        inservice
      rserver SERVER2_ACCESS
        inservice
    class-map match-any OCS_L4ACCESS
      2 match virtual-address x.x.x.176 tcp eq https
      2 match virtual-address x.x.x.176 tcp eq 5061
    policy-map type loadbalance first-match OCS_L4ACCESS
      class class-default
        sticky-serverfarm ACCESS_STICKY
    policy-map multi-match POLICY
    class OCS_L4ACCESS
    loadbalance vip inservice
    loadbalance policy OCS_L4ACCESS
    loadbalance vip icmp-reply active
    connection advanced-options OCS_VIPTIMEOUT
    nat dynamic XXX vlan 503

    Even if you use the 4710 appliance or expect the inheritance in the module software, it's worth considering if this is really what you want. If you keep multiple ports in the L3/L4 class-map you can't handle the services independently. You will have a common serverfarm for both https and 5061. If https service stops on one rserver, the ACE will place that rserver (and not that service) in out-of-operation state and it won't receive any 5061 traffic either. (You have the fail-on-all probe option but I wouldn't say it's a better choice. In that case, https traffic would be sent to the rserver even if https port is closed as long as there is at least one working service on it.) That's why I prefer a separate class-map and separate serverfarm for each service. (They can contain the same rservers, no need to duplicate.) BUT if the software supports probe port inheritance, you can benefit from it even in this scenario: serverfarm-443 and serverfarm-5061 can both use your PROBE_GENERIC_TCP.

  • ACE ignoring class map depending on source???

    I have a problem with a the load balancing "not working" properly depending on the source.
    The load balancing decision is done with a secondary cookie (?ld=fe1 or ?ld=fe2). If it appears and the value is fe1 the request should go to serverfarm FE1-app. If the value is fe2 then serverfarm FE2-app should be choosen. If it is not present in the http request then serverfarm FE-app in the class-default is taking over.
    This approach works if "surfing" to the VIP from a certain part of the internal network. It does not work from another part of the network. It seems that cookie is ignored and only the class default triggers.
    The strange thing is that the same approach works for another setup that looks identical (with different rservers and different VIP of course). There the class map for the cookie triggers always.
    My question is now: Why does the ACE seem to ignore the class map for the cookie when coming from a certain part of the network? How can I debug/follow a certain connection or load balancing decision?
    Here is the config:
    rserver host FE1-app
      description frontend app
      ip address 192.168.137.69
      inservice
    rserver host FE2-app
      description frontend app
      ip address 192.168.137.74
      inservice
    serverfarm host FE1-app
      rserver FE1-app 80
        inservice
    serverfarm host FE2-app
      rserver FE2-app 80
        inservice
    serverfarm host FE-app
      rserver FE1-app 80
        inservice
      rserver FE2-app 80
        inservice
    class-map type http loadbalance match-all COOKIE-FE1
      2 match http cookie secondary ld cookie-value "fe1"
    class-map type http loadbalance match-all COOKIE-FE2
      2 match http cookie secondary ld cookie-value "fe2"
    class-map match-all VIP-app
      2 match virtual-address 192.168.138.39 tcp eq www
    policy-map type loadbalance first-match VIP-app-loadbalance
      class COOKIE-FE1
        serverfarm FE1-app
      class COOKIE-FE2
        serverfarm FE2-app
      class class-default
        serverfarm FE-app
    policy-map multi-match INT470
      class VIP-app
        loadbalance vip inservice
        loadbalance policy VIP-app-loadbalance
        loadbalance vip icmp-reply
    interface vlan 470
      description lb_rpfedrift
      ip address 192.168.138.36 255.255.255.240
      alias 192.168.138.35 255.255.255.240
      peer ip address 192.168.138.37 255.255.255.240
      service-policy input remote_mgmt_allow_policy
      service-policy input INT470
      no shutdown

    Hi Federico,
    The source of the request has no relation with the way ACE handles the connections, so, there are probably other differences in the traffic.
    The best way to troubleshoot these kind of connections is taking a traffic capture on the TenGigabit interface connecting the ACE with the switch backplane. Once you have it, you can try to look for differences between the working and failing connections.
    From what you describe, I wouldn't be surprised if the issue comes from the fact that there are several HTTP requests inside the same TCP flow (in which case, by default, the ACE will look only at the first one), so I would suggest you to enable "persistence rebalance" for this VIP. For more details, check the link below:
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA2_3_0/configuration/slb/guide/classlb.html#wp1062907
    I hope this helps
    Daniel

  • Issues with a http get keepalive

    We are having a issue with some keepalives that are causing our web servers to run really slow. I have explained the environment below and provided some configs from the CSS
    I would appreciate any insight you could provide as to why this issue is occuring and how we might avoid them.
    Thanks,
    Jim
    Environment:
    CSS 11150 with 4.01 (Build 19) code.
    We have 2 applications that connect to backend oracle databases. In order to monitor the database connections, we wrote an asp page for each application that queries the database and returns a normal status web page if a connection was established. If the database connection can not be obtained, an error web page is returned. We created 2 services with a keepalive method of get pointing to the asp page we wrote with the expectation that it would create a checksum for the normal web page.
    Issue:
    The problem we are having is that when we activate these two services, the web server that is running the applications slow down considerably. In addition to the speed issues, we also sometimes get a page cannot be displayed error from the application. If you get a page cannot be displayed error but hit refresh in your browser the application comes back. If we suspend the services the server speeds back up and we have no issues with the application.
    Configuration:
    **************************Service**********************
    service web02qi-compoint-SMDR
    ip address 172.28.1.102
    keepalive type http
    keepalive frequency 10
    keepalive maxfailure 2
    keepalive method get
    keepalive uri "/keepalive/compointkeepalive.asp"
    service web02qi-issuestrk-SMDR
    ip address 172.28.1.102
    keepalive type http
    keepalive frequency 10
    keepalive maxfailure 2
    keepalive method get
    keepalive uri "/keepalive/crmdbcheck.asp"
    ************************Owner*************************
    content compoint1
    protocol tcp
    port 80
    url "/dataproducts/*"
    add service redirect-compoint
    vip address 172.28.1.100
    balance aca
    add service web02qi-compoint-SMDR
    active
    content compoint2
    protocol tcp
    port 80
    url "/dpcompoint/*"
    add service redirect-compoint
    vip address 172.28.1.100
    balance aca
    add service web02qi-compoint-SMDR
    active
    content issuestrk
    protocol tcp
    port 80
    url "/crmdpd/*"
    add service redirect-issuestrk
    vip address 172.28.1.100
    add service web02qi-issuestrk-SMDR
    balance aca
    active

    What happen if you remove your uri in the service, do the server speed return to normal? What is the serivce 'redirect-compoint'? Try to remove any unnecessary commands such as balance aca to see if anything changes?
    What is the response time of your keepalive asp pages? What happen if you run this asp page on another computer while you're access the application on differnent computer? Trying to simulate what CSS is trying to do and see what happen.
    If nothing else works, try to upgrade to the version 5.0.
    Hope this help.
    Brad

  • Issues with Weblogic - Offending class: javax/servlet/Servlet.class

    Hi,
    I've been working on a servlet that calls EJB objects and I'm having problems deploying it under Tomcat. It prints the following error message when I try to deploy the app:
    INFO: validateJarFile(/home/xxxxx/tomcat/webapps/hello/WEB-INF/lib/wlfullclient.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
    For reference, here is how my web.xml file looks like:
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">
    <web-app>
    <display-name>Hell World Servlet</display-name>
    <description>
    A Hello World servlet example for Entity Beans.
    </description>
    <servlet>
    <servlet-name>HelloWorldServletEJB</servlet-name>
    <description>
    A Hello World servlet example for Entity Beans.
    </description>
    <servlet-class>examples.helloworld.HelloWorldServletEJB</servlet-class>
    <load-on-startup>5</load-on-startup>
    </servlet>
    <servlet-mapping>
    <servlet-name>HelloWorldServletEJB</servlet-name>
    <url-pattern>/HelloWorldServletEJB</url-pattern>
    </servlet-mapping>
    <session-config>
    <session-timeout>30</session-timeout> <!-- 30 minutes -->
    </session-config>
    </web-app>and here is my directory tree structure:
    hello/
    `-- WEB-INF
    |-- classes
    | `-- examples
    | `-- helloworld
    | |-- Hello.class
    | |-- HelloHome.class
    | `-- HelloWorldServletEJB.class
    |-- jsp
    |-- lib
    | `-- wlfullclient.jar
    |-- web.xml
    `-- web.xml.oldI've been dealing with this problem for the past 3 days and I'm really stuck at this point. Any help would be much appreciated.
    Thanks
    Edited by: spinth on May 19, 2009 9:19 PM
    Edited by: spinth on May 19, 2009 9:20 PM

    I'm not sure what your code does but Tomcat doesn't support EJBs.

  • Namespace issue with oracg generated classes

    Hi,
    I'm having problems generating classes with oracg from the Java Xdk from an XML schema. All classes are generated, but do not compile. In some sources (mostly in the type classes) "public void addSomething(null.Something theSomething)" is generated as the method declaration, and that doesn't compile. When I add a targetnamespace to the xsd file, the generated sources compile (the 'null.' is replaced with 'myPackage.', but when I generate an XML document, I contains a namespace reference (ns1) like this:
    <ns1:Note xmlns:ns1 = "http://www.somewhere.org">
    <ns1:Form>
    <ns1:Reference>
    <ns1:ReferenceNbr>1</ns1:ReferenceNbr>
    <ns1:ReferenceType>1</ns1:ReferenceType>
    </ns1:Reference>
    </ns1:Form>
    </ns1:Note>
    What I want is this:
    <Note>
    <Form>
    <Reference>
    <ReferenceNbr>1<ReferenceNbr>
    <ReferenceType>1<ReferenceType>
    </Reference>
    </Form>
    </Note>
    How can I get this result ?
    Kind regards.

    Did you try adding the the XmlSeeAlso annotation to the webservice
    @XmlSeeAlso({<package.name>.AccountIC.class})
    This will add the schema for the data type (AccountIC) to the WSDL.
    Hope this helps.
    -Ajay

  • Issue with splitting 1:N mapping using Synchronous mode.

    Hi All,
    My Scenario is like below and i'm using BPM to handle this scenario
    SOAP request from sys-A --> SOAP sync call to Sys-B --> Send sync response from Sys-B  to Sys-C
    - I will be getting mutlple orders in single message from Sys-A.
    - I need to split this single message into multiple messages and pass as a sync request to Sys-B
    - The responses from sys-B should go to Sys-C.
    Issue:
    The scenario is working fine when I send the orders in Asynchronous mode to Sys-B by changing the occurence to 0..unbounded in message mapping and interface mapping.
    The same scenario is not working when I try to send the orders in Synchronous mode to Sys-B. When I tried to change the occurance in Interface mapping, the reponse tab is disappearing when I click "Read interfaces" in Interface mapping.
    If I don't mention 0..occurance in interface mapping then the interface mapping is not showing up in interface determination (when i click Enhannced radio button to select the interface mapping).
    Is there any limitation that split messages won't work in Synchronous mode?
    Do I need to use any function in BPM to handle this splitting message? I want do this in a simple way without complicating in BPM.
    Kindly suggest me.
    Thanks
    Deepthi

    Hi Bhupesh,
    I think you didn't get my scenario correctly. Here I explained with BPM steps.
    Start>Receive(Async)>Send(Sync)>Send(Async)>stop
    receive req from SysA >Send sync req to sysB>Map sync response to Idoc and send to SysC
    While sending Sync message to Sys-B, I will be mapping Abstract Sync message to Inbound Sync message.
    So in interface mapping, I will be assigned
    Abstract_SyncB <---> Inbound_SyncB
    request and response tabs will present.
    This scenario is working perfectly fine when i try to send single order sync message to SysB. But according to my requirement I need to Split the input message into multiple messages and send to sysB.
    To do this, I trying to change the occurances from 0..1 to 1..unbounded in both message mapping and interface mapping. by doing this, I can use the enhanced button in interface determination. So that the splitting the message will happen.
    When I change the occurance to 0..unbounded and save in interface mapping, the response tab is dissapearing.
    What might be the reason for this?  Is sync message can't handle splitting the messages?
    Thanks
    Deepthi.

  • OLAP issue with MANY TO MANY mapping

    Hi All,
    We have a requirement where we have to pull specific measures & associated dimensions data from an OLAP to SQL tables. The source cube has almost 80 % of MANY TO MANY mappings.
    When we pull this data to SQL tables either by writing MDX or DMX dimension level metric values are not matching with what OLAP browsing is providing.
    When we pull this measure with only regular dimensions metric values with all dimensions exactly match. The mismatch issue comes when we have at least 1 MANY TO MANY dimension part of MDX or DMX query. Further to this we have pulled all intermediate facts
    & dimensions involved in MANY TO MANY mapping into SQL tables & tried a number of JOINS but the metric values haven’t match up.
    We are very close on delivery dates & are not sure on any resolution. Could you please guide us on next steps here.
    Thanks is advance.

    Hi All,
    We have a requirement where we have to pull specific measures & associated dimensions data from an OLAP to SQL tables. The source cube has almost 80 % of MANY TO MANY mappings.
    When we pull this data to SQL tables either by writing MDX or DMX dimension level metric values are not matching with what OLAP browsing is providing.
    When we pull this measure with only regular dimensions metric values with all dimensions exactly match. The mismatch issue comes when we have at least 1 MANY TO MANY dimension part of MDX or DMX query. Further to this we have pulled all intermediate facts
    & dimensions involved in MANY TO MANY mapping into SQL tables & tried a number of JOINS but the metric values haven’t match up.
    We are very close on delivery dates & are not sure on any resolution. Could you please guide us on next steps here.
    Thanks is advance.

  • Compiler issue with programmer defined class

    I'm trying an example out of a Java book. I'm using jdk vs 5 to compile. In the example there are 2 classes Coin and CountFlips. CountFlips imports a class called Coin. I can use the -classpath statement and compile Coin ok, but when I compile CountFlips, it doesn't like the import statement ie import Coin; it gives me an error saying '.' expected. Since Coin.class is just in that directory and not part of a package, how should I get this to work ? I really would like to understand this.
    Thank you in advance.

    Hi,
    do you deploy the Spring classes with the application ? I suggest to try the OracleAs forum as well to ensure this has to be in a specific path to be loaded. A list of forums is available from here
    http://forums.oracle.com/forums/index.jspa?categoryID=84
    Frank

  • I need help with the https class please.

    Hello, i need add an authentication field in my GET request using HTTPS to authenticate users. I put the authentication field using the setRequestProperty method, but it doesn't appear when i print all properties using the getRequestProperties method. I wrote the following code:
    try{
    URL url = new URL ("https://my_url..");
    URLConnection conexion;
    conexion = url.openConnection();
    conexion.setRequestProperty("Authorization",my_urlEncoder_string);
    conexion.setRequestProperty("Host",my_loginServer);
    HttpsURLConnection httpsConexion = (HttpsURLConnection) conexion;
    httpsConexion.setRequestMethod("GET");
    System.out.println("All properties\r\n: " + httpsConexion.getRequestProperties());
    }catch ....
    when i run the program it show the following text:
    All properties: {Host=[my_loginServer]}
    Only the Host field is added to my HttpsURLConnection. The authentication field doesnt appear in standar output. How can i add to my HttpsURLConnection an Authentication field?
    thanks

    I have moved this to the main Dreamweaver forum, as the other forum is intended to deal with the Getting Started video tutorial.
    The best way to get help with layout problems is to upload the files to a website and post the URL in the forum. Someone can then look at the code, and identify the problem. Judging from your description, it sounds as though the Document window is narrow, which would result in the final menu tab dropping down to the next row. Try turning on Live view or previewing the page in a browser. Design view gives only an approximate idea of the final layout. Live view renders the page as it should look in a browser.

  • Issue with a Validation Class

    Hello all,
    I have the following validating class that is supposed to check the usernames and passwords held in a file against what the user has typed into a form;
    package bus;
    import java.io.BufferedReader;
    import java.io.FileReader;
    import java.io.IOException;
    import org.springframework.validation.Errors;
    import org.springframework.validation.Validator;
    import bus.Credentials;
    public class LogonValidator implements Validator {
        public boolean supports(Class clazz) {
            return clazz.equals(Credentials.class);
        public void validate(Object obj, Errors errors) {
             Credentials credentials = (Credentials) obj;
             String usernameCompare = credentials.getUsername();
             String passwordCompare = credentials.getPassword();
             String username;
              String password;
              String[] data;
             try {
                BufferedReader in = new BufferedReader(new FileReader("C:/Documents and Settings/Jaz/workspace/OBS/war/LoginInfo.txt"));
                String inLine = null;
                while ((inLine = in.readLine()) != null) {
                     data = inLine.split(",");
                     username = data[0];
                     password = data[1];
                   if (((username.toString()).equals(usernameCompare))== false){
                         errors.rejectValue("username", "error.login.invalid-user",
                                   null, "Value required.");
                   else{
                   if (((password.toString()).equals(passwordCompare)) == false){
                              errors.rejectValue("password", "error.login.invalid-pass",
                                        null, "Incorrect Password.");     
               in.close();
          }catch (IOException e){
    }the file the class is to read from (LogonInfo.txt) intially contained only;
    guest,guestand the app worked perfectly fine. However when more entries were added as such;
    guest,guest
    vip,vip
    someone,someone
    nobody,nobodythe form did not validate anything anymore. When I enter a valid username and password that is found in the txt file it simply says value required. Even if I use the initial entries of guest. Im completely lost with this one. Can anyone help?
    Thank You

    Thank you very much for your help. I have amended the code as such;
    while ((inLine = in.readLine()) != null) {
                     data = inLine.split(",");
                     username = data[0];
                     password = data[1];
                   if (username.equals(usernameCompare) && password.equals(passwordCompare)) {
                       break;
                if (username.equals(usernameCompare)== false && password.equals(passwordCompare)){
                             errors.rejectValue("username", "error.login.invalid-user",
                                       null, "Value required.");
                 else{
                 if (password.equals(passwordCompare) == false && username.equals(usernameCompare)){
                             errors.rejectValue("password", "error.login.invalid-pass",
                                       null, "Incorrect Password.");
               } I thought this would have worked, however it validates the username and password even if both are incorrect. What I would have expected it to do is to validate only if both username and password were correct.
    Also if the username was correct and password incorrect display the appropriate error message. Again if the password was incorrect and the username correct display the error message.
    I dont understand why this is not working.
    Message was edited by:
    Jazman

  • EA6500 Issue With Running HTTP Server

    I use Windows Home Server 2011 to host media and all sorts of things. One of the features is remote access over the web to files through a Dynamic DNS Service Homeserver.com. Currently whenever I try to connect even though my ports are forwarded properly, I get forwarded to the login page of the router to change router settings. Is there a setting I need to change that I'm missing? I've waiting over an hour for live chat and never got connected.

    Wanted to check where your NAT is. IF the ISP modems is bridged fully then single NAT should be on the router. Having double NAT can cause problems. 
    I presume the configuration of the ports maybe the issue on the router. How are the ports configured? Try using Port Triggering instead of PF. Disable uPnP if your using PF. 

Maybe you are looking for

  • KM2M serial port not working in Linux

    I noticed a few Linux postings so I thought I'd give this a shot. I'm running Fedora Core and for some strange reason I can't seem to send any communications out to the ttyS0 (COM 1) or ttyS1 (COM 2) ports. Does anyone have any suggestions on making

  • Flash-driven web photo gallery in Contribute

    I created a flash-driven web photo gallery in LightRoom. I'm trying to insert it in Contribute to post on my website but Contribute won't recognize the file. Any suggestions as to how to insert this photo gallery on Contribute? Miguel54

  • Table with varying number of columns

    Hello experts, my issue: I need to print a table with varying number of columns. Depending on if all cells of a certain column are initial the whole column should disappear. Hiding is not enough. If this columns is in the middle of the table the foll

  • Taking Print in WEb dynpro Application

    hello, I have a situation the front end is web dynpro JAVA and at the backend  of it R/3 is bein gcalled for print. but it is getting stucked up saying that 'FRONTEND UNAVAILABLE. But i got a solution that is not automated. i need a other alternative

  • HP TouchSmart 520-1047c Webcam Issue

    My webcam has gone MIA. My Chrome Hangouts tries to launch and place a video call and reports it could not access my video camera. The Camera HP High Definition 1 MP shows in the imaging devices of my Device Manager. I have uninstalled and reinstalle