Load balanced router hangs

Hello,
did anybody else also experience the following problem?
Problem:
The router of a load balanced service object sometimes and all of a sudden stops forwarding incoming requests to its instances, although all instances are available and free.
This finally causes the whole application to hang, since no further call to a method of that service object is being processed.
Observations:
The dump of the load balanced router during this situation indicates that none of the instances is being used (see below). Besides, the instrument MembersInUse has a value of 0.
CPU load of the nodemgr and the router process increase significantly.
There is no DB deadlock.
We have had this problem on several different load balanced service objects (at different times; with dialog durations message or transaction).
It does not depend on overall system load or on available memory resources - the problem can occur at any time.
We can solve this lock situation by restarting the router.
UDS 5.0.3, HP-UX 11
Thanks in advance for any help or hints on what may be going on.
Martin.
Thu Apr 27 09:55:14 :         ---------------------LoadBalance-Router------------------------
Thu Apr 27 09:55:14 :         State ADDING_MEMBERS  Members: 5  MessageList: 0
Thu Apr 27 09:55:14 :         Versions: part 14 object 0
Thu Apr 27 09:55:14 :         ----------------------Member-Map-------------------------------
Thu Apr 27 09:55:14 :           Id: 0x1  Max: 1 Cur: 0  XactId: [, 0]
Thu Apr 27 09:55:14 :           Object: qqlo_Object
Thu Apr 27 09:55:14 :           Id: 0x2  Max: 1 Cur: 0  XactId: [, 0]
Thu Apr 27 09:55:14 :           Object: qqlo_Object
Thu Apr 27 09:55:14 :           Id: 0x3  Max: 1 Cur: 0  XactId: [, 0]
Thu Apr 27 09:55:14 :           Object: qqlo_Object
Thu Apr 27 09:55:14 :           Id: 0x4  Max: 1 Cur: 0  XactId: [, 0]
Thu Apr 27 09:55:14 :           Object: qqlo_Object
Thu Apr 27 09:55:14 :           Id: 0x5  Max: 1 Cur: 0  XactId: [, 0]
Thu Apr 27 09:55:14 :           Object: qqlo_Object

Hi Mark,
thank you for your response. I talked to our network group, they told me, that there should be no scans going on. Do you have an idea how we could verify this from the application side, e.g. are there any trace flags we could enable to get some feedback?
Anyway, we did further investigations and found the following:
1) The nameservice contains references to old, non-existing partitions, even to partitions that lived before the last reboot of the system, which are not marked as "[Needs Rebind] [Rebinding]" (showpart in nameservice). By the way, the instrument DeleteOnCommFailure is set to TRUE in our environment.
2) The directory $FORTE_ROOT/tmp containing the unix domain socket files does not get cleaned up. It contains even very old entries.
3) Putting 1) and 2) together, we found out that during the hangs of our system, the load balanced router tries to send a message to one of the not-more-existing instances of the Service Object.
Example:
The following dumps were done while our system was hanging.
The router partition in question is ...:0x3ce25:0x1.
The non-existing partition of the Service Object instance is ...:0x3b913:0x2.
The non-existing process has the PID 16736 (there was such a process running a Service Object instance prior to rebooting the system).
The socket file '/forte/tmp/FORTE_A00004160' still exists.
An extract of 'showpart' on the nameservice agent:
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913 realenv
Forte Runtime             Forte_DCE_Executor        ExecId: 16736 (ftserver)
  Locations:
        Location Descriptor for protocol: Forte!UnixDomain
            Path                        /forte/tmp/FORTE_A00004160
            HostName                    omega
        Location Descriptor for protocol: Forte!TCP/IP
            HostName                    omega
            PortNumber                  59128
            DotAddress                  xxx.xxx.xxx.xxx
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 realenv
Forte Runtime             DBSharedDataEntities_cl0_Part2 ExecId: 16736 (ftserver)
  Locations:
        Location Descriptor for protocol: Forte!UnixDomain
            Path                        /forte/tmp/FORTE_A00004160
            HostName                    omega
        Location Descriptor for protocol: Forte!TCP/IP
            HostName                    omega
            PortNumber                  59128
            DotAddress                  xxx.xxx.xxx.xxx
A TaskMgr dump during the hang:
(notice the messages having as destination the non-existing Service Object instance partition ...:0x3b913:0x2).
Thu Apr 27 09:55:14 : 165 DOM Id      8 PART_CREATEPART     id 0x3b913
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 166 INC id      8 count   3 proxymgr.ResolveOutGoingProxy
Thu Apr 27 09:55:14 : 167 DOM Id      8 PART_STARTPART      id 0x3b913
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 168 DOM Id      8 PART_CHECKSTART     id 0x3b913
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 169 DOM Id      8 LOCSET_CREATELOCSET id 0x3b913 partid 0x0
Thu Apr 27 09:55:14 :   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913   Version: 0
Thu Apr 27 09:55:14 :       PartitionsUsing: 1  FailedNumber: 13106
Thu Apr 27 09:55:14 : 170 INC id      8 count   3 dom.exchangemethod.1
Thu Apr 27 09:55:14 : 171 DOM Id      8 MSG_ALLOCATE        id 0x16edd local 0x15
Thu Apr 27 09:55:14 : 172 INC id      8 count   5 proxymgr.ResolveOutGoingProxy
Thu Apr 27 09:55:14 : 173 DEC id      8 count   3 proxymgr.ResolveOutGoingProxy
Thu Apr 27 09:55:14 : 174 DOM Id      8 MSG_SENT            id 0x16edd to partid 0x3cd65
Thu Apr 27 09:55:14 : 175 DOM Id      8 MSG_COMPLETEDOM     id 0x16edd
Thu Apr 27 09:55:14 : 176 DOM Id      8 MSG_COMPLETECM      id 0x16edd
Thu Apr 27 09:55:14 : 177 DOM Id      8 MSG_POSTSEND        id 0x16edd
Thu Apr 27 09:55:14 : 178 DEC id      8 count   2 dom.exchangemethod.2
Thu Apr 27 09:55:14 : 179 DOM Id      8 MSG_SUSPEND         id 0x16edd
Thu Apr 27 09:55:14 : 180 DOM Id     18 MSG_ALLOCATE        id 0x16ede local 0xa
Thu Apr 27 09:55:14 : 181 DOM Id     18 MSG_BEGINDESER      id 0x16ede
Thu Apr 27 09:55:14 : 182 DOM Id     18 MSG_FOUND_REPLY     id 0x16ede
Thu Apr 27 09:55:14 : 183 INC id     18 count   1 domsg.process.1
Thu Apr 27 09:55:14 : 184 DOM Id     18 MSG_RECEIVE         id 0x16ede reply msg 0x16edd
Thu Apr 27 09:55:14 : 185 DOM Id     18 MSG_ACK             id 0x16edd
Thu Apr 27 09:55:14 : 186 DOM Id     18 MSG_RESUME          id 0x0 resuming task 0x40166638
Thu Apr 27 09:55:14 : 187 DEC id     18 count   0 domsg.process.8
Thu Apr 27 09:55:14 : 188 DOM Id      8 MSG_FREE            id 0x16edd local 0x15
Thu Apr 27 09:55:14 : 189 DOM Id      8 MSG_FREE            id 0x16ede local 0xa
Thu Apr 27 09:55:14 : 190 DOM Id      8 LOC_ADDLOCATION     id 0x938 partid 0x3b913
Thu Apr 27 09:55:14 :       0x938 State: DESTROY  Adv OwningSubPart: 0
Thu Apr 27 09:55:14 :         PartId:         xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913
Thu Apr 27 09:55:14 :         CM DestPartId:  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 : Unix Domain Socket Location - Host: omega Path: /forte/tmp/FORTE_A00004160
Attributes:
    Path                         /forte/tmp/FORTE_A00004160
    HostName                     omega
Thu Apr 27 09:55:14 :         Counters   Send: 1  Receive: 0
Thu Apr 27 09:55:14 : 191 INC id      8 count   3 dom.exchange.1
Thu Apr 27 09:55:14 : 192 DOM Id      8 MSG_ALLOCATE        id 0x16edf local 0xa
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 :
Thu Apr 27 09:55:14 : 193 DOM Id      8 MSG_SENT            id 0x16edf to partid 0x3b913
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 : 194 DOM Id     13 LOC_STOPLOCATION    id 0x938 partid 0x3b913
Thu Apr 27 09:55:14 :       0x938 State: DESTROY  Adv OwningSubPart: 0
Thu Apr 27 09:55:14 :         PartId:         xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913
Thu Apr 27 09:55:14 :         CM DestPartId:  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 : Unix Domain Socket Location - Host: omega Path: /forte/tmp/FORTE_A00004160
Attributes:
    Path                         /forte/tmp/FORTE_A00004160
    HostName                     omega
Thu Apr 27 09:55:14 :         Counters   Send: 1  Receive: 0
Thu Apr 27 09:55:14 : 195 DOM Id     13 LOC_DESTLOCATION    id 0x938 partid 0x3b913
Thu Apr 27 09:55:14 : Thu Apr 27 09:55:14 :       0x938 State: DESTROY  Adv OwningSubPart: 0
Thu Apr 27 09:55:14 :         PartId:         xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913
Thu Apr 27 09:55:14 :         CM DestPartId:  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 : Unix Domain Socket Location - Host: omega Path: /forte/tmp/FORTE_A00004160
Attributes:
    Path                         /forte/tmp/FORTE_A00004160
    HostName                     omega
Thu Apr 27 09:55:14 :         Counters   Send: 1  Receive: 0
Thu Apr 27 09:55:14 : 196 DOM Id     13 LOCSET_DESTLOCSET   id 0x3b913 partid 0x0
Thu Apr 27 09:55:14 :   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913   Version: 0
Thu Apr 27 09:55:14 :       PartitionsUsing: 1  FailedNumber: 13106
Thu Apr 27 09:55:14 :
Thu Apr 27 09:55:14 : 197 INC id     13 count   2 partmgr.stoplocation.1
Thu Apr 27 09:55:14 : 198 DOM Id     13 PART_DESTREMINT     id 0x3b913 sub 0x2
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 199 DOM Id     13 PART_FAULTNOPROXY   id 0x3b913
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 200 DOM Id     13 PART_PARTLOST       id 0x0 partid 0x3b913
Thu Apr 27 09:55:14 : 201 DOM Id     13 PART_FINCONNLOST    id 0x3b913
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 202 INC id     13 count   2 dom.exchange.1
Thu Apr 27 09:55:14 : 203 DOM Id     13 MSG_ALLOCATE        id 0x16ee0 local 0x15
Thu Apr 27 09:55:14 : 204 DOM Id     13 MSG_SENT            id 0x16ee0 to partid 0x3b913
Thu Apr 27 09:55:14 : 205 DOM Id     13 PART_SENDFAIL       id 0x0 error 0x3b913
Thu Apr 27 09:55:14 : 206 DOM Id     13 MSG_FAILEDDOM       id 0x16ee0 Message::Send.1
Thu Apr 27 09:55:14 : 207 DOM Id     13 MSG_FREE            id 0x16ee0 local 0x15
Thu Apr 27 09:55:14 : 208 DEC id     13 count   1 Dom.exchange.2
Thu Apr 27 09:55:14 : 209 DOM Id     13 PART_FINREMOVE      id 0x3b913 sub 0x2
Thu Apr 27 09:55:14 :       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2 DESTROY - OUTBOUND
Thu Apr 27 09:55:14 : 210 DEC id     13 count   0 partmgr.stoplocation.3
Thu Apr 27 09:55:14 : 211 DOM Id      8 MSG_COMPLETEDOM     id 0x16edf
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 : 212 DOM Id      8 MSG_COMPLETECM      id 0x16edf
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 : 213 DOM Id      8 MSG_POSTSEND        id 0x16edf
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 :
Thu Apr 27 09:55:14 : 214 DOM Id      8 MSG_SUSPEND         id 0x16edf
Thu Apr 27 09:55:14 :       0x16edf-0xa [NETWORK] (EXCHANGE MESSAGE NEEDS_REPLY)
Thu Apr 27 09:55:14 :         ReplyMsg:    0x0-0x0  RelatedMsg: 0x0-0x0  OrigMsgSeq: 0x16edf
Thu Apr 27 09:55:14 :         Status:      OUTBOUND TASK_BLOCKED
Thu Apr 27 09:55:14 :         Previous:    xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Originating: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         Destination: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         Next:        xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3b913:0x2
Thu Apr 27 09:55:14 :         ToUse:       xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :         TaskId:      xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
Thu Apr 27 09:55:14 :         AssocTask:   xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1, 10
                     0x401af4f0
Thu Apr 27 09:55:14 :         Location:    0x0 SavedLocation: 0x00000000 LocaleId: 0x0
Thu Apr 27 09:55:14 :         SpecialOpt:  BRANCH_SYNC
Thu Apr 27 09:55:14 :         Version:     0  FailedNum: 0  Protocol: 0
Thu Apr 27 09:55:14 :         InternalMessage PROXY_VALIDATE
          PartId: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx:0x3ce25:0x1
Thu Apr 27 09:55:14 :           Adv ProxyId: 0x27  Ref ProxyId: 0x0  Duration: 0
          Scope/Class 0x0:0x0  Proxy Status: 0x0
          Version - Obj: 0 Pxy: 0
Thu Apr 27 09:55:14 :           ToPartId: 0x0
Thu Apr 27 09:55:14 :
Thu Apr 27 09:55:14 : 215 DEC id      8 count   2 dom.exchange.3

Similar Messages

  • Using AE with Load Balancing Router?

    Hi,
    I have two Adsl cable from differents ISPs and one Airport Express (AE), I'm using one adsl in AE and wireless from AE works normaly, when the adsl link fails I change to another ADSL cable. I bought a Dlink DI-LB604 (Load Balance Router) that has 2 Wan ports to receive the two ADSL cables that I have. My question:
    Will the Wireless network work if I connect my AE in to Dlink Router using Ethernet cable?
    Tks
    fsoato

    fsoato, Welcome to the discussion area!
    My question: Will the Wireless network work if I connect my AE in to Dlink Router using Ethernet cable?
    It should. It shouldn't be any different than connecting it to any other Ethernet connection.

  • Internet Load Balancing - Routing Issue

    Dear all, good day...
    in our ministry we are going to contract with 2 ISPs to provide us with the internet service (one of them will be the main line 16 MB, and the other line will be working as a backup line). Now, here is my question, is there any router that can holds the 2 ISPs lines at the same time and have the fail over property and load balancing, or i have to use 2 different routers (we have CISCO 2821) to do the load balancing between the 2 internet lines. Thankx

    Hi Tareq
    There are many ways you can do.But depending on your requirement.If you are using 2 ISPs and all of ISPs are willing to do BGP then that is the right way you should do. For doing load-sharing.please check this link out.
    http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml
    Just my thought.In case one of your ISPs can't do BGP then you can use the policy-based routing feature to do out-bound load-sharing(inside to ISPs) by classifying traffics you want.
    Try to understand technology first.
    http://www.cisco.com/en/US/products/ps6599/products_white_paper09186a00800a4409.shtml
    Hope this helps
    Thot

  • How to Configure Multiple Portal Middle Tiers with a Load Balancing Router

    Hi,
    Portal version trying to install 10.1.2 on Windows 2003 boxes.
    I am following the guide http://download.oracle.com/docs/cd/B14099_19/portal.1012/b14037/cg_advnc.htm#i1046354. I have InfraStructure installed on a different box and am trying to install 2 Portal Midtiers each on separate boxes and using LBR. The above document is kind of confusing as I am trying to following
    5.3.1 Step 1: Install a Single Portal and Wireless Middle Tier (M1)
    5.3.2 Step 2: Configure OracleAS Portal on M1 to Be Accessed Through the LBR (AND FOLLOW ARE THE STEPS 1 to 14 in sequence)
    if I follow 1 to 14 steps in sequence the information is not consistent what is being listed in the following sections
    5.4.1 Create Virtual Hosts
    5.4.2 Configure OracleAS Web Cache
    5.4.3 Register OracleAS Portal with OracleAS Single Sign-On
    i.e.
    ptlconfig -dad portal -sso -host www.abc.com -port 7779
    ptlconfig -dad portal -sso -host www.xyz.com -port 7779
    as in the above steps it says to run
    ptlconfig -dad portal -wc -site
    and ssoreg command that always fails because I am running it from midtier as it gives error saying invalid username/password
    as oppoesed to steps listed in point 8, 9, 10, 11 and 12.
    Can someone please privide the steps in sequence I need to follow when installing 2 midtiers with frontend LBR and one infrastructure. I am trying to follow the architecture listed in the above link.
    Any help is really appreciated.
    Thanks

    Hi,
    Will appreciate any inputs on the following.
    I am planning to install Infrastructure and one Midtier BI Forms Reports Discoverer, Portal on one windows box and the second midtier BI Forms Discoverer, Portal on the second windows box.
    Please correct me if I am wrong on installing and configuring the mid-tiers as following are the steps I have compiled going through the document and want to make sure this time I do it right.
    As I'll be installing BI Forms Reports Discoverer, Portal so wondering when I install the second midtier do I need to unselect all Portal, Forms, Reports, Discoverer or just the Portal I need to unselect.
    Also in the host file of both the windows boxes do I just need to keep the LBR IP Address entry and remove the rest.
    LBR:_
    Computer Name: bigip5.prd.com
    IP Address: *167.123.2.5*
    Listen Port: *80*
    Invaidation Port: *9401*
    Infrastructure:_
    Computer Name: portal1.prd.com
    IP Address: *167.123.2.6*
    Oracle HTTP Server Listening Port: *7777*
    Application Server Control port: *1800*
    M1 (Portal & BI Forms Reports Discoverer):_
    Computer Name: portal1.prd.com
    IP Address: *167.123.2.6*
    Oracle HTTP Server Listening Port: *7778*
    OracleAS Web Cache Listening Port: *80*
    OracleAS Web Cache Invalidation Port: *9401*
    OracleAS Web Cache Administration Port: *9400*
    Web Cache Statistics port: *9402*
    Application Server Control port: *1810*
    M2 (Portal & BI Forms Reports Discoverer):_
    Computer Name: portal2.prd.com
    IP Address: *167.123.2.7*
    Oracle HTTP Server Listening Port: *7778*
    OracleAS Web Cache Listening Port: *80*
    OracleAS Web Cache Invalidation Port: *9401*
    OracleAS Web Cache Administration Port: *9400*
    Web Cache Statistics port: *9402*
    Application Server Control port: *1810*
    First to create MetadataRepository and then Install Infrastructure and then follow the below steps to install Midtiers
    Install and Configure of M1 (Portal and BI Forms Reports Discoverer):-_
    *5.3.1 Step 1*: Install a Single Portal and BI Forms Reports Discoverer (M1 i.e. portal1.prd.com)
    *5.3.2 Step 2*: Configure OracleAS Portal and BI Forms Reports Discoverer on M1 to Be Accessed Through the LBR
    *1.* Configure LBR
    *2.* Follow Section 5.4.1.1 to create the Virtual Host for bigip5.prd.com (LBR) and portal1.prd.com (M1)
    *3.* Define a site that matches the virtual host entry for bigip5.prd.com (LBR) on Webcache of M1
    *4.* Use OracleAS Web Cache Manager on M1, to map the site bigip5.prd.com (LBR) to middle tier portal1.prd.com (M1).
    Follow steps 5 and 6 as per the document
    *7.* Configure bigip5.prd.com (LBR) to accept invalidation requests from the OracleAS Metadata Repository on a separate port i.e. 9401
    *8.* Change iasconfig.xml on M1
    *9.* run ptlconfig -encrypt
    *10.* Register the URL changes with OracleAS Portal by running ptlconfig -dad portal -wc -site
    *11.* No need as it is http only
    *12.* Run the follwoing
    MID_TIER_ORACLE_HOME_M1\sso\bin\ssoreg.bat
    -site_name bigip5.prd.com
    -mod_osso_url http://bigip5.prd.com:80
    -config_mod_osso TRUE
    -oracle_home_path MID_TIER_ORACLE_HOME_M1
    -config_file MID_TIER_ORACLE_HOME_M1\Apache\Apache\conf\osso\osso.conf
    -admin_info cn=orcladmin
    -virtualhost
    *13.* Edit targets.xml to enable monitoring of the LBR's front-end host and port settings for OracleAS Portal
    +<Property NAME="PortalListeningHostPort" VALUE=http://bigip5.prd.com:80/>+ and then run
    MID_TIER_ORACLE_HOME_M1\bin\emctl reload
    *14.* Test the setup
    Install and Configure of M2 (Portal and BI Forms Reports Discoverer):-_
    *5.3.4 Step 4*: Install a Single Portal and BI Forms Reports Discoverer (M2 i.e. portal2.prd.com)
    *1.* As I am installing on wiondows so will not set IASCONFIG_LOC environment variable as I can just copy the iasconfig.xml file from M1 to M2
    *2.* Run OUI on M2
    *3.* Clear the selection for OracleAS Portal but don't know if I need to unselect Forms , Reports, Discoverer also.
    *4.* Enable OracleAS Portal
    *5.3.5 Step 5:* Configure the New Middle Tier (M2) to Run Your Existing Portal
    *1.* Create both virtual hosts as done on M1
    *2.* Copy dads.conf, oradav.conf, cache.conf, web.xml from M1 to M2
    *3.* Re-register mod_osso on M2. To do this, perform the following steps by copying osso.conf from M1 to M2
    *4.* Synchronize the DCM by using the following command
    MID_TIER_ORACLE_HOME_M2/Apache/Apache/bin/ssotransfer MID_TIER_ORACLE_HOME_M2/Apache/Apache/conf/osso/osso.conf
    *5.* Run dcmctl updateConfig
    *6.* add the necessary mod_rewrite and mod_oc4j directives to the httpd.conf and mod_oc4j.conf files respectively
    *7.* Restart Oracle HTTP Server on M2
    *8.* Access the OracleAS Web Cache Manager on M1 and follow steps 9,10,11,12,13,14,15,16 for Webcache seetings and clustering.
    Also will appreciate if can get some info on the following:
    *1.*
    When I configure the Webcache as per the Document but if I bring down one Midtier Instance the requests are not going to the other Instance that is up and ignores the case whether an instance is down. Any idea how what and where do I need to provide any setting which in case of instance is down routes the requests to the one that is up.
    *2.*
    What exactly happens when it says To enable monitoring of the LBR's front-end host and port settings for OracleAS Portal edit target.xml. Is this for LBR to find if an Instance is down or not and route the requests appropriately.
    Thanks again for all the help.

  • Load Balancing b/w two cisco router

    Hello Friends,
    Please advise me,We are using two Cisco Routers with F5 Load balancer,
    Router A (Cisco 2811) has one ISP configured
    Router B (Cisco 3825) has the other ISP configured
    ISP on Router A has 5 Mbps Bandwidth
    ISP on Router B has 10 Mbps Bandwidth
    My Doubt is if the load balancer is down,how to utilize the ISP (or) How to divert the connection ?
    Here i have attached my N/w diagram for ur reference..........
    Can someone solve my question.............please
    Thank you.

    Hi Mohamed,
    With default routing in use you can just configure one default route on each router   But it would only do load sharing not load balancing.
    PFR(performance routing) is a better solution but have never tried with two diffferent router series. Also need to validate if the router series you are using supports PFR.
    Regards,
    Sathvik K V

  • Using a DI-LB604 load balancing on mac

    In my office we are using a DI-LB604 load balancing router, since the day they instaled it my internet conecction is not stable, and it works fine for all PCs in the office, i´m the only one ussing Mac

    You can take a look at this thread:
    http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=Getting%20Started%20with%20Wireless&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cbfa834
    But like I said, if you require more bandwidth per link you need to look at another vendor.

  • Question on how does load balancing work on Firewall Services Module (FWSM)

    Hi everyone,
    I have a question about the algorithm of load balancing on Firewall Services Module (FWSM).
    I understand that the FWSM supports up to three equal cost routes on the same interface for load balancing.
    Please see a lower simple figure.
    outside inside
    --- L3 SW --+
    |
    MHSRP +--- FWSM ----
    |
    --- L3 SW --+
    I am going to configure the following default routes on FWSM point to each MHSRP VIP (192.168.13.29 and 192.168.13.30) for load balancing.
    route outside_1 0.0.0.0 0.0.0.0 192.168.13.29 1
    route outside_1 0.0.0.0 0.0.0.0 192.168.13.30 1      
    However I don't know how load balancing work on FWSM.
    On FWSM, load balancing work based on
    Per-Destination ?
    Per-Source ?
    Per-Packet ?
    or
    Other criteria ?
    Your information would be greatly appreciated.
    Best Regards,

    Configuring "tunnel default gateway' on the concentrator allowed traffic to flow as desired through the FWSM.
    FWSM is not capable of performing policy based routing, the additional static routes for the VPN load balancing caused half of the packets to be lost. As a result, it appears that the VPN concentrators will not be able to load balance.

  • Dual ISP connection unequal load balancing

    Hi All,
    I an issue regarding load balancing between to ISP.  I have done policy based routing as stated in other cisco discussions .
     I have 2 /30 as my test ISP and isp ip configured on other switch while i have my customer configs on my end. I can ping the two test ISP from my router but not with PC's in the lan until i remove "ip nat inside source route-map 20 interface GigabitEthernet0/0.20 overload" from the routers config.
    .. Please help 
    Load-Balancing-Router#show run
    Building configuration...
    Current configuration : 2716 bytes
    ! Last configuration change at 04:09:37 UTC Tue Apr 21 2015 by anprasad
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Load-Balancing-Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.1.2
    ip dhcp excluded-address 192.168.1.0 192.168.1.100
    ip dhcp pool LAN
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.1
    ip domain name fnu.ac.fj
    multilink bundle-name authenticated
    license udi pid CISCO1921/K9 sn FGL150925YE
    username anprasad privilege 15 secret 5 $1$Oy40$h13lWAN4upzI19L6/MXjf/
    username aaa privilege 15 secret 5 $1$W3JH$LMd0LUtdxJlXXJkB.NxjB0
    ip ssh version 1
    class-map match-all 512K-Outbound
     match access-group name DR-512K-OutBound
    class-map match-all 10240K-Outbound
     match access-group name DR-1024K-OutBound
    policy-map DR-Outbound
     class 10240K-Outbound
       police rate 10240000 bps burst 1920000 bytes
         conform-action transmit
         exceed-action drop
     class 512K-Outbound
       police rate 512000 bps burst 96000 bytes
         conform-action transmit
         exceed-action drop
    interface GigabitEthernet0/0
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/0.10
     description Student-Internet
     encapsulation dot1Q 10
     ip address 202.0.1.1 255.255.255.252
     ip nat outside
     ip virtual-reassembly
    interface GigabitEthernet0/0.20
     description Staff-Internet
     encapsulation dot1Q 20
     ip address 202.0.2.1 255.255.255.252
     ip nat outside
     ip virtual-reassembly
     shutdown
    interface GigabitEthernet0/1
     description LAN-Network
     ip address 192.168.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     duplex auto
     speed auto
    interface FastEthernet0/0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip nat inside source route-map 10 interface GigabitEthernet0/0.10 overload
    ip nat inside source route-map 20 interface GigabitEthernet0/0.20 overload
    ip route 0.0.0.0 0.0.0.0 202.0.1.2
    ip route 0.0.0.0 0.0.0.0 202.0.2.2
    ip access-list extended DR-10240K-OutBound
     permit ip 192.168.1.0 0.0.0.255 any
    ip access-list extended DR-512K-OutBound
     permit ip 192.168.1.0 0.0.0.255 any
    access-list 100 permit ip 192.168.1.0 0.0.0.255 any
    route-map 10 permit 10
     match ip address 100
     match interface GigabitEthernet0/0.10
    route-map 20 permit 20
     match ip address 100
     match interface GigabitEthernet0/0.20
    snmp-server community fnuro RO
    control-plane
    line con 0
     logging synchronous
     login local
    line aux 0
    line vty 0 4
     login local
    scheduler allocate 20000 1000
    end

    Hi,
    I would like to ask if you are done with your configuration? Is it working?
    next month we will add an addition ISP and I will try to configure it?
    Hope you'll give me some ideas.
    thank you

  • Dual Nic Load Balancing Solution

    Hi,
    I have a very peculiar situation. I'm currently a college student with access to an almost unlimited network. But the problem is that the network limits each IP to 30 Mb/s. I have 2 nics at my disposal and have tried two options so far:
    bonding
    two independent nic, let network manager take care of it
    I set-up bonding and got it working, but it seems limited to roughly the same speeds as a single nic, but I can see the network being slit between the two nics evenly. This is what lead me to conclude that since I have a single ip address it's limiting it by IP not mac addresses. Here I might occasionally spike above the limits but not consistently.
    With the network manager solution, Im basically thrown at random and can occasionally get higher than limited speeds. Specially with torrenting clients.
    Are there any other useful options that I could explore, my next stop was a load balancing routing table but I want to see what you guys know before I keep trying weirder solutions.
    Thanks in advance

    falconindy wrote:There's no problem here. Please don't try to circumvent the policies your network admins are defining.
    Oh come on, we'd all do the same thing if we could double our available bandwidth! 
    I really can't provide much of a solution.  I did this back with my dialup days, many many eons ago.  I used 2 phone lines bonded to get my 56k speeds doubled.  It was a gigantic pain in the rear to set up back then, as well.  However, I'm lucky to remember what I had for breakfast, so remembering how I did something 15+ years ago is pretty much out of the question.
    I'm sure linux can do this, but I'm guessing one of the BSDs would have information about how to do this written up somewhere.  This is right up BSD's alley.  They have all kinds of load-balancing code built into their network stack (Amazon actually had a lot of trouble keeping up with demand when they were getting big, so they wrote up their own networking stack, which has since been returned to the FreeBSD project, iirc).  So it might be worth your time to check that out and possibly run a mini BSD setup on an old computer or something to route the bandwidth to an internal network (of course this would likely require three NICs in a single computer...so more complexity there too).  Some of the problem you are running into may be due to the network just being congested, which could explain the differing speeds.  Then there may be an issue with certain servers not being able to push out 60 MB/s worth of data to you, for whatever reason. 
    Either way, please keep us posted about what you do and how you do it, I'm anxious to find out the final solution here.
    Best of luck to you.

  • Session Binding on Web Cache acting as load balancer

    Hi gurus,
    I have Web Cache 10.1.2 acting as load balancer on the front-end machine, and two OracleAS 10.1.2 enterprise edition installations behind it. The load balancing configuration is done and is working well. The Web Cache (acting as load balancer) routes requests the to the two OracleAS installations very well.
    Now I need to set up session binding, so that a request from the same client is directed to the same OracleAS installation (in the same session). I am really a novice on session binding - could you pl let me know what I need to do?
    Going through the Web cache admin guide, I did try to use JSESSIONID but without much success. Specific Qs:
    1. Do I need to enable session binding at only the back-end OracleAS installations, or also at the front-end Web Cache (acting as load balancer).
    2. If I use JSESSIONID - is it generated by Web Cache / HTTP Server automatically, or do I need to write a J2EE application to generate it?
    Thanks a lot in advance.
    Navneet.

    hi,,,
    i neesd some help in ur issue,
    i face a problem woth web cache in Load balancing ,, it is not working...
    my case is same to ur case, BUT i have AS10g ( 9.0.4 )
    and i got this err
    "FRM-92101: There was a failure in the forms server during startup.
    This could happen due to invalid configuration.
    Please look in the web-server log file for details."
    i followed metalink notes and configration. and Configuring Oracle HTTP Server by modifying the httpd.conf file.
    - CookieTracking On
    - and CookieName xxxxxxx
    and still the same prob ...
    could u help me plz.
    and is it because my AS version which is 10g(9.0.4) ?
    this is my emil : [email protected]

  • Load balancing weirdness using NAT and same-metric route

    Hi.
    I'm trying to set up a double-WAN load-balancing scenario:
    I decided to attempt the "multiple same-metric routes with NAT" approach so I went for the example used in the IOS NAT Load-Balancing for Two ISP Connections Configuration Guide [1].
    I decided to use an upside-down Cisco 871-SEC/K9: use Vlan1 and Vlan2 for the routers and Fa4 for the LAN. I am hoping this is not an issue.
    There is this weirdness with some connections, particularly FTP. I pinpointed the problem to the following scenario: if I do a couple of pings to 100.1.1.1 using the FastEthernet4 as the source address, this is what I get in the logs:
    === PING 1 ECHO REQUEST ===
    *Mar 3 04:38:43.521: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan1), routed via RIB
    *Mar 3 04:38:43.521: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14152]
    *Mar 3 04:38:43.521: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan1), g=10.129.124.1, len 60, forward
    *Mar 3 04:38:43.521: ICMP type=8, code=0
    === PING 1 ECHO REPLY ===
    *Mar 3 04:38:45.589: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19824]
    *Mar 3 04:38:45.589: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
    *Mar 3 04:38:45.589: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
    *Mar 3 04:38:45.589: ICMP type=0, code=0
    === (something else) ===
    *Mar 3 04:38:52.353: RT: SET_LAST_RDB for 0.0.0.0/0
    OLD rdb: via 10.129.124.33, Vlan2
    NEW rdb: via 10.129.124.1, Vlan1
    === PING 2 ECHO REQUEST ===
    *Mar 3 04:38:52.353: IP: tableid=0, s=192.168.60.4 (FastEthernet4), d=100.1.1.1 (Vlan2), routed via RIB
    *Mar 3 04:38:52.353: NAT: s=192.168.60.4->10.129.124.2, d=100.1.1.1 [14159]
    *Mar 3 04:38:52.353: IP: s=10.129.124.2 (FastEthernet4), d=100.1.1.1 (Vlan2), g=10.129.124.33, len 60, forward
    *Mar 3 04:38:52.353: ICMP type=8, code=0
    === PING 2 ECHO REPLY ===
    *Mar 3 04:38:53.029: NAT*: s=100.1.1.1, d=10.129.124.2->192.168.60.4 [19825]
    *Mar 3 04:38:53.029: IP: tableid=0, s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), routed via RIB
    *Mar 3 04:38:53.033: IP: s=100.1.1.1 (Vlan1), d=192.168.60.4 (FastEthernet4), g=192.168.60.4, len 60, forward
    *Mar 3 04:38:53.033: ICMP type=0, code=0
    In the section "Ping 2 Echo Request" line 2 shows the NAT translating the packet to the address for the first provider but line 3 shows it routing it through the second one.
    In this case, the ICMP packet goes through but it is problematic if the ISP restricts the service by source-address (like RPF) or there is some acceleration mechanism inside the provider cloud, other than just plain routing.
    What am I missing? Here is the relevant part of the configuration. I deliberately disabled CEF to be able to debug the messages, but I *think* this may be altering the actual router behavior. This router does not have a "debug ip cef packet" command.
    no ip cef
    ip dhcp pool lan-side
    import all
    network 192.168.60.0 255.255.255.0
    default-router 192.168.60.1
    domain-name doublewan.local
    dns-server 8.8.8.8 8.8.4.4
    lease infinite
    ip domain name doublewan
    interface FastEthernet0
    !doesn't appear on running-config: vlan 1 is the default access vlan
    !switchport access vlan 1
    interface FastEthernet1
    switchport access vlan 2
    interface FastEthernet2
    shutdown
    interface FastEthernet3
    shutdown
    interface FastEthernet4
    ip address 192.168.60.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    no ip route-cache
    duplex auto
    speed auto
    interface Vlan1
    ip address 10.129.124.2 255.255.255.224
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    interface Vlan2
    ip address 10.129.124.35 255.255.255.224
    ip nat outside
    ip virtual-reassembly
    no ip route-cache
    ip route 0.0.0.0 0.0.0.0 Vlan1 10.129.124.1
    ip route 0.0.0.0 0.0.0.0 Vlan2 10.129.124.33
    ip nat inside source route-map nat1 interface Vlan1 overload
    ip nat inside source route-map nat2 interface Vlan2 overload
    ip access-list standard acl4-nexthop-vlan1
    permit 10.129.124.1
    ip access-list standard acl4-nexthop-vlan2
    permit 10.129.124.33
    route-map nat2 permit 10
    match ip address 102
    match ip next-hop acl4-nexthop-vlan2
    match interface Vlan2
    route-map nat1 permit 10
    match ip address 101
    match ip next-hop acl4-nexthop-vlan1
    match interface Vlan1
    control-plane
    Of course, there is some configuration pending for redundancy and stuff.
    Thanks a lot in advance.
    [1] http://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/100658-ios-nat-load-balancing-2isp.html

    Hello.
    This might be a bug in debug command or the IOS (without ip cef) you use; as routing is done before NAT (inside to outside).
    To make sure it works fine with ip cef, just enable strict uRPF (or just ACL) on .1 and .33 interfaces and see if you see any packet sent over wrong interface.
    PS: please check "sh ip cef 100.1.1.1"; I guess ip cef would tell you "per-destination sharing".

  • Load Balancing on 837 router

    HI Prof,
    I've two cisco 837 router with cisco IOS 12.3 currently. I would like to configure load balancing on both the router, have tried to configure GLBP but it show me that the hardware not supported.
    Is there any other protocol or technology to achieve my desire?
    Thank and Advice.

    What are your requirements. Do you have multiple segments to support? Are you only looking for load-balancing or do you have a high availibility requirement?
    In that case you can use multiple HSRP groups for instance.
    Do both 837 routers have a separate xDSL connection?
    Are you using NAT to translate between private and public address pools?
    There is more than one solution to achieve load-balancing. Please answer the above questions and if possible draw a simple diagram of your desired topology.
    HTH
    Leon

  • Multiple WAN connections all through one router with load balancing?

    I am setting up a network in my dormatory for myself and about 20 friends. about half of us have DSL connections at the moment. Is there a way to have all the DSL connections (possibly run through cheap home DSL routers) all connect into a cisco router that then acts as the gateway for our entire network? woudl it be possible for each internet request to go out over the connection that has the least load AND also be able to use some sort of load balancing, so one user cant use all of the outgoing/incoming bandwidth?
    If you have any ideas please let me know

    Hi Ian,
    To get this working, you would either need to use something like PPP to bundle your links together or use a dynamic protocol.
    In bundling the links, you could make them appear as one link, with a single IP address each end and the router takes care of distributing the load. To implement this though, you would need control of both sides of the link, or be terminating with one carrier who is happy to implement this for you.
    The second is to use a dynamic protocol (such as eigrp, ospf, etc), which can build up a map of the network to router from point a to point b. For this you also need control of the link.
    I can't think of another method, unless you can control the link from both sides. Your other option it to pool your money and buy a larger link or a leased line. If you bought a leased line or two, your carrier would be more than happy to talk to you about routing over that, but generally you're looking at mega bucks for that.
    HTH,
    Mark

  • Load balancing using multiple default routes

    Hi Guys,
    I just want to ask does creating multiple default routes on my router provides load-balancing on my WAN side? As far as i know, for example if I have two default routes on my router and let say I have two users connecting to the internet, the first one might go to the first WAN link while the second user might go to the second WAN link.
    Thank you so much
    Rex

    there are the difference between, load balancing and load sharing..which we need to understand.
    load sharing means you have 2 users, user A and User B, user A wants to use ISP1 and user B wants to use ISP2. this is called load sharing. and can be achieved via PBR (Policy based routing).
    we should not try to use load balancing for Internet traffic with 2 different ISPs.

  • Load balancing with use of router 881.

    Hello,
    I have two MPLS line and i want load balancing with the help of CISCO router 881. is it necessary that i require two router on both location.? if one location have firewall and one location have cisco router 881 then can i do a load balancing or i require two router each on both location ? What are the basic requirement that i need.
    Thanks,
    Kuntal

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    An 881 should be able to load share across multiple ports.  Many routing protocol support ECMP, including BGP, but you need "special" hidden/secret commands to enable.  EIGRP also supports unequal cost load sharing.
    If an 881 supports OER or PfR, those too will do unequal load sharing, dynamically.

Maybe you are looking for

  • MDIS failed to generate the Log file!!!

    Hello All, Having a issue where MDIS is not generating the log file.. The scenario is something like this- The files are getting archived and the records not flowing into MDM Basis team says- 2014-06-30T14:11:33.339,47083231971072,24,"[MDS=sapdpm1 Re

  • Iterating Through Properties Loaded from LoadedFromXML Method

    For the first time, I am storing and retrieving application settings from properties files using Java 1.5. What I am looking for is the simplest way to iterate through the key/value pairs and print them out. Any recommendation on the best way to acco

  • Problem exporting to .swf from ID CS5

    Hello all. I have an 18-page InDesign document with animation, buttons, etc and just tried exporting it as a swf. I get a separate swf file for every page, but my client has requested a single swf file containing all the pages. I just watched a video

  • Synchronizing Color Profiles of two monitors

    How do i synchronize the color profile on my macbook pro with another monitor?

  • Reloading system software

    When is it advisable to reload my system software?  What kinds of problems can that help with?  What are the possible pitfalls of doing so?  Finally, since I've done some system upgrades online since installing the original system, would that cause p