Maximum number of interfaces in Port Channel on Nexus 5596

Let me preface this by saying I am not a network expert....
I noticed that our customer had configured a port channel on their Nexus 5596 comprised of 16 interfaces. I thought the maximum number of interfaces in a port channel was 8 interfaces? I see in the Nexus 7000 documentation that if you configure 16 interfaces, the remaining 8 will be in "hot standby." Is this the same behavior on the Nexus 5000 series?
Thank you.

Same behavior on the 5500 series and other Cisco switches like 3750, 3850 , etc..
HTH

Similar Messages

  • MAC flapping reported between 2 port channels on Nexus 5596

    Hi all, I'm seeing messages like the following reported on a Nexus 5596:
    2015 Jan  7 12:40:48.954 Switch-5596A %FWM-6-MAC_MOVE_NOTIFICATION: Host 00ab.cdef.0123 in vlan 104 is flapping between port Po5 and port Po10
    Po5 is connected to a storage cluster and is configured as an access port. It is connected to 2 Nexus 5596 switches using vpc.
    interface port-channel5
      description Storage Shelf 1
      priority-flow-control mode off
      switchport access vlan 104
      spanning-tree port type edge
      spanning-tree bpduguard enable
      speed 10000
      flowcontrol receive on
      vpc 5
    Po10 is the uplink to the core switch:
    interface port-channel10
      description uplink
      switchport mode trunk
      switchport trunk native vlan 2702
      switchport trunk allowed vlan 64,94,104,124
      spanning-tree port type network
      speed 10000
      vpc 10
    Any ideas on why we would be seeing these log messages?
    Thank you.

    You need to trace this mac address: - 00ab.cdef.0123 and check if this has dual nic card if yes then check if nic teaming is configured correctly ...then shut down one of the link and see if you are learning the same mac address on two different ports?
    HTH

  • Maximum number of interfaces to implement

    I was searching for the maximum number of interfaces a class can implement.
    The only references I found, was "more than one", "a two-byte count of the number of interfaces implemented by the class (or interface) defined" and the maximum number for the Java Card VM (15).
    Does this mean that I can implement as much interfaces as I want (as long as the count of the total fits in a two-byte field - whatever that field is)?
    Can anyone tell me how much exactly?
    TIA,
    Mylene

    This compiles fine:
    interface I0 { void doit(); }
    interface I1 { void doit(); }
    interface I2 { void doit(); }
    interface I3 { void doit(); }
    interface I4 { void doit(); }
    interface I5 { void doit(); }
    interface I6 { void doit(); }
    interface I7 { void doit(); }
    interface I8 { void doit(); }
    interface I9 { void doit(); }
    interface I10 { void doit(); }
    interface I11 { void doit(); }
    interface I12 { void doit(); }
    interface I13 { void doit(); }
    interface I14 { void doit(); }
    interface I15 { void doit(); }
    interface I16 { void doit(); }
    interface I17 { void doit(); }
    interface I18 { void doit(); }
    interface I19 { void doit(); }
    interface I20 { void doit(); }
    interface I21 { void doit(); }
    interface I22 { void doit(); }
    interface I23 { void doit(); }
    interface I24 { void doit(); }
    interface I25 { void doit(); }
    interface I26 { void doit(); }
    interface I27 { void doit(); }
    interface I28 { void doit(); }
    interface I29 { void doit(); }
    interface I30 { void doit(); }
    interface I31 { void doit(); }
    interface I32 { void doit(); }
    interface I33 { void doit(); }
    interface I34 { void doit(); }
    interface I35 { void doit(); }
    interface I36 { void doit(); }
    interface I37 { void doit(); }
    interface I38 { void doit(); }
    interface I39 { void doit(); }
    interface I40 { void doit(); }
    interface I41 { void doit(); }
    interface I42 { void doit(); }
    interface I43 { void doit(); }
    interface I44 { void doit(); }
    interface I45 { void doit(); }
    interface I46 { void doit(); }
    interface I47 { void doit(); }
    interface I48 { void doit(); }
    interface I49 { void doit(); }
    interface I50 { void doit(); }
    interface I51 { void doit(); }
    interface I52 { void doit(); }
    interface I53 { void doit(); }
    interface I54 { void doit(); }
    interface I55 { void doit(); }
    interface I56 { void doit(); }
    interface I57 { void doit(); }
    interface I58 { void doit(); }
    interface I59 { void doit(); }
    interface I60 { void doit(); }
    interface I61 { void doit(); }
    interface I62 { void doit(); }
    interface I63 { void doit(); }
    interface I64 { void doit(); }
    interface I65 { void doit(); }
    interface I66 { void doit(); }
    interface I67 { void doit(); }
    interface I68 { void doit(); }
    interface I69 { void doit(); }
    interface I70 { void doit(); }
    interface I71 { void doit(); }
    interface I72 { void doit(); }
    interface I73 { void doit(); }
    interface I74 { void doit(); }
    interface I75 { void doit(); }
    interface I76 { void doit(); }
    interface I77 { void doit(); }
    interface I78 { void doit(); }
    interface I79 { void doit(); }
    interface I80 { void doit(); }
    interface I81 { void doit(); }
    interface I82 { void doit(); }
    interface I83 { void doit(); }
    interface I84 { void doit(); }
    interface I85 { void doit(); }
    interface I86 { void doit(); }
    interface I87 { void doit(); }
    interface I88 { void doit(); }
    interface I89 { void doit(); }
    interface I90 { void doit(); }
    interface I91 { void doit(); }
    interface I92 { void doit(); }
    interface I93 { void doit(); }
    interface I94 { void doit(); }
    interface I95 { void doit(); }
    interface I96 { void doit(); }
    interface I97 { void doit(); }
    interface I98 { void doit(); }
    interface I99 { void doit(); }
    interface I100 { void doit(); }
    interface I101 { void doit(); }
    interface I102 { void doit(); }
    interface I103 { void doit(); }
    interface I104 { void doit(); }
    interface I105 { void doit(); }
    interface I106 { void doit(); }
    interface I107 { void doit(); }
    interface I108 { void doit(); }
    interface I109 { void doit(); }
    interface I110 { void doit(); }
    interface I111 { void doit(); }
    interface I112 { void doit(); }
    interface I113 { void doit(); }
    interface I114 { void doit(); }
    interface I115 { void doit(); }
    interface I116 { void doit(); }
    interface I117 { void doit(); }
    interface I118 { void doit(); }
    interface I119 { void doit(); }
    interface I120 { void doit(); }
    interface I121 { void doit(); }
    interface I122 { void doit(); }
    interface I123 { void doit(); }
    interface I124 { void doit(); }
    interface I125 { void doit(); }
    interface I126 { void doit(); }
    interface I127 { void doit(); }
    public class uu implements I0
    ,I1
    ,I2
    ,I3
    ,I4
    ,I5
    ,I6
    ,I7
    ,I8
    ,I9
    ,I10
    ,I11
    ,I12
    ,I13
    ,I14
    ,I15
    ,I16
    ,I17
    ,I18
    ,I19
    ,I20
    ,I21
    ,I22
    ,I23
    ,I24
    ,I25
    ,I26
    ,I27
    ,I28
    ,I29
    ,I30
    ,I31
    ,I32
    ,I33
    ,I34
    ,I35
    ,I36
    ,I37
    ,I38
    ,I39
    ,I40
    ,I41
    ,I42
    ,I43
    ,I44
    ,I45
    ,I46
    ,I47
    ,I48
    ,I49
    ,I50
    ,I51
    ,I52
    ,I53
    ,I54
    ,I55
    ,I56
    ,I57
    ,I58
    ,I59
    ,I60
    ,I61
    ,I62
    ,I63
    ,I64
    ,I65
    ,I66
    ,I67
    ,I68
    ,I69
    ,I70
    ,I71
    ,I72
    ,I73
    ,I74
    ,I75
    ,I76
    ,I77
    ,I78
    ,I79
    ,I80
    ,I81
    ,I82
    ,I83
    ,I84
    ,I85
    ,I86
    ,I87
    ,I88
    ,I89
    ,I90
    ,I91
    ,I92
    ,I93
    ,I94
    ,I95
    ,I96
    ,I97
    ,I98
    ,I99
    ,I100
    ,I101
    ,I102
    ,I103
    ,I104
    ,I105
    ,I106
    ,I107
    ,I108
    ,I109
    ,I110
    ,I111
    ,I112
    ,I113
    ,I114
    ,I115
    ,I116
    ,I117
    ,I118
    ,I119
    ,I120
    ,I121
    ,I122
    ,I123
    ,I124
    ,I125
    ,I126
    ,I127
    public void doit(){}
    }

  • Maximum number of interfaces per vrf

    hi, is there a limit or maximum number of interface / sub-interface which I could associate to a single vrf? The box is Cisco 10000..thanks..

    Hi,
    The limit is the max number of (sub)interfaces or idb the box can handle.
    HTH
    Laurent.

  • Port channel between Nexus and Server is initializing

    Hi all, 
    I will need your help. 
    I have Nexus 5000, there is a POrt Channel between Nexus and Server, but one port always is in initializing.
    sh interface Ethernet101/1/27
    Ethernet101/1/27 is down (initializing)
      Hardware: 1000/10000 Ethernet, address: c8f9.f920.5b5c (bia c8f9.f920.5b5c)
      MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA
      Port mode is trunk
      auto-duplex, 10 Gb/s, media type is 10G
      Beacon is turned off
      Input flow-control is off, output flow-control is on
      Rate mode is dedicated
      Switchport monitor is off
    Any idea?
    Regards

    how many ports are you using in this port channel.
    can you paste the configuration of the channel ports and the interface.
    check the sh log if you are getting any log related to the port channeling.

  • Interfaces in port-channel keep err-disabling because of keepalives

    Below is the current portchannel that I am having problems with.  The interfaces on Switch A keep going into an error disabled state because they receive their own loopback.  Cisco says to disable keepalives and that it will fix the problem, but I do not like the idea of disabling keepalives.  Has anyone found a solution other than disabling keepalives?  Notice that ios's are different, but am not convinced that this is the issue.  Also one is PoE and the other isn't.  Lastly, i found this article "Keepalives are sent on all interfaces by default in Cisco IOS Software Release 12.1EA-based software. In Cisco IOS Software Release 12.2SE-based software and later, keepalives are not sent by default on fiber and uplink interfaces".  I would think trunked interfaces in a port-channel would be uplink interfaces and if this is true, it should be sending out keepalives anyway since i am running the 12.2SE based ios.  Thanks for whatever input you may have.
    Switch A
    C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)
    System image file is "flash:/c3750e-universalk9-mz.122-55.SE3/c3750e-universalk9-mz.122-55.SE3.bin"
    cisco WS-C3750X-48P
    Port-channels in the group:
    Port-channel: Po52
    Age of the Port-channel   = 219d:04h:32m:49s
    Logical slot/port   = 10/39          Number of ports = 4
    GC                  = 0x00000000      HotStandBy port = null
    Port state          = Port-channel Ag-Inuse
    Protocol            =    -
    Port security       = Disabled
    Ports in the Port-channel:
    Index   Load   Port     EC state        No of bits
    ------+------+------+------------------+-----------
      0     00     Gi1/0/35 On                 0
      0     00     Gi1/0/36 On                 0
      0     00     Gi2/0/45 On                 0
      0     00     Gi2/0/46 On                 0
    %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on GigabitEthernet1/0/35.
    %PM-4-ERR_DISABLE: loopback error detected on Gi1/0/35, putting Gi1/0/35 in err-disable state
    %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/35, changed state to down
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel39, changed state to down
    %LINK-3-UPDOWN: Interface Port-channel39, changed state to down
    Switch B
    C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)
    System image file is "flash:/c3750e-universalk9-mz.122-58.SE2/c3750e-universalk9-mz.122-58.SE2.bin"
    cisco WS-C3750X-48
    Port-channels in the group:
    Port-channel: Po52
    Age of the Port-channel   = 443d:18h:43m:06s
    Logical slot/port   = 10/39          Number of ports = 4
    GC                  = 0x00000000      HotStandBy port = null
    Port state          = Port-channel Ag-Inuse
    Protocol            =    -
    Port security       = Disabled
    Ports in the Port-channel:
    Index   Load   Port     EC state        No of bits
    ------+------+------+------------------+-----------
      0     00     Gi1/0/35 On                 0
      0     00     Gi1/0/36 On                 0
      0     00     Gi1/0/45 On                 0
      0     00     Gi1/0/46 On                 0

    PER CISCO
    Symptom:
    An interface on a Catalyst switch is errordisabled after detecting a loopback.
    Mar 7 03:20:40: %ETHCNTR-3-LOOP_BACK_DETECTED: Loop-back detected on
    GigabitEthernet0/2. The port is forced to linkdown.
    Mar 7 03:20:42: %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state
    to administratively down
    Mar 7 03:20:43: %LINEPROTO-5-UPDOWN: Line protocol on Interface
    GigabitEthernet0/2, changed state to down
    Conditions:
    This might be seen on a Catalyst 2940, 2950, 2950-LRE, 2955, 2970, 3550, 3560
    or 3750 switch running 12.1EA or 12.2SE based code.
    Workaround:
    Disable keepalives by using the no keepalive interface command. This
    will prevent the port from being errdisabled, but it does not resolve the root
    cause of the problem. Please see section below for more information.
    Additional Information:
    The problem occurs because the keepalive packet is looped back to the port that
    sent the keepalive. There is a loop in the network. Although disabling the
    keepalive will prevent the interface from being errdisabled, it will not remove
    the loop.
    The problem is aggravated if there are a large number of Topology Change
    Notifications on the network. When a switch receives a BPDU with the Topology
    Change bit set, the switch will fast age the MAC Address table. When this
    happens, the number of flooded packets increases because the MAC Address table
    is empty.

  • SG300 Cannot enable IPv6 on the interface - the maximum number of interfaces 3 has already been used.

    The Sg300 is currently in L3 mode
    Why is it that only 3 IPv6 interfaces are being allowed?
    No where in the device specifications or in the documentation did I ever see this limitation when I purchased the switch!

    That message it means that you will not be able to create another iCloud account on your device as the maximum number have already been created.  Your only options are to either re-use one of the accounts previously created, or create your new account using on a different iOS device or Mac, if you have one.

  • Port Channel in Nexus

    Hi All,
    I have a scenario where I have two nexus 5596 as upstream and have vPC  in between. downstream is the server hooking to the upstrean both nexus  devices.
    On Both the Nexus switch the port channel is down and the VPC is also  down. The physical interfaces are up and passing traffic to the server.
    My understanding is if the server NIC's are teamed, even the switches should also have the portchannle to work properly.
    But since portchannel and vpc both are down in both the switches
    1. how the switch is passing traffic.
    2. I checked the configs for portchannel formation on phy ports which looks good to me still po is down. Why?
    3. I understand as port channel is down so vPC is down ( correct me if I am wrong).
    I have attached the diagram & below are the logs for ur reference:
    The output on Nexus5596 2 device is same as on Nexus5596 1
    Nexus5596 1#Sh vpc
    Legend:
                    (*) - local vPC is down, forwarding via vPC peer-link
    vPC domain id                   : 106
    Peer status                     : peer adjacency formed ok
    vPC keep-alive status           : peer is alive
    Configuration consistency status: success
    Per-vlan consistency status     : success
    Type-2 consistency status       : success
    vPC role                        : primary
    Number of vPCs configured       : 29
    Peer Gateway                    : Disabled
    Dual-active excluded VLANs      : -
    Graceful Consistency Check      : Enabled
    vPC Peer-link status
    id   Port   Status Active vlans
    1    Po4    up     1-2,713-718,999
    vPC status
    id     Port        Status Consistency Reason                     Active vlans
    9      Po9         up     success     success                    2,713-718
    701    Po701       down*  success     success                    -
    702    Po702       down*  success     success                    -
    Nexus5596 1# sh port-channel su
    Group Port-       Type     Protocol  Member Ports
          Channel
    4     Po4(SU)     Eth      LACP      Eth1/27(P)   Eth1/28(P)
    9     Po9(SU)     Eth      LACP      Eth1/29(P)   Eth1/30(P)   Eth1/31(P)
                                                        Eth1/32(P)
    701   Po701(SD)   Eth      LACP      Eth1/1(I)
    702   Po702(SD)   Eth      LACP      Eth1/2(I)
    Nexus5596 1#sh run int e1/1
    interface Ethernet1/1
      description snrkdc1285_1/0
      switchport mode trunk
      switchport trunk native vlan 713
      switchport trunk allowed vlan 713-718
      spanning-tree port type edge trunk
      no snmp trap link-status
      channel-group 701 mode active
    Nexus5596 1# sh int e1/1 status
    Port          Name               Status    Vlan      Duplex  Speed   Type
    Eth1/1        snrkdc1285_1/0     connected trunk     full    10G     10Gbase-SR
    Thanks,
    Sagar

    Reza - My bad I mistakenly mentioned e1/10 in diagram but it is e1/1 for po701
    Since these are L2 switches SH IP INT BR shows only mgmt Ip
    Please find the requested outputs as below.
    nexus5596 1#sh run int po701
    interface port-channel701
      description snrkdc1285
      switchport mode trunk
      switchport trunk native vlan 713
      switchport trunk allowed vlan 713-718
      spanning-tree port type edge trunk
      speed 10000
      no snmp trap link-status
      vpc 701
    nexus5596 2# sh run int po701
    interface port-channel701
      description snrkdc1285
      switchport mode trunk
      switchport trunk native vlan 713
      switchport trunk allowed vlan 713-718
      spanning-tree port type edge trunk
      speed 10000
      no snmp trap link-status
      vpc 701
    nexus5596 1#sh int br
    Ethernet      VLAN    Type Mode   Status  Reason                   Speed     Port
    Interface                                                                    Ch #
    Eth1/1        713     eth  trunk  up      none                        10G(D) --
    Eth1/2        713     eth  trunk  up      none                        10G(D) --
    Port-channel VLAN    Type Mode   Status  Reason                    Speed   Protocol
    Interface
    Po4          1       eth  trunk  up      none                       a-10G(D)  lacp
    Po9          2       eth  trunk  up      none                       a-10G(D)  lacp
    Po701        713     eth  trunk  down    No operational members       10G(D)  lacp
    Po702        713     eth  trunk  down    No operational members       10G(D)  lacp
    nexus5596 2#sh int br
    Ethernet      VLAN    Type Mode   Status  Reason                   Speed     Port
    Interface                                                                    Ch #
    Eth1/1        713     eth  trunk  up      none                        10G(D) --
    Eth1/2        713     eth  trunk  up      none                        10G(D) --
    Port-channel VLAN    Type Mode   Status  Reason                    Speed   Protocol
    Interface
    Po4          1       eth  trunk  up      none                       a-10G(D)  lacp
    Po9          2       eth  trunk  up      none                       a-10G(D)  lacp
    Po701        713     eth  trunk  down    No operational members       10G(D)  lacp
    Po702        713     eth  trunk  down    No operational members       10G(D)  lacp

  • SAN Port-Channel between Nexus 5000 and Brocade 5100

    I have a Nexus 5000 running in NPV mode connected to a Brocade 5100 FC switch using two FC ports on a native FC module in the Nexus 5000. I would like to configure these two physical links as one logical link using a SAN Port-Channel/ISL-Trunk. An ISL trunking license is already installed on the Brocade 5100. The Nexus 5000 is running NX-OS 4.2(1), the Brocade 5100 Fabric OS 6.20. Does anybody know if this is a supported configuration? If so, how can this be configured on the Nexus 5000 and the Brocade 5100? Thank you in advance for any comments.
    Best regards,
    Florian

    I tried that and I could see the status light on the ports come on but it still showed not connected.
    I configured another switch (a 3560) with the same config and the same layout with the fiber and I got the connection up on it. I just cant seem to get it on the 4506, would it be something with the supervisor? Could it be wanting to use the 10gb port instead of the 1gb ports?

  • Issues with a port-channel between Nexus 5K and 4506

    I'm having some trouble configuring an up-link from a Cisco 4506 to a set of Nexus 5k switches and cannot get either side to recognize the media. My configuration is as follows...
    Nexus 5k
    interface Ethernet1/22
      description ## 1A ##
      switchport mode trunk
      switchport trunk native vlan 150
      speed 1000
    Cisco 4506
    interface GigabitEthernet1/6
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 150
     switchport mode trunk
    I am using 1gb sfp's (GLC-SX-MM) and I have verified that the fiber cables I am using and the fiber between closets is in working condition. But I cannot get the interface to come up. 

    I tried that and I could see the status light on the ports come on but it still showed not connected.
    I configured another switch (a 3560) with the same config and the same layout with the fiber and I got the connection up on it. I just cant seem to get it on the 4506, would it be something with the supervisor? Could it be wanting to use the 10gb port instead of the 1gb ports?

  • SG300 Cannot add IPv6 address on the interface- the maximum number of addresses 3 has already been used.

    First I ran into this brick wall on the number of IPv6 interfaces
    SG300 Cannot enable IPv6 on the interface - the maximum number of interfaces 3 has already been used.
    Also, it appears that there is no IPV6 routing in Layer 3 mode
    SG300 L3 IPv6 routing does NOT work
    And now this, I cant use more than 3 IPv6 addresses

    Good Article 
    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer" Regards Edwin Anthony Joseph

  • SG500x Port-channel limited bandwidth

    Good Day All,
    I have 2 Cisco SG500X-48 setup as Master/Slave using SFP-H10GB-CU1M (10GB Twinax cable).
    First question is with the twinax cables
    Since on the SG500x's you can not configure the 2*10GE Stacking Combo ports. If I put two cables in for redundancy will this cause a network loop, or will STP/RSTP catch this?
    Next question is limited bandwidth.
    I setup 4 Interfaces to Port channel with LACP. On the Server(HP Proliant Gen8 server(s)) end have the NIC Team with 4 NICs. When I run a network stress tool, it seems to cap at around 68MBs. Each port should being 1Gb, shouldn't I be getting closer to 4 GB?
    My Configuration would read much like this:
    VLANs setup:
    ##1-RF System
    ##2-VOIP
    ##3-LAN
    interface Port-channel 3
    spanning-tree portfast
    switchport trunk allowed vlan add ##1,##2
    switchport trunk native vlan ##3
    interface gigabitethernet2/1/5
    spanning-tree portfast
    channel-group 3 mode auto
    switchport mode access
    interface gigabitethernet2/1/6
    spanning-tree portfast
    channel-group 3 mode auto
    switchport mode access
    interface gigabitethernet2/1/7
    spanning-tree portfast
    channel-group 3 mode auto
    switchport mode access
    interface gigabitethernet2/1/8
    spanning-tree portfast
    channel-group 3 mode auto
    switchport mode access
    I dont have much under standing on QOS yet, I assuming this would be based on setting up this?
    Any direction or help would be greatly appreciated
    Chris,

    Hello Chris,
    The way the stacking cables works is it detects when you are using two of them and switches over to what is called 'ring' mode.  It doesn't use both links at once, but if one of those links fails it will immediately use the second one, usually not even dropping one packet.  STP isn't an issue on the stack ports because it doesn't really use it, the stacking is a proprietary protocol that handles all of this for you.  So go ahead and plug up your second set of cables, you should see a log message saying you have moved from 'chain' to 'ring'.
    As for LAGs, this is a common misconception with link aggregation.  I understand the logic, you have 4 gig links, why can't you get 4 gigs of throughput?  It has to do with how LAGs actually work.
    When a packet arrives at the switch and needs to go out the LAG the switch runs a calculation on the source and destination IP (or source and destiantion MAC depending on your settings).  From this calculation it comes up with a number, in your case from 1-4.  That determines the link that it uses to get across that LAG.  There is no way to make one conversation use more than one link, it just isn't how it works.  So when you run a speed test from one IP to one other IP, the result of the switch's calculation will always be the same number, hence all the traffic for that stream goes down the same link in the LAG.
    There isn't any spillover, so even if one link is much busier then the rest it doesn't move them over to one of the other links.
    On some enterprise switches you can use a load balancing algorithm that uses source and destination port, which can result in multiple conversations between the same two clients to use multiple links, but on the Small Business switches we only have IP or MAC.
    Basically any one conversation will always be limited to whatever the speed of 1 link in the LAG is.
    It is possible to utilize the link more, but you would need several different computers talking to the server to really see that.  QoS would not change this.
    As for your speed, it is a bit low, the max for a gigabit link is about 118MB/s (lab max, your mileage may vary) if you are using normal sized frames.  This is assuming two devices directly connected to the with no routing required.  How are you testing the speed?  I like to use a program called Tamosoft throughput tester for this, which is available free on the web.
    Hope that helps a bit,
    Christopher Ebert - Advanced Network Support Engineer
    Cisco Small Business Support Center
    *please rate helpful posts*

  • Sg300-28 port-channel options

    i have an sg300-28 running the latest firmware, and would like some insight on port-channel options.  below are the port configs i have for a LAG to my router.  i am currently using 802.3ad with LACP.  my router is a linux machine pulling duty as a basic (no dynamic routing) router, firewall and internet gateway.  the bonding options on the routers side explained at
    http://docs.fedoraproject.org/en-US/Fedora/16/html/System_Administrators_Guide/sec-Using_Channel_Bonding.html.  the mode is 4 or 802.3ad and the xmit_hash_policy is 2 or layer2+3.  i also have 2 servers setup in a similar fashion with 2 interfaces in a LAG.
    when i run a bandwidth test, iperf, between the two servers, i only get 900+ mbps which indicates that the GB ports are running fine.  this also indicates to me that the traffic is not being "striped" across the port-channeled interfaces, thereby giving me the aggregated bandwidth of all interfaces in the LAG.  i have found no options to use the balance-xor mode to create port-channels, which as i understand it, would aggregate the total bandwidth of all interfaces in the LAG.  is the sg300 capable of creating a LAG that will combine the throughput of all the members of the LAG?  for example, create a 2 GB pipe when 2 interfaces are port-channeled?  is the balance-xor mode what would do this (regardless of the sg300's ability to do this)
    interface gigabitethernet25
    description "Port Channel to Router"                
    channel-group 1 mode auto
    lldp notifications enable
    lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
    lldp management-address automatic
    interface gigabitethernet26
    description "Port Channel to Router"
    channel-group 1 mode auto
    lldp notifications enable
    lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
    lldp management-address automatic
    interface gigabitethernet27
    description "Port Channel to Router"
    channel-group 1 mode auto
    lldp notifications enable
    lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
    lldp management-address automatic
    interface gigabitethernet28
    description "Port Channel to Router"
    channel-group 1 mode auto                           
    lldp notifications enable
    lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
    lldp management-address automatic
    interface Port-channel1
    description "Port Channel to Router"
    switchport mode general
    switchport general allowed vlan add 2-3,25,37,50,52,253-255 tagged
    switchport general pvid 255

    Hi Brendan,
    You said "i only get 900+ mbps which indicates that the GB ports are running fine.  this also indicates to me that the traffic is not being "striped" across the port-channeled interfaces, thereby giving me the aggregated bandwidth of all interfaces in the LAG.  i have found no options to use the balance-xor mode to create port-channels, which as i understand it, would aggregate the total bandwidth of all interfaces in the LAG."
    As the Admin guide says on page 130, http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/78-19308-01.pdf
    Load Balancing
    Traffic forwarded to a LAG is load-balanced across the active member ports, thus achieving an effective bandwidth close to the aggregate bandwidth of all the active member ports of the LAG.
    Traffic load balancing over the active member ports of a LAG is managed by a hash-based distribution function that distributes Unicast and Multicast traffic based on Layer 2 or Layer 3 packet header information.
    The switch supports two modes of load balancing:
    By MAC Addresses—Based on the destination and source MAC addresses of all packets.
    By IP and MAC Addresses—Based on the destination and source IP addresses for IP packets, and destination and source MAC addresses for
    non-IP packets.
       So,  an IP host running running IPERF maybe checking unicast throughput between the two IP hosts.  There will be a Source and Desination IP address in that test.  The switch will direct the traffic over one of the LAG port members .  It wont Round robin the unicast traffic over multiple LAG ports, if the Source and Desination IP address of the traffic is the same.  .
    If the  PC  running IPerf,  had  another concurrent IPerf session to another or different IP host, the hash algorithm on the switch may direct that stream , maybe, over a different physical LAG interface.
    So your comment about  achieving  900+mbps  sounds normal   Yes LAG spreads the load, the benefit comes when lots of hosts on  both sides of the switches.
    You hay find with just two hosts on either side of a LAG, that the switch may run the traffic between two hosts over just one member of the LAG group.
    regards Dave

  • ASA EIGRP Port Channel Bug?

    Hi All
    I have EIGRP configured on an ASA5512-X code version 9.1(4). When I do a "show eigrp interfaces" the Port Channel linking to the adjacent router is not listed. It is not a passive interface (even did a "no passive-interface outside" to double check). Other interfaces are listed. Debugging EIGRP shows no hellos arriving on that interface either, even though a debug on the adjacent router confirms they are being sent. Am I missing something or is this a bug?
    Thanks for looking!
    - James

    Hello,
    It does... Thanks for the explanation
    Now if you are behind the inside interface you should be able to ping it.
    Can you share the show run icmp
    Also do the following on the ASA
    cap capin interface inside match icmp any host 172.17.120.254
    cap asp type asp-drop all circular-buffer
    Then try to ping the ASA inside interface and provide me:
    show cap capin
    show cap asp | include 172.17.120.254
    Regards,
    We are here to help, Remember to rate all the post that help ( If you do not know how to rate a post, just let me know, I will let you know how )
    Julio

  • MDS configuration for port channel

    I've tried to set up the new FC port channel upload to a pair of MDS 9124s, but as I don't know enough about the MDS side I can't get the link to come up. Are there any references available anywhere that tell you blow by blow exactly how to configure the MDS side of the port channel? Or perhaps a sample working config?
    Thanks

    Simon,
    A few items:
    1) You are on 1.4.1i Balboa code
    2) FI's are in FC switch mode as MDS 9124's don't support F-port channel (NPV/NPIV)
    3) It's a lot easier the first time if you have matched speed sfp+ all around. Although, with the correct configs, unmatched speeds can be made to work.
    If the FIs are in switch mode and your MDS is running a minimum 3.3 here are some configs that may help:
    MDS side interfaces 4/11 and 4/12 are plugged into the UCS fc ports. First setup and ensure ISLs are working properly between UCS and MDS, then configure the port-channels
    interface fc4/11
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      no shutdown
    interface fc4/12
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      no shutdown
    The UCS GUI Equipment -> Fabric Interconnects -> FI-A -> Set FC Switching Mode. This will cause both FI's to reboot into FC switch mode. This is VERY DISRUPTIVE, both FI's will reboot.
    On the UCS CLI you should see this on the UCS fc ports connected to the MDS
    cae-sj-ca3-A(nxos)# show running-config interface fc 2/1-2
    !Command: show running-config interface fc2/1-2
    !Time: Wed Oct 20 16:49:39 2010
    version 4.2(1)N1(1.4)
    interface fc2/1
      switchport mode E
      no shutdown
    interface fc2/2
      switchport mode E
      no shutdown
    Until you have VSAN trunks enabled, make sure the ports on the UCS and MDS are in the same VSAN. VSAN 1 for example.
    Once you have working ISLs, then proceed to turn them into port-channels and enable VSAN trunking. Start with the MDS
    Create a channel group, it should look like this
    cae-sj-9506-1# show run interface port-channel 3
    !Command: show running-config interface port-channel 3
    !Time: Wed Oct 20 17:06:01 2010
    version 5.0(1a)
    interface port-channel 3
      channel mode active
      switchport mode E
      switchport rate-mode dedicated
      switchport trunk mode auto  <-- VSAN trunking
    Enable VSAN trunking on the MDS ISL interfaces, it'll look like this:
    cae-sj-9506-1# show run interface fc 4/11-12
    !Command: show running-config interface fc4/11-12
    !Time: Wed Oct 20 17:07:05 2010
    version 5.0(1a)
    interface fc4/11
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      no shutdown
    interface fc4/12
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      no shutdown
    Add the channel group information to the MDS ISL interfaces:
    Enter configuration commands, one per line.  End with CNTL/Z.
    cae-sj-9506-1(config)# interface fc 4/11-12
    cae-sj-9506-1(config-if)# channel-group 3 force
    fc4/11 fc4/12 added to port-channel 3 and disabled
    please do the same operation on the switch at the other end of the port-channel,
    then do "no shutdown" at both ends to bring it up
    cae-sj-9506-1(config-if)# show run interface fc 4/11-12
    !Command: show running-config interface fc4/11-12
    !Time: Wed Oct 20 17:07:39 2010
    version 5.0(1a)
    interface fc4/11
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      channel-group 3 force
      no shutdown
    interface fc4/12
      switchport rate-mode dedicated
      switchport mode E
      switchport trunk mode auto
      channel-group 3 force
      no shutdown
    Create the SAN port channel on the UCS side
    SAN -> SAN Cloud -> Fabric A -> FC Port Channels -> Create Port Channel
    After you create the SAN port channel in UCS, make sure and enable it. I also bounce the MDS port channel at this point.
    If all is correct, in a few agonizing minutes, the port-channel will be formed and passing data.
    cae-sj-ca3-A(nxos)# show interface san-port-channel 1
    san-port-channel 1 is trunking
        Hardware is Fibre Channel
        Port WWN is 24:01:00:0d:ec:d3:5d:c0
        Admin port mode is E, trunk mode is on
        snmp link state traps are enabled
        Port mode is TE
        Port vsan is 1
        Speed is 8 Gbps
        Trunk vsans (admin allowed and active) (1,10,26,50,66,100-101,103,123,222,24
    0)
        Trunk vsans (up)                       (1,10,50,100,103)
        Trunk vsans (isolated)                 (26,66,101,123,222,240)
        Trunk vsans (initializing)             ()
        5 minute input rate 2312 bits/sec, 289 bytes/sec, 2 frames/sec
        5 minute output rate 1440 bits/sec, 180 bytes/sec, 2 frames/sec
          2669 frames input, 194760 bytes
            0 discards, 0 errors
            0 CRC,  0 unknown class
            0 too long, 0 too short
          2677 frames output, 158316 bytes
            0 discards, 0 errors
          0 input OLS, 1 LRR, 0 NOS, 0 loop inits
    Again, make sure you have the ISLs up an running first before configuring the port-channels. It makes troubleshooting much easier.
    Let me know if you need any help.

Maybe you are looking for

  • ITunes Requires Safari 4.0.3 to Access Store: Help??

    I have had a recent problem with the iTunes store after updating to iTunes 9.1 and Safari 4.0.5 (from 3.2.something). Though I am sure I updated Safari, I get a recurrent message that I need to update Safari to at least 4.0.3, but I already have done

  • Sales Invoice Problem

    Dear All, We have create the two type of Sales Document 1) Regular Production Invoice 2) Job Work Invoice In this case there is no problem for Regular Invoice, but Job Work Invoice does create the excise document number because job work type of invoi

  • Podcasts under Music?

    I want to keep my podcasts seperate from Music. In iTunes it displays under podcasts but when I transfer to ipod the podcasts are under music so when I want to listen to music sometimes it gets mixed with podcasts. How can I keep them seperate? Under

  • Customer material Information Record

    Dear All, Can any one tell me the table name of Customer material Information Record? Regards, Jay

  • Cannot change location with my iPod Touch - always Brussels!

    I live in Belgium and set my iPod Touch for Brussels time zone. Great, but yesterday I arrived in JAPAN and even though I try to set the general "Date and Time" for Tokyo, the clocks all show the time for Bruxelles-- that is when I look at internatio