Multiple Group By within one single template

Hello,
In Crystal Reports 2008 Design, I have a template, this template uses a sp, which returns 10 columns as the Database Fields. Could anyone tell me if I can do the following with this template and how?
If the parameter ?company = ABC, then count column1 and group by column2, column3 and column4, and display the data points column2, column3 and column4 in the report for company ABC
If the parameter ?company = BCD, then count column1 and group by column5, column6 and column7, and display the data points column5, column6 and column7 in the report for company BCD
If the parameter ?company = CDE, then count column1 and group by column8, column9 and column10, and display the data points column8, column9 and column10 in the report for company CDE
Thanks!

Try creating 3 formulas like this
@Group1:
whilereadingrecords;
if {?company} = "ABC" then
{column2}
else if {?company}="BCD" then
{column5}
else if {?company}="CDE" then
{column8}
else
"Others"
@Group2:
whilereadingrecords;
if {?company} = "ABC" then
{column3}
else if {?company}="BCD" then
{column6}
else if {?company}="CDE" then
{column9}
else
"Others"
@Group3:
whilereadingrecords;
if {?company} = "ABC" then
{column4}
else if {?company}="BCD" then
{column7}
else if {?company}="CDE" then
{column10}
else
"Others"
Now insert group on @Group1 and then insert one more on @Group2 and then @Group3
You can also place the formulas as columns like
@Group1   @Group2  @Group3
Regards,
Raghavendra

Similar Messages

  • Multiple SOA clusters within a Single Domain

    Hi All,
    We're looking at a scenario where there would be multiple SOA clusters within a single domain. Would that be possible to do? I mean I can create multiple SOA clusters but it seems that applications deployed to one of the 2 SOA clusters seem to go into an inconsistent state. Please advise. Thank you.

    This is just because all SOA servers in a domain will refer to one(same) SOAINFRA schema for SOA deployments info and hence belong to same logical group (cluster) and that's the reason why you cann't even have two separate SOA managed servers without a cluster.
    Regards,
    Anuj

  • In Pages (5.5.1) can I create multiple Paragraph Styles within one paragraph?

    In Pages (5.5.1) can I create multiple Paragraph Styles within one paragraph. 
    I need to make a table of contents for my Mater's Thesis and want to use the automatic table of contents feature.  I want the first sentence of a paragraph to have a different paragraph setting than the rest of the paragraph.  Is this possible?
    Thanks!

    Nice of you to be doing this for your Mother's Thesis.
    There are several issues here:
    1. A Paragraph Style is what it says, the style for the paragraph
    2. You can format text within a paragraph by applying a Character Style
    3. Pages 5.5.1 lets you apply formatting to overall text for the T.O.C. but not parts of it and you can not retain that formatting as a Paragraph style
    So in answer to your question, no.
    You will need to create the T.O.C. manually and unfortunately as Pages 5.5.1 can't create bookmarks (just one of over 100 missing features) you will be unable to link the T.O.C. to the referred pages in the list.
    Peter
    Apple's marketing slogan:
    Pages 5.5.1 - Can't Do That!

  • How do I bind multiple PDF Documents into one single document?

    I am trying to bind multiple PDF documents into one single document can anyone please help me?

    You would need Adobe Acrobat to do that. Reader doesn't have the ability.

  • How to combine multiple Unmanaged Solution to one single Managed solution

    Hi,
    How to combine multiple Unmanaged Solution to one single Managed solution.?
    There were some other third party developer have kept things lik ein UAT there are 2 release solution and both are Managed Solution.
    And in Production the changes are only deployed for release 1 and for the release 2 changes deployment needs to be done.
    But when i import that second release Managed Solution from UAT to Production then i got number of elements missing but i have checked they are already there in Soolution.
    I did some R&D on this but not much helpful.
    I thought i require to convert Unmanaged Solution of Production environment to Managed first for first release and then needs to import Managed solution of UAT to Production for second release.
    Is this the right way to overcome form this situation?
    Any help and response would be really appreciated.
    Thanks.
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Hi, 
    You can prepare unmanaged solution by adding all the components from the default solution,which are there in the managed solution, If Customizatiable entity is true in  the managed solution.

  • Concatenate multiple pdf files into one single postscript file

    Hi,
    Could anyone help me with a code to "Concatenate Multiple pdf files into one single postscript file" ?
    Thanks for the help

    Thanks for your reply! Actually the main purpose is to allow user to select multiple pdf documents on a single web page and then he should be able to print all of them at once by hitting the print button on the web page instead of selecting each document seperately to print it. Also he should be able to see all the printing services available to print those documents.
    Thanks,

  • Burn multiple video files to one single DVD

    I am converting a ton of old home videos to digital format, and I want to store them on DVDs.  I'm using Elgato Video Capture to connect my VCR to my Mac which works fine for creating mp4s.  I can then "right-click" on the mp4 file name in Finder and one of the options is "Burn [filename] to Disc".  This is fine.  But my problem is that many of these videos are fairly short clips and I don't want to use one single DVD for each one. 
    Does anyone know any way that I can burn multiple mp4 files onto one single DVD?  Whenever I go to burn one of them to Disc, it seems to want a blank disc each time. 
    I suspect there is software out there that I could purchase, but I was hoping not to spend much money on this project.  Any way of doing this in the standard Mac software?  Or maybe a not too expensive DVD burner software I could buy which would allow this?
    Thanks!

    Click here and follow the instructions.
    (92775)

  • Multiple Idocs (DEBMAS06) into one single file

    Hi All,
    Multiple Idocs(DEBMAS06) are sent from SAP in bulk to be sent to FTP server via XI...(Cannot use Append the file as The structure is with Header,Detail(all the idoc details) and Trailer)
    I have seen different threads which speaks about the same,
    But Please suggest me the best approach to proceed with this kind of scenario...
    Multiple IDocs -> XI -> Flat file which is speaking about BPM and also Packaging(SAP note 814393)
    and https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/30ea2fdf-f047-2a10-d3a2-955a634bde6b
    (How Tou2026 Send Multiple IDocs Within One XI Message)
    I prefer not to use BPM... but if required then....
    Please suggest me which is the best approach to proceed with it..
    Thanks and Regards,
    Sridhar Reddy

    Hi ,
    I had tried the scenario Multiple IDOC's coming from R/3 and send all of them into a Single File
    But it did not work...
    Of course i changed as Micahel mentioned in
    The specified item was not found.
    (Collect and make pack size to 50) but still the idocs are posting as 50 messages in XI and 50 files are being created ...
    But as per his remarks we need customization which is very difficult...
    And also i checked Michaels blog
    The specified item was not found.
    But this is dicussing reverse of my scenario...
    and finally i am thinking of going with the stefens weblog...
    Collecting IDocs without using BPM
    Can any one please suggest any other best way to handle this...
    Instead of going for BPM i am implementing as Stefen suggested ... This is because we have many such interfaces where SAP sends collective idocs....
    Regards,
    Sridhar Reddy
    Edited by: sridhar reddy kondam on Oct 22, 2008 6:20 AM

  • Concatenate multiple pdf files into one single file

    hi,
    Could any one help me with a code "combining or merging multiple pdf files selected from the browser into one single document" to send it as one single request to the printer?
    Thanks ,

    It is called the Big Faceless PDF library.
    they have a free trial download.
    in regards to doing it yourself, of course.
    but this is a pure java library that can do what you want without you having to re-invent the wheel (for a price of course).
    they have excellent technical support as well, usually solving your problem within a day or so.

  • Multiple payment advises in one single pymnt document

    Hi gurus,
    we are having payment advises getting generated through IDOCs, there will be many payment advises for one single customer, so we thought of including multiple payment advises while choosing open item, but system is allowing only one payment advise.
    can we go for multiple payment advises
    or
    we tried to modify the g/l fast entry screen, but in that we did not find the payment advise field.
    Thanks in advance.

    hello Babu,
                     now i got the same problem like you.......... you find the solution for  tht.....
    if you know the solution plz help me
    bye laxmi

  • Playing multiple stereo channels out one single mono channel tia sal22

    Greetings All
    I have a vi which creates multiple stereo audio signals
    in labview 8.6.1 and I would like to play all of the stereo channels out one single Mono channel
    is this possible?  I tried setting all the device ID's to the same thing but a lot of clicks and pops occurred.  Basically I'm trying to play and mix all the signals out one mono channel at the same time.
    Please note I would like to have each signal that is created played over
    the mono channel at the same time.
    tia sal22
    Solved!
    Go to Solution.
    Attachments:
    lvt_audio_realtime-out left right device ID test onw while loop.vi ‏69 KB
    stereo_to_mono.png ‏63 KB

    sal22 wrote:
    Thanks but which options allows me to do this
    tia sal22
     Just add the arrays if they have the same length. Use the standard add function (like in 2+2=4). Then arrays are added each index is added together
    Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
    (Sorry no Labview "brag list" so far)

  • Can I have multiple different vlans in one Single Mode Transparent Firewall

    Hi,
    I am about configuring Data Center FW (ver 9.2) to protect multi tier Servers Farm; Web, Applications & Data Base. There is a requirement to set the FW in Transparent Mode, while the license is the base 2-contexts, only.
    I wonder if One Single Transparent Context, with different bridge-groups, one for each vlan is a workable solution. I have pasted the configuration of the FW, it may help in understanding the setup.
    ======
    firewall transparent
    names
    interface TenGigabitEthernet0/8
     description To Nx7K-1 Port-8
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet0/9
     description Nx7K-1 Port-9
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet1/8
     description Nx7K-2 Port-8
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet1/9
     description Nx7K-2 Port-9
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface BVI1
     desc Services Zone
     ip address x.x.41.250 255.255.255.0
    interface BVI2
     description WEB-APPS Zone
     ip address x.x.42.250 255.255.255.0
    interface BVI3
     desc Oracle management
    ip address x.x.43.250 255.255.255.0
    interface BVI4
     descr Oracle DB
     ip address x.x.44.250 255.255.255.0
    interface Port-channel9
     description ECLB Trunk to NX7Ks
     duplex full
     port-channel load-balance src-dst-ip-port
     no nameif
     no security-level
    switchport mode trunk
    switchport trunk allowed vlan 41-44,141-144
    interface Port-channel9.41
     vlan 41
     nameif Services-Outside
     bridge-group 1
     security-level 0
    interface Port-channel9.141
     description Services-Inside
     vlan 141
     nameif Services-Inside
     bridge-group 1
     security-level 100
    interface Port-channel9.42
    description WEB_APPS-Outside
     vlan 42
    nameif WEB_APPS-Outside
     bridge-group 2
     security-level 0
    interface Port-channel9.142
     description WEB_APPS-Inside
     vlan 142
     nameif WEB_APPS-Inside
     bridge-group 2
     security-level 100
    interface Port-channel9.43
    desc Oracle management
     vlan 43
     nameif Oracle_Mgmt-Outside
     bridge-group 3
     security-level 0
    interface Port-channel9.143
     description Oracle management Inside
     vlan 143
     nameif Oracle_Mgmt_Inside
     bridge-group 3
     security-level 100
    interface Port-channel9.44
    desc Oracle DB
     vlan 44
     nameif Oracle_DB_Outside
     bridge-group 3
     security-level 0
    interface Port-channel9.144
     description Oracle DB Inside
     vlan 144
     nameif Oracle_DB_Inside
     bridge-group 4
     security-level 100

    it is possible but it is not scaleable.  If I remember correctly you can only have a maximum of 8 BVI interfaces...so this means you can only have 8 subnets going across the ASA.  You would also need seperate VLANs for the inside interface and the outside interface since you can not configure two interfaces to be in the same VLAN, and then assign these interfaces to the appropriate BVI group.
    Please remember to select a correct answer and rate helpful posts

  • Multiple po's into one single inbound delivery

    Hi Experts,
    How to create the Multiple purchase order line items (Ex; In one po i am selecting only 2 line items and one more po i am select 3 line items)  into one single inbound delivery for this where is the settings .
    please guide me any one.
    Thanks,
    KK

    Deshpande i have the same problem.
    I tired giving all the PO for a collective inbound delivery in VL34, but it still creates one delivey for every PO item
    Anand: did u manage to solve ur issue
    Regards
    Sumanth

  • Help!!! I can't save multiple PDF documents into one single PDF!  Need answers!

    Hello!
    I'm trying to save a very large PDF file.  I'm using Adobe Acrobat X Pro.  There are about 200 plus pages and I'm trying to save merged PDF files as one single PDF document.  I've compressed the PDF's as much as I could prior to saving.  For some reason, the process of saving it as a single file takes a long time and usually doesn't work.  Will a higher version of Adobe be faster?  I was told that Adobe X is a 32 bit program and that could be why it's running slow.  I'm unfamiliar with how it all works so I'm hoping someone could offer a simple explanation as to why this is happening and a solution on how to make something as simple as saving a document, go faster.
    Thank you!
    c

    Best to keep the replies in the other post, but I wanted to comment on something you said "I was told that Adobe X is a 32 bit program and that could be why it's running slow." Yes, it's a 32 bit program. No, it's complete nonsense to say that 32 bit programs run slow. There seems to be a general belief that 64 bit is better because, well, because, um, because it's a bigger number so it must be, right? Sorry, I'm not mocking you, but there is such nonsense about this, that I think software makers are having to put a lot of effort into making 64 bit software for no good reason at all.

  • Multiple ZR2740w failures within one and half year

    Hello,
    i would like to ask you if it is "normal" for me to have this series of issues with my ZR2740w's (by normal i mean if this is typical problem for this model; i know it is not normal to have that many RMA) :
    1) first ZR2740w (let's call it A, bought in December 2011) died completely one month after purchase, panel got replaced via the onsite warranty by a new panel (let's call it B; RMA at end of January 2012).
    2) i bought a second ZR2740w (let's call it C) a half year later.
    3) C died one month ago after a year (end of April 2013), got replaced by probably a new or refurbished panel (call this one D) :
    http://www.youtube.com/watch?v=-NnHiEn42cM
    4) D died today, same (or very similar) issue as C; i expect a replacement panel around Friday or next Monday :
    http://www.youtube.com/watch?v=bU1wf7QsvWQ
    I wonder if it is something at my side, but i can't imagine what, everything else works fine. Socket voltage is withing tolerance (voltage here in Slovakia should be 230V, my socket has 236V which is within the +/-5% tolerance), the issue happens using any of connections (DVI/DP), from any source (tried 2 different computers with 3 different graphic cards - 2x Intel in various computers, 1xNVIDIA), using different power cables. C died when used on Eaton UPS, D died when connected directly to the socket.
    While i still have year and half left from the warranty of the older display and nearly 2 years of the newer one, i dislike this happening all the time, as it means i am usually one week without one of my displays, plus i can expect both displays dying within one year after the warranty expires, which is unacceptable for ~600€ display (that is around a half of my monthly salary).
    PS: And i don't even mentoin the "running pixels" issue of B on certain backgrounds (gray, blue and similar darker colors) - the pixels are moving from top to bottom, from half to about 3/4 of the display width; this one can be seen mostly when i am closer than 40cm from the display, further away it is nearly invisible (it's hard to catch it on camera, i hope you can see it at the first half of the video) :
    http://www.youtube.com/watch?v=zhiPDpSsa3g
    PS2: And i am not sure i will be even able to ask for refund once the replacement for D dies again, as it would be the 3rd failure within warranty, but technically the whole panel gets replaced, so not sure if that law applies in this case... Plus it was replaced by an authorized HP service, not by the seller.

    Just got a call from service centre, they will replace this display again, and if i get a 3rd failure within the warranty period they will refund me through the seller i bought the display from. Still can't understand why it happens, the only common thing between the failures of C and D is the power socket i get the power from (no issues with other devices connected to the same power line - LCD TV, AVR, two PC's, another ZR2740w, 23xi, Mac Mini), which i cannot change and not even the other ZR2740w has problems with.

Maybe you are looking for

  • Specify Output Filename in Frame Document

    WebWorks provided a clever way to specify the name of the HTML output file within the source FrameMaker file; it involved using a 'filename' marker type and specifying the name of the file. Does RoboHelp offer an analogous approach?

  • Report of Opening, Isuue, Receipt & closing stock

    Dear Expert, There is any report in which Opening, Isuue, Receipt & closing stock can be download with Qty & Value. I had try MB5B, in which information has been download in vertical format, but we need in horizantical format same data...so there is

  • [Solved] How to test Boinc if it is 64 bit?

    I have archlinux 2.6.18 and have installed boinc via: pacman -S boinc. Boinc seems to run just fine, but the boinc project does not. On the project forum they have suggested that I use 32 bit version of boinc instead of 64. On Archlinux, is there a w

  • Role assignment user-exit

    Hi All, I am in search of a user exit or badi which gets called once role has been assigned to the user. We are into a process so that whenever few critical role/roles are assigned to the user, a email should be sent to the responsible person. I am l

  • Cancel auto embed

    my illustrator started automaticlly embeding files. i can't find where to cancel it! it is increasing the file size by milion & it's pretty much nightmare working like that. PLS help!! nete that i recently registered my software- can it be related to