Multiple routing tables and/or policy routing

Hey all,
I'm trying to configure a Mac Mini (10.8) for multiple routing tables and policy routing.  This server runs Ostinato, a freeware traffic generator.  My purpose is to generate traffic on multiple VLANs towards different gateways and different destinations.  To that end, I have VLAN tagged the (only) Ethernet port and configured 5 VLANs on it.  The first one has the default route (I manage this Mac over this VLAN).  The other four have IP addresses in the test range I'm using. 
The goal is to have traffic sourced from IP-address-X go out vlanX towards gateway-X.  It's counterpart on the far end runs Linux and I have configured it in this way:
ip route add default via <gateway-X> dev ethX table X
ip rule add from <network-X> table X priority X
Researching on OpenBSD forums (since it's the base of MacOS X), provided this:
route -T X add 0.0.0.0/0 -iface <gateway-X>
echo pass in from <network-X> to 0.0.0.0/0 rtable X | pfctl -mf -
However, the Mountain Lion "route" command does not support the -T option, so that killed that idea.  Another forum suggested that this would have worked on 10.4:
ipfw add X fwd <gateway-X> ip from <IP-address-X> to any
I tried this on 10.8 though the man page says it's deprecated, and (surprise, surprise) it did not work. 
Any ideas to get this working appreciated!
Thanks,
Aaron

Still doesn't have it in 10.9.4.
irene:~ cschwartz$ sudo bash
bash-3.2# route -T add
route: illegal option -- T
usage: route [-dnqtv] command [[modifiers] args]
I'm guessing you want policy-based routing due to VLANs...? If you can get a USB-to-Ethernet adapter, then maybe you can work around this by using multiple physical links instead of VLAN tagging. But if you need source-based routing etc. then no.

Similar Messages

  • How Clean ip Route Table and configuration

    How Clean ip Route Table and configuration?
    Cisco have any best practice?

    Hey Juan,
    your question is not very clear but i believe you want to know how to clean ip route table and configuration. So:
    1. Cleaning IP routing table - clear ip route * - This will refersh the routing table.
    2. Cleaning configuration - It depends on the device however in most of Cisco devices you may clear the startup configurtion and its done :)
    HTH.
    regards,
    RS.

  • Join multiple fact tables and dimensions and use all tables in report issue

    Hi,
    I have a report requirements and need to use multiple fact tables and unconformed dimensions as described below
    Fact table: F1,F2,F3
    Dimensions tables: D1.....D9
    F1:(joined to) D1,D2,D3,D4
    F2::(joined to)D1,D2,D5,D6
    F3::(joined to)D1,D2,D7,D8
    D7::(joined to)D9,D8 (dimension D7 joined to two other dimensions D9 and D8
    I'm trying to use columns from almost all the fact and dimension tables but getting "Unable to navigate requested expression. Please fix the metadata consistency warnings."
    Repository is consistent and no errors and warnings.
    How can I configure the repository to develop reports using all fact tables and dimensions?
    Appreciate for your help.
    Thanks
    Jay.
    Edited by: Jay on Feb 9, 2012 4:14 PM

    So you want me to convert snowflake schema to star. does it solve my problem? individual star queries are working find but when I query multiple stars together getting inconsistency errors. I removed content tables dim level totals for unconformed dimensions in logical fact LTS and set level for measures at total level for unconformed dimensions. it is still in progress and need to test.
    Thanks
    Jay.

  • Merging Multiple fact tables and creating a BIA target

    Hi Folks
    We are  using Dataservices with BIA.
    We want to merge mutliple fact table and create a sinvglc cube on BIA.
    when we tried to do that we get a error message that we cannot merge multiple fact tables.
    any pointers ?
    Poonam

    You could have the cubes individually on the BIA and then have a multiprovider which you can use..?
    or create separate universes on the cubes and then merge the universes in BO and then you could hit the BIA for the same..?

  • Numbers' Functions and Formulas in Multiple Cells, Tables, and Sheets

    Hello,
    I'm stuck with specifics that center around usage, and I get the funny feeling I'm overlooking a simple detail or two.
    If I may, here goes.
    I'm working with a single spreadsheet that has several sheets within it, and each sheet has an identical table. Each table is used to record various data, and I use an additional table in a separate sheet to consolidate some of the information, so that I can track results, at a glimpse, by looking at averages, totals, etc.
    Each data table is organized for consolidation by tracking wins, ties, or losses. It is important to know that each data table only records a single win, tie, or loss along with its other applicable data. And on the actual consolidation table I am trying to tally specific data fields by the use of Numbers' functions and formulas, yet I wish to keep these tallied results organized by the determining factor of whether or not they were gathered from a table that recorded a win, a table that recorded a tie, or a table with a loss.
    To illustrate, each table contains data fields that record start time, finish time, elapsed time, the day of the week, etc. Let's say I have eight tables, and the first two are winning tables, three more are tables that record a tie, and the last three are losing tables. For example, on my consolidated data table I wish to enter a function and formula capturing which of the eight tables are wins, ties, and losses so that I can, at a glance, see how much time elapsed to obtain the wins, ties, and losses. So then, in this example, for wins I want to determine which of those wins took 20 minutes, or which of them took 15 minutes, etc. So then, out of the two wins, let's say both of them took 20 minutes each. I need the numeral 2 to be counted and recorded on the consolidation table since only two tables match the criteria. And I would do the same for all remaining data fields (e.g., start time, finish time, etc.). Just so long as everything is determined by wins, ties, and losses, and then organized by the respective data fields. Simply put, this example determines a total of two wins that meet the data field requirement of 20 minutes. Out of the eight tables (one table per sheet) any other wins would then be organized according to the specific data in the elapsed time data field on it's data table (e.g., 5 minutes, 15 minutes, etc.).
    The exact syntax structure of the functions and formula I'm unsuccessfully using follows below. It only seems to return a result of 1, and I think it is returning this value from the IF Statements. By the way, the Win, Tie, or Loss cell in each data table is cell formatted as a pop-up so I can either select None or 1. But in this example I'm basing this on the time period of 20 minutes, and out of the eight data tables I have two wins which also record the time period as 20 minutes, so I should see 2 and not 1 in the 20 minutes column of the consolidated data table. Also, I tried changing the syntax where I would type "=1" in the IF Statements, but it returned a result of =1, and if I don't include the equals sign and quotation marks the result just shows up as 1.
    My Syntax:
    IF(Trade 1::'Data Recorded (1)' '* Win', 1, IF(Trade 2::'Data Recorded (1)' '* Win',1, IF(Trade 3::'Data Recorded (1)' '* Win',1, IF(Trade 4::'Data Recorded (1)' '* Win',1, IF(Trade 5::'Data Recorded (1)' '* Win',1, IF(Trade 6::'Data Recorded (1)' '* Win',1, IF(Trade 7::'Data Recorded (1)' '* Win',1, IF(Trade 8::'Data Recorded (1)' '* Win',1, IF(COUNTIFS(Trade 1::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 2::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 3::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 4::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 5::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 6::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 7::'Data Recorded (1)' '* Time in Trade (in minutes)', "=20m")+COUNTIFS(Trade 8::'Data Recorded (1)' '* Time in Trade (in minutes)'))))))))))
    Please bear in mind that the COUNTIFS portion of the above syntax structure is something I'm already successfully using to count the totals of other things not mentioned above, and I'm hesitant to delete it since it already works to my satisfaction when I want to, for example, determine the total number of overall wins. So, just for illustration purposes, I might have an overall wins column in my consolidation table that records how many wins there are, regardless of organization by elapsed time, or any other data field. In other words, the COUNTIFS syntax structure already works to my satisfaction. I'm not sure if it's possible to alter it so that it isn't so long, but what's there does work just when counting total numbers, as just mentioned.
    In summary, I'm wondering which function I can use with the COUNTIFS function to determine which of my eight data tables are winning tables, but break those wins down further based on criteria like elapsed time, and in the above example the time elapsed is 20 minutes. As you may see above, I'm unsuccessfully using the IF function. Finally, I've looked at the function browser descriptions of things like LOOKUP, HLOOKUP, VLOOKUP, INTERSECT.RANGES, and a few others. And so far I haven't made good use of any of them the way I've done when I use the COUNTIFS function by itself when only counting overall totals. But now I must determine totals that meet certain criteria, as explained above.
    Please help if you dare (smile). This is a huge project I'm undertaking, and so as not to cause confusion I have not included all of the details. But rather, I've taken a small sampling and set it to the side for experimentation. If this small sample works out to my satisfaction I can simply copy and paste the syntax in all other respective cells in the consolidation table, changing only reference locations, and perhaps conditions or values. One thing is certain, I don't intend on giving up on it.
    Thank you for your time and advice.
    Blessings!
    Message was edited by: solo68
    Added image.

    I'd like to edit the last paragraph of my second posting, but for some reason an entirely new posting is being created when I attempt to do this. So when reading this post, please use it to replace only the last paragraph of my second post containing the four inserted images.
    Last paragraph begins:
    In closing, I need each cell in each column of each row in my consolidation table to remain as is. I have my reasons for doing this, and they all serve a specific purpose. The only exception would be the formatting of the last three rows as footer rows. Most importantly, and I should have made this abundantly clear earlier, my apologies, I need a single function and formula in cell E7 of my consolidation table that will firstly determine which data tables are winning tables while secondly and simultaneously counting which of those winning tables have elapsed times of 20 minutes. Perhaps, now this better explains why my syntax is written the way it is written. In the example I provided, if the proper function and formula were written it would result as 2 in cell E7 in my consolidation table. If there is anything else specific you need of me in order to assist me, please request it. Thank you.
    Last paragraph ends:
    Additionally, to t quinn:
    First off, thank you for returning to assist me. I really do appreciate your efforts. Please be aware that I'm avoiding going into details about each and every portion of my spreadsheet because I wish to avoid discussion that is off topic. As I stated earlier, I'm new to using these features of Numbers. My spreadsheet encompasses a much larger amount of data than I'm referring to in the example in my first post. But in my example I'm isolating just the information concerning what I'm now trying to accomplish to finish my spreadsheet project. Moreover, most of what I've done up to this point I was able to figure out on my own, or get help from watching videos on YouTube, or simply using the application help menu. Please be aware that I consulted all of these, repeatedly. I even contacted AppleCare, and was told this sort of support is not available. In spite of this, I've accomplished a great deal in my first large spreadsheet project. Please be aware that when I wrote my second post and specifically responded to you, I didn't want to be rude or ungrateful, and I still don't, but maybe the suggestions you and Hiroto made about gathering the count of wins, ties, and losses are something I've already done. I think I've done that separately. These counts are already in separate cells, and they are working fine. In my first post where I inserted only one image you can see examples of this in my consolidation table image, in cells B3 and E6. I apologize for not making this abundantly clear earlier. Furthermore, the portion of my syntax that shows the COUNTIFS is the exact way I accomplished this, and it is written the way it is written because I need separate sheets, each with their own data tables. Again, in cell E7 I need to determine which of the eight data tables that record wins are also recording 20 minutes, but I need this in a single function and formula with the result appearing only in cell E7. Once this is figured out I will adjust the syntax to do the same thing with every column (these are not shown but they exist) in my consolidation table for the last three footer rows, named Win Column Totals, Tie Column Totals, and Loss Column Totals. The last three rows being footer rows may not be necessary, and if so, I can convert them back to normal rows. Nonetheless, my consolidation table is counting the totals of all data in all data tables. This much I've already accomplished. Now I have one last function and formula I'm working on in order to determine which of the eight data tables record wins, ties, or losses while it simultaneously counts which of the wins, ties, or losses fall within certain categories like elapsed time, and this will be shown on my consolidation table only in the last three rows. Yes, I've gotten the total wins counted, and separately counted the total number of times 20 minutes was the elapsed time used, but so far, just looking at my consolidation table I don't know if the total number of times 20 minutes was used was with a win, tie, or loss. That's what I need to know now. Everything else is already accomplished. So then my consolidation table will show the totals for all data fields in my eight data tables as illustrated in cells B3 and E6. The last three rows of my consolidation table will break this down in a single function and formula with one row for wins, a second for ties, and a third for losses. And each of these respective last three rows will in the same function and formula determine if the win, tie, or loss also is one of the data fields in my eight data tables. How? By the use of columns in my consolidation table. Remember, each of my eight data tables are identical. In the example in my first post I only used one data field, elapsed time (Time in Trade), to illustrate in one column on my consolidation table what I'm trying to accomplish with all of the columns not shown in my consolidation table. Once this is figured out I can adjust it to complete the remainder of the consolidation table. Thank you, t quinn.
    To all reading this and attempting to offer assistance, if for any reason I'm still not explaining myself clearly, please continue to ask me more specific questions. I realize it's hard to communicate this way, and if Apple allowed us to upload the actual spreadsheet it would make this entire forum a better place to communicate. But that's going off topic, so let's simply focus on the matter at hand. Thank you.
    Blessings!

  • Multiple fact tables and dimensions

    I have two fact tables actual sales and planned sales and 8 dimension tables, using a star schema. I want to query on the two fact tables with two dimensions, product and time. When I create the report in discoverer i bring in the sales from actuals and then the product_desc and month_desc. Then I bring in the measure from the second fact table and a join window pops up asking which join to use. If I choose the join to the time dimension then I get no data for the second fact table and correct data for the first fact table. If I choose the product dimension then I get correct data for the first fact table and grossly incorrect data for the second fact table.
    How can I stop this from happening?
    Nick

    Nick,
    I hope you solved your reporting issue and can share the solution with me. I am encountering the same problem. I have used Oracle Warehouse Builder 10Gr2 to design and deploy a pretty simple ROLAP data mart. We are using Discoverer Plus for OLAP as our reporting tool. We have 5 dimension tables using a star schema and have 3 fact tables, when I create the worksheet I bring in our sales measure from our sales item table and then Store_Name from my Stores Dimension and then week-ending from my time dimension, everything looks good at the stage. Then I bring in a measure from our advertising cost table and a join window pops up asking which join to use, if I choose either the Store or the Time dimension I get correct data for the first fact table (sales) and grossly incorrect data for the ad cost from the second fact table (advertsing costs)...... any help would be appreciated
    monalisa

  • How to combine multiple fact tables and dimensions in one worksheet?

    Hello Forum,
    I am encountering a reporting problem when trying to create a worksheet that uses more than one cube/fact table and common dimensions. I have used Oracle Warehouse Builder 10Gr2 to design and deploy a pretty simple ROLAP data mart. We are using Discoverer Plus for OLAP as our reporting tool. We have 5 dimension tables using a star schema and 3 fact tables, when I create the worksheet I bring in our sales measure from our sales item table and then Store_Name from my Stores Dimension and then day from my time dimension, everything looks good at the stage, we're just trying to get a sum of all sales for that store on that day. Then I bring in a measure from our advertising cost table and a join window pops up asking which join to use, if I choose either the Store or the Time dimension I get correct data for the first fact table (sales) and grossly incorrect data for the ad cost measure from the second fact table (advertsing costs)...... any help would be appreciated

    You have encountered one of the key limitations of Discoverer... which I complained about to the Discoverer product manager at OpenWorld in 2001....
    Anyhow, to get around this, you are going to have to deal with it either in the database, (views, materialized views, tables), or within the admin tool by creating a custom folder.
    Discoverer also calls this the "fan trap", but never really had a solution to the problem. [The solution only worked is you joined to one and only one dimension!]
    What you want (using Sales_Fact and Inventory_Fact as an example) is to join Sales to Time, Store, and Product, and save that result. Then join Inventory to Time, Store, and Product, save that result, then do a double outer join between the two intermediate temporary tables in order to calculate something useful like inventory turns by store and product line.
    This is also known a "multipass SQL", and is supported by some (but not many) other tools.
    So, to accomplish this with Discoverer, you'll either need to create a view, or table, or materialized view that has already put Sales and Inventory into a single (virtual?) fact table. Alternatively you can write the SQL for how to do this linkage (don't forget to handle missing data), and use the Discoverer admin tool to create a custom folder that uses your SQL.
    Hope this helps!

  • Multiple child tables and repeating frames

    I have three tables(A,B,and C) where A is the parent of both B, and C. There is no relation between B and C.In the data model, There are three queries, one to each table and I have set up the parent/child relationship in the data diagram.
    In the layout Window I have a master repeating frame which breaks on each record for A. And within that master frame I have two constrained repeating frames for both B and C in that order designed to print all on the same page.
    The problem is that when there is more data for B, the extra records are not displayed .For overflow conditions, I would want A and C information to be reprinted along the top and bottom of each successive page while the middle section would contine on with the extra B records. (I realize this is similar to having header (A) and footer (B) information in the margin, but it is not quite the same thing since B and C depend on A's repeating frame.)

    I'm assuming that all the rows of (C) can always fit onto the page and don't overflow to the next. If so then you'll need the following:
    A Group frame "M_A" that completely surrounds (A) fields
    A Group frame "M_B" that surrounds (B) and defines the space available for (B) to print
    A Group frame "M_C" that surrounds (C)
    Set the properties against each frame:
    M_A:
    Vertical Elasticity: "Variable"
    Print Object On: "All Pages"
    Base Printing On: "Enclosing Object"
    M_B:
    Vertical Elasticty: "Fixed"
    (Re-size this frame in the layout to define the space available for (B))
    M_C:
    Vertical Elasticity: "Variable"
    Print Object On: "All Pages"
    Base Printing On: "Enclosing Object"
    You should end up with:
    A.....
    B1....
    B2....
    B3....
    C1....
    C2....
    A.....
    B4....
    C1....
    C2....

  • BOM and Routing tables and batch tables

    Hi gurus,
    We want to identify certain HIBE materials if they are used in BOMs or routings or if they have batches. What are the tables that i can look that will tell me whether these materials are used in BOM, ROUTING and if they have batch.
    For batches i think it is MCHA. I need to find out for BOM and ROUTINGS. Please help
    Thanks
    Anusa

    Routing
    PLPO          Routing Operation Details
    PLKO         Routing Header Details
    MAPL         Routing Link to Material
    PLAB          Relationships - Standard Network
    PLAS          Task List - Selection of Operations
    PLMZ         Component Allocation
    PLPH          CAPP Sub-operations
    PLFH          PRT Allocation
    PLWP         Maintenance Package Allocation
    PLMK         Inspection Characteristics
    Bill of Material
    STPO          BOM Item Details
    STPU          BOM Sub Items (designators)
    STKO         BOM Header Details
    MAST         BOM Group to Material
    STZU          BOM History Records
    STAS          BOM Item Selection
    STPF           BOM Explosion Structure

  • Multiple Fact Tables and Dimension Tables

    I have been having some problems trying to model the data from Oracle E-Business Suite maintenance. I will try to give the best description of how the data is held in the tables. The structure is such that a work order can have multiple operations and an operation can have multiple resources as well. I believe the problem comes in the fact that an operation doesn't necessarily need to have a resource. I could not attach an image so I have written out an example below. I am not saying this is right or that it works, but just to give you an idea of what I am thinking. The full dimension would be Organization -> WorkOrder -> Operation -> Resource. Now, the fact tables all hold factual data for the three different levels, with the facts being at each corresponding level. This causes an obvious problem in combining the tables into one large fact table through the ETL process.
    Can anyone tell me if they think this can be done? Am I way off? I am sure that there is a solution as there always is but I have been killing myself trying to figure this one out. I currently have the entire solution in different Business Models. I would like however to be able to compare facts from multiple areas such as the Work Order level and the Resource level.
    Any help is greatly appreciated. I realize that the solution may also require additional work on the ETL side so I am open to any and all suggestions.
    Thank you in advance for anyones time. :)
    Dimension Tables
    WorkOrder_D
    Operation_D
    Resource_D
    Organization_D
    Fact Tables
    WorkOrder_F
    Operation_F
    Resource_F
    Joins
    WorkOrder_D -> Operation_D
    Operation_D -> Resource_D
    WorkOrder_D -> WorkOrder_F
    Operation_D -> Operation_F
    Resource_D -> Resource_F
    Organization_D -> WorkOrder_D
    Organization_D -> Operation_D
    Organization_D -> Resource_D

    Hi,
    Currently the dimension table is taken as a simple logical table in rpd as it does not have have any levels or hierarchy.
    Its a flat dimension. Can you guide me how can I implement a flat dimension in OBIEE? Because this dimension is taken as simple logical table
    I am not able to set appropriate level for fac tables. This dimension does not appear in the list of dimensions.

  • How to join multiple source tables and do lookup?

    I have a requirement to load a target table by joining 4 source tables. Also I have to do a lookup on a domain table to transform codes and check for nulls. What will be the best approach to load the target table?
    Is it possible to do it in one interface or do I need to build multiple interfaces to achive this?
    My source and target database both are oracle and I am planing to use Oracle Incremental Update Merge.
    Thank you

    You are in the right direction by creating one interface for this transformation.
    You will need to drag drop 4 source tables + the lookup table on the Sources window of Interface and then make appropriate joins.
    Also, check for NULLS in the transformation. Depends what you want to do with the NULLS. If you want to ignore them, use a filter.
    If you want them to error out, use a constraint.
    If you want to convert them, use NVL
    Start with Oracle Incremental Update and once successful, use Oracle Incremental Update MERGE.

  • Multiple VPN's and overlapping policy

    Hello,
    We currently have a complex VPN network with watchguard firewalls that we want to migrate to cisco routers but cant get it to work.
    Site A has a connection with site B using the ipsec policy 10.50.0.0/16 - 10.0.0.0/8.
    site C also has a VPN with site B using the ipsec policy 10.60.0.0/16 - 10.0.0.0/8.
    Site A can reach site C via site B.
    We want to also connect site A directly to site C using ipsec policy 10.50.0.0/16 - 10.60.0.0/16.
    How can i get this to work ? cause the overlapping policy seems to be preventing the creation of the direct tunnel between A and C.

    We currently have this running on watchguard firewalls and want to get it running on cisco routers.
    The problem we are having now is that if there is an overlapping tunnel present on the cisco routers that the direct tunnel wil not work.
    Ill try and explain the situation.
    site A 10.50.0.0/16
    site B 10.100.0.0/16
    site C 10.60.0.0/16
    site D 10.70.0.0/16
    Site A has a VPN to site B using policy 10.50.0.0/16 - 10.0.0.0/8 same goes for site C and D only using policies 10.60.0.0/16 - 10.0.0.0/8 for C and 10.70.0.0/16 - 10.0.0.0/8 for D.
    This will allow all sites to communicate with all sites via site B.
    Site A and C exchange a higher volume of traffic with each other so its preferable that they also get a VPN with each other using policy 10.50.0.0/16 - 10.60.0.0/16.
    The problem is that this VPN wont come online unless I change the other policies to 10.50.0.0/16 - 10.100.0.0/16 and 10.60.0.0/16 - 10.100.0.0/16.
    This is however not an option. Both A and C also need to be able to communicate with site D and we dont want to create extra VPN's
    Thank you in advance

  • Naming Networks in EEM route table monitor

    I have the following EEM applet running on one of my core devices to monitor any changes in the routing table.
    event manager applet route-table-monitor
    event routing network 0.0.0.0/0 ge 1
    action 0.5 set msg "Route changed: Type: $_routing_type, Network: $_routing_network, Mask/Prefix: $_routing_mask, Protocol: $_routing_protocol, GW: $_routing_lastgateway, Intf: $_routing_lastinterface"
    action 1.0 syslog msg "$msg"
    action 2.0 cli command "enable"
    action 3.0 info type routername
    action 4.0 mail server "*.*.*.*" to "roger@*********" from "Core1" subject "Routing Table Change" body "$msg  $_cli_result"
    action 8.0 set msg "Route changed: Type: "
    This works brilliantly however the email I get lists the networks by IP and I am trying to get it to identify them by name
    Email Output
    Route changed: Type: modify, Network: 10.8.4.0, Mask/Prefix: 255.255.255.0, Protocol: BGP, GW: 10.1.1.1, Intf: N/A
    The script is running on a 3750
    I tried putting ip host info on the switch but that did not work.
    I am not sure if there is an extra line I can add to the script or if anyone else has done this?
    Thanks
    Roger

    I don't understand the request.  Where would the network "name" come from?  Networks are unnamed on IOS.

  • Trouble getting internet route table distributet in a VRF

    Hi every one ..
    I'm have some trouble getting distributed the internet routing table between PE routers ...
    CE1 og PE1 works fine, BGP routes all internet routes are shown i en route table, but distributing between PE1 and PE2 is now working .. any one having a clue !!.
    My gold is to move internet access into it's oven VRF, and away from the global routing table
    In the MPLS core aim running the same AS number as our official AS, that we use for peering to the internet..
    snap of configurations
    ***CE1***
    router bgp 65534
    neighbor 172.31.61.55 remote-as 65534
    neighbor 172.31.61.55 description PE-1
    neighbor 172.31.61.55 shutdown
    neighbor 172.31.61.55 update-source Loopback0
    neighbor 172.31.61.55 next-hop-self
    ***MPLS PE1***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.35
    encapsulation dot1Q 35
    ip vrf forwarding NET-INTERNET
    ip address 172.31.61.55 255.255.255.224
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.146 remote-as 65534
    neighbor 192.168.0.146 description PE2
    neighbor 192.168.0.146 update-source Loopback0
    neighbor 192.168.0.146 version 4
    neighbor 192.168.0.146 next-hop-self
    address-family vpnv4
    neighbor 192.168.0.146 activate
    neighbor 192.168.0.146 send-community both
    exit-address-family
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.1.2 remote-as 65534
    neighbor 172.31.1.2 activate
    neighbor 172.31.1.2 description CE1
    no auto-summary
    no synchronization
    exit-address-family
    ***MPLS PE2***
    ip vrf NET-INTERNET
    rd 65534:10051
    route-target export 65534:10051
    route-target import 65534:10051
    interface Port-channel1.67
    encapsulation dot1Q 67
    ip vrf forwarding NET-INTERNET
    ip address 172.31.254.1 255.255.255.252
    mpls label protocol ldp
    tag-switching mtu 1546
    tag-switching ip
    router bgp 65534
    neighbor 192.168.0.132 remote-as 65534
    neighbor 192.168.0.132 description PE1
    neighbor 192.168.0.132 update-source Loopback0
    neighbor 192.168.0.132 version 4
    address-family ipv4 vrf NET-INTERNET
    neighbor 172.31.254.2 remote-as 65534
    neighbor 172.31.254.2 activate
    Best regards
    /Peter

    For VPN routes to be exchanged between the two PEs, you first need to configure VPNv4 address family on each one of the PEs.
    Carrying the full Internet routing table over VPNv4 will work but it is not very scalable since all PE routers have to hold the full Internet routing table in the VRF context in addition to potentially full Internet routing table in the global routing table. If you want to exchange full Internet routing table between the two CEs, it would be preferable to use something Carrier Supporting Carrier (CSC).
    Please refer to the following URL for additional information on CSC:
    http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s23/fscscl23.htm
    Hope this helps,

  • Sharing global routing table with vrf for intra-as traffic

    We have a network block of 10.201.0.0/16 which is divided into two subnet 10.201.0.0/18 and 10.201.192.0/18. We are getting a internet feed for each subnet.
    10.201.192.0/18 is in global routing table, and 10.201.0.0/18 is in a vrf-lite green.
    I am thinking doing the following:
    ...........HUB
    VL199/....\VL198
    SPOKE1 SPOKE2
    Hub and spoke are from perspective of vrf green.
    For vrf green in the HUB:
    ip route vrf green 10.201.0.0 255.255 255.192 vlan 199
    ip route vrf green 10.201.64.0 255.255.255.192 vlan198
    SPOKE1
    ip route 0.0.0.0 0.0.0.0 vlan199
    SPOKE2
    ip route 0.0.0.0 0.0.0.0 vlan198
    Suppose we already get the 2 internet feeds to HUB route with vrf green and global routing table. This should get vrf green going.
    But we also have global routing table on the HUB router.
    We would like to have 10.201.0.0/16 communicating with each other, and only keep internet default separated.
    How should we get to 10.201.0.0/18 from global routing table and how should we get to 10.201.192.0/18 from SPOKE[12]?

    In my lab, I have 2 ports configured.
    int gi1/2
    ip vrf forward green
    ip address 10.201.192.253 255.255.255.252
    int gi1/1
    ip address 10.201.192.254 255.255.255.252
    ip route 10.201.0.0 255.255.192.0 gi1/2
    ip route vrf 10.201.192.0 255.255.192.0 gi1/1 10.201.192.254
    This way, from vrf green to global has go through HUB. and vrf greens will also go through greens.
    Is there any other much elegant way for this purpose?

Maybe you are looking for

  • Safari and Mail crashing everytime on MBA Late 2010

    Safari and Mail keep crashing everytime. Here are details of the problem. Can anyone help? Process: Safari [190] Path: /Applications/Safari.app/Contents/MacOS/Safari Identifier: com.apple.Safari Version: 5.0.3 (6533.19.4) Build Info: WebBrowser-75331

  • Change in Word folder behavior since Mavericks update

    Since updating to Mavericks it appears Microsoft Word 2011 is having trouble with default folders. The location set in Preferences - File Locations - Documents seems to be ignored. Further, any Save As bounces back to Documents rather than to the doc

  • Hp Pavilion Dv6 3153si - Recovery Discs

    Hi. Can anyone please help me with recovery discs for Hp Pavilion Dv6 3153si. On Hp's site you can order discs but not for this specific model. I had harddrive issues and had do do a complete format. As you all know the recovery was supplied on the h

  • How to find and install Wave Burner?

    Hi, recently i bought Logic 9 from App Store and I don't have Wave Burner as it was normally with previous versions. How can I obtain it? Regards

  • Subfolders - again

    I really have exhausted the many posts that discuss importing the folder/subfolder structure from a hard drive into the Aperture library. I've read the Aperture manual, bought the Digital Workflow "Apple Aperture 2" book, and read through several Int