Need help on efficient searches using hashes on large #s of data structures

I have a massive amount of data and I need a way to access it using generated indexes instead of traditional searching such as binary chop as I require a fast response time.
I have 100,000 Array data structures each containing roughly 10 to 60 elements. The elements of the Arrays do not store any raw data they just hold references to objects. I have about 10,000 unique objects which are referenced to by the arrays.
What I need to do is supply a number of objects as the query and the system should return all the arrays which contain two or more different objects from the query.
So for example>
Given query objects> “DER” , “ERE” , “YPS”
and arrays> [DER, SFR, PPR]
     [PER, ERE, SWE, YPS]
     [ERE, PPD, DER, YPS, SWE]     
     [PRD, LDF, WSA, MMD]
It should return arrays 2 and 3.
I had a look at hashMaps but I’m not entirely sure if that’s what I need.
Would I need to hash the each Array and then hash the query objects and look for overlaps in the two hashes or something similar?
Thanks In Advance

For a single query, it's more efficient to do less work, so don't create intermediate objects, don't create a index of objects to sets of possibles, and stop counting matches when you find enough:.
                final HashSet<String> querySet = new HashSet<String>(Arrays.asList(query));
                final Set<String> results = new LinkedHashSet<String>();
                // find matches using scan of all arrays
                for (String[] array : data) {
                    int matchCount = 0;
                    for (String elt : array) {
                        if (querySet.contains(elt)) {
                            ++matchCount;
                            if (matchCount >= 2) {
                                results.add(Arrays.asList(array).toString());
                                break;
                }Using random data, 100,000 arrays of selections from a list of 10,000 trigrams, scanning all the arrays takes about as long as the set code, but doesn't require generation of the map, which can take up a lot of memory if you pre-create the sets (I didn't complete a run doing that, although it should be faster to query, it used too much memory and my computer started swapping so I gave up after a few minutes).
Running queries of size 2 to 25, times in ms:
linear scan of all arrays in data set:
elapsed: 2196
creating index of trigram to arrays containing trigram:
elapsed: 4635
query using set union and index lookup:
elapsed: 2195
query using direct scan and index lookup:
elapsed: 164
So if I was doing one query per dataset, just use a simple scan as above. If you're doing lots on the same dataset, then create a map<String, List<String[]>> to index the arrays, and the lookup will save quite a bit of time.
Creating the index:.
            dataSets = new HashMap<String, List<String[]>>();
            for (String trigram : trigrams)
                dataSets.put(trigram, new ArrayList<String[]>());
            for (String[] array : data)
                for (String trigram : array)
                    dataSets.get(trigram).add(array);Finding matches using scan of arrays with at least one elt in query:.
                final HashSet<String> querySet = new HashSet<String>(Arrays.asList(query));
                final Set<String> results = new LinkedHashSet<String>();
                for (String trigram : query) {
                    for (String[] array : dataSets.get(trigram)) {
                        for (String elt : array) {
                            if (elt != trigram && querySet.contains(elt)) {
                                results.add(Arrays.asList(array).toString());
                                break;
                }

Similar Messages

  • I need help I tried to use cloud backup on my iPhone 5.0.1 and after all my camera roll pictures are blurry and videos canot be played messege says URL not on this server ! Please help!! iPhone 4S, iOS 5.0.1

    I need help I tried to use cloud backup on my iPhone 5.0.1 and after all my camera roll pictures are blurry and videos canot be played messege says URL not on this server ! Please help!!
    iPhone 4S, iOS 5.0.1

    Try updating to iOS 6.1.3.

  • Need help writing host program using LabView.

    Need help writing host program using LabView.
    Hello,
    I'm designing a HID device, and I want to write a host program using National Instrument's LabView. NI doesn't have any software support for USB, so I'm trying to write a few C dll files and link them to Call Library Functions. NI has some documentation on how to do this, but it's not exactly easy reading.
    I've written a few C console programs (running Win 2K) using the PC host software example for a HID device from John Hyde's book "USB by design", and they run ok. From Hyde's example program, I've written a few functions that use a few API functions each. This makes the main program more streamlined. The functions are; GetHIDPath, OpenHID, GetHIDInfo, Writ
    eHID, ReadHIC, and CloseHID. As I mentioned, my main program runs well with these functions.
    My strategy is to make dll files from these functions and load them into LabView Call Library Functions. However, I'm having a number of subtle problems in trying to do this. The big problem I'm having now are build errors when I try to build to a dll.
    I'm writing this post for a few reasons. First, I'm wondering if there are any LabView programmers who have already written USB HID host programs, and if they could give me some advice. Or, I would be grateful if a LabView or Visual C programmer could help me work out the programming problems that I'm having with my current program. If I get this LabView program working I would be happy to share it. I'm also wondering if there might already be any USB IHD LabView that I could download.
    Any help would be appreciated.
    Regards, George
    George Dorian
    Sutter Instruments
    51 Digital DR.
    Novato, CA 94949
    USA
    [email protected]
    m
    (415) 883-0128
    FAX (415) 883-0572

    George may not answer you.  He hasn't been online here for almost eight years.
    Jim
    You're entirely bonkers. But I'll tell you a secret. All the best people are. ~ Alice

  • I need help from chile and use a language translator to write and not turn my iphone4

    I need help from chile and use a language translator to write and not turn my iphone4

    http://support.apple.com/kb/TS3281       
    Not turn on

  • Need help about ref cursor using like table

    Hi Guys...
    I am devloping package function And i need help about cursor
    One of my function return sys_refcursor. And the return cursor need to be
    join another table in database . I don't have to fetch all rows in cursor
    All i need to join ref cursor and another table in sql clause
    like below
    select a.aa , b.cc form ( ref_cursor ) A, table B
    where A.dd = B.dd
    I appeciate it in advance

    My understanding is that you have a function that returns a refcursor and is called by a java app.
    Because this is a commonly used bit of code, you also want to reuse this cursor in other bits of sql and so you want to include it like table in a bit of sql and join that refcursor to other tables.
    It's not as easy as you might hope but you can probably achieve this with pipelined functions.
    Is it a direction that code should be going down? yes, eventually. I like the idea of pulling commonly used bits of code into a SQL statement especially into the WITH section, provided it could be used efficiently by the CBO.
    Is it worth the effort given what you have to do currently to implement it? possibly not.
    what else could you do? construct the sql statement independently of the thing that used it and reuse that sql statement rather than the refcursor it returns?
    Message was edited by:
    dombrooks

  • Need help doing text search of Blob

    I presently have a simple single table candidate tracking application that create records of candidate information and you attach their resume in a word format into a blob column named RESUME within the table.
    I need to be able to do a full text boolean search of the attached documents, since we're going to use this to allow us to search an internal database for people with particular skill sets.
    I'm not a DBA or a developer, I just started working with Oracle Application Express and need a simple way of creating this search feature.
    I also need to add the search feature into a region for users to input search terms.
    Any help would be greatly appreciated.
    Edited by: user10608055 on Nov 25, 2008 11:57 AM

    try
    http://tahiti.oracle.com/
    in the list of books, look at 'TEX' for Oracle text.
    Interesting you should bring this up. I'm slighly involved with US Transition team.
    Many resumes are coming in.
    Tim

  • Need help in english to use my iphone4 with orange.fr in france

    I am travelling in France with my factory unlocked iphone4. England and Thailand services have been fine but Orange France is a nightmare. They say I can't get 3G on my iphone4 and there is no english speaking support to help me out. My network settings are turned off but my 20 euro credit has either dissappeared or never was there in the first place. Where can I get English support for this company?

    Hello
    The whole story is a little bit confusing for me. So lets see what you wrote:
    >... thinking that it would fix it but it ended up erasing the whole of my computer even windows 7.
    Thinking is wrong. What you need is exact info about recovery installation and this can be found in users manuals document. Recovery disc is not like Microsoft installation disc and cannot be used for repair. Recovery disc contains recovery image and can be used for clean OS installation (recovery image installation) only.
    > So now I have a computer I can't use
    Why you cannot use it? Recovery image installation installs OS again. Which OS is installed after running recovery image installation?
    > I have also bought the product recovery disks from toshiba's backup media site
    But why if you already have recovery disc that you have used at the beginning of the whole story?
    What you need to do is to use this original disc for OS installation.
    -start your notebook and press F12 several times to enter BOOT menu
    -when the menu is shown put recovery disc into ODD
    -select CD/DVD drive in the menu and press ENTER
    -follow the menu on the screen
    After recovery image installation you will have factory settings again and everything should be OK.
    More questions?

  • Need Help Understanding How To Use iMessage Between Two iPhones

    I have an iPhone 4 and my wife an iPhone 3GS.  We both have iOS 5, but I have discovered something about iMessage I need to make sure I understand correctly.  As I understand it iMessage can send text even if our voice carrier service is unavailable.  I tend to loose signal inside the building I work in.  I usually can get texts in and out, but sometimes not.  But in testing the two phones sending iMessages, I've noticed is that if I have one of the phones with iMessage turned on and the other with iMessage turned off, the two phones will not be able to exchange text.  Is that how it's supposed to work?  Even though one of these phones can receive an iMessage doesn't mean the other one send one back.  Can't the system detect when one phone is connected and another one not, and the one that is not gets sent SMS messages instead?  I don't want to try to send my wife an iMessage because I can't get a voice signal in my building, but her have iMessages turned off and not able to get any messages from me, iMessage or SMS.  I guess I need help better understanding how this actually works between the two phones so I can always get texts back and forth between my wife and I.  My other misgiving is that this iMessage thing consumes my data limit.  My wife gets unlimited because she had her phone before the limits were imposed, but I got on board after, so I am hesitant to use iMessage all the time because of it.  I have no intention to send picture mail through iMessage, but the thing is if I wanted to switch to SMS to send picture mail to save data, but my wife's phone is set to iMessage, she won't get it.  If this is how this thing is supposed to work, I'm not really impressed.  Some insight would be appreciated

    I think you are making this way too complicated. Why are you turning iMessage off? If you are at your office connect to the WiFi there and send your wife messages that way (unless your office is blocking the port iMessage uses). When possible the two phones will use iMessage but will revert to SMS is iMessage is not available if that option is set that way.
    I would not worry about using up your data plan if you have the 2GB, text iMessages are going to be very small and MMS (picture) ones are not very large either. Unless you are sending hundreds of picture iMessages a day you will have a hard time using up your data.
    If you are near an Apple Store you should explore signing up for an intro iPhone course and have them run through iMessage options.

  • Need help on how to use conference facility within adobe connect

    I need some help on how to use conference facility within adobe connect?

    I'd recommend you start here: Getting Started with Adobe Connect - Adobe Connect User Community

  • Need help please. When using Safari while banking online I cannot get rid of Pop ups although I have ticket no Pop ups. Any ideas ?

    Need your help please. When using Safari while banking online- I cannot get rid of the Pop ups although I have ticked the correct place. Any ideas ?
    A few months ago I downloaded a program someone suggested.

    Get Adblock or GlimmerBlocker.

  • NEED HELP ON QUERRY (Search with SAF/TREX)

    Hello Gurus,
    I have to work on standard screen in that they are fetching database and extracting the data by using CL_CRM_EI_IIA_QUERY_UI class. In this calss they are using SET_QUERY, GET_QUERY, GET_TEXT_QUERY, SET_TEXT_QUERY,CREATE_TEXT_EDITOR methods.
    I have to add three more fields to this existing screen and ned to add these field values in the search process. I am trying to understand the code and they have not used any select statement. can you pelase help me how to use the above class and for my requirement..
    the screen which i am trying to change is CIC0 transaction in CRM win client in FAQ tab knowledge search screen.
    Please help me on this issue.
    regards

    Hi,
    In MM03, the search help for material no is a collective search help MAT1 consisting of
    many elementary search helps.
    For your requirement create a collective search help for ex. ZHELP, consisting of the elementary search help
    Material by old material number - MAT1A , material by EAN - MAT1N
    and material by several classes -  MAT1O.
    Regards,
    Vinod

  • Need help on Self Hosting Using channel Factory

    Hello,
         Need Help.
         I am trying to self host WCF service using cutom Channel Factory class. but I am getting exception.
     The scenario is something like below this  : -
    I want to create the endpoint connection to WCF service. I want to achieve this  using custom channel factory(not using default channel factory API provided in .Net Framework).
    I have written one class and it is derived from channel factory and we are reading the service endpoints, behaviors, bindings from external configuration file added in the project.
    I am able to connect to server side service hosted on different machine using following sample code successfully.
    In the case of “self-hosting”  I am receiving following error : --
         "There was an error reading from the pipe: The pipe has been ended. (109, 0x6d)."
    Below is the code which I have written for self hosting WCF service using custom channel factory.
    // Method where I am calling CustomChannel Factory constructor
    internal void ProxyCall(string msgEndpointConfigurationName, string url)
                string appConfigDirName, extConfigFilePath;
                FileInfo configFileInfo = new FileInfo(appConfigName);
                appConfigDirName = configFileInfo.DirectoryName;
                extConfigFilePath = appConfigDirName + "\\" + extConfigFileName;
                this.messageEndpointConfigurationName = msgEndpointConfigurationName;
                if (string.IsNullOrEmpty(url))
                    this.messageFactory = new CustomChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName);
                else
                   //EndpointAddress e = new EndpointAddress(url + ClientToServerOperations.ServiceAddress);
                   //this.messageFactory = new ChannelFactory<IServerOperationsMessage>(this.messageEndpointConfigurationName, e);
                   this.messageFactory = new CustomSelfHostingChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName, url + ClientToServerOperations.ServiceAddress);
                   //this.messageFactory = new CustomSelfHostingChannelFactory<IServerOperationsMessage>(extConfigFilePath, this.messageEndpointConfigurationName, e);
       ClientMessageFormatterBehavior formatterBehavior = new ClientMessageFormatterBehavior();
       foreach (OperationDescription operation in this.messageFactory.Endpoint.Contract.Operations)
        if (!operation.Behaviors.Contains(typeof(ClientMessageFormatterBehavior)))
         operation.Behaviors.Add(formatterBehavior);
       this.messageFactory.Endpoint.Behaviors.Add(new MessageStatisticsBehavior());
       this.messageFactory.Open();
    // Custom Channel Factory Class
    internal class CustomSelfHostingChannelFactory<T> : ChannelFactory<T>
            /// Custom client channel. Allows to specify a different configuration file
            /// <typeparam name="T"></typeparam>
            private string configurationPath, selectedMsgEndPoint, uriAddress;
            public PPCCustomSelfHostingChannelFactory(string configurationPath, string selectedEndPoint, string uriAddress)
                : base(typeof(T))
                this.configurationPath = configurationPath;
                this.selectedMsgEndPoint = selectedEndPoint;
                this.uriAddress = uriAddress;
                EndpointAddress e = new EndpointAddress(this.uriAddress);
                base.InitializeEndpoint(selectedEndPoint,e);
            //As you can see, a call to the method InitialiazeEndpoint of the base class is required.
            //That method will automatically call to our CreateDescription method to configure the service endpoint.
            ///Loads the serviceEndpoint description from the specified configuration file
            protected override ServiceEndpoint CreateDescription()
                ServiceEndpoint serviceEndpoint = base.CreateDescription();
                return serviceEndpoint;
            private EndpointIdentity GetIdentity(IdentityElement element)
                EndpointIdentity identity = null;
                PropertyInformationCollection properties = element.ElementInformation.Properties;
                if (properties["userPrincipalName"].ValueOrigin != PropertyValueOrigin.Default)
                    return EndpointIdentity.CreateUpnIdentity(element.UserPrincipalName.Value);
                if (properties["servicePrincipalName"].ValueOrigin != PropertyValueOrigin.Default)
                    return EndpointIdentity.CreateSpnIdentity(element.ServicePrincipalName.Value);
                if (properties["dns"].ValueOrigin != PropertyValueOrigin.Default)
                    return EndpointIdentity.CreateDnsIdentity(element.Dns.Value);
                if (properties["rsa"].ValueOrigin != PropertyValueOrigin.Default)
                    return EndpointIdentity.CreateRsaIdentity(element.Rsa.Value);
                return identity;
            private Binding GetBinding(IBindingConfigurationElement configurationElement)
                if (configurationElement is CustomBindingElement) return new CustomBinding();
                else if (configurationElement is BasicHttpBindingElement) return new BasicHttpBinding();
                else if (configurationElement is NetMsmqBindingElement) return new NetMsmqBinding();
                else if (configurationElement is NetNamedPipeBindingElement) return new NetNamedPipeBinding();
                else if (configurationElement is NetPeerTcpBindingElement) return new NetPeerTcpBinding();
                else if (configurationElement is NetTcpBindingElement) return new NetTcpBinding();
                else if (configurationElement is WSDualHttpBindingElement) return new WSDualHttpBinding();
                else if (configurationElement is WSHttpBindingElement) return new WSHttpBinding();
                else if (configurationElement is WSFederationHttpBindingElement) return new WSFederationHttpBinding();
                return null;
            private Binding CreateBinding(string bindingName, ServiceModelSectionGroup group)
                BindingCollectionElement bindingElementCollection = group.Bindings[bindingName];
                if (bindingElementCollection.ConfiguredBindings.Count > 0)
                    IBindingConfigurationElement be = bindingElementCollection.ConfiguredBindings[0];
                    Binding binding = GetBinding(be);
                    if (be != null)
                        be.ApplyConfiguration(binding);
                    return binding;
                return null;
            private void AddBehaviors(string behaviorConfiguration, ServiceEndpoint serviceEndpoint, ServiceModelSectionGroup group)
                EndpointBehaviorElement behaviorElement = group.Behaviors.EndpointBehaviors[behaviorConfiguration];
                for (int i = 0; i < behaviorElement.Count; i++)
                    BehaviorExtensionElement behaviorExtension = behaviorElement[i];
                    object extension = behaviorExtension.GetType().InvokeMember("CreateBehavior", BindingFlags.InvokeMethod | BindingFlags.NonPublic | BindingFlags.Instance, null,
    behaviorExtension, null);
                    if (extension != null)
                        serviceEndpoint.Behaviors.Add((IEndpointBehavior)extension);
    Thanks in advance !! :-)

    Hi,
    There was an error reading from the pipe: Unrecognized error 109 (0x6d).
    One reason was inconsistent binding between client and server <netNamedPipeBinding> <security mode="None"></security>... (no
    communication)
    The other intermittent issue was time-out related.
    For more information, you could refer to:
    http://stackoverflow.com/questions/15836199/wcf-namedpipe-communicationexception-the-pipe-has-been-ended-109-0x6d
    http://stackoverflow.com/questions/22334514/wcf-named-pipe-error-the-pipe-has-been-ended-109-0x6d
    Regards

  • I am Stuck! Need Help With Multicast Streaming Using VLC Player

    I have a Multicast network topology shown below
    and my configs
    HUB ROUTER
    no ip domain lookup
    ip domain name primestarhotel.com
    ip multicast-routing
    interface Loopback0
    ip address 5.5.5.5 255.255.255.255
    ip pim sparse-dense-mode
    interface FastEthernet0/0
    ip address 200.0.0.2 255.255.255.240
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.65
    description "Server Vlan"
    encapsulation dot1Q 65
    ip address 10.1.65.1 255.255.255.0
    ip pim sparse-dense-mode
    ip virtual-reassembly
    router ospf 200
    log-adjacency-changes
    network 5.5.5.5 0.0.0.0 area 0
    network 10.1.65.0 0.0.0.255 area 0
    network 200.0.0.0 0.0.0.15 area 0
    ip route 200.1.1.0 255.255.255.252 200.0.0.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    no ip http server
    no ip http secure-server
    ip pim send-rp-announce Loopback0 scope 6
    ip pim send-rp-discovery Loopback0 scope 6
    ISP ROUTER
    interface FastEthernet1/0
    interface FastEthernet1/1
    no switchport
    ip address 200.0.0.1 255.255.255.240
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/2
    no switchport
    ip address 200.1.1.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    interface FastEthernet1/3
    no switchport
    ip address 200.2.2.1 255.255.255.252
    ip pim sparse-dense-mode
    duplex full
    speed 100
    router ospf 200
    log-adjacency-changes
    network 200.0.0.0 0.0.0.15 area 0
    network 200.1.1.0 0.0.0.3 area 0
    network 200.2.2.0 0.0.0.3 area 0
    SPOKE 1 Router
    interface FastEthernet0/0
    ip address 200.1.1.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    no ip address
    ip pim sparse-dense-mode
    ip virtual-reassembly
    speed 100
    full-duplex
    interface FastEthernet0/1.12
    description "Workstation pc"
    encapsulation dot1Q 12
    ip address 10.1.12.1 255.255.255.0
    ip pim sparse-dense-mode
    router ospf 200
    log-adjacency-changes
    network 10.1.12.0 0.0.0.255 area 0
    network 200.1.1.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.1.1.1
    SPOKE 2
    interface FastEthernet0/0
    ip address 200.2.2.2 255.255.255.252
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    interface FastEthernet0/1
    ip address 10.2.22.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    router ospf 200
    log-adjacency-changes
    network 10.2.22.0 0.0.0.255 area 0
    network 200.2.2.0 0.0.0.3 area 0
    ip route 0.0.0.0 0.0.0.0 200.2.2.1
    ip route 200.2.2.0 255.255.255.252 200.0.0.1
    I have implemented multicast on the network in a hub and spoke topology. i have set up ospf routing protocol and broadcast all network and can successfully ping.
    I am currently using VLC player as my media streaming server and client. i have set up rtp streaming from the HUb router using multicast ip 224.2.2.2 and unable to broadcast the multicast traffic across the spokes 1 and 2 PC's
    I have never used vlc player  never set up multicast network before and i am struggling with this and need help.
    these are my router configs below
    http://dl.dropbox.com/u/20145606/ip%20video%20config.txt
    Message was edited by: Louis Ojuwu

    I have edited the message and the configs and topology are visible above now. instead of the links i provided

  • Need Help With Military DTD Using FrameMaker 8

    Fellow Forum Members,
    I hope someone out there with experience in using Department of Defense DTDs with FrameMaker can contribute to this thread.
    Attached is the MIL STD 400051-2 DTD that needs to play with FrameMaker. Does anyone out there know where I could find FrameMaker templates already setup that comply and play with the MIL STD 400051-2 DTD standard? If the Department of Defense is freely distributing the MIL STD 400051-2 DTD, shouldn't somebody in the Department of Defense also be providing MIL STD 400051-2 FrameMaker Templates for free that are already setup?  I would greatly appreciate if anyone out there could provide an online source where I could download MIL STD 400051-2 FrameMaker templates.
    Lastly, can anyone out there clarify what the purpose of the entities are inside the "Charant" and "Boilerplate" folders?  The Department of Defense does not provide a readme file that define what the "Charant" and "Boilerplate" folders are about.
    Any info will be greatly appreciated. Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

  • Need help with database migration using export/import

    Hi,
    I am planning to do a database migration from 8.0.6 to 10.2.0.4. I am using export/import. Please answer some of my queries:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=y
    2) Will there be any data corruption while export.
    3) Is export/import the only method of migration/upgradation.
    Please help
    Thanks.

    I'll answer the specifics that I know about your questions, but please look at the post from Srini for additional info:
    1) Do i need to do full export using SYS/SYSTEM user.
    exp80 system/manager file=c:full.dmp log=c:\full.txt full=y consistent=yA full export will move as much information (metadata/data) as possible. In order to do a full export/import, you need to do this from a
    privileged account. A privileged account is one with EXP_FULL_DATABASE for export and IMP_FULL_DATABASE for import.
    2) Will there be any data corruption while export.The data in the objects that you are exporting is being read, nothing is written to user data. I'm not sure what this is available in 8.0.6,
    but if you need a consistent export, look to see if consistent=y is available in 8.0.6. All this means is that the dump file created will have
    consistent data in it.
    3) Is export/import the only method of migration/upgradation.If you are changing hardware, the only supported way from 8.0 to 10.2.0.4, that I know of, is using exp/imp.
    Hope this helps.
    Dean

Maybe you are looking for

  • How to check the tables

    Dear experts! Thank you for your attention! I have studied the SAP SD for half a year, though I still don't know how to check certain table like: KNVS---customer master shipping data KNBK---customer master (bank detail) ADR---address table ect. could

  • Slow scrolling with all add-ons and extensions disabled, but OK is safe mode

    I have a page for work, with a lot of links, that scrolls very slowly, with a choppy action. It is the same with all add-ons and extensions disabled. But when restarted in safe mode, the scrolling is OK. What else does the safe mode block? Or what co

  • Trash emptying slowly

    Hey, so I had my external hardrive connected to my computer and was trying to delete old back ups so that I could make a new one. In the process, I now somehow have 55,000 + items emptying from the trash, and it is TAKING FOREVER. Is there anything I

  • Wrongly updated the newest iOS for my iphone 3GS

    As I pluged my iPhone 3GS into a new laptop, I wrongly updated the newest iOS version into my phone. This causes a few content loses and the phone runs very slowly. How can I restore/recover the right iOS at my 3GS? Thanks a lot.

  • About passive ftp mode?

    In proxies passive ftp mode is checked and in the box this domain*.local, 169.254/16 is always visible.  My internet is dongle wifi - Wimax.  Can I uncheck this box without it affecting my wifi connection.  Something very strange is happening when I