Overloading

Thanks in advance to all,
I need one information
Most built-in functions are overloaded.
For example, the function TO_CHAR in the package STANDARD has
four different declarations
The function can take either the DATE or the NUMBER
FUNCTION TO_CHAR (p1 DATE) RETURN VARCHAR2;
FUNCTION TO_CHAR (p2 NUMBER) RETURN VARCHAR2;
Instead, I have some funtion as
FUNCTION GET_DESC (table_name IN VARCHAR2,.....) RETURN varchar2
FUNCTION GET_DESN (table_name IN VARCHAR2,.....) RETURN NUMBER
FUNCTION GET_DESD (table_name IN VARCHAR2,.....) RETURN DATE
have same 'In' parameter but different 'OUT' datatype return Parameter.
Of course, I can use TO_CHAR,TO_NUMBER, TO_DATE with same return parameter (ex: VARCHAR2)
my question is, Does another method exist similar to the overloding?
Thanks in advance for any help

Not possible.
Check documentation at http://download-east.oracle.com/docs/cd/B19306_01/appdev.102/b14261/subprograms.htm.
>>>
You cannot overload two functions that differ only in the datatype of the return value, even if the types are in different families. For example, you cannot overload two functions where one returns BOOLEAN and the other returns INTEGER.
>>>

Similar Messages

  • Overload problems in Logic 8

    I'm on a G5 2.0Ghz with 12Gb Ram, but Logic seems to lock up all the time with overloads on only one core. Sounds quickly become crackly as the core overloads, but the other core hardly shows any activity.
    I have tried all kinds of different configurations of settings, followed all the standard advice for buffer settings, ticking and unticking all the options.
    I'm using a Tascam FW-1804 interface which Tascam assure me is fine in Leopard.
    Is this a problem with Logic misreporting CPU activity? Or is one core really overloading while the other remains largely dormant?
    Are there some specific settings im missing that is required when using a non intel G5?
    Thanks in advance!
    Bob

    Here's a great article about how Logic distributes processing power over multiple cores. Some useful info on how to balance out loads:
    http://support.apple.com/kb/HT3161
    And make sure I/O Safety Buffer box is OFF.
    Good Luck!

  • My MacBook Pro (purchased in 2011) is taking 10 minutes to boot-up.  It's also taking much longer to open files.  I have 650 GB out of 700 GB left on my machine so it's not that I've overloaded the memory.  Is anyone else having this problem?

    My MacBook Pro (purchased in 2011) is taking 10 minutes to boot-up.  It's also taking much longer to open files.  I have 650 GB out of 700 GB left on my machine so it's not that I've overloaded the memory.  Is anyone else having this problem?

    Look at this comprehensive trouble shooting document;
    https://discussions.apple.com/docs/DOC-3353
    I suggest that you start with SMC and PRAM resets.
    Then  a Safe Boot.
    Ciao.

  • How to overload two different procedure with just one name in to package

    i have created two procedure avg1 and avg2.avg1 calculate average of total salary based on e_id and avg2 calculate average based on j_id.now i want to create a package with specification and body where i want to use just one name -avg- for two different procedure.

    You can overload the same name for procedure as long as their formal parameters differ in number, order, or datatype family.
    Read more about overloading in documentation

  • How to set up load balancing with overload server on css

    can anyone tell me how to set up a load balancing config on css that will enable me to LB proxy caches and when they have too many connections then LB against an overload proxy-cache.
    Such that when the normal proxy-cache farm is under the ceiling of max connections then the overload server is not used ?
    I don't think redirect or sorry server will do this ?

    see the below configuration,any question,just tell me.
    service proxy-1
    ! below is the real ip of server
    ip address 10.1.1.1
    keepalive type icmp
    active
    service proxy-2
    ip address 10.1.1.2
    keepalive type icmp
    active
    ! enter owner config-mode
    owner proxy
    ! define a content rule,match what you want to load balancing
    content rule-proxy
    ! below is virtual ip,it can be another ip segment
    vip address 10.1.1.50
    add service proxy-1
    add service proxy-2
    protocol any
    advanced-balance sticky-srcip
    active

  • Bug in Apex 2.2.1.00.04 in overload call of function?

    We are having custom table defined as:
    CREATE TABLE HTMLDB_USERS (
      ID             INTEGER               CONSTRAINT HTMLDB_USERS_ID_NN NOT NULL,
      USERNAME       VARCHAR2(64 BYTE)     CONSTRAINT HTMLDB_USERS_USERNAME_NN NOT NULL,
    desc htmldb_users Name                                      Null?    Type
    ID                                        NOT NULL NUMBER(38)
    USERNAME                                  NOT NULL VARCHAR2(64)
    ...Where ID is primary key and on USERNAME there is unique index defined.
    In package we have two overload functions defined as:
    FUNCTION update_password (
                p_id       IN HTMLDB_USERS.ID%TYPE
               ,p_password IN HTMLDB_USERS.PASSWORD%TYPE
              ) RETURN PLS_INTEGER;and later declared:
    FUNCTION update_password (
                p_username       IN HTMLDB_USERS.USERNAME%TYPE
               ,p_password IN HTMLDB_USERS.PASSWORD%TYPE
              ) RETURN PLS_INTEGER;which should be correctly determined in call according different data types. In our page we had a call like:
    :P102_STATE :=#OWNER#.pkg_auth.update_password(:P102_ID,:P102_NEW_PASSWORD2);
    ...Call was going to correct function (the one with ID in parameter).
    In trace (have special pragma function for writing values to database) we get that passed values all the time was "-2", regarding that "P102_ID" was having correct INTEGER value ("3", "4", "7" etc...).
    Interesting thing was that call with v('P102_ID') in function results OK!
    When we place call by reference
    p_id=>:P102_ID,p_password=>:P102_NEW_PASSWORD2);Then all was OK!
    We are pointing to this bug because it may raise many problems to users....
    select * from v$version;BANNER
    Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Prod
    PL/SQL Release 10.2.0.1.0 - Production
    CORE    10.2.0.1.0      Production
    TNS for 32-bit Windows: Version 10.2.0.1.0 - Production
    NLSRTL Version 10.2.0.1.0 - ProductionHope this was worth of logging....and even this may not be treated as bug worth ow warning...

    Vikas,
    all clear but that v('P102_ID') call is bothering me!
    And other thing....I was debugging in first function (with number parameter)...and if API is making VARCHAR2 value, then in no circumstances first function (with number) cannot be called but only second one (with two VARCHAR2)...which was not called !!!!
    To make more clear, create two function (in this order in package):
    FUNCTION update_password (
                p_id       IN HTMLDB_USERS.ID%TYPE
               ,p_password IN HTMLDB_USERS.PASSWORD%TYPE
              ) RETURN PLS_INTEGER;
    BEGIN
      dbms_output.put_line(v('P102_ID'));
      dbms_output.put_line('Number called function "'||to_char(p_id)|'"');
      return null;
    END;
    FUNCTION update_password (
                p_username       IN HTMLDB_USERS.USERNAME%TYPE
               ,p_password IN HTMLDB_USERS.PASSWORD%TYPE
              ) RETURN PLS_INTEGER;
    BEGIN
      dbms_output.put_line(v('P102_ID'));
      dbms_output.put_line('VARCHAR2 called function "'||p_username||'"');
      return null;
    END;and make a call like in my case.
    This is most interesting of all! Intersting which function will be called!
    Maybe this note helps someone to be mislead...
    Message was edited by:
    Funky

  • I have just switched over to iCloud and I am now getting an error message in iCal which is the following: The server is currently unable to handle the connection due to a temporary overloading or maintenance of the server. If this continues you should con

    I have recently switched from MobileMe to iCloud and I now getting an error message in iCal :
    "The server is currently unable to handle the connection due to a temporary overloading or maintenance of the server. If this continues you should contact the server administrator.
    You may try to connect to the server again or take the account offline."
    Since I am working from home and I am not on a server other than iCloud I don't understand why I am getting this message. (for 3 days). How do I fix it?

    TomCT60,
    Is your MacBook using Mac OS X 10.6.8 as indicated in your post? If so you will not be able to fully integrate with iCloud.
    iCloud and Snow Leopard, by Roger Wilmut describes what iCloud options are available for Snow Leopard.
    If you are using Lion, go to iCal>Preferences...>Accounts, and delete/re-add your iCloud CalDAV server.

  • System Overload ...i know ..I'm not the 1st ...

    _History Below_
    Topic : System Overload ...i know ..I'm not the 1st ...
    This topic has been archived - replies are not allowed.
    Your question is not answered.
    Mark as answered.
    Use the "helpful" or "solved" buttons to award points to replies.
    Subscribe to this Topic Back to Topic List
    Replies : 10 - Pages : 1 - Last Post : Aug 10, 2009 12:04 PM by: Pancenter
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 7:52 PM
    Any quick tips on what to do? My project is small - while monitoring my CPU usage it never goes above 30 while running the project - I've got 2.78 GB of free disk space - 4Gig Ram - I dont use my IMAC OSX 10.5.5 for anything but Logic? Hoping to get around this CONSTANT issue - thanks for your help.
    Imac Mac OS X (10.5.5)
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 9:48 PM in response to: 4feet4
    Well, if you are saying you have only 2.78 GB's of space on your hard drive, then you'll want to have more. You should leave about 10-15% of your drive free.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 10:51 PM in response to: Larry Mal
    I'm running LP8 - I have an IMAC OSX 10.5.5 - 2.4 processor - 4 GB RAM - M-Audio Fast Track Pro interface (USB direct to MAC) - I do NOT have an external hard drive ( sounds like I should ? - although I was told by others my system would be sufficient) - I use ALL instruments/track options ( midi etc) and will need to in the future - I want to be able to run a full music project 10-15 tracks. So far I'm running 4-5 tracks -(1) midi - the rest are audio with little to no effects ( in one project I'm using an LP8 template but deleted most of the tracks to cut down on the load ). Don't know if I can freeze these tracks-I'm new to this - thats why I'm looking for options ........ i was also using a 3rd party software in the project - Steinberg Groove Agent 3 (drums) but it was giving me the same error ..even when it was the ONLY track in the project....(its not fully compatible) - however I was finally able to create a full drum track with GA3 - play the midi data back - and record it to an audio track - therefore deleting the midi data I was having issues with and keeping the drums.... hope this helps?
    Imac Mac OS X (10.5.5)
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 6:39 AM in response to: 4feet4
    Updated
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 7:54 AM in response to: 4feet4
    Perfect. Well here are some suggestions:
    1) Logic 7, 8 and 9 all have a "freeze" function. Logic 9 has a new "bounce in place" function which I haven't used yet. These will make temporary audio files of your MIDI instruments so that you are able to play them as finished audio for the most part and free up CPU power. ( I haven't yet used "bounce in place", I just got Logic 9.) This will help with MIDI instruments quite a bit, and you can still go back and change them by un-freezing... I guess "thawing" would be the proper term.
    2) The reason I was asking about your audio interface is because I was wondering what you had available. You very definitely want to record to a non-system (on that Logic nor your operating system are on) drive. Firewire is much superior to USB, which is why I'm glad to hear you are using USB as your audio in. By using Firewire in and Firewire out, on an iMac, you would be halving the bandwidth. In your case you are not.
    You will add very much stability to your Logic work by adding an external Firewire drive and recording audio to it, and working on Logic projects there! If you have the money, I'd go with Firewire 800, which is frankly overkill, but why not. Firewire 400 drives will work fine for you. Add one and many of the overload messages will disappear, simply because right now you are pulling information from (in the form of calculating what the virtual instruments and Logic are doing) and writing information to (in the form of writing what those instruments and Logic are resulting in) to the same disk.
    Try these two things and get back to us. I think you'll be very happy with the results.
    It's also important to pay attention to your buffer size. When it is not important for you to play with it in real time, you want to make it be 1024. Otherwise as low as possible. So when you are recording audio to a MIDI drum track, you'd want it to be very low so you can play along accurately. When you have all that done, and are editing MIDI only, then put the buffer higher. When mixing, put it higher.
    Let me know how this works, good luck, L
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:10 AM in response to: Larry Mal
    Ok Great - Thanks - makes sense - I was using a Lacie with Protools an my PC ( it recently crashed) - I was under the impression I would have enough processing power with out it on the MAC.
    Looks like I can pick one up for just a little over $100 ( I'm rolling in that kind of cash) ... please clarify though - you stated: "Firewire is much superior to USB, which is why I'm glad to hear you are using USB as your audio in. By using Firewire in and Firewire out, on an iMac, you would be halving the bandwidth. In your case you are not" ....are you GLAD to hear I am using USB as in - We may have found the problem .... go external to free up processing ? Please confirm.
    Thanks again
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    CCTM
    Posts: 249
    Registered: Mar 11, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:28 AM in response to: 4feet4
    4feet4 wrote:
    Ok Great - Thanks - makes sense - I was using a Lacie with Protools an my PC ( it recently crashed) - I was under the impression I would have enough processing power with out it on the MAC.
    As stated in an earlier reply, if you only have 2 or 3 gigs of free space on your Mac hard drive, processing power is NOT the problem. Your boot disc is way too full. You should have at least 20-30GB free.
    Running a second drive for the audio side will, of course, help, but you MUST clear out the main hard drive (or fit a larger one) before you run into even more serious problems.
    HTH
    CCT
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:37 AM in response to: 4feet4
    Well, you have enough processing power, that isn't the issue. All the processing power in the world won't matter if you have 64 megabytes of RAM, there will be a bottleneck. Another bottleneck is with data transference. Like I said, when using a single drive to transfer date from as well as to- which is what you are doing when you are using Logic, running within the scope of the operating system, and hosting virtual instruments, all of which is writing the resulting audio information to the same drive, at the same time, then you are creating another problem. But you don't have to do that, by sending the audio written to another drive other than the one the audio is being generated from.
    In other words, your processing power is both faster than and irrelevant to the physical limitations of the hard drive itself.
    Another bottleneck would be if you were recording tracks on a Firewire in, and sending that to and external Firewire drive out. This is one of the limitations of the iMac, there is no way to add what is called another bus, which is simply another pipeline for data transference. You can get around that with a Mac Pro, in which you add another internal hard drive, which connects directly to the motherboard, and has its own bus. Or by adding another Firewire PCIe card, which will add another Firewire bus, again, with its own data transference. On an iMac, you have one Firewire bus, and one USB bus.
    Clear? You can imagine these as pipes of water. The more pipes you have leading to and from a location the faster it will go.
    USB, in your case, is a dedicated pipeline in. Nothing (well, your mouse, maybe a flash drive) is using that pipeline. Your Firewire is a pipeline out, in this case- you could reverse this, it doesn't matter*. If you use Firewire in and out, then you are sending water flowing in both directions in the same pipe. It will work, but not as well. By adding a dedicated bus, you would be adding another pipe to flow in one way, while the original flowed the other way. No impedances.
    I don't see why you can't use the Lacie drive you already have, though. It's quite likely your crash wasn't due to it. No need to buy another drive, if it's Firewire, anyway. Just give it a shot- this isn't a cure all, but just good audio practice. Let me know how it pans out. Good luck, L
    *Firewire is better than USB in all situations. But you seem to be going a track or two of USB audio in, so I'd use USB for that. For light use it's fine. Then you can use your superior Firewire bus to write the audio to the external Firewire drive.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 11:12 AM in response to: Larry Mal
    L - Thanks for laying that out in simple terms - learning a ton and loving it ( when things work) - I will pick up another Lacie - my old Lacie for my PC crashed - I'm better off starting from scratch ( I'm still trying to retrive some data of the old one) ... I'll let you know how it works. I would have got an external drive outright but the Logic Certified guys at Apple told me I would not need one - sounds like this is the big problem. I'll use the freeze method when needed also....... maybe I'll have better luck with Groove Agent 3 with the external drive.
    Much appreciated-
    (TBD)
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 11:39 AM in response to: 4feet4
    And free up some room on that system drive.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    Pancenter
    Posts: 3,306
    From: Southwest U.S.
    Registered: Apr 22, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 12:04 PM in response to: 4feet4
    4feet4 wrote:
    L - Thanks for laying that out in simple terms - learning a ton and loving it ( when things work) - I will pick up another Lacie - my old Lacie for my PC crashed - I'm better off starting from scratch ( I'm still trying to retrive some data of the old one) ... I'll let you know how it works. I would have got an external drive outright but the Logic Certified guys at Apple told me I would not need one - sounds like this is the big problem. I'll use the freeze method when needed also....... maybe I'll have better luck with Groove Agent 3 with the external drive.
    Groove Agent 3 loads samples into memory so I doubt if your luck will change.
    The -first- thing I would do is clear some space on your hard drive, my feeling is that OSX is writing swap files and the drive head is working overtime to try and find free space to write. That in itself could cause an overload.
    Free drive space now or expect more problems than you're currently experiencing.
    pancenter-
    Power Mac G5 1.8GHz Dual, 4GB RAM Mac OS X (10.5.5) RME Audio - MOTU MIDI, Mac (Logic 8.02), Intel/XP-Pro Quad Core PC

    _History Below_
    Topic : System Overload ...i know ..I'm not the 1st ...
    This topic has been archived - replies are not allowed.
    Your question is not answered.
    Mark as answered.
    Use the "helpful" or "solved" buttons to award points to replies.
    Subscribe to this Topic Back to Topic List
    Replies : 10 - Pages : 1 - Last Post : Aug 10, 2009 12:04 PM by: Pancenter
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 7:52 PM
    Any quick tips on what to do? My project is small - while monitoring my CPU usage it never goes above 30 while running the project - I've got 2.78 GB of free disk space - 4Gig Ram - I dont use my IMAC OSX 10.5.5 for anything but Logic? Hoping to get around this CONSTANT issue - thanks for your help.
    Imac Mac OS X (10.5.5)
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 9:48 PM in response to: 4feet4
    Well, if you are saying you have only 2.78 GB's of space on your hard drive, then you'll want to have more. You should leave about 10-15% of your drive free.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 9, 2009 10:51 PM in response to: Larry Mal
    I'm running LP8 - I have an IMAC OSX 10.5.5 - 2.4 processor - 4 GB RAM - M-Audio Fast Track Pro interface (USB direct to MAC) - I do NOT have an external hard drive ( sounds like I should ? - although I was told by others my system would be sufficient) - I use ALL instruments/track options ( midi etc) and will need to in the future - I want to be able to run a full music project 10-15 tracks. So far I'm running 4-5 tracks -(1) midi - the rest are audio with little to no effects ( in one project I'm using an LP8 template but deleted most of the tracks to cut down on the load ). Don't know if I can freeze these tracks-I'm new to this - thats why I'm looking for options ........ i was also using a 3rd party software in the project - Steinberg Groove Agent 3 (drums) but it was giving me the same error ..even when it was the ONLY track in the project....(its not fully compatible) - however I was finally able to create a full drum track with GA3 - play the midi data back - and record it to an audio track - therefore deleting the midi data I was having issues with and keeping the drums.... hope this helps?
    Imac Mac OS X (10.5.5)
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 6:39 AM in response to: 4feet4
    Updated
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 7:54 AM in response to: 4feet4
    Perfect. Well here are some suggestions:
    1) Logic 7, 8 and 9 all have a "freeze" function. Logic 9 has a new "bounce in place" function which I haven't used yet. These will make temporary audio files of your MIDI instruments so that you are able to play them as finished audio for the most part and free up CPU power. ( I haven't yet used "bounce in place", I just got Logic 9.) This will help with MIDI instruments quite a bit, and you can still go back and change them by un-freezing... I guess "thawing" would be the proper term.
    2) The reason I was asking about your audio interface is because I was wondering what you had available. You very definitely want to record to a non-system (on that Logic nor your operating system are on) drive. Firewire is much superior to USB, which is why I'm glad to hear you are using USB as your audio in. By using Firewire in and Firewire out, on an iMac, you would be halving the bandwidth. In your case you are not.
    You will add very much stability to your Logic work by adding an external Firewire drive and recording audio to it, and working on Logic projects there! If you have the money, I'd go with Firewire 800, which is frankly overkill, but why not. Firewire 400 drives will work fine for you. Add one and many of the overload messages will disappear, simply because right now you are pulling information from (in the form of calculating what the virtual instruments and Logic are doing) and writing information to (in the form of writing what those instruments and Logic are resulting in) to the same disk.
    Try these two things and get back to us. I think you'll be very happy with the results.
    It's also important to pay attention to your buffer size. When it is not important for you to play with it in real time, you want to make it be 1024. Otherwise as low as possible. So when you are recording audio to a MIDI drum track, you'd want it to be very low so you can play along accurately. When you have all that done, and are editing MIDI only, then put the buffer higher. When mixing, put it higher.
    Let me know how this works, good luck, L
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:10 AM in response to: Larry Mal
    Ok Great - Thanks - makes sense - I was using a Lacie with Protools an my PC ( it recently crashed) - I was under the impression I would have enough processing power with out it on the MAC.
    Looks like I can pick one up for just a little over $100 ( I'm rolling in that kind of cash) ... please clarify though - you stated: "Firewire is much superior to USB, which is why I'm glad to hear you are using USB as your audio in. By using Firewire in and Firewire out, on an iMac, you would be halving the bandwidth. In your case you are not" ....are you GLAD to hear I am using USB as in - We may have found the problem .... go external to free up processing ? Please confirm.
    Thanks again
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    CCTM
    Posts: 249
    Registered: Mar 11, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:28 AM in response to: 4feet4
    4feet4 wrote:
    Ok Great - Thanks - makes sense - I was using a Lacie with Protools an my PC ( it recently crashed) - I was under the impression I would have enough processing power with out it on the MAC.
    As stated in an earlier reply, if you only have 2 or 3 gigs of free space on your Mac hard drive, processing power is NOT the problem. Your boot disc is way too full. You should have at least 20-30GB free.
    Running a second drive for the audio side will, of course, help, but you MUST clear out the main hard drive (or fit a larger one) before you run into even more serious problems.
    HTH
    CCT
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 9:37 AM in response to: 4feet4
    Well, you have enough processing power, that isn't the issue. All the processing power in the world won't matter if you have 64 megabytes of RAM, there will be a bottleneck. Another bottleneck is with data transference. Like I said, when using a single drive to transfer date from as well as to- which is what you are doing when you are using Logic, running within the scope of the operating system, and hosting virtual instruments, all of which is writing the resulting audio information to the same drive, at the same time, then you are creating another problem. But you don't have to do that, by sending the audio written to another drive other than the one the audio is being generated from.
    In other words, your processing power is both faster than and irrelevant to the physical limitations of the hard drive itself.
    Another bottleneck would be if you were recording tracks on a Firewire in, and sending that to and external Firewire drive out. This is one of the limitations of the iMac, there is no way to add what is called another bus, which is simply another pipeline for data transference. You can get around that with a Mac Pro, in which you add another internal hard drive, which connects directly to the motherboard, and has its own bus. Or by adding another Firewire PCIe card, which will add another Firewire bus, again, with its own data transference. On an iMac, you have one Firewire bus, and one USB bus.
    Clear? You can imagine these as pipes of water. The more pipes you have leading to and from a location the faster it will go.
    USB, in your case, is a dedicated pipeline in. Nothing (well, your mouse, maybe a flash drive) is using that pipeline. Your Firewire is a pipeline out, in this case- you could reverse this, it doesn't matter*. If you use Firewire in and out, then you are sending water flowing in both directions in the same pipe. It will work, but not as well. By adding a dedicated bus, you would be adding another pipe to flow in one way, while the original flowed the other way. No impedances.
    I don't see why you can't use the Lacie drive you already have, though. It's quite likely your crash wasn't due to it. No need to buy another drive, if it's Firewire, anyway. Just give it a shot- this isn't a cure all, but just good audio practice. Let me know how it pans out. Good luck, L
    *Firewire is better than USB in all situations. But you seem to be going a track or two of USB audio in, so I'd use USB for that. For light use it's fine. Then you can use your superior Firewire bus to write the audio to the external Firewire drive.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    4feet4
    Posts: 17
    From: Pasadena
    Registered: Mar 12, 2009
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 11:12 AM in response to: Larry Mal
    L - Thanks for laying that out in simple terms - learning a ton and loving it ( when things work) - I will pick up another Lacie - my old Lacie for my PC crashed - I'm better off starting from scratch ( I'm still trying to retrive some data of the old one) ... I'll let you know how it works. I would have got an external drive outright but the Logic Certified guys at Apple told me I would not need one - sounds like this is the big problem. I'll use the freeze method when needed also....... maybe I'll have better luck with Groove Agent 3 with the external drive.
    Much appreciated-
    (TBD)
    Imac Mac OS X (10.5.5) 2.4 Processor, 4 GB RAM, M-Audio Fast Track Pro Interface, No External HD
    Larry Mal
    Posts: 654
    From: Saint Louis, Missouri
    Registered: Sep 27, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 11:39 AM in response to: 4feet4
    And free up some room on that system drive.
    dual 2.8GHz Mac Pro, Macbook Pro 2.16 GHz Mac OS X (10.5.6) 2 GB RAM
    Pancenter
    Posts: 3,306
    From: Southwest U.S.
    Registered: Apr 22, 2007
    Re: System Overload ...i know ..I'm not the 1st ...
    Posted: Aug 10, 2009 12:04 PM in response to: 4feet4
    4feet4 wrote:
    L - Thanks for laying that out in simple terms - learning a ton and loving it ( when things work) - I will pick up another Lacie - my old Lacie for my PC crashed - I'm better off starting from scratch ( I'm still trying to retrive some data of the old one) ... I'll let you know how it works. I would have got an external drive outright but the Logic Certified guys at Apple told me I would not need one - sounds like this is the big problem. I'll use the freeze method when needed also....... maybe I'll have better luck with Groove Agent 3 with the external drive.
    Groove Agent 3 loads samples into memory so I doubt if your luck will change.
    The -first- thing I would do is clear some space on your hard drive, my feeling is that OSX is writing swap files and the drive head is working overtime to try and find free space to write. That in itself could cause an overload.
    Free drive space now or expect more problems than you're currently experiencing.
    pancenter-
    Power Mac G5 1.8GHz Dual, 4GB RAM Mac OS X (10.5.5) RME Audio - MOTU MIDI, Mac (Logic 8.02), Intel/XP-Pro Quad Core PC

  • Solution for "Error while trying to synchronize Audio and MIDI" and "System Overload" messages

    Article for those who hate Logic error windows
    Seen in Logic Pro 9.1.7 on Mac OS X Lion 10.7.4
    and Logic Pro 9.0.0 on Mac OS X Snow Leopard 10.6.5
    Logic Pro:
    System Overload.
    The audio engine was not able to process all required data in time.
    (-10011)
    Error while trying to synchronize Audio and MIDI.
    Sample Rate xxxxx recognized.
    Check conflict between Logic Pro and external device.
    The search in the help given as follows: overload occurs when you use a lot of tracks and a lot of effects on them, and the synchronization is lost when the selected MIDI track for recording or playback. Yes, this is all that is written in the resources. And here are useful tips that have been found:
    The Bounce function allows the entire instrument track to be recorded as an audio file. This bounced audio file can then be used (as an audio region) on a standard audio track, allowing you to reassign the available processing power for further software instrument tracks. For more details, see "Bouncing Your Project."
    You can also make use of the Freeze function to capture the output of a software instrument track, again saving processing power. For details, see "Freezing Tracks in the Arrange Area."
    These tips - about the timing. About overload - there are no tips, except as "reducing the number of plug-ins" and "increasing latency". Zero useful tips - I got two errors in the test project with a blank audio track with no effects, MIDI drums and standard synthesizer, it was no aux buses, and the entire project was only a single plugin in the master track.
    Here is the configuration of my computer:
    iMac12, 2
    CPU: Intel Core i5 3,1 GHz
    Memory: 4 GB
    And here's a project that almost immediately stops Logic, all instruments and plug-ins with the init-patch, ie not the most demanding settings:
    It's sad.
    When this happened the first time, I could start the project only if the empty audio track has been selected, a track specially designed so that you can at least start the project. Then, this problem has evaporated along with the changing conditions of work and I forgot about it until the last case.
    I was looking for the cause of the problem in the console and the system monitor for two days, and finally I found that Logic ping to the network frequently. I remembered the exact time of occurrence of the problem, and system logs revealed that the problems began immediately, as soon as I deactivate the service of the Internet.
    Solution: enable the Internet, or add a new network service on a computer with no Internet. I just created the Ethernet connection to the ip address 1.0.0.0
    Logic immediately began to sing.

    Hi gabaghoul
    Yes, it worked for me on four different OS and Logic versions (10.6 - 10.8 and 9.0 - 9.1.6)
    It does not work in some cases, hard enough to tell in which one, but you can try, it very easy: go to the net settings and create new Ethernet connection to the ip address 1.0.0.0 and connect LAN cable to the port.
    Also you can try to figure out what happens in your system while Logic error occured - fot that you just start Console and search "logicpro"
    Pay attention to repetitive events in a console and events with suitable timing, not so far from error
    The problem may be related to the GUI or system memory, sometimes turning off Safari (or Chrome, others browsers) might help.
    Message was edited by: spred

  • CPU Overload (-10010) with Logic 9.0.2 and SL 10.6.2 after clean install

    Whether using the demo song (Numbers Game), or a new song even with just a couple of instruments (EXS) and a single audio track I get a CPU overload -10010 or -1009 message sometimes every few seconds, sometimes every 30 minutes.
    I thought perhaps a conflict with drivers or other software, so I have tried a clean install of SL10.6, updated to 10.6.2, loaded Logic Pro, updated to 9.0.2, and added NO OTHER SOFTWARE AT ALL, and used internal audio, still same problem.
    This seems to be a bug in Logic or SL. What can I do?
    Message was edited by: ebjornard

    This is no bug, your system is telling you that it cannot handle the full load of this song. Try Freezing tracks with heavy CPU-using plugins on them.
    Also, check (and bookmark!) these docs:
    http://support.apple.com/kb/TA24535?viewlocale=en_US
    http://support.apple.com/kb/HT3161
    http://support.apple.com/kb/HT2375
    and especially:
    http://discussions.apple.com/thread.jspa?threadID=2175192&tstart=0

  • Logic error-hard drive too slow or system overload (new macbook!)

    have made a few short tracks with logic with no probs. when i have tried to play the demo songs which have many tracks, i get an error msg saying hd too slow or system overload. i have a new macbook, 2.4, 2mb ram, 250 gb hd (with loads space left). airport turned off when using logic. what gives???

    Samples that I am using are located on a 7200 external HD.
    Is your external formatted for Mac? If you didn't buy it from a store that sells mac drives specifically, it's probably formatted for windows. You must reformat for Mac or you'll have a lot of performance issues.
    I've a Macbook 2,2 Ghz Core 2 DUO with 2Go of RAM.
    You should get more Ram, it's really cheap these days.
    Airport is disconnected. My AUdio Buffer is 1024 in the Logic preferences.
    Make sure the I/O Safety Buffer is OFF, and then set the buffer size at 256 or 512.

  • "system overload" in logic pro 8 on my Mac Pro with only three tracks

    I am running Logic Pro 8, on a 2.66 Quad Core Mac Pro w/ only 1GB of RAM. I have not had the money for the much needed ram upgrade, yet.
    The day before yesterday I opened a project I had opened many times, with only three tracks - two audio and a midi synth with only a few notes. These tracks are fairly well plugin-ed up, but this Mac Pro has always eaten them up, no problems. When I tried to play the project, I got system overloads every 2 seconds, rather precisely actually. My CPU usage reads low in logic and with iStat, but suddenly it peaks to 100% on my third core and I get the system overload.
    I had my buffer size at 128, so I switched it to 1024, it worked, and then I switched it back again and everything worked like it used to!
    But now I have to go through this slightly illogical little procedure everytime I open a project. I have read threads here about this subject before, back I cant seem to apply them / understand them in relation to my particular situation.
    any ideas?

    Join the club...wait for them to patch/update it.
    I've tried the various work arounds, sometimes they work temporarily, sometimes not at all.
    For the overloads the most reliable "work around" is to select each track, open the VI/FX modules associated with that track, then close them, go to the next track and repeat the process. OR, if you know all the modules (VI/FX) you're using, just open each one. This will "initialize" their existance BEFORE the audio engine hits them in playback.
    My guess is LP8 tries to reduce it's memory foot print and does NOT initialize all the VI/FX in a saved project that is just opened until it actually needs to use them -- a good idea one would think. However, when you do your playback and it hits the VI/FX for the first time (after you just opened your saved project) it appears the audio engine stalls waiting for the VI/FX to initialize the 1st time around and hence the overloads error. Obviously I can't prove this since I don't have access to the code, but I'm a developer and this would be my logical guess based on the evidence at hand.
    I can reproduce the problem consistently:
    1. Start LP8
    2. Open existing project with 3 tracks (staggered to start a different times) with different VI on each track
    3. Have 3 buses with a different FX on each bus
    4. Do nothing other than hit Play
    Overload when it hits start of 1st track VI, stop, restart, overloads when it hits start point of 2nd track VI, stop restart, overloads when it hits start point of 3rd track.
    Why wasn't something this obvious caught in testing? Good question.
    Rob.
    Message was edited by: Rob A.

  • Is my CPU really overloaded....why all the crashes?

    I'm on a quad core G5 with oodles of RAM running 10 or so tracks of pretty big multilayered Audio Instruments. My monitors say I've plenty of RAM left and plenty of CPU power to spare. In fact only 3 of the 4 processors seem to be being used. But I keep crashing and getting Core Audio overload error messages. This happens upon loading the song too as the samples load. Whatever song I create runs into the same problem at about the same stage of it's development. Any ideas?
    G5 Quad Core   Mac OS X (10.4.6)   16GB RAM
    G5 Quad Core   Mac OS X (10.4.6)   16GB RAM
    G5 Quad Core   Mac OS X (10.4.6)   16GB RAM
    G5 Quad Core   Mac OS X (10.4.6)   16GB RAM

    Thanks both!
    My songs are on my primary hard drive with Logic application and with the external sample players I'm using (Kompakt with East/West Symphonic Orchestra).
    The samples libraries are on the second hard drive. Should the songs be there too?
    Justin, what do you mean by search benchmark song 2. Sorry for being dense here! Many thanks. I'd heard of Logic only assigning itself a fixed amount of RAM...one of those small but crucial bits of infor that apple and Logic don't like to announce I imagine...
    Thanks.

  • TS2529 I understand that iTunes 10.7 is available, but when I try to download, I still show 10.6. etc.  Is this just a matter of the servers being overloaded with requests right now ?  TIA

    I understand that iTunes 10.7 is available, but when I try to download, I still show 10.6. etc.  Is this just a matter of the servers being overloaded with requests right now ?  TIA

    There are intermittent issues reported with iTunes reporting that the update is available, but ASU not showing it as an option to install. (Got that a bit with the last 10.6.x version, too.)
    If that's what is going on, I'd try updating your iTunes using an iTunesSetup.exe (or iTunes64Setup.exe) installer file downloaded from the Apple website:
    http://www.apple.com/itunes/download/

  • Is there a way to overload the Map's toString() function?

    Hello everyone. I was wondering if its possible to overload the toString() function of the Map datastructure supplied by java.
    I looked it up and it says:
    public class HashMapextends AbstractMapSo I looked up AbstractMap and it says:
    public abstract class AbstractMapextends Objectimplements MapAnd I found a toString() function in the AbstractMap saying:
    toString
    public String toString() Returns a string representation of this map. The string representation consists of a list of key-value mappings in the order returned by the map's entrySet view's iterator, enclosed in braces ("{}"). Adjacent mappings are separated by the characters ", " (comma and space). Each key-value mapping is rendered as the key followed by an equals sign ("=") followed by the associated value. Keys and values are converted to strings as by String.valueOf(Object). This implementation creates an empty string buffer, appends a left brace, and iterates over the map's entrySet view, appending the string representation of each map.entry in turn. After appending each entry except the last, the string ", " is appended. Finally a right brace is appended. A string is obtained from the stringbuffer, and returned.
    here: http://java.sun.com/j2se/1.3/docs/a...ml#toString()So I did the following:
    package parse;
    import java.util.ArrayList;
    import java.util.HashMap;
    import java.util.Iterator;
    import java.util.List;
    import java.util.Map;
    import java.util.Set;
    import java.io.*;
    //this class should store all the Messages or "Events" and
    //you can access them based on their EntityID key.
    public class MessageDB extends HashMap
         //database to hold the information
         //     holds the Alerts/messages
         public static Map<Integer, List<String>> AlertMap;
         //Constructor
         MessageDB()
              AlertMap = new HashMap<Integer, List<String>>();
         public String toString()
              return ( )//not sure what to put here...
         //print, outputs the contents of the hashMap
         public static void print()
            //want to print out the Key and all the Messages
              //associated with that key
              Set keys = AlertMap.keySet();          // The set of keys in the map.
              Iterator keyIter = keys.iterator();
              System.out.println("The map contains the following associations:");
              while (keyIter.hasNext()) {
                    Object key = keyIter.next();  // Get the next key.
                    Object value = AlertMap.get(key);  // Get the value for that key.
                    System.out.println( "EntityID: " + key + "\n"
                                  + "Message: " + value + "\n" );
         //overloaded print to print to user screen.
         public static void print(PrintWriter out)
              //want to print out the Key and all the Messages
              //associated with that key
              Set keys = AlertMap.keySet();          // The set of keys in the map.
              Iterator keyIter = keys.iterator();
              out.println("The map contains the following associations:");
              out.flush();
              while (keyIter.hasNext()) {
                    Object key = keyIter.next();  // Get the next key.
                    Object value = AlertMap.get(key);  // Get the value for that key.
                   //out.flush();
                   /* out.println( "   (" + key + "," + value + ")" );
                   out.flush();*/
                   // out.println("------------------\n");
                   out.println("EntityID: " + key + "\n"
                                  + "Message: " + value + "\n");
                   //out.println("------------------\n");
                   out.flush();
         void add(Message msg)
              //getting the position of the List by EntityID if avaiable
              List<String> Alert = AlertMap.get(msg.entityID);
              //checking to see if there is a unique Key already in the Map.
              if (Alert == null)
                   //if there isnt a key in the map, add a new key, and a new List mapping
                   //to the key EntityID;
                     Alert = new ArrayList<String>();
                     AlertMap.put(msg.entityID, Alert);
                     Alert.add(msg.message);
              else
              //adding message to List
                   Alert.add(msg.message);
    }Right now the output is like this:
    The map contains the following associations:
    EntityID: 99999
                      Message: [a test ]
    EntityID: 800
                    Message: [this is a test , again a test ]
    EntityID: 801
                    Message: [again a test ]
    EntityID: 111
                    Message: [a test again yes , a test once again ]You see how its automatically doing [message1, message2,...,message x]
    By me calling this line of code:
    out.println("EntityID: " + key + "\n"
                                  + "Message: " + value + "\n");Because I found out it implicity calls the toString() method when concatinating it to a string.
    What I would like it to display would be:
    EntityID: 800
    Message:
    This is a test
    This is a test again
    any ideas would be great!
    Or is there a way to just iterate over the messages, rather than doing it my way?
    Message was edited by:
    lokie

    Hi,
    When you do a String concatenation in java, calls are implicitly done to #toString().
    Means, you are doing this:
    while (keyIter.hasNext()) {
                    Object key = keyIter.next();  /
                    Object value = AlertMap.get(key); 
                    System.out.println( "EntityID: " + key.toString()+ "\n"
                                  + "Message: " + value.toString() + "\n" );
    }The "[ [/b]... [b], ... , ... ]" you can see in your output is created by the implicit call to List#toString() method.
    You can Override it in an anonymous class by doing:
    if (Alert == null)
                   //if there isnt a key in the map, add a new key, and a new List mapping
                   //to the key EntityID;
                     Alert = new ArrayList<String>(){
                              @Override
                               public String toString(){
                                StringBuilder sb = new StringBuilder();
                       for(String s: this){
                        sb.append(s);
                        sb.append("\n");
                               return sb.toString();
                             };PS:
    toString() is usually used for debbuging only...

  • NAT overload is not working when i configure Double NAT for VPN

    I have Cisco 2921 router with OS version 15.1(4)M1.
    the router is configured for NAT overload and working fine, i have site to site VPN tunnel with peer with normal NAT translation. now we need to configure Double NAT on the VPN tunnel as we need to free the subnet on peer network. for double nat i use 3.2.21.x - 3.2.23.x / 24 network and apply following command
    Double NAT translation
    ip nat inside source static network 192.168.10.0 3.2.21.0 /24 no-alias
    ip nat inside source static network 192.168.20.0 3.2.22.0/24 no-alias
    ip nat inside source static network 192.168.30.0 3.2.23.0 /24 no-alias
    Nonat
    access-list 101 deny   ip 3.2.21.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 3.2.22.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 3.2.23.0 0.0.0.255 3.2.1.0 0.0.0.255
    VPN encrypted traffic over the tunnel
    access-list 115 permit ip 3.2.21.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 115 permit ip 3.2.22.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 115 permit ip 3.2.23.0 0.0.0.255 3.2.1.0 0.0.0.255
    Problem:
    as soon as i apply Double NAT translation command the  NAT overload stop working and client cannot reach to the internet
    the router partial configuration is as below
    REACH-R01(config)#do sh run
    Building configuration...
    Current configuration : 19233 bytes
    ! Last configuration change at 09:56:45 MST Tue Jan 29 2013 by admin
    ! NVRAM config last updated at 13:57:54 MST Wed Jan 30 2013
    ! NVRAM config last updated at 13:57:54 MST Wed Jan 30 2013
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname REACH-R01
    boot-start-marker
    boot-end-marker
    card type t1 0 0
    logging buffered 51200 warnings
    no aaa new-model
    clock timezone MST -7 0
    clock summer-time MST recurring
    network-clock-participate wic 0
    network-clock-select 1 T1 0/0/0
    no ipv6 cef
    ip source-route
    ip cef
    ip dhcp excluded-address 192.168.20.1 192.168.20.99
    ip dhcp excluded-address 192.168.20.250 192.168.20.255
    ip dhcp pool CISCO_PHONES
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.254
    option 150 ip 192.168.20.254
    no ip domain lookup
    ip domain name reach.local
    ip inspect name ethernetin ftp timeout 3600
    ip inspect name ethernetin h323 timeout 3600
    ip inspect name ethernetin http timeout 3600
    ip inspect name ethernetin rcmd timeout 3600
    ip inspect name ethernetin realaudio timeout 3600
    ip inspect name ethernetin smtp timeout 3600
    ip inspect name ethernetin sqlnet timeout 3600
    ip inspect name ethernetin streamworks timeout 3600
    ip inspect name ethernetin tcp timeout 3600
    ip inspect name ethernetin tftp timeout 30
    ip inspect name ethernetin udp timeout 15
    ip inspect name ethernetin vdolive timeout 3600
    multilink bundle-name authenticated
    isdn switch-type primary-ni
    trunk group PRI
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-3180627716
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3180627716
    revocation-check none
    rsakeypair TP-self-signed-3180627716
    voice-card 0
    dsp services dspfarm
    voice service voip
    allow-connections sip to sip
    fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
    sip
    voice translation-rule 1
    rule 5 /^7804981231/ /401/
    voice translation-rule 2
    rule 5 // /7804981231/
    voice translation-profile DID_INBOUND
    translate called 1
    voice translation-profile DID_OUTBOUND
    translate calling 2
    license udi pid CISCO2911/K9 sn FGL1540114P
    license accept end user agreement
    license boot module c2900 technology-package securityk9
    hw-module ism 0
    hw-module pvdm 0/0
    username test test
    redundancy
    controller T1 0/0/0
    cablelength long 0db
    pri-group timeslots 1-6,24
    no ip ftp passive
    crypto isakmp policy 10
    encr aes 256
    authentication pre-share
    group 2
    crypto isakmp key P@ssw0rd address 33.33.33.33 no-xauth
    crypto ipsec transform-set ESP-AES256-SHA esp-aes 256 esp-sha-hmac
    crypto map VPN-TUNNEL 1 ipsec-isakmp
    description COMPUGEN
    set peer 33.33.33.33
    set transform-set ESP-AES256-SHA
    match address 115
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description Outside Interface To the Internet
    ip address dhcp
    ip access-group outside_access_in in
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    crypto map VPN-TUNNEL
    interface ISM0/0
    ip unnumbered GigabitEthernet0/1.20
    service-module ip address 192.168.20.2 255.255.255.0
    !Application: CUE Running on ISM
    service-module ip default-gateway 192.168.20.254
    interface GigabitEthernet0/1
    no ip address
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface GigabitEthernet0/1.10
    description VLAN 10 DATA VLAN
    encapsulation dot1Q 10
    ip address 192.168.10.254 255.255.255.0
    ip nat inside
    ip inspect ethernetin in
    ip virtual-reassembly in
    interface GigabitEthernet0/1.20
    description VLAN 20 VOICE VLAN
    encapsulation dot1Q 20
    ip address 192.168.20.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    interface GigabitEthernet0/1.30
    description VLAN 30 WIRELESS VLAN
    encapsulation dot1Q 30
    ip address 192.168.30.254 255.255.255.0
    ip nat inside
    ip inspect ethernetin in
    ip virtual-reassembly in
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface ISM0/1
    description Internal switch interface connected to Internal Service Module
    no ip address
    interface Serial0/0/0:23
    no ip address
    encapsulation hdlc
    isdn switch-type primary-ni
    isdn incoming-voice voice
    trunk-group PRI
    no cdp enable
    interface Vlan1
    no ip address
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip http path flash:CME8.6/GUI
    ip nat inside source static tcp 192.168.10.10 443 interface GigabitEthernet0/0 443
    ip nat inside source static tcp 192.168.10.10 25 interface GigabitEthernet0/0 25
    ip nat inside source static tcp 192.168.10.10 1723 interface GigabitEthernet0/0 1723
    ip nat inside source static tcp 192.168.10.10 3389 interface GigabitEthernet0/0 3389
    ip nat inside source static tcp 192.168.10.10 123 interface GigabitEthernet0/0 123
    ip nat inside source static tcp 192.168.10.10 987 interface GigabitEthernet0/0 987
    ip nat inside source list 101 interface GigabitEthernet0/0 overload
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 75.152.248.1
    ip route 0.0.0.0 0.0.0.0 75.152.248.1 254
    ip route 0.0.0.0 0.0.0.0 205.206.0.1 254
    ip route 192.168.20.2 255.255.255.255 ISM0/0
    ip access-list extended outside_access_in
    permit udp any any eq bootps
    permit udp any any eq bootpc
    permit tcp any host 22.22.22.22 eq 1723
    permit tcp any host 22.22.22.22 eq 3389
    permit tcp any host 22.22.22.22 eq smtp
    permit tcp any host 22.22.22.22 eq 443
    permit tcp any host 22.22.22.22 eq domain
    permit udp any host 22.22.22.22 eq domain
    permit tcp any host 22.22.22.22 eq 123
    permit icmp any host 22.22.22.22 unreachable
    permit icmp any host 22.22.22.22 echo-reply
    permit icmp any host 22.22.22.22 packet-too-big
    permit icmp any host 22.22.22.22 time-exceeded
    permit icmp any host 22.22.22.22 traceroute
    permit icmp any host 22.22.22.22 administratively-prohibited
    permit icmp any host 22.22.22.22 echo
    permit tcp any host 22.22.22.22 eq 987
    permit tcp any host 22.22.22.22 eq 47
    permit gre any host 22.22.22.22
    permit udp any host 22.22.22.22 eq isakmp
    permit esp any host 22.22.22.22
    access-list 23 permit any
    access-list 101 deny   ip 192.168.20.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 192.168.30.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 192.168.10.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 3.2.21.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 3.2.22.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 deny   ip 3.2.23.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 101 permit ip 192.168.10.0 0.0.0.255 any
    access-list 101 permit ip 192.168.20.0 0.0.0.255 any
    access-list 101 permit ip 192.168.30.0 0.0.0.255 any
    access-list 110 permit ip 0.0.0.0 255.255.255.0 0.0.0.0 255.255.255.0
    access-list 115 permit ip 3.2.21.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 115 permit ip 3.2.22.0 0.0.0.255 3.2.1.0 0.0.0.255
    access-list 115 permit ip 3.2.23.0 0.0.0.255 3.2.1.0 0.0.0.255
    Solution: Support forums team

    I have the same problem also.  Restarting isn't helping and the auto lock/unlock button is on.  Plus a couple of time when I turn it on it is asking if I want to power off.  That is when I push the button on the front to wake it up.  Not the power button on top.  I have an IPAd 2. Worked fine before the update. 

Maybe you are looking for

  • I have two iTunes accounts, can I load content from both onto iPhone

    I had an iPod from a couple years ago and and I have an iPhone now. They are under two different iTunes and apple id's. The IPod was stolen from me recently and I was wondering if I can get everything from my iPods account onto iPhone?

  • IDM 8.1 with firefox does not show all GUI items

    Hi, we are running IDM 8.1 Patch_5 on Solaris 10. We have 2 instances, Prod & UAT. UAT runs from Tomcat 5, Prod uses Sun Appserver 8. But our problem seems to be the Web Client. When We lookup a user and then open the tabs for them, for example "Secu

  • RFC call on click of button

    Hi, I need to make RFC call to  ABAP function module with some input parameters. On click of a button, I need to navigate between views based on returned values. I have followed steps similar to FlightList example. Created a  model, custom controller

  • Changing a DataSet Schema

    Post Author: kjlj CA Forum: .NET I'm using Crystal Reports for Visual Studio 2003 and have a ADO.Net Dataset as the datasource. I added several fields to one of the tables in the dataset. Is there any way to get the report to use the new schema with

  • Backing up controlfile to trace, but in a diff location

    With the alter database backup controlfile to trace, how can I specify a diff. location. I tried it this way but got an error: I want to move it to another location so that one of my scripts can pick up this file and move it somewhere else (part of a