Pointer Confusion + global JTree

Hi there,
I wonder if it is possible to change the JTree represented in a JScrollPane if defined as follows:
class A extends JPanel{
static JTree m_tree;
A(){
JScrollPane treeView = new JScrollPane(m_tree);
JSplitPane splitPane = new JSplitPane( JSplitPane.HORIZONTAL_SPLIT, treeView,someOtherView );
this.setLayout(new BorderLayout());
this.add("Center", splitPane );
what I want to do is to show a completely different JTree (not just modifying certain elements, but exchanging it as a whole). Can this be done? I am rather sure, that it is possible, but I don't have an idea how, right at the moment. Should a method like:
public static void set_and_Show_New_Tree(JTree tree){
A.m_tree = tree;
A.getContentPane().validate()
be enough? I don't think so, because m_tree is not a pointer, but a complete Instance, so the contentpane does not know that there is a new JTree. But how to propagate this information and delete the old tree??
I would really be grateful for any help :).
Sincerely
JebeDiAH

Hi there,
I wonder if it is possible to change the JTree represented in a JScrollPane if defined as follows:
class A extends JPanel{
static JTree m_tree;
A(){
JScrollPane treeView = new JScrollPane(m_tree);
JSplitPane splitPane = new JSplitPane( JSplitPane.HORIZONTAL_SPLIT, treeView,someOtherView );
this.setLayout(new BorderLayout());
this.add("Center", splitPane );
what I want to do is to show a completely different JTree (not just modifying certain elements, but exchanging it as a whole). Can this be done? I am rather sure, that it is possible, but I don't have an idea how, right at the moment. Should a method like:
public static void set_and_Show_New_Tree(JTree tree){
A.m_tree = tree;
A.getContentPane().validate()
be enough? I don't think so, because m_tree is not a pointer, but a complete Instance, so the contentpane does not know that there is a new JTree. But how to propagate this information and delete the old tree??
I would really be grateful for any help :).
Sincerely
JebeDiAH

Similar Messages

  • Access point confusion

    Hey thanks! So is each access point connected to a cable, but just from behind the device if it's not daisy chained? I guess this is the most confusing to me. Sorry to be a pain! ha

    All of the jobs that I have had mainly were end user support, hardware/software support. Some server management in AD , Exchange, etc. Virus removal, training, along with network support. Everything though, was pre-existing so I had never set up an entire network from nothing, on my own. Where I work they are installing around 15-20 access points since the building is huge. I am not sure, if any how involved i will be but would like to get some knowledge from people with experience because I want to learn and ensure that I understand what is going on.How are these connected, exactly? When you look at them, they appear to be just on the ceiling or wall with no cords at all (Maybe the Ethernet is hidden?) but lit up. I believe they are POE so they will only require an Ethernet cord, right? How are they connected? To where? Is each one...
    This topic first appeared in the Spiceworks Community

  • End point confusion for connecting lines

    Am I stupid or is it iWorks?
    I often create two text boxes and connect them.
    Generally I want an arrow two the right, but each time I go to the inspector and select an endpoint, it always points in a random direction. Using the right hand one to add an arrow on the right does not always work that way - often it adds an arrow on the left.
    Is there any rule here or is this something Apple did just to frustrate the tourists?
    Thanks
    Peter

    No, it's not just you. It makes me crazy. I'm laughing now, but I make it a game - statistically how often can I get it wrong. Surprisingly, it's well over 50% of the time. So I think it knows where you want the arrow to go, and puts it in the other place. If in a hurry, or doing a lot of them, it is VERY annoying. Apple, make it so that the arrow goes towards the second object selected. C'mon!

  • IEEE-754-Standard floating point confusion

    Hi there,
    I am really confused. The datatype double should be in C++ and Java the same standard acc. to IEEE-754.
    But when I try to investigate the several bytearrays created from a double value e.g. 1.1d, it is different in C and Java.
    below are the results:
    Value 1.1 in C++
    intCsigned
         bit0     bit1     bit2     bit3     bit4     bit5     bit6     bit7
    byte0     1     1     0     0     1     1     0     1     -51
    byte1     1     1     0     0     1     1     1     0     -52
    byte2     1     0     0     0     1     1     0     0     -116
    byte3     0     0     1     1     1     1     1     1     63
    byte4     1     1     0     0     1     1     0     0     -52
    byte5     1     1     0     0     1     1     0     0     -52
    byte6     1     1     0     0     1     1     0     0     -52
    byte7     1     1     0     0     1     1     0     0     -52
    Value 1.1 in Java
    intJava(signed)
    byte0     0     0     1     1     1     1     1     1     63
    byte1     1     1     1     1     0     0     0     1     -15
    byte2     1     0     0     1     1     0     0     1     -103
    byte3     1     0     0     1     1     0     0     1     -103
    byte4     1     0     0     1     1     0     0     1     -103
    byte5     1     0     0     1     1     0     0     1     -103
    byte6     1     0     0     1     1     0     0     1     -103
    byte7     1     0     0     1     1     0     1     0     -102
    Can please somebody bring light into that?????
    Does somebody know the exact specification of a double datatype in c++ and java?
    with the best regards,
    stonee

    OK,
    It seems my C-program created a bad array. I finally
    found out, that the Java and C Array of each double is
    exactly turned.
    C[0] == J[7]
    C[1] == J[6]
    C[2] == J[5]
    its probably big endian vs little endian issues plus on top of that nibble swapping.
    I happen to be working on this very problem at this instant. I'll see what I can dig up.

  • Confusion building JTree from path strings

    If I have a bunch of strings like this:
    "/dira/dir1/file1"
    "/dira/dir1/file2"
    "/dira/dir2/file1"
    "/dira/dir3/anotherdir/file1"
    etc.
    Does anybody have an easy solution to getting them in a JTree that looks like this:
       dira
        |
        +-dir1
        |  |
        |  +-file1
        |  |
        |  +-file2
        |
        +-dir2
        |  |
        |  +-file1
        |
        +-dir3
           |
           +-anotherdir
              |
              +-file1Mainly I am having trouble getting the tree to populate without duplicating nodes. For example dir1 gets listed twice. I am looking for a solution that will parse these strings and build the tree. I have found demos that read a file system, but nothing that works with strings. I have tried to pick apart the file system demos, but so far I can't get it to work correctly.
    Thanks,
    Jeff

    This compiles and works (with 1.4):
    import java.awt.*;
    import javax.swing.*;
    import javax.swing.tree.*;
    import java.util.HashMap;
    public class TreeStrings extends JFrame {
        public TreeStrings() {
            super("Tree strings");
            setDefaultCloseOperation(EXIT_ON_CLOSE);
            setSize(500, 400);
            String[] inputStrings = {"/dira/dir1/file1", "/dira/dir2/file1", "/dira/dir2/file2"}; // your bunch of Strings     
         DefaultMutableTreeNode rootNode = new DefaultMutableTreeNode("www");
         HashMap nodeMap = new HashMap();
         for(int i = 0; i < inputStrings.length; i++) {
             String s = inputStrings;
         DefaultMutableTreeNode lastNode = rootNode;
         int lastIndex = 0;
         while(true) {
              DefaultMutableTreeNode tempNode = null;
              int nextIndex = s.indexOf("/", lastIndex + 1); // <- i forgot + 1
              if(nextIndex != -1) { //we are somewhere in middle of s, checking nodes from root to leaf, one by one.
         String nodeKey = s.substring(0, nextIndex);
         if(nodeMap.get(nodeKey) == null) { //no such node, must make one
              String nodeName = s.substring(lastIndex, nextIndex); // you want the last nodeKey word for node name
         DefaultMutableTreeNode newNode = new DefaultMutableTreeNode(nodeName);
         nodeMap.put(nodeKey, newNode);
         lastNode.add(newNode);
         lastNode = newNode;
         else { //allready such node, just put it to be lastNode
         lastNode = (DefaultMutableTreeNode) nodeMap.get(nodeKey);
    lastIndex = nextIndex;
         else { //no more "/" , it means we are at end of s, and that all parent nodes for this leaf-node exist.
         // and we just add the leaf node to last node
         String leafName = s.substring(lastIndex, s.length());
         DefaultMutableTreeNode leafNode = new DefaultMutableTreeNode(leafName);
         lastNode.add(leafNode);
         break; // go to next s
         //You first make your tree structure with DefaultMutableNodes,
         //Then make a DefaultTreeModel with the root node,
         //Then make a Tree with the DefaultTreeModel
         DefaultTreeModel treeModel = new DefaultTreeModel(rootNode);
    JTree yourTree = new JTree(treeModel);
    getContentPane().add(yourTree, BorderLayout.CENTER);
    show();
    public static void main(String[] args) {
         new TreeStrings();
    Anything else?

  • Redundant access from MPLS VPN to global routing table

    Several our customers have MPLS VPNs deployed over our infrastructure. Part of them requires access to Internet (global routing table in our case).
    As I'm not aware of any methods how to dynamicaly import/export routes between VRF/Global routing tables, at the moment there are static routes configured - one inside VRF pointing to global next hop, another one in global routing table, pointing to interface inside VRF.
    Task is to configure redundant access to Internet. By redundancy I mean using several exit points (primary and backup), what physically represents separate boxes.
    Here comes tricky part - both global static routes (on both boxes, meaning) are valid and reachable in all cases - no matter if specific prefix is reachable in VRF or not. What I'd like to achieve is that specific static route becomes valid only if specific prefix is reachable inside VRF. Yea, sounds like dynamic routing :), I know
    OK, hope U got the idea. Any solutions/recommendations ? Running all Internet routing inside VRF isn't an option, at least for now :(

    Hi Andris,
    I did not mean to have a VRF on the CE. The CE would have both PVCs in the global routing table - his ONLY routing table in fact. One PVC would be used to announce routes into the customer specific VPN (VRF configured on the PE). The other PVC would allow for internet access through the PE (global IP routing table on the PE).
    dot1q will be ok as well.
    This way the CE can be a normal BGP peer to the PE, i.e. there is no MPLS VPN involved here. This allows all options of customer-ISP connectivity.
    Example:
    PE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0/0.1 point-to-point
    description customer VPN access
    ip vrf customer
    ip address 10.1.1.1 255.255.255.252
    interface Serial0/0.2 point-to-point
    description customer Internet access
    ip address 192.168.1.1 255.255.255.252
    router rip
    address-family ipv4 vrf customer
    version 2
    network 10.0.0.0
    no auto-summary
    redistribute bgp 65000 metric 5
    router bgp 65000
    neighbor 192.168.1.2 remote-as 65001
    address-family ipv4 vrf customer
    redistribute rip
    CE config:
    interface Serial0/0
    encapsulation frame-relay
    interface Serial0.1 point-to-point
    description VPN access
    ip address 10.1.1.2 255.255.255.252
    interface Serial0.2 point-to-point
    description Internet access
    ip address 192.168.1.2 255.255.255.252
    router bgp 65001
    neighbor 192.168.1.1 remote-as 65000
    router rip
    version 2
    network 10.0.0.0
    no auto-summary
    Of course you can replace RIP with whatever is suitable for you. And don´t sue me when you do not apply required BGP filters for internet access... ;-)
    The other option ("mini internet") would be feasible as well. Just make sure your BGP filters are NEVER messed up and additionally apply a limit on the numbers of prefixes in your VRF mini-internet.
    Regards
    Martin

  • What is meant by change pointer and change request

    hi,
    what is meant by change pointer and change request in sap r3
    plz can u any one notes or link on this , or if possible briefly tell about this..
    i am looking for clear idea on this..
    thanks
    Ruban

    With respect to Dictionary Change pointers means all the changes done to dictionary objects.
    All the change logs with respect to tables are stored in CDHDR and CDPOS table
    Change Pointers in broad sense are used with respect to IDOC
    Change Pointers & Reduction of IDOCs.
    Applications, which write change documents, will also try to write change
    pointers for ALE operations. These are log entries to remember all modified
    data records relevant for ALE.
    Following Steps must be followed in case of Change Pointer.
    1) Goto Transaction BD60.
    Note down the Details of the Message Type for which change pointer has to activate. Details like Function Module, Classification Object, ALE object Type etc.
    E.g. ZDEBP3
    2) Next step is goto transaction BD53
    Click on change button.
    First select the segment for which the fields has to modified (either remove or
    add ).
    It will show the fields in a pop-up window where the user can select, deselect the respective fields.
    Save the settings for the Message type. Don’t forget to activate the change pointers by clicking Activate Change pointers button on the main screen.
    3) Once the activation is done system will reset the settings for the Message type in Change pointers (BD60). Maintained the old settings for the Message type.
    Check this FAQ
    . Do you really need change pointers?
    You need change pointers to distribute changes with the ALE SMD tool. If you do not use this tool, you do not need to write change pointers.
    You can deactivate change pointers and activate them again with the transaction BD61.
    2. Do you really need to activate change pointers for this messages type?
    If some messages types are no longer to be distributed by change pointers, you can deactivate change pointers for this messages type.
    You can deactivate change pointers for the message type
    and reactivate them again.
    For reduced message types, deactivate the change pointer with the
    Reduction tool (transaction BD53).
    3. Are there still too many change pointers to be processed?
    The change pointers are analyzed with the transaction BD21 or the report RBDMIDOC in ALE and flagged as processed. If the change pointers are created periodically, this report should also run periodically.
    4. Are no longer required change pointers reorganized in time?
    The report RBDCPCLR (transaction BD22) to reorganize the change pointer should run periodically. Depending on how many change pointers are created or processed, you can schedule the background job hourly, daily or weekly. You should delete all obsolete and processed change pointers. You can also use this report for specified message types.
    We come across change pointer technique while dealing with master data distribution thru ALE/IDOCs
    When we want to reflect changes made to master data(i.e customer master, vendor master, material master ...) visible to other clients listed in customer distribution model, we follow change pointer technique.
    What is customer distribution model?
    A customer model depicts various messages (master data, transactional data) exchanged between the systems and establishes a sender and receiver of data
    A customer model is always maintained on any system for the entire distributed network of SAP systems, so it must be distributed to various systems in the distributed network.
    These r some details regarding change pointer technique which u may find it usefull.............
    The change pointers technique is based on the change document technique, which tracks changes made to key documents in SAP, such as the material master, customer master, vendor master & sales orders. changes made to a document are recorded in the change document header table CHDHR, and additional change pointers are written in the BDCP table for changes relevant to ALE. BDCPS table stores the status of changed documents processed or not.
    The process for distributing master data using change pointers involves the following steps.
    The application writes change documents. SAP maintains change documents for
    several objects in the system, such as materials, customers, invoices, and bank data, to provide an audit trail for changes made to an object. A change document object represents a set of tables for which changes are recorded. For example, the change document for the material master is named MATERIAL and it contains the various tables of the material master object, such as MARA and MARC.
    When an application transaction makes changes to an object, the application writes change documents, which are stored in the CDHDR and CDPOS tables for each change made to an object.
    Tip
    Execute transaction SCDO to see a list of change document objects and
    their tables.
    The SMD (Shared Master Data) tool writes change pointers. When changes are made to an object, the SMD tool checks the ALE settings and consults the ALE distribution model to determine whether a receiver is interested in the object that was changed. If the system finds an appropriate receiver, the system creates change pointers in the BDCP table that point to change documents in the CDHDR table.
    The ALE programs analyze change pointers and generate IDocs. SAP provides
    standard function modules that read the change pointer table and generate IDocs for the objects that were changed. These programs are designed to ignore multiple changes and create only one IDoc. For example, if a material is changed four times before the function module is invoked, only one IDoc with the latest data from the material master data is created. The function modules are invoked by a standard report, RBDMIDOC. The selection parameters of this report allow you to specify the message type for which change pointers are to be analyzed. Configuration
    you must carry out the following configuration steps to enable master data
    distribution based on changes to the object.
    Step 1: Enable Change Pointers Globally
    Transaction: BD61
    This option enables the change pointer process globally. Make sure that the flag is checked.
    Step 2 :Enable Change Pointers for a Message Type
    Transaction: BD50
    This setting is required for activating change pointers for a specific message type.
    make sure that the Active flag is checked for your message type.
    Step 3 :Specify the Fields for Which Change Pointers Are to Be Written
    Transaction: BD52
    For standard master data objects such as the material, customer, and vendor objects, SAP already provides a list of fields for which change pointers are written. If you are satisfied with the standard set of fields, you can skip this step. If you want to add new fields, you must add entries for the required fields. If you are not interested in IDocs being generated for changes to a particular field, you can remove it from the list. For example, if you do not want to distribute the
    material master for changes made to the Catalog Profile (RBNRM) field, you can delete this entry from the table.
    Step 4: Changing a Field in the Master Data
    Change a field in the master data object for which the change pointer is enabled. For example, if you change the net weight of a material in the material master data, a change pointer is written.
    Tip : You can verify a change document and change pointer by viewing entries in
    tables CDHDR and BDCP, respectively.
    Step 5 :Executing Program RBDMIDOC to Process Change Pointers
    Execute program RBDMIDOC to initiate the process of generating an IDoc. On the selection screen, specify the message type. For example, you can specify MATMAS. After you execute the process, it displays the number of entries processed.
    Note :
    Normally, you schedule this program to run frequently and start IDoc
    generation for different message types.
    Step 6 : View the idocs in WE02/05

  • JTree update

    Hey,
    in one of the tools I am currently writing I am displaying data in a JTree.
    The user can edit the data that goes with the nodes,save the tree (not yet) and load a tree from a local file.
    Right now I want the user to be able to "reset" the tree. That means, whenever the user goes to "File - New Tree" he/she should get a new empty JTree.
    I put the JTree into a JScrollpane, which is part of a SplitPane, which is part of a JPanel, which is part of a JFrame.
    I wrote a little method "resetTree()" to update the tree.
    In this method I tried to just call the setup method again - which build the tree in the first place - but I was still able to see the old tree in my GUI.
    I tried to repaint all of the Panes above but that did not work either.
    //My constructor:
    public MyProgram() extends JPanel
    JFrame frame = new JFrame("Test");
    setupTree();
    setupSplitpane(); //This just takes the two ScrollPanes (one for each side) and
    //sets up a SplitPane
    this.setLayout(new BorderLayout());
    this.add(splitPane,BorderLayout.CENTER);
    frame.getContentPane().add(this,BorderLayout.CENTER);
    frame.pack();
    //This is the method which I call when creating the tree for the first time.
    private static void setupTree(String from)
    //TreeBuilder builds the tree. It can read a local xml file into
    //the tree. "from" is the path of the file. "data" is a Hashtable.
    //The method puts the data from the xml file into "data" and builds a tree.
    TreeBuilder myTreeBuilder = new TreeBuilder(from,data);
    //"tree" is a global JTree. "getTree()" returns the JTree myTreeBuilder build.
    tree = myTreeBuilder.getTree();
    //treeView is the JScrollPane
    treeView = new JScrollPane(tree);
    treeView.setPreferredSize(new Dimension( leftWidth, windowHeight ));
    tree.addMouseListener(new PopupListener(popup));
    //This is the method I call when trying to reset the tree.
    public void resetTree(String from)
    data = null;
    setupTree(from); //from = null in this case.
    splitPane.repaint(); //Repaint the Splitpane
    frame.repaint(); //Repaint the Frame
    this.repaint(); // Repaint the Panel.
    Again, my problem is, that when I call resetTree() the tree I can see in my GUI does not change. I want the tree in the left side of my JSplitpane to be setup again from zero (containing no data and no nodes) and than to update the GUI.
    I hope somebody got what I am trying to do and is able to show me a solution or just give me a little hint on howto solve this problem.
    THX!
    Martin

    Thank you very much!
    I got it working like this:
    JTree tree = myX.getTree();
    DefaultTreeModel mdel = (DefaultTreeModel)(tree.getModel());
    Object t = mdel.getRoot();
    if(t instanceof DefaultMutableTreeNode)
    DefaultMutableTreeNode root = (DefaultMutableTreeNode)(t);
    root.removeAllChildren();          
    mdel.reload();
    Still quick and dirty but it works...
    THX
    Martin

  • Dynamic-Global Entry List

    All,
    We created some custom action for combo-box, and defined one dynamic FM in the entry list of it. This is what we did a month back, and now when I try to open the same model I see the entry list is pointing to Global rather than dynamic, and we don't have any Global entry list defined. Please advice if this is some bug, or I am missing with something?
    We are not VC 7.0 SP16.
    Thanks,
    Kamaljeet

    Hi,
    you mean Dynamic changed to global Entry list right ?
    if it so ,are you getting dispalyed the if you run the model ?
    andCheck also the global entry list with the name wht you getting
    Govindu

  • How do I track motion on a video with inconsistent track points?

    I have a video of a teacher in front of a chalk board. There is one camera motion when the teacher walks from one side of the chalk board to the other. I want to add graphics on the chalk board and make it look like they are pinned on the board. What's the most accurate way to track this motion for my graphics? I'm a real newb to motion tracking and actually haven't been successful at it so this one may take some extra explaining for me.
    One think I tried was using the motion tracking behavior and I placed three track points at the bottom left, top left, and top right of the chalk board. I couldn't ad one on the top right because the teacher was in the way and at one point, the teacher walks in front of the bottom left motion track point, confusing it and loosing focus on what it's tracking. Am I making this harder than it has to be or can it be done accurately?
    Here are a couple frames to show the (simple) panning from the right of the chalk board to the left. Other than this pan, the rest of the footage is still.

    I don't do MAC's, but have you contacted their tech support?
    I had this same problem on a PC notebook (TOSHIBA) which didn't have the TILDE key. One program I had needed the TILDE key for a major, often used function. The issue never got resolved.
    expeditonwest

  • Database upgrade from SE(10.1.0.x) to EE(10.2.0.x) DBUA need clarification

    dear All
    I want to upgrade my subject database using document ID 117048.1.
    I could not understand following:
    2. De-install the SE software
    3. Install the EE software (optionally on Unix in a new ORACLE_HOME)
    I am confused at point 3. Does I need to installed EE binaries e.g in may case i have HP-UX, does following binary shall be okay, i have downloaded from Oracle Download:
    10gr2_database_hpi.zip
    Kind Regards
    S. Garewal

    1. De-install the SE software
    2. Install the EE software using existing oracle_home
    3. I have used the option 'Create Database' and point the 'Global Database name' and SID to my existing sid name.
    4. Startup the database
    5. Run the "catalog.sql" and "catproc.sql" scripts, as usual.
    Now i can connect to the database, but seems i am connecting to new database only.
    But i am not able to connect my exsiting database users/schemas?
    where i made mistake?You have done mistake at step 3.
    At step 3 , you should have upgraded the existing database instead of creating a new database .
    You are not able to see existing schemas because you have created a new database.
    During de installing SE , did you drop the database also ? Do you have old database backup ?
    Regards
    Rajesh

  • Add-in for Access 2010/2013 with Visual Studio 2012 (2013 Preview)

    Hello!
    Am i right: Microsoft wants to kill Access in favor of Azure/SQL stuff?
    I was unable to find any Projects in Visual Studio 2012/2013 to create an Addon for Access 2010 or 2013 (only Word, Excel, Outlook).
    There is even no Microsoft.Office.Tools.Access.ApplicationFactory
    to install add-in to Access App.
    Any solutions for VS 2012?
    Or i should use outdated Shared Add-in with VS 2010?
    Thank you!

    Sorry Donald M from Microsoft,
    You need to rethink that response.  IDTExtensibility2 is an outdated Office 2003 technology. 
    Everything EXCEPT the ThisAddIn.designer.cs reference to ApplicationFactory _factory compiles when you switch references in another Office application's VSTO project template to msaccess and dao libraries.  Even the Access icon shows up in Visual
    Studio 2013.  The only reason a Ribbon.xml project will not load into Access is that Microsoft hasn't provided the Microsoft.Office.Tools.Access DLL for it.  If you leave the Factory reference pointing to global::Microsoft.Office.Tools.Factory,
    the add-in compiles but will not load.
    MICROSOFT: Please provide us the missing Factories for MSAccess and OneNote.
    Could not create an instance of startup object AccessRibbonAddin.ThisAddIn in assembly AccessRibbonAddin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=664b6483efff25e6.
    ************** Exception Text **************
    Microsoft.VisualStudio.Tools.Applications.Runtime.CannotCreateStartupObjectException: Could not create an instance of startup object AccessRibbonAddin.ThisAddIn in assembly AccessRibbonAddin, Version=1.0.0.0, Culture=neutral, PublicKeyToken=664b6483efff25e6.
    at Microsoft.VisualStudio.Tools.Office.Runtime.DomainCreator.ExecuteCustomization.CreateEntryPoint(String entryPointTypeName)
    at Microsoft.VisualStudio.Tools.Office.Runtime.DomainCreator.ExecuteCustomization.Microsoft.VisualStudio.Tools.Office.Runtime.Interop.IExecuteCustomization2.LoadEntryPoints(IntPtr serviceProvider)
    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18052 built by: FX45RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    Microsoft.VisualStudio.Tools.Office.Runtime
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualStudio.Tools.Office.Runtime/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualStudio.Tools.Office.Runtime.dll
    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18060 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    System.Security
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18055 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Security/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Security.dll
    Microsoft.VisualStudio.Tools.Applications.Hosting
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualStudio.Tools.Applications.Hosting/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualStudio.Tools.Applications.Hosting.dll
    Microsoft.VisualStudio.Tools.Applications.Runtime
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualStudio.Tools.Applications.Runtime/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualStudio.Tools.Applications.Runtime.dll
    System.Deployment
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Deployment/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
    Microsoft.VisualStudio.Tools.Applications.ServerDocument
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualStudio.Tools.Applications.ServerDocument/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualStudio.Tools.Applications.ServerDocument.dll
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18036 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.18021 built by: FX45RTMGDR
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.0.30319.17929 built by: FX45RTMREL
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
    Microsoft.Office.Tools
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.Office.Tools/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.Office.Tools.dll
    Microsoft.Office.Tools.Common.Implementation
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.Office.Tools.Common.Implementation/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.Office.Tools.Common.Implementation.dll
    Microsoft.Office.Tools.Common
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.40305.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.Office.Tools.Common/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.Office.Tools.Common.dll
    AccessRibbonAddin
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Source/Home/Access/bin/Debug/AccessRibbonAddin.DLL
    Microsoft.Office.Tools.Common.v4.0.Utilities
    Assembly Version: 10.0.0.0
    Win32 Version: 10.0.30319.1
    CodeBase: file:///C:/Source/Home/Access/bin/Debug/Microsoft.Office.Tools.Common.v4.0.Utilities.DLL

  • Phone with busted screen turns on right after turn...

    Hello everyone,
    Thought i'd register to lay out a problem i have with my N95 phone. First of all, great phone, ive been using it for years and it still competes with everything out there for me. It did break down occasionally, but nothing i couldn't fix by cleaning the contacts or whatever, i always found a way to get it going again.
    Last month somewhere i went for a run, but on my way there the derailleur of my bike (gear shifter thing) snapped off, my wheel locked up, i came tumbling off and i had to fish my beloved N95 out of my pocket in two bits, the screen and the main body. After carrying my bike home i ordered a new flex cable, a new screen and a new body for my N95, build it in with no problem at all (done it 3 times before) and popped in the battery to have a go. That's when it got interesting.
    The phone turned on (giving the customary bleep), the keys lit up (although one keyboard led seemed to have broken) but the screen wouldn't turn on. Oh well i thought, let me just buy another screen since this one is obviously DOA. But with the second screen it still wouldn't work, and what are the odds of receiving two DOA parts from different stores? Not very likely. 
    I started looking for cases similar to mine and i came across tons of topics, they all pointed in the same general direction, format the phone using either the 3 * green button method or calling to #7370# and so on. Would be fine solutions if my screen worked, but since it didn't i was in for a blast. I tried the 3 button method and it seemed to be doing something, but since i couldn't see anything it was a little tricky to tell, but anyway i just assumed it did something. I left for a few days (i'm not one for half measures) hooked to the power and just let it format, or i thought so because i couldn't actually see anything happening because the screen wouldn't come on. After seeing nothing change i just turned it off. But it wouldn't turn off, because immediately after it gave a bleep and turned back on again. When i try to shut it down it happens again, comes back on. Only way to kill the power is to take out the battery, but when i pop the battery back in the same thing happens, the phone turning on after turning it off. 
    So to recap: phone busted, new flexcable, new screen and new body, after reassembling screen not working and after a seemingly botched attempt at formatting it won't turn off normally, instead it turns back on with the screen still not working. 
    The obvious question here is: what is going on and what can i do to get it going again? Either by formatting the thing and hopefully fixing corrupt video drivers and get the screen going again or some other solution i haven't thought of yet. Any suggestion would be greatly appreciated, as i said i think its a fantastic phone. Now im using my old 1100 which is of course a poor substitute to an N95, even if its more functional in terms of being able to use it to hammer concrete nails into walls :-) And i know what your thinking: just drop it in the bin and buy a new one. But i'd rather fix it, i always try to fix broken appliances, phones and computers and it has probably saved me thousands of euros. So again: any help is greatly appreciated!
    Moderator's Note: We have removed mention of unofficial parts which may void warranty of other users.

    Hi miintz,
    You phone will need repair. Please contact a Nokia Care point in your country so they can take a look at your phone and help. You can find Care point locations globally from www.nokia.com/repair or your local Nokia website -> Support.
    Also note that as your warranty may be void, a charge may be in place to get it fixed. Let us know how you get on.
    Regards,
    haZey
    If you find this post helpful, a click upon the white star at bottom would always be appreciated.
    If it also solves your problem, clicking ACCEPT AS SOLUTION below it will benefit other users!

  • Configure OEM in Oracle 10.2.0.4 Two nodes RAC

    Hi all,
    I'm having some troubles making rigth configuration for OEM in my RAC.
    Everything during installation or configuracion seems ok but later it's all wrong.
    The point is:
    Global database is ON and every of two nodes is also ON. I can accees it from inside and outside the server nodes.
    CRS shows everything OK with all services and resources ONLINE.
    emctl status dbconsole -clusterhttps://node2:5500/em/console/aboutApplication
    EM Daemon is running.
    emca -displayConfig dbcontrol -clusterINFO:
    **************** Current Configurationl ****************
    INSTANCE NODE DBCONTROL_UPLOAD_HOST
    inode2 node2 node2
    inode1 node1 node2
    So everything should be OK
    When I try to access OEM, it says that status can't be acess and offers me the choice of START or BEGIN RECOVER
    When I go through START the two nodes are up but can't access the instances.
    So I know that something has wrong configuracion but I don't know WHAT!!!
    Any Idea???
    Thanks in advance

    Start looking at the logs under $OH/<node_name>/sysman/log - most likely it will offer some clues.

  • UNABLE TO INJECT A STATIC DEFAULT ROUTE FROM PE????

    UNABLE TO INJECT A STATIC DEFAULT ROUTE FROM PE????
    Description:
    I am unable to get a static default route via MPBGP session for a vrf, any other route redistributed the same way is getting through.
    Just the static default route isn't ????
    1>
    SOURCE PE WHERE IS THE ROUTE REDISTRIBUTED:
    pe1#
    router bgp 4755
    bgp router-id 10.10.10.103
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor 10.10.10.100 remote-as 4755
    neighbor 10.10.10.100 update-source Loopback0
    address-family vpnv4
    neighbor 10.10.10.100 activate
    neighbor 10.10.10.100 send-community extended
    exit-address-family
    address-family ipv4 vrf B
    redistribute static <<<<<<<<<<<<<< STATIC REDIS
    no auto-summary
    no synchronization
    exit-address-family
    address-family ipv4 vrf A
    redistribute static <<<<<<<<<<<<<< STATIC REDIS
    no auto-summary
    no synchronization
    exit-address-family
    ip classless
    ip route vrf A 0.0.0.0 0.0.0.0 Serial1/0 192.168.1.2 global <<<< STATIC ROUTE POINTING THE GLOBAL CONTEXT INTERFACE
    ip route vrf B 0.0.0.0 0.0.0.0 Serial1/0 192.168.1.2 global <<<< STATIC ROUTE POINTING THE GLOBAL CONTEXT INTERFACE
    DESTINATION PE HERE I CANNOT SEE THE STATIC DEFAULT ROUTE:
    pe3(config-router-af)#do sh ip bgp vpnv4 all
    BGP table version is 11, local router ID is 10.10.10.103
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    Network Next Hop Metric LocPrf Weight Path
    Route Distinguisher: 4755:1 (default for vrf A)
    *>i172.16.1.0/30 10.10.10.101 0 100 0 ?
    *>i172.16.2.0/30 10.10.10.102 0 100 0 ?
    *>i172.16.10.0/24 10.10.10.101 2297856 100 0 ?
    *>i172.16.20.0/24 10.10.10.102 2297856 100 0 ?
    *>i172.16.200.0/24 10.10.10.102 2170112 100 0 ?
    Route Distinguisher: 4755:2 (default for vrf B)
    *>i172.16.1.0/30 10.10.10.101 0 100 0 ?
    *>i172.16.2.0/30 10.10.10.102 0 100 0 ?
    *>i172.16.10.0/24 10.10.10.101 2297856 100 0 ?
    *>i172.16.20.0/24 10.10.10.102 2297856 100 0 ?
    *>i172.16.200.0/24 10.10.10.102 2170112 100 0 ?
    THE STAITC ROUTE IS REDISTRIBUTED TO LOCAL VRF CONTXT ASWELL AS WE CAN SEE:
    pe3(config-router-af)#do sh ip route vrf A
    Routing Table: A
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
    Gateway of last resort is 192.168.1.2 to network 0.0.0.0
    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    B 172.16.200.0/24 [200/2170112] via 10.10.10.102, 00:00:23
    B 172.16.20.0/24 [200/2297856] via 10.10.10.102, 00:00:23
    B 172.16.10.0/24 [200/2297856] via 10.10.10.101, 00:00:23
    B 172.16.1.0/30 [200/0] via 10.10.10.101, 00:00:23
    B 172.16.2.0/30 [200/0] via 10.10.10.102, 00:00:23
    S* 0.0.0.0/0 [1/0] via 192.168.1.2, Serial1/0
    Hope I am clear in explaining the issue...
    Thanks,
    Dara

    Hehehe :)
    "Unfortunately" that's true !!!!
    This could have been the last thing that I try.
    Getting he techs work, protocols work is fine.
    But if get to make myself understand the logic behind adding this command as well than ... :(
    Thanks a lot,

Maybe you are looking for