Problems setting up public/private vlans on sg300-52 switches

A real beginner here with a problem on how to setup 3 SG300-52 (in L2 mode) as per this diagram:
Port 1 on all switches should be able to talk to each other and access the blob at the right.
The ports 25 on the other hand should only be able to talk among themselves in their own
private vlan. They are to carry sensitive traffic.
So I created 3 vlans, vlan 78 for ports gi1, gi51 and vlan 10 for port25,49,50 and a dummy vlan: 666
with the intent of segratating vlan 10 from vlan 78.
My attempts so far have failed.
ports gi49-50 are configured as trunk ports and gi1,gi51 as access ports as the following
cli output (excerpts of the startup config):
vlan database
vlan 10,78,666
exit
interface vlan 1
ip address 172.16.10.11 255.255.255.0
no ip address dhcp
interface gigabitethernet1
switchport mode access
switchport access vlan 78
interface gigabitethernet25
switchport mode access
switchport access vlan 10
interface gigabitethernet49
switchport trunk allowed vlan add 10,78
switchport trunk native vlan 666
switchport default-vlan tagged
interface gigabitethernet50
switchport trunk allowed vlan add 10,78
switchport trunk native vlan 666
switchport default-vlan tagged
interface gigabitethernet51
switchport mode access
switchport access vlan 78
Ports gi1 can talk to each other and access the blob but ports 25 refuse to talk to each other. But as soon as I remove
the access links to the blob they can! Obviously, at that point port gi1 lose access.
Is such a topology feasable or even advisable?
Thanks,
jf

Hi Jean,
Here's a pretty picture
Now I will explain.
The layer 3 switch is going to service as your core switch.
Vlan 78 looks like your BLOB connection.
Vlan 10 and 666 look like they don't belong on the BLOB.
So how to configure this-
You will want to configure the switch that connects directly to the BLOB as the layer 3 switch depicted in my diagram.
Layer 3 switch, follow this document
https://supportforums.cisco.com/docs/DOC-27038
Bear with me, I am making up random numbers since I don't know what you want or will use.
So VLAN 78 looks like the BLOB and 10 and 666 are staying out of the BLOB.
config t
vlan database
vlan 10, 78, 666
int vlan 1
ip address 192.168.1.254 /24
int vlan 10
ip address 192.168.2.254 /24
int vlan 78
ip address 192.168.3.254 /24
int vlan 666
ip address 192.168.4.254 /24
Configure the port you want to go to the BLOB, I am assuming vlan 78.
config t
int gi01
switchport mode access
switchport access vlan 78 (that 3750, what is the native vlan of the port it is connecting to??)
Next, configure the downlink port to connect the layer 2 switch
config t
int gi0/2
switchport mode trunk
switchport trunk allowed vlan add 10, 78, 666  (this will make the port native vlan 1 untagged, rest ports tagged)
On the downstream switch you need to configure an uplink and downlink with the respective vlans. It will remain layer 2 mode.
config t
vlan database
vlan 10, 78, 666
int gi0/1
switchport mode trunk
switchport trunk allowed vlan add 10, 78, 666
int gi0/2
switchport mode trunk
switchport trunk allowed vlan add 10, 78, 666
Same thing for the last switch, it will remain layer 2 mode
config t
vlan database
vlan 10, 78, 666
int gi0/1
switchport mode trunk
switchport trunk allowed vlan add 10, 78, 666
int gi0/2
switchport mode trunk
switchport trunk allowed vlan add 10, 78, 666
Let me know if this works out or if it is not logical for you.
-Tom
Please mark answered for helpful posts

Similar Messages

  • How to setup Private VLAN in Small business switch SF200-24

    Dear All,
    According release notes 1.4 , private vlan is supported. I've upgraded my SF200-24 with firmware 1.4.0.88 and boot 1.3.5.06. The system information show firmware version 1.4.0.88 and boot version 1.3.5.06 after reboot. I can't find private vlan setup command on GUI. Please help me to setup private vlan. Thanks.

    Hi,
    Unfortunately PVLAN is not supported on 200 series. However you might be able to overcome this using general port concept.
    for example:
    isolated port - general 10P (PVID), 30U, drop tagged traffic
    community - 20UP, 30U, drop tagged traffic
    promiscuous - 30UP, 10U, 20U
    Note: primary vlan 30
    does it address your requirements?
    Aleksandra

  • Private VLAN Promiscuous Trunk Port - Switches which support this function

    Can anyone confirm if the "Private VLAN Promiscuous Trunk Port" feature is supported in any lower end switches such as Nexus 5548/5672 or 4500X? According to the feature navigator support seems to be restricted to the Catalyst 4500 range (excluding the 4500X) as shown below. If the feature is going to be supported in the Cat 3850 this would be good to know, thanks

    4500x Yes
    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/release/note/OL_26674-01.html
    Nexus 5k Yes
    http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/layer2/521_n1_3/b_5k_Layer2_Config_521N13/b_5k_Layer2_Config_521N13_chapter_0100.html
    3850s
    They dont support pvs at all yet
    http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3850/software/release/3se/vlan/configuration_guide/b_vlan_3se_3850_cg/b_vlan_3se_3850_cg_chapter_0100.html
    Restrictions for VLANs
    The following are restrictions for VLANs:
    The switch supports per-VLAN spanning-tree plus (PVST+) or rapid PVST+ with a maximum of 128 spanning-tree instances. One spanning-tree instance is allowed per VLAN.
    The switch supports IEEE 802.1Q trunking methods for sending VLAN traffic over Ethernet ports.
    Configuring an interface VLAN router's MAC address is not supported. The interface VLAN already has an MAC address assigned by default.
    Private VLANs are not supported on the switch.
    You cannot have a switch stack containing a mix of Catalyst 3850 and Catalyst 3650 switches.

  • Re:Can't able to access shared folders from different VLANs in SG300 series switches

    Hi All,
    I supplied 3 numbers of SG300 series switches for the sole reason to have inter-vlan routing. I created 4 VLANs in the switches and made one switch as Layer 3 switch and other 2 as Layer 2 switch. Inter-Vlan routing is working fine. I am able to ping PCs from different VLANs. But I am not to access shared folders. Customer has installed Window 2003 server installed and it is in VLAN 1. There are some folders created in this server and it is very important for users to have access to the folders.Also, I am not able to access shared folders in other VLANs. I have created a case with Cisco small business and I got a reply saying that the switches will not support shared folder feature, which I think is not real. I am getting a very time to implement this solution in the network. I have a Sonicwall firewall after Core switch which is connected to ISP.
    ISP<----->Sonicwall FW<----->Core Switch<------>Layer 2 switch<------>Layer 2 switch
    Kindly help me out to resolve this issue.
    Regards,
    Prashant K

    Hi Prashant,
    I think you're running into a Windows firewall issue. SMB file sharing, by default I believe, is only allowed on your local subnet. Please try disabling windows firewall on the computer hosting the shared folder, then see if you can access the shared file.
    Best,
    David
    PS: It looks like this post got published twice. You can delete the other one using the task bar on the right.
    Please remember to rate helpful resonses and identify correct answers.

  • SUP WS-X45-SUP6-E & private-vlan community

    All,
    I tried to upgrade Cisco 6500 from Sup-2 to Sup-6 running IOS cat4500e-entservicesk9-mz.122-40.SG.bin.
    After upgrade everything came back up normal , no problem with hardaware.
    Except with private VLAN community.
    After this upgrade I can not configure "Private VLAN comunity" on this switch.
    AUNN00RS_XXXXX(config-vlan)#private-vlan community
    % Invalid input detected at '^' marker.
    AUNN00RS_MGMT1(config-vlan)#private-vlan     ?    
      association  Configure association between private VLANs
      isolated     Configure the VLAN as an isolated private VLAN
      primary      Configure the VLAN as a primary private VLAN
    It works absolutely fine with Sup-2 running same IOS.
    AUAN00RS_XXX(config-vlan)#private-vlan ?
      association  Configure association between private VLANs
      community    Configure the VLAN as a community private VLAN
      isolated     Configure the VLAN as an isolated private VLAN
      primary      Configure the VLAN as a primary private VLAN
    Regards
    Sachin

    I just checked the command reference:
    http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/40sg/command/reference/cmdref.html
    And it should be there....I couldn't find any related bugs.
    Do you have the option of upgrading the IOS? The latest is 12.2(53) SG3
    Regards,
    Ian

  • Private VLAN Problem

    I have a 6509 running with a Sup720 and the latest IOS. Trying to configure several ports as a private VLAN with the below config. Problem is, in addition to not being able to talk to each other, hosts can't talk to the promiscuous port. Thoughts?
    vlan 172
    private-vlan primary
    private-vlan association 472
    vlan 472
    private-vlan isolated
    interface GigabitEthernet4/7
    switchport
    switchport private-vlan mapping 172 472
    switchport mode private-vlan promiscuous
    no ip address
    no cdp enable
    interface GigabitEthernet4/8
    switchport
    switchport private-vlan host-association 172 472
    switchport mode private-vlan host
    no ip address
    no cdp enable
    interface GigabitEthernet4/9
    switchport
    switchport private-vlan host-association 172 472
    switchport mode private-vlan host
    no ip address
    no cdp enable

    That did the trick, thank you. I guess I missed that the first two times I read through the documentation. I still have one problem, though. I ended up configuring 5 ports, 1 in promiscuous mode in port 25, two in community mode in ports 11 and 12, and two in private mode in ports 13 and 14. The PIX was in port 25, the internet router and a Nortel Contivity were in the community ports as these need to talk to each other as well as the PIX, and two other devices that only need connectivity to the PIX were in the private ports. Traffic flowing from inside the network was moving through the PIX to the WAN router fine. Traffic flowing through the PIX to the private ports was working fine. Traffic through the Contivity to the PIX and the router were flowing fine. But, VPN connectivity through the WAN router to the PIX wouldn't work. It wasn't a configuration issue with the PIX or the router, because as soon as I put them all in a standard VLAN, it worked fine, so it had something to do with the PVLAN configuration, but it just didn't make sense to me. Everything else was working in all directions. Any ideas?

  • Want to change Public, private and vip address on RAC 10g R2 windows 2003

    The network section told us the configuration of the network who support our cluster will have to change all ip address.
    We are looking for a complet document who give all the step by step instructions how to make this change.
    We have to change the Public, private and VIP at the same time of our 3 nodes cluster.
    We know the OCRCFG will be impact. So we will take backup of it first.
    Can someone are able to indicate us how to procede to execute this task.
    Thanks

    Hi,
    i check the Note:283684.1 you give me, but it didn't give all the answers to my problem.
    I finally found a recipe to make the job. I would like to tell you it's not supported be Oracle, but it work very well
    Don't forget to take a good backup of the ocrcfg and vote disk before you start.
    Here we go:
    Stop all Oracle service on all nodes before the change of the address, the low format of the ocrcfg and vote disk
    change the address in the file host in C:\WINDOWS\system32\drivers\etc with the new address
    change the ip address in the window network definition connection with the new address
    ocopy \\.\ocrcfg d:\backup\ocrcfg.dmp
    ocopy \\.\votedsk1 d:\backup\votedsk1.dmp
    rem go to directory of the cluster binary crs\bin
    cd /D D:\Oracle\Ora10g\crs/bin
    rem Format raw ocrcfg and vote disk
    LogPartFormat.exe \\.\ocrcfg /q
    LogPartFormat.exe \\.\votedsk1 /q
    rem Run in prompt mode the cluster setup
    rem crssetup.exe config -nn %s_nodenumberlist% -pn %s_privatenamelist% -ch %ORA_CRS_HOME% -oh %s_OracleHome% -c %s_clustername% -l "%s_languageid%" -q %s_votedisklist% -g %s_usergroup%
    rem example for 2 node
    crssetup.exe config -nn host_name_node_1 ,1,host_name_node_2,2 -pn host_name_node_1-priv,1,host_name_node_2-priv,2 -ch D:\Oracle\Ora10g\crs -oh D:\Oracle\Ora10g\crs -c crs_lab -l "CANADIAN FRENCH_CANADA.WE8MSWIN1252"; -q "\\.\votedsk1"
    rem ensures that all nodes are configured with the same port for the ONS
    racgons.exe add_config host_name_node_1:6200 host_name_node_2:6200
    rem oifcfg to direct components to use specific network interfaces
    oifcfg.exe setif -global "Public"/10.200.5.0:public "Prive"/192.169.255.0:cluster_interconnect
    rem to rebuild the vip address vipca in wondow componant and make the incription in the cluster (in prompt mode or online)
    rem at the same time it will create the gsd and ons service
    vipca.bat -silent -nodelist "host_name_node_1,host_name_node_2" -nodevips "host_name_node_1/host_name_node_1-vip/255.255.255.0/Public,host_name_node_2/host_name_node_2-vip/255.255.255.0/Public";
    rem vipca
    rem check the state of the crs services (inscription)
    crs_stat -t
    rem now make the registration of the listener in the cluster.
    rem important don't use the prompt command below, it will give you a crs-0223 error at the startup service
    Rem to solve this problem use netca on line
    rem crs_register ora.host_name_node_1.LISTENER_host_name_node_1.lsnr -dir D:\Oracle\Ora10g\crs\crs\profile
    rem crs_register ora.host_name_node_2.LISTENER_host_name_node_2.lsnr -dir D:\Oracle\Ora10g\crs\crs\profile
    rem srvctl start nodeapps -n host_name_node_1
    ren srvctl start nodeapps -n host_name_node_2
    netca
    rem check the state of the crs services (inscription)
    crs_stat -t
    rem start oracle object service and cluster volume before registering and accessing to asm services
    sc \\host_name_node_1 start ”Oracle Object Service”
    sc \\host_name_node_1 start OracleClusterVolumeService
    sc \\host_name_node_2 start ”Oracle Object Service”
    sc \\host_name_node_2 start OracleClusterVolumeService
    rem go the the rdbms directory to make the registration of asm and the database
    set ORACLE_HOME=D:\Oracle\Ora10g\rdbms
    rem add the service asm in the cluster in my case asm1 and asm2 for my 2 nodes
    srvctl add asm -n host_name_node_1 -i +ASM1 -o %ORACLE_HOME%
    srvctl add asm -n host_name_node_2 -i +ASM2 -o %ORACLE_HOME%
    rem start the asm service on each node
    srvctl start asm -n host_name_node_1
    srvctl start asm -n host_name_node_2
    rem check the state of the crs services (inscription)
    crs_stat -t
    rem go to the bin directory of rdbms directory to make the registration of the database
    cd /D D:\Logiciels\Oracle\Ora10g\rdbms/bin
    rem register the database (in my case labotary lab) and the to database service (lab1 and lab2) of each node
    srvctl add database -d lab -o %ORACLE_HOME%
    srvctl add instance -d lab -i lab1 -n host_name_node_1
    srvctl add instance -d lab -i lab2 -n host_name_node_2
    rem finally start the database
    srvctl start database -d lab
    rem go to directory of the cluster binary crs\bin
    rem all the services
    cd /D D:\Logiciels\Oracle\Ora10g\crs/bin
    rem you can go in the database with sqlplus and check all your components
    crs_stat -t
    I hope this will help someone who are in the same situation
    Edited by: ron_berube on 2008-12-12 09:21
    Edited by: ron_berube on 2008-12-12 10:08
    Edited by: ron_berube on 2008-12-13 08:25
    Edited by: ron_berube on 2008-12-18 10:49

  • Having problems setting text to a JLabel!!

    HI *.*,
    i'm having problems setting text to a JLabel.
    i have a JFrame with a JPanels and on the JPanel i have a JLabel.
    I have a text field wihich is used to input text.
    So, i'm using textField.getText() to read the text of the text field and setText() to write it to the Label.
    but setText() isn't displaying the text on the label.
    I'm using NetBeans as an ide
    Does anyone have any ideas??

    Here is some code
    public class AddClass extends JFrame implements ActionListener{
        public AddClass() {
            initComponents();
        }//end of 1st constructor with initComp
        //initComponents
        private void initComponents() {
            getContentPane().setLayout(new java.awt.GridLayout(3, 1));
            setDefaultCloseOperation(javax.swing.WindowConstants.EXIT_ON_CLOSE);
            prodPanel.setLayout(new java.awt.GridLayout(1, 3));
            prodPanel.setBackground(new java.awt.Color(255, 255, 255));
            prodPanel.setBorder(javax.swing.BorderFactory.createTitledBorder(javax.swing.BorderFactory.createEtchedBorder(), "Production", javax.swing.border.TitledBorder.DEFAULT_JUSTIFICATION, javax.swing.border.TitledBorder.DEFAULT_POSITION, new java.awt.Font("Arial", 1, 12)));
            westPanel.setLayout(new java.awt.GridLayout(6, 0));
            westPanel.setBackground(new java.awt.Color(255, 255, 255));
            westPanel.add(westLab1);
            westLab2.setBackground(new java.awt.Color(255, 255, 255));
            westLab2.setFont(new java.awt.Font("Arial", 1, 36));
            westLab2.setForeground(new java.awt.Color(0, 204, 0));
            westLab2.setHorizontalAlignment(javax.swing.SwingConstants.CENTER);
            westLab2.setIcon(new javax.swing.ImageIcon("C:\\icontexto-webdev-bullet-048x048.png"));
            westLab2.setText("MQ 35");
            westLab2.setHorizontalTextPosition(javax.swing.SwingConstants.LEFT);
            westLab2.setIconTextGap(10);
            westLab2.setInheritsPopupMenu(false);
            westPanel.add(westLab2);
            westPanel.add(westLab3);
            westPanel.add(westLab4);
            westPanel.add(westLab5);
            prodPanel.add(westPanel);
            setJMenuBar(menuBar);
            setTitle("Broker Monitor");
            this.setSize(700, 700);
            BrokerWindowCloser brkWindowCloser = new BrokerWindowCloser();
            this.addWindowListener(brkWindowCloser);
            pack();
            //       setVisible(true);
        }//end of initComponents
        public AddClass(String st) {
            initComponents();
            westLab6.setVisible(true);
    //        System.out.println("in broker  " + st); 
            westLab6.setText(st);
            System.out.println(st);
            westLab6.setBackground(new java.awt.Color(255, 255, 255));
            westLab6.setFont(new java.awt.Font("Arial", 1, 36));
            westLab6.setForeground(new java.awt.Color(0, 204, 0));
            westLab6.setHorizontalAlignment(javax.swing.SwingConstants.CENTER);
            westLab6.setIcon(new javax.swing.ImageIcon("C:\\PNG\\icontexto-webdev-bullet-048x048.png"));
            westLab6.setEnabled(true);
            westLab6.setHorizontalTextPosition(javax.swing.SwingConstants.LEFT);
            westLab6.setIconTextGap(15);
            westLab6.setInheritsPopupMenu(false);
            westPanel.add(westLab6);
    //       this.validate();
            westPanel.repaint();
        public void actionPerformed(ActionEvent ae) {
            Object source = ae.getSource();
            if(source == exitMI) {
                System.exit(0);
            }//end of if exitMI
            if(source == addMI){
                new AddMQ_1_1();
            if(source == removeMI){
                new RemoveMQ_1();
        }//end of actionPerformed
        class BrokerWindowCloser extends WindowAdapter {
            public void windowClosing(WindowEvent we) {
        }//end of windowcloserclass
        public static void main(String args[]) {
            java.awt.EventQueue.invokeLater(new Runnable() {
                public void run() {
                    new AddClass().setVisible(true);
        }//end of main
    }// End of variables declaration
       public void addButtonActionPerformed(java.awt.event.ActionEvent evt) {
    // TODO add your handling code here:
            Object source = evt.getSource();
            if(source == addButton){
                System.out.println("here");
                String st = mqNameJTF.getText();
                Broker1 br = new Broker1(st);
                AddClass adc = new AddClass(st);
                this.repaint();
    this.dispose();
            }//end of if addButton
        }//end addButtonActionPerformed

  • Problem setting JComboBox background in Nimbus

    I am having a problem setting the background component of a JComboBox when using the Nimbus L&F. The call to JComboBox.setBackground() changes the background of both the content area and the button. I do not want the background color of the button to be changed. I reviewed a number of similar posts in the forums and found a suggested change that results in the button keeping its original background. The code for the suggested change is shown below:
    JComboBox bandComboBox;
    bandComboBox.setBackground(Color.YELLOW);
    // This next line of code changes the background color of the button back to its original value
    bandComboBox.getComponent(0).setBackground(UIManager.getColor("control"));
    This change did not work for the Nimbus L&F but it did work for the Metal L&F. I really need a solution for the Nimbus L&F. Any suggestions would be greatly appreciated.
    I am currently running java 1.6_u13.
    Thanks!
    Casey

    Except for the actual arrow, the combo box arrow button doesn't paint anything in Nimbus. The highlight, the border, and the gradient background of the arrow button are drawn by the combo box painter. Hence, when you set the background color on the combo box, it also affects the look of the arrow button.
    So I thought, what if I made the arrow button opaque? Well.. it does become its own color, but it essentially becomes a giant solid-color square appended to the end of the combo box. Not exactly what we were looking for.
    So then I thought that maybe we could use the "Nimbus.Overrides" feature to override the colors on the combo box. Turns out you can't do that. The feature doesn't apply to colors. To change the base colors, you would have to go through the UIManager, and in effect change colors for all the components. Plus, the JComboBox uses colors derived from the same core color - "nimbusBase" - to paint the background of the combo box and the arrow button. So if you change "nimbusBase" to yellow then the whole combo box is still effected (although the results admittedly look better then setBackground(Color.yellow) since the gradient effects are retained).
    Anyway, after fiddling around with some ideas, this is what I came up with.
    import javax.swing.*;
    import javax.swing.UIManager.LookAndFeelInfo;
    import java.awt.Color;
    import java.awt.Graphics;
    public class Test {
        public static void main(String[] args) throws Exception {
            SwingUtilities.invokeLater(new Runnable() {
                public void run() {
                    createAndShowGUI();
        public static void createAndShowGUI(){
            try {
                for (LookAndFeelInfo laf : UIManager.getInstalledLookAndFeels()) {
                    if ("Nimbus".equals(laf.getName())) {
                        UIManager.setLookAndFeel(laf.getClassName());
            } catch (Exception e) {
                e.printStackTrace();
            }finally {
                if(!("Nimbus".equals(UIManager.getLookAndFeel().getName()))) {
                    System.err.println("Could not find/install Nimbus LAF!");
                    System.exit(-1);
            SpecialNimbusComboBox specialBox = new SpecialNimbusComboBox(new String[] {
                "One","Two","Three"
            specialBox.boxColor ;     = Color.yellow;
            specialBox.arrowBoxColor = Color.red;
            JComboBox regularBox = new JComboBox(new String[] {
                "One","Two","Three"
            JFrame frame = new JFrame();
            frame.setLayout(new java.awt.FlowLayout());
            frame.add(specialBox);
            frame.add(regularBox);
            frame.setSize(250,150);
            frame.setLocationRelativeTo(null);
            frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
            frame.setVisible(true);
        public static class SpecialNimbusComboBox extends JComboBox{
            public Color boxColor;
            public Color arrowBoxColor;
            private boolean ignoreRepaint;
            public SpecialNimbusComboBox() {}
            public SpecialNimbusComboBox(ComboBoxModel aModel) {super(aModel);}
            public SpecialNimbusComboBox(Object[] items) {super(items);}
            @Override
            public void paintComponent(Graphics g) {
                ignoreRepaint = true;
                try {
                    java.awt.Rectangle b = getComponent(0).getBounds();
                    g.setClip(0, 0, getWidth() - b.width, getHeight());
                    setBackground(boxColor);
                    super.paintComponent(g);
                    g.setClip(b.x, b.y, b.width, b.height);
                    setBackground(arrowBoxColor);
                    super.paintComponent(g);
                } finally {
                    ignoreRepaint = false;
            @Override
            public void repaint() {
                if(!ignoreRepaint)
                    super.repaint();
    }

  • Private Vlan, Etherchannel and Isolated Trunk on Nexus 5010

    I'm not sure if I'm missing something basic here however i though that I'd ask the question. I recieved a request from a client who is trying to seperate traffic out of a IBM P780 - one set of VIO servers/clients (Prod) is tagged with vlan x going out LAG 1 and another set of VIO server/clients (Test) is tagged with vlan y and z going out LAG 2. The problem is that the management subnet for these devices is on one subnet.
    The infrastructure is the host device is trunked via LACP etherchannel to Nexus 2148TP(5010) which than connects to the distribution layer being a Catalyst 6504 VSS. I have tried many things today, however I feel that the correct solution to get this working is to use an Isolated trunk (as the host device does not have private vlan functionality) even though there is no requirement for hosts to be segregated. I have configured:
    1. Private vlan mapping on the SVI;
    2. Primary vlan and association, and isolated vlan on Distribution (6504 VSS) and Access Layer (5010/2148)
    3. All Vlans are trunked between switches
    4. Private vlan isolated trunk and host mappings on the port-channel interface to the host (P780).
    I haven't had any luck. What I am seeing is as soon as I configure the Primary vlan on the Nexus 5010 (v5.2) (vlan y | private-vlan primary), this vlan (y) does not forward on any trunk on the Nexus 5010 switch, even without any other private vlan configuration. I believe this may be the cause to most of the issues I am having. Has any one else experienced this behaviour. Also, I haven't had a lot of experience with Private Vlans so I might be missing some fundamentals with this configuration. Any help would be appreciated.

    Hello Emcmanamy, Bruce,
    Thanks for your feedback.
    Just like you, I have been facing the same problematic last months with my customer.
    Regarding PVLAN on FEX, and as concluded in Bruce’s previous posts I understand :
    You can configure a host interface as an isolated or community access port only.
    We can configure “isolated trunk port” as well on a host interface. Maybe this specific point could be updated in the documentation.  
    This ability is documented here =>
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/layer2/513_N2_1/b_Cisco_n5k_layer2_config_gd_rel_513_N2_1_chapter_0101.html#task_1170903
    You cannot configure a host interface as a promiscuous  port.
    You cannot configure a host interface as a private  VLAN trunk port.
    Indeed a pvlan is not allowed on a trunk defined on a FEX host interface.
    However since NxOS 5.1(3)N2(1), the feature 'PVLAN on FEX trunk' is supported. But a command has to be activated before => system private-vlan fex trunk . When entered a warning about the presence of ‘FEX isolated trunks’ is prompted.
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/layer2/513_N2_1/b_Cisco_n5k_layer2_config_gd_rel_513_N2_1_chapter_0101.html#task_16C0869F1B0C4A68AFC3452721909705
    All these conditions are not met on a N5K interface.
    Best regards.
    Karim

  • Windows Public / Private JRE

    Hi,
    Does anyone have any suggestions about linking between the public and private JRE's. I am on a windows platform and my sdk is in installed at C:\j2sdk1.4.2 and I have a JAVA_HOME variable set this directory. Most of my apps: Tomcat, Cocoon, etc. require the JAVA_HOME variable to run, the run scripts tack on the \jre\bin\java to execute the private JRE included with the SDK.
    I also run several apps via Java Webstart which I could only get to work under the public JRE installed at C:\Program Files\Java\j2re1.4.2_01. Now, even though my path is set for the Private JRE anytime I invoke the java command, the public JRE is executed.
    My problem is I do not want to maintain two copies of the \ext directory, nor do I want to worry about trying to debug code not knowing which JRE was invoked.
    Is there a simple way without breaking existing scripts to use a single JRE with the SDK and Web Start?
    Thanks,
    Adam

    IIRC this is just registry database stuff.
    Not recommended for regedit novices.
    Be sure to first use regedit to export HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment to a .reg file for safe keeping, so you can roll back.
    ### CAUTION Munging about in the registry can seriously mess up windows... ###
    File: UsePrivJRE.reg
    [code]REGEDIT4
    [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment]
    "CurrentVersion"="1.4"
    [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.4]
    "JavaHome"="C:\\j2sdk1.4.2\\jre"
    "MicroVersion"="1"
    "RuntimeLib"="C:\\j2sdk1.4.2\\jre\\bin\\client\\jvm.dll"[/code]

  • Problems setting up username & password for SQL

    Due to the outstanding advice I recieved from this excellent forum, I have managed to overcome my first problem with declaring a new Class.
    This leads me to request help with my next biggest problem:
    Setting up a user GUI that takes a "username" & "password" that will be used to access a password protected database.
    I am a simple bloke, with simple thought processes, so please, go easy on me...
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import java.sql.*;
    public class DBQuery1 {
         String username = "" , password = "";
         public static void main(String[] arguments) {
              PassDB UPass = new PassDB();
              String data = "jdbc:odbc:JavaTestDataBase";
              try {
                   Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
                   Connection conn = DriverManager.getConnection(data, "" + username, "" + password);
                   Statement st = conn.createStatement();
                   ResultSet rec = st.executeQuery(
                        "SELECT Title, ContactID, First, Last, Dear FROM Contacts "
                        + "WHERE (Title='Mr') ORDER BY ContactID");
              /*     ResultSet rec2 = st.executeQuery(
                        "SELECT Subject, ContactID FROM Calls "
                        + "WHERE (Subject Is Not Null) ORDER BY ContactID");
              System.out.println("\nFirst Name\tSurname\t\tNick Name\t\tSubject\n");
              while(rec.next()) {
                   System.out.println(rec.getString(3) + "\t\t" + rec.getString(4) + "\t\t" + rec.getString(5) /* + rec2.getString(1) */ );
              st.close();
              catch (SQLException s) {
                   System.out.println("SQL Error: " + s.toString() + " " + s.getErrorCode() + " " + s.getSQLState());
              catch (Exception e) {
                   System.out.println("Error: " + e.toString() + e.getMessage());
    class PassDB extends javax.swing.JFrame implements ActionListener {
         String username = "", password = "";
         JTextField uname = new JTextField(10);
         JTextField pword = new JTextField(10);
         // JPasswordField pword = new JTextField(10);
         PassDB() {
              super("duBe's database logon");
              setSize(220, 160);
              setDefaultCloseOperation(EXIT_ON_CLOSE);
              JPanel pane = new JPanel();
              JLabel unameLabel = new JLabel ("Username: ");
              JLabel pwordLabel = new JLabel ("Password: ");
              JButton submit = new JButton("OK");
              submit.addActionListener(this);
              pane.add(unameLabel);
              pane.add(uname);
              pane.add(pwordLabel);
              pane.add(pword);
              pane.add(submit);
              setContentPane(pane);
              setVisible(true);
         public void actionPerformed(ActionEvent evt) {
              PassDB clicked = (PassDB)evt.getSource();
              username = uname.getText();
              password = pword.getText();
    This code generates two errors, stating:
    C:\Java_progs>javac DBQuery1.java
    DBQuery1.java:14: non-static variable username cannot be referenced from a static context
    Connection conn = DriverManager.getConnection(data, "" +
    username, "" + password);
    ^
    DBQuery1.java:14: non-static variable password cannot be referenced from a static context
    Connection conn = DriverManager.getConnection(data, "" +
    username, "" + password);
                    ^
    2 errors*****************************
    The code works when I remove the reference to the variables "username" & "password" in Connection "conn" call & replace them with the actual username & password, but this is not exactly what I was after. I was hoping to make the program responsive to each individual user, not set in code.
    I also would like to make the program pause after the call in "main" to "PassDB" to wait for "PassDB" to exit before continuing.
    I would also like to make "PassDB" destroy itself after the "OK" button is pressed & the "username" & "password" set.
    If that isn't enough for you, I would really like the program to search 2 different database tables, return their values & compare them to be sure that they are the same.
    When I try & search 2 different tables, as in:
    ResultSet rec = st.executeQuery(
                        "SELECT Title, ContactID, First, Last, Dear FROM Contacts "
                        + "WHERE (Title='Mr') ORDER BY ContactID");
                   ResultSet rec2 = st.executeQuery(
                        "SELECT Subject, ContactID FROM Calls "
                        + "WHERE (Subject Is Not Null) ORDER BY ContactID")javac tells me that "ResultSet" is set to null 0
    As always, I am extremely appreciative of any assistance you are able to offer.
    Kind regards
    duBedat
    [email protected]

    This is where I'm at now:
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import java.sql.*;
    public class DBQuery {
         static String username = "" ;
         static String password = "" ;
         public static void main(String[] arguments) {
         PassDB UPass = new PassDB();
         String data = "jdbc:odbc:JavaTestDataBase";
         try {
              Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
              Connection conn = DriverManager.getConnection(data, "" + DBQuery.username, "" + DBQuery.password);
              Statement st = conn.createStatement();
              ResultSet rec = st.executeQuery(
              "SELECT Title, ContactID, First, Last, Dear FROM Contacts "
              + "WHERE (Title='Mr') ORDER BY ContactID");
              /*     ResultSet rec2 = st.executeQuery(
                   "SELECT Subject, ContactID FROM Calls "
                   + "WHERE (Subject Is Not Null) ORDER BY ContactID");
              System.out.println("\nFirst Name\tSurname\t\tNick Name\t\tSubject\n");
              while(rec.next()) {
                   System.out.println(rec.getString(3) + "\t\t" + rec.getString(4) + "\t\t" + rec.getString(5) /* + rec2.getString(1) */ );
              st.close();
         catch (SQLException s) {
              System.out.println("SQL Error: " + s.toString() + " " + s.getErrorCode() + " " + s.getSQLState());
         catch (Exception e) {
              System.out.println("Error: " + e.toString() + e.getMessage());
    class PassDB extends javax.swing.JFrame implements ActionListener {
         static boolean getOut = false;
         JTextField uname = new JTextField(10);
         JTextField pword = new JTextField(10);
         // JPasswordField pword = new JTextField(10);
         public PassDB() {
              super("duBe's database logon");
              setSize(220, 160);
              setDefaultCloseOperation(EXIT_ON_CLOSE);
              JPanel pane = new JPanel();          
              JLabel unameLabel = new JLabel ("Username: ");
              JLabel pwordLabel = new JLabel ("Password: ");
              JButton submit = new JButton("OK");
              submit.addActionListener(this);
              pane.add(unameLabel);
              pane.add(uname);
              pane.add(pwordLabel);
              pane.add(pword);
              pane.add(submit);
              setContentPane(pane);
              while(getOut == false)
                   setVisible(true);                         
         public void actionPerformed(ActionEvent evt) {
              PassDB clicked = (PassDB)evt.getSource();
              DBQuery.username = uname.getText();
              DBQuery.password = pword.getText();
              getOut = true;               
    }          Any advice is greatly appreciated
    duBe

  • Error while creating folder inside the Public & Private Folders

    Dear Gurus,
    I am trying to create a new folder under Public & Private folder. But system is giving the error as " Please enter complete document key. Rollback was unsuccessful; the document is not assigtned to the folder."
    But system is creating the folder outside the Public & Private folder.Created folder is visible only in the serach result. I am not able to delete the folder also from the serach result.
    Request your inputs on how can I solve this issue
    Regards
    Damodar Pai

    Dear Gurus,
    Problem got solved. There is one more table DOST which is linked to DRAW & DRAT. We deleted the vales of DOST & tried. It is wokring now.
    Thanks for your precious inputs.
    Regards
    Damodar Pai
    Edited by: damspai on Aug 25, 2009 9:37 AM

  • Hi all, need advice on OSPF and private vlans

    Hi all.
    I have a project to complete and need some help on the possible solution I can use.
    Basically we have ospf area 0 and the users in question are in ospf area 7 and is a stub.
    I need to route the traffic from these users out through area 0 through 3 core devices, onto an external firewall interface to be placed onto the vpn that sits on it. The firewall is not included in the ospf domain.
    My thinking was that the firewall has a default route back into the ospf domain so dont need to worry about traffic coming in, however my job is to segregate these users and take them out of our core network and place them onto an external network via this vpn.
    Not sure how to achieve this apart from static routing redistributed but surely this does not seperate their traffic only points the route to ospf?!
    I was thinking I might have to use private vlans or policy routing but when I try policy routing the policy gets ignored due to normal forwarding.
    Any help and advice would be greatly appreciated.
    Cheers
    Steve

    Steve
    Thanks, that helps.
    GRE is defintely out because apart from the 6500 GRE tunneling is not supported on the Cisco switches.
    It's good that area 7 is only for these users and not mixed up with other users.
    So if i understand correcty the 4500 interface connecting to the 6500 is in area 0 and the interface connecting to the 3550 is in area.
    Or is the 3550 connected to both areas and the 4500 totally in area 0 ?
    Can you confirm the above ?
    In terms of keeping them separate there are 2 possible choices. You can either -
    1) use VRF-LIte, although i'm not sure whether the HP switch would support this. With VRF-Lite you are in effect creating virtual devices on the same physical device. This means each virtual device has it's own routing and forwarding table so it is quite secure because you would only populate the routing table with the routes needed so there would be no way for users to jump to thes rest of your networks.
    The downside is that is can become quite complex to configure. If the 4500 is only used to connect are 7 to area 0 then that would not be a problem but the connection from the 6500 to the HP could and i don't even know whether the HP supports VRF-Lite functionality let alone how to configure it on that switch.
    But it would, at least from the 4500 to 6500 to HP provide complete separation in terms of routing and forwarding. Once it got to the HP it wouldn't but that might not be an issue.
    2) Use PBR (possibly together with acls). This is easier to configure ie. you configure PBR on the 4500 and the 6500 to get the traffic to the HP switch. But you do not get the actual separation you get with VRF-Lite ie. the traffic simply overrides the existing routing tables.
    The other thing to bear in mind with PBR is that you also have to configure the return traffic as well so each device would need multiple PBR configs.
    Again i don't know whether the HP supports PBR but it may not be an issue depending on what the routing is on the HP.
    You could also use a combination of the above ie VRF-Lite between the Cisco switches and then PBR for the last hop to the HP device.
    I should say i don't have a huge amount of experience with VRF-Lite but that should not necessarily stop you using it if it is what you need. There are lots of other people on here so i'm sure there will be other people who can help if i can't.
    It still depends on how much separation is required. VRF-Lite is definitely seen as a way to separate traffic running across a shared infrastructure, PBR is not really seen in the same way.  So it may well be worth going back to find out exactly what "segregating" user traffic means.
    I don't want to confuse the issue but it's still not entirely clear what the actual requirement is.
    Jon

  • Is a Public/Private Key Pair possible in SAP?

    I have a web service that I would like to run as part of a nightly script. I currently use username/password authentication, but it is not acceptable to have them hard coded, due to Sarbanes-Oxley rules. SAP's site claims to support authentication with x.509 certificates, but is unclear on the implementation details. How could I go about setting up and using a public/private key pair in SAP?

    Not really a portal question, and maybe you'll get a better result in a security forum...
    However, briefly, yes, the AS Java supports X509 certificates as an authentication mechansm. You need to use Visual Admin to generate a server side certificate, then you need the client side to register its own X509 certificate and then in the Java user admin you need to associate the client certificate with a known user. Now when the client executes the web service call it can pass the certificate and the AS Java will back translate the certificate to a real username.

Maybe you are looking for

  • The Remote App and Windows 8.1

    Since... ( I believe)  I updated my windows to 8.1   my app remote on my iphone, touch and ipad  has not be able to control or even sometimes find my itunes library.. it will show up for a bit then totally stop working.. both my apple Tvs are good bu

  • Display "barcodes"

    I have the original G5 1.8 that came out when the G5s were first launched, with an ATI 9800 Pro, OEM. Just recently the display went crazy displaying lines of all different colors, a box that follows the cursor, those kinds of things. It gets worse i

  • Color Shift from Quicktime Movie

    Ok, Here is my problem.  When I do a copy and paste into director from a Quicktime movie for the first and last frame of my movie the is a noticible color shift when the movie starts to play on my command and when the movie transitions from the last

  • Ipod won't display song info under "Now Playing"

    I searched for this, but couldn't find an answer. My 60GB IPOD works fine, plays fine and displays info (and movies, photos, etc.) correctly in all areas except the "Now Playing" screen, at which point it won't display any info (song title, artist, a

  • Is there any software to help me remain login to yahoomail all the time

    Hello friends , I just need a software that will help me remain login to the yahoomail , like yahoo messenger , we can close the yahoo messenger window after logging in. Similarly is there any similar software which will help us to remain logged in t