Proxy usage in interzone calls

Hi all,
I have a problem with setting up Cisco MCM environment that I hope somebody can help me with.
I have three networks connected with two Cisco 2621 routers. Let's call networks 1, 2, and 3, and routers A and B. Router A connects networks 1 and 2, and B connects networks 2 and 3.
On both routers, gatekeepers are configured and local zones created at addresses A2 and B3, serving networks 2 and 3 respectively.
On the router A, MCM Proxy is enabled and tied to interface A1. The goal is to mask both networks 2 and 3 from users on network 1.
On the router B, IP routing is enabled, and static route is configured for the network 1 using A2. (The only reason for this route is to reach the proxy interface which is A1). On the router A, IP routing is disabled, and default gateway is set to B2.
On both routers, both local and remote zones are configured, with their respective prefixes.
On router A, default proxy usage settings are set to "use proxy" for all types of calls. However, additional rule is configured as "no use-proxy" for both inbound and outbound terminal calls to/from zone B.
Now, what is wrong. When I make a call from zone B endpoint to a zone A endpoint, everything is connected properly - endpoints communicate directly. However, when I call from zone A endpoint to a zone B endpoint, the call is using a proxy.
What did I do wrong and how to set it up to have calls in both directions (from A to B and from B to A) to not use the proxy?
Configuration for both routers is attached below.
=====================================================
ROUTER A
version 12.2
no parser cache
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname qa-proxy1
enable secret xxxxxx
enable password xxxx
ip subnet-zero
no ip routing
no ip domain-lookup
ip domain-name qa.fvc.com
ip dhcp excluded-address 10.2.1.1 10.2.1.100
ip dhcp pool Cisco210
network 10.2.1.0 255.255.255.0
default-router 10.2.1.2
proxy h323
interface FastEthernet0/0
ip address 10.1.41.26 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
h323 interface
h323 h323-id qaproxy1
h323 gatekeeper id qacisco1 ipaddr 10.2.1.1
h323 t120 bypass
interface FastEthernet0/1
ip address 10.2.1.1 255.255.255.0
no ip route-cache
no ip mroute-cache
duplex auto
speed auto
ip default-gateway 10.2.1.2
ip classless
no ip http server
ip pim bidir-enable
dial-peer cor custom
gatekeeper
zone local qacisco1 cisco1.qa.fvc.com 10.2.1.1
zone remote qacisco2 cisco2.qa.fvc.com 10.2.2.1 1719
no zone subnet qacisco1 default enable
zone subnet qacisco1 10.2.1.0/24 enable
zone prefix qacisco1 210*
zone prefix qacisco2 220*
lrq forward-queries
lrq lrj immediate-advance
no use-proxy qacisco1 remote-zone qacisco2 inbound-to terminal
no use-proxy qacisco1 remote-zone qacisco2 outbound-from terminal
no shutdown
endpoint ttl 60
server registration-port 11000
line con 0
line aux 0
line vty 0 5
session-timeout 180 output
no login
monitor
end
=====================================================
ROUTER B
version 12.2
no parser cache
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname "qa-proxy2"
enable secret xxxxx
enable password xxxx!
ip subnet-zero
no ip domain lookup
ip domain name qa.fvc.com
ip dhcp excluded-address 10.2.2.1 10.2.2.100
ip dhcp pool Cisco220
network 10.2.2.0 255.255.255.0
default-router 10.2.2.1
lease 30
interface FastEthernet0/0
ip address 10.2.1.2 255.255.255.0
no ip mroute-cache
duplex auto
speed auto
interface FastEthernet0/1
ip address 10.2.2.1 255.255.255.0
no ip mroute-cache
duplex auto
speed auto
ip default-gateway 10.2.2.254
ip classless
ip route 10.1.41.0 255.255.255.0 10.2.1.1 2
no ip http server
ip pim bidir-enable
dial-peer cor custom
gatekeeper
zone local qacisco2 cisco2.qa.fvc.com 10.2.2.1
zone remote qacisco1 cisco1.qa.fvc.com 10.2.1.1 1719
no zone subnet qacisco2 default enable
zone subnet qacisco2 10.2.2.0/24 enable
zone prefix qacisco1 210*
zone prefix qacisco2 220*
lrq forward-queries
no use-proxy qacisco2 default inbound-to terminal
no use-proxy qacisco2 default outbound-from terminal
no shutdown
endpoint ttl 60
line con 0
line aux 0
line vty 0 4
password xxxx
no login
line vty 5
no login
end
=====================================================

This might work if you disable the proxy on the router A. Use the command "no proxy h323" on Router A . This should work.

Similar Messages

  • Faulty Parental Controls & Proxy usage

    Dear all,
    the follow problem concerns:
    - Guest user account, Parental Control, Proxy usage, Safari
    Plattform: MacOS 10.7.4 with all updates installed
    The Problem occurs with the following steps:
    >> 1. Fresh Install of MacOS 10.7.4, Update Installation and create a normal Guest user using the control panel
    >> 2. Configuring a proxy on the wired Interface via the control panel. Fixed Proxy.
    >> 3. Testing the Preferences made as Admin user without restrictions, everything works fine as it should.
    >> Firefox => Running without Problems.
    >> 4. At this this Time Parental Controls for the Guest user are inactive.
    >> 5. Logoff the Admin user, relogin with the guest user, everythings fine. Internet Acces works with Safari and Firefox.
    >> 6. Logoff as Guest and relogin as Admin.
    >> 7. Now we're activating Parental Controls WITHOUT ANY RESTRICTIONS for Webaccess for the Guest user
    >> 8. Logoff Admin and login as Guest user ...
    >> 9. There's no Internet Access at all for anything the Safari and Firefox prompt "The Connection has been reset" ...
    Seems that some Programmer at Apple desgined a faulty Parental Control ...
    => What do you think ? Any suggestions any idea how to fix that problem
    About the Background:   The solution mentioned should be deployed in a School with ~ 150 Macs ... And the only thing stopping us from deploying Lion is that fault mentioned above ...
    Thanks in advance,
    Markus

    Thank you for your help! I work for a school district and teach digital video course in a magnet program. We purchased 11 new iMacs with the Lion OS and every single one of those new iMac computers had the exact problem when the parental control panel is set and you have to use a proxy setting. None of the computers would allow Internet access in those student user accounts.
    I have been stuck since May 2012 for an Apple fix. We buy our Apple products with a three year Apple Plan and they have been pretty much useless! I had to take one of the computers twice to the Apple store Genius and they could not do anything.  I called their online support and they asked me to run a special program they sent me to trace and download the debug routine results. They sent me an email to confirm that indeed it was an Apple OS bug and not anything on my part! It's like telling me I'm not an idiot.
    Well, that was in early June 2012 and it is September 2012 still with no fix and several poor responses like, "we don't have a fix and if we do, we will sent out a patch. So, no need for you to call!"  So much for the other 20 new machines we were planning to add.
    I will try you fix to see if it works. Thanks again.
    Herm

  • Bandwidt, Latency and Proxy usage for Fusion Cloud

    Hello,
    Do we have any information on Fusion pre-requisites from a performance standpoint ?
    - Do we have bandwidth requirements or recommendation? Any figures concerning the bandwidth consumption will be per user (min, average,max) ?
    - Do we have latency requirements or recommendation?
    - Do we have recommendation on the proxy usage ? How does it affect the performance and is there any parameter to configure (no cache for instance)?
    Many thanks in advance
    Nicolas

    Hi Helmut,
    valid question. And to cut a long story short: yes
    Right now we have the packages which you have described on the HANA Marketplace. We start with 128 GB there.
    We also have 64 GB packages. We have not yet published them on the HANA Marketplace. And I guess, you would still consider them expensive, if you do not need the persistency layer in the cloud (if you need a HANA database, I consider them fairly priced).
    The infrastructure with Git, cloud proxy / dispatcher etc. which you refer to (Lightweight HTML5 apps and Git on SAP HANA Cloud Platform) is currently available on the trial landscape. While working on the necessary steps to productize them, we also think about corresponding packages to make these new features available for the scnearios you describe and at a price which makes them attractive for exactly these scenarios.
    If you are interested in a discussion, feel free to drop me your contact details (via eMail or DM).
    Best regards
    Thorsten Schneider
    SAP HANA Cloud Platform Product Management

  • Java Proxy Runtime:  failure to locate proxy bean on inbound call

    Hello gurus of the SDN,
    I have been trying to get an inbound Java Proxy scenario to work in XI 3.0 but have not been able to get the JPR to recognize my generated and deployed java code.  My scenario is set up to call the java proxies generated from a message interface based on the MATMAS Idoc.  I successfully deployed the generated java proxies on the same host box as is running the XI instance.  The objects are named as follows
    Message interface on XI = Inbound_MATMAS04
    Generated proxy bean = Inbound_MATMAS04_PortTypeBean
    Implementing class = InboundMATMAS04_PortTypeImpl
    Implementing method = inboundMATMAS04
    I used the JPR transport servlet to register the interface and implementing class but am not sure if I did this correctly.  I used the following entry in my web browser:
    http://nadcp786:50000/ProxyServer/register?
    ns=urn:xiTrainingLabs:groupXX:SAP&
    interface=InboundMATMAS04&
    bean=InboundMATMAS04_PortTypeImpl&
    method=inboundMATMAS04
    I also tried using the localejb/ prefix for the bean name in the above step since the code is co-located.  When I trigger the scenario, the Idoc info is passed into XI and the Java Proxy Runtime is called, but I get the following error response back in the SOAP header:
    - <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">
      <SAP:Category>XIAdapterFramework</SAP:Category>
      <SAP:Code area="PARSING">GENERAL</SAP:Code>
      <SAP:P1 />
      <SAP:P2 />
      <SAP:P3 />
      <SAP:P4 />
      <SAP:AdditionalText>com.sap.aii.af.ra.ms.api.DeliveryException: Cannot locate proxy bean InboundMATMAS04_PortTypeImpl: com.sap.aii.proxy.xiruntime.core.XmlInboundException: Cannot locate proxy bean InboundMATMAS04_PortTypeImpl</SAP:AdditionalText>
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack />
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>
    Finally, appended at the end of this post is the audit log of the messaging system showing that the JPR is called but without being able to locate the bean.  I think I am missing a configuration step somewhere, but can’t figure out what it is!!  Can anyone help me? 
    Many thanks in advance.
    Regards,
    Nick Simon
    Time Stamp     Status     Description
    2004-10-25 19:47:32     Success     The message was successfully received by the messaging system. Profile: XI URL: http://nadcp786.bcsdc.lexington.ibm.com:50000/MessagingSystem/receive/JPR/XI
    2004-10-25 19:47:32     Success     Using connection JPR. Trying to put the message into the receive queue.
    2004-10-25 19:47:32     Success     The message was successfully retrieved from the receive queue.
    2004-10-25 19:47:32     Success     The message status set to DLNG.
    2004-10-25 19:47:32     Success     Java proxy runtime (JPR) accepted the message
    2004-10-25 19:47:34     Error     JPR could not process the message. Reason: Cannot locate proxy bean localejbs/InboundMATMAS04_PortTypeImpl
    2004-10-25 19:47:34     Error     Delivery of the message to the application using connection JPR failed, due to: Cannot locate proxy bean localejbs/InboundMATMAS04_PortTypeImpl.
    2004-10-25 19:47:34     Error     The message status set to FAIL.
    2004-10-25 19:47:34     Error     Asynchronous error detected: Cannot locate proxy bean localejbs/InboundMATMAS04_PortTypeImpl. Trying to report it.
    2004-10-25 19:47:34     Error     Asynchronous error reported.
    Message was edited by: Nicholas Simon

    Hi
    How do you determine the JNDI naming of the a EJB?
    I have following entry in JNDI directory in the root
    Object Name FlightQueryIn
    Class Name javax.naming.Reference
    Context Name 
    Object Value Reference Class Name:
    Type: clientAppName
    Content: sap.com/JavaProxyEAR
    Type: interfaceType
    Content: remote
    Type: home
    Content: com.sap.aii.proxy.xiruntime.core.AbstractProxyInboundHome4
    Type: ejb-link
    Content: FlightSeatAvailabilityQueryIn_PortTypeBean
    Type: jndi-name
    Content: FlightQueryIn
    Type: remote
    Content: com.sap.aii.proxy.xiruntime.core.AbstractProxyInboundRemote4
    I tried to register the bean with JPR using:
    http://ctsapxid01:50100/ProxyServer/register?ns=http://sap.com/xi/XI/Demo/Airline&interface=FlightSeatAvailabilityQuery_In&bean=FlightQueryIn&method=flightSeatAvailabilityQueryIn
    I followed the following blog
    http://wiki.sdn.sap.com/wiki/display/Java/JavaProxyChangesinPI7.1fromPI7.0
    Thanks,
    Chris

  • Charged international phone usage for Whatsapp calls

    I have consistently used Whatsapp for years and love it. However, something very odd has happened in the last two months and I got a
 call from my provider (Verizon) saying there have been an unusually high 
frequency of international calls made by my phone and I had racked up $1200 
in charges. I figured it was fraud but then checked my usage online and all calls
 (to two regular numbers I call in Europe) show up as regular 
international calls. This began at the beginning of September (2014) and I
 can't understand what is happening. The rate for these calls is about $1.29/min.
    I live in the US and have many contacts in Europe, so like many other people, I have great use for Whatsapp. I was
 especially excited back in the spring of this year when they announced free
 calling, and I used it a lot. It doesn't make sense to me why I was 
successfully making calls for free for the first few months, and then all 
of a sudden in September, they've been going out as if I was calling
 internationally through my carrier. There was no mistake on my part as I haven't changed any of my methods since the beginning of using Whatsapp calling.
    Has anybody else had this experience? Is there some setting that got switched in a new iOS update that makes their calls just run normally? (I know, highly unlikely but I don't know what else could have happened).
    Thank you very much for any help!

    I sent an email to whatsup. They told me the call icon is only for convinience but that this app is for texting only. I replied to their email asking gor assistance With the phone bill but they never replied. AT&T is my cell provider so I contacted them. They helped me by adding retroactively an international plan that cost $30.00 so Inwould not have to pay for the full bill. I now have terminated that additional service just did it for a month. AT&T explained to me whatsup is causibg a lot of problems by not explaining this feature up front. I am do glad I have AT&T since it is one of the few american companies that still lrovide awesome chstomer service. Goid luck to you if you have a different cell provider. I have dince deleted shatsup which is own by Facebook    they have no accountability!!!!

  • Data usage recorded phone calls

    Is there any way to stop the recorded phone calls from Comcast when you exceed your allotted data usage? I don't mind texts, but running to the phone to find out something I already know is a bit annoying.

        Hi reignman75056!
    Thanks for the post! It's a great idea to monitor your data usage! Your actual phone calls will not take away from your monthly allowance. Do you check your usage by dialing #DATA, or on My Verizon? That would be the best way to monitor the usage that is taken from your allowance. Let us know if you need anything else!
    Katie H
    VZW Support
    Follow us on Twitter @VZWSupport

  • Advantages and disadvantages of ABAP Proxy vs. RFC call on XI target..

    Hi guys!
    We have a scenarion, when we send a message to XI and need to write data to SAP as the target system.
    Do you have experience, what would be better? RFC adapter or ABAP Proxy? And why?
    Thanx for answer!
    Peter

    hi,
    ABAP proxy if you can:
    1. /people/michal.krawczyk2/blog/2006/04/19/xi-rfc-or-abap-proxy-abap-proxies-with-attachments
    2. error handling with proxies is better
    3. RFC adapter (sender) is sometimes causing problems
    Regards,
    michal
    <a href="/people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions"><b>XI / PI FAQ - Frequently Asked Questions</b></a>

  • ISE Guest force proxy usage

    We have a cisco ISE 1.3 and WLC 5508. We have guest access portal using sms. We need to force the wireless guest user to use our proxy after completing  the sms authentication process. Is there a way to make this happen?

    If you wan't to use an explicitly configured proxy on your guests devices, that won't work well, and will make your guest network very difficult to support also.I would advise you to forget about doing that

  • Engine heap usage exceeded when calling Subflow

    Hello all,
    We are running a single server UCCX 7.0(1)SR05_Build504 with two CUCM version 7.1.5.11901-1 servers.
    We recently added a subflow call to seven of our scripts. The subflow checks an XML file that we loaded to Applications > Document Management in UCCX. The XML file is very small. See screenshot
    This is the Subflow:
    We had no problems when we had only one script calling this subflow. However, now that we have seven of our scripts calling it, we are getting this message when attempting to update or refresh an application.
    I found this article (see link below) even though it refered to version 8.0, and so as soon as I removed the Call subflow from the seven scripts, this message stopped appearing. Do I need to somehow delete at cached document at the end of the subflow script or reset some value? We would like to continue to use the subflow for checking for holidays.
    article - http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a0080b51d17.shtml
    Thank you in advance for any help anyone can provide. :-)

    You have to open a Cisco TAC case and they will give you access to a secial download area.
    ES05 was issued around June last year.
    The 7.0(2) was released around June this year and that bug is fixed in 7.0(2)
    If you have the contract you can order the 7.0(2) upgrade via the PUT tool. You can't download it Cisco have to ship you the CD.
    http://www.cisco.com/upgrade
    If you don't have a contract you have a problem
    Regards
    Graham

  • I purchased new iPhone 5 but phone shows cellular usage for lifetime calls 5 days 11 hours. How can this be?

    I purchased a new iPhone 5 and it shows 5 days 11 hours of cellular lifetime call time. I suspect someone had used this phone prior to selling it. Can someone tell me if I am correct. Shouldn't it show only the time that I have logged in calls since purchasing it?

    I synced it with my iTunes account if that is how you restore from a backup. But my old phone shows 7 days and 2 hours call time and my new phone shows 5 days 11 hours.

  • Data Loader On Demand Proxy Usage for Resume operation

    Hi,
    My project required me to use the proxy feature available in Data Loader R19 release.
    I could use the proxy at command line for insert /update operations.
    However, the same doesnt work for RESUME operation in Data loader.
    Tried using proxy settings from command line as well as property file but to no use.
    Any suggestions...
    Regards,
    Sumeet

    Its a Java application so it may run on your Linux/Unix system, you would have to test to see if works. Last time I checked Oracle only supports the application running on windows.

  • SelectManyShuttle proxy usage with reset() and addItem() methods

    I would like to pre-populate the trailing list of the shuttle with values that can change with a select one choice component. The leading list would be populated with another select one choice and these could be added to the existing values in the trailing list.
    I am assuming I could do this by using a proxy
    var proxy2 = new ShuttleProxy("testShuttle2", "testForm2");
    and using the addItem() method for the trailing list. Then doing a reset() each time the select one choice component is changed.
    I would just like to know if this is do-able and if there are any more detailed examples than can be found at
    http://www.oracle.com/technology/products/jdev/htdocs/partners/addins/exchange/jsf/doc/tagdoc/core/selectManyShuttle.html
    Thanks

    Hi,
    I think this all better comes from a single selection list that you build e.g. in a managed bean. Based on the selected value of the selectOnceChoice poplist, you can then pre-select elements from the list.
    Note that using separate lists bears the problem of what to do when the user de-selects an item. How do you recover this?
    Frank

  • I am so thouroughly disgusted with my VERIZON services.  I bought the mini ipad from my verizon store and added it to my plan in December 2013.  I was contacted via text that I was over my data usage.  I called verizon and was ASSURED that I was NOT over

    VERIZON has no respect for customers and LIES TO THEM OVER THE PHONE.   I just paid $430.00 for NOTHING BECSUE I WAS LIED TO.  my number is 870-307-4425  not that any of you will have the balls to call me back.  ******* CORPORATE ******* THEIVES.

    Also, grab your most recent $430 bill and look at the breakdown. Pro rations are on there and a bunch of stuff is going on, it all makes sense if you take time to read your statement.

  • Proxy Vs Adapter usage in an Async Communication

    Hello All,
    Just want to get a better clarification on the proxy usage.
    The communication is Asynchronous and there is a standard IDOC existing or an IDoc generated from BAPI.
    is it advisiable to use Idoc adapter in this case.
    OR
    I take the proxy approach.
    Regards,
    Sita K

    Hi Sita,
    SAP always recommends usage of ABAP proxies since WAS 6.4 and above due to the presence of local integration engine which enhances the performance. and hence usage of RFC has diminished over the years.
    But in your case you already have a standard Idoc for processing. In this case you need to identify two things:
    i) Is the incoming payload huge? - In my personal experience if the interface is for Data migration stuffs for some legacy systems, best is to use proxy since in one single Idoc more than 100 records will result in some issues (i dnt remember the exact error but there will be error). For this you need to trigger an Idoc for each 100 or more data. And during Data Migration there will be huge records.
    ii) Whether the processing logic would not be easy to implement.
    If you can call the standard BAPI or FM from the server proxy and the data is huge go for proxy else go for IDoc.
    Hope this clarifies.
    Souvik
    Rewards point if helpul.

  • Is there an APP to monitor call usage and number of texts sent

    Is there an APP to monitor call usage (in minutes) and number of texts sent etc so I can ensure I am keeping within my contract? I am getting my 3GS on Thursday so do not know if the phone has this facility already inbuilt or whether there is an app I can buy to do this for me?
    Thank you for any help and info to answer my question.

    Unless O2 has an app available via the iTunes app store that provides for this as AT&T does for the iPhone sold in the U.S., I don't believe so.
    The iPhone includes a usage indicator for Call Time and Cellular Network Data usage, which can be reset on a monthly basis based on your billing cycle, but there is no usage indicator for the number of messages sent or received.

Maybe you are looking for