RDP Capability Needed

I am looking to setup some computers as thinclients to connect to my MS Terminal Servers. We have a homebrew application that configures RDP sessions. A user logs into a webpage that dynamically generates a "launch.rdp" file. This file is generated to balance the load between servers.
What I'd like to do is configure an image to boot up into Mozilla. When the user goes to the webpage, I'd like the launch.rdp file to open up in a terminal server session.
I've tried with rdesktop and tsclient, but unfortunately neither would work with a "rdp" file. Any help or suggestions are appreciated. Thanks!

awk does what it advertises on this file too... not sure what you're doing wrong. This is an Arch box with gawk, right?
try sed:
sed -n '/^full address/s/.*:\(.*\)$/\1/p' launch.rdp
or grep...
grep -oE '[[:digit:]]+.[[:digit:]]+.[[:digit:]]+\.[[:digit:]]+' launch.rdp
or pure Bash!
while read line; do
try=${line##*:};
[[ $try =~ [[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+ ]] && echo $try
done < launch.rdp
Overboard:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define FULLADDRESS "full address:s:"
int main(void) {
char *buffer;
FILE *fd;
buffer = calloc(1, BUFSIZ);
fd = fopen("launch.rdp", "r");
if (!fd)
exit(EXIT_FAILURE);
while (fgets(buffer, BUFSIZ, fd))
if (strstr(buffer, FULLADDRESS)) {
printf("%s", buffer + strlen(FULLADDRESS));
break;
free(buffer);
fclose(fd);
return 0;
edit: i need more sleep... brisbin's probably onto something...
Last edited by falconindy (2010-06-01 18:36:59)

Similar Messages

  • Remote Control and RDP sessions

    Is anyone else experiencing the following using ZEN 11 SP1 with Windows 7 SP1...
    A user is accessing their machine via RDP and needs assistance so we attempt to use zenworks remote control to connect to their desktop, but all we see is the ctrl-alt-del screen.
    This functionality worked fine for use in our XP/Zen 10.2.1 environment. From the reseach that I've done so far it seems that it could be related to the added security in windows 7 where the services run in session0 and the the user desktop runs in session1 whereas with XP, everything runs in session0
    Wondering if I'm missing a setting. I opened an SR, but no resolution yet. They told to use the /console switch (which doesn't even apply to window 7 - its now /admin) but that did not work.
    Any insight is appreciated...
    Thanks,
    Andy Beiter
    Hodgson Russ LLP

    Originally Posted by hrabeiter
    From the reseach that I've done so far it seems that it could be related to the added security in windows 7 where the services run in session0 and the the user desktop runs in session1 whereas with XP, everything runs in session0
    Hi Andy,
    Yes, I have seen this too and also concluded the difference in session handling is causing this. Don't have a workaround for you so far unfortunately.
    -Willem

  • Lenovo Yoga with Windows 8 Pro, Office 2013 and Visual Studio

    For you developer types, I just wanted to post a message and let you know my experience with Lenovo Ideapad Yoga 13 as a development machine. I bought Lenovo Ideapad Yoga 13 from Bestbuy for $999.99. As expected, it came with a crap ton of bloatware installed by Lenovo.
    Here is a summary of what I did to it (I take no responsilibity for accuracy of below information. You are on your own if you decide to follow them. I am just putting this down from my memory so that I can look it up in the future if I ever need to do this again).
    INITIAL CLEANUP
    Installed Lenovo hotfix for partition cleanup/merging: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS033035
    Installed Lenovo Touchpad driver fix.
    CAUTION: I take no responsibility for below steps. I am writing them from memory and if you decide to follow them and end up making your machine unusable, you are on your own as Lenovo might not honor your warranty.
    BACK UP ENTIRE DISK (requires an empty USB flash drive for booting and another external USB drive for backup)
    Copied Drivers from D_Backup folder to the external USB hard drive (plugged into USB 3.0 port).
    Installed Paragon Backup & Recovery 2012 Free: http://www.paragon-software.com/home/br-free/
    Created Paragon Backup & Recovery boot USB flash drive with default Linux recovery environment option (flash drive plugged into USB 2.0 port).
    Shutdown Lenovo Yoga.
    Plugged in the Paragon Backup & Recovery boot USB flash drive (USB 2.0 port). 
    Pressed the one key recovery button (next to power button). Went to BIOS.
    In the BIOS, enabled Legacay mode and made Legacy high priority and saved the changes.
    The machine booted into Paragon Backup & Recovery mode. From there, made a backup of entire disk to the external USB hard drive.
    Shut down the machine, pressed the one key recovery button (next to power button). Went to BIOS. Turned off Legacy mode and switched back to UEFI boot mode and saved the changes and restarted the machine.
    Logged into the machine and verified that everything was good and checked the external USB drive to verify that the backup image was present.
    MAKE WINDOWS 8 PRO BOOT USB FLASH DRIVE (requires a second empty USB flash drive and a second computer with Windows 7. This USB Flash Drive has to be between 4GB to 32GB as Windows won't format 64GB flash drives to FAT32 mode)
    (Note: I installed Windows 8 Pro in UEFI mode. See http://pcsupport.about.com/od/windows-8/a/install-windows-8-usb.htm)
    You need a licensed ISO image of Windows 8 Professional Full version (not the upgrade version) from your MSDN or Technet subscription or create an ISO from the Windows 8 Pro full version DVD.
    Download Windows 7 USB/DVD Download Tool on the computer with windows 7.
    Plug in the second empty USB flash drive (has to be at least 4GB but less than 32GB) into the computer with Windows 7.
    Using Windows 7 USB/DVD Download Tool and the ISO file, create the Windows 8 Pro bootable USB Flash drive.
    Create a new folder on your computer disk, for example, C:\WIN8USB.
    Copy all the files from your USB flash drive to the newly created folder (created in the previous step).
    Right click on the USB drive icon in Computer window and select “Format…” from the context menu. Make sure you select “FAT32 (Default)” in “File system” drop down menu. Click “Start” and wait till the drive gets formatted. This step is needed because NTFS is not readable by BIOS in UEFI boot mode. During formatting, MBR is preserved so the thumbdrive is still bootable.
    Copy all the files from the folder you created earlier (C:\WIN8USB, for example) to the formatted drive. Your Windows 8 installation USB drive is ready to install in UEFI mode.
    WIPE THE DISK PARTITIONS
    Shut down the machine, pressed the one key recovery button (next to power button). Went to BIOS, enabled Legacay mode and made Legacy high priority and saved the changes.
    Booted into Paragon Backup & Recovery boot USB flash drive again. This time, I deleted all partitions on the primary disk (Disk 0). CAUTION: This WILL wipe your hard disk and will make your machine unusable!!! 
    Shut down the machine, pressed the one key recovery button (next to power button). Went to BIOS. Turned off Legacy mode and switched back to UEFI boot mode and saved the changes and shut down the machine.
    At this point, the disk is wiped clean. All factory installed software and recovery partitions are gone!!!
    INSTALL WINDOWS 8 PRO
    Plug in the USB Flash Drive with Windows 8 Pro install files.
    Windows 8 Installer would show the unallocated disk space. I can't remember the exact details but either I had to click on Delete or New to delete and then create a new GPT partition. The entire partition was about 119GB.
    From that point, follow the Windows 8 Pro installation steps.
    After booting up into Windows 8 Pro, plug the external USB drive that had the drivers folder backed up from D_backups.
    Install all the drivers from this folder (I was able to install everything except for one Intel fast boot one because of missing partition but my Yoga still boots up just as fast).
    Go to device manager to check and everything should be good now.
    Run Windows Update.
    You should now have about 101GB free on C: drive!!
    INSTALL VISUAL STUDIO, SQL SERVER and OFFICE 2013 ON LENOVO YOGA 13
    I installed the following in that order:
    Microsoft SQL Server 2008 R2 Developer edition (I installed all components, everything!). Then I installed latest service pack.
    Microsoft Visual Studio 2010 (I installed all components, everything!). Then I installed latest service pack.
    Microsoft SQL Server 2012 Developer edition(I installed all components, everything!). Then I installed latest service pack.
    Microsoft Visual Studio 2012(I installed all components, everything!)
    I ran Windows update and also installed Nov 2012 updates of SQL Server Data tools.
    I then installed Office 2013 Pro Plus.
    MAKE LENOVO YOGA 13 MORE SECURE
    Go to Control Panel and enable Windows Defender (it is included by default in Windows 8 and is anti-virus and anti-malware solution)
    Enable full hard-disk encryption using BitLocker feature of Windows 8 Pro. Since Lenovo Ideapad Yoga 13 doesn't have hardware TPM, you have to enable password based option. For this, follow the steps here: http://rics.partners.org/show_article.php?id=274. 
    Basically, you go to GPEDIT.MSC and Open Computer Configuration => Administrative Templates => Windows Components => BitLocker Drive Encryption => Operating System Drives. From the right pane double-click "Require additional authentication at startup. Select Enabled radio button and check the box for "Allow BitLocker without a compatible TPM...". Click OK and close the policy editor. Then Right-click your C drive in the Computer folder, click Turn on BitLocker. Then select Enter a password instead of USB option. Then provide a strong password (make sure to write it down and put it in a SAFE place, if you lose the password, no one can boot into your hard disk). Then select Save to a file and save it to the External Drive. Select "Encrypt entire drive...", click Next. When this is done, you will get a pop-up on the lower-right a prompt to restart the computer. Restart your PC. Enter the encryption password created earlier. If you are successful in getting into Windows, you're all set.
    I also hooked up to Skydrive and used BoxCryptor to encrypt my files in cloud.
    The available free disk space should now be about 54GB.
    I verified that Lenovo Yoga 13 works like a champ with no slowdown with Visual Studio 2010, Visual Studio 2012 and SQL Server Management Studio open simultaneously and Bitlocker enabled!
    The keyboard right SHIFT key is small but other than that, it can work as a great portable development machine and Microsoft Reader is great for reading PDF eBooks.
    So if you are a Developer on Microsoft platform, go right ahead. Lenovo IdeaPad Yoga 13 is great for running Visual Studio 2010 and Visual Studio 2012 (1600x900 resolution is totally usable) while on the move. Since I have only had this machine for a few days, I can't tell much about the long term reliability.
    Solved!
    Go to Solution.

    Thank you for posting this. I am in this exact situation. I purchased a yoga 13, and installed Visual Studio Express 2012 for Windows Phone. As it turns out, the Windows Phone Emulator ONLY works in a Windows 8 Pro environment. Since the Yoga doesn't have a disc drive, I shared my W7 computer's cd drive, then put in Windows 8 Pro, so that it could install onto the Yoga. Well, after the installation was done, I tried running my program again and ran into the same issue. It prompted me that my environment must be Windows 8 Pro! I thought that Windows 8 Pro already installed but, what confuses me is that I see no indication that Windows 8 Pro installed. When I go to the System Window, it reads: "Windows 8". Should it read Windows 8 Pro?
    Ultimately, I'd like to know, are you able to execute the Windows Phone Emulator? I'm not sure as to whether the Yoga has the hardware capability (needs to be SLAT enabled or something like that?), I HOPE it is able to, and judging by your post, it seems like it but I'd love to know your perspective on my approach.
    Please let me know if this makes sense, as I'm new to this kind of thing but really want to start development for Windows Phone.

  • ITunes/iPhone not yet compatible with key new feature of iLife '08

    I've upgraded to iLife '08 and am using the new Events feature of iPhoto and am loving it... and in the process I'm realizing that I can nix my own "Albums" that are no longer needed! But then I realize that photos are being deleted from my iPhone because the album no longer exists... duh! Okay, this makes sense, but where is the update to iTunes to support iPhoto Events????????????
    Does anyone know of a work-around other than creating an album for each Event?
    Come on Apple -- this iTunes syncing capability needs to be here very, very soon!!

    Then perhaps you need to upgrade your computer?  If your computer is not compatible with the current version of iTunes:
    PC with a 1GHz Intel or AMD processor and 512MB of RAM
    Windows XP Service Pack 2 or later, 32-bit editions of Windows Vista, Windows 7, or Windows 8
    64-bit editions of Windows Vista, Windows 7, or Windows 8 require the iTunes 64-bit installer
    400MB of available disk space
    Broadband Internet connection to use the iTunes Store
    I assume Windows computer.  If your Windows computer isn't compatible with these requirements, I suggest donating to the local old folks home and getting a PC from this century.

  • Process Task Child Table Delete Event passes empty values

    Hi All,
    I'm trying to implement a delete event in a process task for a child table. I am assuming the value to be deleted
    should be getting passing into the adapter but it's passing empty strings instead. The insert event is working fine however.
    Any one else using the delete event that works?
    Thanx
    Fred

    Hi Kevin.
    Any idea how to programmatically access the "old value" variant of a form field?
    It's the sort of thing one needs occasionally when a value changes and some associated capability needs to be updated. The old value specifies what needs to be removed while the new value tells the system what is to be added in its place.
    (It so happens in our environment that we have dozens of these values per user profile, so it would be very painful to store "old" values in a parallel set of fields.)
    Thanks,
    Dan

  • Sun VDI 3.1-EA: "Microsoft Remote Desktop" Provider -- Bug?

    It seems there is a bug in VDI 3.1:
    After having added a VirtualBox desktop provider I also wanted to add a Windows 2003 terminal server as desktop provider, so I go ...
    - https://localhost:1801
    - Desktop Providers
    - Windows Remote Desktop
    - New ...
    - Step 1 ... Next
    - Specify New Host
    ... And now it asks me for this information:
    Host:
    SSL Port: 443
    User Name:
    Password:
    SSL Port? For a Windows 2003 server?
    I am confused ... So I want to check the "Help" tab. The "Help" tab links to this URL:
    https://localhost:1801/vda/faces/jsp/providers/tswizard/NewTSProviderWizard.jsp#
    So guessing from that URL ( ... "NewTSProviderWizard" ...) I'd expect to find information regarding Windows TS servers?
    But the help text reads ".... Enter the hostname or IP address, and administrator credentials for the *+VirtualBox+* host server ... "
    VirtualBox? I wanted to get help with Windows 2003 TS.
    So I'd assume that this is a bug?
    - the "Add Microsoft Remote Desktop" wizard will get you the one for VirtualBox
    - Help text is talking about VirtualBox too
    I assume that this will be fixed before the final release?
    Regards,
    DJ.

    What specifically does your customer object to ?The server being +"touched"+. That's already enough for them. I'm ashamed to admit this ... but I too was a Windows admin once. I was young, stupid and I needed the money. ;-)
    So having been a Windows admin once myself ages ago in my dark past I can fully understand them. One stupid patch, one stupid incompatible product, one silly addon someone somewhere wrote ... and that server dies in a nice ugly "Bluescreen of Death". Or so they think. Because a typical Windows admin spends 90% of their daily job running from one dying Windows server to another dying Windows server the last thing they want is yet another server that is bound to die because one of us unworthy Penguin worshippers dared to install something on it ....
    So NOT having to install anything on that server like with SSGD is perceived as being OK.
    Having to install ANYTHING on that server for which the admin doesn't understand the reasons within 1 second simply is a NO GO for them.
    +"Why doy ou want to install this BS? My RDP connections work tip top without that thing you want to install ... take your hands off my server ... "+
    So ... How do I explain to a very very stressed and hyper-nervous Windows server administrator that I need to install some SSL stuff on his precious Windows 2003 or Windows 2008 installation when SSGD (also from Sun last time I checked ...) didn't need that? And none of his other RDP applications need that?
    How do you explain something like that? YOU CAN'T. The discussion is over even before it can begin. And if their Windows administrators are screaming like mad and panicking that you are about to hose their precious Windows systems then soon enough even their managers (who up to that second were on your side) demand an explanation ... "Why does VDI require that when SSGD didn't require that??"
    In the end it's easier for me to configure an Windows RDP application via SSGD and deliver it that way to the VDI sessions than argue with the customer and their nervous admins about why in the world I now have to touch their servers with this stuff ...
    See what I mean? Yes, I know: I exagerated slightly. Just to give you a feeling of the troubles us people in the frontlines are facing.
    SERIOUSLY:* The RDP-Provider in VDI 3.1 is in need of being re-evaluated and re-designed. Like it or not: But it simply is not going to fly the way it is now. Most Windows admins simply don't want any additional stuff installed on their servers. PERIOD. Because only the Gods know what other things such stuff will break one day ...
    So the RDP provider in VDI 3.1 should look and feel and act exactly like the one in SSGD. If you want to offer RDP-over-SSL: fine, offer it as an option for the lucky few who don't have to argue with their customer about that.
    RIght now it's easier for me to create a Linux VM that auto-boots into a pre-configured "rdesktop" session and then deliver that as a login option to users than to argue with the Windows admins why their precious servers need to be touched ... So yes, I'd say this part of the Sun VDI 3.1 product is in need of a re-design.

  • Best CDMA Phones for Mac - Suggestions Sought

    Anyone have any suggestions on a good phone to sync w/my MacBook Pro & iMac? I'm limping along with numerous steps using iCal import/export, PhoneDirector and iCal Dupe Deleter. There must be a better way! Plus, I want to get email on my phone now. Tethering capability needed, also.
    iPhone is out-of-the-question as my carrier in Alaska only runs CDMA.
    Alternatively, any REAL solutions for CDMA iPhone compatibility?
    Thanks in advance-

    I hear good things about the Skull Candy earphones. I mean if you want the best, Bose, Beats by Dre are 2 of the best earphones, but they're over $100..haha

  • MII Security Issues

    Hi,
    I am having issues with security on my MII systems.  I am wondering how many levels of security there are on MII projects.  I know that there is the user level security.  I have Admin, Developer, and User roles on the system via ABAP/UME.  I have checked the actions of each of the roles have the following assigned:  XMII_Full_Access, XMII_Developer, XMII_User, and XMII_Read_Only. 
    I know that there is transactional security.  But what levels does the transactional security apply to?  Does transactional security apply to project level, a specific folder level, or just individual transactions?
    I have heard about template security, but have not found out how to change/modify this.  Help here would be appreciated.
    Are there any other security levels that I haven't mentioned above?
    The reason that I am asking these questions is that I am seeing the error '<user> is not assigned to a role that can perform this action' much too often.  As I mentioned above I should have full access on MII though my admin role.  I also guess some of my problems have to do with the fact that we aren't assigning the default roles to our users, but instead get permissions through abap roles and ume.  Therefore is there a way to change the default roles that are assigned to transactional security so it doesn't have to be changed every time?
    Having Admin (full access) abilities on MII, is there a way to change transactional security on objects that I can't open?  (I'm guessing my roles aren't in the read/write transactional security for the object)
    I am currently working on a system that uses MII 12.1.8.28.
    I have tried searching through the SDN for this information, but haven't found anything that answers my questions.  Any help would be greatly appreciated.  I'm new to MII so sorry if this was a simple question.  Just trying to get a better understanding of how security is handled.
    Justin

    Actions are suitable for granular control of features and specific user 'actions', but were first introduced along with NW's UME in 12.1.  Prior to this the MII related Services were secured by Role(s), just like you can still see with Data Server permissions.
    Everything was Role based, which is also why the templates and the customer base would have evidenced in their applications.  Actions were introduced to provide you R/W/D granularity, where previously you were either a Developer/Admin or basic User and if you wanted to provide access to the WB or one of the Admin menu screens it was full access.
    The mandate for assignement to the base Users role will give you the blanket level of capability needed to exist in the MII world, but if you want to further restrict actions you still have the option.

  • Pegasus R4 vs Synology 412+ or 413?

    I've finally narrowed my external RAID 5 storage device down to two options. I'm either going with a Promise Pegasus R4 connected via Thunderbolt or a Synology 412+ or 413 connected via Giagabit Ethernet. Here are my requirements:
    Mac compatible
    Allows local and remote (via Internet) file access
    Time Machine multi device capable (need to backup several Macs and a PC)
    Able to use as a web develpment server, or at least capable of running MAMP PRO
    Able to stream videos (especially MKV format)
    Reliable and well built
    Expandable
    RAID 5 capable
    Energy efficient
    Relatively fast
    And here's my equipment:
    Mac Book Pro 9,1
    Two LG IPS235 monitors
    Mac Book 6,1
    Alienwareware m14x
    Time Capsule 2GB (I suppose I could use this for my Time Machine backups, but in order to do so with multiple devices I think I need to run OS X Server)
    Mac mini 2.6 GHz (coming soon)
    Based on these needs, which device is my best option?

    Have you looked at some of these?
    http://eshop.macsales.com/shop/firewire/
    Here's the TB speeds...
    http://eshop.macsales.com/item/Promise%20Technology/PR401US/
    Plus, you might consicer a different/better Backup App than TM/TC.
    Get carbon copy cloner...
    http://www.bombich.com/software/ccc.html
    Or SuperDuper...
    http://www.shirt-pocket.com/SuperDuper/
    Or the most expensive one & my favorite, Tri-Backup Pro...
    http://www.tri-edre.com/english/tribackup.html

  • Remote Desktop Session - users presented with Other User only?

    Hi,
    I am running a 2008 R2 server patched up to date.  It has the remote desktop services role installed.  Whenever I RDP or if a user launches a terminal services session they are presented with OTHER USER only.  
    This involves clicking the Other User before entering their credentials which is becoming a pain.  
    Non of the other servers are behaving this way.  I've compared the settings with the other and all is identical.  I've checked the local security policy and disabled all Group Policies but the behaviour still persists. Any ideas?
    Thanks, Matt.

    Hi Matt,
    Can you clarify more for this line, “Whenever I RDP or if a user launches a terminal services session they are presented with OTHER USER only.” what you mean by this? If I understand, when you taking RDP, you need to enter the credential for user manually
    and that you don’t want, yes? If misunderstood, please correct.
    For that, for a try you can enable the Group policy under credential manager and enable SSO for remote desktop connection. You can find the setting under beneath path.
    Computer Configuration\Administrative Templates\System\Credentials Delegation
    Allow Delegating Default Credentials: Enable
    Add "TERMSRV/<Your server name>" to the server list.
    There are other setting which you can check with following link.
    How to enable Single Sign-On for my Terminal Server connections
    http://blogs.msdn.com/b/rds/archive/2007/04/19/how-to-enable-single-sign-on-for-my-terminal-server-connections.aspx
    Hope it helps!
    Thanks.
    Dharmesh Solanki
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact [email protected]

  • Personal Information and Deleting Posting

    Instructions needed on how to delete a thread that has not been replied to. Instructions and capability need to change name that shows up in posting.

    444/2890
    Hi!
    - delete a thread that has not been replied to:
    Sorry, this ability has been removed from the New Discussions software.
    Also: if you go back to the thread and decide to "mark it as answered", as a result it will be taken back to the top of the page,
    so,
    if you want it to be just forgotten, the best you can do is: leave it alone.
    - change name:
    The only way I heard about, is to go change your settings in the general Apple registration pages.
    You might prefer to create another account in some cases?
    Good luck!
    Axl

  • Need to find professional income tax preparation software, capable of handling 1065, 1120, 1041, 990, etc. preferably PPR compatible with Mac's OS

    Need to find pro tax prep software compatible w/Macs. My software maker, Drake, does not have Mac version. I've checked Pro-Series (no) and maybe 1 other. I don't want to spend Lacert kind of $$ (neither do the majority of longtime Lacert users apparently). Obviously, no Turbo Tax, Tax Cut or any other commercial, deduction & crdit missing commercial software. They would ned to have the ability to 1) convert a few years of Drake to their program, 2) Covert files created on PC to files that 10 OS could use. Also, would like them to have reasonable PPR program, free efile, free unlimited states, capable of 1040, 1065, 1120, & (S), 1041, 990. Built in tax knowledge base. I'd be eternally indebted to you if you found sometghing as intuitive and value oriented as Drake but for OS 10. BEGINNING TO THINK APPLE bends over backwords for artistic tools but not so much business tools. Too bad, I've had a few tax returns that have bordered on art.
    I will likely need to add Parallels & Windows 7 OS, preferably 64-bit to this Macbook Air. If so, I do not think I have sufficient memory or storage so would like to download & install onto NFTS (sp?) formatted 1TB HD. I do not know if hard drives, USB hubs, Optical drives etc. that work w/ Windows (as long as you choose correctly btwn SATA & IDE) will work on MacBook Air. Help greatly appreciated. So if you happen to know any pro tax prep software ompatible w/ OS 10 and/or, you could give me some info on what characteristics peripherals would need to have to use on MacBook (I'm hoping that most are inrterchanheable but my hoping ain't gonna make it so. OR if you know any great deals on Parallel-I saw some promos but not from reliable places. If I could find on Bradsdeals or Coupon Cabin I'd feel safe. I've seen  an Apple ad for a bundle of software w/ some other decent parts (Snagit) . I'd love to find a promo that applies to the bundle and download all 9programs for $9.99 (right). Too many questions, sorry for any protocol violations.  As you might have noticed, a keyboard is high on my agenda- I hate laptop keyboards though Apple's seems better than most. I also hate using scroll pads. Much rather have mouse. Real challenge is to find Bluetooth OS 10 keybrd that has numeric keypad. I wonder if the financial dept. @ apple uses keyboards w/ no numeric keypad, saw one that started at $99. I spent all the $$ I have on a MacBook, none leftover for overpriced peripherals, esp. w/ 2 kidfs going off to college in Sept.
    Thanks for allowing me to whine & ramble. Feel free to call me on any breach of protocol as I am 1st time poster.
    Thanks for your time and consideration, I HOPE I'M CORRECT IN MY GUT FEELING THAT I've joined the forces for good by switching. Too many PCs ruined by malware.
    Bill S

    Bill I've also run into a very similar problem, I own many Macs but I've had a PC for Tax Stuff. My PC broke and I refused to buy another one so I began to search for an alternative. Window's Emulators have given me so much trouble with my Tax Software.
    However, I've since found out that Intuit has a cloud based tax solution that works with a MAC because it's all done online. Which means you'll need a reliable internet connection whenever you want to prepare a client's return.
    It's suppose to support all of the major returns (1040, 1041, 1065, 1120, 1120S and 990)
    I've yet to use this solution, but it's the best thing that I've been able to find so far. This is what I'll be using this upcoming Tax Season.
    So I figured that it would be worth mentioning. Good Luck!
    http://accountants.intuit.com/tax/online/?s_cid=SEM&s_ev1=SEM_TOE_Brand_Lower-ke yword_proline_tax_online

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • RDP listening port needs to be changed on one client PC - can't connect via Anywhere Access

    We have a setup with Server 2012 Essentials and 10 workstations. We have setup Anywhere Access and is working fine. We have one system (Windows 7 Pro) on the network running AADS Server (use to be called XP Unlimited). This allows several users to logon
    to that PC remotely at once as well as someone local using it. This PC needs to be changed from the default 3389 port due to the new AADS Server version requiring it. When ever we change the listening port we cannot remote desktop into this PC. It is available
    in Remote Web Access Portal but just sits trying to connect. We have allowed the new connection in the Windows Firewall and even turned the firewall off as a test with no luck.
    My question is, can we change the default 3389 port connection that the Server redirects you to for one PC on the network? If not how do you change in the Server to look at another local port for RDP once in the portal?
    Thanks, Jason

    Hi Jboy,
    Can you navigate to HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Control, Terminal Server, WinStations and RDP-Tcp.  Right click on the PortNumber dword and select Modify.  Change the base to Decimal and enter a new port between 1025 and 65535
    that is not already in use. Finally click OK.
    http://support.microsoft.com/kb/306759
    Thanks,
    Umesh.S.K

  • How many CALs do i need? Server 2012 - Exchange 2013 - RDP

    Hi,
    (I apologize for the grammar and spelling mistakes, but im confident in the fact that the text is understandable. If not, please let me know. I have used UK English for spelling.)
    I did some research and read the following:
    (unable to post links, my email needs to be 'verified')
    And some MS pages regarding the CALs for Windows 2008 R2 (don't ask why).
    This is basically what i want to do:
    OS:                        
    Windows 2012 R2, possibly 2x because of the RDS role.
    Roles Server1:  Active Directory and Exchange 2013
    Roles Server2: File server and RDS
    Users:                 
    20
    PC’s:                    
    Approx. 15. Not sure about the exact numbers, but i am sure that there are more users than client pc’s.
    Users RDP:        
    Starting with 10 but eventually every user will be using RDP, so it might be also 20. The 10 we start with will not have the ability of logging into a client PC but RDP only.
    MS Software:    Outlook 2010 or 2013, depends on the support by MS.
    We are going to start with an AD with a home folder, roaming profiles and an email account. If everything go’s whell, we plan to start letting users connect tot heir workspace via RDP.
    I came to the following conclusion and need your input on this:
    20 User CALs, As far as i know, I need 1 user cal for an AD account and a RDP cal for
    one RDP account. Without a User CAL, i cant issue a RDP user cal, is this correct?
    20 RDP User CALs, does this mean that all my users can log into a RDS session via any client, even their own private pc?
    No Device calls, redundant?
    20 Exchange CALs, I am not sure about this one, the second link i found only mentions acces via web and mobile. I would also like to know if the Exchange CAL is per user or email. If it’s per user, then wat do i do with an email that is meant for multiple
    users?
    2 Server CALs, This is just buying 2012R2 isnt it? Does this also allow me to use one physically and the other as a VM in the physical one? Just asking, im not really going to use a VM.
    Hope you guys can help me out on this one, i didn’t expect the CALs would bet his complicated.

    Hi,
    Under Per User licensing, you need a license for each unique human that will access the software.  Based on what you have written above, below is a general description of the licenses you need:
    20 Per User Windows Server CALs
    20 Per User RDS CALs
    20 Per User Exchange Standard CALs
    1 Exchange Server 2013 Standard license
    2 Windows Server 2012 R2 Standard licenses
    Notes: 
    Each Server 2012 R2 Standard license allows you to install it on a physical server (up to 2 CPU sockets) with the Hyper-V role installed, and install it in 2 VMs.  The key here from a licensing perspective is the installation on the physical server
    is only being used for Hyper-V--if you use it for some other purpose (like AD, SQL, etc.) then you are only permitted to run 2012 R2 on 1 VM without an additional license.  Running your servers as VMs is the common and recommended method now, unless
    you have a specific reason not to.
    I listed two 2012 R2 licenses above because from your description I get the idea that you will have 2 physical servers.
    It is preferred to split key roles/functions onto separate VMs if possible.  For example, it would be preferred to have Exchange on its own VM(s).  This is obviously subject to your specific situation, budget, etc.  In smaller environments
    some roles will be combined in order to save money.
    I did not include licenses for Office in the list above.
    Yes, Per User licensing means the user can access the software from any device, even their own private pc.
    I recommend you purchase licenses through a MS volume licensing program that fits your needs.  Adding Software Assurance (SA) to your licenses will allow you to get the new versions when they are released as well as give some additional licensing rights.
    As always, it is essential to read the Product Use Rights (PUR) document, licensing agreements, terms and conditions, etc., as applicable to your licenses.
    I recommend you also take a look at the Office365 plans that include Office/Exchange/etc.  There are Exchange-only plans as well.  Depending on your needs it may be preferred to have your users access Exchange in the cloud and run RDS on premises. 
    Licensing Windows Server 2012 R2 Remote Desktop Services and Microsoft Desktop Applications for Use with RDS
    http://www.microsoft.com/licensing/about-licensing/briefs/winserv2012-rds.aspx
    Exchange Server 2013 licensing
    http://products.office.com/en-us/exchange/microsoft-exchange-server-licensing-licensing-overview
    -TP

Maybe you are looking for

  • Balance sheet as per Business area

    Hi gurus, client wants business area wise balance sheet. so that I had define the 2 difference business area &i  had get balance sheet as per business area. but i found that there are some stock accounts which update business area by-default & some w

  • How to pick the sender files dynamically using the same File CC

    hi, My requirements is like , Same Sender File communication Channel has to pick up the different file which are having differnt file conventions and which are placed in different directories .. then it has to send to diffentn directories in the rece

  • APIs for downloading content

    At http://portalstudio.oracle.com/pls/ops/docs/FOLDER/COMMUNITY/PDK/plsql/doc/sdk23pkg.htm I find a description for Content Area APIs to upload or modify content in content areas. Are APIs available for downloading too? Based on a given topURL and a

  • Sadow process in oracle

    Hi All, Can anyone make me understand what exactly is shadow process in oracle? and how it is different between user process and server process.? I have googling it but did not any good answer thanks Vishu

  • Help! i installed the update for the flash player, now nothing works!

    I have an imac computer and installed the new update, but now nothing works! Just keeps saying plugin failure. How do i fix this? Im running 10.7.5.