Retrieve UM Auto Attendant configuration

in
this-link there are many shell commands for editing UM Auto Attendant configuration , 
but there are no commands for retrieve the same information ... is EWS API is the answer? 
I'm trying with C# / shell commands to get these information 
How I  : 
get UMAutoAttendant Business Hours ?
get Business Hours Greeting ? 
etc...
for example you can change business hours schedule  , but you can't get the same data
Set-UMAutoAttendant -Identity MyUMAutoAttendant -BusinessHoursSchedule 0.10:45-0.13:15,1.09:00-1.17:00,6.09:00-6.16:30
I wanna retreive the same information 
0.10:45-0.13:15,1.09:00-1.17:00,6.09:00-6.16:30
the only thing i can get is
[PS] C:\Windows\system32>Get-UMAutoAttendant -Identity ZakosUM
Name UMDialPlan PilotIdentifierList SpeechEnabled Status
ZakosUM DP {} True Enabled
thanks

You can execute the cmdlets from Managed code using Remote powershell
http://msdn.microsoft.com/en-us/library/office/ff326159(v=exchg.140).aspx
eg
System.Security.SecureString secureString = new System.Security.SecureString();
foreach (char c in Password)
secureString.AppendChar(c);
PSCredential credential = new PSCredential(AdminUserName, secureString);
WSManConnectionInfo connectionInfo = new WSManConnectionInfo(new Uri("https://" + PSServerName), "http://schemas.microsoft.com/powershell/Microsoft.Exchange", credential);
connectionInfo.AuthenticationMechanism = AuthenticationMechanism.Basic;
connectionInfo.SkipCACheck = true;
connectionInfo.SkipCNCheck = true;
connectionInfo.MaximumConnectionRedirectionCount = 4;
Runspace runspace = System.Management.Automation.Runspaces.RunspaceFactory.CreateRunspace(connectionInfo);
runspace.Open();
Pipeline plPileLine = runspace.CreatePipeline();
Command gmUMAutoAttendant = new Command("Get-UMAutoAttendant");
gmUMAutoAttendant.Parameters.Add("Identity", "test");
plPileLine.Commands.Add(gmUMAutoAttendant);
Collection<PSObject> RsResultsresults = plPileLine.Invoke();
foreach (PSObject obj in RsResultsresults)
PSObject bhs = (PSObject)obj.Properties["BusinessHoursSchedule"].Value;
ArrayList bhsObj = (ArrayList)bhs.BaseObject;
foreach(String Element in bhsObj){
Console.WriteLine(Element);
plPileLine.Stop();
Cheers
Glen

Similar Messages

  • Configure Cisco CME auto-attendant to forward call after ext is dialed

                       I am trying to configure my CME if the auto attendant picks up and a users extension is dialed after hours to forward that call to the number configured for that extension, currently if the extension is dialed the call is not forwarded.
    Thank you,
    -Tom

    Hi,
    I have same or similar issue, when a person call my company and press option 3 for example (after hour) the call get forward to a manager mobile number, my question is how can I disable the forwarding from CUCM? the OS i use is
    8.6.2.22900-9
    Many thanks

  • Multiple Schedules and Auto Attendant in UC560

    Dear all,
    I have configured two schedules in UC560 using CCA 3.0.1 (office_hours and break_time).  I have then configured two auto-attendants. AA1 is used for office_hours and AA2 for break_time.  AA1 is working fine.  However, when it is break time, AA2 is not being used, instead the menu for closed hours in AA1 is used.  If I swap office_hours and break_time as AA2 and AA1, then break_time is ok while office_hours settings do not work.
    Internally, I can dial both AA extension numbers and get the correct prompt.  The problem is when an external call comes in.
    Any ideas what I may be doing wrong?

    Hi Tiziana,
    Sorry, I should have been more specific. What you have there is the built in script editor express. You can download the standalone CUE script editor here:
    http://www.cisco.com/cisco/software/release.html?mdfid=282825559&softwareid=282774364&release=7.0.6&relind=AVAILABLE&rellifecycle=&reltype=latest
    Edit to add: I think there are also some sample scripts that may help you out there as well. Here is also the Unity Express Script Editor guide.
    Best,
    David

  • All off-silte call directly goes to Auto Attendant

        Hello  everyone,
    I have an issue with UC520. There is one PSTN line connected to the voice port 0/2/0, All dial out works fine,  All off-site calls goes directley to the Auto Attendant, however, interal dial-in works fine, I mean user can dial internal extension properly but not from offsite to insite.
    I was wondering if any one can help me.
    Here is the partal UC configuration:
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.01.13 13:51:51 =~=~=~=~=~=~=~=~=~=~=~=
    sh run
    Building configuration...
    Current configuration : 31685 bytes
    dot11 syslog
    dot11 ssid uc520-data
    vlan 1
    authentication open
    dot11 ssid uc520-voice
    vlan 100
    authentication open
    ip source-route
    ip cef
    ip dhcp relay information trust-all
    ip dhcp excluded-address 10.1.1.1 10.1.1.10
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp pool phone
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.1
    option 150 ip 10.1.1.1
    ip dhcp pool data
    import all
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    ip name-server 63.203.35.55
    ip inspect WAAS flush-timeout 10
    ip inspect name SDM_LOW dns
    ip inspect name SDM_LOW ftp
    ip inspect name SDM_LOW h323
    ip inspect name SDM_LOW https
    ip inspect name SDM_LOW icmp
    ip inspect name SDM_LOW imap
    ip inspect name SDM_LOW pop3
    ip inspect name SDM_LOW netshow
    ip inspect name SDM_LOW rcmd
    ip inspect name SDM_LOW realaudio
    ip inspect name SDM_LOW rtsp
    ip inspect name SDM_LOW esmtp
    ip inspect name SDM_LOW sqlnet
    ip inspect name SDM_LOW streamworks
    ip inspect name SDM_LOW tftp
    ip inspect name SDM_LOW tcp
    ip inspect name SDM_LOW udp router-traffic
    ip inspect name SDM_LOW vdolive
    no ipv6 cef
    multilink bundle-name authenticated
    stcapp ccm-group 1
    stcapp
    stcapp feature access-code
    stcapp supplementary-services
    port 0/0/0
    fallback-dn 301
    port 0/0/1
    fallback-dn 302
    port 0/0/2
    fallback-dn 303
    port 0/0/3
    fallback-dn 304
    trunk group ALL_BRI
    translation-profile outgoing PROFILE_ALL_BRI
    voice call send-alert
    voice rtp send-recv
    voice service voip
    sip
    no update-callerid
    voice class codec 1
    codec preference 2 g729r8
    voice class custom-cptone CCAjointone
    dualtone conference
    frequency 600 900
    cadence 300 150 300 100 300 50
    voice class custom-cptone CCAleavetone
    dualtone conference
    frequency 400 800
    cadence 400 50 200 50 200 50
    voice register global
    max-dn 56
    max-pool 14
    voice translation-rule 4
    rule 15 /^...$/ /0354434848/
    voice translation-rule 1000
    rule 1 /.*/ //
    voice translation-rule 1111
    voice translation-rule 1112
    rule 1 /^0/ /*/
    voice translation-rule 2222
    voice translation-profile CALLER_ID_TRANSLATION_PROFILE
    translate calling 1111
    voice translation-profile CallBlocking
    translate called 2222
    voice translation-profile OUTGOING_TRANSLATION_PROFILE
    translate called 1112
    voice translation-profile PROFILE_ALL_BRI
    translate calling 4
    voice translation-profile nondialable
    translate called 1000
    voice-card 0
    dspfarm
    dsp services dspfarm
    license udi pid UC520W-8U-2BRI-K9 sn FHK131827A2
    archive
    log config
    logging enable
    logging size 600
    hidekeys
    username cisco privilege 15 secret 5 $1$TC0B$LXMORw4u1vQpD/2eJdN4W1
    username admin privilege 15 password 0 admin
    username parham privilege 15 password 0 parham
    ip tftp source-interface Loopback0
    translation-rule 22
    bridge irb
    interface Loopback0
    description $FW_INSIDE$
    ip address 10.1.10.2 255.255.255.252
    ip access-group 101 in
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/0
    description $FW_OUTSIDE$
    ip address dhcp
    ip access-group 104 in
    ip nat outside
    ip inspect SDM_LOW out
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface Integrated-Service-Engine0/0
    description cue is initialized with default IMAP group
    ip unnumbered Loopback0
    ip nat inside
    ip virtual-reassembly in
    service-module ip address 10.1.10.1 255.255.255.252
    service-module ip default-gateway 10.1.10.2
    interface FastEthernet0/1/0
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/1
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/2
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/3
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/4
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/5
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/6
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/7
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/8
    switchport mode trunk
    no ip address
    macro description cisco-switch
    interface BRI0/1/0
    no ip address
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    interface BRI0/1/1
    no ip address
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    interface Dot11Radio0/5/0
    no ip address
    ssid uc520-data
    ssid uc520-voice
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    interface Dot11Radio0/5/0.1
    encapsulation dot1Q 1 native
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0/5/0.100
    encapsulation dot1Q 100
    bridge-group 100
    bridge-group 100 subscriber-loop-control
    bridge-group 100 spanning-disabled
    bridge-group 100 block-unknown-source
    no bridge-group 100 source-learning
    no bridge-group 100 unicast-flooding
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Vlan100
    no ip address
    bridge-group 100
    bridge-group 100 spanning-disabled
    interface BVI1
    description $FW_INSIDE$
    ip address 192.168.10.1 255.255.255.0
    ip access-group 102 in
    ip nat inside
    ip virtual-reassembly in
    interface BVI100
    description $FW_INSIDE$
    ip address 10.1.1.1 255.255.255.0
    ip access-group 103 in
    ip nat inside
    ip virtual-reassembly in
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/gui
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
    control-plane
    bridge 1 route ip
    bridge 100 route ip
    voice-port 0/0/0
    cptone AU
    voice-port 0/0/1
    cptone AU
    voice-port 0/0/2
    cptone AU
    voice-port 0/0/3
    cptone AU
    voice-port 0/1/0
    cptone AU
    voice-port 0/1/1
    cptone AU
    voice-port 0/2/0
    translate calling 1112
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/0-Custom-AA
    caller-id enable
    voice-port 0/2/1
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/1-Custom-AA
    caller-id enable
    voice-port 0/2/2
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/2-Custom-AA
    caller-id enable
    voice-port 0/2/3
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/3-Custom-AA
    caller-id enable
    voice-port 0/4/0
    auto-cut-through
    signal immediate
    input gain auto-control -15
    description Music On Hold Port
    sccp local Loopback0
    sccp ccm 10.1.1.1 identifier 1 version 4.0
    sccp
    sccp ccm group 1
    associate ccm 1 priority 1
    associate profile 1 register confprof1
    dspfarm profile 1 conference
    description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
    codec g711alaw
    codec g711ulaw
    maximum conference-participants 32
    maximum sessions 2
    associate application SCCP
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    destination-pattern 300
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2001 voip
    description ** cue auto attendant number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 398
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2012 voip
    description ** cue prompt manager number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 739
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 90 pots
    description AU-Mobile
    preference 1
    destination-pattern 04........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 68 pots
    description NSW Number
    preference 1
    destination-pattern 02........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 69 pots
    description TAS Number
    preference 1
    destination-pattern 03........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 70 pots
    description WA-SA-NT number
    preference 1
    destination-pattern 08........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 72 pots
    description QA-number
    preference 1
    destination-pattern 07........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 74 pots
    description International number
    preference 1
    destination-pattern 0011T
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 30 pots
    description Australia-1800
    preference 1
    destination-pattern 1800......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 31 pots
    description Australia-1300
    preference 1
    destination-pattern 1300......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 32 pots
    description 13 Australia
    preference 5
    destination-pattern 13....
    port 0/2/0
    forward-digits all
    dial-peer voice 67 pots
    description mel-number
    preference 1
    destination-pattern 9.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 75 pots
    description mel-Number
    preference 1
    destination-pattern 8.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 76 pots
    description VIC number
    preference 1
    destination-pattern 5.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 33 pots
    description Emergency NUmber
    preference 1
    destination-pattern 0000
    port 0/2/0
    forward-digits all
    no sip-register
    no dial-peer outbound status-check pots
    telephony-service
    sdspfarm conference mute-on 111 mute-off 222
    sdspfarm units 5
    sdspfarm tag 1 confprof1
    conference hardware
    video
    max-ephones 14
    max-dn 56
    ip source-address 10.1.1.1 port 2000
    max-redirect 20
    auto assign 1 to 1 type bri
    calling-number initiator
    service phone videoCapability 1
    service phone webAccess 0
    service dnis overlay
    service dnis dir-lookup
    timeouts interdigit 7
    system message UC520
    url services http://10.1.10.1/voiceview/common/login.do
    url authentication http://10.1.10.1/CCMCIP/authenticate.asp
    load 7906 SCCP11.9-2-1S
    load 7911 SCCP11.9-2-1S
    load 7931 SCCP31.9-1-1SR1S
    load 7960-7940 P00308010200
    load 521G-524G cp524g-8-1-17
    time-zone 48
    date-format dd-mm-yy
    voicemail 300
    max-conferences 8 gain -6
    call-forward pattern .T
    call-forward system redirecting-expanded
    hunt-group logout HLog
    multicast moh 239.10.16.16 port 2000
    web admin system name cisco secret 5 $1$NPt8$6I2moMN32fQoz083VCFm90
    dn-webedit
    time-webedit
    transfer-system full-consult dss
    transfer-pattern 0.T
    transfer-pattern .T
    secondary-dialtone 0
    night-service day Sun 17:00 09:00
    night-service day Mon 17:00 09:00
    night-service day Tue 17:00 09:00
    night-service day Wed 17:00 09:00
    night-service day Thu 17:00 09:00
    night-service day Fri 17:00 09:00
    night-service day Sat 17:00 09:00
    create cnf-files version-stamp 7960 Dec 23 2013 10:55:20
    ephone-template 15
    softkeys remote-in-use Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    button-layout 7931 2
    ephone-template 16
    softkeys remote-in-use Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    ephone-template 17
    softkeys remote-in-use CBarge Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    ephone-template 18
    softkeys remote-in-use CBarge Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    button-layout 7931 2
    ephone-dn 5 dual-line
    number 301 no-reg primary
    label 301
    description PhoneA Analog
    name PhoneA Analog
    ephone-dn 6 dual-line
    number 302 no-reg primary
    label 302
    description PhoneB Analog
    name PhoneB Analog
    ephone-dn 7 dual-line
    number 303 no-reg primary
    label 303
    description PhoneC Analog
    name PhoneC Analog
    ephone-dn 8 dual-line
    number 304 no-reg primary
    label 304
    description PhoneD Analog
    name PhoneD Analog
    ephone-dn 9
    number BCD no-reg primary
    description MoH
    moh out-call ABC
    ephone-dn 10 dual-line
    number 201 no-reg primary
    pickup-group 1
    label 201
    description Extension 201
    name Receptionist Receptionist
    mobility
    call-forward busy 300
    call-forward noan 300 timeout 20
    ephone-dn 11 dual-line
    number 207 no-reg primary
    label 207
    description Extension 207
    name None None
    ephone-dn 12 dual-line
    call-waiting ring
    number 203 no-reg primary
    pickup-group 1
    label 203
    description Extension 203
    name Peter Steve
    call-forward busy 300
    call-forward noan 300 timeout 15
    huntstop channel
    ephone-dn 13 dual-line
    call-waiting ring
    number 204 no-reg primary
    pickup-group 1
    label 204
    description Extension 204
    name Tim OConnor
    call-forward busy 300
    call-forward noan 300 timeout 20
    huntstop channel
    ephone-dn 14 dual-line
    number 205 no-reg primary
    pickup-group 1
    label 205
    description 205
    name 205
    ephone-dn 15 dual-line
    number 206 no-reg primary
    pickup-group 1
    label 206
    description 206
    name 206
    ephone-dn 16 dual-line
    call-waiting ring
    number 202 no-reg primary
    pickup-group 1
    label 202
    description Extension 202
    name David Holmes
    call-forward busy 300
    call-forward noan 300 timeout 15
    huntstop channel
    ephone-dn 17 dual-line
    number 208 no-reg primary
    label 208
    description 208
    name 208
    ephone-dn 18 dual-line
    number 209 no-reg primary
    label 209
    description 209
    name 209
    ephone-dn 19 dual-line
    number 210 no-reg primary
    label 210
    description 210
    name 210
    ephone-dn 43 octo-line
    number 771 no-reg primary
    conference meetme
    preference 3
    ephone-dn 44 octo-line
    number 771 no-reg primary
    conference meetme
    preference 2
    no huntstop
    ephone-dn 45 octo-line
    number 771 no-reg primary
    conference meetme
    preference 1
    no huntstop
    ephone-dn 46 octo-line
    number 771 no-reg primary
    conference meetme
    no huntstop
    ephone-dn 49 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 3
    ephone-dn 50 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 2
    no huntstop
    ephone-dn 51 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 1
    no huntstop
    ephone-dn 52 octo-line
    number C001 no-reg primary
    conference ad-hoc
    no huntstop
    ephone-dn 55
    number A801... no-reg primary
    mwi off
    ephone-dn 56
    number A800... no-reg primary
    mwi on
    ephone 1
    device-security-mode none
    mac-address 4142.4DB8.0000
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:5
    ephone 2
    device-security-mode none
    mac-address 4142.4DB8.0001
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:6
    ephone 3
    device-security-mode none
    mac-address 4142.4DB8.0002
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:7
    ephone 4
    device-security-mode none
    mac-address 4142.4DB8.0003
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:8
    ephone 5
    device-security-mode none
    mac-address 0024.97AA.E811
    ephone-template 15
    max-calls-per-button 2
    username "Receptionist" password receptionist
    type 7931
    button 1:10
    --More--                    !
    ephone 6
    device-security-mode none
    mac-address 0024.C4FC.4013
    ephone-template 16
    username "None"
    type 7911
    button 1:11
    ephone 7
    device-security-mode none
    video
    mac-address 000F.34FA.168B
    ephone-template 16
    username "steve" password petersteve
    speed-dial 1 xxx label "Peter - Home"
    speed-dial 2 xxx label "David - Mobile"
    speed-dial 3 xxx label "Tim - Mobile AUS"
    speed-dial 4 xxx label "Tim - Mobile USA"
    type 7960
    button 1:12
    ephone 8
    device-security-mode none
    video
    mac-address A40C.C394.B1F0
    ephone-template 16
    username "tim" password timoconnor
    speed-dial 1 xxx label "David - Mobile"
    speed-dial 2 xxx label "Peter - Mobile"
    speed-dial 3 xxx label "Clare - Mobile"
    type 7911
    button 1:13
    ephone 9
    device-security-mode none
    mac-address 0024.C4FC.5425
    ephone-template 16
    type 7911
    button 1:14
    ephone 10
    device-security-mode none
    mac-address 0024.C4FD.E27C
    ephone-template 16
    type 7911
    button 1:15
    ephone 11
    device-security-mode none
    video
    mac-address 0007.5098.1AB6
    ephone-template 16
    username "holmes" password davidholmes
    speed-dial 1 xx label "David - Home"
    speed-dial 2 xxxl abel "Sue - Mobile"
    speed-dial 3 xxx label "Peter - Mobile"
    speed-dial 4 xxx label "Tim - Mobile USA"
    speed-dial 5 xxx label "Tim - Mobile AUS"
    type 7960
    button 1:16
    ephone-hunt 1 sequential
    pilot 501
    list 202, 203, 204
    final 300
    timeout 8, 8, 8
    no-reg pilot
    statistics collect
    description Sales
    alias exec cca_vm_notification schedule from_time=00 to_time=24
    banner login ^CCisco Configuration Assistant. Version: 3.2 (3). Fri Nov 15 22:54:23 EST 2013^C
    line con 0
    no modem enable
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0 4
    transport input all
    line vty 5 100
    transport input all
    ntp master
    end
    UC520#

    I was configure custom disconnect tone refer to this site:
    http://ciscoflair.blogspot.com/2009/05/cisco-fxo-disconnect-issue.html
    And the tone is in the attachment, and the custom disconnect tone configuration like below:
    voice class custom-cptone Disconnect
    dualtone disconnect
      frequency 420 420
      cadence 251 255 245 250 249 250 250 250
    and the port configuration was like below:
    voice-port 0/1/2
    supervisory disconnect dualtone mid-call
    supervisory custom-cptone Disconnect
    cptone NL
    timeouts interdigit 4
    timeouts call-disconnect 5
    timeouts wait-release 5
    timing hookflash-out 500
    connection plar 334
    impedance complex2
    caller-id enable
    caller-id alerting line-reversal
    caller-id alerting dsp-pre-allocate
    but it was not working and the phone still ringing after the PSTN caller disconnect.
    but i was read about "dualtone-detect-params", and i was add the below command and i do not understand it, but it was solve hte problem:
    voice class dualtone-detect-params 1
    freq-max-deviation 20
    cadence-variation 50
    so what it is and how to determine this parameters.

  • Full Directory option on auto attendant consoles

    Hi All,
    I have been following the guide and there is something that isn't clear. Is the full directory setting  mapped to the ldap settings on the cucm? if i have added a local  user manually on cucm will this not show on the full directory of the auto-attendant console?
    I have already configured the settings on server to sync contacts.
    Please advise.
    Thanks

    Yes, all End Users (not Application Users) from CUCM should appear in the CUxAC directory provided that it meets any rules you have configured. By default it should pull everything over. This does not happen in realtime so you may need to force a sync, most commonly through a service restart.
    Please remember to rate helpful responses and identify helpful or correct answers.

  • Cisco UC560 java.lang.NullPointerException error when opening "auto attendant" CCA

    Hi Guys,
    In CCA i get the error:java.lang.NullPointerException and it is only when selecting "Auto Attendant".
    No Configuration has been done via CLI
    Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.1(4)M5, RELEASE SOFTWARE (fc1)
    CCA version 3.2(2)
    Attaching CCA logs
    Any Ideas ?

    I would suggest downloading the latest version of the IDE (v. 5.0) which is available at:
    http://wwws.sun.com/software/sundev/jde/index.html

  • Auto-Attendant Not Running in UC500 Series

    Hi guys,
    I've got a little problem here. My auto-attendant couldn't run in my UC500.
    Here I give you a little command I took from my UC500:
    dial-peer voice 2003 voip
    description ** cue auto attendant PSTN number **
    translation-profile outgoing AA_Profile
    destination-pattern 57973199$
    b2bua
    voice-class sip outbound-proxy  ipv4:10.1.10.1
    session protocol sipv2
    session target ipv4:10.1.10.1
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    Please let me know if you need any more command from my UC.
    Regards,
    Denny

    updated,
    There is no information in service-module integrated-Service-Engine 0/0 status.
    I think this is the part of voicemail configuration (CMIIW)
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    destination-pattern 221
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    If I telnet the UC via CME, the user interface looks so simple, very2 different with the old one.
    Actually, I don't care with the voicemail, but I just care with the auto attendant. Because the ip phone cannot be dialled from outside using its direct line, but can be dialled from inside.
    I really appreciate if you can give me another advice for this one.
    Regards,
    Denny

  • UC520 FXO To Auto Attendant Disconnect Problem

    We have UC520 with FXO card, and have a problem when we point the inbound call to the Cisco Unity Express Auto Attendant, the problem is if the PSTN caller disconnect, the FXO remain off-hook for along time, and if the PSTN caller dial an extension and then disconnect the phone remain ringing for a long time.
    but if we point the inbound call an extention, there is no problem and the phone stop ring when the PSTN caller disconnect.
    below is the voice-port, and CUE dial-peer configuration:
    voice-port 0/1/2
    translate calling 3
    compand-type a-law
    cptone NL
    timeouts interdigit 4
    timeouts call-disconnect 5
    timeouts wait-release 5
    timing hookflash-out 500
    connection plar 489
    impedance complex2
    description LandLine 5105586
    caller-id enable
    caller-id alerting line-reversal
    caller-id alerting dsp-pre-allocate
    voice-port 0/1/3
    translate calling 3
    supervisory disconnect dualtone mid-call
    compand-type a-law
    cptone NL
    timeouts interdigit 4
    connection plar 489
    impedance complex2
    description LandLine 5105388
    caller-id enable
    caller-id alerting line-reversal
    caller-id alerting dsp-pre-allocate
    dial-peer voice 499 voip
    description VoiceMail
    destination-pattern 498
    media flow-around
    session protocol sipv2
    session target ipv4:10.1.10.2
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    so what we can do?

    I was configure custom disconnect tone refer to this site:
    http://ciscoflair.blogspot.com/2009/05/cisco-fxo-disconnect-issue.html
    And the tone is in the attachment, and the custom disconnect tone configuration like below:
    voice class custom-cptone Disconnect
    dualtone disconnect
      frequency 420 420
      cadence 251 255 245 250 249 250 250 250
    and the port configuration was like below:
    voice-port 0/1/2
    supervisory disconnect dualtone mid-call
    supervisory custom-cptone Disconnect
    cptone NL
    timeouts interdigit 4
    timeouts call-disconnect 5
    timeouts wait-release 5
    timing hookflash-out 500
    connection plar 334
    impedance complex2
    caller-id enable
    caller-id alerting line-reversal
    caller-id alerting dsp-pre-allocate
    but it was not working and the phone still ringing after the PSTN caller disconnect.
    but i was read about "dualtone-detect-params", and i was add the below command and i do not understand it, but it was solve hte problem:
    voice class dualtone-detect-params 1
    freq-max-deviation 20
    cadence-variation 50
    so what it is and how to determine this parameters.

  • Removal of Auto Attendant ....

    Hi Gurus,
    I am having some problems with the UC 520 namely,
    1) Is it possible to remove the auto attendant?
    2) I would like when people call in to the main line, it would be diverted to a voice hunt group.
        The voice hunt group has already been configured as show below,
        voice hunt-group 1 sequential
        final 3399
        list 3309,3317,3318,3315
        timeout 10
        pilot 3380

    I am not sure what do you mean by E1/T1?
    Indeed i am using a DID service.
    Here you go,
    dial-peer cor custom
    name internal
    name local
    name domestic
    name international
    name 900
    name 976
    dial-peer cor list call-internal
    member internal
    dial-peer cor list call-local
    member local
    dial-peer cor list call-domestic
    member domestic
    dial-peer cor list call-international
    member international
    dial-peer cor list call-900
    member 900
    dial-peer cor list call-976
    member 976
    dial-peer cor list user-internal
    member internal
    dial-peer cor list user-local
    member internal
    member local
    dial-peer cor list user-domestic
    member internal
    member local
    member domestic
    dial-peer cor list user-international
    member internal
    member local
    member domestic
    member international
    dial-peer cor list user900-internal
    member internal
    member 900
    member 976
    dial-peer cor list user900-local
    member internal
    member local
    member 900
    member 976
    dial-peer cor list user900-domestic
    member internal
    member local
    member domestic
    member 900
    member 976
    dial-peer cor list user900-international
    member internal
    member local
    member domestic
    member international
    member 900
    member 976
    dial-peer voice 2001 voip
    description ** cue auto attendant number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 3398
    b2bua   
    session protocol sipv2
    session target ipv4:IP ADDRESS
    dtmf-relay sip-notify
    codec g711ulaw
    no vad  
    dial-peer voice 150 pots
    description ** incoming dial peer **
    translation-profile incoming INCOMING_DID
    incoming called-number .%
    direct-inward-dial
    port 0/3/0:15
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    destination-pattern 3399
    b2bua   
    session protocol sipv2
    session target ipv4:IP ADDRESS
    dtmf-relay sip-notify
    codec g711ulaw
    no vad  
    dial-peer voice 400 voip
    description Office Tele
    destination-pattern 4..
    voice-class codec 1
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 500 voip
    description TeleInformatics Voicemail
    destination-pattern 5..
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 6 voip
    description Oilexec
    preference 7
    destination-pattern 6..
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 31 voip
    description London Office internal Extensions 31**
    destination-pattern 31..
    voice-class codec 1
    session protocol sipv2
    session target ipv4:IP ADDRESS
    dtmf-relay sip-notify
    dial-peer voice 32 voip
    description Jersey Office internal Extensions 32**
    destination-pattern 32..
    voice-class codec 1
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 199 voip
    description Aberdeen Reception phone
    destination-pattern 199
    voice-class codec 2
    session protocol sipv2
    session target ipv4:IP ADDRESS
    dtmf-relay sip-notify
    dial-peer voice 151 pots
    corlist outgoing call-local
    description ** E1 pots dial-peer **
    translation-profile outgoing OUTGOING_DID
    preference 5
    destination-pattern 9[5-9]T
    port 0/3/0:15
    no sip-register
    dial-peer voice 153 pots
    corlist outgoing call-international
    description ** E1 pots dial-peer **
    translation-profile outgoing OUTGOING_DID
    preference 5
    destination-pattern 9001T
    port 0/3/0:15
    prefix 001
    no sip-register
    dial-peer voice 8 voip
    description SIP Link to Regent Quay - ABZ Dial-tone
    translation-profile outgoing VOIP_ABERDEEN
    destination-pattern 8T
    voice-class codec 1
    session protocol sipv2
    session target ipv4:IP ADDRESS
    dtmf-relay sip-notify
    clid network-number 12345678912
    dial-peer voice 201 voip
    description C-MAR internal Extensions 2**
    destination-pattern 2..
    voice-class codec 2
    session protocol sipv2
    session target ipv4:172.16.0.1
    dtmf-relay sip-notify
    dial-peer voice 154 pots
    corlist outgoing call-international
    description ** E1 pots dial-peer **
    translation-profile outgoing OUTGOING_DID
    destination-pattern 9019T
    port 0/3/0:15
    prefix 019
    no sip-register
    dial-peer voice 155 pots
    corlist outgoing call-local
    description ** E1 pots dial-peer **
    translation-profile outgoing OUTGOING_DID
    destination-pattern 91800T
    port 0/3/0:15
    prefix 1800
    no sip-register
    dial-peer voice 156 pots
    corlist outgoing call-local
    description ** E1 pots dial-peer **
    translation-profile outgoing OUTGOING_DID
    preference 5
    destination-pattern 9100
    port 0/3/0:15
    forward-digits 3
    no sip-register
    dial-peer voice 2002 voip
    description ** cue auto attendant number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 3397
    b2bua   
    session protocol sipv2
    session target ipv4:10.1.12.1
    dtmf-relay sip-notify
    codec g711ulaw
    no vad  
    dial-peer voice 2003 pots
    destination-pattern 3301
    port 0/0/0
    dial-peer voice 10 pots
    destination-pattern 3301
    port 0/0/0
    dial-peer voice 157 pots
    description ** FAX 1**
    destination-pattern 9012T
    port 0/3/0:15
    prefix 012
    dial-peer voice 158 pots
    description ** FAX 2 **
    destination-pattern 9013T
    port 0/3/0:15
    prefix 013
    dial-peer voice 159 pots
    destination-pattern 916..
    port 0/3/0:15
    forward-digits 4
    dial-peer voice 34 voip
    description wellington Office internal Extensions 34**
    destination-pattern 34..
    voice-class codec 1
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 35 voip
    description Dubai Office internal Extensions 35**
    destination-pattern 35..
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 37 voip
    description Mumbai Office internal Extensions 37**
    destination-pattern 37..
    voice-class codec 1
    session target ipv4:IP ADDRESS
    dtmf-relay h245-alphanumeric
    no vad  
    dial-peer voice 30 voip
    description Houston Office internal Extensions 30**
    destination-pattern 30..
    voice-class codec 1
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    no vad  
    dial-peer voice 38 voip
    description Brasil Office internal Extensions 38**
    destination-pattern 38..
    session target ipv4:IP ADDRESS
    dtmf-relay cisco-rtp
    codec g711ulaw
    no vad  
    no dial-peer outbound status-check pots
    sip-ua   
    registrar ipv4:172.16.3.1 expires 3600

  • Final Auto Attendant Prompt

    Hi Guys,
    I am configuring Exchange Auto Attended (Exchange 2013) and I've managed to get all of my personalized prompts in place but there is one exchange default one that I can't seem to find to disable...It's the one that says
    "I couldn't hear you, please say the name of the person you want to contact, or the option you'd like to choose"
    That final prompt doesn't sound professional, I am wondering if it's part of some kind of timeout or if it can even be changed.
    THanks
    Bryan

    How have you been disabling them?  You can search for the prompt in the  <Program Files>\Microsoft\Exchange Server\V15\UnifiedMessaging\Prompts\<language>.   They're pretty well named, once I find it, I'll usually
    rename it .old and make a copy of the smallest blank one that's in the directory (sort by size) with the same name as the one you want to replace.  Of course, you'll have to rinse and repeat on potentially many servers here and watch that it doesn't come
    back with a patch, but it's one method.
    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer".
    SWC Unified Communications

  • Auto-attendant on CUCM 7.0

    Hello,
    is there anyway to configure autoattendant on CUCM 7.0?
    Thanks

    Hi javalenc,
    I have implemented CUCMBE 7.1 on a linux system with unity.
    Everythink works perfect.
    But I need to configure auto attendant that can:
    Answer a call
    Play a user-configurable welcome prompt
    Plays a main menu prompt that asks the caller to perform one of three actions:
    Press 0 for the operator.
    Press 1 to enter an extension number.
    Press 2 to spell by name.
    Please I need all the steps to through up to end. If possible the screen show of the steps.

  • SPA9000 Auto Attendant busy

    If anyone has some constructive words of advice on this issue, I would greatly appreciate them. I have come to a road block on this one issue with my SPA9000. It seems that after changing my scripts and messages my Auto Attendant is no longer available, it just gives a busy signal. So inbound callers get a busy signal, since its set to go to "aa" on inbound calls. I've done lots of things to try to pin point the issue including rolling back to a previous configuration(scripts etc.), and the only consistent thing I've noticed is both Auto Attendant( Directory -> Corporate Directory -> Auto Attendant) and pbx2 are responding with a busy signal. Even after a Factory Reset. When I was setting up my AA messages I did make a mistake and dialed "*72" instead of "****" then 72...(on FXS 2). That is the only possible cause from a human error perspective, that may have caused this issue. I've tried to see what that combination of key strokes may have done but there is no documentation (in my possession) that gives any insight. So if anyone may know where to look or has run into this before could you please point me in the right direction. -Thanks

    not sure if this will help but when i ran into an AA problem before this resolved it...not sure why, but here it is anyway...
    under the AA parameters of SIP tab enter a value on the Daytime field (For example, start=9:0:0;end=17:0:0 means the start time is 9 AM and the end time is 5 PM. The other hours (5 PM to 9 AM) are considered nighttime hours.)
    DayTime AA: Yes (default)
    DayTime AA Script: 1 (default)
    Also, check if Current AA under Info tab (Auto Attendant Prompt Status ) states Daytime...

  • New UM Cert only half works? Lost voice mail, kept Auto Attendant

    We have a Lync 2013 environment with a collocated front end/mediation server using Exchange 2010 for UM services (voice mail and auto attendant to pick up and transfer by extension) Today our UM cert expired so I replaced it with a new one from a new internal
    CA we brought up. Exchange accepted the cert (its valid for use) and applied the UM service to it with no problems. After restarting the UM service and testing I have noticed that we have lost voice mail since the switch.
    In the past whenever we had a problem with the UM cert or UM in general we have lost access to BOTH voice mail and our auto attendant so this is weird to me. I noticed I am getting my missed call notifications in outlook, but no voicemail (and not being
    prompted to leave one as the calling party either). 
    Event viewer isn't showing much for errors. Here is one that sounds related, but it doesn't appear every time I try to make a test call to voice mail.
    The Unified Messaging server encountered an error while trying to process the message with header file "C:\Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\voicemail\12635b29-9d7f-4e2f-a274-e80a4c4bc04c.txt". Error details: "Microsoft.Exchange.UM.UMCore.SmtpSubmissionException:
    Submission to the Hub Transport server failed. The operation will be retried. ---> Microsoft.Exchange.Net.ExSmtpClient.UnexpectedSmtpServerResponseException: Unexpected SMTP server response. Expected: 220, actual: 500, whole response: 500 5.3.3 Unrecognized
    command

    Hi,
    Please go to the voicemail folder under \Program Files\Microsoft\Exchange Server\V14\UnifiedMessaging\ to check if the folder is empty.
    Please check the sentence below in the link:
    http://blogs.technet.com/b/kamehta/archive/2010/12/20/um-2010-voicemail-delivery-failure-to-hub-transport.aspx
    “If the folder is empty, then the voicemail files have left the UM and on its way to Hub Transport.
    If you see voicemail audio files there it means the connection between UM and HT is broken somewhere. This can arise because of one of the following scenarios.
    The HT receive connector is mis-configured. Check the AUTH on the receive connectors
    Verify if you can telnet on hub transport's IP and port number 25
    Verify if HT FQDN is resolving to the correct IP
    Check if any anti-virus software is installed”
    Best Regards,
    Eason Huang
    Eason Huang
    TechNet Community Support

  • Manual switch Auto Attendant

    Hello,
    When an incoming call hits the UC, I want to switch manually (button or code) what it does.
    Normally during day the calls go to the Auto Attendant.
    During night there is a message.
    During the break there is another message.
    And they want to have also 2 other messages they want to use in other cases.
    Is it possible to resolve this problem with a script of some kind?
    If not I need to let the call come in on a phone and set the phone in call-forward to the AA or different voicemail boxes through floating extensions.
    Thanks,
    Stephan

    Hello,
    This is going to be a little tricky. There is a couple of ways this can be accomplished, but there are some limitations with each method.
    You can use the opened/closed hours in the Auto Attendant to change the greetings. The limitation here is that you can't manually switch, only be a schedule.
    The alternative, is to use a manual night service configuration to send calls to 2 separate auto attendants. This will allow manual control, but only between 2 messages.
    This might be possible with a custom script, but as we don't support custom scripts with UC500s, I couldn't tell if that would work.
    Hope this helps.
    Thanks,
    -john

  • Ring Duration Before Auto Attendant

    Hi,
    I have Call Manager Express with Integrated Unity 8.0 and i wants to configure ring duration before auto answer the call.  How to configure this please?                  

    I dont need any ringing i need direct to auto answer whenever calling from outside from auto answer i will select the extension like below message.  I need the command to configure in cme or integrated cue.
    http://docs.fortinet.com/fvox/cli-html/2-2-0/index.html#page/FortiVoice%20Online%20CLI%20Reference/config.3.39.html
    ring-duration
    Enter the number of seconds for the phone to ring before the auto attendant answers with the greeting message.

Maybe you are looking for