Route tagging on BGP

Hello,
I have following problem. I want to tag a route on a CE router and advertise it into the MPLS.
router A (CE-A): subnet 10.12.10.0/24
CE-A   ------ PE-A ------- MPLS --------PE-B-------CE-B------
I want to tag the routes on router CE-A with tag500 and want to receive the tag on router CE-B with that tag in order to redistribute them based on the Tag 500.
I have tried following:
route-map Tag500 permit 10
 set tag 500
network 10.12.10.0 mask 255.255.255.0 route-map Tag500
and
neighbor 10.192.96.9 route-map Tag500 out
on the second command i am receiving:
% "Tag500" used as BGP outbound route-map, set tag not supported
on the router CE-B i am receiving only Tag XXXX (replaced real EBGP neighbor AS with XXXX). YYYY is own AS.
CE-B#show ip route 10.12.10.254
Routing entry for 10.12.10.0/24
  Known via "bgp YYYY", distance 20, metric 0
  Tag XXXX, type external
  Last update from 10.192.96.61 04:34:47 ago
  Routing Descriptor Blocks:
  * 10.192.96.61, from 10.192.96.61, 04:34:47 ago
      Route metric is 0, traffic share count is 1
      AS Hops 4
      Route tag XXXX
I would like to see something like:
CE-B#show ip route 10.12.10.254
Routing entry for 10.12.10.0/24
  Known via "bgp YYYY", distance 20, metric 0
  Tag 500, type external
  Last update from 10.192.96.61 04:34:47 ago
  Routing Descriptor Blocks:
  * 10.192.96.61, from 10.192.96.61, 04:34:47 ago
      Route metric is 0, traffic share count is 1
      AS Hops 4
      Route tag 500
How can i make this happen ?
Can i do this with communities ? If yes, could someone please explain how ?
Kind Regards,
Oliver

Do you have control of the other side? If not, you'll  have to work with the isp to make sure they treat your community the way that you want. You'll also need to make sure they support them. Other than that, you can set communities outbound in the route map, and you'll need to configure your neighbor to send the communities:
route-map Community permit 20
set community 123:1234 (usually ASN:Number)
router bgp 1
neighbor 1.1.1.1 send-community both
neighbor 1.1.1.1 route-map Community out
When they receive it, they'll need to match on the community instead of the tag...
HTH,
John

Similar Messages

  • Assistance Needed: Inter-VRF Routing with MP-BGP

    hello everyone,
    I've been trying to solve a problem for over a day regarding inter-vrf routing using MP-BGP and I can't seem to figure a few things out.
    I have Cisco 1921 which has VRF-JLAN and VRF-JGLOBE with 3 interfaces configured as (g0/0 = vrf JLAN, g0/1=no vrf, g0/2 = dot1q trunk to 2960S). vrf JLAN is a restricted network for users access, dns server, e.t.c. vrf JGLOBE is for Video server and global routing table belongs to Wifi Access. I've been able to seperate all the network and I can route traffic out to the Internet from vrf JLAN and the global route table but where I'm having issues is getting vrf JGLOBE to route traffic using the Global route table.
    For example: vrf JLAN should not be accessed by either Global or vrf JGLOBE. JGLOBE should be able to access vrf JLAN dns server but it should route its internet traffic via Global route table (g0/1). Last JLAN should be able to access 2 networks from the Global route table.
    I've attached my config and diagram so you can better understand what I'm trying to achieve. More light to solving this problem would be much appreciated.
    ip vrf JGLOBE
     rd 65001:2
     export map WIFI
     route-target export 65001:2
    ip vrf JLAN
     rd 65001:1
     import ipv4 unicast map C-GLOBAL
     route-target export 65001:1
     route-target import 65001:1
     route-target import 65001:2
    interface GigabitEthernet0/0
     description LAN-ACCESS-INTERNET [TO Nexthop FIREWALL]
     ip vrf forwarding JLAN
     ip address 192.168.4.3 255.255.255.248
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     ip flow egress
     ip inspect INTERNET-FW out
     ip virtual-reassembly in
     load-interval 30
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     description GLOBAL-Wifi-INTERNET [TO Nexthop - FIREWALL]
     ip address 192.168.5.3 255.255.255.248
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip flow ingress
     ip flow egress
     ip inspect GLOBAL-FW in
     ip inspect GLOBAL-FW out
     ip virtual-reassembly in
     load-interval 30
     duplex auto
     speed auto
    interface GigabitEthernet0/2
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/2.3
     description Users LAN
     encapsulation dot1Q 3
     ip vrf forwarding JLAN
     ip address 192.168.30.1 255.255.255.240
    interface GigabitEthernet0/2.4
     description Video Server
     encapsulation dot1Q 4
     ip vrf forwarding JGLOBE
     ip address 10.6.40.1 255.255.255.0
    router ospf 1 vrf JLAN
     router-id 10.6.6.10
     redistribute bgp 65001 subnets
     network 0.0.0.0 255.255.255.255 area 0
    router ospf 2 vrf JGLOBE
     router-id 10.5.7.10
     redistribute bgp 65001 subnets
     network 0.0.0.0 255.255.255.255 area 0
    router bgp 65001
     bgp router-id 10.4.6.4
     bgp log-neighbor-changes
     bgp graceful-restart restart-time 120
     bgp graceful-restart stalepath-time 360
     bgp graceful-restart
     address-family ipv4
      redistribute connected
     exit-address-family
     address-family ipv4 vrf JGLOBE
      redistribute connected
      redistribute ospf 2
     exit-address-family
     address-family ipv4 vrf JLAN
      redistribute connected
      redistribute ospf 1
     exit-address-family
    ip dns view vrf JGLOBE default
    ip dns view vrf JLAN default
    ip route 0.0.0.0 0.0.0.0 192.168.5.1
    ip route vrf JGLOBE 0.0.0.0 0.0.0.0 GigabitEthernet0/1 192.168.5.1
    ip route vrf JLAN 0.0.0.0 0.0.0.0 192.168.4.1 name LAN_INET
    ip prefix-list GLOBAL-INET seq 5 permit 0.0.0.0/0
    ip prefix-list SERVER-NET seq 5 permit 10.6.40.2/32
    ip prefix-list WIFI-NET seq 5 permit 10.254.0.0/22 le 32

    Hi Matt
    Yes the X/32 routes needs to be present in the VRF Routing-Table and if they are to be learnt statically then the MP-iBGP config for that particular VRF address-family has to redistribute static routes as well.
    Regards
    Varma

  • ISR router EIGRP Route Tag

    Hi,
    Wondering any one has successfully set route tag for EIGRP routes?
    What I am trying to achieve here is to set route tag for the summary routes of the connected interfaces and subnets of some other connected interfaces.
    Let's say an ISR router R1 with IOS 15.1(4)M3 has three interfaces running with EIGRP.  
    Interface Gi0/0 
    ip add 172.16.0.1/24
    summary-add 172.16.0.0/16
    Interface Gi0/1 
    ip add 172.16.1.1/24
    summary-add 172.16.0.0/16
    Interface Gi0/2 
    ip add 192.168.2.1/24
    I am having difficulty to set route tag for summary add 172.16.0.0/16 and 192.168.2.0/24 before they get advertised to another router.
    Any idea please?
    Thanks
    Cedar

    Duplicate posts.  
    Go here:  https://supportforums.cisco.com/discussion/12256521/isr-router-eigrp-route-tag

  • Does a Router support 2 BGP As in one router

    Does a Router support 2 BGP As in one router. I have gone through the below Cisco page, however my router is not allowing to enter the second AS in the router, it is giving the error as usual " BGP is already running; AS is XX" . 
    http://www.cisco.com/c/en/us/td/docs/ios/12_2s/feature/guide/fsbgpdas.html#wp1056689
    My Router :- Cisco 3845
    IOS Version :- c3845-advipservicesk9-mz.124-24.T8.bin

    Hi,
    You can not run multiple BGP processes on a single router with each of them being in a separate AS. What you can do, and the link in your post explains that, is that towards a particular eBGP neighbor, you can use the neighbor local-as command to appear to be in a different AS than the one you really are in. So you do not start two BGP processes, you just make your single BGP process to appear to use a different ASN on a particular eBGP peering.
    Best regards,
    Peter

  • MPLS - unknown metric on routes found on BGP table

    Hi All,
    Wondering what are below highlighted value as they are used for route preferences.
    pe401c6506#sh ip bgp vpnv4 vrf DATA 10.18.0.0/16
    BGP routing table entry for 10.254.0.253:120:10.18.0.0/16, version 157413
    Paths: (2 available, best #2, table DATA)
      Advertised to update-groups:
         1          2          3          4          5          6          7
         8          10         11         12         13         14         15
         53
      Local, (aggregated by 65001 10.254.4.254), (Received from a RR-client), imported path from 10.254.4.254:120:10.18.0.0/16
        10.254.4.254 (metric 3) from 10.254.4.254 (10.254.4.254)
          Origin IGP, metric 0, localpref 100, weight 300, valid, internal, atomic-aggregate
          Extended Community: RT:65001:120
      Local, (aggregated by 65001 10.254.4.253), (Received from a RR-client), imported path from 10.254.4.253:120:10.18.0.0/16
        10.254.4.253 (metric 2) from 10.254.4.253 (10.254.4.253)
          Origin IGP, metric 0, localpref 100, weight 300, valid, internal, atomic-aggregate, best
          Extended Community: RT:65001:120
    *Note - Are red highlighted some sort of different metric from the BGP MED metric?
    Regards,
    Hin

    Hi Hin
    The Red Highlighted Metrics are the IGP Metrics to reach the MP-iBGP Peer which is the 8th Criterion for Best Path Selection Algo..
    If we will check for a show ip route 10.254.4.254/253 we will see the IGP metric as to be as the one highlighted in red above.
    Hope this helps to answer your query..
    Regards
    Varma

  • Does a route-policy override BGP split-horizon rule in IOS-XR?

    If I receive a default route from a non-client, can I turn around and send it to another non client if I have the following applied to the non-client?
    prefix-set send-default
      0.0.0.0/0
    end-set
    route-policy DEFAULT-POLICY
      if destination in send-default then
        pass
      else
        drop
      endif
    end-policy
     neighbor-group BLAH
      remote-as XXXXX
      password encrypted XXXXXXX
      description iBGP to Decryptors
      update-source Loopback0
      address-family ipv4 unicast
       route-policy DEFAULT-POLICY out
       soft-reconfiguration inbound always
     neighbor X.X.X.X
      use neighbor-group BLAH
    end

    Hi Carlopez,
    For BGP to inject a default rotue you need the "default-information originate" command, unfortunately, you can't redistribute or regenerate a route via the RPL method you described.
    regards
    xander

  • Route restriction on BGP

    Hi,
    I have two MPLS links from two different ISPs are terminating on a single router and eBGP is configured between PEs and CE router.  We have some sites are connecting via 1st IPS's MPLS link and some other sites are connecting via 2nd Mpls link from 2nd ISP.  But terminating on same CE Router.
    I am worried about, how do I confirm traffic from 1st link of 1st ISP should not leak to 2nd link from 2nd ISP and vise versa.  And also for forwarding traffic should maintain this.
    Please give me some idea on this.

    Hi,
    if you want to keep the MPLS clouds separated, just check carefully which prefixes you are advertising to each MPLS provider from your HQ site by the CE router peering to both.
    If you advertise only the local site prefixes (with an empty AS_PATH), each provider will not get the prefixes from the other provider and your HQ will be reachable from both MPLS clouds.
    You can easily configure
    ip as-path access-list 1 permit ^$
    route-map local_only permit 10
    match as-path 1
    router bgp ...
    nei x.x.x.x route-map local_only out
    nei y.y.y.y route-map local_only out
    on your HQ CE router.
    If you are not advertising default route or something similar from your HQ to the MPLS providers, only traffic with destination = your HQ should be delivered to your CE router.
    Best regards,
    Milan

  • Find Source IP of Router for Route Learned via BGP

    Hi All, 
    45 minutes of searching documents and google, and I cannot find a series of commands that will help me identify the Source IP of the router which advertised a route.  The router I am accessing is the on-premise router, and only has one neighbor from which it learns all the routes. 
    I recall being able to do this fairly easily in the past. 
    Regards,
    Jerry

    To clarify, 
    If I do
    show ip bgp neighbor 10.100.100.2 route
    I see about 100 routes learned from that neighbor. 
    Is there any way to track down where each of those routes came from?
    Thanks in advance,
    Jerry

  • Route tag is not added - ASR1000

    Hello,
    I am working an ASR1000 router with the configuration below.
    router ospf 1
    redistribute connected metric-type 1 subnets route-map TO-OSPF
    route-map TO-OSPF permit 10
    match ip address 100
    set tag 200
    access-list 100 permit ip 10.1.0.0 0.0.0.255 any
    access-list 100 permit ip 10.2.0.0 0.0.0.255 any
    access-list 100 deny   ip any any
    interface GigabitEthernet0/0/1
    ip address 192.168.0.253 255.255.255.0
    ip address 10.1.0.253 255.255.255.0 secondary
    ip address 10.2.0.253 255.255.255.0 secondary
    standby 1 ip 192.168.0.254
    standby 1 ip 10.1.0.254 secondary
    standby 1 ip 10.2.0.254 secondary
    I appended a secondary and standby address, and updated the access-list 100.
    But the route newly redistributed into OSPF didn't have the tag 200.
    I recreated and reapplied the route-map and ACL, but the problem was not solved.
    Is there any solution?
    Thanks,
    Jun

    I am not sure if I am right, but if you want the external routes to be tagged, like the 10.3.0.0/24 which you have mentioned, I believe you should have had that mentioned in the route-map.
    route-map TO-OSPF permit 10
    match ip address 100
    set tag 200
    access-list 100 permit ip 10.1.0.0 0.0.0.255 any
    access-list 100 permit ip 10.2.0.0 0.0.0.255 any
    access-list 100 deny   ip any any
    From the above and the logs you have attached, I understand that anything which is permit in the route-map will get tagged whereas the one's which are denied will not get tagged.
    A simple test can be made, where in you can do permit ip any any on the route-map and check if the tagging is happening to the routes you expect. If yes, then those routes should be in the permit list and the others in the deny.
    Hope this makes sense.

  • Advertising ipv4 routes via ipv6 bgp peers

    Hello,
    I have established IPV6 bgp sessions with ipv6 prefix-list filter. But ipv4 routes were advertised over this bgp session. Do I I need special configuration under address family or ipv4 prefix-list filters required ?
    Note : the config was  IBGP between 7200 routers and 6509 core switches.
    Thank you all
    Nael

    Hi Nael,
    This is because address-family ipv4 unicast gets activated by default when you configure a new neighbor in BGP. You either need to configure "no bgp default ipv4-unicast" or go under address-family ipv4 unicast and do a "no neighbor" for the ipv6 neighbor.
    Hope this helps

  • MPLS BGP routes push to DMVPN spokes

    I have an MPLS with BGP. I also have sites that are not connected directly to the MPLS, but have a s2s VPN to hub sites that are connected to the MPLS and that way they access the MPLS resources. I need to communicate the route changes to the MPLS when the DMVPN fails-over to another hub.
    Currently this is my config:
    Datacenter (MPLS only)
    interface GigabitEthernet0/1
    description MPLS
    ip address 192.168.0.34 255.255.255.252
    interface Vlan2
    ip address 192.168.96.2 255.255.255.0
    router bgp 65511
    bgp log-neighbor-changes
    network 192.168.96.0
    neighbor 192.168.0.33 remote-as 65510
    Hub site 1 (MPLS + internet)
    interface Tunnel200
    ip address 10.99.99.1 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication auth
    ip nhrp map multicast dynamic
    ip nhrp network-id 12345
    ip nhrp holdtime 600
    tunnel source GigabitEthernet0/0
    tunnel mode gre multipoint
    tunnel key 200
    tunnel protection ipsec profile dmvpn
    interface GigabitEthernet0/1
    description MPLS
    ip address 192.168.1.2 255.255.255.0 secondary
    ip address 192.168.0.2 255.255.255.252
    router bgp 65001
    bgp log-neighbor-changes
    network 192.168.1.0
    network 192.168.21.0
    !10.99 clients are DMVPN spokes
    neighbor 10.99.99.3 remote-as 99010
    neighbor 10.99.99.3 route-reflector-client
    neighbor 10.99.99.21 remote-as 99001
    neighbor 10.99.99.21 route-reflector-client
    !as 65000 is the MPLS PE
    neighbor 192.168.0.1 remote-as 65000
    Hub Site 2, has the same configuration, except for local ip address and router BGP ID.
    Spoke site:
    interface Tunnel200
    ip address 10.99.99.3 255.255.255.0
    no ip redirects
    ip mtu 1400
    ip nhrp authentication auth
    ip nhrp map 10.99.99.1 PUBLIC_IP_HUB_1
    ip nhrp map 10.99.99.16 PUBLIC_IP_HUB_2
    ip nhrp network-id 12345
    ip nhrp holdtime 600
    ip nhrp nhs 10.99.99.1 priority 1
    ip nhrp nhs 10.99.99.16 priority 5
    ip nhrp nhs fallback 60
    tunnel source GigabitEthernet0/0
    tunnel mode gre multipoint
    tunnel key 200
    tunnel protection ipsec profile dmvpn
    interface GigabitEthernet0/1
    description Internal
    ip address 192.168.3.1 255.255.255.192
    router bgp 99010
    bgp log-neighbor-changes
    network 192.168.3.0
    neighbor 10.99.99.1 remote-as 65001
    neighbor 10.99.99.16 remote-as 65013
    On this spoke site 
    #sh ip route
    B 192.168.1.0/24 [20/0] via 10.99.99.1, 00:47:01
    which is the HUB network, but the rest of the MPLS routes are not "learned".
    What am I missing?
    Thanks!

    Hi Jon, I've ommited the configuration of the MPLS provider routers in between.  The DC is connected to a router that has the AS 65510.
    DC:CPE---PE:{MPLS}PE---CPE:HUB---{internet}---Spoke
    The DC is ok getting the network information via BGP:
    #sh ip route
    B 192.168.3.0/24 [20/0] via 192.168.0.33, 3d05h
    B 192.168.21.0/24 [20/0] via 192.168.0.33, 3d05h
    #sh ip bgp 192.168.21.0
    BGP routing table entry for 192.168.21.0/24, version 559
    Paths: (1 available, best #1, table default)
    Not advertised to any peer
    Refresh Epoch 1
    65510 3549 6140 3549 65000
    192.168.0.33 from 192.168.0.33 (###.###.###.###)
    Origin IGP, localpref 100, valid, external, best
    #sh ip route 192.168.21.0
    Routing entry for 192.168.21.0/24
    Known via "bgp 65511", distance 20, metric 0
    Tag 65510, type external
    Last update from 192.168.0.33 3d05h ago
    Routing Descriptor Blocks:
    * 192.168.0.33, from 192.168.0.33, 3d05h ago
    Route metric is 0, traffic share count is 1
    AS Hops 5
    Route tag 65510
    MPLS label: none
    Spoke:
    #sh ip bgp
    BGP table version is 494, local router ID is 192.168.21.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
    x best-external, a additional-path, c RIB-compressed,
    Origin codes: i - IGP, e - EGP, ? - incomplete
    RPKI validation codes: V valid, I invalid, N Not found
    Network Next Hop Metric LocPrf Weight Path
    *> 10.0.129.32/27 10.99.99.16 0 65013 65012 3549 ?
    *> 192.168.96.0 10.99.99.16 0 65013 65012 3549 6745 65510 ?
    #sh ip route 192.168.96.0
    Routing entry for 192.168.96.0/24
    Known via "bgp 99001", distance 20, metric 0
    Tag 65013, type external
    Last update from 10.99.99.16 00:02:11 ago
    Routing Descriptor Blocks:
    * 10.99.99.16, from 10.99.99.16, 00:02:11 ago
    Route metric is 0, traffic share count is 1
    AS Hops 5
    Route tag 65013
    MPLS label: none
    #sh ip bgp 192.168.96.0
    BGP routing table entry for 192.168.96.0/24, version 465
    Paths: (1 available, best #1, table default)
    Not advertised to any peer
    Refresh Epoch 2
    65013 65012 3549 6745 65510
    10.99.99.16 from 10.99.99.16 (10.2.16.1)
    Origin incomplete, localpref 100, valid, external, best
    The route is not being updated to the rest of the routers, and the 192.168.21.0 network is still announced via the old route.
    (from spoke)
    ping 192.168.96.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.96.2, timeout is 2 seconds:
    Success rate is 0 percent (0/5)
    From DC
    #traceroute 192.168.21.1
    Type escape sequence to abort.
    Tracing the route to 192.168.21.1
    VRF info: (vrf in name/id, vrf out name/id)
    1 192.168.0.33 [AS 65510] 0 msec 0 msec 0 msec
    2 172.50.1.33 [AS 65510] 56 msec 36 msec 36 msec
    3 10.80.1.1 [AS 3549] 44 msec 44 msec 44 msec
    4 10.80.1.2 [AS 3549] 172 msec 172 msec 168 msec
    5 172.50.1.1 [AS 3549] 168 msec 168 msec 172 msec
    6 172.50.1.2 [AS 3549] 180 msec 180 msec 176 msec
    7 192.168.0.2 [AS 65000] 172 msec 172 msec 168 msec <- old route, should be 192.168.0.9
    8 192.168.0.2 [AS 65000] !H * !H

  • Filtering OSPF routes from MPBGP to BGP speaker in the same VRF

    I'm wondering if anyone has some ideas they an share on this.
    Assume the following:
    - CE1 is speaking *iBGP and OSPF to PE1 inside vrf foo
    - PE1 is mutually redistributing CE1's OSPF table with MPBGP
    - PE1 exchanges MPBGP routes with PE2.
    - PE2 is mutually redistributing CE2's OSPF table with MPBGP
    - CE2 is speaking *iBGP and OSPF to PE2 inside vrf foo
    So the problem is that the OSPF routes redistributed into MPBGP from via one CE are being announced to the other CE via the PE-CE BGP process.  Because those routes are already being received by the CE via the PE-CE OSPF process, they are showing up in the CE's BGP table as RIB failures.
    Is there any way to filter those out?  I've tried setting and matching tags and communities from within various redistribution points on the PE, but I can't seem to keep them out of the CE's BGP table.

    are you sure you are using iBGP on both sides and not eBGP?
    I'm asking because routes learnt by PE1 from CE via iBGP ( meaning same BGP AS number on CE1 and PE1 vrf foo) will not be propagated to CE2, because an iBGP route learned by a BGP speaker in not pushed to another iBGP speaker.
    So it means that a show ip bgp neighbor vrf foo advertised routes on PE2 shall  show that no routes from CE1 are being advertised to CE2.
    As mentionned earlier, changing BGP admin distance is an option. Let BGP have a better distance on your CEs and this should do the trick :
    router bgp xxx
    distance bgp 20 20 20
    Then after clearing bgp session, the rib failures are gone as OSPF is AD 110 and BGP is now AD 20 ( also remember that BGP does not annouces rib failure routes to other BGP peers)
    cheers

  • BGP Communities - Tagging our "own" range?

    Hi Everyone,
    We tag routes received from upstreams + peers(In BGP session), so we can easily control what we advertise to our customers that peer with us eg. Customer A only wants routes advertised to them from our "peering" partners(i.e. no Internet), Customer B only wants full table from our upstream carrier A, but nothing from carrier B...this works fine.
    My question is, how do we tag our own address block in a similar fashion?  (As we are not "receiving" it from someone via BGP, we cant tag it that way)
    i.e. If customer C wants our peering partner ranges, but also all of "our" range...it would be really simple to just have all our routes tag'd so we can create a community-list with the permitted community tags, create a route-map  that matches the community-list, then add it to the neighbour statement?  We can then even go further and break up our IP allocation into subsets, so customers can be restricted to certain "views/areas" of our network.
    Ive had very little sleep, so Im probably missing something extremely trivial here, or there is a much "easier" way to do this :)
    Cheers.

    Hi,
    how are you getting your BGP prefixes to the BGP table?
    Redistributing from some IGP?
    Or simply
    network ... mask ...
    command under your BGP process?
    In both cases you could use ... route-map tag-comm
    option and within the
    route-map tag-comm
    set community ....
    to any value you need.
    Best regards,
    Milan

  • Importing not-just-1-best bgp route to VRF in XR in case of unique RD per PE

    I'm trying to import  BGP prefix from several different sources into VRF for fast convergence. When RD on local and remote PE match, it works right away. But if RDs are different, then I can see many different routes in "sh bgp vpnv4 unicast rd x:x (remote PE's RD)" with NOT-IN-VRF flag, but only best one is present in "sh bgp vpnv4 unicast vrf YYY" or  "sh bgp vpnv4 unicast rd y:y (RD of local PE)". 
    As I understand, in IOS it is handled like this:
    router bgp 1
    address-family ipv4 vrf YYY
      import path selection all
      import path limit 4
    But can not figure out how to do it in XR. Any suggestions? Do not want to roll back to same-RD-on-all-PEs approach, as IOS doesn't do much of add-paths for VPNv4 ;(. 

    I dont know if this will exactly suit your needs but you can enable PIC (Prefix independent convergence) with the additional-paths command.
    The exact command depends on your XR version (additional-paths install backup or additional-paths election)
    Refer to the document:
    http://www.cisco.com/c/en/us/td/docs/routers/crs/software/crs_r4-1/routing/command/reference/b_routing_cr41crs/b_routing_cr41crs_chapter_01.html#wp2841279186

  • Inject BGP Default Routes into Multiple VRF before Best Path Selection

    Hello, 
    I have the following setup:
    Multiple Border Routers with eBGP sessions to external AS. We receive a default route from this multiple AS to keep the Table manageable. We noticed an important part of our traffic was been SW routed instead of CEF when we had the Full Internet table. Router Resources came to the ground when we changed to a default. 
    Now I want to separate this default routes into different VRF. Attached is the Diagram. 
    My question is,  the multiple default route all go into the BGP Table. The BGP table then select the best route and place it on the RIB and then to the FIB. 
    I want to redistribute the different Route on the BGP table prior to the Best path selection algorithm and placed on the RIB. 
    How can I achieve this?

    Hi,
    Redistribution of multiple routes to same prefix is not possible. Even if you have configured BGP multipath and all different bgp routes got installed into routing table, during redistribution only route will be redistributed. 
    Also would like to understand the requirement of redistributing multiple BGP routes in to IGP. As per your diagram, 3 different eBGP sessions are on three different routers, so you can prefer eBGP route over iBGP received from other routers and can distribute eBGP route to IGP from each router. Thus you will have three different default routes in to IGP in core.
    Please don't forget to rate this post if it has been helpful
    - Akash

Maybe you are looking for

  • HELP! Indesign Saving options turn in-active

    After working on a file for days all of the sudden my saving options (Indesig>File>Save) all turn light grey en in-active. Now my file is totally useless! Even after closing (and non-saving) an re-opening. So unless i save a new version every hour or

  • [SOLVED] Slow DNS lookup, I think

    Hi I have a really annoying problem. My DNS lookup in Arch is painfully slow. I know it's not a network problem, as I don't have any problems in my Ubuntu installation. I have tried to run two simple tests to show you what I mean. The first is a simp

  • "Not Authorized" problem • iTunes 9.0.2 • Nano 5th Gen ?

    I've had a look at a lot of posts on this subject but none that I have seen have helped me resolve the problem (I went back to the beginning of Nov in the posts menu), hence this post - *forgive me if the answer is buried here somewhere*. *Its a quer

  • Using RSCRM_REPORT to store query result into DSO

    Hi, Is there a way to use this transaction in order to store the query result in a DSO? I tried specifying as result table the one of active rows of the DSO but it always create a new table. Thanks for your reply

  • WHEN-TREE-NODE-SELECTED

    Hello alllll i have a master-detail block besides a tree block All i wanna do Simply and logically is to select a tree node then a Master-Detail records related to this tree node is to be retrieved... _i have the following code in the WHEN-TREE-NODE-