Routing via AUX port

I have a dial-up modem connected to my router's AUX port.
Using this setup, I need to get remote users to access our internal servers via dial-up.
The users aren't network admins, so they should not have exec access to the routers. They only need to be able to access the servers on our system, i.e. I need to route their Laptops's traffic via the aux port to the intended server.
Is there a way of configuring the router and modem to do this? Or do I need more equipment in order for this to work?
The router is a 2960 series and the modem is a US Robotics dial up modem.
Any help is greatly appreciated. Thanks!

These configs are a bit old and crusty , but they should give you an idea on how to set up async routing on the AUX ports. As Paolo says , performance is not brilliant, but it will work ... The chat scripts would likely need to be modified to suit your particular modems -
#####DIALING SIDE############
username PRIROUTER password SAMEPASSWORDS
chat-script modem "" "atdt\T" TIMEOUT 60 CONNECT \c
chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"
interface Async1
ip address 192.168.10.2 255.255.255.0
encapsulation ppp
async default routing
async mode interactive
dialer in-band
dialer string 5553731
dialer-group 1
ppp authentication chap
ip route 0.0.0.0 0.0.0.0 Async1
dialer-list 1 protocol ip permit
line aux 0
modem InOut
script reset rstusr
transport input all
flowcontrol hardware
script dialer modem
######RECEIVING SIDE##############
Username RouterA password cisco
interface Async1
ip address 192.168.10.1 255.255.255.0
encapsulation ppp
async default routing
async mode dedicated
dialer in-band
dialer-group 1
ppp authentication chap
ip route 0.0.0.0 0.0.0.0 async1
dialer-list 1 protocol ip permit
chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0" "OK"
line aux 0
modem InOut
script reset rstusr
transport input all
flowcontrol hardware

Similar Messages

  • Telnet to router through AUX port

    i have configured my router to telnet through modem dialin but when i dials from my pc to router it give me garbage charcter in my hyperterminal. can any one help me that is this is problem with my router configuration or the cable connection with the router.
    router AUX port --> ciscoconsole cable --> cisco 29-4043-01-->modem

    Even though the AUX port is supposed to "auto-baud" (usually you need to hit the "Enter" key a couple times), some/many/most/all current modems will set the DTE speed (the console cable) to the DCE speed (the modem-to-modem link) ... and "auto-baud" doesn't always work.
    Since the modems will (by default) connect at 56K (or the top speed), chances are that it will try to talk to your Cisco device at some baud above 9.6K, which it is probably expecting.
    You can do one of a couple things:
    Hard set the modems to a 9.6k DTE speed (and/or DCE speed, since you won't go faster then the slowest baud)
    OR
    Experiment on the router to hard set the DTE speed to the baud set on the modem's serial port (frequently 115 kilobaud).
    Check it out and get back to us.
    Good Luck
    Scott

  • Router keeps initiating session on aux port

    Hi all,
    I have a situation where I telnet to routerA. This router has, via its AUX port, a connection to routerB on the console-port.
    So I can normally do a reverse telnet from routerA to routerB. (via the lo0 on port 2001 on routerA)
    Problem is, routerA keeps trying to connect to routerB, thereby causing line 1 (for the AUX port) to be busy most of the time.
    Ergo, I'm having trouble connecting to routerB (If I try a couple of times, I usually succeed after a while)
    I can also confirm the login attempts when I do "monitor traffic line 1" (line 1 being the aux-port), and also in the ACS I see a lot of Failed login attempts from routerA with caller-id async
    I don't understand why routerA is tryiing to login to routerB, nor how to stop it while leaving my access intact ofcourse
    routerA
    interface loopback0
    ip address x.x.x.x x.x.x.x
    line aux 0
    session time-out 5
    modem inout
    transport preffered none
    transport input all
    transport output all
    routerB
    line con 0
    logging synchronous
    login local
    Any suggestions would be welcome....

    Hi Richard,
    this has solved it indeed, thanks a lot! Though it's unclear why the routerA was setting up sessions in the first place, at least its not doing so anymore.
    regards

  • How to Port forward your router via browser

    I Am having trouble port forwarding 19132 and I tried using airport extreme to port forward but everyTime I connect using my external ip it just fails.
    i Have port forwarded the port, and I did it correctly, hence I watched a few videos before and after. so I need to know how to port forward 19132 via browser.
    i Learned how to open the the config of the router via browser, or so I thought. I need to allow google access to my network, but I don't know how.
    please help.

    This is for Apple routers which do not use browser setup.. you must use the airport utility for any setup.
    There is particular advice by the section GURU.. Tesserax on how to port forward in apple routers.
    Finding the tips is now an exercise though.
    AirPort - Port Mapping Basics using AirPort Utility v6.x

  • Cisco asr1000 aux-port

    Hi. I have a Cisco ASR 1006 Router, with the the aux-port connected but i can´t configure the "line aux 0".. the line does not exist in the running config. 
    http://www.cisco.com/c/en/us/td/docs/routers/asr1000/install/guide/asr1routers/asr1higV8/asr1_hw2.html
    In the related link Cisco says "The AUX port is a diagnostics access port". 
    I need to connect Cisco ASR1000 Aux-port with a Cisco CRS Console-Port as a second remote control method.
    I Wish to confirm this before deploy several sites in the same way.
    Thanks

    Hi Saima,
    With the Cisco 7942, you would leverage the setting under
    the product specific porting of the config via device>phone
    and set Wireless Headset Hookswitch Control to Enabled
    http://headsetplus.com/PDF/Jabra-EHS-guide.pdf
    Cheers!
    Rob
    "And if I should fall behind
    Wait for me" - Springsteen

  • ASR 1006 Aux port

    I can't use Aux port for ASR 1006, becouse i can't find it in configuration.
    Version: asr1000rp2-advipservicesk9.03.07.05.S.152-4.S5.bin"
    router#sho line ?
      <0-16>       First Line range
      async-queue  Show async-queue
      console      Primary terminal line
      summary      Quick line status summary
      vty          Virtual terminal
      |            Output modifiers
     <cr>
    router#sho line 
       Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int
         0 CTY              -    -      -    -    -      0       0     0/0       -
    *    1 VTY              -    -      -    -    1      4       0     0/0       -
    *    2 VTY              -    -      -    -    1     16       0     0/0       -
    *    3 VTY              -    -      -    -    1      2       0     0/0       -
         4 VTY              -    -      -    -    1      3       0     0/0       -
    Can you help me whith my problem?

    Hi,
    I see you are using initiator unclassified ip-address. How exactly are you trying to trigger the session here? What type of traffic are you sending from your CPE? Please make sure you send a packet which 'crosses' the ISG box. A packet with destination the ISG will not trigger a session. Only a packet that needs to be forwarded by the ISG will. If you are not seeing anything with those debugs, it seems like no FSOL is seen to spawn the session.
    Also, if your subscriber is connected with L2 network, why do you configure "ip subscriber routed"? This is conceptually wrong since you are telling to ISG that the subscriber is connecting via a L3 routed network which is not correct according to what you say.
    Regards

  • Connecting iMac to ASDL router via home Phone Network Adaptor (PNA)

    I connect to the internet via an ASDL Router from BT called the Network 1200.
    This allows other computers in the home to connect to the router via a telephone point close to the computer. This is achieved by plugging a Phone Network Adaptor into a USB port on the computer on one end and the telephone socket on the other. The driver for the PNA is contained on disc. I have been connecting several PCs to the router in this way for many years.
    I then buy a new iMac, load the driver for the PNA. Plug it into the USB port (expecting this to connect the iMac to the router and so achieving an internet connection) ....but nothing happens. iMac doesn't even acknowledge something has been plugged into a USB port. This works perfectly well with any other PC.
    Can anybody help steer me in the right direction to solve this?
    Thanks
    Unbeaten449

    The Driver was meant to be compatible with a Mac but I guess it could have been for earlier Macs and operating systems. Next question is where do I get one if one exists?
    Unbeaten449

  • Is It possible connect two router**from console port to console port

    Hi,
    I need this for doing reverse telnet.
    Thanks very much

    No
    you can connect router 1's aux port to router 2's console port.
    line aux 0
    password blablabla
    login
    modem InOut
    transport input all
    find the aux port's line number which depends on the router model then telnet to a live ip on router 1 on that port.
    Worc_3640#sh line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
    0 CTY - - - - - 0 0 0/0 -
    129 AUX 9600/9600 - inout - - - 0 0 0/0 -
    * 130 VTY - - - - - 75 0 0/0 -
    so say 10.1.1.100 2129 if 10.1.1.100 is on that box.
    should get you going..
    Chris

  • Connection a RS232 device to the Aux port.

    Dear,
    I have a home lab wthe a 2600 access server (16 port octal).
    From this 2600 router I want to connect to a Raritan 8 ports RPC.
    This RPC (Remote power control) has a rs232 serial port (RJ45)
    I tried a lot and still I do not get connected to the RPC, has anyone ever done this before.
    When I use a rs232 serial cable from the RPC to my serial pc port, I get into the rpc directly when putty is opened.
    pinout  RPC
    Pinout Aux (cisco)
    Pinout rs-232 (db9)
    1  DTR
    1  RTS
    1  DCD
    2  GND
    2  DTR
    2  RX
    3  RTS
    3  TX
    3  TX
    4  TX
    4  GND
    4  DTR
    5  RX
    5  GND
    5  GND
    6  -
    6  RX
    6  DSR
    7 GND
    7  DSR
    7  RTS
    8 DCD
    8  CTS
    8  CTS
    9  RI (ring indicator)
    I created several cables without succes.
    I connected RTS to CTS and DTR to DSR.
    On aux port I used the following.
    speed 9600 8n1
    transport all
    modem inout
    (also tried with modem printer)
    I'm missing something to get is working.
    Any help?
    Kind regards,
    Remko

    If you attach this USB drive to your Mac can it be accessed now?

  • How to disable AUX port in ASR 9010

    Hi All,
    How to disable the AUX port in ASR 9010. Inside "line aux" I can't configure anything except "login authentication" (which is used for aaa authentication).
    Also after IOS XR 3.2 the configuration for AUX port has been removed
    Platform used: ASR 9010
    Version: IOS-XR 4.1.2
    Best Regards
    Saikat Chakraborty

    Hi Saikat,
    AUX has the same authentication method as we have on the system.  From this perspective, AUX is protected the same way as the Console port and only those who have an account can login via AUX (same way as via console). Any attempts to log on AUX will be logged:
    Successful:
    ksh[65902]: Successfully authenticated user 'XXX' for ksh access via 'aux' on '0/RSP0/CPU0'
    Incorrect:
    ksh[65902]: Failed authentication attempt by user 'YYY' for ksh access via 'aux' on '0/RSP0/CPU0
    But if anyone has a physical access to the device, that would be even bigger threat compare to system protected AUX login.
    BTW, tacacs authentication should work for AUX too. We’d need to define a template for it.
    Example:
    aaa authentication login tacacs_template group tacacs+ local
    line template aux
          login authentication tacacs_template
    Regards,
    /A

  • Aux port configuration

    Hi,
    I have a following configuration:
    Router AUX port -> FW Console
    If there is something problem in the FW I can log the FW from cisco aux but the problem is now that the aux port is sending character's to FW's console port and now if the FW is rebooting it will go bootloop because when the FW boot's there is situation where is something "press any key" and now cisco router sends characters and the FW boots again.
    Router AUX port config is following:
    line aux 0
    no exec
    transport input all
    stopbits 1
    Which aux-port config the Cisco won't send any character to FW's console.
    br
    J

    Hi Jody,
    Thanks for your reply.
    Actually I have no logging console configured at router but I will configure this also to the FW..I forgot to configure this at FW :)

  • Cisco Router 2600 Serial Port communications

    I am working on configuring communications Router to Router through serial port. I have seen some videos and read some documentations. My configuration is as follows: 
    R1 (DCE) -> f0/0 192.168.1.1/24 - s0/0 192.168.2.1/24 <-----> Router2 ->(DTE)  S0/1 192.168.2.2/24 f0/0 192.168.3.1.
    I have configured the routing tables at both routers. It works when I ping from router to router and router to hosts successfully. Nevertheless, I can ping from hosts to the default gateways, but I cannot ping from hosts to the serial ports (adjacency). In short I cannot communicate from Network1 to Network2. Please do I have to do any extra configuration.

    Router 1 (KelliR)
    KelliR#show ip interface brief
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                192.168.1.1     YES manual up                    up
    Serial0/0                  192.168.3.1     YES manual up                    up
    TokenRing0/0               unassigned      YES unset  administratively down down
    Serial0/1                  unassigned      YES unset  administratively down down
    KelliR#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
    C    192.168.1.0/24 is directly connected, Ethernet0/0
    S    192.168.2.0/24 [1/0] via 192.168.3.2
    C    192.168.3.0/24 is directly connected, Serial0/0
    ============================================
    Router 2 (HelderR)
    HelderR#
    HelderR#show ip interface brief
    Interface                  IP-Address      OK? Method Status                Protocol
    Ethernet0/0                192.168.2.1     YES manual up                    up
    Serial0/0                  192.168.3.2     YES SLARP  up                    up
    TokenRing0/0               unassigned      YES unset  administratively down down
    Serial0/1                  unassigned      YES unset  administratively down down
    HelderR#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    Gateway of last resort is not set
    S    192.168.1.0/24 [1/0] via 192.168.3.1
    C    192.168.2.0/24 is directly connected, Ethernet0/0
    C    192.168.3.0/24 is directly connected, Serial0/0
    ============================================
    Even with  f0/0 and s0/0 configured with the addresses in any router, no host at its respective routers is able to ping the s0/0. Hosts are able to ping its ethernet ports.
    See ping comand below:
    From router KelliR
    KelliR#ping 192.168.3.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
    KelliR#ping 192.168.2.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms
    KelliR#ping 192.168.2.101
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.101, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
    KelliR#
    ==================================================================================
    From router HelderR
    HelderR#ping 192.168.3.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.3.1, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/33/36 ms
    HelderR#ping 192.168.1.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms
    HelderR#ping 192.168.1.101
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.101, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms
    HelderR#
    ====================================================
    From Host connected to KelliR
    C:\>ping 192.168.1.1
    Pinging 192.168.1.1 with 32 bytes of data:
    Reply from 192.168.1.1: bytes=32 time=2ms TTL=255
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=255
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=255
    Reply from 192.168.1.1: bytes=32 time=1ms TTL=255
    Ping statistics for 192.168.1.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 2ms, Average = 1ms
    C:\>ping 192.168.3.1
    Pinging 192.168.3.1 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Ping statistics for 192.168.3.1:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)
    =====================================================
    From Host connected to HelderR
    C:\Users\Helder>ping 192.168.2.1
    Pinging 192.168.2.1 with 32 bytes of data:
    Reply from 192.168.2.1: bytes=32 time=3ms TTL=255
    Reply from 192.168.2.1: bytes=32 time=1ms TTL=255
    Reply from 192.168.2.1: bytes=32 time=1ms TTL=255
    Reply from 192.168.2.1: bytes=32 time=1ms TTL=255
    Ping statistics for 192.168.2.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 1ms, Maximum = 3ms, Average = 1ms
    C:\Users\Helder>ping 192.168.3.2
    Pinging 192.168.3.2 with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    Ping statistics for 192.168.3.2:
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

  • Out-of-band dialin to AUX port

    Hi
    Setting up a modem to dial into on the AUX port has been a nightmare. I have the following configured on R1:
    line aux 0
    password cisco
    login
    modem inout
    speed 115200
    flowcontrol hardware
    transport input all
    modem auto configure type default
    I then have to reverse telnet to the modem, this being necessary for a remote dialin to connect to the aux port. However, when I dialin from a remote pc using the normal Microsoft dial-up connection, I get a black window with a blinking prompt but I'm unable to type in window. If I enter a command in the window, I can see it being entered into the modem of the AUX port. If I click the button called DONE on this screen, it gets stuck on "verifying username and password". The reverse consol session then shoots out garbage characters and connection drops.
    All I want is a simple out-of-band dialin to connect to a remote router. I have spent 2 valuable days on this and gone through all documentation. Is it my dial-up connection or the modem (the modem is a standard 56k V.92/V.90 with NO dip switches only software switches). The only AT command I've used is the at&f1s0=1 I simply cannot get hold of a USRobotics modem in this country. I have tried connecting at 9600 but that doesn't work.
    Help please
    Marcus

    look here http://www.cisco.com/en/US/tech/tk801/tk36/tech_configuration_examples_list.html

  • HT5429 Can the maps voice be routed via Bluetooth to my car's speakers?

    Can the iPhone 5 Maps app voice instructions be routed via Bluetooth to my car - the way the telephone does?
    Thanks.
    raywat

    As KiltedTim says, you most likely have to set your car stereo to select your iPhone as its music source.
    For my Acura I have to select Aux/Bluetooth in order to have turn-by-turn directions come out my car speakers. This also means I have to have my iPhone as my music source. No car AM/FM radio, satellite radio, cd, etc…
    I have found that Apple's maps and Waze can be told to use the iPhone speakers for turn-by-turn directions, but Google maps always seems to vector to Bluetooth if my hand free phone link is synced.

  • When I connect my Mac Mini 2011 with Lion to a TV via HDMI and an earphone cable is plugged in, it´s not possible to choose sound out via hdmi, as opposed to connection via minidisplay port. Anybody knows how to fix this?

    When I connect my Mac Mini 2011 with Lion to a TV via HDMI and an earphone cable is plugged in, it´s not possible to choose sound out via hdmi, as opposed to connection via the minidisplay port. Anybody knows how to fix this?

    Was just on the phone with Apple about this.
    The solution was as follows for me anyway...
    Go to your Finder
    Choose the Go Menu
    Choose Computer
    Choose your Macintosh Hard Drive
    Choose your "Library" Folder
    Choose the "Preferences" Folder
    There should be a folder called "Audio"
    Move that whole folder to the trash
    Empty the Trash
    Restart from the Apple Menu
    When you are back up and running;
         Choose System Preferences from the Apple Menu
         Choose Sound
          In the output tab you should now be able to make the HDMI "Sticky"
          Enjoy your sound over HDMI and no more dirty knees or broken backs unplugging the desktop speakers!
    Mac Mini 2011 2.5Ghz 8 GB of RAM - Planar 17" VGA via display port adapter and Samsung 26" LCD TV via HDMI

Maybe you are looking for