SNMP v3 TRAP

Hi,
We are trying to configure SNMP V3 trap on our routers and switches. I can able send V3 trap to our NMS, but it is mentioned that we need contextengine and contextname to process the trap.
We have configured a simple TRAP configuration without aut and priv.
How can i find the context information.Is this is configurable.How ?
Here is my trap configuration
snmp-server user TRAP TRAP v3
snmp-server group TRAP v3 noauth notify *tv.FFFFFFFF.FFFFFFFF.FFFFFFFF.FFFFFFFF0F
snmp-server host 10.4.x.x version 3 noauth TRAP
Thx
-uthay

You don't need context information for sending traps.  Your NMS will need to know the SNMP engineID of the agent, however.  You can find that with the "show snmp engine" command.  You will then need to configure your NMS with the agent's engineID and authentication/privacy parameters.

Similar Messages

  • Snmp enable traps slb ft

    I trying to enable snmp traps on the CSM-S in order to get notification through HP Openview Network Node Manager that a 'fault tolerant' event has taken place. I am running 2.1(5) code.
    I found the command reference for the CSMS 2.x code:
    http://www.cisco.com/en/US/customer/docs/interfaces_modules/services_modules/csms/2.1.1/command/reference/s.html#wp1057213
    There is a reference to the command: snmp enable traps slb ft
    This is supposed to send an SNMP trap when the CSM transitions from standby to active after detecting a failure in its fault tolerant peer.
    This example shows how to enable fault tolerant traps:
    Cat6k-2(config-module-csm)# snmp enable traps slb ft
    This command is not available in CSM configuration mode. In fact, there are no snmp commands at all in the CSM config mode.
    Do I have to enable something globally on the 6500 first?

    The "config" trap enables the ciscoConfigManEvent notification, which triggers when you exit configuration mode or do a SNMP set.
    The "config-copy" and "copy-config" traps are the same thing on different platforms, and enables the ccCopyCompletion trap, and triggers when a configuratio copy operation via SNMP completes.
    The "config-ctid" trap enables either the ccmCTIDRolledOver or ciscoConfigManCTIDNotifyGroup, which appears to be related to the configuration change tracking identifier feature.

  • SNMP Configuration Traps

    Hey Guys,
    Can someone explain to me - or point me in the direction - where I may be better able to determine the difference between the following taps.
         config                Enable SNMP config traps
         config-copy       Enable SNMP config-copy traps
         config-ctid         Enable SNMP config-ctid traps
         copy-config       Enable SNMP config-copy traps
    Thanks
    Nik

    The "config" trap enables the ciscoConfigManEvent notification, which triggers when you exit configuration mode or do a SNMP set.
    The "config-copy" and "copy-config" traps are the same thing on different platforms, and enables the ccCopyCompletion trap, and triggers when a configuratio copy operation via SNMP completes.
    The "config-ctid" trap enables either the ccmCTIDRolledOver or ciscoConfigManCTIDNotifyGroup, which appears to be related to the configuration change tracking identifier feature.

  • Snmp/bgp traps

    Hi
    Is there anyway of limiting the type of traps to be sent to a particular SNMP management station? When I enable snmp-server enable trap ds1 e.g., I would only like that type of trap to go to SNMP Server A and not SNMP Server B. Can't think of any way myself?
    Regards
    Mary

    Hi Farrukh
    When I type the command snmp-server host 10.50.1.228 traps snmp ? , I get the traps below but not linkup linkdown. The router is running flash:c2800nm-entservicesk9-mz.124-7a.bin. Output of what I see below.
    Router_A#(config)#snmp-server host 10.50.1.228 traps snmp ?
    atm Allow SNMP atm traps
    bgp Allow BGP state change traps
    bstun Allow bstun event traps
    bulkstat Allow Data-Collection-MIB traps
    cnpd Allow NBAR Protocol Discovery traps
    config Allow SNMP config traps
    config-copy Allow SNMP config-copy traps
    cpu Allow cpu related traps
    dlsw Allow dlsw traps
    dnis Allow SNMP DNIS traps
    ds0-busyout Allow ds0-busyout traps
    ds1 Allow SNMP ds1 traps
    ds1-loopback Allow ds1-loopback traps
    ds3 Allow SNMP ds3 traps
    dsp Allow SNMP DSP traps
    dspu Allow dspu event traps
    eigrp Allow SNMP EIGRP traps
    entity Allow SNMP entity traps
    envmon Allow environmental monitor traps
    event-manager Allow SNMP Embedded Event Manager traps
    flash Allow SNMP FLASH traps
    frame-relay Allow SNMP frame-relay traps
    hsrp Allow SNMP HSRP traps
    icsudsu Allow SNMP ICSUDSU traps
    ipmobile Allow SNMP ipmobile traps
    ipmulticast Allow SNMP ipmulticast traps
    isdn Allow SNMP ISDN traps
    l2tun-session Allow SNMP L2 tunnel protocol traps
    mpls-ldp Allow SNMP MPLS label distribution protocol traps
    mpls-traffic-eng Allow SNMP MPLS traffic engineering traps
    mpls-vpn Allow SNMP MPLS Virtual Private Network traps
    msdp Allow SNMP MSDP traps
    mvpn Allow Multicast Virtual Private Network traps
    ospf Allow OSPF traps
    pim Allow SNMP PIM traps
    rsrb Allow rsrb event traps
    rsvp Allow RSVP flow change traps
    rtr Allow SNMP Response Time Reporter traps
    sdlc Allow sdlc event traps
    sdllc Allow sdllc event traps
    snmp Allow SNMP-type notifications
    stun Allow stun event traps
    syslog Allow SNMP syslog traps
    tty Allow TCP connection traps
    udp-port The notification host's UDP port number
    voice Allow SNMP Voice traps
    vrrp Allow SNMP vrrp traps
    vsimaster Allow SNMP vsimaster traps
    vtp Allow SNMP VTP traps
    x25 Allow x25 event traps
    xgcp Allow XGCP protocol traps
    Any ideas?
    Regards
    Mary

  • Snmp v2c trap receiver

    Hi all
    By using snmp4j packege I have written a trap listener code for snmpV3, but am not able to catch any trap. In etherial i am getting snmp trap.
    Could anyone please tell me whats wrong with my program...
    public class V3trapListen {
    public V3trapListen() { }
    public synchronized void start(String address) throws Exception {
    UdpAddress listenAddress = new UdpAddress(address);
    ThreadPool threadPool = ThreadPool.create("DispatcherPool", 2);//1
    MessageDispatcher mtDispatcher =
         new MultiThreadedMessageDispatcher(threadPool,
              new MessageDispatcherImpl());//2
    // add message processing models
    mtDispatcher.addMessageProcessingModel(new MPv1());
    mtDispatcher.addMessageProcessingModel(new MPv2c());
    mtDispatcher.addMessageProcessingModel(new MPv3());
    // add default security models
    SecurityProtocols.getInstance().addDefaultProtocols();
    Snmp snmp = new Snmp(mtDispatcher);
    CommunityTarget target = new CommunityTarget();
    if(target != null) {
              target.setCommunity(new OctetString("public"));
              target.setAddress(listenAddress);
         target.setVersion(SnmpConstants.version3);
         } else {
              System.out.println("Unable to create Target object");
              System.exit(-1);
    CommandResponder trapPrinter = new CommandResponder() {
    public void processPdu(CommandResponderEvent e) {
    PDU command = e.getPDU();
    if (command != null) {
    System.out.println("\n"+e.getPDU());
    if (snmp.addNotificationListener(listenAddress, trapPrinter)) {
    snmp.listen();
    System.out.println("snmp.addNotificationListener returned TRUE ");
    System.out.println("Waiting for [trap] on "+listenAddress.toString());
    try {
         this.wait();
    catch(InterruptedException ex) {
    System.out.println("Caught InterruptException: "+ex.toString());
    catch(Exception ex) {
         System.out.println("CaughtException: "+ex.toString());
    } else {
    System.out.println("snmp.addNotificationListener returned FALSE");
    System.out.println("TestListener closing...");
    regards
    sanjay

    I use Ciscoworks LMS to send me emails when a given syslog arrives. (syslog, automated Actions)
    It can also take SNMP TRAPS, not sure if it can actually send you email when it gets a specific TRAP, but i guess it can.
    Any linux server with the right basic tools will also do the same.
    castlerock SNMPc is a very good SNMP tool, and can search and email among other things.
    Also gives you a Red,amber, green view and polls devices f.x. for a given service, like a TCP port.
    highly customizable.

  • Problems understanding SNMP OIDs/Traps

    Dear Community,
    i would be very glad if you could help me with this thopic...i seem to have some trouble understanding it...
    Here an example:
    2010-01-18 06:28:44    Unknown alert received from device ber-be-swt01.is24-rz.de of type SwCiscoIOS. Device Time 82+21:21:53. (Trap type 1.3.6.1.4.1.9.9.43.2.0.1.6.0)\nTrap var bind data: \nOID:  1.3.6.1.4.1.9.9.43.1.1.6.1.3.738  Value:  1\nOID:  1.3.6.1.4.1.9.9.43.1.1.6.1.4.738  Value:  4\nOID:  1.3.6.1.4.1.9.9.43.1.1.6.1.5.738  Value:  2\nOID:  1.3.6.1.6.3.18.1.3.0  Value:  10.3.32.2
    Ok. Let's take the trap type:
    1.3.6.1.4.1.9.9.43.2.0.1.6.0
    Searching with SNMP Object Navigator (http://tools.cisco.com/Support/SNMP/do/BrowseOID.do?local=en) i only get as far as:
    1.3.6.1.4.1.9.9.43.2.0.1   -> ...6.0 is unkown.
    If i search for the OID
    1.3.6.1.4.1.9.9.43.1.1.6.1.3.738 for example
    i get the following:
    1.3.6.1.4.1.9.9.43.1.1.6.1.3  -> ...738 is unknown.
    This happens with a lot of OIDs for me (not just these ones). If i understand the OID correctly, this could be a command from the command line which forced this trap.
    So what's the .738 for? Why couldn't it be recognised by the search-function?
    In advance i like to thank you for any feedback.
    Sven Schlingloff

    Try using my search and translate tool at http://jaguar.ir.miami.edu/~marcus/snmptrans.html .  If you do, you will see that 1.3.6.1.4.1.9.9.43.2.0.1.6.0 translates to ciscoConfigManEvent.  The OID 1.3.6.1.4.1.9.9.43.1.1.6.1.3.738 translates to ccmHistoryEventCommandSource.  However, ccmHistoryEventCommandSource'd OID is 1.3.6.1.4.1.9.9.43.1.1.6.1.3.  The .738 is the specific instance.  The definition of ccmHistoryEventCommandSource is:
    "The source of the command that instigated the event."
    This object comes from the ccmHistoryEventTable which is indexed by the ccmHistoryEventIndex object.  The definition of that object is:
    "A monotonically increasing integer for the sole
    purpose of indexing events.  When it reaches the
    maximum value, an extremely unlikely event, the agent
    wraps the value back to 1 and may flush existing
    entries."
    So, the 738 is simply a unique number which identifies this particular history event.

  • LMS 3.2.1 integration with Clarity NMS for snmp trap forwarding

    Our client have integrated Clarity NMS to Ciscoworks LMS 3.2.1. So far they are receiving raw alarms/snmp traps but it lacks information/inventory of the originating device. Kindly see sample raw alarms below:
    2420: 2011-11-25 12:10:46 Received trap ==> Received SNMPv1 Trap
    Community=ciscoworks
    Enterprise=1.3.6.1.6.3.1.1.5
    Generip trap type=2
    Specific Trap Type=0
    Trap From=10.220.10.1
    Trap ID=1.3.6.1.6.3.1.1.5.2
    Trap Time=-1436283373
    1.3.6.1.2.1.2.2.1.1.83=83
    1.3.6.1.2.1.2.2.1.2.83=GigabitEthernet1/40
    1.3.6.1.2.1.2.2.1.3.83=6
    1.3.6.1.4.1.9.2.2.1.1.20.83=Lost Carrier
    EndTrap
    10933: 2011-11-24 11:57:53 Received trap ==> Received SNMPv1 Trap
    Community=ciscoworks
    Enterprise=1.3.6.1.4.1.9.1.291
    Generip trap type=2
    Specific Trap Type=0
    Trap From=10.220.10.1
    Trap ID=1.3.6.1.4.1.9.1.291.2
    Trap Time=1628056965
    1.3.6.1.2.1.2.2.1.1.8=8
    1.3.6.1.2.1.2.2.1.2.8=E1 0/0/0
    1.3.6.1.2.1.2.2.1.3.8=18
    EndTrap
    As you can see, those raw alarms doesn’t contain any information about the originating equipment or the physical card, port related information where those alarms were generated. Instead those alarms received are just NMS level alarms.
    How do we resolve this so that the inventory of the equipment would be part of the trap to be received by Clarity from Ciscoworks.

    Hi,
    Is the issue you have the source IP address of the forwarded trap?  Per RFC it is the IP of the actual device sending the trap.  The originating IP should be contained within the packet. I have included some additional information you may find helpful.
    Q. What is the difference between SNMP Raw Trap Forwarding and SNMP Trap alert/event Trap Forwarding? Does DFM support both?
    A. You can configure raw trap forwarding at DFM > Other configuration > SNMP Trap forwarding, and processed event/alert trap forwarding at DFM > Notification Services > SNMP Trap Forwarding. Processed trap is "when DFM receives certain SNMP traps, it analyzes the data found in fields (Enterprise/Generic trap identifier/Specific Trap identifier/variable−bindings) of each SNMP trap message, and changes the property value of the object property (if required)". Raw trap is the trap that the device forwards to DFM and DFM has yet to process it. For more information, refer to the DFM User Guide. Yes, DFM supports both ways of trap forwarding.
    http://www.cisco.com/en/US/products/sw/cscowork/ps2421/products_qanda_item09186a0080a9b35b.shtml
    DFM will only forward SNMP traps from devices in the DFM inventory. It will not change the trap format—it will forward the raw trap in the format in which the trap was received from the device. However, you must enable SNMP on your devices and you must do one of the following:
    Configure SNMP to send traps directly to DFM
    Integrate SNMP trap receiving with an NMS or a trap daemon
    The versions of SNMP traps supported by DFM are described in SNMP and ICMP Polling. For information on forwarding processed and pass-through traps, see Processed and Pass-Through Traps, and Unidentified Traps and Events.
    Pass-through traps are traps that DFM receives from devices that are not in the DFM inventory, and DFM has not processed. Forwarding these traps is controlled using Configuration > Other Configurations > SNMP Trap Forwarding. These traps are shown in the Alerts and Activities display because of their relevance to fault monitoring. Pass-through traps are displayed as follows:
    As one of the following events:
    > InformAlarm
    > MinorAlarm
    > MajorAlarm
    With the device type and the device name from which it was generated.
    If DFM does not know which device generated the trap, it ignores the trap. Pass-through traps will be cleared after a default interval of 10 minutes to one hour
    http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_device_fault_manager/3.2/user/guide/dfm32ug_Book.html

  • SNMP TRAP on EvENT

    Hi & Thanks for read it,
    I would like to design SNMP event, traps in order to be managed by SNMP Network management platform, like HP OpenView, or other.
    It's possible to generate a trap in pl/sql or via enterprise manager on procedure event?
    Anyone have test log4plsql for send traps?
    Anyone know if it's possible to send traps via OS COMMAND on ORACLE?
    Thanks

    I don't want to use oracle MIB. I want to use my own
    MIB.
    For example I want to send a trap if process of ETL
    fails.I am not expert of SNMP setup but looks like Oracle SNMP support in this respect is kinda limited. Hope others may have better idea.

  • Prime Infrastructure 2.1 - Fan-Failure SNMP-Trap Issue

    Hello,
    I am facing the following Prime Infrastructure (v2.1) issue:
    - A Fan-Failure SNMP-Trap from a Cisco 3650 switch doesn't appear on Prime, but a Link-Failure from the same switch does.
    - The both events appears on Prime with Syslog.
    - The command "snmp-server enable traps envmon fan shutdown supply temperature status" is set up.
    - The switch is in "Managed" state in PI, I have checked the ACL at the "snmp-server community" command, it is okay.
    - I have set up an SNMP-Trace for the switch on PI, but only "SNMP Null was returned for class com.cisco.server.managedobjects.bridge.Fan3KStats attribute fanIndex" arrived. Please find the log below.
    07/02/14 12:39:53.211 TRACE [presence-9] [] Adding attributes for object Fan3KStats[151206060_,1012]
    07/02/14 12:39:53.211 TRACE [presence-9] [] Index name : fanIndex
    07/02/14 12:39:53.211 TRACE [presence-9] [] Index Value : 1012
    07/02/14 12:39:53.211 TRACE [presence-9] [] Device MIB table index: .1012
    07/02/14 12:39:53.211 TRACE [presence-9] [] MIB table row index: .1012
    07/02/14 12:39:53.211 TRACE [presence-9] []     OID for : fanIndex = 1.3.6.1.2.1.47.1.1.1.1.1.1012
    07/02/14 12:39:53.211 TRACE [presence-9] []     OID for : fanOperStatus = 1.3.6.1.4.1.9.9.13.1.4.1.3.1012
    07/02/14 12:39:53.211 TRACE [presence-9] [] Get fragment
    07/02/14 12:39:53.211 TRACE [presence-9] [] Creating PDU: Get
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.2.1.47.1.1.1.1.1.1010
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.4.1.9.9.13.1.4.1.3.1010
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.2.1.47.1.1.1.1.1.1011
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.4.1.9.9.13.1.4.1.3.1011
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.2.1.47.1.1.1.1.1.1012
    07/02/14 12:39:53.211 TRACE [presence-9] []     VarBind OID=1.3.6.1.4.1.9.9.13.1.4.1.3.1012
    07/02/14 12:39:53.218 TRACE [presence-9] [] Error Status: 0
    07/02/14 12:39:53.218 TRACE [presence-9] [] Error index:  0
    07/02/14 12:39:53.218 TRACE [presence-9] [] SNMP Null was returned for class com.cisco.server.managedobjects.bridge.Fan3KStats attribute fanIndex
    07/02/14 12:39:53.218 TRACE [presence-9] []     Setting attribute: fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] []     SnmpInt Value : ?
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes, storing result, class=com.cisco.server.managedobjects.bridge.Fan3KStats, attr=fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] [] SNMP Null was returned for class com.cisco.server.managedobjects.bridge.Fan3KStats attribute fanIndex
    07/02/14 12:39:53.218 TRACE [presence-9] []     Setting attribute: fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] []     SnmpInt Value : ?
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes, storing result, class=com.cisco.server.managedobjects.bridge.Fan3KStats, attr=fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] [] SNMP Null was returned for class com.cisco.server.managedobjects.bridge.Fan3KStats attribute fanIndex
    07/02/14 12:39:53.218 TRACE [presence-9] []     Setting attribute: fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] []     SnmpInt Value : ?
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes, storing result, class=com.cisco.server.managedobjects.bridge.Fan3KStats, attr=fanOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes, assembling attributes
    07/02/14 12:39:53.218 TRACE [presence-9] []     MIB lookup, OID for: powerSupplyIndex = 1.3.6.1.2.1.47.1.1.1.1.1
    07/02/14 12:39:53.218 TRACE [presence-9] []     GetMultiAttributes needs class=com.cisco.server.managedobjects.bridge.PowerSupply3kStats, field=powerSupplyIndex
    07/02/14 12:39:53.218 TRACE [presence-9] []     MIB lookup, OID for: powerSupplyOperStatus = 1.3.6.1.4.1.9.9.13.1.5.1.3
    07/02/14 12:39:53.218 TRACE [presence-9] []     GetMultiAttributes needs class=com.cisco.server.managedobjects.bridge.PowerSupply3kStats, field=powerSupplyOperStatus
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes invoked
    07/02/14 12:39:53.218 TRACE [presence-9] [] GetMultiAttributes building OIDs for next PDU
    07/02/14 12:39:53.218 TRACE [presence-9] [] Adding attributes for object PowerSupply3kStats[151206060_,1009]
    - The switch sends the SNMP Trap, based on the followings:
    Jul  7 13:38:30 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:30 UTC: %PLATFORM_THERMAL-6-FRU_FAN_OIR: Switch 1: System fan 1 removed
    Jul  7 13:38:30 UTC: %PLATFORM_THERMAL-1-FRU_FAN_NOT_PRESENT: Switch 1: System fan 1 not present
    Jul  7 13:38:30 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:30 UTC: SNMP: V2 Trap, reqid 33202, errstat 0, erridx 0
    sysUpTime.0 = 576753333
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, NotExist
    ciscoEnvMonFanStatusEntry.3.1010 = 5
    Jul  7 13:38:30 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:30 UTC: SNMP: V2 Trap, reqid 33203, errstat 0, erridx 0
    sysUpTime.0 = 576753333
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, NotExist
    ciscoEnvMonFanStatusEntry.3.1010 = 5
    Jul  7 13:38:30 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:30 UTC: SNMP: V2 Trap, reqid 33204, errstat 0, erridx 0
    sysUpTime.0 = 576753333
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, NotExist
    ciscoEnvMonFanStatusEntry.3.1010 = 5
    Jul  7 13:38:30 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:30 UTC: SNMP: V2 Trap, reqid 33205, errstat 0, erridx 0
    sysUpTime.0 = 576753333
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, NotExist
    ciscoEnvMonFanStatusEntry.3.1010 = 5
    Jul  7 13:38:31 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:31 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:31 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:31 UTC: SNMP: Packet sent via UDP to IP_ADDRESS 
    Jul  7 13:38:45 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:51 UTC: %PLATFORM_THERMAL-6-FRU_FAN_OIR: Switch 1: System fan 1 inserted
    Jul  7 13:38:54 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:54 UTC: SNMP: V2 Trap, reqid 33206, errstat 0, erridx 0
    sysUpTime.0 = 576755733
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, Normal
    ciscoEnvMonFanStatusEntry.3.1010 = 1
    Jul  7 13:38:54 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:54 UTC: SNMP: V2 Trap, reqid 33207, errstat 0, erridx 0
    sysUpTime.0 = 576755733
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, Normal
    ciscoEnvMonFanStatusEntry.3.1010 = 1
    Jul  7 13:38:54 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:54 UTC: SNMP: V2 Trap, reqid 33208, errstat 0, erridx 0
    sysUpTime.0 = 576755733
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, Normal
    ciscoEnvMonFanStatusEntry.3.1010 = 1
    Jul  7 13:38:54 UTC: SNMP: Queuing packet to IP_ADDRESS
    Jul  7 13:38:54 UTC: SNMP: V2 Trap, reqid 33209, errstat 0, erridx 0
    sysUpTime.0 = 576755733
    snmpTrapOID.0 = ciscoEnvMonMIBNotifications.8
    ciscoEnvMonFanStatusEntry.2.1010 = Switch 1 - FAN 1, Normal
    ciscoEnvMonFanStatusEntry.3.1010 = 1
    Jul  7 13:38:55 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:55 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:55 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    Jul  7 13:38:55 UTC: SNMP: Packet sent via UDP to IP_ADDRESS
    It seems like PI and the switch doesn't understand each other concerning the fan...
    Thanks for any ideas, comments and feedbacks,
    Csaba

    I have the very same problem.
    The switch has a power supply error (one of the two is down). There is the syslog message in PI about it, but no event has created, so nor alarm is there as well.
    When I check the status of the switch in the Device Work Center, and choose the Environment in Device Details I can see that PI has not realized the power supply error.
    However when I click on the Sync for this very device the power supply status is updated, but still no event or alarm.
    This is the case with the FANs as well.

  • Cisco Prime Infrastructure 1.4 SNMP Traps are not converted into Alarms

    Hi everybody,
    I just configured SNMP Traps on a Cisco Catalyst 3750-x to send to our Cisco Prime Infrastructure 1.4 Appliance.
    Now I forced the Switch to send some traps (Power off a Power Supply, Interface errdisable). The only events I see in Alarms & Events on PI is the same information message everytime:
    Configuration management event has been recorded in ccmHistoryEventTable.
    I think the forced traps should be converted into alarms? Why can't I see them?
    Thanks,
    Marc

    Ok, I started debugging as you said. I get the following output:
    Mar 13 09:28:13.711: SNMP: V2 Trap, reqid 11689, errstat 0, erridx 0
     sysUpTime.0 = 198609846
     snmpTrapOID.0 = ciscoSyslogMIB.2.0.1
     clogHistoryEntry.2.1688 = PM
     clogHistoryEntry.3.1688 = 5
     clogHistoryEntry.4.1688 = ERR_RECOVER
     clogHistoryEntry.5.1688 = Attempting to recover from bpduguard err-disable state on Gi1/0/13
     clogHistoryEntry.6.1688 = 198609844
    Mar 13 09:28:13.737: SNMP: Queuing packet to xx.xx.xx.xx
    Looks like the Switch is sending SNMP Traps from the ciscoSyslogMIB. Is this why PI can't show the Traps and convert it into a alarm?
    After this test I configured logging (syslog) to the PI. Now the errors are showed but still not converted into alarms. I just want to be notified by email when such errors occurs.
    Thanks,
    Marc

  • NAC SNMP MAC notification traps not being sent

    I have the switch set up for mac notification, and the switch has the below config. But no mac notification traps get sent to the CAM.
    interface GigabitEthernet1/0/24 switchport access vlan 800 switchport mode access snmp trap mac-notification added spanning-tree portfast!snmp-server community **** ROsnmp-server community **** RWsnmp-server enable traps snmp linkdown linkupsnmp-server enable traps MAC-Notificationsnmp-server enable traps stpx root-inconsistency loop-inconsistencysnmp-server host 10.101.90.20 version 2c **** snmp-server host 10.101.90.20 **** MAC-Notification snmp
    Below is a debug of snmp packets when a host it connected to the switch on port 1/0/24
    1y29w: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/24, changed state to up1y29w: SNMP: Queuing packet to 10.101.90.201y29w: SNMP: V2 Trap, reqid 62, errstat 0, erridx 0            sysUpTime.0 = 648642685            snmpTrapOID.0 = snmpTraps.4            ifIndex.10124 = 10124            ifDescr.10124 = GigabitEthernet1/0/24            ifType.10124 = 6            lifEntry.20.10124 = up1y29w: SNMP: Queuing packet to 10.101.90.201y29w: SNMP: V1 Trap, ent products.516, addr 10.202.1.2, gentrap 3, spectrap 0            ifIndex.10124 = 10124            ifDescr.10124 = GigabitEthernet1/0/24            ifType.10124 = 6            lifEntry.20.10124 = up1y29w: SNMP: Packet sent via UDP to 10.101.90.201y29w: SNMP: Packet sent via UDP to 10.101.90.201y29w: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/24, changed state to up
    Am I missing something in the config or something?

    Hello,
    Please post your SNMP receiver config on the CAM. Also, can you do a capture on the CAM to see if you're seeing the packets getting there?
    To do the capture, in a SSH session, use this command: tcpdump -ieth0 'host ' -s0 -wcapture.pcap
    Once you've captured the success/failure, hit Ctrl-C to kill the capture. You can then use WINSCP or any other SCP program to get that file off of the CAM for further analysis.
    HTH,
    Faisal

  • Snmp traps will not stop

    We are getting a ton of snmp "cold start" traps. About every minute or less. I even took the statement out of the configuration to stop the device from sending those traps but they're still coming.
    I used the "no snmp-server traps enable snmp coldstart warmstart"
    I verified that it was no longer in the config as well. Any help?

    Are your ap's bouncing? I have only seen this when the ap is on the secondary controller and fails to joins its primary.

  • Docsis CMTS SNMP traps issue

    Hi all ,
    If anyone can help me ( maybe with config issue ) 
    When cable modem goes offline / online i get this messages 
    This is happening whit any type of modem .
    Does someone using traps on CMTS , any working config example ?
    Cable modem goes offline
    Dec 19 14:41:23.327: SNMP: V1 Trap, ent ciscoDocsExtMIB.2, addr xx.xx.xx.xx, gentrap 6, spectrap 1
     docsIfCmtsCmStatusEntry.2.4475717 = H{&65
     docsIfCmtsCmStatusEntry.3.4475717 = 10.5.5.87
     docsIfCmtsCmStatusEntry.4.4475717 = 0
     docsIfCmtsCmStatusEntry.5.4475717 = 8113
     cdxCmCpeEntry.5.6.200.251.38.182.53.157 = 2885
     cdxCmtsCmStatusExtEntry.1.4475717 = 1
    Dec 19 14:41:23.339: SNMP: Queuing packet to xx.xx.xx.xx
    Dec 19 14:41:23.339: SNMP: V1 Trap, ent ciscoDocsExtMIB.2, addr xx.xx.xx.xx, gentrap 6, spectrap 1
     docsIfCmtsCmStatusEntry.2.4475717 = H{&65
     docsIfCmtsCmStatusEntry.3.4475717 = 10.5.5.87
     docsIfCmtsCmStatusEntry.4.4475717 = 0
     docsIfCmtsCmStatusEntry.5.4475717 = 8113
     cdxCmCpeEntry.5.6.200.251.38.182.53.157 = 2885
     cdxCmtsCmStatusExtEntry.1.4475717 = 1
    Dec 19 14:41:23.379: SNMP: Packet sent via UDP to xx.xx.xx.xx
    Dec 19 14:41:23.379: SNMP: Queuing packet to xx.xx.xx.xx
    Cable modem comes online
    Dec 19 14:41:42.340: SNMP: V1 Trap, ent ciscoDocsExtMIB.2, addr xx.xx.xx.xx, gentrap 6, spectrap 1
     docsIfCmtsCmStatusEntry.2.4475717 = H{&65
     docsIfCmtsCmStatusEntry.3.4475717 = 10.5.5.87
     docsIfCmtsCmStatusEntry.4.4475717 = 0
     docsIfCmtsCmStatusEntry.5.4475717 = 8113
     cdxCmCpeEntry.5.6.200.251.38.182.53.157 = 2885
     cdxCmtsCmStatusExtEntry.1.4475717 = 12
    Dec 19 14:41:42.352: SNMP: Queuing packet to xx.xx.xx.xx
    Dec 19 14:41:42.352: SNMP: V1 Trap, ent ciscoDocsExtMIB.2, addr xx.xx.xx.xx, gentrap 6, spectrap 1
     docsIfCmtsCmStatusEntry.2.4475717 = H{&65
     docsIfCmtsCmStatusEntry.3.4475717 = 10.5.5.87
     docsIfCmtsCmStatusEntry.4.4475717 = 0
     docsIfCmtsCmStatusEntry.5.4475717 = 8113
     cdxCmCpeEntry.5.6.200.251.38.182.53.157 = 2885
     cdxCmtsCmStatusExtEntry.1.4475717 = 12
    Dec 19 14:41:42.592: SNMP: Packet sent via UDP to xx.xx.xx.xx
    bg-b45-c-1#scm 10.5.5.87
                                                                                     D
    MAC Address    IP Address     I/F           MAC           Prim RxPwr  Timing Num I
                                                State         Sid  (dBmv) Offset CPE P
    c8fb.26b6.359d 10.5.5.87      C5/1/3/U0     online(pt)    2885!-2.00  823    0   N
    Otherwise, normally it should be like this
    Dec 19 14:42:36.836: SNMP: V1 Trap, ent ciscoDocsExtMIB.2, addr 89.216.7.28, gentrap 6, spectrap 1
     docsIfCmtsCmStatusEntry.2.4478568 = C8 FB 26 F8 D6 28 
     docsIfCmtsCmStatusEntry.3.4478568 = 10.5.26.57
     docsIfCmtsCmStatusEntry.4.4478568 = 0
     docsIfCmtsCmStatusEntry.5.4478568 = 0
     cdxCmCpeEntry.5.6.200.251.38.248.214.40 = 5736
     cdxCmtsCmStatusExtEntry.1.4478568 = 12
    Dec 19 14:42:36.848: SNMP: Queuing packet to xx.xx.xx.xx
    Second problem is that CMTS is not sending all trap messages when cable modem goes offline
    What we lack are the messages that the modem goes offline (which are more importantly), and as far as online reaches 99% of messages. Something  that we observed is that for example in the first 10  modems that we reset CMTS send traps for three only (not consecutive).After ten messsage CMTS send all of them  (the test is usually reset the modem 20-30). There is not any connection about the type of modem that sends the trap.
    Suspicion fell on PRE card but the tests were tried on various  (2 CMTS with pre2, 2 CMTS  with pre4 and 1 CMTS pre5). and  different IOS from the SCF3 - SCH1.
    Config is :
    interface Cable3/0
     cable enable-trap cmonoff-notification
     cable enable-trap cmonoff-interval 60
    snmp-server trap-source Loopback0
    snmp-server enable traps cable cm-onoff
    snmp-server host xx.xx.xx.xx public-cmts
    snmp-server host xx.xx.xx.xx public-cmts
    Thanks 
    VZ

    I looked at the trap PDUs that correspond the timestamps in the log output, and I do not see any problems.  Is there additional debugging you can enable in the Smarts application that will indicate why it thinks these traps are mangled?
    The traps themselves come from RME because it looks like you have enabled Inventory and Config collection failure notification, and RME cannot fetch the config from certain devices.  It appears that perhaps RME is doing periodic config collection or polling around 11:30 pm when these traps start to get generated.

  • Cisco ACS SNMP Traps

    Is it possible to send an SNMP trap from Cisco ACE 4710  for any configuration changes that  occurs?
    Regards,
    Hesham                 

    Hi Hesham,
    these are the traps which are supported by ACE.
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA5_1_0/configuration/administration/guide/snmp.html#wp1177230
    read section "ACE SNMP Notifications (Traps)"
    I do not see a trap which is useful for your requirement.
    regards,
    Ajay Kumar

  • SNMP TRAPS and SLA

    HI
    I am trying to configure IP SLA to send SNMP TRAPS but looks like doing some mistake ..
    i have following configured
    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-parent:"";
    mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
    mso-para-margin:0cm;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:12.0pt;
    font-family:"Times New Roman";
    mso-ascii-font-family:Cambria;
    mso-ascii-theme-font:minor-latin;
    mso-fareast-font-family:"Times New Roman";
    mso-fareast-theme-font:minor-fareast;
    mso-hansi-font-family:Cambria;
    mso-hansi-theme-font:minor-latin;}
    ip sla monitor 2
    type echo protocol ipIcmpEcho 150.1.3.3 source-ipaddr 1.1.98.7
    frequency 10!
    ip sla monitor schedule 2 start-time now recurring
    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-parent:"";
    mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
    mso-para-margin:0cm;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:12.0pt;
    font-family:"Times New Roman";
    mso-ascii-font-family:Cambria;
    mso-ascii-theme-font:minor-latin;
    mso-fareast-font-family:"Times New Roman";
    mso-fareast-theme-font:minor-fareast;
    mso-hansi-font-family:Cambria;
    mso-hansi-theme-font:minor-latin;}
    ip sla reaction-configuration 2 react rtt threshold-type immediate action-type trapOnly  
    ip sla logging traps
    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-parent:"";
    mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
    mso-para-margin:0cm;
    mso-para-margin-bottom:.0001pt;
    mso-pagination:widow-orphan;
    font-size:12.0pt;
    font-family:"Times New Roman";
    mso-ascii-font-family:Cambria;
    mso-ascii-theme-font:minor-latin;
    mso-fareast-font-family:"Times New Roman";
    mso-fareast-theme-font:minor-fareast;
    mso-hansi-font-family:Cambria;
    mso-hansi-theme-font:minor-latin;}
    snmp-server community public RO
    snmp-server enable traps rtr
    snmp-server host 1.1.128.226 public
    1.1.98.7 is the loopback ip on my network. To test the snmp traps, i enabled debug snmp packets and shutdown loopback interface (1.1.98.7)
    I don't see any snmp message in debug output ..
    am i missing something or it is not possible to get traps directly from ip sla .. do i need EEM for this?

    sorry, it actually worked .. i just gave a restart to ip sla and it worked.
    looks like router was already in threshold stage when i was activating reaction-config ..
    but i am still confused which command is actualluy generating these traps since i have taken out some of the snmp config out and i stil get traps ..
    below is the oputput of traps which i get when i restart ip sla .
    *Feb 15 17:10:43.453: SNMP: 150.150.1.1 queue overflow, dropping packet
    *Feb 15 17:10:43.453: SNMP: Queuing packet to 150.150.1.1
    *Feb 15 17:10:43.453: SNMP: V1 Trap, ent rttMonNotificationsPrefix, addr 65.65.2.2, gentrap 6, spectrap 3
    rttMonCtrlAdminTag.1 = 
    rttMonHistoryCollectionAddress.1 = 41 41  03 03   
    rttMonCtrlOperOverThresholdOccurred.1 = 1
    *Feb 15 17:10:43.497: SNMP: 150.150.1.1 queue overflow, dropping packet
    *Feb 15 17:10:43.501: SNMP: Queuing packet to 150.150.1.1
    *Feb 15 17:10:43.501: SNMP: V1 Trap, ent rttMonNotificationsPrefix, addr 65.65.2.2, gentrap 6, spectrap 5
    rttMonCtrlAdminTag.1 = 
    rttMonHistoryCollectionAddress.1 = 41 41  03 03   
    rttMonReactVar.1 = 1
    rttMonReactOccurred.1 = 1
    rttMonReactValue.1 = 12
    rttMonReactThresholdRising.1 = 5
    rttMonReactThresholdFalling.1 = 1
    rttMonEchoAdminLSPSelector.1 = 00 00  00 00  
    *Feb 15 17:10:43.585: SNMP: 150.150.1.1 queue overflow, dropping packet
    *Feb 15 17:10:43.585: SNMP: Queuing packet to 150.150.1.1
    *Feb 15 17:10:43.585: SNMP: V1 Trap, ent rttMonNotificationsPrefix, addr 65.65.2.2, gentrap 6, spectrap 5
    rttMonCtrlAdminTag.1 = 
    rttMonHistoryCollectionAddress.1 = 41 41  03 03   
    rttMonReactVar.1 = 1
    rttMonReactOccurred.1 = 1
    rttMonReactValue.1 = 12
    rttMonReactThresholdRising.1 = 5
    rttMonReactThresholdFalling.1 = 1
    rttMonEchoAdminLSPSelector.1 = 00 00  00 00 
    below is my running config and sh ver
    R2#sh ver
    Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2009 by Cisco Systems, Inc.
    Compiled Fri 19-Jun-09 15:13 by prod_rel_team
    ROM: System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)
    R2 uptime is 8 hours, 9 minutes
    System returned to ROM by power-on
    System image file is "flash:c2800nm-adventerprisek9-mz.124-24.T1.bin"
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    If you require further assistance please contact us by sending email to
    [email protected].
    Cisco 2811 (revision 53.50) with 237568K/24576K bytes of memory.
    Processor board ID FTX0952C333
    2 FastEthernet interfaces
    4 Serial(sync/async) interfaces
    1 Virtual Private Network (VPN) Module
    DRAM configuration is 64 bits wide with parity enabled.
    239K bytes of non-volatile configuration memory.
    62720K bytes of ATA CompactFlash (Read/Write)
    Configuration register is 0x2102
    R2#            
    R2#sh run
    Building configuration...
    Current configuration : 2233 bytes
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname R2
    boot-start-marker
    boot-end-marker
    no aaa new-model
    memory-size iomem 10
    dot11 syslog
    ip source-route
    ip cef
    ipv6 unicast-routing
    ipv6 cef
    multilink bundle-name authenticated
    voice-card 0
    vtp domain 29
    vtp mode transparent
    archive
    log config
      hidekeys
    interface Loopback0
    ip address 65.65.2.2 255.255.255.0
    interface FastEthernet0/0
    shutdown
    duplex auto
    speed auto
    interface FastEthernet0/1
    ip address 65.65.128.193 255.255.255.224
    shutdown
    duplex auto
    speed auto
    interface Serial0/2/0
    ip address 65.65.13.2 255.255.255.224
    encapsulation ppp
    clock rate 2000000
    interface Serial0/3/0
    no ip address
    shutdown
    router ospf 65
    router-id 65.65.2.2
    log-adjacency-changes
    network 65.65.2.2 0.0.0.0 area 1
    network 65.65.13.2 0.0.0.0 area 1
    network 65.65.128.193 0.0.0.0 area 1
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip sla 1
    icmp-echo 65.65.3.3 source-ip 65.65.2.2
    request-data-size 1500
    frequency 10
    ip sla schedule 1 life forever start-time now
    ip sla reaction-configuration 1 react rtt threshold-value 5 1 threshold-type immediate action-type trapOnly
    snmp-server community public RO
    snmp-server host 150.150.1.1 public
    control-plane
    mgcp fax t38 ecm
    mgcp behavior g729-variants static-pt
    line con 0
    line aux 0
    line vty 0 4
    login
    scheduler allocate 20000 1000
    end
    R2#                                 
    R2#

Maybe you are looking for

  • Share Buttons Greyed Out

    I woke up this morning to find that all my share buttons were greyed out. Can't access to share on Twitter, Flickr or anything. Very odd. I went into my System Prefs, deleted and then renewed all my accounts, to no avail. Deleted and reinstalled iPho

  • Not to hard for you java types.  Simply creating a doubly linked list.

    How do i go about declaring a doubly linked list and add nodes to it?

  • Why does mail suddenly import thousands of messages again?

    Once every few months Mail under 10.6.8 re-imports 2700 or so emails and takes half an hour, but when finished it has not added anything I see in the mail list. Specifically there are no "new" email messages.  This has been going on for years. 2010 M

  • "Unsupported Device" nonsense

    I am more than a little bit angry when I plug a Lightning cable or wall charger into my new iPhone 6 and it tells me that either or both are 'unsupported devices.' I'm not talking about those cheap, Chinese knockoffs. I expect Apple to 'protect and s

  • XI System copy information

    Gurus,      If we perform a system copy for XI after migrating java-add-in target system, do we have to install Exchange infrastructure again as a fresh install. or just migrating java-add-in is enough? Please let me know, Regards, N.S