Solaris 10 Dev. Edition - Network config issue (NIC,DHCP,Can't ping router)

I am a developer getting started with Solaris 10 configuration. I recently installed Solaris 10 and have run into an issue with network connectivity.
I have done much research on this and I was able to get communiction to the internet established once, but the settings were lost on reboot.
Overview - The Solaris box is connected to a router which is acting as a DHCP server.
AMD 64 dual 2.6
nForce4+ integrated NIC
1) I am not able to obtain an address from the router. Nor do I get a respons back when I ping it. I get an IP etc if I boot into Windows so phyicial connectivity is fine.
2) Upon reboot the device nfo0 as shown using ifconfig -a has an IP of 0.0.0.0.
3) If I run ifconfig [hostname] my machine gets the ip from the hosts file, but I would like to obtain this from the router.
4) NOTE - the machine shows as active on my router, but the Solaris box cannot be reached from other computers on the networ, nor do I get a reply back when pinging the router from the Solaris box.
GOAL - reach and obtain a DHCP from the router and have the changes stick upon reboot.
/etc/hosts contents
127.0.0.1 localhost loghost
192.168.1.55 solarisX /*<-- this is what I get when I do ifconfig nfo0 solarisX */
/etc/hosname.nfo0
netmask + 255.255.255.0
solarisX
/etc/defaultrouter
192.168.1.254
/et c/netmasks
192.168.0.0 255.255.2550
Specific Steps taken:
Using the driver nfo-2.4.5 locate at http://homepage2.nifty.com/mrym3/taiyodo/eng/ I did the following.
% cd /.../nfo-x.x.x
% rm obj Makefile
% ln -s Makefile.${KARCH}_${COMPILER} Makefile
% ln -s ${KARCH} obj
where ${KARCH} is the result of `isainfo -n`, and ${COMPILER} is
"gcc" or "suncc" which you want to use to make the driver.
4. Testing
Testing before installation is strongly recommended.
# cd /.../nfo-x.x.x
# /usr/ccs/bin/make install
# ./adddrv.sh
# /usr/ccs/bin/make uninstall (for solaris7, don't remove the file )
# modload obj/nfo
# devfsadm -i nfo (for solaris7, use drvconfig and reboot with -r )
# ifconfig nfoN plumb ( where N is an instance number, typcally 0 for first card)
# ifconfig -a ( you will see an entry for nfoN)
# ifconfig nfoN YOUR-HOST-NAME
# ifconfig nfoN ( ensure IP address is correct)
# ifconfig nfoN up ( and then you can test with ping, telnet, ftp ...)
5. Installation
After you ensure that the nfo driver is fully functional, install it.
(1) copy the nfo driver into the kernel directory
# cd /.../nfo-x.x.x
# /usr/ccs/bin/make install
If you do not test the nfo driver yet, execute the following commands:
# ./adddrv.sh
# devfsadm -i nfo (for solaris7, use drvconfig and reboot with -r)
(2) Configure the network interface. Create and/or modify the following file:
/etc/hostname.nfoN
(3) Reboot the system.
# init 6
Edited by: hedger on Nov 16, 2007 11:17 PM

Thanks Alan. I worked on trying to get the NIC working again last night. I had it working once, although the settings did not perist. I can still get the device to load, but I can't communciate with the router (it's not physical because another OS can reach it.
I took your advice and tried the sys-unconfig. But I did not have much success.
I am wondering if plopping in a new PCI NIC would be the most efficient route to get the server up.
What kind of NIC do you utilize and have had success with?
I am looking at possibly a DLINK DFE-530 or NetGear FA-311. I don't need wireless at this point just a rock solid DEV box.
Thanks again for the previous info.
Ted

Similar Messages

  • ASA 5505 VPN clients can't ping router or other clients on network

    I have a ASA5505 and it has a vpn set up. The VPN user connects using the Cisco VPN client. They can connect fine (the get an ip address from the ASA), but they can't ping the asa or any clients on the network. Here is the running config:
    Result of the command: "show running-config"
    : Saved
    ASA Version 7.2(4)
    hostname ASA
    domain-name default.domain.invalid
    enable password kdnFT44SJ1UFX5Us encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 10.0.0.4 Server
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone MST -7
    clock summer-time MDT recurring
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    access-list vpn_splitTunnelAcl standard permit any
    access-list inside_nat0_outbound extended permit ip any 10.0.0.192 255.255.255.192
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPNpool 10.0.0.220-10.0.0.240 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
    static (inside,outside) tcp interface pop3 Server pop3 netmask 255.255.255.255
    static (inside,outside) tcp interface www Server www netmask 255.255.255.255
    static (inside,outside) tcp interface https Server https netmask 255.255.255.255
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable 480
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    group-policy vpn internal
    group-policy vpn attributes
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value vpn_splitTunnelAcl
    username admin password wwYXKJulWcFrrhXN encrypted privilege 15
    username VPNuser password fRPIQoKPyxym36g7 encrypted privilege 15
    username VPNuser attributes
    vpn-group-policy vpn
    tunnel-group vpn type ipsec-ra
    tunnel-group vpn general-attributes
    address-pool VPNpool
    default-group-policy vpn
    tunnel-group vpn ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:df7d1e4f34ee0e155cebe86465f367f5
    : end
    Any ideas what I need to add to get the vpn client to be able to ping the router and clients?
    Thanks.

    I tried that and it didn't work. As for upgrading the ASA version, I'd like to but this is an old router and I don't have a support contract with Cisco anymore, so I can't access the latest firmware.
    here is the runnign config again:
    Result of the command: "show startup-config"
    : Saved
    : Written by enable_15 at 01:48:37.789 MDT Wed Jun 20 2012
    ASA Version 7.2(4)
    hostname ASA
    domain-name default.domain.invalid
    enable password kdnFT44SJ1UFX5Us encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 10.0.0.4 Server
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.0.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone MST -7
    clock summer-time MDT recurring
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    access-list vpn_splitTunnelAcl standard permit any
    access-list inside_nat0_outbound extended permit ip any 10.0.0.192 255.255.255.192
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPNpool 10.0.0.220-10.0.0.240 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    asdm location Server 255.255.255.255 inside
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface smtp Server smtp netmask 255.255.255.255
    static (inside,outside) tcp interface pop3 Server pop3 netmask 255.255.255.255
    static (inside,outside) tcp interface www Server www netmask 255.255.255.255
    static (inside,outside) tcp interface https Server https netmask 255.255.255.255
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable 480
    http 10.0.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    group-policy vpn internal
    group-policy vpn attributes
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value vpn_splitTunnelAcl
    username admin password wwYXKJulWcFrrhXN encrypted privilege 15
    username VPNuser password fRPIQoKPyxym36g7 encrypted privilege 15
    username VPNuser attributes
    vpn-group-policy vpn
    tunnel-group vpn type ipsec-ra
    tunnel-group vpn general-attributes
    address-pool VPNpool
    default-group-policy vpn
    tunnel-group vpn ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect icmp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:78864f4099f215f4ebdd710051bdb493

  • Server 2012 Standard Edition network teaming issue at bootup

    I have a Windows server 2012 x64 standard edition server (not R2) using two Intel I210AT nic's on an ASUS P9D-X motherboard.  They are setup in a team using the Microsoft teaming.  No special options, latest updates and the latest Intel drivers.
      The team is setup in switch independent mode and connected with quality cat6 cables to a Cisco 3600 switch.  No special options on the ports of the switches, no LACP or trunking, just standard unconfigured ports.
    The problem we have is when the server is rebooted the team will not communicate with the network.  If we unplug one network cable communication begins.  We can then plug the cable back in and both
    ports work and communicate normally.   
    This issue is serious as it requires physical action on every restart.   
    We have tried deleting the team and recreating it and we get the same results.  Is there some specific change that needs to be made to make this work or is this possibly a known bug? 

    May be problem on Cisco side, Cisco is very clever, could assessed network traffic as a problem and close the port. When OS is running, then NIC Teaming working fine, but when you boot up server, "BIOS not running with NIC Teaming", in this moment
    may occur problem on Cisco side.
    I recommend, if you use Cisco, configure NIC Teaming in LACP mode and configure your two ports on Cisco to LACP, it's better way.
    Regards,
    thennet
    Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable. This helps the community, keeps the forums tidy, and recognises useful contributions. Thank you!

  • Solaris 10 zones network config using different IP address

    I have a Solaris 10 global zone with two networks 172.x.x.x and 192.x.x.x
    The zone loaded on this global zone has two networks 192.x.x.x and 144.x.x.x
    I have the 192 network working fine on both the global and non-global zones.
    I have aggr2 on the global zone assigned the 172 IP.
    I have aggr2:1 on the non-global zone assigned the 144.
    On the global zone all networking functions correctly.
    On the non-global zone I can't get the 144 interface to work.
    I've checked my defaultroutes, they are correct, I've tracerouted from the global zone using a 144 address and it goes out the 172 interface correctly.
    When I traceroute from the non-global zone it can't even leave the zone.
    My question is, can I have an IP on the non-global zone that does not reside on the global zone?

    Hi Jim, 
    We have check the following path on our Exchange Server :
    C:\Program
    Files\Microsoft\Exchange Server\Logging\TraceLogs 
    And
    we not found any log files here.
    Thanks.
    Best Regards,
    Antoni

  • Re: Z97S SLI Krait Edition Network Drivers Issue

    That&#39;s because you will need a wireless chip for your desktop if you don&#39;t want to use an Ethernet cable. Most of them are quite cheap but some very high end ones get pricey I think. After that you will need the wireless drivers for that specific wirel...

    Every time I power on my computer for the first time (cold start), it will boot up then RESTART and then boot up properly. It always takes 2 times. I&#39;m running on the latest BIOS and anyone else faces the same issue?
    What&#39;s happening? Other than that e...

  • Having issues configuring DHCP and with Redundant router

    Hello everyone
    I am new to Cisco and I am having few problems in configuring my topology in Packet tracer.
    I am having redundancy in router and swithes both,
    I have assigned one layer2 2960 switch as a VTP server and asssigned VLANs from that switch then assigned ports to the hosts in access layer switches.
    Problem 1:  If I take my Router1 off I am unable to ping so the pupose of having redundant router does not serve the pupose.
    Problem 2 : I need to assign DHCP server for the users who will be connecting wirelessly with Access Points, so can I configure DHCP on Access Points which I am unable to do so in Packet tracer any idea how? / Or shall I configure the DHCP on Router1 and Router2 and exclude the addresses I have assigned to all the hosts connected using ethernet.
    Also how can I configure Email server in this tolpolgy and where?
    Thank you
    A.K

    Hi Asif, Jeff is right.
    (1) You need to configure either HSRP (Hot standby routing protocol) or VRRP (Wirtual routing redundancy protocol), or GLBP (Gateway load balancing protocol).
    With either of this config, you will be able to configure 1 logical IP address, which will act as a gateway on your computers. However, both routers will need different IP's (all within the same subnet). You will also need to create multiple HSRP groups to support all your VLAN's. So one HSRP group per VLAN. The logical IP in the HSRP group will act as the default gateway on computers within the VLAN.
    Though I don't think packet tracer supports any of the above configs - FYI it's part of the CCNP Switch sylabus. So the above explaination will make sense after you've got a good understanding of HSRP, VRRP and/or GLBP.
    (2) I would recommend setting both the Router as a DHCP server, and configure the Access Point (AP) with a static IP (disable NAT and DHCP on the AP)
    (3) In packet tracer, choose the Server icon and check it's properties. You should find an option to enable EMAIL server. Connect it to any of the Distribution layer switches.
    Hope this helps get you started on the learning curve :-)

  • Solaris 10 - Installation - Networked Option not display- RTL 8139 NIC Card

    Hi,
    when i installing Solaris, the Networkd (Yes/No) option not display. In my PC (x86) RTL 8139 Networkd Card is installed. Please advice, how can i enable Networked option and docs says that Solaris-10 Supports RTL 8139 Network card. (Ref: http://www.sun.com/software/solaris/self_help.jsp#installing )
    Here pls refer "Network Devices (x86)" Section ).
    Thanks

    I'm not quite sureee, but you might want to run the SDDT test scripts...
    http://www.sun.com/bigadmin/hcl/hcts/device_detect.jsp
    This you can run from Windows, Linux on the same box, and it will list all the drivers for the hardware that solaris knows about. Inside the tool you can select, whether you want that list for Solaris 10 or SXDE...
    Matthias
    P.S.: I assume, the driver should be e1000g, but am not quite sure...

  • Solaris 10 zone configuration with sysidcfg and dhcp and hostname

    Hi
    Excuse me if I look like a n00b... it's probably because I'm a n00b.
    I've been struggling in the dark for more than 2 days now and I'm wondering if I'm thinking about this all wrong...
    I have stand-alone server where I need to run zones. I want to create zones and automagically configure them at boot (read: by running a script). So here's what I need...
    A zone
    starting from unconfigured state
    whose hostname is not the same as the zone name
    using corporate DHCP to get its IP address
    with DNS config coming from the DHCP server
    registering its address the DNS
    with a preconfigured root password
    (I don't own the corporate DHCP or DNS servers, I can't put my own DHCP or DNS servers on the network.)
    I would lke to create the zone, throw some config at it, then boot the zone and walk away. I am using zones with exclusive-IP. I can construct the zones and manually configure them once they're started to have DHCP, my own name, registered IP address with DNS and everything else I have specified above. But I don't want to do it manually...
    Sysidcfg seems to do some of what I want but not entirely.
    In sysidcfg I can set the root_password, the primary interface using DHCP, DNS server. I can't set a hostname in sysidcfg AND use configure it for DHCP. So the hostname is not what I want it to be after the zone is started and ready to go. The DHCP server is providing the DNS configuration, Solaris does not seem to honour it, but i'll ignore that for the moment.
    I have tried various combinations of using sysidcfg, /etc/nodename, /etc/hostname.+interface+ and /etc/dhcp.+interface+ but I can't find any combination that actually works.
    I can write to the zonestorage/etc/nodename to set the nodename, that works. But it does not match the DHCP address, so I get prompted for a new name service because it can't find a DNS entry for the name.
    I can write to the zonestorage/etc/hostname.+interface+ and /etc/dhcp.+interface+ (to get the system to register its name with the DNS server after getting its DHCP address) but then I get a system with no root password and no DNS configuration, even though they are set in the sysidcfg file.
    I can write a script that gets part of the way using sysidcfg and /etc/... files, then boots the zone and then runs a bunch of voodoo via zlogin commands to fix all the stuff that couldn't be done 'properly', but that's not a 'boot and walk away' environment. I can write a script that uses sysidcfg and hacks around with other files in /etc (like nsswitch.conf, resolv.conf), but that just feels likes a dirty hack to fix something that wasn't done properly in the first place.
    So where am I going wrong and how do I do it right (within the constraints defined)? Why can't I configure, boot and walk away?
    Thanks

    Thanks abrante
    Thanks for your response!
    I don't think the config is messed up after the installation. I think the installation is fine, it's just not what I want :-)
    I'm trying to decouple the zonename from the system name and get DNS registrations working. After installation, a DHCP client can get its hostname from DNS but I'm trying to do it the other way around. I want the DHCP client specify its own hostname, get an address from the DHCP server and then register its hostname with DNS. If the system gets its name from DNS/DHCP then I have to configure those to provide the system name and I don't own the DHCP/DNS infrastructure. These zones are for a development/QA environment, so we create and reconfigure these frequently. Hence the need to specify the system name within the zone and register that name in the DNS.
    I have tried fiddling with the PARAM_REQUEST_LIST but it does not seem to be working as I expect. :-$ Removing 12 did not help with setting the hostname from the system. DNS does not have a registered name for this system anyway, so even if it tried to get a name for this system, it would get nothing.
    I also do want the DHCP to change the DNS server and domain name, but this does not happen even though my dhcpagent includes 6 and 15 in the PARAM_REQUEST_LIST. I still have to set them in the sysidcfg file because it is always ignored in Solaris (S10u8 with 10_Recommended 30-Jul-2010)
    As stated, I know I can hack around with the system after it has booted. But I'm trying to configure the system before it starts and let it take care of itself and not have to touch it. Frankly I'm surprised that the sysidcfg does not allow you to set a hostname name when you are using DHCP, that the default DHCP configuration does not register the system name with the DNS server, and the DNS config from the DHCP response is ignored. Even a sys-unconfiged system requires DNS configuration during initial boot, when I know that the DHCP response contains DNS information.
    FYI: Windows systems using DHCP work as expected in this respect by default, i.e. set system name, use DHCP --> system gets address from corporate DHCP, DNS settings are set from DHCP information, DNS registration is made for system name.
    I'm working around this at the moment... I call my zone by the system name I want, I hardcode the DNS settings in the sysidcfg file and I create the hostname.+nic+ and dhcp.+nic+ files in the zone storage to get the system to register its name with DNS, them boot.
    Edited by: cydonian on Aug 19, 2010 7:45 PM

  • Solaris 10 x86 & 2 x NIC. Can some1 pls have a look if i do all correctly?

    i have a server with two NICs and Solaris 10 x86 installed.
    i want to use NIC1 with ADSL router (10.0.0.x) and NIC2 with switch (192.168.16.x). i also want to setup a DHCP server for LAN machines (NIC2) and DNS server.
    can someone pls confirm/correct my thoughts/steps in configuring two interfaces?
    1. during install i had to chose a default route for both interfaces. for NIC1 it was easy - i just entered the ADSL router IP which was 10.0.0.1.
    however, i have a difficulty with NIC2. what default route if at all should i use here?
    2. my understanding is that after configuring two interfaces they should act as a bridge so that i could setup a DNS server using my LAN machine addresses (192.168.16.x) and traffic coming from outside the office will be converted properly to reach LAN machines (mail, web servers, etc). is that correct or will i need to setup and configure 2 DNS servers for each NIC respectively?
    3. DHCP server. any guidance here in terms of two NICs machine?
    many thanks
    Alex

    i have a server with two NICs and Solaris 10 x86
    installed.
    i want to use NIC1 with ADSL router (10.0.0.x) and
    NIC2 with switch (192.168.16.x). i also want to setup
    a DHCP server for LAN machines (NIC2) and DNS
    server.
    can someone pls confirm/correct my thoughts/steps in
    configuring two interfaces?
    1. during install i had to chose a default route for
    both interfaces. for NIC1 it was easy - i just
    entered the ADSL router IP which was 10.0.0.1.
    however, i have a difficulty with NIC2. what default
    route if at all should i use here?You don't choose a default route for an interface, you choose a default route for a system. It isn't very useful to have multiple default routes for one machine. You will presumably want your default route to point to the internet-facing router.
    2. my understanding is that after configuring two
    interfaces they should act as a bridgeNo. You can use 'routeadm' on recent releases to configure routing. Otherwise, you need correct routing tables and make sure IP forwarding is enabled.
    so that i
    could setup a DNS server using my LAN machine
    addresses (192.168.16.x) and traffic coming from
    outside the office will be converted properly to
    reach LAN machines (mail, web servers, etc). is that
    correct or will i need to setup and configure 2 DNS
    servers for each NIC respectively?Unless your ADSL router understands the routes behind the solaris machine (it almost certainly doesn't), it will never send traffic there. Instead, you would have to run a NAT setup on the machine. ipfilter/ipnat can be used to do that.
    3. DHCP server. any guidance here in terms of two
    NICs machine?Should be no issues. Just create a scope for the 192.x subnet. If you're using the Solaris DHCP server, you can create a file which prevents it from listening on the other interface, but that's not required.
    Darren

  • [SOLVED] Network connection issues - need to make connections twice

    I've a strange issue with my network connection that has recently started to appear where if I:
    - Attempt to install a package with pacman.
    - Visit a webpage in chromium.
    - FTP a file using Thunar.
    - SSH into a server.
    Then I quite often have to attempt the connection twice i.e:
    - Pacman will return "error: failed retrieving file" on a first attempt, but be fine on the second.
    - Chromium (or any other browser) will partially load pages or will show a 'Server Not Found' message on the first attempt but be OK after a refresh.
    - FTP will not resolve the server on the first attempt but will on the second.
    - ssh will return  "Could not resolve hostname Name or service not known" on the first attempt then be fine on the second.
    This issue just used to occur with pacman & ssh and I just put it down to 'one of those things I needed to fix when I had time'. Yet the issue has recently started occuring with chromium as well so is making browsing the web a real pain.
    I'm at a bit of a loss as to how to track down the issue so would appreciate any tips!
    I'm using netctl to connect over wifi & just as I tried to post this message an error appeared in Chromium which may give me some hints as to how to fix this:
    The server at bbs.archlinux.org can't be found because the DNS look-up failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Chromium from accessing the network.
    I'm using netcl to connect over wifi.
    I also recently installed dhcpd which I occasionally start and stop though the issue with pacman & ssh was occurring before this.
    Thanks
    Tom
    Last edited by anthillsocial (2013-10-14 10:28:48)

    Thanks for that Strike0. It prompted a thorough reading of a number of man pages, though while I 'think' I understand the general concept of how things should be working, I'm finding the configuration confusing!!
    I created and added some nameserver settings to the following config file '/etc/resolv.conf.head'  (googles 8.8.8.8 and 8.8.4.4 also work):
    $ vim /etc/resolv.conf.head
    # OpenDNS servers
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    Then I reload  /etc/resolv.conf and view its new content:
    $ resolvconf -u;cat /etc/resolv.conf
    # Generated by resolvconf
    # OpenDNS servers
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    domain home
    nameserver 192.168.1.254
    And this seems to make everything work, where network connection are being reached after the first attempt!!
    Though I'm confused why 192.168.1.254 is being used? Am I right in understanding that 192.168.1.254 is a broadcast address so all network devices on 192.168.1.* are being queried for a DNS server? If I use the host command on 192.168.1.254 it seems to fail.  Does this fail mean that my home router is not working correctly or theres' an internal config issue?
    $ host www.archlinux.org 192.168.1.254
    Using domain server:
    Name: 192.168.1.254
    Address: 192.168.1.254#53
    Aliases:
    www.archlinux.org is an alias for gudrun.archlinux.org.
    gudrun.archlinux.org has address 66.211.214.131
    Host gudrun.archlinux.org.home not found: 2(SERVFAIL)
    What does the "Host gudrun.archlinux.org.home not found: 2(SERVFAIL)" output mean? Where is it getting the .home name from?
    As comparison
    $ host www.archlinux.org 8.8.4.4
    Using domain server:
    Name: 8.8.4.4
    Address: 8.8.4.4#53
    Aliases:
    www.archlinux.org is an alias for gudrun.archlinux.org.
    gudrun.archlinux.org has address 66.211.214.131
    In one of the man pages I saw that you can test an internal DNS with:
    $ host www.archlinux.org 127.0.0.1
    ;; connection timed out; no servers could be reached
    Though wouldn't a dhcpd4.service need to be running for that to work?
    Lots of questions I know, but I would like to understand exactly what's happening so I can easily trouble shoot in the future.
    Tom
    Last edited by anthillsocial (2013-10-11 13:55:30)

  • Solaris 10 for x88 install issue: cannot start X11 server

    AFter fixing my "can't set locale" problem I am moving onto the "Server for display :0 can't be started" issue.
    Checking /etc/dtc/Xerrors yields:
    1) error (PID 380) : Server unexpectedly died
    2) error (PID 380) : Server for display :0 can't be started
    I've tried running kdmconfig and setting XSun not XOrg. I am using a 2 channel KVM with a 3 button mouse (the only PS2 mouse I have lying around...) but it seems to pick it up without any problems. But, editing the config and saving (F4...) doesn't work. The changes don't commit and running kdmconfig again I see the choices have not changed.
    Also, I notice this message when I try to boot up:
    svccfg (/tmp/kdm_svccfg_cmds, ;ine 1): Pattern 'application/x11/x11-server' doesn't match any instances or services.
    Feel free to reply direct to me g.h.lawrence<at>gmail.com if you wish. Thanks in advance for any and all replies.
    Greg

    Hello Greg,
    unfortunately you're posting in the wrong forum.
    These forums are for Sun Hardware, you have a configuration problem with a piece of software - the x-server. Please post in one of these forums
    Solaris on x86
    http://forum.sun.com/jive/forum.jspa?forumID=291
    Installation
    http://forum.sun.com/jive/forum.jspa?forumID=292
    General Solaris 10 Discussion
    http://forum.sun.com/jive/forum.jspa?forumID=298
    Michael

  • X6450 network performance issue

    We are seeing a network performance issue using the Blade 6000 chassis with two (10x 1 Gbps Ethernet) NEM modules. The x6450 blades in the chassis have Solaris 10 u7 installed. In our tests, we used two blades in the following manner: each blade had only one network interface connected (and plumbed in the OS level) and each blade was connected to a different NEM. Both blades were connected to the same gigabit switch. There were two other test systems (x2270-s) also connected to the same switch. We ran the following tests:
    both the application client and server are on the same blade (i.e. application is using the loopback network interface): n operations/second (the number here is irrelevant, only the relation to other test numbers are relevant)
    application client on first blade, server on second blade: 0.77 x n operations / second (i.e. 23% degradation)
    application client on blade, server on x2270: 0.77 x n operations /second (i.e. 23% degradation)
    application client on x2270, server on blade: 0.75 x n operations /second (i.e. 25% degradation)
    We ran similar tests with the x2270. We did not see any difference between running the test on the loopback interface vs. running the test between two x2270-s.
    Is there a known issue with these network modules or their drivers?
    Edited by: kbertold on Jul 14, 2009 11:54 AM

    Just use a high interval and you see how much throughput you have in that time
    example: dlstat vnet1 120
    Best regards,
    Marcel

  • Connecting Eclipse Hana Dev Studio to CAL HANA Dev Edition  on AWS

    I have recently created a HANA dev Edition Instance in CAL using my AWS account. I have an eclipse HANA dev studio on my PC.
    I have been trying for hours to get the dev edition system added to my systems  in the dev studio AAAAARGH!
    Can someone please put together a screenshot run through of how to do this for this idiot to follow?
    I have read several blogs but none are terribly clear on what information in the dialogs in the hana studio relate to which elements on CAL or AWS.
    For instance:-
    Landscape host = ??? from where (IP address of instance supposedly but which one in the CAL instance detail as there are two ip addresses shown,
         an internal and an external). One blog talks about an elastic IP but  I haven't seen one labelled as such anywhere.
    Account name... This supposedly begins with a small letter but my account name for CAL does not, so confusing!! What account name is this meant to be?
    User Name = CAL user name or AWS user name?
    Password = password from where. Is this the CAL password or the aws ACCOUNT PASSWORD.
    Any help may well save me from a trip to the funny farm!
    NOTE I am adding the system as a cloud system.
    Cheers,
    Ross G.

    Hi Ross,
    Let's see if we can't get you through this really quickly.
    1) Are you on a corporate network that has ports blocked? If so the HANA Studio will not connect as it needs additional ports like 30015.
    2) If you are on a public internet with nothing blocked then under the SAP HANA Development perspective in HANA Studio you need to click (left side under "Systems" tab) "Add System"
    You need the IP of your server (most likely the public IP) and the fact that the instance is "00". An Elastic IP is the same as the IP the difference is that this IP is static and does not change when you start or stop the instance.
    Description is nice if you have a lot of systems.
    Then your user name and password.
    That's all you need. The best way to check is to be sure that you can open the server in your browser window (just enter the IP address) - or use the "connect" option in CAL.
    Craig
    these videos may also help.
    https://www.youtube.com/watch?v=yDAy4ufldtk
    SAP HANA Academy - SAP HANA installation: 5. Studio on Mac OS X - YouTube

  • Solaris Dev 11 and Bind version

    I tried to load Sol 10 on IBM and it was no go, loaded 11 Dev no problem except I had to also add the Broadcom drivers to get the NICS up.
    I think that 10 and 11 use BIND 9, but I have been told that I must use BIND 8 for my project.
    Any info on how to go from BIND 9 to BIND 8 on Sol 11 Dev edition would be appreciated.
    Thanks

    OK, the reason we had to stay at 8 has to do with rrset fixed not working in 9, until now, evidently it is now working in BIND 9.4.1
    So I am using Solaris Express 11, it has BIND 9.3.4, I went to freesunware and got there pkgadd version of BIND 9.4.1, I did pkgadd and it placed a lot of files in /usr/local
    I checked named -v and 9.3.4 is running right now for nslookup type dns client functions (so the web surfing will work for example)
    I need to actually setup a DNS server, I did not try on 9.3.4 but it is on the machine by default.
    What do I now need to do to get 9.3.4 off this machine (or at least disabled) and to get 9.4.1 up and running on this machine.
    I have files from our other server that I am replacing like named.conf and a db that I will also be adding so I can get this thing ready to field and replace the old machine.
    But first, what do I do to disable the old BIND and get the new version in /usr/local up and running.
    Thanks

  • Just bought Galaxy S5 today (no contract) - when is the Dev Edition coming?

    I really wanted to buy a Nexus S5, which does have the Verizon bands, but is "not allowed" on the Verizon network.
    So, I settled for the Samsung S5, which is great so far.  I bought it outright - for $600.  But I'm a developer and I like to mod my phone and flash various OS's on it.  So I'm frustrated to find out that the bootloader is locked and that if I do load a custom bootloader, I may void the warranty.
    When is the Dev Edition of this device coming?  I see news articles that vaguely say "soon".  Does anyone know for sure?  Can you provide me with a general idea?

    Maybe when VZW has a pure 4G/lte service without the old legacy 3G/1X Google will want to deal with VZW as Google is letting VZW put their service on the NEXUS 7 tablet.  I know I will not buy a VZW tablet.  I learned a valuable lesson when I purchased the Samsung i815 7.7 tablet VZW never supported updating the OS on that tablet.  I finally sent it to Samsung and when it came back they had updated it to ICS.  The tablet kept saying it wanted to update and it would download the update and then try to update but it would always fail.  VZW had many complaints about this same thing but VZW never fixed the issue and afaik that issue has never been fixed.  I read a recent thread on here about a week ago and I just replied to the guy and told him what I did to get the tablet updated to ICS.  Anyway after I got Samsung to update my tablet I sold it on Swappa.com and I will never buy another VZW tablet.  I purchase the NEXUS line of tablets now any tether via Wifi to my phone and not worry about the overages on my phone data.  I have yet to have an issue with my NEXUS 10.  Great tablet.  Just wish NEXUS line would have SD Slot.

Maybe you are looking for

  • I'm needing a laptop for the end of Highschool/University

    I was thinking a a MBP but now seeing other's opinions I'm debating whether to look into a Pro or a Air. I'm expecting to do video editing, Internet, viewing word documents, spreadsheets, Power points, and app developing. I need it to be somewhat por

  • Unable to click 'Set and save as my Active Configuration for this project'

    Environment: OWB 11.1.0.6 Client running on Windows XP Pro SP3 repository and targets on AIX (IBM UNIX). I have created a new Configuration under a specific Project and I'd like to make this configuration the default whenever I login and select this

  • Multiple selection of Checkboxes in ALV

    Hi All I have created an ALV Report in which Final Internal Table(Fields to be displayed) is having a Field as CheckBox. Problem is when I'm clicking multiple checkboxes only single field of table is getting updated but I want multiple rows to be upd

  • Problem in Load File into BI-Integrated Planning

    <b>Hi Marc, When I am running the URL for file upload in BI Integrated Planning, I am getting the below message ( we have created the variable on navigational attribute):</b> Note The following error text was processed in the system BWD : /BI0/OICOST

  • EJB-Ref rewriting in IAS-Console

    Hi, I have an EJB A from wich i want to call another EJB B. So I put an EJB Reference in ejb.jar and orion.xml from EJB A. The EJB B I want to call is in another Application. So I want to set the jndi- location in the settings on the Application Serv