Stuck on getting iPhone secure channel to work

I have created a simple 'hello world' flex mobile project to go on an iphone.  There is also a server created using grails and I am using Blazeds to communicate between the two.  I wanted the communication between them to be secure, so I wanted to use a secure channel.  So I have the following channel definition:
<channel-definition id='my-secure-amf' class='mx.messaging.channels.SecureAMFChannel'>
     <endpoint url='https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure'
          class='flex.messaging.endpoints.SecureAMFEndpoint'/>
     <properties>
          <add-no-cache-headers>false</add-no-cache-headers>
     <properties>
</channel-definition>
and an equivalent CallResponder and service created via the Flash Builder Data/Services wizard.  When I run the flex project on the iphone simulator on the desktop everything works fine, but when I package it into an app and run it on my iphone i get the following error message:
Send failed
Channel.Connect.Failed error
NetConnection.Call.Failed: HTTP:
Failed: url: 'https://www.example.com/messagebroker/amfsecure'
(I have changed the website address, but it does work on the simulator and I also have an ordinary flex project which runs fine against the website address.)
Please can anybody help, as I have run out of ideas.
Thanks in advance.

Also tryed out the tips from https://discussions.apple.com/message/6982187#6982187
But no succes

Similar Messages

  • I can't get iphone screen mirroring to work via my  apple tv

    I have ios5 on my phone, and an apple TV. I can not get the mirroring funcion to work on the Apple TV. I double click the home button on the phone, slide the bottom row of aps all the way to the right, and click on the Air Play symbol, but no luck. Any ideas?

    Mirroring is working on my iPad2 and iPhone4S (IOS5) but not on my iPad (ios5) or iPhone 3G (IOS4).
    As I understand it, mirroring is restricted to iPad2 and iPhone4S on ios5.
    Hope that helps.
    Mort

  • Can't get iPhone 5 recording to work using Quicktime on Yosemite

    QuickTime on Yosemite now has this nifty feature where you can record your iPhone, provided you connect it using a lightning cable. Now I've done all that, but when I open QuickTime and select my iPhone from the dropdown menu next to the record button on QuickTime, it stutters and fails to pull my iPhone's image to my mac. If I press record anyways, it crashes.
    One thing that does happen is that it keeps reopening iPhoto asking if I want to import photos from my phone. (a little annoying.) Maybe the cable is bust? It works fine in any other occasion.
    Who else has this problem? I need the recording function pretty badly...

    I'm having a similar issue.  I'm trying to record some games on my iPhone 6 Plus.  My Macbook Pro is from 2010 and still running strong.  However, I'm getting crashes when trying to record Vain Glory.  I can record other games like Grand Theft Auto: San Andreas.  Quicktime on the Mac just seems to be crashing with certain iPhone apps.  Weird issue.

  • Can't get iPhone Remote App to work

    I'm running iTunes 10.7 on OS-X10.6.8 and trying control using an iPhone 4S running iOS 6.0.1. In theory I should be able to link via my AppleID OR by some other passcode authenticated technique. Neither seem to work at all.
    Both seem to be happily talking to iTunes/AppStore and are on the same network.
    Any ideas or recommended threads to look at?

    Problem Solved, Just had to play around with the firewall settings...
    Cheeers !

  • Can't get "Encode Alpha Channel" to work.

    I created an animation in Apple Motion with an Alpha Channel and exported it as a .mov.  I put it on my web page and the Alpha Channel appears fine.  When I run my file through Media Encoder, the Alpha Channel is gone even though my settings appear to be correct: FLV, ON2VP6, CBR.

    Looks like this question is for Adobe Media Enocder not for Flash Media Live Encoder. Please post on
    http://forums.adobe.com/community/ame

  • After doing the new upgrade, my security cameras quit working.

    How do I get my security cameras to work with the new upgrade

    Disappointed iOS 6 wrote:
    Can I reinstall the previous iOS , my iphone is now a POS because of the new IOS . My iPad no longer has the YouTube app?? And what happened to google maps?  Galaxy 3 for me and a google tablet seems like a better option.
    No more posts from you then.
    Excellent!

  • Stuck at "verifying iphone software" for hours

    i've searched for this problem before with no answers. updating to 3.0 was a mistake, it got stuck at verifying iphone software and nothing worked. reinstalled itunes and did everything. some old messages suggested i try to install itunes on another computer and try, and it worked. now i have a iphone with everything deleted off it. i used a public computer to do this.
    how do i begin using my iphone back on my laptop, sync it, etc? i know i have my old pictures, etc on my old computer, can i put it back? and what the heck kind of problem is this where apple doesn't have a solution for?

    Hi! This link has helped a lot of our customers:
    http://support.apple.com/kb/TS1275
    If that doesn't fix it it is typically caused by 3G PC card software (Aircard, etc), Internet Service Provider communication software, or internet speed software that modify the default TCP/IP packet size. We would need to edit your registry to get this resolved. If this applies to you call us at 800-MY-IPHONE and one of us will be able to help!

  • Secure Channel and Key sharing

    Hi all,
    I'm new in this Java Card technology and in the last month i've been studying some documents and guidelines to develop a SIM Toolkit application.
    What i have in hands now will need the share keys for assymmetric encryption, so i will need the share a public key.
    So my main doubts are, when a Secure Channel is established from the card, the other point of the channel is the network operator right? So to establish a secure connection i will need get a secure channel in the install() method and send the random key to use in decryption? For this i read somewhere that there are APDU specific commands for keys.
    Maybe this is a little confusing but there are some concepts about this that aren't clear inside my head ;)
    If someone can provide me some answers or some guideline regarding this i would be very thankful.
    Regards

    Hi Shane,
    Thanks for your answers! So analysing what you said:
    safarmer wrote:
    Hi,
    igosneves wrote:
    What i have in hands now will need the share keys for asymmetric encryption, so i will need the share a public key.This is easy enough to do. When you install the Applet, you should be able to generate a key pair for this. Then when you need to encrypt data to the card, you can first send an APDU to retrieve the public key. Then use it to encrypt the data before sending back to the card.
    Yes, this can be done using APDU but to retrieve they key i have to use a specific APDU created by me? I ask this because i only found APDU for Put Key operation... :P
    igosneves wrote:
    So my main doubts are, when a Secure Channel is established from the card, the other point of the channel is the network operator right? Not sure what you mean by this, but the client application will be the other end of the secure channel. That is, the application communicating with the applet through APDU's.
    Yes that is what i meant to. The client application will be someone that is sending APDUs through a card reader or through an OTA platform am i right?
    And if i want to do something like have a server, generate the key pairs in that server and share the public key to the Applet so that there i can send encrypted SMS from the mobile to the server? The process is the same for sharing keys? The only way to put the key in the card is using card reader or OTA?
    igosneves wrote:
    So to establish a secure connection i will need get a secure channel in the install() method and send the random key to use in decryption? For this i read somewhere that there are APDU specific commands for keys. If you want to use a GP secure session you will need to ensure that the client knows the card platform keys. Since this is not a overly secure model (as you are using a secret key), you may want to focus on using the key pair you mentioned earlier in your post. If the platform keys are compromised it is possible for code to be added/removed from your card. You can either simply use the public key for securing data to the card, or you can use 2 asymmetric key pairs (client and server) to establish a symmetric session key (3TDEA?) for the secure session. You could model this off TLS/SSL.
    Cheers,
    ShaneThanks again,
    Rodrigo

  • Secure Channel base key

    Hi everyone,
    Please, how can i get the Secure Channel base key ?
    All my thanks !
    Edited by: user13723459 on 27 janv. 2011 05:55

    Regarding this issue,
    I have two cards (for GSM). To manage contents on the first one I have to provide two 16-byte keys (Cenc and Cmac). The process involves INITIALIZE_UPDATE/EXTERNAL_AUTHENTICATE and the commands are sent to the Card Manager (select by default after reset). Once I have identified myself I can start loading/installing/deleting etc.
    Withe the second one I have to do things different:
    1. The very first APDU I send is VERIFY (with a key), not an INITIALIZE_UPDATE/EXTERNAL_AUTHENTICATE pair
    2. I send the VERIFY to the GSM applet (selected by default after reset), not to the card manager
    3. Having successfully identified myself before the GSM applet, I select the Card manager and start loading/installing/deleting etc.
    What is the difference, or maybe why should there be a difference? I understand the first case-show your credentials to the card manager and it will let you manage card contents, but what is the difference in the second case? Why do I identify myself before the GSM applet, not before the card manager?
    Thanks

  • I have Iphone 3GS and the IOS is 6.1.3 I have downloaded BBM but it's getting stucked at Spot Line. Does it work with 6.1.3?

    I have Iphone 3GS and the IOS is 6.1.3 I have downloaded BBM but it's getting stucked at Spot Line. Does it work with 6.1.3?

    Forgot to mention I live in Peru Southamerica, the cell provider is Claro (America Moviles).

  • I have an iphone 3gs and when i first updated to the ios 5 it didnt work, when i did it again, it shut down my phone and told me i had to restore.  However, when i try to restore it gets stuck in "restoring iphone firmware"  Help!!!!

    I have an iphone 3gs and after trying to update to ios 5 my phone needed to be restored and is now stuck in "restoring iphone firmware"  I have tried powering on and off, reinstalling itunes, my phone is useless.  Is this temporary or is it dead?

    Ali i had this problem today and it took me 7 hours to get it back on . i ended up downloading firmware from a third party site , it  was a nightmare . i would recommend just taking ur fone into apple

  • Can't get secure wlan to work with new guest wlan

    Dear Support,
    I'm having a nightmare! where I can seem to get either one wlan to work or the other but not both together.
    I posted previously and reconfigured as per the suggestion, however the problem I get is that the secure wlan client associates, then de-associates after roughly 30 seconds with both a guest (no security) and secure (eap using ms ias as radius server)
    my previous post is;
    http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Wireless%20-%20Mobility&topic=Security%20and%20Network%20Management&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddcfe12
    and the log shows the following, obviously the client is set to connect automatically.
    *Mar 1 00:04:35.105: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:04:51.391: %DOT11-6-ASSOC: Interface Dot11Radio0, Station 000e.35f8
    .5d13 Associated KEY_MGMT[NONE]
    *Mar 1 00:04:51.506: %DOT11-4-MAXRETRIES: Packet to client 000e.35f8.5d13 reach
    ed max retries, removing the client
    *Mar 1 00:04:51.506: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 000e.35f8.5d13 Reason: Previous authentication no longer valid
    *Mar 1 00:05:15.176: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:05:32.703: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:05:58.780: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:06:16.141: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:06:40.759: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:06:58.145: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:07:00.560: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:07:18.020: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:07:43.902: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:08:01.254: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:08:16.172: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:08:16.737: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:08:37.397: %DOT11-6-ASSOC: Interface Dot11Radio0, Station AP-CDC#2 00
    13.cefd.48ca Associated KEY_MGMT[NONE]
    *Mar 1 00:08:54.732: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating
    Station 0013.cefd.48ca Reason: Sending station has left the BSS
    *Mar 1 00:08:57.193: %DOT11-4-MAXRETRIES: Packet to client 0013.cefd.48ca reach
    ed max retries, removing the client
    Thanks in advance for your assistance.
    Any prompt reply will be greatfully received. I also rate responses.
    Thanks again, regards, Adrian

    Hi Ben,
    Please find attached AP config, I can access the switch at the moment, but the config is fairly basic, trunk port with two vlans and vlan 1 as the native.
    here's the ap config.
    AP-CDC#2#sh startup-config
    Using 2989 out of 32768 bytes
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname AP-CDC#2
    enable secret 5 $1$LQ1O$NKYZoYAeiahKw0805kLHg0
    clock timezone GMT 0
    clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00
    ip subnet-zero
    ip domain name wlan.internal
    aaa new-model
    aaa group server radius rad_eap
    server 10.10.10.2 auth-port 1645 acct-port 1646
    aaa group server radius rad_mac
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    dot11 vlan-name dmz vlan 2
    dot11 ssid Secure
    vlan 1
    authentication open eap eap_methods
    authentication network-eap eap_methods
    dot11 ssid Guest
    vlan 2
    authentication open
    guest-mode
    username Cisco password 7 062506324F41
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption vlan 1 mode wep mandatory
    ssid Secure
    ssid Guest
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
    54.0
    no preamble-short
    channel 2412
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface Dot11Radio0.2
    encapsulation dot1Q 2
    no ip route-cache
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    bridge-group 2 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    hold-queue 160 in
    interface FastEthernet0.1
    encapsulation dot1Q 1 native
    no ip route-cache
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface FastEthernet0.2
    encapsulation dot1Q 2
    no ip route-cache
    bridge-group 2
    no bridge-group 2 source-learning
    bridge-group 2 spanning-disabled
    interface BVI1
    ip address 10.10.10.49 255.255.255.0
    no ip route-cache
    ip default-gateway 10.10.10.253
    ip http server
    no ip http secure-server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
    ip radius source-interface BVI1
    radius-server attribute 32 include-in-access-req format %h
    radius-server host 10.10.10.2 auth-port 1645 acct-port 1646 key 7 xyz
    radius-server vsa send accounting
    control-plane
    bridge 1 route ip
    line con 0
    line vty 0 4
    end
    AP-CDC#2#
    Thanks again, regards, Adrian

  • I have a macbook pro version 10.7.5 and my mailbox will not open at all and comes up with a quit message even though it is not open. how can i get into my account. it works on my iPhone an i have internet and all other functions working on my computer

    I have a macbook pro version 10.7.5 and my mailbox will not open at all and comes up with a quit message even though it is not open. how can i get into my account. it works on my iPhone and i have internet and all other functions working on my computer

    Launch the Console application in any of the following ways:
    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.
    Step 1
    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left. If you don't see that menu, select
    View ▹ Show Log List
    from the menu bar.
    Enter the name of the crashed application or process in the Filter text field. Select the messages from the time of the last crash, if any. Copy them to the Clipboard by pressing the key combination command-C. Paste into a reply to this message by pressing command-V.
    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.
    Please do not indiscriminately dump thousands of lines from the log into this discussion.
    Important: Some private information, such as your name, may appear in the log. Anonymize before posting.
    Step 2
    In the Console window, look under User Diagnostic Reports (not "Diagnostic and Usage Messages") for crash reports related to the crashed process. The report name starts with the name of the process, and ends with ".crash". Select the most recent report and post the entire contents—the text, not a screenshot. I know the report is long. Please post all of it anyway.
    In the interest of privacy, I suggest that, before posting, you edit out the “Anonymous UUID,” a long string of letters, numbers, and dashes in the header of the report, if it’s present (it may not be.)
    Please don’t post other kinds of diagnostic report—they're very long and rarely helpful.

  • My apple remote app on my iPhone 4S has stopped working after the 7.0.6 security update.

    My apple remote app on my iPhone 4S has stopped working after the 7.0.6 security update. It's not my home sharing or router setting, I have an ipad that I haven't yet updated that works completely fine and my network is run on the newest AirPort Extreme.

    i have same problem but much worst.. i update my iphone4s ios 7.1.1 to 7.1.2 and my iphone CAN'T READ MY SIM, MODEM FIRMWAY GONE, IMEI GONE, and same issue as you guys can't hear sound on my speaker but using earphone works, battery drain much faster than before. Any suggestion guys to Fix my iphone.thanks a lot. APPLE PLEASE FIX. TAKE ACTION.

  • My iPhone is using my work email to sign in to the cloud, but my apple id and password are with my "personal" email address.  I can't get rid of my "work" email address on my iPhone 4S

    My iPhone is using my work email to sign in to the cloud, but my apple id and password are with my "personal" email address.  I can't get rid of my "work" email address on my iPhone 4S

    Hi Sister Kate,
    If you change the Apple ID you are using on an iPhone or other iOS device, there are several places you need to change it on the device. See this article -
    Apple ID: What to do after you change your Apple ID
    Thanks for using Apple Support Communities.
    Best,
    Brett L 

Maybe you are looking for

  • ABAP RFC Validations in WebDynpro for Java

    Hi All, Any idea how I can handle ABAP validations in WebDynrpo for Java. For example, there is a standard BAPI for (MM01), howare the validations and ECC Configurations (as in plant data etc) shown in WDJ. Do they also come as some drop-down or sear

  • Can't create, delete or edit users in /LDAPv3/127.0.0.1 via WGM

    Hi guys, I have followed Mike Bombiches guide to 'Leveraging AD on Mac OSX.' All was fine yesterday... But today I cannot create, delete or edit users in the OD Directory. The New User/Group etc.. icons are greyed out... And yes I am authenticated...

  • SSD drive will not connect using USB adapter

    Hello- I am having a problem with my CT250BX100SDI drive. It was fully functional in a laptop that I retired. I removed it and plan to use it as a external USB drive for backups.However I cannot reliably connect to it.I have tried a Win 8.1 laptop, U

  • DB13c Error:ORA-12541: TNS:no listener for windows systems

    Hello Gurus, We are facing an issue in DB13C jobs. Background: DB13c is setup in Solution Manager. Only for windows systems DB13 jobs are failing. Job log is given below: Job started Step 001 started (program RSDBAJOB, variant &0000000002249, user ID

  • Re: Batchs

    Hello, 1) I use Forte for batch applications. But the definition of a batch may be different with that kind of architecture : you have events. In fact, I think that classic batch (long processing done by night to close the day activity for instance)