Using Applescript to connect to VPN and add routes

I posted this in the wrong place last night, but actually managed to get an answer to it. Here is the original post:
I need to be able to set some routes upon opening a particular VPN connection so I did some searching and found a really simple Applescript that does the job. Problem is it tries to set the routes before the VPN actually connects so the routes don't go in.
I added in a 10 second delay which does the trick, but I'm thinking there has to be a way to do this that waits until the VPN actually connects before continuing - so if it takes 5 seconds or 10 or whatever, it waits.
The other thing I'm doing that I think is bad is I'm sending a route delete command before sending the add command. Why? Because if I don't and for some reason the route is partially in the table, it doesn't give an error and ends up not routing. Again, probably a better way to do this.
Here is my current script:
-- Connect Work VPN
tell application "System Events"
tell current location of network preferences
set VPNservice to service "Work" -- name of the VPN service
if exists VPNservice then connect VPNservice
end tell
end tell
delay 10
set gateway to "x.x.x.x" -- omitted here for security
do shell script "route delete 192.168.25.0/24 " & gateway with administrator privileges
do shell script "route delete 192.168.20.0/24 " & gateway with administrator privileges
do shell script "route add 192.168.25.0/24 " & gateway with administrator privileges
do shell script "route add 192.168.20.0/24 " & gateway with administrator privileges
From the response I received, I modified the script to this:
tell application "System Events"
tell current location of network preferences
set VPNservice to service "Work" -- name of the VPN service
if exists VPNservice then connect VPNservice
repeat until (connected of current configuration of VPNservice)
delay 1
end repeat
end tell
end tell
set gateway to "x.x.x.x" -- omitted here for security
do shell script "route delete 192.168.25.0/24 " & gateway with administrator privileges
do shell script "route delete 192.168.20.0/24 " & gateway with administrator privileges
do shell script "route add 192.168.25.0/24 " & gateway with administrator privileges
do shell script "route add 192.168.20.0/24 " & gateway with administrator privileges
That seems to work perfectly, but I'm still wondering if there is a better way of handling the routes. Suggestions?
Thanks.

I realize the VPN gateway should add the routes, but it's not and they don't seem to want it to. No idea why.
As for deleting/adding the routes, yes it does seem wrong to do this or pointless. The reason I'm doing this is for what I found in my testing of the script which was if the script hung for some reason and the route did not fully go into the table, I would be unable to add it with the script when I ran it again.
I'm probably not explaining it that well, but when I couldn't route after trying to run my script initially, I tried manually running the add route command and I'd get an error. Thus, I deleted/added the route and than it worked again.
As pointless as it seems it works every time. I'm sure there's a better/cleaner/smarter way of doing this, but I don't know enough about Applescript to do any more. At this point I can probably remove the delete command, though, since it should run properly each time.

Similar Messages

  • If I'm overseas, and I use iMessage not connected to wifi, and I'm messaging someone who has an iPhone as well with ios 7, will get charged SMS/mms fees?

    if I'm overseas, and I use iMessage not connected to wifi, and I'm messaging someone who has an iPhone as well with ios 7, will get charged SMS/mms fees?

    No, but cellular data will be used at whatever international roaming rate you carrier charges for data in whatever country.
    Exchanging iMessages requires the same thing as email - an available internet connection. SMS/MMS is completely separate from iMessage.

  • How use jndi to create a organization and add a  user  to it.(ÈçºÎ´´½¨Ò»¸ö×éÖ¯µ¥Î»)

    how use jndi to create a organization and add a user to it¡£THANKS£¡
    ÈçºÎ´´½¨Ò»¸ö×éÖ¯µ¥Î»,²¢½«Ò»¸öÓû§Ìí¼Ó½øËü¡£Ð»Ð»£¡

    Hi,
    The command above about creating a group only works for the root site of the site collection, because the scope of the user group is site collection level, these groups
    can be used in all the sites in this site collection.
    With the existing groups in the root site, we can add users into them and grant specific permissions of a specific sub site to these groups.
    Here is a demo about how to assign permission to a group using Client Object Model(though in C#) for your reference:
    http://www.c-sharpcorner.com/UploadFile/54db21/set-permission-to-group-in-sharepoint-2010-programmatically/
    Best regards,
    Patrick
    Patrick Liang
    TechNet Community Support

  • Cisco ASA 5505 VPN connection issue ("Unable to add route")

    I'm trying to get IPSec VPN working onto a new Cisco ASA5505. Pretty standard configuration.
    Setup:
    * Cisco VPN client on Windows 7 (v5.0.07.0290 x64 on Laptop1 and v5.0.07.0440 x64 on Laptop2)
    * PPPoE/NAT and internal DHCP on the ASA were configured with the Startup Wizard in ASDM
    NATting is working fine - internal PCs get an IP address in the 192.168.2.0/24 range and can all access the Internet.
    I wanted to be able to connect from anywhere to the ASA in order to reach one of the internal servers. Should be pretty basic.
    First I tried with the built-in ASDM IPSec Wizard, instructions found here.
    VPN clients can connect to the ASA, are connected (until they're manually disconnected), but cannot reach the internal network nor the Internet. Note VPN client can connect fine to a different VPN site (not administered by myself).
    Client logs show following error messages:
    1 15:53:09.363 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    2 15:53:13.593 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.101
    3 15:53:13.593 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100165, Gateway: ac100101.
    4 15:54:30.425 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    5 15:54:31.433 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CheckUpVASettings: Found IPADDR entry addr=172.16.1.101, error 0
    6 15:54:32.445 02/11/12 Sev=Warning/2     CVPND/0xA3400015
    Error with call to IpHlpApi.DLL: CleanUpVASettings: Was able to delete all VA settings after all, error 0
    7 20:50:45.355 02/11/12 Sev=Warning/3     IKE/0xA300005F
    Firewall, Cisco Intrusion Prevention Security Agent, is not running, the client will not send firewall information to concentrator.
    8 20:50:50.262 02/11/12 Sev=Warning/2     CVPND/0xE3400013
    AddRoute failed to add a route with metric of 0: code 160
    Destination     192.168.1.255
    Netmask     255.255.255.255
    Gateway     172.16.1.1
    Interface     172.16.1.100
    9 20:50:50.262 02/11/12 Sev=Warning/2     CM/0xA3100024
    Unable to add route. Network: c0a801ff, Netmask: ffffffff, Interface: ac100164, Gateway: ac100101.
    I've already tried the suggestions from this link, although the problem is different there (as the user can still access the internet, even without split tunneling, which I cannot).
    A show run shows the following output (note in the below I have tried a different VPN network: 192.168.3.0/24 instead of 172.16.1.0/24 seen in the Client log)
    Result of the command: "sh run"
    : Saved
    ASA Version 8.2(5)
    hostname AsaDWD
    enable password kLu0SYBETXUJHVHX encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.2.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group DW-VPDN
    ip address pppoe setroute
    ftp mode passive
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.240
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    ip local pool DWD-VPN-Pool 192.168.3.5-192.168.3.15 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.2.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    vpdn group DW-VPDN request dialout pppoe
    vpdn group DW-VPDN localname fa******@SKYNET
    vpdn group DW-VPDN ppp authentication pap
    vpdn username fa******@SKYNET password *****
    dhcpd auto_config outside
    dhcpd address 192.168.2.5-192.168.2.36 inside
    dhcpd domain DOMAIN interface inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy DWD internal
    group-policy DWD attributes
    vpn-tunnel-protocol IPSec
    username test password ******* encrypted privilege 0
    username test attributes
    vpn-group-policy DWD
    tunnel-group DWD type remote-access
    tunnel-group DWD general-attributes
    address-pool DWD-VPN-Pool
    default-group-policy DWD
    tunnel-group DWD ipsec-attributes
    pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum client auto
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:3e6c9478a1ee04ab2e1e1cabbeddc7f4
    : end
    I've installed everything using the CLI as well (after a factory reset). This however yielded exactl the same issue.
    Following commands have been entered:
    ip local pool vpnpool 172.16.1.100-172.16.1.199 mask 255.255.255.0
    username *** password ****
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash sha
    isakmp policy 1 group 2
    isakmp policy 1 lifetime 43200
    isakmp enable outside
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 10 set transform-set ESP-3DES-SHA
    crypto dynamic-map outside_dyn_map 10 set reverse-route
    crypto dynamic-map outside_dyn_map 10 set security-association lifetime seconds 288000
    crypto map outside_map 10 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp nat-traversal
    sysopt connection permit-ipsec
    sysopt connection permit-vpn
    group-policy dwdvpn internal
    group-policy dwdvpn attributes
    vpn-tunnel-protocol IPSec
    default-domain value DWD
    tunnel-group dwdvpn type ipsec-ra
    tunnel-group dwdvpn ipsec-attributes
    pre-shared-key ****
    tunnel-group dwdvpn general-attributes
    authentication-server-group LOCAL
    default-group-policy dwdvpn
    Unfortunately I'm getting the same "AddRoute failed to add a route with metric of 0: code 160" error message.
    I'm very confused as this should be a pretty standard setup. I tried to follow the instructions on the Cisco site to the letter...
    The only "differences" in my setup are an internal network of 192.168.2.0 (with ASA IP address 192.168.2.254) and PPPoE with DHCP instead of no PPPoE at all.
    Does anyone know what's going on?

    Yes, I have tried from a different laptop - same results. Using that laptop I can connect to a different IPSec site without issues.
    Please find my renewed config below:
    DWD-ASA(config)# sh run: Saved:ASA Version 8.2(5) !hostname DWD-ASAenable password ******* encryptedpasswd ****** encryptednames!interface Ethernet0/0 switchport access vlan 2!interface Ethernet0/1!interface Ethernet0/2!interface Ethernet0/3!interface Ethernet0/4!interface Ethernet0/5!interface Ethernet0/6!interface Ethernet0/7!interface Vlan1 nameif inside security-level 100 ip address 192.168.2.254 255.255.255.0 !interface Vlan2 nameif outside security-level 0 pppoe client vpdn group DWD ip address pppoe setroute !ftp mode passiveaccess-list inside_nat0_outbound extended permit ip any 192.168.50.0 255.255.255.224 pager lines 24logging asdm informationalmtu inside 1500mtu outside 1500ip local pool vpnpool 192.168.50.10-192.168.50.20 mask 255.255.255.0icmp unreachable rate-limit 1 burst-size 1no asdm history enablearp timeout 14400global (outside) 1 interfacenat (inside) 0 access-list inside_nat0_outboundnat (inside) 1 0.0.0.0 0.0.0.0timeout xlate 3:00:00timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolutetimeout tcp-proxy-reassembly 0:01:00timeout floating-conn 0:00:00dynamic-access-policy-record DfltAccessPolicyhttp server enablehttp 192.168.2.0 255.255.255.0 insidehttp 0.0.0.0 0.0.0.0 outsideno snmp-server locationno snmp-server contactsnmp-server enable traps snmp authentication linkup linkdown coldstartcrypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac crypto ipsec security-association lifetime seconds 28800crypto ipsec security-association lifetime kilobytes 4608000crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAPcrypto map outside_map interface outsidecrypto isakmp enable outsidecrypto isakmp policy 10 authentication pre-share encryption 3des hash sha group 2 lifetime 86400telnet timeout 5ssh 0.0.0.0 0.0.0.0 outsidessh timeout 5console timeout 0vpdn group DWD request dialout pppoevpdn group DWD localname *****@SKYNETvpdn group DWD ppp authentication papvpdn username *****@SKYNET password ***** dhcpd auto_config outside!dhcpd address 192.168.2.10-192.168.2.40 insidedhcpd enable inside!threat-detection basic-threatthreat-detection statistics access-listno threat-detection statistics tcp-interceptwebvpn enable outside svc enablegroup-policy DfltGrpPolicy attributes vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpngroup-policy dwdipsec internalgroup-policy dwdipsec attributes vpn-tunnel-protocol IPSec default-domain value DWDDOMusername user1 password ***** encrypted privilege 0username user1 attributes vpn-group-policy dwdipsectunnel-group dwdipsec type remote-accesstunnel-group dwdipsec general-attributes address-pool vpnpool default-group-policy dwdipsectunnel-group dwdipsec ipsec-attributes pre-shared-key *****tunnel-group dwdssl type remote-accesstunnel-group dwdssl general-attributes address-pool vpnpool!class-map inspection_default match default-inspection-traffic!!policy-map type inspect dns preset_dns_map parameters  message-length maximum client auto  message-length maximum 512policy-map global_policy class inspection_default  inspect dns preset_dns_map   inspect ftp   inspect h323 h225   inspect h323 ras   inspect rsh   inspect rtsp   inspect esmtp   inspect sqlnet   inspect skinny    inspect sunrpc   inspect xdmcp   inspect sip    inspect netbios   inspect tftp   inspect ip-options !service-policy global_policy globalprompt hostname context no call-home reporting anonymousCryptochecksum:f5c8dd644aa2a27374a923671da1c834: endDWD-ASA(config)#

  • Creating AppleScript That Watches a Folder and Adds New Files to iTunes

    Is it possible to create a AppleScript that watches a folder and automatically adds any new files placed into the folder to my iTunes library?

    Probably. You can take a look through Doug's AppleScripts for iTunes and see if there's anything pre-existing you could use or modify.
    An alternative might be Hazel which says it can do that. It's not free, but if it works it would probably be a lot easier.
    Regards.

  • When using the Database Connectivity Toolset, reads and writes with long binary fields are incompatible.

    I am trying to write LabVIEW Variants to long binary fields in a .mdb file using the Database Connectivity Toolset. I get errors when trying to convert the field back to a variant after reading it back from the database.
    I next tried flattening the variant before writing it and ultimately wound up doing the following experiments:
    1) If I use DB Tools Insert Data to write an ordinary string and read it back using a DB Tools Select Data, the string is converted from ASCII to Unicode.
    2) If I use DB Tools Create Parameterized Query to do an INSERT INTO or an UPDATE operation, specifying that the data is BINARY, then read it back using a DB Tools Select Data,
    the length of the string is prepended to the string itself as a big-endian four-byte integer.
    I can't think of any way to do a parameterized read, although the mechanism exists to return data via parameters.
    Presuming that this same problem affects Variants when they are written to the database and read back, I could see why I get an error. At least with flattened strings I have the option of discarding the length bytes from the beginning of the string.
    Am I missing something here?

    David,
    You've missed the point. When a data item is flattened to a string, the first four bytes of the string are expected to be the total length of the string in big-endian binary format. What is happening here is that preceding this four-byte length code is another copy of the same four bytes. If an ordinary string, "abcdefg" is used in place of the flattened data item, it will come back as <00><00><00><07>abcdefg. Here I've used to represent a byte in hexadecimal notation. This problem has nothing to do with flattening and unflattening data items. It has only to do with the data channel consisting of writing to and reading from the database.
    I am attaching three files that you can use to demonstrate the problem. The VI file c
    ontains an explanation of the problem and instructions for installing and operating the demonstration.
    Ron Martin
    Attachments:
    TestLongBinaryFields.vi ‏132 KB
    Sample.UDL ‏1 KB
    Sample.mdb ‏120 KB

  • Outlook 2010 and 2013 are unable to connect but OWA (and mail routing) works fine

    Hi-
    Not sure why but this past Sunday (just after DST adjustment) outlook clients (using 2010 and 2013) were unable to connect to an Exchange 2013 server.  OWA and mail routing (internal and external) is working fine.  I've even tried on multiple machines
    and all of them experience the same issue.  On a new machine with a fresh version of outlook 2013 installed here is what happens:
    Click on Outlook 2013
    Click Next until the account setup is displayed.
    Name and email is auto-populated
    Established network connection is good
    Searching for email address settings is good (once the self-signed exchange 2013 cert is accepted)
    And then the logging onto the mail server fails.  The first pop-up is:
    The Connection to Microsoft Exchange is unavailable.  Outlook must be online or connected to complete this action.
    Clicking "OK" is followed up with a window with the Microsoft Exchange connection info.
    It lists Microsoft Exchange server which is populated with: GUID@<domain suffix>
    Mailbox which is populated with: =SMTP:<Valid Email address>
    On the Exchange Server I have noticed that the Web Management Service (WMSVC) is stopped and will not start.  Starting the service outputs:
    EventID 7024
    "The Web Management Service terminated with the following service-specific error:  Unspecified error"
    Not really helpful :)
    Since this is only happening with Outlook on multiple clients I'm expecting something with Exchange or the ability for outlook to connect to exchange.
    Thanks in advance!

    Hi
    I know this is an old post, but I'm having a very similar issue. I have CU6 installed and all other client connectivity apart from internal Outlook connectivity is working fine. I have distributed the new Self-Signed Certificate and the tested to verify
    the clients trust it. I have tried on multiple machine with multiple accounts and none of them connect.
    I'm at the stage of reinstalling, but I would rather troubleshoot the problem, just in case ever hit the same wall in the future. I have run Test-OutlookConnectivity with the following output;
    RunspaceId         : 71f8d740-c499-4bbe-8baf-9cbb12566fb8
    Server             : PW-SC-01.companyname.local
    MonitorIdentity    : Outlook.Protocol\OutlookRpcDeepTestProbe\NEW2013
    RequestId          : 75641e34-aa49-4fce-aad7-181b56dd7b29
    ExecutionStartTime : 10/11/2014 13:50:03
    ExecutionEndTime   : 10/11/2014 13:50:03
    Error              : Error 0x6ba (The RPC server is unavailable) from ClientAsyncCallState.CheckCompletion: 
                         RpcAsyncCompleteCall 
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 2
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1710
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: 0 (0x00000000)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 13
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1352
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: -1073606646 (0xC002100A)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0xC002100A
                         EEInfo: Detection location: 1380
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 12175 (0x00002F8F)
                         EEInfo:    prm[1]: Unicode string: /rpc/rpcproxy.dll?PW-SC-01.companyname.local:6001
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0x00010000
                         EEInfo: Detection location: 1385
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 8 (0x00000008)
                         EEInfo:    prm[1]: Binary Buffer: [48-1263-10248-1262-126-9632122164676121-3988104-118-11373-61-94
                         -111-112-98-1217048136942-12272-122-91311550483449324830638543192311910198979999101115115461121199
                         91111091091154699111461171074830231349524949485349505348484990231349574949485349505348484990483449
                         324830638543192311910198979999101115115461121199911110910911546991114611710748-12613448136942-1227
                         2-122-913111503-126115048-1261102-126110-22103-15-109-16-121-119-3121-4-106119-119-9369122-5779121
                         719-98-24-67-32918-98-236-19-10715326827-76102-61100108-12718-438331-37109-102-57-9942-11389-10374
                         -77-5-4-107109-11847342222-63-48-7468-17-1067033-56111-33-54-16-105-62-76-1282011-1664-12158-4915-
                         88-53-9-29-2994-49-54-5211-1364-212121-12396-127-353-396185117-681229-434246070-109818119-4858-128
                         -106-1279248-49110-44-81-121494199-118-17-106-71106828294-93-110-110-106-415084-127126-45-12331421
                         -61-2757-24-128-28-25111-52113121-56-98-5821527282-47255245104-111-55-1099747-115-11172-287-12526-
                         79-12430-119421360-107-6430-5410282-52-51-128533354-116672757-77-75-111-72-118-10114-84484825-40-1
                         8-70-24-9111-61-5391-8034125-12632-16-19-128112030-8-427523101-93-127-5348-127-5648146385291511-14
                         4325-9648-127-110638529174-127-11848-127-121-12623119101989799991011151154611211999111109109115469
                         911146117107-1262211211945115994548494611211999111109109115461081119997108-12626651171161116810511
                         59911111810111446808767111109109115461081119997108-12626651171161116810511599111118101114468087671
                         11109109115469911146117107-12613808767111109109115461081119997108-12613808767111109109115469911146
                         11710748196385293741248106843615573148126385291911-14248048136942-12272-122-913115503-12611081-930
                         6613-74953718-12745-14-25-94107-80-5-45-2231536-1728-12897-8587577-1252765-892896-83-10267-7926-20
                         -9841-1079-12-29-4315671111357-684036-40-5129-91-24-461066-12306-65-9118-89115191071-30-20-1067161
                         -83-91-74105-931649-48-96126-13-71-118-8967567-40-64-104-113-31-51-102357125100-50113-103-113123-9
                         873-627067-25-908-10131118125122-71-115-37-1850-1055851-31410-77-7312-36848124-26104-10711043-2048
                         -48-12666611759121127-2960-1571-9-95-98-1036911610-74221-32-25114-108749933-7147562114-3635-101-81
                         -1058-73108-61-78-128-116-715155112714-37-18-84-8331-2716-1174257-76-5-1598-15-12875-98-7329632178
                         -10714-123-6312212-1028359-56-76-683-873987-2120-845954-7617-71-57999828110], size=926
    Exception          : Microsoft.Exchange.Rpc.ServerUnavailableException: Error 0x6ba (The RPC server is unavailable) 
                         from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall 
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 2
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1710
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: 0 (0x00000000)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 13
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1352
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: -1073606646 (0xC002100A)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0xC002100A
                         EEInfo: Detection location: 1380
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 12175 (0x00002F8F)
                         EEInfo:    prm[1]: Unicode string: /rpc/rpcproxy.dll?PW-SC-01.companyname.local:6001
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0x00010000
                         EEInfo: Detection location: 1385
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 8 (0x00000008)
                         EEInfo:    prm[1]: Binary Buffer: [48-1263-10248-1262-126-9632122164676121-3988104-118-11373-61-94
                         -111-112-98-1217048136942-12272-122-91311550483449324830638543192311910198979999101115115461121199
                         91111091091154699111461171074830231349524949485349505348484990231349574949485349505348484990483449
                         324830638543192311910198979999101115115461121199911110910911546991114611710748-12613448136942-1227
                         2-122-913111503-126115048-1261102-126110-22103-15-109-16-121-119-3121-4-106119-119-9369122-5779121
                         719-98-24-67-32918-98-236-19-10715326827-76102-61100108-12718-438331-37109-102-57-9942-11389-10374
                         -77-5-4-107109-11847342222-63-48-7468-17-1067033-56111-33-54-16-105-62-76-1282011-1664-12158-4915-
                         88-53-9-29-2994-49-54-5211-1364-212121-12396-127-353-396185117-681229-434246070-109818119-4858-128
                         -106-1279248-49110-44-81-121494199-118-17-106-71106828294-93-110-110-106-415084-127126-45-12331421
                         -61-2757-24-128-28-25111-52113121-56-98-5821527282-47255245104-111-55-1099747-115-11172-287-12526-
                         79-12430-119421360-107-6430-5410282-52-51-128533354-116672757-77-75-111-72-118-10114-84484825-40-1
                         8-70-24-9111-61-5391-8034125-12632-16-19-128112030-8-427523101-93-127-5348-127-5648146385291511-14
                         4325-9648-127-110638529174-127-11848-127-121-12623119101989799991011151154611211999111109109115469
                         911146117107-1262211211945115994548494611211999111109109115461081119997108-12626651171161116810511
                         59911111810111446808767111109109115461081119997108-12626651171161116810511599111118101114468087671
                         11109109115469911146117107-12613808767111109109115461081119997108-12613808767111109109115469911146
                         11710748196385293741248106843615573148126385291911-14248048136942-12272-122-913115503-12611081-930
                         6613-74953718-12745-14-25-94107-80-5-45-2231536-1728-12897-8587577-1252765-892896-83-10267-7926-20
                         -9841-1079-12-29-4315671111357-684036-40-5129-91-24-461066-12306-65-9118-89115191071-30-20-1067161
                         -83-91-74105-931649-48-96126-13-71-118-8967567-40-64-104-113-31-51-102357125100-50113-103-113123-9
                         873-627067-25-908-10131118125122-71-115-37-1850-1055851-31410-77-7312-36848124-26104-10711043-2048
                         -48-12666611759121127-2960-1571-9-95-98-1036911610-74221-32-25114-108749933-7147562114-3635-101-81
                         -1058-73108-61-78-128-116-715155112714-37-18-84-8331-2716-1174257-76-5-1598-15-12875-98-7329632178
                         -10714-123-6312212-1028359-56-76-683-873987-2120-845954-7617-71-57999828110], size=926
                            at Microsoft.Exchange.Rpc.ClientAsyncCallState.CheckCompletion()
                            at Microsoft.Exchange.Rpc.ExchangeClient.ClientAsyncCallState_Connect.End(IntPtr& 
                         contextHandle, TimeSpan& pollsMax, Int32& retryCount, TimeSpan& retryDelay, String& dn
    PoisonedCount      : 0
    ExecutionId        : 63105129
    SampleValue        : 33.5194
    ExecutionContext   :     Mailbox logon verification
                                 EMSMDB.Connect()
                                 Task produced output:
                                 - TaskStarted = 10/11/2014 13:50:03
                                 - TaskFinished = 10/11/2014 13:50:03
                                 - Exception = Microsoft.Exchange.Rpc.ServerUnavailableException: Error 0x6ba (The RPC 
                         server is unavailable) from ClientAsyncCallState.CheckCompletion: RpcAsyncCompleteCall 
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 2
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1710
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: 0 (0x00000000)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 13
                         EEInfo: Status: 0x000006BA
                         EEInfo: Detection location: 1352
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 1
                         EEInfo:    prm[0]: Long val: -1073606646 (0xC002100A)
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0xC002100A
                         EEInfo: Detection location: 1380
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 12175 (0x00002F8F)
                         EEInfo:    prm[1]: Unicode string: /rpc/rpcproxy.dll?PW-SC-01.companyname.local:6001
                         EEInfo: ComputerName: n/a
                         EEInfo: ProcessID: 14544
                         EEInfo: Generation Time: 2014-11-10 13:50:03.737
                         EEInfo: Generating component: 14
                         EEInfo: Status: 0x00010000
                         EEInfo: Detection location: 1385
                         EEInfo: Flags: 0
                         EEInfo: NumberOfParameters: 2
                         EEInfo:    prm[0]: Long val: 8 (0x00000008)
                         EEInfo:    prm[1]: Binary Buffer: [48-1263-10248-1262-126-9632122164676121-3988104-118-11373-61-94
                         -111-112-98-1217048136942-12272-122-91311550483449324830638543192311910198979999101115115461121199
                         91111091091154699111461171074830231349524949485349505348484990231349574949485349505348484990483449
                         324830638543192311910198979999101115115461121199911110910911546991114611710748-12613448136942-1227
                         2-122-913111503-126115048-1261102-126110-22103-15-109-16-121-119-3121-4-106119-119-9369122-5779121
                         719-98-24-67-32918-98-236-19-10715326827-76102-61100108-12718-438331-37109-102-57-9942-11389-10374
                         -77-5-4-107109-11847342222-63-48-7468-17-1067033-56111-33-54-16-105-62-76-1282011-1664-12158-4915-
                         88-53-9-29-2994-49-54-5211-1364-212121-12396-127-353-396185117-681229-434246070-109818119-4858-128
                         -106-1279248-49110-44-81-121494199-118-17-106-71106828294-93-110-110-106-415084-127126-45-12331421
                         -61-2757-24-128-28-25111-52113121-56-98-5821527282-47255245104-111-55-1099747-115-11172-287-12526-
                         79-12430-119421360-107-6430-5410282-52-51-128533354-116672757-77-75-111-72-118-10114-84484825-40-1
                         8-70-24-9111-61-5391-8034125-12632-16-19-128112030-8-427523101-93-127-5348-127-5648146385291511-14
                         4325-9648-127-110638529174-127-11848-127-121-12623119101989799991011151154611211999111109109115469
                         911146117107-1262211211945115994548494611211999111109109115461081119997108-12626651171161116810511
                         59911111810111446808767111109109115461081119997108-12626651171161116810511599111118101114468087671
                         11109109115469911146117107-12613808767111109109115461081119997108-12613808767111109109115469911146
                         11710748196385293741248106843615573148126385291911-14248048136942-12272-122-913115503-12611081-930
                         6613-74953718-12745-14-25-94107-80-5-45-2231536-1728-12897-8587577-1252765-892896-83-10267-7926-20
                         -9841-1079-12-29-4315671111357-684036-40-5129-91-24-461066-12306-65-9118-89115191071-30-20-1067161
                         -83-91-74105-931649-48-96126-13-71-118-8967567-40-64-104-113-31-51-102357125100-50113-103-113123-9
                         873-627067-25-908-10131118125122-71-115-37-1850-1055851-31410-77-7312-36848124-26104-10711043-2048
                         -48-12666611759121127-2960-1571-9-95-98-1036911610-74221-32-25114-108749933-7147562114-3635-101-81
                         -1058-73108-61-78-128-116-715155112714-37-18-84-8331-2716-1174257-76-5-1598-15-12875-98-7329632178
                         -10714-123-6312212-1028359-56-76-683-873987-2120-845954-7617-71-57999828110], size=926
                            at Microsoft.Exchange.Rpc.ClientAsy
    FailureContext     : 
    ExtensionXml       : 
    ResultType         : Failed
    RetryCount         : 0
    ResultName         : 75641e34aa494fceaad7181b56dd7b29-OutlookRpcDeepTestProbe/NEW2013
    IsNotified         : False
    ResultId           : 1748063
    ServiceName        : InvokeNow
    StateAttribute1    : Momt
    StateAttribute2    : UnknownIssue
    StateAttribute3    : PW-SC-01.companyname.local
    StateAttribute4    : Unknown
    StateAttribute5    : {C54AD38D-1E00-4F53-ABAE-26518C3FF82F}
    StateAttribute6    : 0
    StateAttribute7    : 0
    StateAttribute8    : 0
    StateAttribute9    : 0
    StateAttribute10   : 0
    StateAttribute11   : Momt
    StateAttribute12   : 
    StateAttribute13   : VgEAVAdXaW5kb3dzQwBBCEtlcmJlcm9zTA9QV0NPTU1TXG5hdGhhbmhVLlMtMS01LTIxLTIwNTc0OTEwMzItMzE4NDA2NDk3OC
                         0xNTQ2MTE0ODM1LTI2MzJHHQAAAAcAAAAtUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtNTEzBwAA
                         AAdTLTEtMS0wBwAAAAdTLTEtNS0yBwAAAAhTLTEtNS0xMQcAAAAIUy0xLTUtMTUHAADAE1MtMS01LTUtMC0zNDc3ODcxMTMHAA
                         AALlMtMS01LTIxLTIwNTc0OTEwMzItMzE4NDA2NDk3OC0xNTQ2MTE0ODM1LTQxODcHAAAALVMtMS01LTIxLTIwNTc0OTEwMzIt
                         MzE4NDA2NDk3OC0xNTQ2MTE0ODM1LTUxMgcAAAAuUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtND
                         E3NAcAAAAuUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtMzU3MAcAAAAuUy0xLTUtMjEtMjA1NzQ5
                         MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtNDEyMgcAAAAuUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMT
                         Q4MzUtMTE2NAcAAAAuUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtMTE0MQcAAAAuUy0xLTUtMjEt
                         MjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtNDE1MwcAAAAuUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LT
                         E1NDYxMTQ4MzUtNDE0NQcAAAAtUy0xLTUtMjEtMjA1NzQ5MTAzMi0zMTg0MDY0OTc4LTE1NDYxMTQ4MzUtNTE4BwAAAC5TLTEt
                         NS0yMS0yMDU3NDkxMDMyLTMxODQwNjQ5NzgtMTU0NjEx
    StateAttribute14   : 
    StateAttribute15   : 
    StateAttribute16   : 0
    StateAttribute17   : 0
    StateAttribute18   : 0
    StateAttribute19   : 0
    StateAttribute20   : 0
    StateAttribute21   : /o=companyname/ou=first administrative group/cn=Recipients/cn=NathanH
    StateAttribute22   : EMSMDB.Connect()
    StateAttribute23   : https://pw-sc-01.companyname.local:444/rpc/rpcproxy.dll?PW-SC-01.companyname.local:6001
    StateAttribute24   : Negotiate
    StateAttribute25   : [33]10/11/2014 13:50:03 [FAILED!] EMSMDB.Connect(); 
    Identity           : fcd6159dd8fe42aebf10100cc4934356
    IsValid            : True
    ObjectState        : New

  • Applescript to open various files and add info from filename to the file

    Hi guys,
    first time using this forum...
    and first time trying to do a script for apple...
    I figured out how to do simple things... like open files and stuff to text files...  but don't know where to begin:
    I have a directory datalogs...
    within the directory i have multiple text files that have the following format:
    dataXXYYY_Waf2_7_19_11.csv
    dataXXYYY_Waf3_7_19_13.csv
    dataXXYYY_Waf25_7_19_16.csv
    typically 25 files, but sometimes less
    I would like to be able to take each file within the datalogs folder ...
    Scan the file name and look for the number afer Waf
    The number can be anywhere from (single digit) 1 to 25
    I would like to take that value after Waf  and then append a line in the txt file
    the line I would have to add will be 5 rows down and it shoulld say:
    wafer,1 
    the 1 above is the value that was in the file name....
    i.e.
    for the file
    dataXXYYY_Waf25_7_19_16.csv
    before append the file contains random data ... i.e.
    dummyline1
    dummyline2
    dummyline3
    dummyline4
    dummyline5
    dummyline6
    Then after the script...
    the file will be saved with same name:
    dataXXYYY_Waf25_7_19_16.csv
    and the data should look like:
    dummyline1
    dummyline2
    dummyline3
    dummyline4
    wafer,25
    dummyline5
    dummyline6
    any help will be appreciated
    -thanks

    Copy your source folder - named 'datalogs' to your home directory and run this script by copying into a new AppleScript Editor document and pressing Run. 
    I think I've followed your specification, and there will be other ways to do this, but ask if you have questions.  (I have put comments in the code which should explain some of it!)
    There is no error checking, but I have made copies of the original files in the source directory.  (You can comment out the line "duplicate theFile" by prefixing with "--" when you are sure it's working.
    As always, ensure your data is backed-up before proceeding.
    --starts here
    --sets path to datalogs folder
    set theDirectory to (path to home folder as text) & "datalogs"
    set fileNames to {}
    tell application "Finder"
      --gets all the files in the source directory
              set fileList to files of folder theDirectory
      --iterates through the files
              repeat with theFile in fileList
      --makes a duplicate
      duplicate theFile
      --puts the fileName and fileLocation into records in a list of lists
                        set end of fileNames to {fileName:name of theFile, fileLoc:theFile as alias}
              end repeat
      --iterates thru the files
              repeat with theFile in fileNames
      --gets offset of the string "Waf"
                        set WafOffset to offset of "Waf" in (fileName of theFile)
      --trims the name so that it now starts with the character after "Waf"
                        set fileName to text (WafOffset + 3) thru end of fileName of theFile
      --gets offset of the next underscore
                        set UScoreOffset to offset of "_" in fileName
      --stores the desired number by trimming off the end of the file name
                        set fileNumber to text 1 thru (UScoreOffset - 1) of fileName
      --sets up the text to insert by prefixing with "Wafer," and suffixing with return
                        set insertText to "Wafer," & fileNumber & character id 10
      --opens the file with write permission
                        set FileRef to open for access (fileLoc of theFile) with write permission
      --initialise container
                        set fileContents to ""
      --puts first five lines into container
                        repeat 5 times
                                  set fileContents to fileContents & (read FileRef until character id 10)
                        end repeat
      --adds the new text to the container
                        set fileContents to fileContents & insertText
      --adds the rest of the file to the container
                        set fileContents to fileContents & (read FileRef)
      --effectively empties the file
      set eof FileRef to 0
      --writes contents of the container to the file
      write fileContents to FileRef
      --closes the file
      close access FileRef
              end repeat
    end tell
    --ends here

  • New windows 8 laptop gives error 800 when tries to connect to vpn and it is unable to connect to softphone as well.

    Hi,
    I am trying to switch over my work computer from a windows 7 laptop to a new windows 8 laptop so far I have not been able to connect to the VPN on windows 8. The windows 7 connects without an issue and is still connected. The same for my softphone using
    the same settings it connects on windows 7 but says account failed to enable on windows 8. I am only using windows defender as I uninstalled the anti virus software that came pre-installed. 
    Any help on this issue will be greatly appreciated!

    Hi,
    Error 800: Unable to establish the VPN connection. The VPN server may be un-reachable, or security parameters may not be configured properly for this connection.
    Please temporarily disable Windows firewall and Windows defender to check if that helps.
    Regards,
    Kelvin Xu
    TechNet Community Support

  • Using same ip adress for VPN and inside interface

    Hi, I want to know if it's possible on a ASA to use the same IP on the LAN and on the VPN. My user has actually a fixed ip on the LAN and I would like to reuse the same IP when they are connect to the VPN.
    The target is to allowed/restric the same thing when they are on the VPN or on the LAN.
    Thank !

    Hi Francis
    You can provide ips from the same ip block which is being used in the local lan , but its always advisable to provide ips from different block altogether.
    regds

  • I can't use tabbed browsing with my VPN and Intel iMac

    I had no problem using tabbed browsing (with Safari) when connecting to
    my virtual private network (go to my pc), when I used my iMac G5. Now that
    I'm using an 'Intel' iMac, when I tab back to my VPN, it defaults to my log in
    screen. I've checked my Safari settings, and they're all the same as my iMac
    G5. Does anyone have any suggestions?
    Thanks,
    Paul

    It works now...

  • -How to use JDBC to connect the SQLServer and Oracle.

    Hi,
    I create a table in the WIP DB, I want to modify this table when use "PRE-START" activity in POD.
    SAPME version: 5.2.3.4     SDK:2.0    DB:SQL2005 and Oracle 10.2g
    SourceCode like below:
    public void execute(StartHookDTO dto) throws Exception {
              initServices();
              try{
                   Class.forName("com.microsoft.sqlserver.jdbc.SQLServerDriver");
                   Connection conn = DriverManager.getConnection("jdbc:microsoft:sqlserver://127.0.0.1:1433;DatabaseName=SAPMEWIP", "sa" ,"sap12345");
                   conn.close();
              }catch(Exception e){
                   e.printStackTrace();
    Besides, I already setup the JDBC ClassPath in ConfigTool, but it gets somes error when executing.
    the error code like below:
    java.sql.SQLException: No suitable driver
    Please give me some support or a example, thank you so much!
    Br,
    Alex

    You probably want to use the WIP Datasource defined in JNDI.

  • I am in China and the front page of Firefox is partly in Chinese. I use Astrill which is a VPN, and code it from Australia, but still the Mandarin appears. Can you help please?

    <blockquote>Locking duplicate thread.<br>
    Please continue here: [[/questions/845839]]</blockquote>
    I deleted and re downloaded Firefox 5 using my VPN "Astrill" linked "from Australia" but it still happens. Can you assist, as a lot of the downloads I create have Mandarin instructions in them. I can't get adobe Flash 10 to work here in China either, but FF and A10 were both working prior to leaving Australia when I used xp. I had a computer crash and reloaded everything new, including FF and Adobe 10 Flash when I arrived in China. Can you shed any light?

    Thanks jscher2000. That did the trick! I looked everywhere too. The last download I also deleted all previous records of the previous instal. Thanks again!

  • How to use bind_variable for connectivity between Oracle and SQLServer 2005

    The code specified below could be used as an example of how to call a remote SQLServer 2005 procedure from Oracle.
    The problem I am facing is that I am not able to use the dbms_hs_passthrough.bind_variable without exceptions.
    Could someone help me out on this?
    declare
    CREATE PROCEDURE dbo.OrcaMessageTranslator
    @inp nvarchar(255),
    @outp nvarchar(255) output
    AS
    BEGIN
    select @outp = @inp+'output'
    END
    c integer;
    nr integer;
    inp varchar2(255);
    outp varchar2(255);
    sql_stmt varchar2(32767);
    begin
    dbms_output.put_line('call SQLServer procedure OrcaMessageTranslator');
    dbms_output.put_line('value of input variable inp is HowToReplaceThisValueByBindVariable ');
    sql_stmt := 'DECLARE @outp nvarchar(255)
    EXEC dbo.OrcaMessageTranslator
    @inp = N''HowToReplaceThisValueByBindVariable'',
    @outp = @outp OUTPUT
    SELECT @outp as N''@outp''';
    c := dbms_hs_passthrough.open_cursor@pp_preorca;
    dbms_hs_passthrough.parse@pp_preorca(c,sql_stmt);
    nr := dbms_hs_passthrough.fetch_row@pp_preorca(c);
    dbms_hs_passthrough.get_value@pp_preorca(c, 1, outp);
    dbms_hs_passthrough.close_cursor@pp_preorca(c);
    dbms_output.put_line('acquired value of output variable outp is '||outp);
    end;

    Hi,
    BIND_VARIABLE is useful when you have only IN variable but in your case you have IN and OUT.
    I don't know if you use the gateway for MS SQL SERVER or HSODBC/DG4ODBC but here how you can do to call a remote procedure with bind variables:
    DECLARE
    ret integer;
    inp varchar2(255);
    outp varchar2(255);
    BEGIN
    inp :='Hello World';
    outp :='';
    ret := "dbo"."in_out_proc_test"@tg4msql( inp, outp);
    dbms_output.put_line('Input value: ' ||v_ut1||' - Output value: '||v_ut2);
    END;
    The MS SQL Server procedure belongs to the user "dbo" and the database link
    being used is tg4msql.
    The following line initilaize the out variables of the procedure with an
    empty string:
    outp :=''
    I hope it helps you.
    Regards
    Mireille

  • I want to learn how to use the existing stationary in Mail and add my own stationary.

    I use the stationary in my Mail program often.  I would like to learn more about using it, changing it, making my own stationary to use in Mail - and also to allow PC users to receive it.

    Here's a thread that will possibly help:
    https://discussions.apple.com/message/18175872#18175872
    Mail templates use HTML, so those receiving your e-mail should able to view the stationery. It doesn’t matter if they’re on a PC or Mac.

Maybe you are looking for