What the structure of packet?

Hello everyone
   I am developing pci-7344`s driver under RTX.It says in the DDK that
command and data passed to or from the controller is handled in a
packet format. A packet consists of resourceID,commandID,data etc.Now I
know the information of resourceID,commandID,data etc.DDK or the
hardware user manual does not mention how to send them in a packet.
  Moreover The command buffer register is 16-bit.
  I try to send them one by one but it indicates "modal error" in the
csr.Since I have not programmed "error-handling" part of the driver ,so
I do not know what the error codes are.
Hope some advice on how to send the command packet? It is best if there
is an example !!
Thank you!!!

Hi,
I am not sending idoc to XI. I am sending a collective idoc (packet size 2) from an R/3 system to another R/3 system. I am getting only one idoc number in the target structure for 2 idocs and the segments are repeatedly appearing for each idoc. Is this the way it should be or different?
Thanks

Similar Messages

  • What is the field "INFTY" in the structure P0006 used for?

    Hi HR Experts,
    The PSKEY vs PAKEY is the field INFTY. So what is the field INFTY in the structure P0006 used for?
    Thanks!
    Anthony

    The PSKEY is related to teh PSNNNN structure that is associated with the data of a given info type.  the PSKEY holds INFTY for processing info type data genericaly in background programs through generic structures,  IE: pass any info type structure to a FM.  This INFTY field allowed the programs to know which info type structure is being processed unlike the PAKEY which is used to save infotype data in the back end system at the DB level.
    thanks.
    JB

  • What is the name of the structure that is generated ina a recording

    hi
    what is the name of the structure that is generated ina a recording  using transaction recorder.

    Hi,
    to store data use BDCDATA  structure which holds the field name and field values.
    BDCMSGCOLL is the structure which will holds the message numbers after calling the TCode in your BDC program.
    it holds which records error records by msg type E.
    You can find which records are error records while uploading data.
    in call transaction method it will use for error records .
    Reward points if usefull.

  • So what's the difference bewteen "packet data" and...

    just wanna know the difference between "packet data"and "highspeed GSM"while creating new access point in destination section.
    totally confused,any help should be appreciated.

    Essentially nothing.
    Depending on what you have your compiler strictness level set to, you can get it to generate a warning when you use an uninitialized variable.
    In Java, variables are assigned a default value dependent on type. All subclasses of Object are assigned a default type of null, and all primitive number data types are assigned a default value of 0.
    This differs from (for example) C, where variables are simply assigned a location in memory when they are declared, and the value of the variable is whatever was currently in that memory location when allocated. Using uninitialized variables in C is generally a big no-no.
    You'll find a lot of old-school C programmers who migrated to Java will initialize their variables :)
    Btw, this question probably belongs in another forum.

  • What is the structure

    what is the structure for screen how it wil be usefull in report and when

    Hello Naresh,
    Below are the fields of screen.
    NAME
    GROUP1
    GROUP2
    GROUP3
    GROUP4
    REQUIRED
    INPUT
    OUTPUT
    INTENSIFIED
    INVISIBLE
    LENGTH
    ACTIVE
    DISPLAY_3D
    VALUE_HELP
    REQUEST
    VALUES_IN_COMBO
    COLOR
    and some brief description about screen...
    LOOP - Loop on screen fields
    Basic form    LOOP AT SCREEN.
    Effect        All fields of the current screen are stored in the system
                   table SCREEN with their attributes.
                   The LOOP AT SCREEN statement places this information in the
                   header line of the system table.
                   If you want to change the attributes, you must put back the
                   changed header line with MODIFY SCREEN. However, you can only
                   do this in the PBO module of a screen.
                   If you use this statement for step loop processing, the
                   information (and any changes) apply only to the current
                   steploop line. Outside step loop processing, the information
                   for a step loop field applies to the complete column.
                   You can also modify fields in the loop processing of a table
                   control using this loop statement. Unlike a step loop,
                   modifications before the loop have no effect, since the system
                   gets the initial values for the columns from the column table
                   of the table view.
                   Step loop fields should never be changed after the
                   corresponding step loop processing has been performed.
                   You can use the CONTINUE statement to leave the current loop
                   pass prematurely and continue with the next loop pass.
    Reward If Useful
    Sasi.

  • What is the difference between packet-speaker and packet-publisher?

    What is the difference between packet-speaker and packet-publisher in Coherence?

    I believe that both are responsible for sending packets on the network. The packet speaker is used by the packet publisher when the publisher determines that there is a good chance that the send operation will block. By allowing the speaker to handle the potentially blocking send operation the publisher can continue to process outgoing packets.

  • What will be the Structure of itab created with "LIKE TABLE OF sy-ucomm"

    Data fcode like table of sy-ucomm
    The table thus created will have one column but it will not have any structure.
    How can I write a code with this effect:
    LOOP AT fcode.
      WRITE:/ fcode-????.
    ENDLOOP.
    This question is just out of my curiosity I undertsand that by altering the declaration like
    Data begin of fcode occurs 0,
    data ucomm like sy-ucomm,
    end of fcode.
    I will be able to name it. But out of the academic interest I want to know that without altering the decalation part can we do it

    Hello Flora,
    There are two points to be noted here -
    1. the table you have created doesn't have a header line.
    2. The table you have created doesn't have a "structure".
    All internal tables declared with reference to a non-structural type / object have got only one field.
    for example -
    Data ITAB TYPE I OCCURS 0.
    These internal tables have certain limitations. They cannot be displayed in an ALV Grid, for instance.
    And since they do not have a <i>structure</i>, the hypen operator '-' doesn't really make sense. When you say SYST-UCOMM, you are referring to the field UCOMM in the structure SYST.
    Hope that's clear.
    Regards,
    Anand Mandalika.

  • What the difference and use between   of  TABLES and SY-REPID?

    Hi,
    Experts,
    I have came accross 2 cases that i can't able understand
    EX1:
    TABLES: VBAP   -
    >( Here also Appplication Server(AS) creates Wrokarea of Structure VBAP but, by 
    data: v_vbeln like vbap-vbeln.    double clicking on variable v_vbeln AS taking me to DDIC VBAP table VBELN field then what the using declaring tables. )
    ( and ) 
    DATA: VBAP TYPE VBAP -->( Here also Appplication Server(AS) creates Wrokarea of Structure VBAP data: v_vbeln like vbap-vbeln.    but,double clicking on variable v_vbeln AS taking me to user declared VBAP
                                                  i.e., above DATA declaration statement )
    Then Which one is better in Functionality wise as well as Performance wise or when we have to go for TABLES and when we have to go for DATA declaration of DDIC objects.
    EX2:
    what the difference between
    I know that SY_REPID is not a system variable. And also that
    Data: vrepid type SY_REPID.--> Predefined data type in ABAP
    and
    Data: vrepid like SY_REPID.-> Predefined Constatnt in ABAP( it is a constant it allowing with out VALUE                                                                               
    attribute)
    what difference between them and when we have to go Data: vrepid type SY_REPID and when we have to go Data: vrepid like SY_REPID.
    Thank U,
    Shabeer Ahmed.

    Hi Ahmed,
    TABLES:
      VBAP.   " DDIC
    DATA:
      v_vbeln like vbap-vbeln.
    *Here you are using the DDIC VBAP
    DATA:
      VBAP TYPE VBAP.
    DATA:
      vbeln like vbap-vbeln.
    *Here you are using the local data object as your data type so it will always
    * take you to user declared VBAP which is declared by you.
    DATA:
      T_VBAP TYPE VBAP.
    DATA:
      vbeln like vbap-vbeln.
    * here its using T_VBAP not DDIC VBAP
    And for performance always the second option is better, use Data instead of tables, declare your own local structure.
    Data:
      vrepid type SY_REPID.  thereis nop redefined data type in ABAP as SY_REPID
    * its SY-REPID which is a system variable.
    Data:
      vrepid type SY-REPID.
    Also refer to the links:
    Difference between tables statement and by using type statement
    for type and like:
    Re: LIKE and Type in abap statements
    With luck,
    Pritam.

  • The structure of the profit center report in new GL

    Hello,
    I must finish a query for the customer this week. This query must base on a sap standard report for the new GL.
    Because our ECC 6.0 system hasn't the Enhancement Package 3 (contains the necessary new features) yet, so I can't see this standard report which should be displayed under the path:
    SAP Menu --> Accounting --> Financial Accounting --> General Ledger --> Information System --> General Ledger Reports (New) --> Profit Center Reports --> S_E38_98000088 - Profit Center Group: Plan/Actual/Variance
    Can somebody tell me the structure of this report, if you can see this report in your system?
    - Which key figure has been used in the report?
    - What are in the rows and columns?
    - Which characteristics are available to navigation?
    - Which variables and General data selections are there?
    Hope somebody can help me. Thanks a lot!
    Best regards,
    Yuanyuan

    Hi,
    Then my suggesion is you copy the form & report structure  of most suitable report (which you have downloaded through FGIQ) .Modify the form according to your reporting requirement. Create new report by coping standard report & assign this newly created form to this report.This will serve your purpose.
    Please do not make any changes to standard report.Copy it & then do the changes.
    Transaction code for the same is FGI0 or  FGI1 or FGI2 or 3 or 4 or 5 or FGI6.
    Second suggestion is in SPRO in GL information system (infact in each information system ) you will find drilldown report node in that import report transaction e.g. FSIQ .Import all reports you might get your required report.
    Regards,
    Abhijit

  • How to delete the structure created from Tx: EEWB ?

    Hi SAP Guru’s
    I have an issue at hand. I have added three components in the structure <b>BUS000___I</b> and the components are <b>ZZ1, ZZ2, ZZ3</b>, I was following the <b>EEWB</b> wizard and from there these three components were made, now I cannot delete these components directly from <b>SE11</b>. Because after adding these components the system is not allowing me to do so and is asking for the access code.
    I am getting a syntax error in all the tx where <b>Business Partner</b> is used. No old versions for this structure was found in the system. The only structure that has come into this BP structure is <b>ZBSTC0000000000</b> followed by three data elements of this structure.
    I know the <b>Project and the enhancement</b> that was created and I have tried deleting the enhancement from EEWB but when i try deleting it, it always fall into an intermediate stage where it leaves some entries and due to these left over entries these errors are coming.
    Another imp thing is that the structure that i have reported is a newly created one I cannot find this anywhere else. looks like this structure was created after executing the EEWB transaction only.
    Now when I try activating the enhancement again the <b>magic wand button</b> used to activate an enhancement and the <b>generate button</b> is also inactive in EEWB and now it is not getting activated, even after rt click enhancement then clicking change or by clicking on the edit-change button on the top tool bar. Do you think if I create another enhancement this button might get activated?
    Please let me know how do I delete these components.
    Kindly reply at the earliest.
    Regards,
    Amit

    Hi, I had the similar problem (and here the solution):
    Spezifikation: Deletion of EEWB fields manually, error in middleware bdoc,  
    Kurztext 
    Deletion of EEWB fields manually, error in middleware bdoc, 
    Langtext 
    BDOC-Error from function module BAPI_CRM_SAVE. no further using of the
    middleware for sales activities (sales order) possible.
    see steps for reconstruction
    Schritte zur Rekonstruktion 
    what done before:
    - added one field via transaction code EEWB to business object
    SALES_TRANSACTION (Verkaufsvorgang), "Erweiterungstyp CUSTOMER_I
    (Positions-Zusatzextension erweitern) with one existing data element
    type Z_, Geschäftsvorgangstypen = Verkauf
    no selection of "Datenaustausch mit den Mobile Clients",
    "Datenaustausch mit R/3 Supply Chain Execution" or
    "Business Information Warehouse".
    - deleted the extension manually, deleted the eewb project manually
    (successful)
    - got an short dump on saving a sales order via transaction code
    CRMD_ORDER:
    dump type: LOAD_TYPE_VERSION_MISMATCH
    Der Abbruch trat im ABAP-Programm "SAPLCRM_UPLOAD" auf, und zwar in
    "CRM_UPLOAD_BUS_TRANS_MSG". Das Hauptprogramm war "CRM_1O_FRAME ".
    Im Quelltext befindet sich die Abbruchstelle in Zeile 5
    des (Include-)Programms "LCRM_UPLOAD$18".
    (bei Anwahl des Editors: 50) der ABAP-Source "LCRM_UPLOAD$18".
    000040 *********************************************************
    FUNCTION $$UNIT$$ CRM_UPLOAD_BUS_TRANS_MSG
    000060
    000070 IMPORTING
    000080 REFERENCE(IV_GUID) TYPE !CRMT_OBJECT_GUID
    000090 EXPORTING
    000100 REFERENCE(ES_BDOC_HEADER) TYPE !SMW3_FHD
    000110 REFERENCE(ES_BDOC_MESSAGE) TYPE !/1CRMG0/BUS_TRANS_MSG
    000120 REFERENCE(ES_BUS_TRANS_MSG) TYPE !BAD_BUS_TRANSN_MESSAGE
    000130 EXCEPTIONS
    000140 !ERROR_OCCURED .
    - re-generation of a lot of of function modules
    (e.g. CRM_UPLOAD_BUS_TRANS_MSG)
    and some corresponding structures (e.g. CRMT_CUSTOMER_I_COM)
    - fixed the short dumps with this gereration
    Current Errors:
    - the crm middleware (mBdoc) cannot copy sales orders from crm to r/3
    - via transaction code CRMD_ORDER i copy an existing sales order and
    save or try to change just one field and save.
    - saving is succesfull (message type s), but on changing again, the
    order is locked by middleware
    - bdoc in transaction SMW02 is on state yellow "An Empfänger gesendet
    (nicht alle haben bestätigt) BUS_TRANS_MSG"
    - in transaction code SMW02 occurs:
    Mdt Benutzer Funktionsbaustein Queue-Name
    100 CPIC_FILO BAPI_CRM_SAVE R3AD_SAL_ERR
    Datum Zeit
    12.04.2007 17:52:10
    Statustext
    Inkonsistenz zwischen den DDIC-Typen CRMT_CUSTOMER_I_COMT und ABAP-
    genera
    SOLUTION:
    re-generation of *ALL* code which using structure CRMT_CUSTOMER_I_COMT had solved it.

  • Hiding XML elements in the structure view – scripting influence to the structure view?

    Hi
    Is there a way to hide specific XML elements (really the elements and not the attributes) in the structure view?
    I am asking this question to know if it is possible to influence the structure view by scripting.
    Many elements are indeed used as a kind of help for constructions which have nothing to do with the actual contents especially in the case of tables.
    You inflate the the structure view unnecessarily and the author will lose track of the real contents. It would be nice if there was a possibility to hide those help construction elements.
    Thank you for any hints.
    Regards
    Apollo102

    Hello Apollo,
    There is a way to hide elements from the Structure View (one such method is offered by the free AXCM plug-in). What happens when you use AXCM (or other methods to hide elements) is that the elements get wrapped into hidden content. This might make the structure view less complex for your authors, but has a number of disadvantages and dangers.
    1. The structure is normally invalidated, as the helper elements are usually required.
    2. Accidentally deleting hidden content may make the invalidation permanent and render your documents useless.
    It is NOT good practice to hide elements from authors in the structure view. Instead, you should either teach authors about the structure, or let them work in the Author View while adding sufficiently clear formatting to show them the underlying structure. In some cases, it might be better to create an authoring structure which is automatically transformed into the required full structure using an XSLT or other processing step. I have created a couple of such environments and they work fine. It just depends on the difference between the structure required for further processing and the structure that would be optimal for your authors (which in turn depends on the level at which your authors are experienced in working with structured content).
    I hope this helps you solve your problem without having to tweak the structure view.
    Kind regards
    Jang

  • Pages: how can I see the structure of a document?

    Hi, I'm a new user, I just bought my first mac last week.
    I have a problem with Pages. How can I see the structure (organization) of the document I'm working on? I mean headings, headings 2, etc? In Microsoft Word you see it on the left. I don't mean thumbnails, but the construction of the document.
    I know how to mark headings and other parts of a typical document but how can I see the structure afterwards?
    Thanks in advance.

    What you are asking for is Outlining, and that has been removed from Pages 5.2 along with 110 other features.
    Use Pages '09 if you can.
    Peter

  • Error while creating the structure

    hello friends,
    i have two doubts
    1)
    i am getting the error while creating the structure in se11.
    well i am creating the structure in the following way
    in component i am giving the values as bom and in component type i am giving the value as meins.
    i am getting the status warning message as the below
    'field name does not agree with the proposed name base_bom for bapi table'
    2)
    and more over can we create the structure as the follwing in se11.
    component = f1 and
    component type =  tablename-fieldname
    when i am doing in the second way i am getting the error as the following table is not active though the table is active

    hi guru,
    just component name as --- your field name.
    where as component type as give just data element k.
    no need to give tablenme-fieldname k.
    component         component type .
    f1                        matnr----
    data element
    thanks anji.
    Moderator message: please do not use SMS speak, what does that "k" mean, short for "OK"? please get your act together, these are professional forums.
    Edited by: Thomas Zloch on Nov 15, 2010 9:10 AM

  • Error: The decapsulated inner packet doesn't match the negotiated policy in the SA

    I upgraded my ASA from 8.2(1) to 8.4(3) as I wanted to try to get Android devices to properly connect via VPN.
    After some effort, I was able to get the Android devices to connect via VPN.  However, my syslog server has a number of errors recorded that look this this:
    %ASA-4-402116: IPSEC: Received an ESP packet (SPI= 0x1E76EFA6, sequence number= 0x1F0) from x.x.x.x (user= testuser) to y.y.y.y.  The decapsulated inner packet doesn't match the negotiated policy in the SA.  The packet specifies its destination as z.z.z.z, its source as a.a.a.a, and its protocol as tcp.  The SA specifies its local proxy as y.y.y.y/255.255.255.255/udp/42246 and its remote_proxy as x.x.x.x/255.255.255.255/udp/0.
    Digging further, it seems this error might be due to a NAT issues with the VPN connections.  VPN previously worked with Cisco's VPN client on Windows, though I did not test to see if that is no longer working.  However, I made no changes in the config, except for those related to additions needed to support L2TP.  With the below config, Android clients can connect to the ASA and access the internal network, but they cannot connect to external addresses.  I'm at a loss.
    The addresses used in the config: 192.168.1.0/24 are on the internal LAN and 192.168.3.0/24 are addresses assigned to VPN clients.
    I noted in the config this line:
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    The access list is not referenced anywhere, though it was referenced in the 8.2(1) config like this:
    nat (inside) 0 access-list inside_nat0_outbound
    I'm not sure what else changed, but I've looked over the config and I just cannot see what the issue might be.  I'm hoping somebody might be able to point out my error.
    Here's the config file (at least the parts that might be of interest):
    : Saved
    ASA Version 8.4(3)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    boot system disk0:/asa843-k8.bin
    object network obj-192.168.3.0
    subnet 192.168.3.0 255.255.255.0
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    access-list outside_access_in extended permit icmp any interface outside time-exceeded
    access-list outside_access_in extended permit icmp any interface outside echo-reply
    access-list outside_access_in extended permit icmp any interface outside unreachable
    access-list outside_mpc extended permit ip any interface outside
    access-list inside_mpc extended permit ip 192.168.1.0 255.255.255.0 any
    access-list testVPN_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any
    access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
    ip local pool VPN-Pool-1 192.168.3.1-192.168.3.254 mask 255.255.255.0
    ip verify reverse-path interface outside
    nat (inside,any) source static any any destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
    object network obj-192.168.3.0
    nat (outside,outside) dynamic interface
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group outside_access_in in interface outside
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    group-policy testVPN internal
    group-policy testVPN attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value testVPN_splitTunnelAcl
    default-domain value test.us
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    group-policy testVPNns internal
    group-policy testVPNns attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol ikev1
    username testuser password PASSWORD encrypted privilege 15
    username testuser2 password PASSWORD nt-encrypted privilege 15
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group testVPN type remote-access
    tunnel-group testVPN general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPN
    tunnel-group testVPN ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNns type remote-access
    tunnel-group testVPNns general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNns
    tunnel-group testVPNns ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp type remote-access
    tunnel-group testVPNnsl2tp general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group testVPNnsl2tp ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group testVPNnsl2tp ppp-attributes
    authentication ms-chap-v2
    One last question: in order to get the connection from Android to work, I was forced to use "tunnel-group DefaultRAGroup".  Is that actually a limitation, or did I make an error that forced that requirement?  I wanted to use "tunnel-group testVPNnsl2tp".
    Thanks!

    Chris,
    This is still a bit off the mark.  I think I might be confusing the issue by including some of the VPN configuration that I had previously installed and working (e.g., two other VPN tunnel groups with split tunneling on one of them).  Let's just remove that stuff from consideration.  I actually tested the current configs just to see if they are working since the upgrade.  testVPN is working with the split tunneling, but testVPNns (no-split tunneling) does not allow external access.  I guess there is a NAT config issue there, too, but not sure what it is, yet.  I've not investigated that closely.
    I want to solve one problem at a time, though I understand there are some interdependencies.
    What I'd like to focus on right now is just the L2TP VPN connection.
    From what I've been able to understand from the documentation, what I need are these lines:
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    group-policy testVPNnsl2tp internal
    group-policy testVPNnsl2tp attributes
    wins-server value 192.168.1.8
    dns-server value 192.168.1.8 192.168.1.4
    vpn-idle-timeout none
    vpn-tunnel-protocol l2tp-ipsec
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPN-Pool-1
    default-group-policy testVPNnsl2tp
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key P74bmqL6rT40bl5
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    crypto ikev1 policy 5
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    I still want to assign the IP addresses to VPN clients out of 192.168.3.0/24.
    The tricky part is understanding exactly what NAT rules to insert and to avoid that error message I'm getting relatred to the encapsulated packets.  I tried to introduce the commands you had, but it's missing stuff that I would need for L2TP/IPSec (e.g., "mode transport").  I also don't think I want "pfs group5".  The above config "works" in that I get connected -- all negotiation is done.  It's just that packets from the VPN client are not able to go out to the Internet and I'm seeing that encapsulation error messages when I try to send a packet.
    Paul

  • How to find out the structure of storing settings in iTunesPrefs.xml?

    In iTunes settings are stored in the iTunesPrefs.xml! It is used to store base64.. I need to know what to read and write, you have to know the structure of storage options. Someone have an idea how to do it? The first thing that occurred to me, to trace the call stack, and with IDA to disassemble the right given and look for, but it is a very complex way.

    hi,
       Go to transaction ST05,Click activate trace with filter,Give the transactio name as cj31,Go to the transaction and navigate to the place where the particular field is present, then again go to st05 ,Deactivate the trace and display the trace.
    Now u can see how the data is fetched ,U can even go to display mode of the same transaction cj33
    Thanks
    San

Maybe you are looking for

  • Error in Installing From Creative Cloud

    installing from Creative Cloud I get this errors Exit Code: 7 Please see specific errors and warnings below for troubleshooting. For example,  WARNING: DW020 ... -------------------------------------- Summary -------------------------------------- -

  • Satellite Pro L20 - Can't get WLAN to work

    Hi, I'm having problems with my Satellite Pro L20 after a reinstall. The wlan wont work. I installed the correct driver but have had no luck. Any body have the same issue? Any help would be great

  • Camera for final cut pro

    Hi I have about £2000 UK pounds to spend on a video camera for producing footage to be edited in Final Cut pro. What is the best type of camera to get for quality and ease of importing and editing? Not sure between tape and hard disk etc. Thanks

  • Threshold image inside loop

    I am trying to threshold an image inside a while loop so the user can fine tune their threshold values.  The threshold values are being iterated correctly but when the image passes through its 2nd iteration the image goes black or disappears.  Any su

  • Problem while opening data from mysql  in Excel

    Hi friends when i try to download data from MySQL to excel sheet I am getting error of This file is not in a recognizable format. . If you know the file is from another program which is incompatible with Microsoft Office Excel,click Cancel then open