Why is package access higher priviliged than protected?

Hello,
why is the access level of fields and methods on package level higher priviliged than the 'protected' modifier? I am searching for a general answer to this behaviour, because I am writing my master's thesis about this.
How can I give subclasses access to fields without widing the access protection to the other package members? Shouldn't there be another access level 'in between' of default(package-private) and private, that gives access only to subclasses?
Example:
If you want to let a class be extended, than you have to set some fields from private to protected. Now a subclass has access to this field. Let's imagine a 'EvilClass' that wants to change the state of an object. EvilClass has only be to put in the same package and then EvilClass gains imidietly access to protected fields. The reason is, that protected gives access to subclasses AND to classes in the same package.
Thanks for any comment
Greetings, Timo

TimoMeinen wrote:
Thank you for your replies. But I am still not satisfied with this logic.
In C++ the protected keyword has exactly the meaning of "access to subclasses" becauser there is no "compilation unit"-philosophy like the package system in Java. C++ is using friends-classes for this.So what? This is Java and not C++. Classes in the same package are friends.
And yes, you're obviously right to say, that packages are closer than subclasses, but I think there are a lot of examples, where a stricter access level would be fine.No
>
I think of the "Visitor Pattern" for example, which often has to reduce the access level, so that visitors are able to do their job. Or, OR-Mapping Tools, which aren't allowed to use reflections to fill the private fields of entities. A (friend=hibernate) would be nice. ;-)You can populate a private field using reflection, but I would probably use cglib or asm or any other library to create subclasses during loading.
>
Another 'evil'-idea: What about somenone wants to attack me. He is able to gain access to 'my' protected fields, just by define an 'attackclass' in the same package. So, the only possibilty to deny such attacks is by sealing my jars?Is that an attack? Sounds just like something stupid. It would be much easier to replace your class with another one.

Similar Messages

  • Any need to access higher directory than public_html?

    I am setting up a site in Dreamweaver and I have a basic
    question about which directory I should be using.
    I have a remote site and an identical local site.
    In Dreamweaver's site window, is there any reason to need to
    upload any files to the directory above public_html?
    Or should I simply set my remote host directory to
    public_html?
    You see, when I first logged into my FTP, I was able to see
    these following files:
    passwd.cdb
    public_html
    users
    The users folder contained a few other folders called:
    users/info/cur
    users/info/new
    users/info/temp
    Is there any reason for these other higher-level files
    (passwd.cdb and users or any others) to be accessible to
    Dreamweaver from the site window?
    My solution was to simply set the remote host directory to
    public_html but then I cannot see these other higher-level files
    (passwd.cdb and users). I think that is the proper way to set up a
    site but I just need to confirm this with other more experienced
    Dreamweaver users. Is this OK?
    Is it correct to set the remote host directory to
    public_html, thereby not giving yourself access to any files above
    public_html via Dreamweavers site window?
    Or should I leave the remote host directory at the top root
    (where you end up when first log in to FTP) so that I can access
    the passwd.cdb and users files and then mirror this structure on my
    local computer?
    PS I will be sure to mirror the exact directory structure of
    the remote site with my local site.
    I am using Dreamweaver MX 6.1 on a mac. (I am sure not much
    had changed in later versions of Dreamweaver in terms of this
    question)
    Second related question: where is the best place for the
    cgi-bin, databases, php.ini or .htaccess? In public_html or outside
    of public_html? Basically, I am trying to find out if there is any
    need for Dreamweaver to access the folder above public_html. The
    answer to this will help me set up my Dreamweaver site properly
    with the correct, most versatile directory structure.
    Third question: can you put the index.html page in a folder
    or must it always placed directly in public_html?
    Thank you for any advice :)

    Alan, Don't know if you check this, but;
    I am receiving 100s of Error Log Messages through my server
    stats all stating:
    File does not exist:
    /........./............/public_html/...........
    The site in question www.ruusutila.com appears to work
    perfectly on my and other computers.
    On my Remote View the top file is www/ and within that I have
    three folders; _private, cgi-bin and images. There is no reference
    to public_html, I presume there should be but where and what should
    be in it I don't exactly know.
    If I add a folder public_html where should I put it, and do I
    put all my pages in it or only the sites index (home) page? I also
    don't see how to set it as the "host directory", how do I do this?
    Thanks in advance and hoping you are still following this
    thread.
    A Taxed Mind

  • Why are iPhotos previews higher quality than my exports?

    I have just now noticed this after using it for so long. I was using it to de-noise  a photo I took earlier today and turned it up to 100%. I looks clean and smooth like I want, so I exported it first as a jpeg with max quality, but I noticed a lot of noise in it. So I exported it again as an original and it looks the same still. I just exported it as Current to see if there is still noise, and there is. I have exhausted the other formats as well, all export with noise.
    I put iPhoto in fullscreen mode and took a screen cap of the photo via cmd+shift+4, and compared the the screen cap to both of the exports and it looks much cleaner, even though its more than half the resolution being displayed.
    This is not right, plain and simple.
    Here are two links, one to the original export, and the other is a screen cap.
    http://dl.dropbox.com/u/68608/IMG_0006.JPG
    http://dl.dropbox.com/u/68608/Screen%20Shot%202011-08-06%20at%2010.06.48%20PM.pn g
    What am I doing wrong? Are my eyes playing tricks?

    I just came to my local Apple dealer to get help and they have never encountered this before. Questions they asked that made it less clear for them; they were shot in jpeg and I have exported using every setting all yielding the same results.
    This sounds to be a software issue and I encourage Apple's staff to investigate it.

  • Why local class merely be final/abstract/package access?

    The scenario is that while declaring a local class as final/abstract/package access only and why this access specifier is using?
    could anyone plz express the reason for that?
    With Regards,
    Stalin.G

    final String efg = "efg";
    testCallback(new Callback()
    public void execute(String str)
    try
    Thread.sleep(3000);
    } catch (InterruptedException e)
    System.err.println(str+efg);
    System.err.println("finished " + System.currentTimeMillis());
    //...Look at the local variable efg, it must be final, or the code does not compile,, Can anybody explain why efg has to be final?*explained by dcminter and Jardium in [an older thread|http://forums.sun.com/thread.jspa?messageID=10694240#10694240]:*
    >
    ...Final variables are copied into inner classes - that's why they have to be declared final; to avoid the developer making an incorrect assumption that the local variable can be modified and have the change reflected in the copy.
    When a local class uses a local variable, it doesn't actually use the variable. Instead, it takes a copy of the value which is contained in the variable at the moment the class is instantiated. It's like passing the variable to a constructor of the class, except that you do not actually declare any such constructor in your code.
    To avoid messy execution flows to be present in a Java method, the Java language authors thought it was better to allow a single value to be present in such a variable throughout all its life. Thus, the variable has to be declared final.

  • Why is optimizer different in sql than in pl/sql?

    Hello, I am running Oracle database 9i, it is running on an On-Demand hosted server, its purpose is to serve our Oracle Payroll application.
    I have a certain query, and first tried it as a stand-alone query. It displayed the results almost immediatly.
    Then I inserted the exact same query in a pl/sql block. It took more than one hour and canceled it. By looking at the session browser in TOAD, I saw that it was stuck on that query.
    I also saw that the explain-plan for the query changed drastically from running as stand-alone sql to running inside pl/sql.
    Why is this happening? How can I avoid this?
    Please note that I do not intend to use optimizer hint since the indexes are built by oracle On-Demand and not me, so I don't know which indexes exist.
    Here is the explain plan when running from stand-alone SQL:
    Operation Object Name Rows Bytes Cost Object Node In/Out PStart PStop
    SELECT STATEMENT Optimizer Mode=CHOOSE          1           65                     
    bq. SORT AGGREGATE          1      72
    bq. bq. TABLE ACCESS BY INDEX ROWID     HR.PAY_ELEMENT_ENTRY_VALUES_F     1      13      4
    bq. bq. bq. NESTED LOOPS          1      72      65
    bq. bq. bq. bq. MERGE JOIN CARTESIAN          1      59      61
    bq. bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID     HR.PAY_ELEMENT_ENTRY_VALUES_F     1      13      4
    bq. bq. bq. bq. bq. bq. NESTED LOOPS          1      36      33
    bq. bq. bq. bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID     HR.PAY_ELEMENT_ENTRIES_F     1      23      29
    bq. bq. bq. bq. bq. bq. bq. bq. INDEX RANGE SCAN     HR.PAY_ELEMENT_ENTRIES_F_N50     44           3
    bq. bq. bq. bq. bq. bq. bq. INDEX RANGE SCAN     HR.PAY_ELEMENT_ENTRY_VALUES_F_N50     9           3
    bq. bq. bq. bq. bq. BUFFER SORT          1      23      57
    bq. bq. bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID     HR.PAY_ELEMENT_ENTRIES_F     1      23      28
    bq. bq. bq. bq. bq. bq. bq. INDEX RANGE SCAN     HR.PAY_ELEMENT_ENTRIES_F_N50     44           2
    bq. bq. bq. bq. INDEX RANGE SCAN     HR.PAY_ELEMENT_ENTRY_VALUES_F_N50     9           3
    And here is the plan when running inside pl/sql:
    Operation Object Name Rows Bytes Cost Object Node In/Out PStart PStop
    SELECT STATEMENT Optimizer Mode=CHOOSE 1 293463
    bq. SORT AGGREGATE 1 48
    bq. bq. MERGE JOIN CARTESIAN 1 M 56 M 293463
    bq. bq. bq. MERGE JOIN CARTESIAN 78 3 K 3771
    bq. bq. bq. bq. MERGE JOIN CARTESIAN 1 34 57
    bq. bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID HR.PAY_ELEMENT_ENTRIES_F 1 17 29
    bq. bq. bq. bq. bq. bq. INDEX RANGE SCAN HR.PAY_ELEMENT_ENTRIES_F_N50 44 3
    bq. bq. bq. bq. BUFFER SORT 1 17 28
    bq. bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID HR.PAY_ELEMENT_ENTRIES_F 1 17 28
    bq. bq. bq. bq. bq. bq. INDEX RANGE SCAN HR.PAY_ELEMENT_ENTRIES_F_N50 44 2
    bq. bq. bq. BUFFER SORT 15 K 107 K 3743
    bq. bq. bq. bq. TABLE ACCESS BY INDEX ROWID HR.PAY_ELEMENT_ENTRY_VALUES_F 15 K 107 K 3714
    bq. bq. bq. bq. bq. INDEX RANGE SCAN HR.PAY_ELEMENT_ENTRY_VALUES_F_N1 15 K 39
    bq. bq. BUFFER SORT 15 K 107 K 289749
    bq. bq. bq. TABLE ACCESS BY INDEX ROWID HR.PAY_ELEMENT_ENTRY_VALUES_F 15 K 107 K 3714
    bq. bq. bq. bq. INDEX RANGE SCAN HR.PAY_ELEMENT_ENTRY_VALUES_F_N1 15 K 39
    As you can see, the cost goes way up when running inside a pl/sql block.
    Thank you very much for your help.
    Eduardo Schñadower
    Edited by: shinaco on Dec 12, 2008 4:10 PM
    Added indentation. Sorry for that, I didn't realize copy-paste didn't work well here.

    I meant to add,
    Why is optimizer different in sql than in pl/sql? It is not different, it is the same optimizer.
    If you replace bind variables with literals then you have a totally different query, with much more information available to the optimizer. If you are seeing the same statement with the same literal values get a different plan within PL/SQL than in SQL*Plus or TOAD etc then there must be something else different. Unfortunately there is a lot less diagnostic info available in 9i (and I don't have 9i around to test on). Perhaps you can get a 10053 trace from each session and see if you can see what is different.
    btw I still can't read the execution plan. There is more information in the DBMS_XPLAN output, and it needs to be formatted using ** tags or equivalent HTML.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  • Why the flashback log'size smaller than the archived log ?

    hi, all . why the flashback log'size smaller than the archived log ?

    Lonion wrote:
    hi, all . why the flashback log'size smaller than the archived log ?Both are different.
    Flash logs size depends on parameter DB_FLASHBACK_RETENTION_TARGET , how much you want to keep.
    Archive log files is dumped file of Online redo log files, It can be either size of Online redo log file size or less depending on online redo size when switch occurred.
    Some more information:-
    Flashback log files can be created only under the Flash Recovery Area (that must be configured before enabling the Flashback Database functionality). RVWR creates flashback log files into a directory named “FLASHBACK” under FRA. The size of every generated flashback log file is again under Oracle’s control. According to current Oracle environment – during normal database activity flashback log files have size of 8200192 bytes. It is very close value to the current redo log buffer size. The size of a generated flashback log file can differs during shutdown and startup database activities. Flashback log file sizes can differ during high intensive write activity as well.
    Source:- http://dba-blog.blogspot.in/2006/05/flashback-database-feature.html
    Edited by: CKPT on Jun 14, 2012 7:34 PM

  • Uninstall/install 3810/3805 or higher other than 10

    I need to uninstall java 3810 and install 3805 or higher other than 10, if you can help please advise in lay terms to [email protected]

    found this after some browsing. Haven't tried it, so no garantees of course
    "Microsoft Virtual Machine (VM) Removal
    By Kurt Koller, February 12, 2003.
    It would appear that Sun and Microsoft have finally battled out this chapter of the Java saga, resulting in a situation where the Microsoft Virtual Machine will no longer be distributed.
    Microsoft has a whole FAQ for developers, but they leave out one bit of information: how to actually uninstall the VM from your system.
    Removing this is vital for me, because I need to make 100% sure that any migration I've done is correct, and the only way to be 100% sure that we're never using the Microsoft VM is to remove it.
    Sure, we could port some stuff to J#/.NET and we are allowed to redistribute the VM with our products, but we'd rather just say good riddance. So here's how (but don't blame me if you trash something):
    Instructions
    Start -> Run...
    Key in the following and hit return: rundll32 advpack.dll,LaunchINFSection java.inf,UnInstall
    You will then get a prompt to uninstall (a scary one telling you that IE will no longer be able to download files, which is bogus), choose yes, and then when finished it will want to reboot. Let it.
    To remove the residual traces you may have of the Microsoft VM, remove the following (where %WINDOWS% is your system directory, usually C:\WINDOWS\ or C:\WINNT\ depending on OS:
    * %WINDOWS%\java (entire folder)
    * %WINDOWS%\inf\java.inf (may have been deleted by uninstall)
    * %WINDOWS%\inf\java.pnf (may have been deleted by uninstall)
    * Search your system drive for "javavm.dll" and remove it (may have been deleted by uninstall)
    That's it. Then go install the VM of your choice.
    If you have problems with IE continually telling you that you need to install a VM even if you already have one installed, turn off the option "Install on Demand (Other)" in Tools -> Internet Options... -> Advanced.
    "

  • Why is outer join more expensive than inner joins.

    Why is outer join more expensive than inner joins.
    Other than it may return more rows.
    If you know of any ORA docs on this, please let me know.
    Thanks.

    Outer join is inner join with outer union applied on top of it. As you correctly observed it returns more rows and that alone makes it more expensive. Secondly, outer join is not commutative. As a result some join permutations are exclused from consideration, which results in higher cost.

  • Give LAN higher priority than wireless / deactivate wireless if LAN is connected

    Hi.
    What I want to do is quite simple: Im my office there is a quite fast LAN connection and a rather poor wireless connection. Therefore, I want to tell my device: "If there is a LAN cable plugged in, just use LAN. Do not use Wifi in this case. If there is no LAN cable plugged in, try to connect to Wifi."
    It is really annoying to change that manually each time.
    I have already changed the network connection priority in Windows 7 as described here: http://support.microsoft.com/kb/2526067
    But to no avail.
    My notebook is E531.
    Wifi Device: Intel Centrino Wireless-N 2230
    Driver Date 30.09.2012
    Driver Version 15.3.1.2
    Solved!
    Go to Solution.

    Hi cis,
    do you by any chance have Access Connections installed on your system?  It is possible that the WLAN adapter is set to a higher priority than LAN in your location profile which is causing the behaviour.  If you don't have AC installed it may be a possible solution you could try. 
    Link to another thread on this subject;
    http://forums.lenovo.com/t5/ThinkVantage-Technologies/Access-Connections-disable-WiFi-on-Wired-Conne...
    Andy  ______________________________________
    Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points
    Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos Please add your type, model number and OS to your signature, it helps to help you. Forum Search Option T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more. FYI Unsolicited Personal Messages will be ignored.
      Deutsche Community     Comunidad en Español    English Community Русскоязычное Сообщество
    PepperonI blog 

  • Why can't I download more than 50mb in iPhone ??

    Why can't I download more than 50mb in iPhone ??

    Deggie is correct. The carriers originally wanted it so people wouldnt be downloading large files on their networks and causing congestion. Also look at is from a carrier perspective for protecting costumers. People could also complain if they went over their data plan that they should have received a warning about downloading large files. Rather than argue about updating/downloading apps, they have the warning now.
    I am hoping down the road that carriers converse with Apple to lift those, we will see what happens. Rodgers has more influence on lifting that limit that normal costumers would.

  • Package access helper in htc

    package access helper is draining my batter in HTC for second time...magically fixed itself after 3 weeks of draining battery in 3 hours.  now doing it again.  nobody seems to know how to fix it...verizon store and htc clueless.  any thoughts?  (yes popped battery out, yes did factory reset, yes bought new battery...none of these are the issue)

        eric97229,
    I definitely understand you need your batter to last longer than what it is right now, let's work on this! Use http://vz.to/1pGkBsA to determine if it's working as it should. Was the factory reset performed without Automatic Restore, meaning your phone is as new(content-wise)?
    AdaS_VZW
    Follow us on Twitter at @VZWSupport 

  • Accessing Intranet Web application (protected by  Agent)  through Gateway

    Hi All,
    I have installed Sun Portal Server in one machine and SRAGateway on different machine and also I have an intranet Web Application server(not accessable through internet), is protected by Access Manager Policy Agent.
    I am just displaying this web application Url in a portal desktop . So when user access the Gateway (https://host.com) , after successful authentication he can able to see the portal desktop with web application url. After clicking this url he can enter in to the Web Application.
    I am able to enter into the portal desktop , but when I click the web application url its giving the following error" (https://gatwayhost.domain.com/http://websver.domain.com)
    "Unable to connect to the host, Contact Administrator
    Please help me to solve this.
    Thanks in Advance

    We use a reverse proxy because we had specific requirements. It's more complex than just using the rewriter proxy and maybe not the best solution for you.
    The setup is quite simple, you install an apache server (with mod_proxy module) , you install the access manager agent on top of apache and you set the httpd.conf to tell the apache to act as a reverse proxy.
    You tell the gateway to use the reverse proxy instead of the real site. In our case we simply add a line poiting to the reverse proxy for the server name in the /etc/hosts file.
    You open the http port 80 in your firewall from the gateway to the apache reverse proxy and from the apache to the intranet website.
    And it's done.

  • Why i cant access asa 8.4 thruogh asdm from outside interface ???

    hi all ,
    plz help e why i cant access asa asdm from outside interface
    my puclic ip on outisde is :
    x.x.55.34
    i changed  portf of asdm to 65000 because i have portforward  ,
    i tried to connect to my ip thriuogh asdm bu :
    x.x.55.34
    x.x.55.34:65000
    but no luck ,
    it succed if i try to connect locally
    here is my sh run command :
    ====================================================
    ASA5505#
    ASA5505# sh run
    : Saved
    ASA Version 8.4(2)
    hostname ASA5505
    enable password qsddsEGCCSH encrypted
    passwd 2KFsdsdbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 2
    interface Vlan1
    nameif ins
    security-level 100
    ip address 10.66.12.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 50
    ip address x.x.55.34 255.255.255.248
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network obj-0.0.0.0
    host 0.0.0.0
    object network localsubnet
    subnet 10.66.12.0 255.255.255.0
    description localsubnet
    object network HTTP-Host
    host 10.66.12.249
    description web server
    object network HTTPS-HOST
    host 10.66.12.249
    description Https
    object network RDP-Host
    host 10.66.12.122
    description RDP host
    object network citrix-host
    host 10.66.12.249
    description citrix
    object service rdp
    service tcp destination eq 3389
    object service https
    service tcp destination eq https
    object service citrix
    service tcp destination eq 2598
    object service http
    service tcp destination eq www
    object network RDP1
    host 10.66.12.249
    object network HTTPS-Host
    host 10.66.12.249
    object network CITRIX-Host
    host 10.66.12.249
    object-group network RDP-REDIRECT
    object-group network HTTP-REDIRECT
    object-group network HTTPS-REDIRECT
    object-group network CITRIX-ICA-HDX-REDIRECTION
    object-group network CITRIX-ICA-SESSION-RELIABILITY-REDIRECTION
    object-group service CITRIX-ICA-HDX
    object-group service CITRIX-SR
    object-group service RDP
    object-group network MY-insideNET
    network-object 10.66.12.0 255.255.255.0
    access-list outside_in extended permit tcp any host 10.66.12.249 eq www
    access-list outside_in extended permit tcp any host 10.66.12.249 eq https
    access-list outside_in extended permit tcp any host 10.66.12.249 eq 2598
    access-list outside_in extended permit tcp any host 10.66.12.122 eq 3389
    access-list outside_in extended permit tcp any host 10.66.12.249 eq citrix-ica
    access-list outside_in extended permit tcp any host x.x.55.34 eq 65000
    access-list outside_in extended permit tcp any host x.x.55.34 eq https
    access-list outside_in extended permit ip any any
    pager lines 24
    mtu ins 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    object network localsubnet
    nat (ins,outside) dynamic interface
    object network HTTP-Host
    nat (ins,outside) static interface service tcp www www
    object network RDP-Host
    nat (ins,outside) static interface service tcp 3389 3389
    object network HTTPS-Host
    nat (ins,outside) static interface service tcp https https
    object network CITRIX-Host
    nat (ins,outside) static interface service tcp citrix-ica citrix-ica
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 62.109.55.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable 65000
    http 10.66.12.0 255.255.255.0 ins
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
        308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
        0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
        30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
        13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
        0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
        20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
        65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
        65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
        30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
        30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
        496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
        74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
        68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
        3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
        63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
        0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
        a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
        9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
        7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
        15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
        63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
        18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
        4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
        81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
        db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
        7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
        ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
        45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
        2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
        1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
        03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
        69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
        02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
        6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
        c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
        69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
        1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
        551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
        1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
        2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
        4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
        b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
        6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
        481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
        b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
        5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
        6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
        6c2527b9 deb78458 c61f381e a4c4cb66
      quit
    telnet 0.0.0.0 0.0.0.0 outside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access outside
    dhcpd address 10.66.12.160-10.66.12.180 ins
    dhcpd dns 212.112.166.22 212.112.166.18 interface ins
    dhcpd enable ins
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username test password P4ttSdddd3SV8TYp encrypted privilege 15
    username ADMIN password 5dddd3ThngqY encrypted privilege 15
    username drvirus password p03BtCddddryePSDf encrypted privilege 15
    username cisco password edssdsdOAQcNEL encrypted privilege 15
    prompt hostname context
    call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DD
    CEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
    : end

    For access over VPN you need:
    management-access inside
    and don't forget:
    ssh inside
    http inside
    I'm guessing you forgot to grant ASDM (http/https) access to the IP addresses used by the VPN?  Can you SSH?  If not, that is your problem to solve first.

  • Why is Motion so much quicker than FCP doing Steady Cam?

    Being a helicopter operator I keep doing projects that require steady cam.
    I used to use Shake, then Motion, and now FCP with the additon of steadycam but I am wondering why Motion is so much quicker than FCP with the same clip.
    Maybe a dumb question but one I need to ask.

    running the same filter in both fcp and motion, motion always renders faster.
    This is because motion renders and draws all frames directly on your graphics card. FCP now uses the GPU for many effects but has to read back from your card to main memory.
    Unless Apple does a total rewrite of FCP this is unlikely to change, guess you either have to keep swapping apps or put up with longer renders in FCP.
    Roger
    CoreMelt

  • Why can't TextEdit open more than 5 links at a time in Yosemite?

    Why can't TextEdit open more than 5 links at a time in Yosemite? In the previous OS, I could highlight many links at a time, right click and then select "Open URL" to open the links in Safari. Now, if I select more than five links at a time (and sometimes with five links) it will only open the first five and TextEdit pops up with the alert, "The 'Open URL' service could not be used."
    I'm running 10.10.1 on a MacBook Pro (13-inch, Mid 2009), 2.53 GHz Intel Core 2 Duo, 4 GB 1067 MHz DDR3, 500 GB HD.
    TextEdit is Version 1.10 (319).

    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.
    Feedback

Maybe you are looking for

  • CFPOP and digital signatures

    Emails - Exchange 2003 mail server - that use "Digital signatures" do not show any Body text. Either in the "BODY" or in the "TEXTBODY" fields. Are there any work arounds or fixes for this? Thanks,

  • My site is gone apparently - WWYD?

    I posted below that when I upgraded iPhoto it for some reason corrupted my entire iWeb site. I lost my templates, texts, photos. Support did a DataCapture and they're trying to figure out what happened and trying to retrieve data from my Domain file,

  • Broadband username-non recognition

    I have my e-mail from BT.com giving me my  BT Total Broadband username.  My hub and e-mail has been  connected and working for nearly two years. However when I try to log in to MyBT or anything to do with my Broadfband package I simply get the messag

  • Materail Master - MRP view 4

    Dear experts, pls explain MRP view 4 - Follow-up matl field? what use? how to use? Regards, Sankaran

  • Budget allocation, Urgently needed

    Hai 2 All, my client have 3 branches in X,Y,Z places but he is doing all the transactions like invoices, salaries, expenses and so on from Branch X for other branches also and he wants to maintaines only one COA and book all expenses and revenues for