Wred based on MPLS exp bits on 12000

I want to use WRED with MQC on 12000 but there is no mpls/exp-bits statment on the "random-detect" command.
I found this note at cisco documentation:
Note: The legacy CLI also uses the precedence syntax for Multiprotocol Label Switching (MPLS) traffic. The router treats the MPLS bits as though they are IP Type of Service (ToS) bits and puts the appropriate packets into the correct queues. This is not at all true for MQC.
so, is there a way to use WRED with MPLS EXP-bits on MQC?

Hi,
As fas as I know the solution is as follows:
1. Use MQC on the inbound interface of your P/PE LSR to match your desired traffic and set discard-class
2. Use MQC on the outbound interface of your P/PE
LSR to set desired WRED policy based on discard-class you marked in previous step. You also need to mark WRED as "discard-class-based"
Here is an example:
Inbound:
class-map class1
match XXXXX
class-map class2
match YYYYY
policy-map in-policy
class class1
set discard-class 0
class class2
set discard-class 1
Outbound:
policy-map out-policy
class class-default
random-detect discard-class-based
random-detect discard-class 0 10 20 5
random-detect discard-class 1 20 30 5
Hope that helped.
David

Similar Messages

  • MPLS EXP-BIT

    class-map X
    match ip dscp af41
    policy whatever
    class-map X
    police 312000 24000 48000 conform-action set-mpls-exp-transmit 6 exceed-action set-mpls-exp-transmit 2
    Question:
    does the "set-mpls-exp-transmit" remark or encapsulate this AF41 to MPLS-EXP 6? My objective here is maintain "transparency" of the DSCP marking that is coming, meaning I would like this AF41 marking to remain untouched across my mpls backbone. My research tells me to do that I need to use set-mpls-exp with the "topmost" keyword which will give me DSCP Tunneling.
    Can you guys clarify that for me? Am i reading this thing right?

    Hi,
    setting the MPLS exp bits does leave the IP DSCP bits untouched. The default behaviour by the way is to copy precedence to MPLS exp bits anyhow. With the policer you can remark in your MPLS network according to the SLA negotiated.
    On some platforms you might have to use for example
    policy-map CustomerIn
    class business
    police cir percent 25
    conform-action set-mpls-exp-imposition-transmit 4
    exceed-action set-mpls-exp-imposition-transmit 0
    violate-action set-mpls-exp-imposition-transmit 0
    Be aware that on the output from PE to CE you will have IP packets again. The exp bits are not copied to IP precedence by default. So either you use DSCP in the output policy on the PE with the customer values.
    The other option is to map exp bits to a qos group and use this for the output policy. The advantage of the latter approach is that you do have consistent qos policies on a PE not refering to (different) customer markings.
    Hope this helps
    Martin

  • MPLS EXP BITS, PHB Router, forwarding treatement

    Hi every body
    I hope you guys are doing great. Reading this great book " MPLS fundamentals"   , got some question for you guys.
    Let say R1 Is PHP router , it will pop  incoming label 234 before sending the plain ip packet to R2
      ---cloud---R1------R2---IP world
    1) A mpls labelled packet ( labelled 234)arrives on R1 from MPLS cloud, what will R1 do next as far QOS forwarding of packet is concerened?
    As R1 is PHB, it is supposed to POP label 234, will R1 do QOS forwarding ( scheduling, queing ) first based on EXP bits in label 234 and then POP label 234 ?  Please keep in mind we are not using any qos group, i am just exploring default behavior.
    Thanks and have a great weekend

    Hello Sarah,
    By Defaut, NO the PHP router in this Case R1 doesnt perform any QoS sheduling or Queing on label 234.
    Once R1 recieves Label 234, it performs the POP operation before it applies QoS queing on label 234.
    Regards,
    Mohamed

  • TE with MPLA exp bit set

    Hello
    I have a multilink bundle which will be the path used for my primary tunnel. I need to set mpls exp bit for qos (bandwidth reservation for specific traffic class)
    Now iam applying my service policy applied on the multilink interface.
    If enable my tunnel with explicit path configured as the ips of Multilink interfaces where should my service policy go either on the tunnel interface or Multilink interface.
    Futher when my primary tunnel fails i have another path configured as next path option either explicit or dynamic. Can i have the same qos on the other path also if enable the service policy on the tunnel interface.
    REgards
    Parthiban

    The following documents have more information on marking packets in QoS.
    http://www.cisco.com/warp/public/105/dscpvalues.html
    http://www.cisco.com/en/US/products/sw/iosswrel/ps5014/products_feature_guide_chapter09186a00800ca4f0.html

  • EXP bits with Label Stacking

    In 12.0S, with ATOM or L3VPNs and label stacking which label's EXP bits are set using 'set mpls experimental' or using rate-limits? All labels in the stack?
    I see the newer 'set mpls experimental' commands in 12.2 and 12.3 that can control which label's EXP bits are set; topmost, etc. However, I need 12.0S for any-to-any ATOM.
    Thanks.

    This command will set the EXP bits on all labels at label imposition. The IP Precedence bits will not be affected.
    Hope this helps,

  • COS to EXP bits mapping

    Hi Guys,
    theoretically and practicaly the DSCP or IP prec values are copied to EXP bits of shim header.
    Does that same applies to when Atom is configured ?? because in Atom the PE receives traffic from CE and that could be vlan tagged. PE imposes the MPLS tag received from egree PE and then imposes the tunnel tag and send it to the egress PE.
    are the COS values copied to the appropriate EXP bits at this time ??

    Thanks for the reply.
    What is the command to see the cos-dscp mapping from a GSR 10k router, there is no mls qos command?
    Here are the config:
    Hub CE:
    njli2pece1#sh run int gi3/24
    interface GigabitEthernet3/24
    no ip address
    load-interval 30
    wrr-queue bandwidth percent 30 20 50
    wrr-queue queue-limit 40 30 15
    wrr-queue random-detect min-threshold 1 60 80 100 100 100 100 100 100
    wrr-queue random-detect min-threshold 2 60 80 99 99 100 100 100 100
    wrr-queue random-detect min-threshold 3 99 100 100 100 100 100 100 100
    wrr-queue random-detect max-threshold 1 80 100 100 100 100 100 100 100
    wrr-queue random-detect max-threshold 2 80 100 100 100 100 100 100 100
    wrr-queue cos-map 2 3 6
    wrr-queue cos-map 2 4 7
    wrr-queue cos-map 3 1 3
    wrr-queue cos-map 3 2 4
    mls qos trust dscp
    no cdp enable
    end
    njli2pece1#sh run int gi3/24.112
    interface GigabitEthernet3/24.112
    encapsulation dot1Q 112
    ip vrf forwarding r1-aiggs
    ip address 68.139.194.194 255.255.255.252
    ip flow ingress
    ip flow egress
    no cdp enable
    end
    Hub PE:
    worge01>show config | b GigabitEthernet4/1.49659
    interface GigabitEthernet4/1.49659
    encapsulation dot1Q 112
    ip vrf forwarding V127453:AmericanInternational
    ip address 68.139.194.193 255.255.255.252
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip directed-broadcast
    no ip proxy-arp
    ip mtu 1500
    plim qos input map cos 5 queue low-latency
    service-policy input DSCP_CE-PE_ETM_G=5008K_R=300M
    service-policy output DSCP_PE-CE_282000K_gsr_6Q !
    worge01>show policy-map DSCP_CE-PE_ETM_G=5008K_R=300M
    Policy Map DSCP_CE-PE_ETM_G=5008K_R=300M
    Class class-default
    police cir 300000000 bc 37500000 be 37500000
    conform-action transmit
    exceed-action drop
    service-policy DSCP_CE-PE_ETM_G=5008000_gsr
    worge01>show policy-map DSCP_CE-PE_ETM_G=5008000_gsr
    Policy Map DSCP_CE-PE_ETM_G=5008000_gsr
    Class dscp_EF_ipprec_5_5Qs
    police cir 5008000 bc 626000 be 1252000
    conform-action set-mpls-exp-imposition-transmit 5
    exceed-action drop
    Class dscp_AF4x_ipprec_4_5Qs
    set mpls experimental 4
    Class dscp_AF3x_ipprec_3_6_7_5Qs
    set mpls experimental 3
    Class dscp_AF2x_ipprec_2_5Qs
    set mpls experimental 2
    Class ip_best_effort_BE
    set mpls experimental 0
    worge01>sh config | b dscp_EF_ipprec_5_5Qs
    class-map match-any dscp_EF_ipprec_5_5Qs
    match ip dscp 40 46
    Remote CE:
    mdhv113ce1#sh run int s0/0/0:0
    interface Serial0/0/0:0
    no ip address
    encapsulation frame-relay IETF
    load-interval 30
    service-policy input Verify-Dscp
    service-policy output TypeB-Remote-QOS-Out
    end
    mdhv113ce1#sh run int s0/0/0:0.100
    interface Serial0/0/0:0.100 point-to-point
    ip address 159.24.187.178 255.255.255.252
    ip flow ingress
    ip flow egress
    snmp trap link-status
    frame-relay interface-dlci 100 IETF
    end
    Remote PE:
    ptnes05>show config | b Serial8/0/2.1/28:1.20505
    interface Serial8/0/2.1/28:1.20505 point-to-point
    ip vrf forwarding V128431:AmericanInternational
    ip address 159.24.187.177 255.255.255.252
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    frame-relay interface-dlci 100
    service-policy input DSCP_CE-PE_ETM_G=448000
    service-policy output DSCP_PE-CE_1536K_6Q
    ptnes05>show policy-map DSCP_PE-CE_1536K_6Q
    Policy Map DSCP_PE-CE_1536K_6Q
    Class class-default
    shape 1536
    service-policy DSCP_PE-CE_1344000_to_120M_6Q
    ptnes05>show policy-map DSCP_PE-CE_1344000_to_120M_6Q
    Policy Map DSCP_PE-CE_1344000_to_120M_6Q
    Class dscp_EF_ipprec_5_5Qs
    priority
    police percent 50 25 ms 0 ms conform-action transmit exceed-action transmit violate-action drop
    ptnes05>sh config | b dscp_EF_ipprec_5_5Qs
    class-map match-any dscp_EF_ipprec_5_5Qs
    match ip dscp cs5 ef

  • Why I can't set exp bit ?

    policy-map match
    class exp_0
    class exp_1
    class exp_2
    class exp_3
    class exp_4
    class exp_5
    class exp_6
    class exp_7
    class-map match-all exp_2
    match mpls experimental topmost 2
    class-map match-all exp_3
    match mpls experimental topmost 3
    class-map match-all exp_0
    match mpls experimental topmost 0
    class-map match-all exp_1
    match mpls experimental topmost 1
    class-map match-all exp_6
    match mpls experimental topmost 6
    class-map match-all exp_7
    match mpls experimental topmost 7
    class-map match-all exp_4
    match mpls experimental topmost 4
    class-map match-all exp_5
    match mpls experimental topmost 5
    policy-map L3VPN_multigold_in_100m
    class class-default
      police cir 100000000 conform-action transmit exceed-action drop
      service-policy L3VPN_mutigold_in_Child
    policy-map L3VPN_mutigold_in_Child
    class realtime
      police rate percent 50 conform-action set-mpls-exp-imposition-transmit 4 exceed-action drop
    class business_data
      police rate percent 25 conform-action set-mpls-exp-imposition-transmit 4 exceed-action drop
    class class-default
      police rate percent 25 conform-action set-mpls-exp-imposition-transmit 4 exceed-action transmit
    class-map match-any realtime
    match dscp ef
    match dscp cs5
    match dscp cs6
    match dscp cs7
    match dscp af41
    class-map match-any business_data
    match dscp af31
    match dscp cs3
    match dscp cs2
    match dscp af21
    interface TenGigabitEthernet2/1
    ip arp inspection limit none
    no ip address
    load-interval 30
    service-policy input L3VPN_multigold_in_100m
    service instance 10 ethernet
      encapsulation dot1q 10
      rewrite ingress tag pop 1 symmetric
      bridge-domain 10
    interface Vlan10
    ip vrf forwarding l3vpn-mqos
    ip address 192.168.1.1 255.255.255.0
    interface TenGigabitEthernet2/2
    mtu 9000
    ip address 192.168.11.2 255.255.255.0
    ip router isis
    load-interval 30
    mpls ip
    mpls traffic-eng tunnels
    clns mtu 1497
    isis circuit-type level-2-only
    isis network point-to-point
    isis metric 100 level-2
    service-policy output match
    ip rsvp bandwidth 1410066
    pe1#sho policy-map int | inc Ten|Cla|pac
    TenGigabitEthernet2/1
    Class-map: class-default (match-any)
      2465961 packets, 2579395206 bytes
      conformed 1264280 packets, 1322436880 bytes; actions:
      exceeded 300382 packets, 314199572 bytes; actions:
    Class-map: realtime (match-any)
      1232980 packets, 1289697080 bytes
      conformed 632139 packets, 661217394 bytes; actions:
      exceeded 600767 packets, 628402282 bytes; actions:
    Class-map: business_data (match-any)
      616491 packets, 644849586 bytes
      conformed 316070 packets, 330609220 bytes; actions:
      exceeded 300384 packets, 314201664 bytes; actions:
    Class-map: class-default (match-any)
      616490 packets, 644848540 bytes
      conformed 316069 packets, 330608174 bytes; actions:
      exceeded 300384 packets, 314201664 bytes; actions:
    TenGigabitEthernet2/2
    Class-map: exp_0 (match-all)
      471098 packets, 494652900 bytes
    Class-map: exp_1 (match-all)
      0 packets, 0 bytes
    Class-map: exp_2 (match-all)
      245559 packets, 257836950 bytes
    Class-map: exp_3 (match-all)
      0 packets, 0 bytes
    Class-map: exp_4 (match-all)
      0 packets, 0 bytes
    Class-map: exp_5 (match-all)
      554263 packets, 581976150 bytes
    Class-map: exp_6 (match-all)
      0 packets, 0 bytes
    Class-map: exp_7 (match-all)
      0 packets, 0 bytes
    Class-map: class-default (match-any)
      0 packets, 0 bytes
    SW: (c7600rsp72043_rp-ADVIPSERVICESK9-M), Version 15.3(1)S
    HW: 76-ES+XT-2TG3CXL
    Thank you very much.

    Now I changed to:
    policy-map L3VPN_mutigold_in_Child
    class realtime
      police rate percent 50 conform-action set-mpls-exp-topmost-transmit 4 exceed-action drop
    class business_data
      police rate percent 25 conform-action set-mpls-exp-imposition-transmit 4 exceed-action drop
    class class-default
      police rate percent 25 conform-action set-mpls-exp-imposition-transmit 4 exceed-action transmit
    Its not changed.
    pe1# pe1#sho policy-map int | inc Cla|pac
        Class-map: class-default (match-any) 
          11721193 packets, 12002501632 bytes
            conformed 6001573 packets, 6145610752 bytes; actions:
            exceeded 0 packets, 0 bytes; actions:
            Class-map: realtime (match-any) 
              11721193 packets, 12002501632 bytes
                conformed 6001573 packets, 6145610752 bytes; actions:
                exceeded 5719822 packets, 5857097728 bytes; actions:
            Class-map: business_data (match-any) 
              0 packets, 0 bytes
                conformed 0 packets, 0 bytes; actions:
                exceeded 0 packets, 0 bytes; actions:
            Class-map: class-default (match-any) 
              0 packets, 0 bytes
                conformed 0 packets, 0 bytes; actions:
                exceeded 0 packets, 0 bytes; actions:
        Class-map: exp_0 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_1 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_2 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_3 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_4 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_5 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_6 (match-all) 
          0 packets, 0 bytes
        Class-map: exp_7 (match-all) 
          0 packets, 0 bytes
        Class-map: class-default (match-any) 
          0 packets, 0 bytes
    Thank you very much.

  • MPLS , DF bit set

    Hi everybody
    According to my book, if an LSR can not fragment the labelled packet because of DF bit, following will occur:
      Only if the IP header has the Don’t Fragment (DF) bit set does the LSR not fragment the IP packet, but it drops the packet and returns an ICMP error message “Fragmentation needed and do not fragment bit set” (ICMP type 3, code 4) to the originator of the IP packet. As with the ICMP message “time exceeded” (type 11, code 0), which is sent when the TTL expires of a labeled packet, the “Fragmentation needed and do not fragment bit set” ICMP message is sent, using a label stack that is the outgoing label stack for the packet that caused the ICMP message to be created. This means that the ICMP message travels further down the LSP until it reaches the egress LSR of that LSP. Then it is returned to the originator of the packet with the DF bit set.
    However, when i put this claim  to test, i do not see that behavior.
    R5---R1 f0/1-----R2----R3---R4
    Above R1 f0/1  mpls mtu 1400
    On R5, i generated a ping of 1500 , DF bit set.   R1 should send ICMP error towards R4 which then send it to R5.
    R5#debug ip icmp
    ICMP packet debugging is on
    R5#ping
    Protocol [ip]:
    Target IP address: 4.4.4.4
    Repeat count [5]:
    Datagram size [100]: 1500
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface:
    Type of service [0]:
    Set DF bit in IP header? [no]: y
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 1500-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
    Packet sent with the DF bit set
    Success rate is 0 percent (0/5)
    I do not see such ICMP errors message being received. Wireshark capture between R1--R2, does not show that any ICMP error message from R1 either. 
    I suspect the packets with DF bit are silently discarded by LSR ( R1). If this is true, then my book is pretty wrong. 
    thanks

    Thanks Nagendra
    R4#show version
    Cisco IOS Software, 2600 Software (C2691-ADVIPSERVICESK9-M), Version 12.4(15)T6, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Mon 07-Jul-08 04:30 by prod_rel_team
    ROM: ROMMON Emulation Microcode
    ROM: 2600 Software (C2691-ADVIPSERVICESK9-M), Version 12.4(15)T6, RELEASE SOFTWARE (fc2)
    R4 uptime is 46 minutes
    System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
    System image file is "tftp://255.255.255.255/unknown"

  • MPLS TE on Cisco 12000 POS-Channel interface

    I get an error when I want to configure mpls te over POS channels on Cisco 12000 routers. Is it something that can be resolved by changing IOS or it is not supported at all?

    Check if you have configured "Hello" for the FRR properly for POS. Following links may help you
    http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/fslnph30.html#wp1055478
    http://www.cisco.com/en/US/tech/tk436/tk428/technologies_white_paper09186a00800a4472.shtml

  • Oracle sql to outer join based on reg exp

    Hi,
    I am expecting output like (3). I want to join two tables with regex. join condition
    . For example, in table1.string(abcYYMMDD.txt) I want to match date part (YYMMDD) wit any possible number in Table2.string (abc150420.txt)
    Please suggest.
    (1) table1:
    abcYYMMDD.txt
    ddefYYMMDD.txt
    ghiYYMMDD.txt
    (2) table2:
    abc150420.txt
    abc150421.txt
    abc150422.txt
    abc150320.txt
    ddef150101.txt
    ddef150404.txt
    (3) Table1 left join Table2 (join example - abc(replace YYMMDD by regex).txt=abc150420.txt)
    abcYYMMDD.txt,abc150420.txt
    abcYYMMDD.txt,abc150421.txt
    abcYYMMDD.txt,abc150422.txt
    abcYYMMDD.txt,abc150320.txt
    ddefYYMMDD.txt,ddef150101.txt
    ddefYYMMDD.txt,ddef150404.txt
    ghiYYMMDD.txt,

    The audittime field is a timestamp field.
    If I give the below query, rownum is not in the sequential order, see below few records..
    SELECT rownum,to_char(audit_time_stamp,'dd-mon-yyyy HH24:MI:SS.FF') from audit_details ORDER BY audit_time_stamp
    ROWNUM     to_char(audit_time_stamp,'dd-mon-yyyy HH24:MI:SS.FF')
    16     18-apr-2007 14:30:52.551010
    17     18-apr-2007 16:33:21.900305
    18     18-apr-2007 17:49:44.061420
    19     18-apr-2007 17:49:44.134804
    20     19-apr-2007 16:40:15.775235
    21     22-apr-2007 23:31:01.818784
    ROWNUM     To_char(audit_time_stamp,'dd-mon-yyyy HH24:MI:SS.FF')
    1     01-may-2007 19:17:46.880342
    2     01-may-2007 19:24:04.952571
    3     01-may-2007 19:24:32.182110
    4     01-may-2007 19:25:49.464260
    5     01-may-2007 19:25:52.127018
    6     01-may-2007 19:27:34.099095
    7     01-may-2007 19:30:34.763481
    8     01-may-2007 19:31:06.226955
    9     01-may-2007 19:32:36.727196
    10     01-may-2007 19:40:44.061941

  • MPLS Qos

    hi, i had a doubt.
    our network is ip N/w and our service provider is C&W MPLS N/w , we had configured Qos in our routers and marking done by using DSCP for voice traffic and for IPSEC traffic we are using access-list , i know few thing like if our data want to cross MPLS network, DSCP to IP Precedence mapping will be done in Provider Edge router because MPLS Qos is based on MPLS exp bit 3 bit , but my doubt is how the ipsec data will be marked in PE router of C&w which we had mark it by using Access-list...

    HI Hariharan, [Pls RATE if HELPS]
    For the IPSec marking's to work please enable "qos pre-classify" command in CE Router.
    When packets are encapsulated by encryption headers, QoS features are unable to examine the original packet headers and correctly classify the packets. Packets traveling across the same tunnel have the same encrypted headers, so the packets are treated identically if the physical interface is congested. With the Quality of Service for Virtual Private Networks (VPNs) feature, packets can now be classified before the encryption occur.
    The qos pre-classify command enables the QoS for VPNs feature .
    Hope this Helps. Please Rate if HELPS
    Best Regards,
    Guru Prasad R.

  • EXP to COS : MPLS on Catalyst

    Hi,
    Which Cisco switch supports EXP to COS mapping , MPLS support on swicth , other than 6500
    Thx,
    GP

    Hello Gaurav,
    I'm afraid you need a C6500 or C7600 with Sup720 3BXL or better for this job.
    I tried to look at the c4500 configuration guide and in the QoS section there is no reference to MPLS frames and EXP.
    However, if your only objective is to have the CoS bits to reflect the MPLS EXP bits this can be a default behaviour being the MPLS frame the payload.
    ethernet header -- 802.1Q header -- MPLS header
    802.1Q CoS should be a copy of MPLS EXP bits by default when it exits the PE interface.
    Hope to help
    Giuseppe

  • QoS best practise in MPLS

    Hi, I'm having a scenarios for applying QoS on the entire customer network. Its something like this:
    i. Equipment -> Layer2 SW -> PE VRF -> P
    The equipment's traffics are not marked with anything at least, the equipment gateway would be the PE VRF. I'm thinking of such QoS in these scenarios:
    i. PE ingress, match any based on the VRF and set dscp marking from here
    ii. PE egress, match by the dscp marked @ the ingress interface and perform policing/shaping and then conversion to MPLS Experimental bit
    iii. P ingress, implement congestion avoidance here, as far as I understand, congestion avoidance are based on dscp, if I perform DSCP convertion to EXP bit in the PE egress interface, would the P ingress interface still use the congestion avoidance?
    I'm venturing into the possibility on how the QoS is best implemented in such scenarios, and appreciate if you guys with such experiences to shed some lights and ideas here...
    Thanks and have a nice day

    can I safely says the approach would be something like this?
    @ the PE
    Router(config)# policy-map policy1
    Router(config-pmap)# class class1
    Router(config-pmap-c)# configure the dscp marking
    check-in this policy as input under the vrf table as this is where the traffic would initiate from the equipment
    Router(config)# policy-map policy2
    Router(config-pmap)# class class2
    Router(config-pmap-c)# match the dscp marked @ the input vrf
    Router(config-pmap-c)# set the mpls experimental topmost bit
    Router(config-pmap-c)# policing the traffic based on bandwidth percent or CIR
    check-in this policy as input @ the PE egress interfaces -> P routers, means the PE egress interface will perform the EXP marking based on the DSCP bit and perform the policing here, would be be efficient way of doing QoS?
    Then from there onwards, P routers only based on the EXP bit to adjust the congestion avoidance? But I saw we can use random-detect dscp @ the P routers, is there any congestion avoidance using the EXP bit @ the P routers end? As if we set the EXP bit on the PE egress interface, P routers would not be able to configure congestion avoidance based on the DSCP right?
    I'm just venturing out the easier and cleaner way to configure the QoS so configuration maintenance would be better in near future.
    Thanks for your suggestion bro

  • EXP propagation

    Hi,
    Can anyone shed some light on the issue of EXP field propagation as labels are removed or added?
    Specifically....
    1. I understand that at ingress of MPLS cloud you would use class-based policy to apply the initial EXP value based on some class-map matching by applying service-policy in either inbound direction in case you want to do on the inbound interface or in the outbound direction if you want to do on the outbound interface (probably frequently used in MPLS DS-TE), however my question is how will this field travel along the LSP?
    2. Do you have to make sure that you apply proper EXP value at any point in LSP when label is being stripped off or applied or is it automatically copies between the labels?
    3. Also, at egree, do you usually match on EXP value to apply proper QoS, like LLC. For example,
    class-map exp5
    match mpls experimental topmost 5
    policy-map premium
    class exp5
    priority 512
    interface fastethernet0/0
    service-policy output premium
    4. Cisco documentation speaks of three modes: Uniform, Pipe and Semi-pipe. Are these simply concept of implementations or are they really configuration parameters?
    Your help would be appreciated.
    Thanks,
    David

    Hi,
    1) the default for a PE is to copy IP precedence to MPLS exp bits in all imposed labels. With a policer you can choose to set exp to different values.
    2) the popped label exp bits are not copied to next label automatically. Assuming however that you set all exp bits to the same value during imposition this should not impose a problem.
    3) This would not work as the output traffic is (presumably) IP. so the trick is:
    class-map exp1
    match mpls exp topmost 1
    policy-map exp-mapping
    class exp1
    set qos-group 1
    class-map qos-group
    match os-group 1
    policy-map customer
    class qos-group
    bandwidth 128
    interface FastEthernet0/1
    description from core
    service-policy input exp-mapping
    interface Serial1/0
    description to CE
    service-policy output customer
    4) The qos models are concepts. Uniform mode means you can (and will) rewrite DSCP as the settings throughout IP/MPLS are using a uniform classification scheme. Pipe and short pipe model let you transport DSCP unchanged through an MPLS domain by setting exp bits ONLY and not rewriting DSCP in any place. This is used in case the customer has different settings than the SP and does not want them to be modified.
    Hope this helps
    Martin

  • IOS support for MPLS QoS as stated in RFC 3270 L-LSP

    Hi,
    does anybody know something about the degree of implementation of RFC 3270 (Multi-Protocol Label Switching (MPLS) Support of Differentiated Services), particularly on the classification based on Labels (L-LSP)?
    From what is detailed on the CCO it seems that only Exp-bits based LSP are supported (configuring all links along the path for the proper data plane behaviour based on the Exp-bits values): E-LSP
    Thanx in advance
    Francesco

    I guess, in PPP and LAN environments, E-LSP is the preferred method and in the ATM only L-LSP is possible. Maybe cisco chose to implement only the E-LSP for the LAN and PPP environments, i am not sure though.
    Anyone knows this for sure?
    Check out http://www.cisco.com/warp/public/732/Tech/mpls/docs/mpls_qos_jayk.ppt for more details on MPLS-QoS

Maybe you are looking for