MAPPING MAPPING configuration error

I am getting MAPPING configuration error while running this code using Tomcat 4.1 on my website whereas it is running at my local webserver
Please HELP
ERROR LOG
StandardHost[site.winwinhosting.net]:MAPPING configuration error for request URI /
NewsFile read: java.lang.NullPointerException:name can:+t be null NewsFile read: java.lang.NullPointerException: name can:+t be null NewsFile read:
java.lang.NullPointerException: name can:+t be null
Bunty
<%@ page import = "java.io.*, java.util.*,java.net.URL,java.awt.*" %>
<HTML>
<head></head>
<body>
<%
// Read in the text file newsfile.txt
ServletContext context = getServletContext();
String file = (context.getRealPath("news.txt"));
//String file = "news.txt";
StringBuffer stringbuffer = new StringBuffer("");
   FontMetrics fm;
    Font f1;
    String str;
    String s;
    String tmp;
    String param;
    int i;
    int disp;
    int tot;
    int pos;
    int pos1;
    int ImageDepth;
    int TextDepth;
    int fmW;
    int dd;
    int width;
    int height;
    int j;
    char ch;
str = new String(" * Online : News * Ticker * ");
tmp = new String("");
param = new String("");
String s3,s2,s1, news = new String();
try {
DataInputStream in = new DataInputStream(new BufferedInputStream(new FileInputStream(file)));
//DataInputStream in = new DataInputStream((new URL( file)).openStream());
//stringbuffer.append(in.readLine());
//stringbuffer.append("   *   ");
//s1 = stringbuffer.toString();
//out.println(s1);
while((in.readLine())!= null)
s2=in.readLine()+ "\r";
stringbuffer.append(s2);
stringbuffer.append("   *   ");
//news += s2 + "\n";
//out.println(s2);
     in.close();
catch(Exception e) {
     System.out.println("NewsFile read: "  + e);
%>
<%
news=stringbuffer.toString();
//out.println(news);
%>
<marquee><%=news%></marquee>
</body>
</html>

I think it is not able to locate your source file(New.txt). Try putting an output statement and see what is the patth it is printing and check whether it is the correct path where is your news.txt is located.
Bye

Similar Messages

  • Jboss/tomcat mapping configuration error

    I can't even get the combination to serve a .jsp file or .html file. Regardless of the URL that I attempt, I only get a No Context configured to process this request error from tomcat and INFO [Engine] StandardHost[localhost]: MAPPING configuration error for request URI from JBoss. I've tried to access all of the various webapps under the catalina directory and can't get to any of them. I know that catalina is started because the log file shows
    <Service name="JBoss-Tomcat">
    <Engine name="MainEngine" defaultHost="localhost">
    <Logger className="org.jboss.web.catalina.Log4jLogger" verbosityLevel="trace" category="org.jboss.web.localhost.Engine" />
    <Host name="localhost">
    <Valve className="org.apache.catalina.valves.AccessLogValve" prefix="localhost_access" suffix=".log" pattern="common" directory="../server/default/log" />
    <DefaultContext cookies="true" crossContext="true" override="true" />
    </Host>
    </Engine>
    <!-- A HTTP Connector on port 8080 -->
    <Connector className="org.apache.catalina.connector.http.HttpConnector" port="8080" minProcessors="3" maxProcessors="10" enableLookups="true" acceptCount="10" debug="0" connectionTimeout="60000" />
    </Service>
    </Server> in jboss.web:service=EmbeddedCatalinaSX
    2002-06-12 23:29:44,760 INFO [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Creating
    2002-06-12 23:29:44,760 INFO [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Created
    2002-06-12 23:29:44,760 DEBUG [org.jboss.deployment.MainDeployer] Done with create step of deploying tomcat4-service.xml
    2002-06-12 23:29:44,760 DEBUG [org.jboss.deployment.MainDeployer] start step for deployment file:/D:/JBoss3.0/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/tomcat4-service.xml
    2002-06-12 23:29:44,760 DEBUG [org.jboss.deployment.SARDeployer] Deploying SAR, start step: url file:/D:/JBoss3.0/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/tomcat4-service.xml
    2002-06-12 23:29:44,760 INFO [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Starting
    2002-06-12 23:29:44,760 INFO [org.jboss.deployment.MainDeployer] Adding deployer: org.jboss.web.catalina.EmbeddedCatalinaServiceSX@7dadcd
    2002-06-12 23:29:44,760 DEBUG [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Setting catalina debug level to: 0
    2002-06-12 23:29:44,760 DEBUG [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Setting catalina.home to: ../catalina
    2002-06-12 23:29:44,760 DEBUG [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Setting catalina.base to: ../catalina
    with no errors. I'm confused because I was able to consistently work with previous versions of JBoss with no problem. The configuration seems to have changed radically, is this some recent change that I just can't find a reference to? Thanks for any help.

    Hi
    For Tomcat 3.x you need to use one of the following options:
    (Note: this is with JBoss/Tomcat OR JBoss/Jetty)
    Place you .war files in the following location:
    C:\jboss-3.0.3\server\default\deploy and the app is automatically available.
    If my app's name is DavidOnline.war, when deployed, I can access it at
    http://localhost:8080/DavidOnline..
    OR
    Copy your entire development directory to the deploy direction above, RENAME your
    directory from say C:\JspApps to C:\JspApps.war and you can work from that location and see your changes immeadiatly.
    There is a file called jboss-service.xml that has some config options, also for the Tomcat bundle there is a file named tomcat-service.xml that has the standard server.xml section.. I suggest you check out the JBoss website, free docs and forums.. http://www.jboss.org.
    Thanks, Hope this helps.

  • XSLT Mapping - Configuration error

    Hi there,
    I have loaded an XSLT mapping that references 2 other mapping templates (in separate files). When I test the main mapping (in the Interface Mapping test tool) I get the following error:
    Transformer configuration exception occurred when loading XSLT POSbankingPacketToWPUFIB.xsl (http://ournamespace, 36cb0f00-1a9b-11d8-96af-e1600a114c15, -1)
    The trace in the tool showed the following:
    Creating XSLT mapping POSbankingPacketToWPUFIB
    URIResolver called with href = EDI_DC40.xsl and base =  POSbankingPacketToWPUFIB.xsl
    Source resolved. System id = EDI_DC40.xsl
    URIResolver called with href = WPUFIB.WPUFIB01.xsl and base = POSbankingPacketToWPUFIB.xsl
    Source resolved. System id = WPUFIB.WPUFIB01.xsl
    Any ideas on how to resolve this problem would be appreciated. Info below may also be helpful:
    - I have tested the XSL mapping in xmlSpy and it produces the required result but in the IR the error above occur. - I am using <xsl:stylesheet version="2.0" .... > in my definition
    - I am calling templates from the POSbankingPacketToWPUFIB.xsl that exist in both EDI_DC40.xsl and WPUFIB.WPUFIB01.xsl
    - I am using variables, template parameters and <xsl:text disable-output-escaping="yes"> in the referenced xsl stylesheets.
    Regards
    Christiaan

    Hi there,
    Thank you for your answer. All of those things were okay.
    The problem was related to XPath 2.0 syntax which does not seem to be supported by XI. The statement in question was:
    <xsl:for-each select="POSbankingPacket/DetailGroup[GroupType ne 'HD']">
    I have now switched to XSLT 1.1 and will hopefully find a adequate replacement statement.
    Thank you,
    Christiaan

  • Mapping debbuging error:DBG1006: Error while initializing test data

    Hi,
    I have created a mapping in which I am trying to delete data from a table based on exisitence of rows in another table with a filter condtion in between them.When i try to run the debbugger, it throws following error:
    ============
    Analyzing map for debug...
    Retrieving Control Center connection info...
    Connecting to Control Center schema...
    Checking character set of Control Center schema...
    Configuring sources and targets...
    Mapping Debugger Error:
    oracle.wh.service.sdk.mapping.debugger.WBMappingDebuggerException: DBG1006: Error while initializing test data for sources and targets:
    oracle.wh.repos.sdk.CMPException: Trying to access invalid Object.
    Element ID: 110138
    Status: 4
    Owning FCO: 98409
    ==================
    Any idea what could be the possible cause?
    Query which I am trying to simulate is of following type:
    Delete from TableA t1
    where exits(select 1 from TableB t2 where t1.col1 = t2.col1 and t2.col2 = 'delete')
    Thanks
    AJ.

    Oops..thats weird.
    Tell me one thing...then how gud is the code generated in terms of working...if someone has to really test the code pre-hand for expected business logicWhy i am raising this concern is becoz there are many features for which OWB provides support in indirect way(workaround) like exists/not exists.
    Do we need to deploy mapping each time and then test through a run from Control centre?
    Other thing, As far i understand, the code generated is not in such a format that one can directly copy paste it in any sql/plsql editor and test it...
    Regards
    AJ.

  • What values in EBM Header maps to error notification entry in AIA console

    Hi Guys,
    Can any one tell me which values of EBM Header maps to error notification entry in AIA console for sending notification to user created ?
    What elements in EBM Header maps to this fields *(SYSTEM CODE, ERROR CODE, SERVICE NAME, and PROCESS_NAME)* in Error notification in AIA Console for sending notification to a particular user other than AIAIntegrationAdmin?

    Hi Gerhard,
    I tried to send notification using feature available in AIA FP whenever remote and binding fault happened to user SysAdmin creatred in Admin console under user & groups.
    I have done the below configuration
    1. Made entry in AIA console under error notification (Error code : blank service name: SampleBpel system code : sys process name: SampleBpel Role: SysAdmin FYIRole: SysAdmin).
    2. configured email driver properties and work flow notification properties.
    3. made entry in http://localhost:7001/sdpmessaging/userprefs-ui/ with user logged in SysAdmin and entered mail-id.
    4. Populated EBM Header with the below values
    <part name="AIAFault">
    <Fault>
    <EBMReference>
    <BusinessScopeReference>
    <InstanceID>SampleBpel</InstanceID>
    </BusinessScopeReference>
    <SenderReference>
    <ID>SYS</ID>
    <ObjectCrossReference/>
    <Application/>
    </SenderReference>
    </EBMReference>
    <B2BMReference/>
    <FaultNotification>
    <FaultMessage>
    <Code/>
    <Text></Text>
    <Stack></Stack>
    <IntermediateMessageHop/>
    </FaultMessage>
    <FaultingService>
    <ID>SampleBpel</ID>
    <ImplementationCode>BPEL</ImplementationCode>
    <InstanceID>10011</InstanceID>
    <ExecutionContextID>480626c0ac4cb5bd:-64972e88:13bb690ac70:-8000-0000000000010746</ExecutionContextID>
    </FaultingService>
    </FaultNotification>
    </Fault>
    </part>
    5.Included fault-policies and fault-bindings.xml in project.
    when testing the project with negative scenario generates the remote fault. I am able to see fault data i.e EBM Header in AIAReadJMSNotificationProcess.
    But  it is unable to send notification for the user created (SysAdmin).
    It is showing the default user values
    Message ID (Recipient)     b89bc86bc0a805f10110c4aa3d93719f (USER:AIAIntegrationAdmin)
    Operation     Send
    Overall Status     Failed
    Status Code     ENGINE_PROCESSING_FAILURE
    Status Message     User could not be resolved to device addresses. Please see the log file for details.
    Timestamp     Dec 20, 2012 7:28:56 PM IST
    Gateway Message ID     
    Sender     
    Recipient     USER:AIAIntegrationAdmin
    Driver Instance Name     
    Engine     /Farm_base_domain/base_domain/AdminServer/usermessagingserver
    Application Name     soa-infra
    Application Instance Name     
    It is unable to send notification to the user   SysAdmin
    Can you provide solution how can i send notification to user created (SysAdmin)?
    what are the EBM Header values that need to be populated for sending notification to user created (SysAdmin)?

  • Changing map configure with OMB

    Does anybody know how to change map configuration settings with OMB+? I would like to change bulk size, commit frequency, max number of errors, etc.. I could not find a good example of how to do this. Any help would be appreciated.
    OWB Client vesion: 10.2.0.3.33
    OWB Repository: 10.2.0.3.0
    Thanks,
    Nick

    It may be the mapping has not been analyzed so it is in an early design phase when either the PLSQL (batch) or SQLLoader properties are not available. If you perform these configuration settings after the operators have been added and the map designed then I think you should be OK. If this still fails try performing an OMBVALIDATE on the mapping before settings the config properties.
    Cheers
    David

  • RuntimeException in Message-Mapping transformatio error in txt to txt  fcc

    hi
    in my design part i executed my mapping program , it executed successfully
    my src is
    <?xml version="1.0" encoding="UTF-8"?>
    <ns0:mt_sarat_txttxt_sender xmlns:ns0="http://Sarat">
       <Company>
          <Header>
             <Key1>H</Key1>
             <RecordId>123</RecordId>
             <PlantName>abc</PlantName>
          </Header>
          <Item>
             <Key2>I</Key2>
             <MaterialId>456</MaterialId>
             <Quantity>def</Quantity>
          </Item>
       </Company>
    </ns0:mt_sarat_txttxt_sender>
    IN SXMB_MONI   i got RuntimeException in Message-Mapping transformatio error
    i reffered some blog according to their sugessition  do as follows
    Go to SXMB_MONI and get the source xml from there and test it in the IR->Mapping Editor
    my source xml is
    <?xml version="1.0" encoding="utf-8" ?>
    - <ns:mt_sarat_txttxt_sender xmlns:ns="http://Sarat">
    - <Company>
    - <Header>
      <Key1>H</Key1>
      <RecordId>123</RecordId>
      <PlantName>abc</PlantName>
      </Header>
    - <Item>
      <Key2>I</Key2>
      <materialId>456</materialId>
      <Quantity>def</Quantity>
      </Item>
      </Company>
      </ns:mt_sarat_txttxt_sender>
    when i executed in mapping editor it gives fatal error
    Fatal Error: com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3) com.sap.aii.utilxi.misc.api.BaseRuntimeException: Fatal Error: com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3) at com.sap.aii.mappingtool.tf3.rt.xparser.MTSaxHandler.run(MTSaxHandler.java:130) at com.sap.aii.mappingtool.tf3.rt.xparser.XParser.run(XParser.java:68) Root Cause: com.sap.engine.lib.xml.parser.NestedSAXParserException: Fatal Error: com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3)(:main:, row=2, col=3) -> com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3) at com.sap.engine.lib.xml.parser.XMLParser.scanProlog(XMLParser.java:2668) at com.sap.engine.lib.xml.parser.XMLParser.scanDocument(XMLParser.java:2713) at com.sap.engine.lib.xml.parser.XMLParser.parse0(XMLParser.java:162) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parseAndCatchException(AbstractXMLParser.java:132) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parse(AbstractXMLParser.java:142) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parse(AbstractXMLParser.java:245) at com.sap.engine.lib.xml.parser.Parser.parseWithoutSchemaValidationProcessing(Parser.java:276) at com.sap.engine.lib.xml.parser.Parser.parse(Parser.java:338) at com.sap.engine.lib.xml.parser.SAXParser.parse(SAXParser.java:125) at javax.xml.parsers.SAXParser.parse(SAXParser.java:345) at com.sap.aii.mappingtool.tf3.rt.xparser.MTSaxHandler.run(MTSaxHandler.java:128) at com.sap.aii.mappingtool.tf3.rt.xparser.XParser.run(XParser.java:68) -
    at com.sap.engine.lib.xml.parser.SAXParser.parse(SAXParser.java:144) at javax.xml.parsers.SAXParser.parse(SAXParser.java:345) at com.sap.aii.mappingtool.tf3.rt.xparser.MTSaxHandler.run(MTSaxHandler.java:128) at com.sap.aii.mappingtool.tf3.rt.xparser.XParser.run(XParser.java:68) Caused by: com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3) at com.sap.engine.lib.xml.parser.XMLParser.scanProlog(XMLParser.java:2668) at com.sap.engine.lib.xml.parser.XMLParser.scanDocument(XMLParser.java:2713) at com.sap.engine.lib.xml.parser.XMLParser.parse0(XMLParser.java:162) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parseAndCatchException(AbstractXMLParser.java:132) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parse(AbstractXMLParser.java:142) at com.sap.engine.lib.xml.parser.AbstractXMLParser.parse(AbstractXMLParser.java:245) at com.sap.engine.lib.xml.parser.Parser.parseWithoutSchemaValidationProcessing(Parser.java:276) at com.sap.engine.lib.xml.parser.Parser.parse(Parser.java:338) at com.sap.engine.lib.xml.parser.SAXParser.parse(SAXParser.java:125) ... 3 more Fatal Error: com.sap.engine.lib.xml.parser.ParserException: XMLParser: No data allowed here: (hex) 2d, 20, 3c(:main:, row:2, col:3)
    but i have mapped main nodes in message message mapping.
    waiting for answers,
    mahesh

    got it maheshwar
    in FCC you have given small "m" .
    <materialId>456</materialId>
    but in data type its caps..
    <MaterialId>456</MaterialId>
    change it in sender comm channel and it will work..
    dont forget to award points..
    regards
    pushkar

  • ABAP Mapping Programm error  Urgent

    I am getting mapping error in ABAP Mapping programm. plz help me how to solve
    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    - <!--
    Request Message Mapping
      -->
    - <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">
      <SAP:Category>Application</SAP:Category>
      <SAP:Code area="MAPPING">APPLICATION_PROGRAM_ERROR</SAP:Code>
      <SAP:P1>Z_HBS_PAYROLL_MAPPING</SAP:P1>
      <SAP:P2>SAP-ABAP</SAP:P2>
      <SAP:P3>UNCAUGHT_EXCEPTION</SAP:P3>
      <SAP:P4>Program Z_HBS_PAYROLL_MAPPING=========CP Include Z_HBS_PAYROLL_MAPPING=========CM001 Line 1</SAP:P4>
      <SAP:AdditionalText />
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack>Error in mapping program Z_HBS_PAYROLL_MAPPING (type SAP-ABAP, kernel error ID UNCAUGHT_EXCEPTION) An exception with the type CX_SY_REF_IS_INITIAL occurred, but was neither handled locally, nor declared in a RAISING clause Dereferencing of the NULL reference</SAP:Stack>
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>

    Hi,
    I think this exception you need to catch it in the ABAP..
    This may help u- http://help.sap.com/saphelp_47x200/helpdata/en/55/bff20efe8c11d4b54a006094b9456f/content.htm
    just cross verify with this guide-
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/e3ead790-0201-0010-64bb-9e4d67a466b4
    Regards,
    moorthy

  • SXMB_MONI : Mapping exception error - cause unknown

    Hi! ALL
    I am getting a mapping exception error....
    However, if i copy the payload and run it through my test tab it is getting processed successfully.
    Is there any other way i can debug this issue....as i do not see any problem with payload or the message mapping and I am getting the following  error...
    <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
    - <!--  Request Message Mapping
      -->
    - <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">
      <SAP:Category>Application</SAP:Category>
      <SAP:Code area="MAPPING">EXCEPTION_DURING_EXECUTE</SAP:Code>
      <SAP:ApplicationFaultMessage namespace="" />
      <SAP:Stack>com.sap.aii.utilxi.misc.api.BaseRuntimeException thrown during application mapping com/sap/xi/tf/_mm_204: RuntimeException in Message-Mapping transformatio</SAP:Stack>
      <SAP:Retry>M</SAP:Retry>
      </SAP:Error>
    Your help is greatly appreciated!!
    Thank you,
    Patrick.

    Dear Patrick,
    As our experts told you can trace by using ST01 and select your ID and start the trace then again test be editing and reactivating the scenario and test it again then you ill came to know if in case any issues.
    1. Other way to test the scenario is Goto RWB--> Component Monitoring --> Select Adapter Monitoring --> Then select the TEST MESSAGE TAB and give Interface details inputs or copy or take your pay load from MONI and past here and check and changes are to be made and then test the message there itself .
    2. Also as u can test the message in Message Mapping TEST TAB and test the mapping and also parallely do Cache Refresh in SXI_CACHE.
    3. You can also check the status of the message in SYSEM STACK of message monitoring this is different from RWB message moni
    [http://Host name:PORT/MessagingSystem/monitor/systemStatus.jsp]
    4. YOu can also trace the message through this system stack also.
    Regards:
    Amar Srinivas Eli
    Edited by: Amar Srinivas Eli on Jan 30, 2009 8:53 AM

  • Runtime Mapping Transformation Error

    Hi Experts,
    I am doing a file to idoc scenario in which the sender system is MDM and the Idocs are to be received in the R/3 system.
    I have generated XSD from the IDOC itself , that is MATMAS05 and used it as the source structure by importing in External Definition and the targer is of course the Idoc.
    In SXMB_MONI i get the Runtime Mapping Transformation error. What can be the reason for this.I read somewhere that the XSD and the xml file that is being picked might have different structures.
    But i checked and they are same.
    Only the problem can be with the encoding part.
    In the XML structure of the Idoc , it is UTF-8 and also after exporting it to file it is UTF-8. But after importing it in the External Definition,it becomes ISO-8859-1 and we are unable to change it.
    Also, the xml file that is given from the MDM system has encoding as UTF-8.
    Kindly help.
    Thanks in Advance.
    -Shweta.

    Hi,
    1) check out imported xsd is correct , valid. Hope while importing you have used Type as "XSD" and then after importing, check out the messages tab to know this
    2) In the mapping, did you map all the madatory fields ? like some of the attributes like BEGIN? For this BEGIN attribute map with constant value. also check all the mandatory nodes/fields
    3) check the mapping in the mapping editor independently in Repository by picking the input xml from the SXMB_MONI. So that you can test the mapping
    Hope this will solve the mapping problem. btw, it is prefer to have exact error posted here.
    Regards, Moorthy

  • Map loader / error loading catalog

    Hi there,
    i have a problem with the "map loader" and my Nokia 5800 XM.
    ... the map loader worked as i bought the phone some months ago. Everything worked fine. Today i had to do a reset. The map is still working, but i cant get the map loader to work.
    After the start of the program and sync with the 5800 XM im getting an errormsg (in german but im trying to translate).. "cannot load the catalog of the 5800 xm"
    Thats it. I googled whole day, but found no solution... so this forum is my last help right now.
    It worked (today) before i have done the reset so im thinking that its not my OS (Windows7 64bit).
    thx in advance
    Murt

    one more thing.. i have updated the FW today to the newest available. 50.0.005
    found also another thread here /t5/Maps-Navigation-and-GPS/Map-Loader-error-while-loading-catalogue/td-p/624895/page/2
    might be an FW problem then?

  • Help with Class-map configuration - ZBFW

    Hello,
    I need some clarification regarding the class-map configuration in a ZBFW. I need to allow https,http,ftp & rdp traffic from Internet to few of the servers inside our LAN. So I put the below configuration to accomplish the task (example shows class-map for only https protocol) :
    a.)
    class-map type inspect match-all HTTPS-ACCESS
    match protocol https
    match access-group name HTTPS-SERVER-ACCESS
    ip access-list extended HTTPS-SERVER-ACCESS
    permit tcp any host 172.17.0.55 eq 443
    permit tcp any host 172.17.0.56 eq 443
    permit tcp any host 172.17.0.36 eq 443
    permit tcp any host 172.17.0.45 eq 443
    permit tcp any host 172.17.0.60 eq 443
    Where 55,56,36,45,60 are the servers inside the LAN (12 more servers are there) that need to be accessed via https,http,ftp & rdp from Internet.
    Is it a correct approach? or do I need to change my configuation so that I have to match ACL with my class-map like below:
    b.)
    ip access-list extended OUTSIDE-TO-INSIDE-ACL
    permit tcp any host 172.17.0.55 eq 443
    permit tcp any host 172.17.0.55 eq www
    permit tcp any host 172.17.0.55 eq 21
    permit tcp any host 172.17.0.55 eq 3389
    permit tcp any host 172.17.0.56 eq 443
    permit tcp any host 172.17.0.56 eq www
    permit tcp any host 172.17.0.56 eq 21
    permit tcp any host 172.17.0.56 eq 3389
    permit tcp any host 172.17.0.36 eq 443
    permit tcp any host 172.17.0.36 eq www
    permit tcp any host 172.17.0.36 eq 21
    permit tcp any host 172.17.0.36 eq 3389
    permit tcp any host 172.17.0.45 eq 443
    permit tcp any host 172.17.0.45 eq www
    permit tcp any host 172.17.0.45 eq 21
    permit tcp any host 172.17.0.45 eq 3389
    class-map type inspect match-all OUT-IN-CLASS
    match access-group name OUTSIDE-TO-INSIDE-ACL
    Which one is the correct approach when we consider the performance of the firewall ? Please help me.
    Regards,
    Yadhu

    Hey
    I do not agree with Varun, I think the first approach is the best one.
    Why? Because when you issue the "match protocol ..." you are usig NBAR wich is an application inspection software, which means that https or whatever protocol is inspected at layer 7, not layer 3 and 4 which the seconds approach does (IP and port-number).
    Lets say you use the second approach and an attacker uses some malicious protocol that runs over port 443 or whatever (a port that you opened).  That attack would be successfull because all you say, you are going to IP-address 172.17.0.56 over port 443 so go ahead.
    But if you are using NBAR, this would not work because NBAR will look at layer 7, inside the protocol itself and look if this really is HTTPS (or whatever protocol).
    That's my two cents. Hope it helped!

  • Class-Map and Policy-Map Configuration in CM Confusion

    Hi,
    I'm implementing a green field WAAS deployment for a customer. We currently have a Proof-of-Concept up and running.
    I've got some questions regarding custom class-map and policy-map configuration in the CM. I'd like to nail-down the custom class-map and policy-map configuration (and understanding) in the PoC before cutting over the PoC branches to the production WAAS environment.
    Assuming a typical WAAS Deployment using WCCP for off-path interception, branch to DC.
     ==> 61 in LAN (BRANCH ROUTER) <== 62 in WAN        (WAN CLOUD)        ==> 61 in WAN (DC ROUTER) <== 62 in LAN
    We are using two distinct device groups, BRANCH and DATA CENTER.
    If the customer has traffic that we need to classify in order to provide TFO only optimisation, should the single class-map include the traffic in both directions? Ie., (assume the SERVER is 10.1.1.1 TCP Port 443). Should the class-map be configured as:
    Class-Map
    Line 1: DST IP 10.1.1.1 DST Port 443
    Line 2: SRC IP 10.1.1.1 SRC Port 443
    Or in this case is only the DST line required? And in which Device Group should the custom policy be applied? Or should it be applied to both Device Groups? If it should be applied to both Device Groups, then would it make more sense to have the policy-map in the Branch DG configured to match the DST traffic, and on the Data Center DG have a different class-map match the SRC traffic?
    My confusion is how to classify the traffic (SRC or DST or Both - Separate classes for each or different lines within the same class-map), and where to apply the appropriate policy (both Device Groups, just Branch, just DC) and why...
    I tried to apply a custom policy and the impact in the PoC was that the TCP Summary report stopped reporting the individual traffic classes showed 'other traffic' only. Can anyone explain why this may have occurred?
    I hope this makes sense.

    for instance like this:
    policy-map police-in
    class class-default
    police rate 10 mpbs <optionally set burst>
    policy-map shape-out-parent
    class class-default
    shape 10 mpbs <optional burst config>
    service-policy shape-out-child
    policy-map shape-out-child
    class class-default
    queue-limit 10 packets
    int g 0/0/0/0
    service-policy police-in in
    service-policy shape-out-parent out
    also have a look at CL 2013/2014 (orlando/sanfran) ID 2904 for more QOS details
    and the support forum article of "asr9000 quality of service architecture"
    xander

  • Acrobat Pro form getting MAPI spooler error

    I have a form created in Acrobat Pro. The users are using Reader 9.3.1. When the user clicks the Submit button, they get a MAPI Spooler error. For some Windows Services closes Reader. Any thoughts on what is causing this and how to fix?
    Thanks,
    MDawn

    Hi Lon ,
    I would request you to get in touch with the support team to get your issue fixed.
    http://helpx.adobe.com/x-productkb/global/service-b.html
    Regards
    Sukrit Dhingra

  • FDM Conditional Map Script Error

    Hi all,
    we trying importing data from EBS to HFM though ERPI by using FDM.
    We used conditional based scripts to importing data from ebs to FDM.
    this scripts used in FDM for ICP dimension between conditional mapping script.script logic is some particular account are related to Intercomapny transaction accounts we have to map to ICP member
    can anyone help me on this:
    this is error :
    ** Begin FDM Runtime Error Log Entry [2011-12-12 15:10:18] **
    ERROR:
    Code............................................. 1014
    Description...................................... Conditional Map Script Error: Expected 'End' at line(2)
    Script:
    If varValues(14)="113401" Then Result="21_ADNIP"
    Else Result="[ICP NONE]"
    End if
    Rule=I1
    Procedure........................................ clsImpProcessMgr.fLoadAndProcessFile
    Component........................................ upsWObjectsDM
    Version.......................................... 1112
    Thread........................................... 13888
    IDENTIFICATION:
    User............................................. admin
    Computer Name.................................... ADNIPHYPUAT01
    App Name......................................... FDMHFM
    Client App....................................... WebClient
    CONNECTION:
    Provider......................................... ORAOLEDB.ORACLE
    Data Server......................................
    Database Name.................................... HYPUAT
    Trusted Connect.................................. False
    Connect Status.. Connection Open
    GLOBALS:
    Location......................................... HFMGLLOAD
    Location ID...................................... 750
    Location Seg..................................... 4
    Category......................................... WLCAT
    Category ID...................................... 12
    Period........................................... May - 2011
    Period ID........................................ 5/31/2011
    POV Local........................................ False
    Language......................................... 1033
    User Level....................................... 1
    All Partitions................................... True
    Is Auditor....................................... False
    Thanks.
    Srini

    Hi, please try the mapping script again having the "Result=" statement on a separate line, like:
    If varValues(14)="113401" Then
    Result="21_ADNIP"
    Else
    Result="[ICP NONE]"
    End if
    Kind regards,
    Jeroen

Maybe you are looking for