Bug in autosmart port macros

Good morning,
I'm observing what appears to be a bug in the smartport feature on our SG300 switches. We use this for our Auto Voice VLAN. We are using our own user defined macro's in place of the ip_phone and ip_phone_desktop as we use native vlans different than what these macro's allow. I believe this to be a bug.
Reproducing steps:
1. Define user based macro - including anti macro:
macro name user_ip_phone
#macro description user_ip_phone
#macro keywords $uservoice_vlan
#macro key description: $uservoice_vlan: The voice VLAN ID
#Default Values are
#$uservoice_vlan = 30
switchport mode trunk
smartport switchport trunk allowed vlan add $uservoice_vlan
spanning-tree portfast
macro name no_user_ip_phone
#macro description no_user_ip_phone
#macro keywords $uservoice_vlan
#macro key description: $uservoice_vlan: The voice VLAN ID
#Default Values are
#$uservoice_vlan = 30
smartport switchport trunk allowed vlan remove $uservoice_vlan
spanning-tree portfast
macro name user_ip_phone_desktop
#macro description user_ip_phone_desktop
#macro keywords $uservoice_vlan
#macro key description: $uservoice_vlan: The voice VLAN ID
#Default Values are
#$uservoice_vlan = 30
switchport mode trunk
smartport switchport trunk allowed vlan add $uservoice_vlan
spanning-tree portfast
macro name no_user_ip_phone_desktop
#macro description no_user_ip_phone_desktop
#macro keywords $uservoice_vlan
#macro key description: $uservoice_vlan: The voice VLAN ID
#Default Values are
#$uservoice_vlan = 30
smartport switchport trunk allowed vlan remove $uservoice_vlan
spanning-tree portfast
2. Apply these to the built in macros:
macro auto user smartport macro ip_phone user_ip_phone $uservoice_vlan 30
macro auto user smartport macro ip_phone_desktop user_ip_phone_desktop $uservoice_vlan 30
3. Set an interface to the following:
int gig1
switchport mode trunk
switchport trunk native vlan 10
spanning-tree portfast
spanning-tree bpduguard enable
4. Apply an IP phone to the interface and it will apply the user_ip_phone macro:
int gig1
spanning-tree portfast
spanning-tree bpduguard enable
switchport trunk allowed vlan add 30
switchport trunk native vlan 10
macro description user_ip_phone
!next command is internal.
macro auto smartport dynamic_type ip_phone
5. This is normal behaviour and is what we are expecting. We also expect that when the switch reboots or the interface is changed, the anti macro no_user_ip_phone should be used.
6. Two strange behaviours occur throughout the course of a reboot.
On firmware 1.4.XX, when the switch reboots the anti macro is performed on the interface - however, the no_ip_phone macro is used instead of the no_user_ip_phone. This removes the native vlan information which is what we do not want and we are left with:
int gig1
spanning-tree portfast
spanning-tree bpduguard enable
switchport trunk allowed vlan add 30
macro description "user_ip_phone | no_ip_phone    | user_ip_phone"
!next command is internal.
macro auto smartport dynamic_type ip_phone
On firmware 1.3.5X, when the switch reboots - the same occurs and the anti macro no_ip_phone is run but the config remains the same for some strange reason:
int gig1
spanning-tree portfast
spanning-tree bpduguard enable
switchport trunk allowed vlan add 30
switchport trunk native vlan 10
macro description "user_ip_phone | no_ip_phone    | user_ip_phone"
!next command is internal.
macro auto smartport dynamic_type ip_phone
However on firmware 1.3.5X, I have observed on multiple occasions on different switches, the statement: "macro auto user smartport macro ip_phone user_ip_phone $uservoice_vlan 30" being removed from the config after reboot which sees the default ip_phone and no_ip_phone macro run.
Impact
This is causing a massive impact on our environment. We've had the last few years on version 1.3.5 and the user macros have worked apart from when the switch has rebooted after being in operation for a few months, this is when the "macro auto user smartport macro ip_phone user_ip_phone $uservoice_vlan 30" gets removed and users cannot get data on their port. This has been hard to debug and investigate and seems to happen randomly.
This is why I have tried upgrade to the 1.4.XX firmware, but have discovered the behaviour is even worse and the behaviour I outlined above happens on every reboot of the switch.
We have about 20 to 25 SG300's in production, only one of which is still within it's 12 months, and I cannot troubleshoot with this switch as it's heavily used. Therefore I cannot approach Support directly with this as there are no switches to troubleshoot on - however, I do feel the above behaviour can be reproduced and I suspect there must be some sort of bug in the macro (anti-macro) application on ports following a reboot.

Hi Tim,
I saw this problem in 1.4 while not in 1.3.5.
Now there is a solution for this issue, which is to add the trunk native vlan setting to the user defined macro so that it will finally be recovered after reboot.
no macro auto user smartport macro ip_phone_desktop
# disassociated the user macro
macro name u_ip_phone_desktop
#macro keywords $u_native_vlan $u_voice_vlan
#macro key description: $u_native_vlan: The native VLAN for trunk
#                       $u_voice_vlan: The voice VLAN ID
#Default Values are
#$u_native_vlan = 10
#$u_voice_vlan = 30
#the default mode is trunk
smartport switchport trunk allowed vlan add $u_voice_vlan
smartport switchport trunk native vlan $u_native_vlan
no macro description
spanning-tree portfast
macro name no_u_ip_phone_desktop
#macro keywords $u_voice_vlan
#macro key description: $u_voice_vlan: The voice VLAN ID
#Default Values are
#$u_voice_vlan = 30
smartport switchport trunk allowed vlan remove $u_voice_vlan
no macro description
spanning-tree portfast auto
macro auto user smartport macro ip_phone_desktop u_ip_phone_desktop $u_native_vlan 10 $u_voice_vlan 30

Similar Messages

  • SG300 & AutoSmart ports for VLAN

    I have a couple of questions regarding the use of the voice VLAN & autosmart ports. I was running into some issues getting this to work %100 in my environment. Here is my network in a nutshell,
    Single SG300 52 port switch, ports 1-47 are configured Untagged VLAN110 (my PC LAN) and Tagged allowed VLAN 140 (my voice VLAN)  the default VLAN on the switch is 1 and I have no IP assigned to it and have it shut.
    Doing various reading I found this on the forums:
    "The Macro's just get in the way most of the time. From a default state on the switch a user will set the voice vlan id with the commands
    (config)#voice vlan id 100
    ** this will create vlan 100
    voice vlan ? ** you can use to change your default dscp and cos settings a long with any other settings.
    (config)#voice vlan state auto-enabled
    (config)#interface range fa1-24
    (config-if-range)#switchport trunk native vlan 101
    (config-if-range)#switchport trunk allowed vlan add 100
    ** this will set the native vlan on the trunk port to 101 for data and the tagged vlan will be 101 for voice.
    CDP is automatically enabled and should learn the capabilities of the phone and join the phone to vlan 101 on that port."
    This worked well for my except in the scenario where I would have a  phone plugged into the switch and a desktop plugged into the back of the phone. I would have to set the macro for IP Phone + Desktop and set the VLAN value for the desktop to 110. If I did not it would stay at VLAN ID of 1.  Is this my only option? Should I change the default VLAN to 110 and just delete VLAN 1? I was also running into a random issue with my laptop only where certain ports I would connect to (even though 1-47 are all configured the same) would just put my laptop on VLAN 1, I would look at the autosmart port and it would just say "Default". I also unchecked all of the macro options except for IP Phone & IP Phone + Desktop. I really only want to use this for phones, I don't need the autosmart ports doing anything else. Any suggestions or tips for this?

    Yes, by default the "phone - PC" macro will set the default of untagged Vlan on the port to Vlan 1.  You should just edit this macro and change the native_vlan parameter to 110.  Thus when this macro is executed the untagged Vlan will be 110.
    No, you should not need to change the default Vlan
    Correct uncheck all the type expect the IP Phone & IP Phone + Desktop

  • SG series switch smart port macro issues

    Hi there,
    There seems to be a problem with some switches that it doesn't allow us to change the untagged VLAN in the smartport macro.
    This causes a problem: if we change it manually when we apply the smartport it works fine but if the switch reboots the smartport is reapplied with the VLAN set in the macro, this puts the port onto the worng VLAN which is not good.
    Please help.

    Hello Gerrard,
    This is actually a currently known issue.  When you try to update the native VLAN on a smartport macro it looks like it has taken effect, but never really gets updated.  I have confirmed the same issue on a device here in the lab.
    Give us a call at 1.866.606.1866 and we can create a support case for you and try to get that issue resovled.
    Thank you for choosing Cisco,
    Christopher Ebert
    Senior Network Support Engineer - Cisco Small Business Support Center
    *Please rate helpful posts*

  • Analog microphone port not working?

    I have a Mac Mini (mid-2010), and no analog microphone will work in it.  I've looked through the forums and Googled around looking for an answer, but I can't find anything.  Is there a known bug with this port, or should I just return the thing for warranty repair?  I've had it only about six months....
    Thanks,
    Scott

    The audio-in port is expecting a "line level" signal - MUCH stronger than a microphone level signal.  One of the big differences between Macs and PCs.  You need a microphone pre-amplifier to raise the signal level (impractical?) or a USB-connected microphone?  Or something like an external USB sound interface, like the Griffin iMic?
    http://www.griffintechnology.com/support/imic
    If you can't find one new, they come up on eBay a lot.

  • E3000 ~ spontaneous port forwarding IP changes

    I have an E3000 with firnware 1.0.04. 
    A forwarded port is spontaneously changing the IP address assigned to it, but with no change indicated in the singel port forwarding configuration.
    I have a web server on IP=XXX.XXX.XXX.7, and another device on my LAN with an internal web server at IP= XXX.XXX.XXX.8.  The single port forwarding configuration is:
            HTTP, external port 80, internal port 80, protocol=TCP, to internal IP address xxx.xxx.xxx.7, enable checked
    The configuration is saved, and all works well for for hours and/or days and I can use the web host from the intenet as expected.  However, after a few days or hours the E3000 suddenly starts sending the http traffic to IP=xxx.xxx.xxx.8 instead of xxx.xxx.xxx.7.  When I log in to the router and look at the port forwarding page, it still says it's forwarding the http traffic to xxx.xxx.xx.7 ~ even though all http traffic is being sent to xxx.xxx.xxx.8!  I have to reboot the router to get the port forwarding to work properly.  If I leave the device at xxx.xxx.xxx.8 powered off, the router seems to work fine for extended periods.
    There are no port forwarding services in the router that reference IP=xxx.xxx.xxx.8 , and it does not appear that the port forwarding problem is related to DHCP.  All devices on my network have a reserved DHCP address based on their MAC.  It does not appear that the spontaneous port forwarding change occurs when when the xxx.xxx.xxx.8 device powers up and gets it's address via DHCP.  I have also deleted the xxx.xxx.xxx.8 device from the DHCP reservation table and simply access the device as needed by referencing it's IP, and xxx.xxx.xxx.8 is outside the range of DHCP assigned addresses, and the spontaneous port redirection still occurs once in a while.
    Is there a known bug where forwarded ports are sent to the wrong IP address?  Is there a fix in the works?  Is there other data I can gather that might help?

    Thanks for the reply.  I have a bunch of services running on several hosts, so configuring each port to forward to the proper host using the E3000 single port forwarding page is the only way to go.  It has been 4 days with uPNP turned off on the host (uPNP is still active in the router), and the problem has not occurred as yet.  However, sometimes it has taken over a week for the problem to occur.  So far things are looking good, and I am starting to believe that this host has been "stealing" port 80 by remapping it in the router via uPNP, albeit for reasons I do not understand.
    Because a uPNP device can change the port-to-DestinationIPAddress map in the router, the router really should be able to display the actual port map rather than just displaying the desired configuration.  Not being able to see the actual mapping make as much sense as not being able to not see actual DHCP assignments and only being able to see the desired DHCP configuration.  With the widespread deployment of uPNP, and considering the programming simplicty needed to display some table entries from the router's memory, this would seem an obvious and easy feature to add to the next firmware release.  A log of runtime configuration changes would be appreciated too, so that people can ascertain what device on the LAN caused a router configuration change and record what the changes were.  This sure would make troubleshooting a lot easier...

  • Apache Tomcat error re: port 8080

    Hello.
    Our environment:
    RoboHelp Server 8.0
    Apache Tomcat 6.0.26
    Windows Server 2008 enterprise without Hyper-V SP2  (32-bit virtual machine)
    RoboHelp 8.0.2.208
    Our help system is periodically non-responsive. The Apache logs (extract below) indicate that there is an application using port 8080. We (my IT support and I) discovered that RDP (Windows Remote Desktop) had been changed from port 3389 (its default) to port 8080. The server is dedicated to our help system; there isn't anyone touching it so we were a bit confused. We reset the RDP port back to 3389 and restarted the server (full server restart) and everything worked as it should. A couple of days later...the same thing...and then a few times in one day. Research indicates there may be some Windows or Apache bug related to ports being reset to 8080, but not a lot of detail or suggestion for resolution or work around.
    Has anyone experienced this port issue?
    I am not familiar with Apache...is there another port that it can use and still run the RoboServer?
    Any thoughts or suggestions re: how to proceed?
    TIA,
    Michelle
    From Catalina log:
    Sep 13, 2010 9:42:34 AM org.apache.catalina.core.AprLifecycleListener init
    INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Apache Software Foundation\Tomcat 6.0\bin;.;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\W indows;C:\Windows\System32\Wbem;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Microsoft SQL Server\90\DTS\Binn\;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PrivateAssemblies\
    Sep 13, 2010 9:42:34 AM org.apache.coyote.http11.Http11Protocol init
    SEVERE: Error initializing endpoint
    java.net.BindException: Address already in use: JVM_Bind <null>:8080
    at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:549)
    at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:176)
    at org.apache.catalina.connector.Connector.initialize(Connector.java:1014)
    at org.apache.catalina.core.StandardService.initialize(StandardService.java:680)
    at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:795)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:548)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:261)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
    Caused by: java.net.BindException: Address already in use: JVM_Bind
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(Unknown Source)
    at java.net.ServerSocket.bind(Unknown Source)
    at java.net.ServerSocket.<init>(Unknown Source)
    at java.net.ServerSocket.<init>(Unknown Source)
    at org.apache.tomcat.util.net.DefaultServerSocketFactory.createSocket(DefaultServerSocketFac tory.java:50)
    at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:538)
    ... 12 more
    Sep 13, 2010 9:42:34 AM org.apache.catalina.startup.Catalina load
    SEVERE: Catalina.start
    LifecycleException:  Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind <null>:8080
    at org.apache.catalina.connector.Connector.initialize(Connector.java:1016)
    at org.apache.catalina.core.StandardService.initialize(StandardService.java:680)
    at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:795)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:548)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:261)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
    Sep 13, 2010 9:42:34 AM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 606 ms
    Sep 13, 2010 9:42:34 AM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Sep 13, 2010 9:42:34 AM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/6.0.26

    The default port with RH Server is 8080 as this is the standard port for all web services. Having said that, I suspect you can change the port to another. I've never used anything other than the default. it sounds like if you have another web services accessing the same port that either it or RH Server needs to be changed.
      The RoboColum(n)
      @robocolumn
      Colum McAndrew

  • SG300-10 (1.4.0.88) Layer-3 Mode

    I'm having an issue getting my SG300-10 into Layer-3 mode.  I had it in Layer-3 mode under version 1.3.7.18, performed a factory reset by holding down the hard-reset button for 10 seconds.  Updated boot loader to 1.3.5.06 and SW Firmware to 1.4.0.88.
    switchc4f42e#sh ver
    SW version    1.4.0.88 ( date  06-Aug-2014 time  16:55:55 )
    Boot version    1.3.5.06 ( date  21-Jul-2013 time  15:12:10 )
    HW version    V02
    Now I cannot find the option to switch it back into Layer-3 mode.  There is no "menu" option at the console (serial).
    switchc4f42e#
      boot                 Boot Commands
      clear                Reset functions
      clock                Manage the system clock
      configure            Enter configuration mode
      copy                 Copy from one file to another
      crypto               Cryptographic commands
      debug-mode           Exit from the EXEC to debug mode
      delete               Delete a file from the flash file system
      dir                  Display the list of files on the flash file system
      disable              Disable privileged commands
      dot1x                802.1x EXEC commands
      errdisable           Err-Disable shutdown commands.
      exit                 Exit from the EXEC
      green-ethernet       Green ethernet commands
      help                 Description of the interactive help system
      ip                   Global IP configuration commands
      login                Exit from the EXEC and Log in
      macro                Ports macros
      more                 Display a file
      no                   Negate command
      ping                 Send echo messages.
      reload               Halt and perform a cold restart
      rename               Rename a file                  
      renew                Renew DHCP address
      resume               Resume telnet session.
      set                  Set System Parameters
      show                 Show running system information
      telnet               Open telnet session.
      terminal             Set current session functions
      test                 diagnose
      traceroute           Discover the routes to destination.
      write                Write running configuration to memory or terminal
    switchc4f42e#menu
    % Unrecognized command
    switchc4f42e#
    What do I need to do to get this switch back into Layer-3 mode?

    Never mind, I found it ....
    switchc4f42e#set system mode router
    Changing the switch working mode will *delete* the startup configuration file and reset the device right after that. It is highly recommended that you will backup it before changing the mode, continue ? (Y/N)[N] Y

  • .xlsm File use from Excel 2013 64bit/Win7 64bit to Excel 2013 32bit/Win8.1 64bit - Component Removed (not API related)

    Work Environment:  Excel 2013 64bit/Win7 64bit
    Home Environment: Excel 2013 32bit/Win8.1 64bit (1 desktop and 1 laptop)
    I am developing an an .xlsm file at work (with Lists and a single form with controls linked to a worksheet ControlSource). It works and saves all day long just fine in my work environment. I save the file to either a USB drive (or DropBox - makes no difference)
    and then open the file on my home computer. I can open the file the first time with no problem and with no error messages. But then when I try to save the file Excel 2013 32bit most often tells me that it has removed a component. But it doesn't tell which
    component it has removed. After that, if I close the file and try to reopen it, it won't reopen. I get a series of error message: [1] file path errors (error 75) [2] Excel has stopped working errors. [3] Excel hasn't enough memory to complete the operation,
    [4] Excel will close. So I click the close button on the last error message and Excel disappears. I say disappears, because its not really gone. Mind you, its not listed in the Task Manager at this point. But, if I then click the Windows Taskbar icon to start
    Excel, Excel will sometimes automatically open up with the file that I was trying to open before, already up and running, i.e. I do not select the file to open it - it just appears. Other time Excel just repeats the series of error messages noted above.
    The strange part is, once this file has been corrupted, I can still take it back to my work environment, fire it up on my work computer, and it works just fine. No error messages, no saving problems.
    I have totally uninstalled and reinstalled Office 2013 (HUP Click to Run) on both my home computers and it makes no difference.
    I can say though, this is driving me nuts. Anyone have any suggestions or ideas?
    phillfri

    I think I solved the issue.
    Step 1: Moved all my code from the Worksheet_Open event to the Auto_Open Macro.
    Result: File would open from inside Excel but when opening by clicking on the file in Windows explorer I would get the error msg "There was a problem sending a command to the program."
    Step 2: Apply FixIt 20074. Note that to get this FixIt to work in Windows 8.1 you MUST save the FixIt file to your desktop and run it from there. If you follow the instructions on the FixIt page - download and run - you will get the error msg "This Fixit
    does not apply because the computer does not have the expected software (Excel.exe)."
    Excel 2013 definitely seems to have some bugs when starting a macro enabled file. I have seen other comments on the internet about the Excel workbook_open event actually failing to run all the VBA commands that are put into it.
    Environments:
    [1] Home: Microsoft HUP Click-n-Run Office Professional 2013; Windows 8.1, 64 bit; Excel 2013, 32 bit.
    [2] Work: Enterprise Microsoft Office Professional 2013; Windows 7, 64 bit; Excel 2013, 64 bit.
    phillfri

  • Left Outer Joining multiple tables to one source table FAILS with VLD-1511

    Hi all,
    Is it me, or is OWB unable to handle left outer joining 1 source table to multiple other tables?
    I want to load a fact table so I have 1 source table with measures. This table must be outer joined to some dimensions that have their FK in the fact table.
    The SQL statement would look like this (and is perfectly valid):
    select ...
    from input, dim1, dim2
    where input.c1 = dim1.c1(+)
    and input.c2 = dim2.c2(+);
    I put the where clause in the joiner operator and validate, but that gives me message VLD-1511: A table may be outer joined to at most one other table.
    Even splitting this up into one outer join per joiner still gives this message.
    A search and look around on the forum and on metalink shows there are related issues (like bug 3334035). Seemingly creating a view is the work-around to use.....? (ie downgrading owb to a simple gui tool) }-;
    Have other people experienced this problem of not being able to outer join one input table to multiple other tables?
    Thanks,
    Ed

    I have had some feedback from Oracle. It turns out this has to do with 2 issues. Below I have pasted the text that Support gave me:
    <---------- START QUOTE ---------->
    RESEARCH
    =========
    Bug 3437036 KEY LOOKUP DOES NOT DETECT ORA-1417 IN VALIDATE/GENERATE STEP
    Unpublished Bug 4211684 FORWARD PORT OF BUG 3437036
    shows:
    Some more development has been completed when this bug is fixed in Paris.
    The following are the details:
    1. If the join condition contains a full outer join such as
    tab1.c (+) = tab2.c (+) and tab2.c (+) = tab3.c
    then the new validations implemented for this bug do not apply since
    in OWB, full outer join triggers generation of joins in ANSI syntax.
    ANSI syntax does not have the original problem the base bug of this
    bug reported.
    2. If the join condition does not contain any full outer join condition,
    then the join is generated in Oracle join syntax, which is subject two
    several restrictions. The fix to this bug check two of the restrictions.
    3. The first restriction in Oracle syntax is that the outer join operator
    "(+)" can only directly be attached to a column name. If you attach it
    to an expression, such as the following:
    (tab1.c + 1) (+) = tab2.c
    Then there will be an ORA-936 error at the time of mapping deployment.
    For this case, I have added a validation message VLD-1512 to error out
    this situation.
    4. The second restriction in Oracle syntax is that a table can only be
    outer joined to exactly one other table.
    For example, this is an invalid join in Oracle syntax:
    tab1.c (+) = tab2.c and tab1.d (+) = tab3.d
    because tab1 is left outer joined to tab2 and tab3.
    But note that the following is still valid in Oracle syntax:
    tab1.c (+) = tab2.c and tab1.d = tab3.d (+)
    because tab1 is left outer joined to tab2 and right outer joined to tab3.
    So this latter case does not violate the restriction that "same oj" to
    more than 1 table is not allowed.
    If same oj to more than 1 table is specified in a join condition,
    VLD-1511 will be issued, and the map is made invalid.
    <---------- END QUOTE ---------->
    OWB does a partial validation, ie not all access paths are (can be) checked. A full check is only done by the database itself. So some scenarios (like checking whether multiple tables are outer joined the correct way) are not checked, and in this case are flagged with an error (even though it is actually a correct scenario).
    Seemingly this was not flagged with an error in earlier versions of OWB, so beware, OWB behaviour may change when upgrading...
    Alternative solutions are (1) using key lookups, (2) using a view with all outer joins in there, (3) using intermediate result tables between the joins.
    Hope this info helps some people prevent spending too much time on a false error message,
    Ed

  • Tethered file name

    When shooting tethered, how do I get Lightroom to name the file the next sequence number that is normally supplied by the camera?
    Such as _30D004567.nef?
    Under Tether Capture Settings window when I start tethered capture, I've tried everything there. LR always does it's own numbering.
    Using Nikon D300 and D300s
    LR v3.5
    Win 7
    Thanks all
    Tgall

    Just an update to my earlier reply. Since you already using the PGP encryption component, just have the following line in the existing component code.
    Note: I have updated the code to meet your exact requirement.
    string sReceivedFileName = pInMsg.Context.Read("ReceivedFileName", "http://schemas.microsoft.com/BizTalk/2003/file-properties")
    //write value to context
    inmsg.Context.Write("ReceivedFileName", "http://schemas.microsoft.com/BizTalk/2003/file-properties", System.IO.Path.GetFileNameWithoutExtension(sReceivedFileName).Replace(".pgp", ""));
    This use the following section in the code to meet your requirment and along with this code you still need to use the send port macro as %SourceFileName%.pgp:
    System.IO.Path.GetFileNameWithoutExtension(sReceivedFileName).Replace(".pgp", "")
    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

  • Live Office - Outlook. Disabled from beginning?

    Hello, we are preparing packages to install BO Live office in our customers and we came accross with this Bug of Live Office and Outlook.
    I know that if i go to C:\Program Files>Business Enterprise 12.0\Live Office 12.0 I can execute enable_addin.exe and disable LiveOffice for Outlook.
    but...can i do this somehow BEFORE the users come accross with the bug?
    Kind of macro or something that disables this option BEFORE the bug appears.
    Thanks a lot folks! BO rules!

    This is due to a security patch for Outlook which forces Outlook-addins to ask the user for a confirmation before taking over the control over the mail client.
    You can try to deactivate the LiveOffice add-in just for Outlook:
    http://blog.techhit.com/5527-how-to-find-and-disable-outlook-2003-add-ins-and-plugins
    Regards,
    Stratos
    Edited by: Efstratios Karaivazoglou on Jul 28, 2010 11:46 PM

  • UC320: how to set (correct) time and date, upload own AA messages, get caller ID, telnet?

    Hello there,
    Just trying out the UC320 I got borrowed from Cisco AT for testing with firmware 2.1.2 (1) localized for Austria.
    The device is connected to the cable modem of my ISP (Kabelsignal) utilizing two FXO ports, getting an IP address from my DHCP being connected to a WS-C2960G-24TD (LAN 1@UC320 connected to Gi0/18@C2960G port macro Cisco Switch enabled).
    Now I would like to try/see the following features:
    - a correct time and date: huh? hwo/where???
    No option to set this right??? No NTP option??? Am I just blind or too stupid to find that option/s?
    - upload own messages for the AA: ok, there are german messages but someone might have a little bit personalized ones - maybe telling callers the company name before asking them to dial the extension if they know it. Making custom messages is not the problem - but how to upload and in which sound/data format?
    - caller ID: my ISP told me that he transfers the caller ID correctly to analoge end devices if caller ID is available and not suppressed. All I can see when a call comes in is which FXO Port is being used by that call. So callback entries on the SPA phone is senseless. Any advise?
    - CLI: You can telnet the device - but which credentials to use to successfully logon? The pre-assigned credentials form Cisco AT are not accepted for logon.
    BTW @Cisco guys: I am also voting for support for the older SPAs (e.g. 942)

    Hi Claus,
    Thanks for giving the UC320W a spin and glad you found the support community!  Let met see if I can help answer your questions....
    Time/Date & NTP -- The UC320W is preconfigured with Cisco's Small Business NTP server.  The preferred method for correct time you will need the UC320W WAN to be connected with Internet access.   If there is no WAN connectivity there is a feature in the 2.1.x firmware where you can set the time on a SPA phone GUI and it will then update the system time.  Alternatively, if you have a LAN side NTP server that is on the same subnet as your Data VLAN subnet, you can use the NTP.pmf file found here:  https://supportforums.cisco.com/docs/DOC-16301
    Upload custom Music on Hold and Auto Attendant prompt files.  We are currently in beta of a new Cloud service.  To participate in the Beta, please send an e-mail to [email protected] requesting MoH/AA Custom files Cloud Beta participation.
    Caller ID on FXO:  Make sure that you have run the impedance matching tool on each of your FXO ports.  For additional information on running the Impedance Matching tool and Caller ID troubleshooting, please see the UC320W Troubleshooting Guide.
    CLI access -- This is for Cisco Support personnel only for low level debugging.  This is not a IOS based device and there is no command line access for provisioning.
    Cheers,
    Chris

  • Automatic file name in InDesign2 file information

    Is there any way to automatically add file names to InDesign2 file information (rather than manually typing file names into the file name field each time).
    Thanks

    Just an update to my earlier reply. Since you already using the PGP encryption component, just have the following line in the existing component code.
    Note: I have updated the code to meet your exact requirement.
    string sReceivedFileName = pInMsg.Context.Read("ReceivedFileName", "http://schemas.microsoft.com/BizTalk/2003/file-properties")
    //write value to context
    inmsg.Context.Write("ReceivedFileName", "http://schemas.microsoft.com/BizTalk/2003/file-properties", System.IO.Path.GetFileNameWithoutExtension(sReceivedFileName).Replace(".pgp", ""));
    This use the following section in the code to meet your requirment and along with this code you still need to use the send port macro as %SourceFileName%.pgp:
    System.IO.Path.GetFileNameWithoutExtension(sReceivedFileName).Replace(".pgp", "")
    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

  • ARD, AEBSn and Airport 7.3.1

    Hi,
    Pre Airport firmware 7.3.1 it was possible to manage all my client computers in remote locations from any Mac on my LAN running ARD. Post the update, only Screen Sharing is available unless ports 3283 are forwarded to the machine running ARD. It strikes me as a bug, that incoming port rules are now required for outgoing connections. Can anyone else corroborate this behaviour? My router is AEBSn.

    We resolved (by-passed) those problems by using the SQL statement
    EXEC SQL SET LOCK MODE TO WAIT 2;
    before the place where we had the problem, then
    EXEC SQL SET LOCK MODE TO NOT WAIT;
    after it.
    The disadvantage is some delay sometimes, but we could not find
    anything else on a single processor system. The issue seems to be
    that Informix continues waiting for the lock to be released, instead
    of switching to the process that keeps it locked. In our applica-
    tion there was no real reason for the lock to exist, except that
    another process scanned parts of the table looking for a specific
    record. (so this is similar to your problem).
    I have the idea that a dual processor system would not have the
    same problem, but cannot prove it.
    Maybe try the Informix newsgroup ? Maybe that would give more information
    Frank
    "Manoj SASIDHARAN" <[email protected]> wrote:
    >
    Hello Friends,
    We are porting our Tuxedo/Oracle based product to Tuxedo/Informix using
    IDS Server
    INFORMIX 7.3.1 with Client SDK 2.50.HC2 on HPUX11 platform.
    When we bring up more instances of Tuxedo servers, the following problem
    arises:
    SQL statements are returning -244/-243 error.
    Description: A record that is locked by a process cannot be read by another
    process.
    (This works fine in Oracle). Also, fetch operation on cursors may result
    in sql
    errors when trying to position on a locked record. There is no way to
    skip locked
    records.
    Is there any way to get more scalability/concurrency using isolation
    levels, indexes,
    configuration setting etc.
    Any suggestion/comment on this would be highly appreciated.
    Thanks in advance.
    Best Regards
    MS

  • Inter-VLAN routing, Auto-Voice VLAN and IP Address-Helper

    Hope that somebody can help me with the setup in the screenshot. 
    Planning to use Auto-Voice VLAN and Smartports to configure VOIP
    LLDP-MED will be enabled on the switch to detect the IP phones so they will be moved to the Voice VLAN (If not the first 6 signs will be added to the OID table). The Voice VLAN ID will be 2 >> Voice VLAN will be automatically enabled once a device is recognized as a IP phone right? 
    Workstations will be connected to the Cisco switch, VLAN data will be untagged and will remain on the native VLAN.
    Smartports will be used to configure the ports (Macro's) >> Should configure the ports as trunks as assigns the correct VLANs right?
    But how do i configure the IP Helper-Address? Do i have to create the Voice VLAN on both switches and then run the command "IP Helper Address" to specify a DHCP server? From what i've been reading it's required, when using Inter-VLAN routing, to configure the VLAN interface with an IP address. But it's going to give problems when both switches are connected to eachother and both have the same VLAN configured including the same IP address assigned to their VLAN interface?
    Normal data should pass  the ASA firewall, VOIP traffic should go through the Vigor modem to a hosted VOIP provider. The best way, i assume, is to configure 2 separate scopes on the DHCP server?
    Still confused on how to set it up, hope that someone can point me in the right direction

    If you're sending voice to only the Vigor modem then there is no need for a trunk between the SF-300 and the Vigor modem. You can just set that to an untag packet for the VLAN 2 between that switch and the Vigor modem.
    On the 'edge' SF300 where the IP phone/PC is it is obviously going to interoute there and of course the phone port is tagged and PC port is untagged.
    For the IP helper, it uses UDP-RELAY and it should be enabled on the port itself and enabled on the global configuration. You may also need option 82. Also keep in mind, depending how your DHCP server works, it may need option 82 configured as well or at least a route to understand the subnets in the layer 3 environment to get traffic across the VLANS.

Maybe you are looking for